Westport HD CM2250

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware failures or internal ECM voltage supply circuits. | Engine may not start.
GX CM2250 - Engine Control Module

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM mounting location varies, depending on engine model, and can be mounted either on or off engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a read or write error internal to the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111.

Last Modified: 04-Nov-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect. The ECM has detected the primary and backup speed sensor signals are connected backwards. | The engine will shut down or will not start.
GX CM2250 - Engine Magnetic Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the crankshaft position and camshaft position signal inputs to the ECM are reversed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD engines.

Shop Talk

This fault code indicates the crankshaft position sensor and the camshaft position sensor wiring harness connectors are reversed. As a result, the engine will not start.

Refer to Troubleshooting Fault Code t05-115.

Last Modified: 08-Jun-2012


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Engine power derate.
GX CM2250 - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

Component Location

The intake manifold pressure sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal voltage is greater than 4.75-VDC for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-122.

Last Modified: 04-Nov-2010


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Engine power derate.
GX CM2250 - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

Component Location

The intake manifold pressure sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal voltage is less than 0.25-VDC for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve will be closed.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-123.

Last Modified: 23-Nov-2010


Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 124

Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 124 PID: P102 SPN: 102 FMI: 16 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Data Valid But Above Normal Operating Range - Moderately Severe Level. Intake manifold pressure is above the maximum operating limit. | Engine power derate.
GX CM2250 - Intake Manifold Pressure/Temperature Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal reading is above the expected level for the present engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the intake manifold pressure is reading within the normal operating limits and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines

Shop Talk

The intake manifold 1 pressure sensor monitors pressure in the intake manifold. This fault code is set active when the intake manifold pressure is too high for the present engine operating conditions. The ECM commands a charge flow command and the variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) valve move to meet this command.

Possible causes of this fault code include:

  • Damaged intake manifold pressure sensor
  • Damaged barometric pressure sensor
  • System tampering.
Refer to Troubleshooting Fault Code t05-124.

Last Modified: 23-Nov-2010


Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 125

Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 125 PID: 102 SPN: 102 FMI: 18 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Intake manifold pressure is below the minimum operating limit. | Engine power derate.
GX CM2250 - Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold.

If the ECM detects that the necessary charge flow into the engine is below the minimum limit for a period of time, this fault code is logged.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal reading is below the expected level for the present engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • It may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the intake manifold pressure is reading within the normal operating limits and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For on-board diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

The intake manifold 1 pressure sensor monitors pressure in the intake manifold. This fault code is set active when the intake manifold pressure is too low for the present engine operating conditions. The ECM commands a charge flow command, and the variable geometry turbocharger and exhaust gas recirculation valve move to meet this command. If the engine is unable to achieve the desired oxygen level necessary for complete combustion, this fault code is logged.

Possible causes of this fault code include:

  • Leaks in the air intake system between the turbocharger and intake manifold
  • Damaged intake manifold pressure sensor
  • Damaged barometric pressure sensor
  • Restriction in the charge-air cooler
  • Leaks or restrictions in the exhaust gas recirculation system plumbing
  • Restriction in the air filter
  • Restriction in the exhaust system.
Refer to Troubleshooting Fault Code t05-125.

Last Modified: 16-Jul-2012


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3/3 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 1 circuit. | Severe derate in power output of the engine. Limp home power only.
GX CM2250 - Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall Effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage for accelerator position 2.

When the ECM senses a signal voltage higher than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal or lever. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is greater than 4.467-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault code include:

  • Accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Malfunctioning acelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-131.

Last Modified: 04-Nov-2010


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 1 signal circuit. | Severe derate in power output of the engine. Limp home power only.
GX CM2250 - Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall Effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage for accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is less than 0.826-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed. If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Damaged accelerator pedal or lever position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-132.

Last Modified: 23-Nov-2010


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P372 SPN: 974 FMI: 3/3 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate. Remote accelerator position will be set to 0 percent.
GX CM2250 - Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the remote accelerator lever is depressed and released. A low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the remote accelerator pedal signal voltage is greater than 0.273-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault code include:

  • Remote accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open remote accelerator pedal or lever return circuit in the harness or connections
  • Remote accelerator supply shorted to battery
  • Malfunctioned remote accelerator pedal or lever position sensor.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-133.

Last Modified: 04-Nov-2010


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P372 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate. Remote accelerator position will be set to 0 percent.
GX CM2250 - Remote Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the remote accelerator pedal signal voltage is less than 0.008-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault code include:

  • Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Damaged remote accelerator pedal or lever position sensor
  • Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-134.

Last Modified: 23-Nov-2010


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
GX CM2250 - Engine Oil Rifle Pressure 1 Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is greater than 4.75-VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the malfunction indicator lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

If the oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-135.

Last Modified: 04-Nov-2010


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P0522 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
GX CM2250 - Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is less than 0.25-VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the engine oil pressure reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let, it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the malfunction indicator lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

If the oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-141.

Last Modified: 23-Nov-2010


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Engine power derate.
GX CM2250 - Engine Oil Rifle Pressure

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low. If the ECM detects low signal voltage, indicating low engine oil pressure, this fault code sets.

Component Location

The engine oil pressure sensor is located on the left side of the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure is less than the engine protection limits for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A torque derate issued by the ECM limits the power output of the engine.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE and the torque derate will be removed immediately after the oil pressure reading is detected to be within the normal operating range and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code t05-143.

Last Modified: 23-Nov-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the electronic control module (ECM). No engine protection for engine coolant temperature circuit faults.
GX CM2250 - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor that is used to measure the temperature of the coolant of the engine. The ECM supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and emissions control.

Component Location

The engine coolant temperature sensor is located near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the coolant temperature signal voltage is greater than 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-144.

Last Modified: 23-Nov-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the electronic control module (ECM). No engine protection for engine coolant temperature circuit faults.
GX CM2250 - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor that is used to measure the temperature of the engine coolant. The ECM supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and emissions control.

Component Location

The engine coolant temperature sensor is located near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature signal voltage is less than 0.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (ODB) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-145.

Last Modified: 23-Nov-2010


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine coolant temperature is above engine protection warning limit. | Power derate and possible engine shutdown if the Engine Protection Shutdown feature is enabled.
GX CM2250 - Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor that is used to measure the temperature of the engine coolant. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than 108° C [226°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the coolant temperature decreases below the engine protection limit and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the applicable engine service manual.

Refer to Troubleshooting Fault Code t05-146.

Last Modified: 23-Nov-2010


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Progressive power derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red STOP lamp starts flashing.
GX CM2250 - Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor that is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than 117° C [ 242°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut off if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the coolant temperature decreases below the engine protection limit and the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code t05-151.

Last Modified: 23-Nov-2010


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the electronic control module (ECM). No engine protection for intake manifold air temperature.
GX CM2250 - Intake Manifold Temperature/Pressure Sensor

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the electronic control module (ECM) for the engine protection system and engine emissions control.

The ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground, therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount, and the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature signal voltage is greater than 4.95-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve will be closed.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
Refer to Troubleshooting Fault Code t05-153.

Last Modified: 23-Nov-2010


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the electronic control module (ECM). No engine protection for intake manifold air temperature.
GX CM2250 - Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor that is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the ECM for the engine protection system and engine emissions control.

The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature signal voltage is less than 0.41 VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve will be closed.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-154.

Last Modified: 23-Nov-2010


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive power and derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red STOP lamp starts flashing.
GX CM2250 - Intake Manifold 1 Temperature Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor that is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the electronic control module (ECM) for the engine protection system and engine emissions control.

The ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold air temperature is greater than 132°C [270°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut off if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-155.

Last Modified: 23-Nov-2010


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply 2 circuit. | Engine power derate.
GX CM2250 - Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2-pin of the electronic control module (ECM) provides 5 volts to the camshaft speed/position sensor, exhaust gas pressure sensor, intake manifold pressure/temperature sensor, and crankcase pressure sensor.

Component Location

Sensor supply 2 is located in the ECM and provides a 5-VDC supply to various engine sensors. The supply voltage is spliced off in the engine harness to each sensor it supports.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 2 signal voltage is less than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The backup camshaft position sensor will not be functional.
  • A default value is used for all other sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

  • Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.
Refer to Troubleshooting Fault Code t05-187.

Last Modified: 24-Nov-2010


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
GX CM2250 - Engine Coolant Level Sensor 1 Circuit - 3-Wire Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes, based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is greater than 4.4-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-195.

Last Modified: 07-Jan-2011


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P2558 SPN: 111 FMI: 4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant level circuit. | None on performance.
GX CM2250 - Engine Coolant Level Sensor 1 Circuit - 3-Wire Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes, based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is less than 0.58-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to ground in the engine harness, connector, or sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-196.

Last Modified: 07-Jan-2011


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P2560 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low engine coolant level detected. | Possible power derate and possible engine shut down if the Engine Protection Shutdown feature is enabled.
GX CM2250 - Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch that is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of the coolant. The engine control module (ECM) monitors the change in voltage caused by changes in the resistance of the sensor to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level sensor signal voltage is higher than 3-VDC for more than 30 seconds, indicating very low coolant level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light after 20 seconds when low engine coolant level has been detected.
  • Torque output of the engine may be reduced.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to inactive immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Note: It may not be possible to perform an aftertreatment diesel particulate filter (DPF) regeneration while this fault code is active.

Refer to Troubleshooting Fault Code t05-197.

Last Modified: 18-Sep-2012


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or an open circuit detected at the engine oil temperature circuit. | No engine protection for engine oil temperature.
GX CM2250 - Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor that is used to measure the temperature of the engine oil in the oil rifle. The electronic control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature signal voltage is greater than 5.13-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

The engine oil temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-212.

Last Modified: 23-Nov-2010


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine oil temperature circuit. | No engine protection for engine oil temperature.
GX CM2250 - Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor that is used to measure the temperature of the engine oil in the oil rifle. The electronic control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-213.

Last Modified: 23-Nov-2010


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | Progressive speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red STOP lamp starts flashing.
GX CM2250 - Engine Oil Temperature Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor that is used to measure the temperature of the engine oil in the oil rifle. The electronic control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature is greater than 122°C [252°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the oil temperature decreases below the engine protection limit and the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code t05-214.

Last Modified: 23-Nov-2010


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply 2 circuit. | Engine power derate.
GX CM2250 - Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 pin of the electronic control module (ECM) provides volt for the camshaft speed/position sensor, exhaust gas pressure sensor, intake manifold pressure/temperature sensor, and crankcase pressure sensor.

Component Location

Sensor supply 2 is located in the ECM and provides a 5-VDC supply to various engine sensors. The supply voltage is spliced off in the engine harness to each sensor it supports.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 2 signal voltage is more than 5.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The backup camshaft position sensor will not be functional.
  • A default value is used for all other sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or by a malfunctioning ECM.

Refer to Troubleshooting Fault Code t05-227.

Last Modified: 24-Nov-2010


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Fuel injection disabled until engine speed falls below the overspeed limit.
GX CM2250 - Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall Effect type sensors. The electronic control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used to determine the position of the engine by the ECM.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine speed has exceeded the calibration limit for excessive engine speed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speed.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the engine speed drops to normal operating speed and the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

If Fault Code 234 becomes active only during engine braking, and the engine brakes fail to engage, check for a short circuit to ground in the engine brake wiring harness. The rocker lever cover must be removed to perform this inspection. Repair or replace the engine brake wiring harness as necessary.

Refer to Troubleshooting Fault Code 234.

Last Modified: 01-Dec-2010


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: P105 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Possible hard starting and rough running.
GX CM2250 - Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Not applicable.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the sensor supply 3 signal voltage is less than a 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD engines.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a calibratible limit, this fault code is recorded.

Possible causes of this fault code include:

  • Short circuit to ground in the engine harness, sensor, or ECM.
Refer to Troubleshooting Fault Code t05-238.

Last Modified: 01-Dec-2010


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Possible hard starting and rough running.
GX CM2250 - Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Not applicable.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 3 signal voltage is more than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD engines.

Shop Talk

High voltage on the +5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or by a damaged ECM.

Refer to Troubleshooting Fault Code t05-239.

Last Modified: 01-Dec-2010


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P84 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect. The ECM lost the vehicle speed signal (VSS) or is reading an erratic value. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise control, gear-down protection, and road speed governor will not work.
GX CM2250 - Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion.

Conditions for Setting the Fault Codes

The ECM detects a loss of vehicle speed when other engine operating conditions indicate that the vehicle should be in motion. This fault code can also become active if the calculated gear ratio and actual gear ratio do not agree while the vehicle is in motion.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.
  • ECM powerdown will be delayed for 60 seconds after key OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and move the vehicle so the ECM can read a vehicle speed. The vehicle may need to be driven for up to 15 minutes to get the diagnostic to run and the fault to go inactive.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the ECM detects a valid engine speed signal from the vehicle speed sensor and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the malfunction indicator lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault code is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault code can also become active if there is a series of clutch, service brake, or throttle movements with no vehicle movement. The fault code is set inactive when the ECM receives a valid vehicle speed signal.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not cover all malfunctions of the circuit due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, refer to the OEM service manual.

A damaged vehicle speed sensor or debris on the end of the sensor could cause the fault code to become active.

Incorrect INSITE™ electronic service tool feature and parameter settings (gear ratio, tire size, rear axle ratio, etc) will also cause the fault to become active. Feature and parameter settings under Transmission Setup and Vehicle Speed source need to be verified with the vehicle components.

If the power is removed from the ECM within 60 seconds of key OFF and before the ECM has powered down, Fault Code 1117 may become active.

Refer to Troubleshooting Fault Code t05-241.

Last Modified: 23-Nov-2010


Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P84 SPN: 84 FMI: 10 LAMP: Amber SRT: | Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change. Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
GX CM2250 - Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle's transmission.

Conditions for Running the Diagnostics

  • The adjustable parameter “VSS Anti-Tampering” must be enabled.
  • This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The ECM detects a tampering event of the vehicle speed signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.
  • Cruise Control, Gear-Down Protection, and Road Speed Governor features will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, turn the vehicle keyswitch ON for 1 minute. The vehicle speed and engine speed must be zero for at least 30 seconds.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Verify that the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for the specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

Once the speed signal has been restored, the fault code will go inactive once the keyswitch is ON for 30 seconds and the ECM senses zero vehicle and engine speed.

Refer to Troubleshooting Fault Code t05-242.

Last Modified: 23-Nov-2010


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S33 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fan control circuit when commanded ON. | The fan can possibly stay on continuously or not run at all.
GX CM2250 - Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the electronic control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is presently set up for use. The fan control circuit varies by the OEM. OEMs can use a solenoid return that is wired to the ECM or use a return that goes to engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is getting energized or de-energized. In some cases, the diagnostics can also run at certain fixed intervals.

Conditions for Setting the Fault Codes

The fan control circuit PWM signal is not detected to be system voltage when the PWM signal is turned ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The fan will not be enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The fan control logic can be adjusted with INSITE™ electronic service tool. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Refer to Troubleshooting Fault Code t05-245.

Last Modified: 23-Nov-2010


Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 249

Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at ambient air temperature circuit. | None on performance.
GX CM2250 - Ambient Air Temperature Sensor 1 Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor that is used to measure the temperature of the ambient air. The electronic control module (ECM) uses this temperature reading to optimize engine performance and to determine if heating of the SCR system is required. The ECM supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air temperature signal voltage is greater than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • The Idle Shutdown Ambient Air Temperature Override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the malfunction indicator lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-249.

Last Modified: 23-Nov-2010


Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 256

Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at ambient air temperature circuit. | None on performance.
GX CM2250 - Ambient Air Temperature Sensor 1 Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor that is used to measure the temperature of the ambient air. The electronic control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the selective catalytic reduction (SCR) system is required. The ECM supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the malfunction indicator lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

The ambient air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-256.

Last Modified: 23-Nov-2010


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
GX CM2250 - SAE J1939 Multiplexing Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1 second.

The ECM detects an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU, or damaged Cummins® ECM. It can become necessary to contact the OEM for proper multiplexing configuration. It is possible to use INSITE™ electronic service tool to monitor multiplexed components.
Refer to Troubleshooting Fault Code t05-285.

Last Modified: 30-Nov-2010


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
GX CM2250 - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM receives an invalid J1939 message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-286.

Last Modified: 30-Nov-2010


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

FAULT CODE 288

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P372 SPN: 974 FMI: 19 LAMP: Red SRT: | SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error. The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | The engine will not respond to the remote throttle. Engine can possibly only idle. The primary or cab accelerator can possibly be able to be used.
GX CM2250 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM VECU or transmission electronic control unit (ECU) in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link. Messages sent from the OEM VECU or transmission ECU are received by the Cummins® ECM and are used for controlling the engine. The Cummins® ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The OEM VECU determines that the remote throttle signal wire or enable switch is shorted high or shorted low. This fault code status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault code to occur in the Cummins® ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the malfunction indicator lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

This fault code can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM VECUs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault code are:

  • The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.
  • When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU, this fault status is transmitted to the ECM on the J1939 data link, which causes this fault to occur in the ECM. Most OEM VECUs will not incorporate fault detection on a switch.

It is still possible to get a Fault Code 285 or 286, if there is an incorrect setup in the OEM VECU or Cummins® ECM for other components, or if the remote throttle and remote throttle switch, or the data link is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. The INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-288.

Last Modified: 30-Nov-2010


Real-Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect

FAULT CODE 319

Real-Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Maintenance SRT: | Real-Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect. Real-time clock lost power. | None on performance. Data in the ECM will not have accurate time and date information.
GX CM2250 - Real Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the electronic control module (ECM) is powered by the vehicle's batteries. If battery power to the ECM is lost, the real-time clock will be powered by a battery in the engine harness (if equipped).

Component Location

The real-time clock battery is secured to the engine harness, near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the real-time clock battery voltage is 3.3-VDC.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE light and/or illuminates the malfunction indicator lamp (MIL) at initial key ON when the diagnostic runs and fails.
  • The real-time clock values in the ECM data will be incorrect.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the real-time clock in the ECM lost power.

Possible causes of this fault code include:

  • Weak or damaged real-time clock battery
  • Damaged wiring or connectors between the battery and the ECM
  • Engine is not equipped with a real-time clock battery and vehicle battery power to the ECM is lost.
Refer to Troubleshooting Fault Code t05-319.

Last Modified: 30-Nov-2010


Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 334

Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 334 PID: P0116 SPN: 110 FMI: 2 LAMP: Amber SRT: | Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect. The engine coolant temperature sensor is reading an erratic value at initial key ON. | A default value for engine coolant temperature is used.
GX CM2250 - Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

The engine must be turned off for period of 10 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 10 hour cold soak.

Conditions for Setting the Fault Codes

If coolant temperature is found to be higher than other engine temperature sensors by a calibratible value, this fault code is logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) on the second consecutive trip that the diagnostic runs and fails.
  • The ECM will estimate engine coolant temperature.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the key in the OFF position for 10 hours. After the 10 hour cold soak, start the engine and let it idle for up to 10 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • In-range malfunction of the engine coolant temperature sensor
  • High resistance in the engine coolant temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code t05-334.

Last Modified: 23-Nov-2010


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 338

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 338 PID: S87 SPN: 1267 FMI: 3/3 LAMP: Amber SRT: | Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal, or Shorted to High Source. Open circuit or short to voltage source detected at the idle shutdown vehicle accessory/ignition bus relay circuit. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
GX CM2250 - Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The Engine Control Module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to “Installed”, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by Original Equipment Manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service manual to determine grounding configuration.

Component Location

This idle shutdown relay location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The idle shutdown relay Pulse Width Modulated (PWM) signal is detected to be at system voltage by the ECM when the PWM voltage is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded OFF, it records this fault code. This fault code can be caused by:

  • ECM Idle Shutdown feature set up incorrectly.
  • Open circuit in the idle shutdown relay, OEM harness, or connectors.
  • Short circuit to a voltage source in the OEM harness or relay.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 338.

Last Modified: 14-Nov-2014


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 339

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 339 PID: S87 SPN: 1267 FMI: 4/4 LAMP: Amber SRT: | Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the idle shutdown vehicle accessory or ignition bus relay circuit when commanded ON. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
GX CM2250 - Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The Engine Control Module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to “Installed”, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by Original Equipment Manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service manual to determine the grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The idle shutdown relay Pulse Width Modulated (PWM) signal is detected by the ECM to be at 0-VDC when the PWM voltage is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on this circuit. This fault code is logged if it detects a low voltage when the relay signal is commanded on. This fault code can be caused by a short circuit to ground in the idle shutdown relay, OEM harness, or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 339.

Last Modified: 14-Nov-2014


Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. ECM power supply errors have been detected. | Possible no noticeable performance effects, engine dying, or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
GX CM2250 - Electronic Control Module (ECM)

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a read or write error internal to the module.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 10 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault code active.

This fault code can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code t05-343.

Last Modified: 23-Nov-2010


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply 1 circuit. | Engine power derate.
GX CM2250 - Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 of the electronic control module (ECM) provides a 5 volt supply for the exhaust gas recirculation (EGR) differential pressure sensor, barometric air pressure sensor, engine oil pressure sensor, and aftertreatment fuel pressure sensor.

Component Location

Sensor supply 1 is located in the ECM and provides a 5 volt supply to various engine sensors. The supply voltage is spliced off in the engine harness to each sensor it supports.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 1 signal voltage is less than 4.75-VDC for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short circuit to ground in supply wire
  • Short circuit between supply wire and return wire
  • Damaged sensor
  • Damaged ECM power supply.
Refer to Troubleshooting Fault Code t05-352.

Last Modified: 10-Dec-2010


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply 1 circuit. | Engine power derate.
GX CM2250 - Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 of the electronic control module (ECM) provides a 5 volt supply for the exhaust gas recirculation (EGR) differential pressure sensor, barometric air pressure sensor, engine oil pressure sensor, and aftertreatment fuel pressure sensor.

Component Location

Sensor supply 1 is located in the ECM and provides a 5 volt supply to various engine sensors. The supply voltage is spliced off in the engine harness to each sensor it supports.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 1 signal voltage is greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code t05-386.

Last Modified: 10-Dec-2010


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Progressive power derate is increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red STOP lamp starts flashing.
GX CM2250 - Engine Oil Rifle Pressure Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, Fault Code 415 will be logged. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The location of the oil pressure switch or sensor varies by engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure is below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • A torque derate is issued by the ECM, limiting the power output of the engine.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the oil pressure reading is detected to be within the normal operating limits and the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Malfunctioning oil pressure switch
  • Engine harness shorted to ground.
Refer to Troubleshooting Fault Code t05-415.

Last Modified: 23-Nov-2010


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection warning limit. | Severity-based torque derate.
GX CM2250 - Engine Oil Temperature Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature is greater than the warning engine protection limit for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer Test, utilize a routine that incorporates acceleration and motoring events, steady state highway operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the oil temperature decreases below the engine protection limit and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the warning engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code t05-421.

Last Modified: 14-Nov-2014


Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 425

Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 425 PID: P175 SPN: 612 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect. The engine oil temperature is erratic. | The engine oil temperature is erratic.
GX CM2250 - Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The electronic control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the oil temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • The first part runs when the keyswitch is turned ON and before engine speed is detected.
  • The ECM must not see a key cycle for a period of 10 hours before this part of the diagnostic will run. The second part occurs when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature is higher or lower than the other temperature sensors on the engine after an extended period of time with the engine OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) after the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the off position for a period of 10 hours. After the 10 hour cold soak, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning oil temperature sensor
  • Resistance in signal line.
Refer to Troubleshooting Fault Code t05-425.

Last Modified: 23-Nov-2010


SAE J1939 Data Link - Abnormal Update Rate

FAULT CODE 427

SAE J1939 Data Link - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9/9 LAMP: None SRT: | SAE J1939 Data Link - Abnormal Update Rate. Communication between the electronic control module (ECM) and another device on the SAE J1939 data link has been lost. | Engine speed will ramp down and remain at idle.
GX CM2250 - SAE J1939 Data Link Circuit

Circuit Description

Devices such as anti-lock braking (ABS) controllers, autoshift transmissions, anti-slip regulation (ASR) systems, electronic displays, electronic information systems, electronic service tools, and vehicle electronic control unit(s) (VECUs) can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1 second. The ECM detects an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM will log the fault code immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits
  • ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages
  • External OEM controlling device has malfunctioned or can no longer transmit on the data link.
Refer to Troubleshooting Fault Code t05-427.

Last Modified: 30-Nov-2010


Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 436

Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 436 PID: 111 SPN: 105 FMI: 2 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect. The intake manifold temperature sensor is reading an erratic value at initial key ON or while the engine is running. | The ECM will estimate engine intake manifold temperature.
GX CM2250 - Intake Manifold 1 Temperature/Pressure Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor that is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the electronic control module (ECM) for the engine protection system and engine emissions control.

The ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or high temperature.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of 10 hours before this part of the diagnostic will run.

The second part runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine intake manifold temperature sensor reading is higher or lower than the other temperature sensors on the engine, after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will estimate engine intake manifold temperature.
  • Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for a period of 10 hours. After the 10 hour cold soak, key ON for 1 minute, and then start the engine let it idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • In-range malfunction of the engine intake manifold temperature sensor
  • High resistance in the engine intake manifold temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code t05-436.

Last Modified: 22-Aug-2011


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine may stop running or be difficult to start.
GX CM2250 - Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 30-ampere fuse in the unswitched battery wires to protect the original equipment manufacturer (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the main battery supply voltage is less than 6-VDC.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code and illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the battery voltage is above +6-VDC and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is logged when the ECM battery supply voltage drops below 6-VDC.

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code t05-441.

Last Modified: 23-Nov-2010


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to all electrical components.
GX CM2250 - Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 30-ampere fuse in the unswitched battery wires to protect the original equipment manufacturer (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the main battery supply voltage is greater than +36-VDC.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code and illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the battery voltage is below +36-VDC and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is logged when the ECM battery supply voltage exceeds +36-VDC.

Possible causes of this fault code include:

  • Malfunctioning alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code t05-442.

Last Modified: 23-Nov-2010


Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 477

Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 477 PID: P444 SPN: 444 FMI: 18 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. The voltage supply to the diesel exhaust fluid (DEF) controller is lower than the electrical system voltage. | DEF injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Controller Voltage Supply Circuit

Circuit Description

The aftertreatment DEF controller communicates with the electronic control module (ECM) and controls the heating, dosing, and purging of the aftertreatment DEF system.

Component Location

The aftertreatment DEF controller is installed on the vehicle by the OEM. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the battery supply voltage is lower than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the battery voltage rises above 10-VDC and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Improper battery voltage setting in INSITE™ electronic service tool
  • Damaged alternator causing low voltage
  • Weak or damaged battery.
Refer to Troubleshooting Fault Code t05-477.

Last Modified: 23-Nov-2010


Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 478

Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 478 PID: P444 SPN: 444 FMI: 16 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. The voltage supply to the diesel exhaust fluid (DEF) controller is higher than the electrical system voltage. | DEF injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Controller Voltage Supply Circuit

Circuit Description

The aftertreatment DEF controller communicates with the electronic control module (ECM) and controls the heating, dosing, and purging of the aftertreatment diesel exhaust fluid system.

Component Location

The aftertreatment DEF controller is installed on the vehicle by the OEM. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

  • The aftertreatment diesel exhaust fluid controller detects the battery supply voltage is greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails
  • DEF injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the battery voltage drops back into normal operating range and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Improper battery voltage setting in INSITE™ electronic service tool
  • Damaged alternator causing high voltage
  • Improperly connected batteries.
Refer to Troubleshooting Fault Code t05-478.

Last Modified: 23-Nov-2010


Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 16/16 LAMP: Amber SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The crankcase breather filter requires maintenance. | None on performance.
GX CM2250 - Crankcase Pressure Sensor Circuit

Circuit Description

The pressure inside the crankcase filter is measured by the crankcase pressure sensor. When the crankcase pressure sensor determines that the crankcase pressure is higher than normal, this fault code is logged.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the crankcase pressure is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light when the crankcase pressure limit is exceeded.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer Test, utilize a routine that incorporates acceleration and motoring events, steady state highway operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced
  • Crankcase pressure sensor damage
  • Malfunctioning crankcase breather filter heater, if equipped
  • Plugged or restricted crankcase breather oil separator
  • Plugged or restricted crankcase breather oil drain tube or check valve
  • Plugged or restricted crankcase breather draft tube
  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and filters in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code 555.

Last Modified: 14-Mar-2017


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: P101 SPN: 101 FMI: 0/0 LAMP: Red SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The crankcase breather filter requires maintenance. | None on performance.
GX CM2250 - Crankcase Pressure Sensor Circuit

Circuit Description

The pressure inside the crankcase is measured by the crankcase pressure sensor. When the crankcase pressure sensor determines that the crankcase pressure is higher than normal, this fault code is logged.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the crankcase pressure is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red CHECK ENGINE lamp when the crankcase pressure limit is exceeded.
  • The engine torque output will be reduced to protect the engine from excessive crankcase pressure.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer Test, utilize a routine that incorporates acceleration and motoring events, steady state highway operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning crankcase breather filter heater, if equipped
  • Crankcase breather filter needs to be replaced
  • Crankcase pressure sensor damage
  • Plugged or restricted crankcase breather oil separator
  • Plugged or restricted crankcase breather oil drain tube or check valve
  • Plugged or restricted crankcase breather draft tube
  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and filters in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code 556.

Last Modified: 14-Mar-2017


Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
GX CM2250 - Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the ECM through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles, or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is being energized or de-energized. In some cases the diagnostic can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

  • Open circuit in the starter lockout relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.

This fault can also be set active if the over crank protection feature (starter lockout) is enabled, but the engine/ECM is not wired to support it.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 584.

Last Modified: 14-Nov-2014


Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S39 SPN: 677 FMI: 4 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at starter lockout circuit. | The engine will not have starter lockout protection.
GX CM2250 - Starter Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the electronic control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is being energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit PWM signal is detected to be greater than 0-VDC when the PWM signal is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The starter lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded ON, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 585.

Last Modified: 14-Nov-2014


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 595

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 595 PID: P103 SPN: 103 FMI: 0 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level. High turbocharger speed has been detected by the ECM. | Engine power derate. The ECM uses an estimated turbocharger speed.
GX CM2250 - Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed is detected to be greater than 150,000 rpm for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will estimate turbocharger speed.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and use the accelerator pedal to accelerate the engine speed to high idle (100 percent), and hold the engine speed at high idle for at least 20 seconds.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
  • Damaged ECM.

If the fault occurs intermittently, look for causes of intermittent open or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code 595.

Last Modified: 30-Nov-2010


Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 16 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. High battery voltage detected by the battery voltage monitor feature. | Amber warning lamp illuminated until high battery voltage condition is corrected.
GX CM2250 - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is higher than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 10 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if idle speedup is enabled. Use INSITE™ electronic service tool to view the Alternator Failure Warning feature settings. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

  • Overcharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code t05-596.

Last Modified: 09-Apr-2012


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 18 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low battery voltage detected by the battery voltage monitor feature. | Amber lamp will light until low battery voltage condition is corrected.
GX CM2250 - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is less than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 10 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if Idle Speedup is enabled. Use INSITE™ electronic service tool to view the Alternator Failure Warning feature settings. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code include:

  • Undercharged batteries caused by a malfunctioning alternator or regulator
  • High current devices on the vehicle, such as citizens band radio amplifiers, numerous exterior lights, or other accessories.
Refer to Troubleshooting Fault Code t05-597.

Last Modified: 09-Apr-2012


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 598

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1 LAMP: Red SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level. Very low battery voltage detected by the battery voltage monitor feature. | Red lamp illuminated until very low battery voltage condition is corrected.
GX CM2250 - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with each OEM. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 10 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if Idle Speedup is enabled. Use INSITE™ electronic service tool to view the Alternator Failure Warning feature settings. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code include:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code t05-598.

Last Modified: 09-Apr-2012


Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 629

Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 629 PID: P314 SPN: 1176 FMI: 1/18 LAMP: Amber SRT: | Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. The estimated differential pressure across the turbocharger is above the critical level. | An engine torque derate will occur.
GX CM2250 - Engine Control Module (ECM)

Circuit Description

The ECM calculates a differential pressure across the turbocharger using the intake manifold pressure sensor and crankcase pressure sensor.

Component Location

The intake manifold pressure sensor is located in the air intake horn. The crankcase pressure sensor is mounted to the crankcase breather filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The calculated differential pressure across the turbocharger is greater than a threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Plugged or restricted air filter plugged
  • Restricted crankcase breather filter plugged
  • Restricted crankcase breather plumbing.
Refer to Troubleshooting Fault Code 629.

Last Modified: 14-Nov-2014


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 31 LAMP: Maintenance SRT: | Engine Oil Change Interval - Condition Exists. Change engine oil and filter. | Maintenance reminder only.
GX CM2250 - Maintenance Reminder

Circuit Description

The engine control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

Refer to the original equipment manufacturer (OEM) service manual for the location of the oil fill port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that, based on the programmable setting in the Maintenance Monitor feature, the engine oil and filter needs to be changed.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the Maintenance Monitor feature has been reset using INSITE™ electronic service tool and the diagnostic runs and passes.

The ECM will turn off the amber MAINTENANCE lamp after the diagnostic runs and passes.

The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code will only become active if the Maintenance Monitor is enabled in INSITE™ electronic service tool. Make sure the oil and filter are changed before clearing the fault code.

Refer to Troubleshooting Fault Code 649.

Last Modified: 14-Nov-2014


Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 686

Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 686 PID: P103 SPN: 103 FMI: 2 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect. An invalid turbocharger speed signal has been detected by the ECM. | None on performance. The ECM uses an estimated turbocharger speed.
GX CM2250 - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a turbocharger speed that is greater than the speed that is physically achievable by the turbocharger.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer Test, utilize a routine that incorporates acceleration and motoring events, steady state highway operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Usually this fault code indicates a faulty turbocharger speed sensor or incorrect speed signals from the sensor. This fault can be caused by malfunctions in the following components:

  • Turbocharger speed sensor
  • Engine harness
  • ECM power supply or grounds
  • Electronic vehicle accessories that emit excessive electromagnetic interference.

If the fault occurs intermittently:

  • Check for causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).
  • Check for sources of electronic noise, such as poorly installed vehicle electronic components.
  • Make sure the vehicle chassis grounds are in good condition.
  • Make sure the ECM power supply and ground circuits are in good condition and that this power supply is not shared with other vehicle electronics.
Refer to Troubleshooting Fault Code 686.

Last Modified: 14-Nov-2014


Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 687

Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: P103 SPN: 103 FMI: 18 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low turbocharger speed detected by the ECM. | Engine power derate. The ECM uses an estimated turbocharger speed.
GX CM2250 - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed is less than 600 rpm for more than 1 second when the engine speed is greater than 1200 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will estimate turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer Test, utilize a routine that incorporates acceleration and motoring events, steady state highway operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
  • Damaged ECM.

If the fault occurs intermittently, look for causes of intermittent open or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code 687.

Last Modified: 14-Nov-2014


Engine Crankshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
GX CM2250 - Engine Crankshaft Speed/Position Circuit

Circuit Description

The electronic control module (ECM) provides a 5-VDC supply to the engine crankshaft speed/position sensor on the engine crankshaft supply circuit. The ECM also provides a ground on the engine crankshaft return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor location varies, depending on the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the crankshaft speed/position sensor while the engine is running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The camshaft speed sensor is used to provide engine speed and position information to the ECM.
  • Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness
  • Damaged or malfunctioning engine speed sensor
  • Damaged tone wheel
  • Sensor air gap that is too small or too large.
Refer to Troubleshooting Fault Code t05-689.

Last Modified: 01-Dec-2010


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: P351 SPN: 1172 FMI: 3 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the turbocharger compressor intake air temperature circuit. | Engine power derate.
GX CM2250 - Turbocharger 1 Compressor Intake Temperature Sensor Circuit

Circuit Description

The compressor intake air temperature sensor is a variable resistance sensor that is used to measure the temperature of the air entering the compressor intake of the turbocharger. The electronic control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

Some engines use a combination ambient air pressure/temperature sensor located in the OEM intake air plumbing, rather than a turbocharger compressor intake temperature sensor. Refer to the engine wiring diagram to determine which sensor your engine has.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the compressor intake temperature signal voltage is greater than 4.96-VDC for more than 10 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • For On-Board Diagnositcs (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 691, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used, depending on the turbocharger arrangement.

Possible causes of this fault code:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or short circuit to a voltage source
  • Malfunctioning sensor.
Refer to Troubleshooting Fault Code 691.

Last Modified: 23-Nov-2010


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal, or Shorted to Low Source.

FAULT CODE 692

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal, or Shorted to Low Source.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: P351 SPN: 1172 FMI: 4 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at turbocharger compressor intake air temperature circuit. | Engine power derate.
GX CM2250 - Turbocharger 1 Compressor Intake Air Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistance sensor that is used to measure the temperature of the air entering the compressor intake of the turbocharger. The electronic control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

Some engines use a combination ambient air pressure/temperature sensor located in the OEM intake air plumbing, rather than a turbocharger compressor intake temperature sensor. Refer to the engine wiring diagram to determine which sensor the engine is equipped with.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the compressor intake temperature signal voltage is less than 0.05-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 692, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used, depending on the turbocharger arrangement.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Malfunctioning sensor.
Refer to Troubleshooting Fault Code 692.

Last Modified: 23-Nov-2010


Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 693

Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 693 PID: P351 SPN: 1172 FMI: 2 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect. A temperature too high or low for the operating conditions has been detected by the turbocharger compressor intake temperature sensor. | A default value will be used for the turbocharger compressor intake temperature.
GX CM2250 - Turbocharger 1 Compressor Intake Temperature Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistance sensor that is used to measure the temperature of the air entering the compressor intake of the turbocharger. The electronic control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

Some engines use a combination compressor intake temperature/barometric pressure sensor located in the OEM intake air plumbing, rather than a turbocharger compressor intake temperature sensor. Refer to the engine wiring diagram to determine which sensor the engine is equipped with.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • The first part runs when the keyswitch is turned to the ON position after a 10 hour cold soak, during which the keyswitch has been turned OFF.
  • The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the compressor intake temperature reading is too high or too low for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute. If the fault code does not go inactive, it may be necessary to perform a 10 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range compressor intake temperature sensor
  • High resistance in the compressor intake temperature sensor signal or return lines
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 693.

Last Modified: 23-Nov-2010


Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3 LAMP: Amber SRT: | Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the internal electronic control module (ECM) temperature sensor. | None on performance.
GX CM2250 - Electronic Control Module (ECM)

Circuit Description

The ECM has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

Not applicable.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the internal temperature sensor circuit is shorted high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code t05-697.

Last Modified: 23-Nov-2010


Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4 LAMP: Amber SRT: | Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the internal ECM temperature sensor. | None on performance.
GX CM2250 - Electronic Control Module (ECM)

Circuit Description

The electronic control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

Not applicable.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the internal temperature sensor circuit is shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code t05-698.

Last Modified: 23-Nov-2010


Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 699

Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 699 PID: PID: P21 SPN: 1136 FMI: 2 LAMP: Amber SRT: | Engine ECU Temperature - Data Erratic, Intermittent or Incorrect. An incorrect of inconsistent temperature reading has been detected internal to the ECM. | None on performance.
GX CM2250 - Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The ECM mounting location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the internal temperature sensor circuit is irrational.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to the Troubleshooting Fault Code 699.

Last Modified: 14-Nov-2014


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S64 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment. Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Excessive smoke, hard start, and rough idle possible. Possible reduced engine performance.
GX CM2250 - Engine Magnetic Speed/Position Circuit

Circuit Description

The crankshaft position and camshaft position sensors are hall effect type sensors. The electronic control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the lobes on the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used to determine the position of the engine by the ECM.

Component Location

The crankshaft position sensor and camshaft position sensor locations vary with the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exaust gas recirculation (EGR) valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines there is a mechanical misalignment between the two sensors.

Possible causes for this fault code include:

  • Engine speed sensor rings that are loose or misaligned
  • Mechanical misalignment.
Refer to Troubleshooting Fault Code t05-731.

Last Modified: 10-Dec-2010


Engine Camshaft Speed / Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed / Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: PID: S64 SPN: 723 FMI: 2 LAMP: Amber SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected a loss of signal from the camshaft position sensor. | Possible reduced engine performance and/or reduced starting capability. Engine runs using primary engine position sensor.
GX CM2250 - Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The electronic control module (ECM) provides 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft speed/position sensor location varies depending on the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the camshaft speed/position sensor while the engine is running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the 5 volt supply, SIGNAL, or RETURN wire in the engine harness.
  • Damaged or malfunctioning camshaft position sensor.
  • Damaged speed indicator lobe.
  • Sensor air gap that is too large or small.
Refer to Troubleshooting Fault Code t05-778.

Last Modified: 10-Dec-2010


Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

FAULT CODE 784

Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 784 PID: S145 SPN: 1590 FMI: 2/2 LAMP: None SRT: | Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect. Loss of communication with adaptive cruise control. | Adaptive cruise control will not operate. Standard cruise control may not operate.
GX CM2250 - Adaptive Cruise Control Mode Circuit

Circuit Description

The adaptive cruise control unit communicates with the electronic control module (ECM,) sending and receiving vehicle speed control messages through the SAE J1939 data link.

Component Location

The location of the adaptive cruise control unit will vary by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from the adaptive cruise control module for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM will log the fault code immediately when the diagnostic runs and fails.
  • The adaptive cruise control will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If Adaptive Cruise Recovery is enabled, the driver can toggle the cruise enable switch from the OFF position to the ON position two times to get regular cruise control to operate and Fault Code 784 will go inactive. At the next key cycle, if the Heartbeat message is still not present, Fault Code 784 will go active.

Refer to Troubleshooting Fault Code t05-784.

Last Modified: 10-Dec-2010


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 627 FMI: 2 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM reached below 6.2-VDC momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects or engine dying or hard starting. Fault code information, trip information, and maintenance monitor data can be inaccurate.
GX CM2250 - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the original equipment manufacturer (OEM) power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that primary ECM power supply dropped below a calibratible value while the keyswitch was in the ON position. The fault code will be active when the keyswitch is turned ON following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM records the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and shut it down properly. The ECM must see adequate primary ECM battery voltage when the keyswitch is turned OFF before the fault code will become inactive.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault code active. This fault code can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active. Use of battery disconnect switches to turn off the engine or any device that disconnects battery voltage to the ECM within 10 seconds of turning the keyswitch OFF can cause damage to the aftertreatment system. The vehicle should not be operated with an active Fault Code 1117.

Refer to Troubleshooting Fault Code t05-1117.

Last Modified: 23-Nov-2010


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: PID: S385 SPN: 2623 FMI: 3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position 2 signal circuit. | Severe derate in power output of the engine. Limp home power only.
GX CM2250 - Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall Effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal. The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position and both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2.When the ECM senses a signal voltage higher than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

  • Accelerator pedal position 2 signal circuit shorted to battery or 5-VDC supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Damaged accelerator pedal position sensor.

The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-1239.

Last Modified: 23-Nov-2010


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: S385 SPN: 2623 FMI: 4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position 2 signal circuit. | Severe derate in the power output of the engine. Limp home power only.
GX CM2250 - Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall Effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal. The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position and both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage for accelerator position 2. When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Damaged accelerator pedal position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-1241.

Last Modified: 23-Nov-2010


Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P091 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect. Accelerator position sensor 1 and 2 are reading different values. | The engine will only idle.
GX CM2250 - Accelerator Pedal or Lever Position Sensor 1 and 2 Circuit

Circuit Description

The accelerator position sensor is a Hall Effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal. The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position and both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage for accelerator position 2.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the readings between accelerator position sensor 1 and accelerator position sensor 2 differ by more than 2 percent.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the malfunction indicator lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 becomes inactive and Fault Code 1239 becomes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.

Possible causes of the fault code include:

  • Damaged accelerator pedal position sensor 1 or damaged accelerator pedal position sensor 2
  • Accelerator pedal position sensor 1 and accelerator pedal position sensor 2 signal wires are shorted together.
Refer to Troubleshooting Fault Code t05-1242.

Last Modified: 23-Nov-2010


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

FAULT CODE 1515

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1515 PID: P91 SPN: 91 FMI: 19 LAMP: Red SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the multiplexed accelerator pedal. | The engine will only idle.
GX CM2250 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VEC)U or transmission electronic control unit in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link. Messages sent from the OEM VECU or transmission electronic control unit are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and VECU location varies by OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the key switch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determines that there is a malfunction of the multiplexed accelerator pedal or lever sensor system.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the multiplexed accelerator pedal.

Refer to Troubleshooting Fault Code t05-1515.

Last Modified: 30-Nov-2010


Aftertreatment Diesel Oxidation Catalyst Missing - Condition Exists

FAULT CODE 1664

Aftertreatment Diesel Oxidation Catalyst Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1664 PID: S380 SPN: 4796 FMI: 31/31 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Missing - Condition Exists. The aftertreatment diesel oxidation catalyst is not present in the exhaust system. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Oxidation Catalyst Circuit

Circuit Description

The aftertreatment system is monitored by temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst intake temperature sensor is located after the turbocharger outlet. The aftertreatment diesel particulate filter intake temperature sensor is located between the aftertreatment catalyst and the aftertreatment particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment particulate filter. These sensors monitor the temperatures in the aftertreatment system and determine if the aftertreatment catalyst is missing.

Component Location

The aftertreatment catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment system is being actively regenerated to reduce soot in the aftertreatment diesel particulate filter. The diagnostic checks for a temperature increase across the catalyst during an active regeneration of the aftertreatment system to detect the presence of the catalyst.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the aftertreatment diesel oxidation catalyst intake temperature sensor and the aftertreatment diesel particulate filter intake temperature sensor are reading the same temperature during an active regeneration of the aftertreatment system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails on two consecutive trips.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

This fault code becomes active when the aftertreatment diesel oxidation catalyst intake and aftertreatment diesel particulate filter intake temperature sensors do not detect the presence of a catalyst in the aftertreatment system.

Possible causes of this fault code include:

  • Tampering with the catalyst system
  • Removing the catalyst system from the vehicle
  • A damaged catalyst.

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Refer to Troubleshooting Fault Code t05-1664.

Last Modified: 12-Jul-2011


Fault Code Path Selection

FAULT CODE 157-fc1668
Fault Code Path Selection

Is the aftertreatment diesel exhaust fluid tank level sensor a 2-wire sensor? | Go to 157-fc1668-2wire
Is the aftertreatment diesel exhaust fluid tank level sensor a 3-wire sensor? | Go to 157-fc1668-3wire

Last Modified: 23-Nov-2010


Fault Code Path Selection

FAULT CODE 157-fc1669
Fault Code Path Selection

Is the aftertreatment diesel exhaust fluid tank level sensor a 2-wire sensor? | Go to 157-fc1669-2wire
Is the aftertreatment diesel exhaust fluid tank level sensor a 3-wire sensor? | Go to 157-fc1669-3wire

Last Modified: 23-Nov-2010


Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1673

Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1673 PID: SPN: 1761 FMI: 1 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level. The aftertreatment diesel exhaust fluid tank level has fallen below the critical warning level. | Immediate engine power derate.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The diesel exhaust fluid level sensor is located in the diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank is critically low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) willl start to flash when the diagnostic runs and fails.
  • The diesel exhaust fluid lamp will be flashing.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 km [5 miles] per hour after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the diesel exhaust fluid (DEF) level is critically low and there will be a power loss. Engine power will be reduced automatically. This can be corrected by refilling the DEF tank. Normal engine power will be restored after refilling the DEF tank.

Refer to Troubleshooting Fault Code t05-1673.

Last Modified: 18-Jan-2011


Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1677

Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1677 PID: SPN: 3031 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid (DEF) tank temperature sensor circuit. | Default temperature value used for aftertreatment DEF tank temperature.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment DEF temperature sensor is used to monitor the temperature of the aftertreatment DEF inside the DEF tank. The DEF controller monitors the voltage on the signal pin, converts this to a temperature value, and communicates this value to the engine ECM.

Component Location

The aftertreatment DEF temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF controller detects that the DEF tank temperature signal voltage is less than 0.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.

The type of DEF tank temperature and level sensor used can vary, depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Refer to Troubleshooting Fault Code t05-1677.

Last Modified: 23-Nov-2010


Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 1678

Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1678 PID: SPN: 3031 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the diesel exhaust fluid (DEF) tank temperature sensor circuit | Default temperature value used for aftertreatment DEF tank temperature.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment DEF temperature sensor is used to monitor the temperature of the aftertreatment DEF inside the diesel exhaust fluid tank. The DEF controller monitors the voltage on the signal pin, converts this to a temperature value, and communicates this value to the engine ECM.

Component Location

The aftertreatment DEF temperature sensor is located in the DEF tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF controller detects that the DEF tank temperature signal voltage is higher than 4.7-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 5 miles per hour after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

The type of DEF tank temperature and level sensor used can vary, depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Refer to Troubleshooting Fault Code t05-1678.

Last Modified: 23-Nov-2010


Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1679

Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1679 PID: SPN: 3031 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid (DEF) tank temperature sensor has indicated a tank temperature too high or too low for the ambient conditions. | Default temperature value used for aftertreatment diesel exhaust fluid tank temperature.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor

Circuit Description

The aftertreatment DEF temperature sensor is used to monitor the temperature of the aftertreatment DEF inside the DEF tank. The DEF controller monitors the voltage on the signal pin, converts this to a temperature value, and communicates this value to the engine electronic control module (ECM).

Component Location

The aftertreatment DEF temperature sensor is located in the DEF tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 10 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after a 10 hour cold soak.

Conditions for Setting the Fault Codes

The ECM detects that the difference between the aftertreatment DEF tank temperature sensor reading and the ambient temperature sensor reading is more than 30°C or 54°F at initial key ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 10 hours. After the 10 hour cold soak, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • In-range failure of the diesel exhaust fluid tank temperature
  • Damaged wiring harness
  • Damaged aftertreatment DEF controller.

The type of DEF tank temperature and level sensor used can vary, depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Refer to Troubleshooting Fault Code t05-1679.

Last Modified: 23-Nov-2010


Aftertreatment Diesel Exhaust Fluid Dosing Unit - Bad Intelligent Device or Component

FAULT CODE 1681

Aftertreatment Diesel Exhaust Fluid Dosing Unit - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1681 PID: SPN: 3361 FMI: 12 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Bad Intelligent Device or Component. An internal error has been detected in the aftertreatment diesel exhaust fluid (DEF) dosing unit. | DEF injection into the SCR aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment DEF dosing unit precisely measures the amount of aftertreatment DEF to be injected into the aftertreatment system. The aftertreatment DEF dosing unit has three primary cycles. A priming cycle makes sure that aftertreatment DEF is available at the aftertreatment DEF dosing unit. During the dosing cycle, aftertreatment DEF is being delivered to the aftertreatment dosing valve. A purge cycle occurs when the engine is turned off. The purge cycle makes sure that all of the aftertreatment DEF is removed from the diesel exhaust fluid lines and dosing valve.

Component Location

The aftertreatment DEF dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment DEF dosing unit detects an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Fault code 1681 is triggered when the aftertreatment diesel exhaust fluid dosing unit has detected an internal error.

A malfunctioning ambient air temperature sensor can also cause the aftertreatment diesel exhaust fluid dosing unit to falsely detect an internal error. Troubleshoot the ambient air temperature sensor before replacing the aftertreatment diesel exhaust fluid dosing unit.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and data link communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code t05-1681.

Last Modified: 14-Nov-2014


Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

FAULT CODE 1682

Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1682 PID: SPN: 3362 FMI: 31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists. The aftertreatment diesel exhaust fluid (DEF) dosing unit is unable to prime. | The DEF dosing unit will be unable to inject DEF into the SCR aftertreatment system.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The DEF dosing unit input lines are responsible for transporting DEF between the dosing unit, dosing valve, and DEF tank.

Component Location

There are three DEF lines. One line is between the dosing unit and dosing valve, and the other two lines are between the dosing unit and the DEF tank. These lines can be partially hidden from view by the selective catalytic reduction (SCR) system and other vehicle components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the SCR system is trying to prime.

Conditions for Setting the Fault Codes

The aftertreatment DEF dosing unit has been unable to successfully prime after multiple attempts.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 Km [5 mph] after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, use INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Doser Override Test" under the "ECM Diagnostics Test" menu
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

This fault code indicates that the diesel exhaust fluid dosing unit was unable to successfully build pressure or prime after multiple attempts. If Fault Code 3612 is also stored in the ECM, the dosing unit may have failed to purge on multiple occasions, and dosing unit damage may have occurred. Troubleshoot Fault Code 3612 after this fault code has been resolved.

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • Line heaters are not successfully thawing the frozen DEF
  • DEF pressure line between the dosing unit and dosing valve is kinked, broken, or disconnected
  • DEF suction line between the diesel exhaust fluid tank and the dosing unit is kinked, broken, or disconnected
  • Damaged DEF dosing unit
  • DEF suction and return lines between the dosing unit and the DEF tank are reversed.
Refer to Troubleshooting Fault Code t05-1682.

Last Modified: 23-Nov-2010


Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

FAULT CODE 1683

Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1683 PID: SPN: 3363 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid (DEF) tank heater circuit. | The aftertreatment DEF tank heater will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment DEF tank heater keeps the DEF from freezing in the DEF tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the DEF tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The DEF tank heater control valve is located near the DEF tank. Specific location will vary, depending on the vehicle OEM. The tank heating coil is internal to the DEF tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller has detected high signal voltage at the DEF tank heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF tank heating will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The DEF tank heater control valve can be powered by an OEM supplied power relay, which is connected to the aftertreatment DEF controller harness. When troubleshooting wiring harness issues, it may be necessary to include the optional line heater relay.

Possible causes of this fault code include:

  • Short to voltage in the line heater relay supply circuit (detected at key OFF)
  • Short to voltage in the aftertreatment DEF controller harness
  • DEF tank heater signal wire and return wire shorted together
  • Malfunctioning DEF tank heater control valve
  • Malfunctioning aftertreatment DEF controller.
Refer to Troubleshooting Fault Code t05-1683.

Last Modified: 07-Jan-2011


Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1684

Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1684 PID: SPN: 3363 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid (DEF) tank heater circuit. | The aftertreatment DEF tank heater will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment DEF tank heater keeps the DEF from freezing in the DEF tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the DEF tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The DEF tank heater control valve is located near the DEF tank. The tank heating coil is internal to the diesel exhaust fluid tank. Specific location will vary, depending on the vehicle OEM. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF controller has detected low signal voltage or a short circuit to ground at the DEF tank heater circuit.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF tank heating will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The DEF tank heater control valve may be powered by an OEM supplied power relay, which is connected to the aftertreatment DEF controller harness. When troubleshooting wiring harness issues, it may be necessary to include the optional line heater relay.

Possible causes of this fault code include:

  • Short to ground in the aftertreatment DEF controller harness
  • Malfunctioning DEF tank heater control valve
  • Malfunctioning aftertreatment DEF controller.
Refer to Troubleshooting Fault Code t05-1684.

Last Modified: 23-Nov-2010


Aftertreatment Diesel Exhaust Fluid Controller - Bad Intelligent Device or Component

FAULT CODE 1688

Aftertreatment Diesel Exhaust Fluid Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1688 PID: SPN: 3360 FMI: 12 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Bad Intelligent Device or Component. An internal error has been detected in the aftertreatment diesel exhaust fluid (DEF) controller. | Aftertreatment DEF dosing will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Controller Circuit

Circuit Description

The aftertreatment DEF controller is the central control for the selective catalytic reduction (SCR) DEF dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. It communicates to the engine via the electronic control module (ECM) via a J1939 data link connection.

Component Location

The location of the aftertreatment DEF controller varies by application and OEM. The controller will typically be mounted to the vehicle frame or suitable rigid bracket using three or four capscrews. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

An internal error has been detected in the aftertreatment DEF controller, and has been communicated to the ECM via the data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

The aftertreatment DEF controller is not serviceable, and must be replaced when malfunctioning.

Refer to Troubleshooting Fault Code t05-1688.

Last Modified: 23-Nov-2010


Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1691

Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1691 PID: P380 SPN: 100 FMI: 18 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level. The temperature increase across the aftertreatment catalyst is lower than expected. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Oxidation Catalyst

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst intake temperature sensor is located after the turbocharger outlet at the intake of the aftertreatment system. The aftertreatment diesel particulate filter intake temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

  • Active regeneration of the aftertreatment diesel particulate filter must be occurring before the diagnostic will run.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the temperature differential across the aftertreatment diesel oxidation catalyst during active regeneration is not matching the expected temperature increase.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Perform INSITE™ electronic service tool Diesel Oxidation Catalyst Maintenance Reset procedure found under the Aftertreatment Maintenance section of Advanced ECM Data.
  • Perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Soot plugging the front face of the aftertreatment diesel oxidation catalyst
  • Engine oil or fuel contamination of the aftertreatment diesel oxidation catalyst
  • Cracked or contaminated aftertreatment diesel oxidation catalyst
  • Malfunction in the aftertreatment fuel injection system
  • Leaking exhaust system between the turbocharger and the diesel oxidation catalyst.

An in-range malfunction of the aftertreatment diesel oxidation catalyst or the aftertreatment diesel particulate filter intake temperature can cause this fault code. Make sure there are not any fault codes related to the aftertreatment temperature sensors before following this troubleshooting tree.

Refer to Troubleshooting Fault Code t05-1691.

Last Modified: 14-Nov-2014


Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1694

Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1694 PID: P2201 SPN: 3226 FMI: 2 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect. An incorrect NOx sensor reading has been detected by the aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor operation will be disabled.
GX CM2250 - Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic only runs during INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.

Conditions for Setting the Fault Codes

The ECM has detected a mismatch between the aftertreatment intake and outlet NOx sensor readings.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) once the diagnostic runs and fails on two consecutive trips.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, followed by INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test. Prior to initiating this test, use INSITE™ electronic service tool to make sure this fault code is inactive.
  • If the fault code is still active after making the repair, use the "Reset All Faults" command in INSITE™ electronic service tool to clear active and inactive faults.
  • If after the completion of the Aftertreatment Diesel Particulate Filter Regeneration Test, the fault code is still not active, the repair has been validated.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for On-Board Diagnostics (OBD) applications.

Shop Talk

Possible causes of this fault code include:

  • Buildup of DEF deposits in the decomposition tube is the most common cause. The first INSITE™ electronic service tool, Aftertreatment DPF Regeneration Test, when the fault code became active, may have cleared the deposits. A second Regeneration Test will need to be performed in the troubleshooting tree for the fault code to be inactive.
  • The ECM has detected that the NOx reading is higher or lower than is possible from the engine output
  • Exhaust system leaks
  • Incorrectly installed aftertreatment outlet NOx sensor
  • Malfunctioning aftertreatment outlet NOx sensor
  • Malfunctioning aftertreatment intake NOx sensor
  • Possible engine misfire
  • NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code t05-1694.

Last Modified: 14-Nov-2014


Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 5 circuit in the OEM harness. | Severe derate in power output of the engine. Limp home power only.
GX CM2250 - Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 of the electronic control module (ECM) provides a (+) 5-VDC supply for the aftertreatment diesel particulate filter differential pressure sensor, remote accelerator, engine coolant level sensor, fan speed sensor, and accelerator position sensor 2.

Component Location

Sensor supply number 5 is located in the ECM OEM harness connector and provides a 5-VDC supply to various components in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 5 signal voltage is greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will have limp home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code 1695.

Last Modified: 23-Nov-2010


Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 5 circuit in the OEM harness. | Severe derate in power output of the engine. Limp home power only.
GX CM2250 - Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 of the electronic control module (ECM) provides a 5 volt supply for the aftertreatment diesel particulate filter differential pressure sensor, remote accelerator, engine coolant level sensor, fan speed sensor, and accelerator position sensor 2.

Component Location

Sensor supply number 5 is located in the ECM OEM harness connector and provides a 5 volt supply to various components in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 5 signal voltage is less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will have limp home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code 1696.

Last Modified: 23-Nov-2010


Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1712

Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1712 PID: SPN: 3363 FMI: 18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level. The aftertreatment diesel exhaust fluid tank heater is unable to thaw the frozen diesel exhaust fluid. | None on performance. Diesel exhaust fluid injection into the aftertreatment system can be disabled if the aftertreatment diesel exhaust fluid is frozen.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve that controls the flow of engine coolant to a heating coil inside the diesel exhaust tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary, depending on the vehicle OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a calibrated amount of time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater has been on long enough to thaw the diesel exhaust fluid, but the SCR dosing system is still not able to prime.

Action Taken When the Fault Code is Active

The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diesel exhaust fluid tank heater is able to successfully thaw the diesel exhaust fluid tank and the diagnostic runs and passes. If a thawing cycle can not be completed, make sure the diesel exhaust fluid tank heater control valve is operating correctly by using the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool, and then clear the fault using the "Reset All Faults" command in INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve stuck closed
  • Blockage or restrictons in the coolant plumbing to the diesel exhaust fluid tank heater
  • Engine coolant level low
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve
  • Malfunctioning aftertreatment diesel exhaust fluid controller is unable to command tank heating.
Refer to Troubleshooting Fault Code 1712.

Last Modified: 23-Nov-2010


Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1713

Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1713 PID: SPN: 3363 FMI: 16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid tank heater is continuously in the on position. | None on performance.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve that controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary, depending on the vehicle OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater is determined to be in the ON position when the engine ECM is commanding the heater to be in the OFF position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Before troubleshooting this fault code, make sure the vehicle is not equipped with an auxiliary heating device for the diesel exhaust fluid tank. Such a device can result in overheating the diesel exhaust fluid in the tank.

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve stuck open
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve
  • Malfunctioning aftertreatment diesel exhaust fluid controller is continuously commanding tank heating.
Refer to Troubleshooting Fault Code 1713.

Last Modified: 23-Nov-2010


Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: P101 SPN: 101 FMI: 3/3 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase pressure circuit. | None on performance.
GX CM2250 - Crankcase Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the crankcase pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankcase pressure sensor provides a signal to the ECM on the crankcase pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the crankcase filter.

Component Location

The crankcase pressure sensor is located in the crankcase filter assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the crankcase pressure signal voltage is greater than 4.75-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1843.

Last Modified: 23-Nov-2010


Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: P101 SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the crankcase pressure circuit. | None on performance.
GX CM2250 - Crankcase Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the crankcase pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankcase pressure sensor provides a signal to the ECM on the crankcase pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the crankcase filter.

Component Location

The crankcase pressure sensor is located in the crankcase filter assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure signal voltage is less than 0.25-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1844.

Last Modified: 23-Nov-2010


Exhaust Gas Recirculation Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1866

Exhaust Gas Recirculation Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1866 PID: P411 SPN: 411 FMI: 2 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect. An error in the EGR delta pressure signal was detected at initial key ON or the sensor failed the autozero test. | EGR valve actuation will be disabled.
GX CM2250 - Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The electronic control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emissions levels. The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube. The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The sensor is located near the air intake.

Conditions for Running the Diagnostics

This diagnostic runs at key OFF when the following conditions are met:

  • Engine coolant temperature is 67°C [154°F] or higher.
  • Intake manifold air temperature is 7°C [44°F] or higher.
  • Keyswitch transitions from ON to OFF.

Conditions for Setting the Fault Codes

The fault code is set active when the EGR differential pressure sensor is reading higher or lower than a calibratible value when the keyswitch is turned OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) at key ON when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer Test, utilize a routine that incorporates acceleration and motoring events, steady state highway operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL, after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This check is only performed at keyswitch OFF, during the ECM powerdown. During this diagnostic check, the ECM monitors the value of the EGR differential pressure sensor. If this value is outside of a specified range, Fault Code 1866 is set active.

Possible causes of this fault code include:

  • A damaged EGR differential pressure sensor
  • High resistance in the wiring harness on the signal or return wire
  • Plugged or restricted EGR differential pressure sensor flow ports.
Refer to Troubleshooting Fault Code 1866.

Last Modified: 14-Nov-2014


Engine Gas Recircuilation Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1867

Engine Gas Recircuilation Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1867 PID: P412 SPN: 412 FMI: 2/2 LAMP: Amber SRT: | Engine Gas Recircuilation Temperature - Data Erratic, Intermittent, or Incorrect. Engine misfire has been detected in multiple cylinder numbers. | A default value will be used for the EGR temperature sensor reading. The EGR valve will be closed.
GX CM2250 - Engine Magnetic Speed/Position Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistance sensor that is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The electronic control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned to the ON position after a 10 hour cold soak, during which the keyswitch has been turned OFF. The second part runs continuously while the engine is running and EGR flow is above a calibratible value.

Conditions for Setting the Fault Codes

The fault code is set active when an EGR temperature reading too high or too low for the operating conditions has been detected, or if the EGR temperature reading is not changing with the operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer Test, utilize a routine that incorporates acceleration and motoring events, steady state highway operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • If the fault code does not go inactive after 10 minutes of driving, it may be necessary to perform a 10 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range EGR temperature sensor
  • High resistance in the EGR temperature sensor signal or return wires.
Refer to Troubleshooting Fault Code 1867.

Last Modified: 14-Nov-2014


Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1879

Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1879 PID: S324 SPN: 3251 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment differential pressure sensor circuit. | Active and stationary regeneration of the diesel particulate filter will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter differential pressure signal voltage is greater than 4.75-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1879.

Last Modified: 23-Nov-2010


Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1881

Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1881 PID: S324 SPN: 3251 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the aftertreatment differential pressure sensor circuit. | Active and stationary regeneration of the diesel particulate filter will be disabled.
GX CM2250 - Aftertreatment Differential Pressure

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter differential pressure signal voltage is less than 0.25-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the aftertreatment diesel particulate filter differential pressure is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code 1881.

Last Modified: 23-Nov-2010


Aftertreatment Diesel Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1883

Aftertreatment Diesel Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1883 PID: S324 SPN: 3251 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter differential pressure sensor is reading an erratic value at initial key ON or during engine operation. | Active and stationary regeneration of the diesel particulate filter will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor

Circuit Description

The ECM provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • One part runs when the keyswitch is initially turned ON before the engine is started
  • The other part runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter differential pressure is greater than 1.5 kpa [0.44 in HG] at initial key ON, or is not changing with engine conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.
  • A default value of the aftertreatment diesel particulate filter differential pressure is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 1 minute. Then start the engine and operate it at high idle for 1 minute. It is necessary to elevate the exhaust flow for at least 30 seconds to clear this fault code. For certain applications, it may be necessary to drive the vehicle in order to achieve adequate exhaust flow.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter differential pressure sensor reading
  • High resistance in the aftertreatment diesel particulate filter differential pressure sensor signal or return wires
  • Disconnected or damaged aftertreatment diesel particulate filter differential pressure sensor tubes
  • Plugged aftertreatment differential pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned off.
Refer to Troubleshooting Fault Code 1883.

Last Modified: 23-Nov-2010


Aftertreatment Intake NOx Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1885

Aftertreatment Intake NOx Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1885 PID: P102 SPN: 3216 FMI: 4 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment intake NOx sensor. | Aftertreatment intake NOx sensor operation will be disabled.
GX CM2250 - Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the engine-out NOx emissions.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature at the aftertreatment intake NOx sensor is above 150° C [302° F] and the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error has been detected in the aftertreatment intake NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 kph [5 mph] after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration. Use INSITE™ electronic service tool. The exhaust gas temperature at the aftertreatment intake NOx sensor must be above 150° C [302° F] before the sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment intake NOx sensor has malfunctioned or is damaged
  • The aftertreatment intake NOx sensor internal heater has malfunctioned
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code 1885.

Last Modified: 01-Dec-2010


Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1887

Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1887 PID: P2202 SPN: 3226 FMI: 4 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor operation will be disabled.
GX CM2250 - Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature at the aftertreatment intake NOx sensor is above 150°C [302°F] and the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error has been detected in the aftertreatment outlet NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced after 10 hours of engine operation with this fault code active.
  • Vehicle speed will be limited to 8 kph [5 mph] after 40 hours of engine operation with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment outlet NOx sensor has malfunctioned or is damaged
  • The aftertreatment outlet NOx sensor internal heater has malfunctioned
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code t05-1887.

Last Modified: 01-Dec-2010


EGR Valve Control Circuit - Abnormal Update Rate

FAULT CODE 1893

EGR Valve Control Circuit - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1893 PID: S324 SPN: 3251 FMI: 2 LAMP: Amber SRT: | EGR Valve Control Circuit - Abnormal Update Rate. No communications or invalid data transfer rate detected on the SAE J1939 data link between the ECM and the smart EGR valve. | EGR valve operation will be disabled.
GX CM2250 - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device and receives commands from the engine electronic control module (ECM) via the SAE J1939 data link. The EGR valve performs its own internal diagnostics and reports malfunctions back to the primary engine ECM using the SAE J1939 data link.

The EGR valve is opened by a motor located on top of the EGR valve. A pin is extended from the motor and contacts the dual poppet valve to open the EGR valve. A spring is used to close the EGR valve.

Component Location

The EGR valve location can vary, depending on the engine application.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The primary engine ECM does not receive a valid SAE J1939 message from the EGR valve for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve will be closed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and enable the EGR valve operation immediately after a valid SAE J1939 message is received from the EGR valve.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the primary engine ECM did not receive valid SAE J1939 information from the EGR valve.

Possible causes of this fault code include:

  • The EGR valve is not receiving power from the ECM. This could be caused by an open circuit in the power supply wire or low voltage supplied by the primary engine ECM
  • Open return circuit on the EGR valve circuit between the engine ECM and the EGR valve
  • Open or short circuit on the SAE J1939 data link circuit between the ECM and the EGR valve
  • Intermittent communications between the EGR valve and the primary engine ECM on the SAE J1939 data link
  • Malfunctioning termination resistors in the engine data link harness
  • A malfunctioning engine ECM
  • A malfunctioning EGR valve.
Refer to Troubleshooting Fault Code t05-1893

Last Modified: 07-Jan-2011


EGR Valve Controller - Bad Intelligent Device or Component

FAULT CODE 1895

EGR Valve Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1895 PID: S146 SPN: 2791 FMI: 12/12 LAMP: Amber SRT: | EGR Valve Controller - Bad Intelligent Device or Component. A calibration mismatch between the EGR valve and the ECM has been detected. | EGR valve actuation will be disabled.
GX CM2250 - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The EGR valve performs its own internal diagnostics and reports malfunctions back to the primary engine electronic control module (ECM) using the J1939 data link.

The EGR valve is opened by a motor located on top of the EGR valve. A pin is extended from the motor and contacts the dual poppet valve to open the EGR valve. The EGR valve motor is not used to close the EGR valve. The pin retracts and a spring is used to close the EGR valve.

This fault code is logged when the calibration version contained in the EGR valve is mismatched with the version in the ECM.

Component Location

The EGR valve location can vary, depending on the engine application.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

  • The ECM has detected a calibration incompatibility between the EGR valve and the ECM calibration.
  • The ECM has detected an incorrect EGR valve installed on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve will stop responding to commands and the spring will close the EGR valve.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and clear the fault code after the keyswitch is cycled and the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the ECM has detected an incorrect EGR valve installed on the engine.

Refer to Troubleshooting Fault Code t05-1895

Last Modified: 07-Jan-2011


EGR Valve Controller - Out of Calibration

FAULT CODE 1896

EGR Valve Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1896 PID: S146 SPN: 2791 FMI: 13/13 LAMP: Amber SRT: | EGR Valve Controller - Out of Calibration. The EGR valve has malfunctioned during the automatic calibration procedure at initial key ON. | EGR valve actuation will be disabled.
GX CM2250 - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The EGR valve performs its own internal diagnostics and reports malfunctions back to the primary engine ECM using the J1939 data link.

The EGR valve is opened by a motor located on top of the EGR valve. A pin is extended from the motor and contacts the dual poppet valve to open the EGR valve. The EGR valve motor is not used to close the EGR valve. The pin retracts and a spring is used to close the EGR valve.

Component Location

The EGR valve location can vary, depending on the engine application.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The EGR valve motor measures the position of the EGR valve at initial key ON. If the valve is detected to be greater than 20 percent open, the fault code is set active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve will stop responding to commands and the spring will close the EGR valve.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and clear the fault code after the keyswitch is cycled and the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

When the keyswitch is initially turned ON and at various times during engine operation, the closed position of the EGR valve is checked. This diagnostic checks to make sure the EGR valve is not stuck open.

This fault code is logged when the following conditions exist:

  • The EGR valve motor measures the position of the EGR valve at initial key ON. If the valve is detected to be out of the normal position, this fault code will be logged.
  • The EGR valve will close when the fault code is active.
  • The fault code will remain active until the next key cycle.

The ECM calibration contains an automatic EGR valve override test 30 seconds after turning the keyswitch ON. The EGR valve will be commanded open to 60 percent and will be held in this position for 1 minute and then it will be commanded to zero percent open. Turn the keyswitch OFF for 20 seconds and then turn the keyswitch ON and read the fault codes. If Fault Code 1896 is active, this indicates that the EGR valve is stuck in the open position.

The fault code will only go inactive if the initial key ON EGR position check passes.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the Snap Acceleration Test to check for a damaged diesel particulate filter. Use the following procedure for aftertreatment reuse guidelines. Refer to Procedure 014-013 in Section 14.

Refer to Troubleshooting Fault Code t05-1896.

Last Modified: 20-Jan-2011


VGT Actuator Controller - Out of Calibration

FAULT CODE 1898

VGT Actuator Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1898 PID: S027 SPN: 641 FMI: 13/13 LAMP: Amber SRT: | VGT Actuator Controller - Out of Calibration. The VGT has failed the automatic calibration procedure at initial key ON. | Low intake manifold pressure. The VGT will be in the open position.
GX CM2250 - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs 5 minutes after engine start up if coolant temperature is greater than 71°C [160°F].

Conditions for Setting the Fault Codes

Conditions for setting the fault code: The internal position reference is not detected during the ECM commanded span check due to mechanical system binding or internal condition. The actual VGT actuator position is not known.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then start the engine and let it idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

This fault code is logged when one of the following error conditions exists.

  • The gear alignment between the actuator and the turbocharger housing is misaligned.
  • Foreign material in the VGT turbocharger can prevent the sliding nozzle from moving to the desired position.
Refer to Troubleshooting Fault Code 1898.

Last Modified: 14-Nov-2014


Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1921

Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1921 PID: S324 SPN: 3251 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The soot load of the aftertreatment DPF has exceeded the recommended limits. | The aftertreatment dash lamp will flash. Engine protection derate.
GX CM2250 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment DPF. Under normal operating conditions, the aftertreatment DPF is self cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment DPF. The soot load in the aftertreatment DPF is estimated using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code can be triggered if the application is not operating at a duty cycle high enough to actively regenerate the aftertreatment DPF. This fault code indicates that the exhaust temperatures exiting the turbocharger are not high enough to actively regenerate the soot that is trapped in the aftertreatment DPF. It may be necessary to increase the duty cycle of the application in order to prevent plugging of the aftertreatment DPF.

Component Location

The aftertreatment DPF is located in the exhaust system and is installed by the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the soot load of the aftertreatment DPF is moderately severe. The aftertreatment system needs to be regenerated to remove the soot.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic fails.
  • The ECM will flash the aftertreatment lamp immediately after the diagnostic fails.
  • Torque output of the engine will be reduced as the soot load in the aftertreatment DPF increases.
  • Mobile regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the soot load of the aftertreatment DPF falls below the moderately severe level and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Note: This fault code indicates that the aftertreatment DPF requires maintenance by performing a stationary regeneration procedure. This is a maintenance procedure only and is not covered by Cummins® warranty.

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to the Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration troubleshooting symptom tree in Section TS, to identify the cause of frequent regeneration.

Possible causes of this fault code include:

  • The engine has been operating in a light load condition that prevents exhaust temperatures from being high enough to actively regenerate the aftertreatment DPF.
  • Possible engine damage that causes excessive black soot to be generated.
  • If Fault Code 2777 is active along with Fault Code 1921, this indicates that a regeneration inhibit message has been received by the engine ECM and that active regeneration of the aftertreatment DPF was not permitted. Confirm that OEM settings for the aftertreatment permit switch are configured correctly. A stationary regeneration of the aftertreatment DPF can be performed. Use INSITE™ electronic service tool.
  • The aftertreatment DPF soot loading can be classified into four different stages. As the soot load increases, the aftertreatment lamp and the Cummins® CHECK ENGINE (Amber) or STOP ENGINE (Red) lamp will operate according to the table below. The stationary regeneration procedure can be used to clear the soot from the aftertreatment DPF in stages 1, 2, and 3. At level 4, the aftertreatment DPF is completely plugged and must be inspected and cleaned or replaced, if the aftertreatment DPF does not meet the inspection criteria. Inadequate exhaust temperatures entering the aftertreatment system can be a cause of high soot loads in the aftertreatment DPF. The duty cycle of the application may need to be increased in order to prevent excessive soot from accumulating in the filter.

Aftertreatment System Soot Stages
Soot Level Stage | Cummins® Fault Code | Aftertreatment Lamp Status | Cummins® Lamp Status | Service Procedure | Engine Protection Strategy
1 | 2639 | Solid | Off | Perform stationary regeneration procedure | No engine protection derate
2 | 2639 | Flashing | Off | Perform stationary regeneration procedure | Mild engine torque derate
3 | 1921 | Flashing | Amber | Perform stationary regeneration procedure | Moderate engine torque and engine speed derate
4 | 1922 | Off | Red | Inspect and clean or replace aftertreatment DPF | Severe engine torque and engine speed derate

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM power distribution center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code t05-1921.

Last Modified: 14-Nov-2014


Aftertreatment Diesel Particulate Filter Differential (DPF) Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1922

Aftertreatment Diesel Particulate Filter Differential (DPF) Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1922 PID: S324 SPN: 3251 FMI: 0 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The soot load of the aftertreatment DPF has exceeded the recommended limits. Engine protection derate is enabled. | Severe engine derate.
GX CM2250 - Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment DPF. Under normal operating conditions, the aftertreatment DPF is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment DPF. The soot load in the aftertreatment DPF is estimated using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code can be triggered if the application is not operating at a duty cycle high enough to actively regenerate the aftertreatment DPF. This fault code indicates that the exhaust temperatures exiting the turbocharger are not high enough to actively regenerate the soot that is trapped in the aftertreatment DPF. It may be necessary to increase the duty cycle of the application in order to prevent plugging of the aftertreatment DPF.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the soot load of the aftertreatment DPF has exceeded the maximum operating limits.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the red STOP ENGINE lamp immediately after the diagnostic fails.
  • Torque output of the engine will be reduced as the soot load in the aftertreatment DPF increases.
  • Active and stationary regeneration of the DPF is disabled.
  • The EGR valve will be closed.

Conditions for Clearing the Fault Code

  • Use INSITE™ electronic service tool to perform the Diesel Particulate Filter (DPF) Reset procedure found under the Aftertreatment Maintenance section of Advanced ECM Data.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter (DPF) Regeneration test found in the ECM Diagnostics Test.
  • The ECM will turn OFF the red STOP ENGINE light immediately after the soot load in the aftertreatment DPF has dropped below the most severe level.
  • Continue to run the regeneration until the soot load in the aftertreatment DPF has dropped to the normal level.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment wiring harness or the aftertreatment temperature sensor connector pin installation may be incorrect.
  • The engine has been operating in a light load condition that prevents exhaust temperatures from being high enough to actively regenerate the aftertreatment DPF.
  • A possible base engine malfunction that causes excessive black soot to be generated.
  • If both Fault Code 1921 and Fault Code 2777 are inactive with an active Fault Code 1922, this indicates that a regeneration inhibit message has been received by the engine ECM and that active regeneration of the aftertreatment DPF was not allowed. Use the OEM manuals to confirm that the OEM settings for the aftertreatment permit switch are configured correctly.

The aftertreatment DPF soot loading can be classified into four different stages. As the soot load increases, the aftertreatment DPF lamp and the Cummins® CHECK ENGINE (Amber) or STOP ENGINE (Red) lamp will operate according to the table below. Inadequate temperature for the exhaust gases entering the aftertreatment system can be a cause of high soot loads in the aftertreatment DPF. The duty cycle of the application may need to be increased in order to prevent excessive soot from accumulating in the filter.

Aftertreatment System Soot Stages
Soot Level Stage | Cummins® Fault Code | Aftertreatment Lamp Status | Cummins® Lamp Status | Service Procedure | Engine Protection Strategy
1 | 2639 | Solid | OFF | Perform stationary regeneration procedure | No engine protection derate
2 | 2639 | Flashing | OFF | Perform stationary regeneration procedure | Mild engine torque derate
3 | 1921 | Flashing | Amber | Perform stationary regeneration procedure | Moderate engine torque and engine speed derate
4 | 1922 | OFF | Red | Inspect and clean or replace the aftertreatment DPF | Severe engine torque and engine speed derate
Refer to Troubleshooting Fault Code t05-1922.

Last Modified: 20-Mar-2014


Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1923

Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1923 PID: S334 SPN: 3482 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment fuel shutoff valve circuit. | Active aftertreatment diesel particulate filter (DPF) regeneration will be disabled until the next key cycle.
GX CM2250 - Aftertreatment Fuel Shutoff Valve 1 Circuit

Circuit Description

The aftertreatment fuel shutoff valve is used to disable the fuel supply to the aftertreatment system.

Component Location

The aftertreatment fuel shutoff valve sensor is located in the aftertreatment shutoff valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment fuel shutoff valve is commanded ON.

Conditions for Setting the Fault Codes

The engine fuel shutoff valve circuit pulse width modulated (PWM) signal is detected to be at system voltage when the pulse width modulated (PWM) voltage is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter (DPF) will be disabled until the next key cycle.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test. Once the temperatures in the aftertreatment are warm enough to inject diesel fuel into the exhaust, the diagnostic will run.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Fuel shutoff valve signal wire shorted to a voltage source in the harness
  • A damaged aftertreatment fuel shutoff valve.
Refer to Troubleshooting Fault Code t05-1923.

Last Modified: 30-Nov-2010


Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1924

Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1924 PID: S334 SPN: 3482 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment fuel shutoff valve circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Fuel Shutoff Valve 1 Circuit

Circuit Description

The aftertreatment fuel shutoff valve is used to disable the fuel supply to the aftertreatment system.

Component Location

The aftertreatment fuel shutoff valve sensor is located in the aftertreatment shutoff valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment fuel shutoff valve is commanded OFF.

Conditions for Setting the Fault Codes

The engine fuel shutoff valve circuit pulse width modulated (PWM) signal is detected to be 0-VDC when the PWM voltage is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter (DPF) will be disabled unitl the next key cycle.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips when the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or shutoff valve
  • A short circuit to ground in the engine harness, connectors, or shutoff valve
  • A shorted aftertreatment fuel shutoff valve.
Refer to Troubleshooting Fault Code t05-1924.

Last Modified: 30-Nov-2010


Aftertreatment Fuel Shutoff Valve 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1925

Aftertreatment Fuel Shutoff Valve 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1925 PID: S334 SPN: 3482 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Fuel Shutoff Valve 1 - Data Erratic, Intermittent, or Incorrect. An error has been detected in the aftertreatment fuel shutoff valve or the aftertreatment fuel injector system. | Active aftertreatment diesel particulate filter (DPF) regeneration will be disabled until the next key cycle.
GX CM2250 - Aftertreatment Fuel Shutoff Valve 1 Circuit

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system, as well as a damaged aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started, a diagnostic test of the system is performed. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold. The aftertreatment shutoff valve is located on the same side of the manifold as the aftertreatment pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment DPF.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detected an internally leaking aftertreatment fuel shutoff valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment DPF will be disabled until the next key cycle.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test. Once the temperatures in the aftertreatment are warm enough to inject diesel fuel into the exhaust, the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips when the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Internal leak of the aftertreatment fuel shutoff valve allowing fuel pressure to leak past the aftertreatment fuel shutoff valve
  • Air trapped in the aftertreatment fuel system
  • Stuck open or closed aftertreatment fuel shutoff valve or aftertreatment fuel drain valve
  • Internal or external leak in the aftertreatment fuel shutoff valve or fuel drain valve
  • Internal or external leak in the aftertreatment fuel injector
  • Stuck closed, plugged, or clogged aftertreatment fuel injector
  • Loose fittings in the aftertreatment fuel system
  • External fuel leaks in the aftertreatment fuel system
  • Third-party aftertreatment fuel shutoff valve manifold
  • Fuel filter plugged.
Refer to Troubleshooting Fault Code t05-1925.

Last Modified: 14-Nov-2011


Aftertreatment Fuel Pressure Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1926

Aftertreatment Fuel Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1926 PID: S332 SPN: 3480 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Fuel Pressure Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the aftertreatment fuel pressure signal is not changing with engine operating conditions. | Active aftertreatment diesel particulate filter (DPF) regeneration will be disabled until the next key cycle.
GX CM2250 - Aftertreatment Fuel Pressure Sensor Circuit

Circuit Description

The aftertreatment fuel pressure sensor is used to monitor the fuel pressure into the aftertreatment system. The electronic control module (ECM) supplies the aftertreatment fuel pressure sensor a 5 volt reference voltage. When the fuel pressure is low, the sensor signal voltage is low. When the fuel pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the aftertreatment fuel pressure signal circuit voltage to calculate the pressure of the fuel within the aftertreatment system.

Component Location

The aftertreatment fuel pressure sensor is located in the aftertreatment shutoff valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment DPF.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment fuel pressure sensor is reading an erratic value, or the aftertreatment fuel pressure reading is not changing with the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A calculated value of aftertreatment fuel pressure is used for aftertreatment operation.
  • Active regeneration of the aftertreatment DPF will be disabled unitl the next key cycle.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test. Once the temperatures in the aftertreatment are warm enough to inject diesel fuel into the exhaust, the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible cause of this fault code:

  • A malfunctioning in-range aftertreatment fuel pressure sensor
  • A plugged fuel filter
  • A malfunctioning fuel pump gear pump..
Refer to Troubleshooting Fault Code t05-1926.

Last Modified: 14-Nov-2014


Aftertreatment Fuel Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1927

Aftertreatment Fuel Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1927 PID: None SPN: 3480 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Fuel Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment fuel pressure sensor circuit. | Active aftertreatment diesel particulate filter (DPF) regeneration will be disabled until the next key cycle.
GX CM2250 - Aftertreatment Fuel Pressure Sensor Circuit

Circuit Description

The aftertreatment fuel pressure sensor is used to monitor the fuel pressure into the aftertreatment system. The electronic control module (ECM) supplies the aftertreatment fuel pressure sensor a 5 volt reference voltage. When the fuel pressure is low, the sensor signal voltage is low. When the fuel pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the aftertreatment fuel pressure signal circuit voltage to calculate the pressure of the fuel within the aftertreatment system.

Component Location

The aftertreatment fuel pressure sensor is located in the aftertreatment shutoff valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment fuel pressure signal voltage is more than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment DPF will be disabled until the next key cycle.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connector, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage
  • A shorted sensor.
Refer to Troubleshooting Fault Code t05-1927.

Last Modified: 10-Dec-2010


Aftertreatment Fuel Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1928

Aftertreatment Fuel Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1928 PID: None SPN: 3480 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Fuel Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment fuel pressure sensor circuit. | Active aftertreatment diesel particulate filter (DPF) regeneration will be disabled until the next key cycle.
GX CM2250 - Aftertreatment Fuel Pressure Sensor Circuit

Circuit Description

The aftertreatment fuel pressure sensor is used to monitor the fuel pressure into the aftertreatment system. The electronic control module (ECM) supplies the aftertreatment fuel pressure sensor a 5 volt reference voltage. When the fuel pressure is low, the sensor signal voltage is low. When the fuel pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the aftertreatment fuel pressure signal circuit voltage to calculate the pressure of the fuel within the aftertreatment system.

Component Location

The aftertreatment fuel pressure sensor is located in the aftertreatment shutoff valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment fuel pressure signal voltage is less than 0.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment DPF will be disabled until the next key cycle.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connector, or sensor
  • SIGNAL wire shorted to ground
  • A shorted sensor.
Refer to Troubleshooting Fault Code t05-1928.

Last Modified: 10-Dec-2010


Aftertreatment Doser - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1932

Aftertreatment Doser - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1932 PID: S382 SPN: 3556 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Doser - Data Erratic, Intermittent, or Incorrect. An internal or external fuel leak has been detected in the aftertreatment fuel system. | Active aftertreatment diesel particulate filter (DPF) regeneration will be disabled until the next key cycle.
GX CM2250 - Aftertreatment Doser Circuit

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system, as well as a damaged aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started and prior to active regeneration of the aftertreatment system, a diagnostic test is performed on the system. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve, are installed in the shutoff valve manifold. The aftertreatment shutoff valve is located on the same side of the manifold as the aftertreatment pressure sensor, while the aftertreatment fuel drain valve is located by itself, on the other side of the manifold.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment DPF.

Conditions for Setting the Fault Codes

The ECM detected a leaking aftertreatment fuel injector or an external leak.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment DPF will be disabled unitl the next key cycle.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test. Once the temperatures in the aftertreatment are warm enough to inject diesel fuel into the exhaust, the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A stuck open or leaking aftertreatment fuel injector
  • An external leak in the aftertreatment fuel injector system.
Refer to Troubleshooting Fault Code t05-1932.

Last Modified: 30-Nov-2010


EGR Actuator Driver Circuit - Root Cause Not Known

FAULT CODE 1935

EGR Actuator Driver Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1935 PID: S146 SPN: 2791 FMI: 11 LAMP: Amber SRT: | EGR Actuator Driver Circuit - Root Cause Not Known. Intermittent communication between the smart EGR valve controller and the electronic control module (ECM) has been detected. | The EGR valve will hold the position of the last valid J1939 message.
GX CM2250 - EGR Valve Circuit

Circuit Description

The EGR valve is a smart device that receives commands from the engine ECM via the J1939 data link. The EGR valve performs its own internal diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link.

The EGR valve is opened by a motor located on top of the EGR valve. A pin is extended from the motor and contacts the dual poppet valve to open the EGR valve. The EGR valve motor is not used to close the EGR valve. The pin retracts and a spring is used to close the EGR valve.

Component Location

The EGR valve location can vary, depending on engine application.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The EGR valve does not receive a valid J1939 message from the primary engine ECM for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve will hold the position of the last valid J1939 message.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and enable EGR valve operation immediately after a valid J1939 message is received by the EGR valve.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the EGR valve controller did not receive valid J1939 commands from the primary engine ECM. Intermittent J1939 data link connections or interference on the J1939 network are possible causes of this fault code. Also check for intermittent power supply and ground connections to the EGR valve controller.

Refer to Troubleshooting Fault Code t05-1935.

Last Modified: 10-Jan-2011


Data Link EGR Valve Relay Power Signal - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1936

Data Link EGR Valve Relay Power Signal - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1936 PID: SPN: N/A FMI: N/A LAMP: Amber SRT: | Data Link EGR Valve Relay Power Signal - Voltage Below Normal or Shorted to Low Source. The signal to the EGR valve power relay has been shorted to ground, or low source. | EGR valve actuation will be disabled.
GX CM2250 - EGR Valve Relay Circuit

Circuit Description

The EGR valve receives power from the engine out NOx external power supply, through the EGR valve supply relay. A signal from the Cummins® CM2250 electronic control module (ECM), through the Westport™ converter harness and the Westport™ modified base engine harness, engages the relay.

Component Location

The EGR valve relay is located on the modified base engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is operating.

Conditions for Setting the Fault Codes

The voltage from the relay signal is shorted to ground or a low source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The EGR valve will be closed.

Conditions for Clearing the Fault Code

  • The keyswitch should be cycled when the issue has been resolved.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes after the keyswitch cycle.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code is logged when the ECM has detected a shorted, grounded, or low power source from the EGR valve relay.

Possible causes of this fault code include:

  • Shorted Westport™ converter harness to ground
  • Shorted Westport™ modified base engine harness to ground
  • Shorted EGR valve power relay.
Refer to Troubleshooting Fault Code t05-1936.

Last Modified: 18-Feb-2011


Data Link EGR Valve Relay Power Signal - Voltage Above Normal or Shorted to High Source

FAULT CODE 1937

Data Link EGR Valve Relay Power Signal - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1937 PID: SPN: N/A FMI: N/A LAMP: Amber SRT: | Data Link EGR Valve Relay Power Signal - Voltage Above Normal or Shorted to High Source. The signal to the EGR valve power relay has an open circuit, or is shorted to a high source. | None on performance.
GX CM2220 - EGR Valve Supply Relay Circuit

Circuit Description

The EGR valve receives power from the engine out NOx external power supply through a relay. A signal from the Cummins® CM2250 electronic control module, through the Westport™ converter harness and the Westport™ modified base engine harness, engages the relay.

Component Location

The EGR valve relay is located on the modified base engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is operating. However, the fault code can only be detected for approximately 15 seconds after the keyswitch is turned to the OFF position, while the Cummins® CM2250 is powering OFF.

Conditions for Setting the Fault Codes

The EGR valve relay wiring has an open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The EGR valve will be closed.

Conditions for Clearing the Fault Code

  • The keyswitch should be cycled when the issue has been resolved.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes after the keyswitch cycle.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

The fault code is logged when the ECM has detected an open circuit or short to a high source from the EGR valve relay.

Possible causes of this fault code include:

  • Open circuit, or short to a high source in the Westport™ converter harness
  • Open circuit, or short to a high source in the Westport™ modified base engine harness
  • Open circuit in the EGR valve power relay.
Refer to Troubleshooting Fault Code t05-1937.

Last Modified: 18-Feb-2011


ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1938

ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1938 PID: S212 SPN: 3597 FMI: 1/18 LAMP: Amber SRT: | ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operationg Range - Moderately Severe Level. Low battery voltage detected by the VGT actuator. | None on performance.
GX CM2250 - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine ECM. The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine control module (ECM) using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fault code is set when the voltage supplied to the VGT actuator drops below 10-VDC for 10 seconds and the engine speed must be zero rpm or above 575 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The VGT actuation will continue until battery voltage drops low enough that VGT actuation can not continue.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the voltage to the VGT actuator is greater than 10-VDC, the engine speed is zero or greater than 575 rpm, and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

This fault code is logged when the voltage to the VGT actuator drops below 10-VDC. The VGT will still continue to respond to commands from the primary engine ECM.

Refer to Troubleshooting Fault Code 1938.

Last Modified: 14-Nov-2014


Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1942

Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1942 PID: P101 SPN: 101 FMI: 2 LAMP: Amber SRT: | Crankcase Pressure - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the crankcase pressure signal is reading an erratic value at initial key ON or during engine operation. | None on performance.
GX CM2250 - Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The electronic control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in the crankcase filter assembly.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part of this diagnostic runs at initial key ON and the second part runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure sensor is reading an erratic value at key ON or the crankcase pressure reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 1 minute. Then start the engine and let it idle for 2 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a crankcase breather hose disconnected between the engine outlet and crankcase filter assembly on engines with an externally mounted crankcase filter option.

Possible causes of this fault code include:

  • Resistance in the wiring harness
  • A malfunctioning in-range pressure sensor
  • Crankcase pressure sensor is not installed correctly in the housing.
Refer to Troubleshooting Fault Code t05-1942.

Last Modified: 30-Nov-2010


Ambient Air Density - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 1943

Ambient Air Density - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1943 PID: SPN: 3555 FMI: 1/17 LAMP: None SRT: | Ambient Air Density - Data Valid But Below Normal Operating Range - Least Severe Level. Engine torque has been reduced because the vehicle was operating at a high altitude condition. | Possible engine derate.
GX CM2250 - Electronic Control Module (ECM)

Circuit Description

The engine electronic control module (ECM) monitors the ambient air pressure using either an ambient air pressure sensor or a combination turbocharger compressor intake pressure/temperature sensor. These sensors respond to pressure changes in the atmosphere, which occur based on the elevation where the engine is currently operating. This pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The ambient air or compressor intake pressure sensor provides a signal to the ECM on the pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness, near the ECM. The turbocharger compressor intake pressure sensor is located just before the inlet to the turbocharger. Use the engine wiring diagram to determine which sensor the engine is equipped with.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure reading is lower than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Engine torque output will be limited due to the engine operating at high altitude conditions.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the engine has been operated in a high altitude location, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating in the high altitude location to protect the turbocharger and engine from excessively high exhaust temperatures. The derate limits the torque output of the engine to keep the temperatures below the maximum temperature limits.

Note: This fault code will most likely not be active with no load in the shop. The engine must be under the same operating conditions (altitude and temperature) at the time that it had originally logged.

Refer to Troubleshooting Fault Code t05-1943.

Last Modified: 18-Jan-2011


EGR Valve Control Circuit Calculated Over Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 1961

EGR Valve Control Circuit Calculated Over Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1961 PID: S146 SPN: 2791 FMI: 0/15 LAMP: Amber SRT: | EGR Valve Control Circuit Calculated Over Temperature - Data Valid but Above Normal Operating Range - Least Severe Level. The EGR valve has detected a high temperature condition. | EGR valve operation will be disabled.
GX CM2250 - EGR Actuator Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The EGR valve performs its own internal diagnostics and reports malfunctions back to the primary engine ECM using the J1939 data link.

The EGR valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve location can vary, depending on the engine application.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code logs when the internal temperature of the EGR valve motor is above 135°C [275°F].

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The fault code is set inactive when the internal temperature of the EGR valve motor is below 125°C [257°F].

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 Section 19.

This fault code is for information only. No action is taken when this fault code is logged.

Refer to Troubleshooting Fault Code t05-1961.

Last Modified: 01-Mar-2011


Aftertreatment Fuel Shutoff Valve 1 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1963

Aftertreatment Fuel Shutoff Valve 1 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1963 PID: S332 SPN: 3482 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment Fuel Shutoff Valve 1 - Mechanical System Not Responding Properly or Out of Adjustment. The aftertreatment fuel shutoff valve has been detected to be stuck closed. | Active aftertreatment diesel particulate filter regeneration will be disabled until the next key cycle.
GX CM2250 - Aftertreatment Fuel Shutoff Valve 1 Circuit

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect malfunctions in the system, as well as the aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started, a diagnostic test on the system is performed. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment fuel system to gear pump is reading gear pump operating pressure.The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel injector then briefly opens and relieves some of the fuel pressure trapped between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment fuel pressure sensor is reading a value lower than a threshold when the aftertreatment fuel shutoff valve is commanded open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled until the next key cycle.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test. Once the temperatures in the aftertreatment are warm enough to inject diesel fuel into the exhaust, the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck closed aftertreatment fuel shutoff valve
  • Missing or malfunctioning fuel supply line to the aftertreatment fuel shutoff manifold.
Refer to Troubleshooting Fault Code t05-1963.

Last Modified: 30-Nov-2010


Aftertreatment Doser Circuit - Current Below Normal or Open Circuit.

FAULT CODE 1977

Aftertreatment Doser Circuit - Current Below Normal or Open Circuit.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1977 PID: S382 SPN: 3556 FMI: 5 LAMP: Amber SRT: | Aftertreatment Doser Circuit - Current Below Normal or Open Circuit. High resistance, short circuit, or open circuit detected on the aftertreatment fuel injector circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Fuel Injector Circuit

Circuit Description

The aftertreatment fuel injector is electronically controlled by the engine electronic control module (ECM) through a pulse width modulated (PWM) signal. The amount of fuel injected is determined by how long the PWM signal to the injector is on.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is turned ON.

Conditions for Setting the Fault Codes

The ECM detects a circuit error within the aftertreatment fuel injector circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled until the next key cycle.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test. Once the temperatures in the aftertreatment are warm enough to inject diesel fuel into the exhaust, the diagnostic will run.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • An open circuit in the supply or return wire in the engine harness
  • An open circuit in the aftertreatment fuel injector solenoid
  • A short circuit to ground in the engine harness
  • A short circuit to voltage source in the engine harness
  • High resistance in the aftertreatment fuel injector solenoid
  • An extremely low resistance in the aftertreatment fuel injector solenoid
  • A damaged ECM.
Refer to Troubleshooting Fault Code t05-1977.

Last Modified: 01-Dec-2010


Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1981

Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1981 PID: None SPN: 3936 FMI: 15/15 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Least Severe Level. The aftertreatment differential pressure has exceeded the maximum operating limits or the diesel particulate filter is plugged. | EGR valve operation will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the diesel particulate filter is plugged or that the differential pressure across the diesel particulate filter is above the maximum limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the differential pressure across the aftertreatment diesel particulate filter has dropped below the maximum severity level and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment wiring harness connectors may be connected to the wrong aftertreatment temperature sensor
  • The aftertreatment wiring harness or aftertreatment temperature sensor connector pin installation may be incorrect
  • The aftertreatment diesel particulate filter can be plugged with ash
  • The engine has been operating in light load conditions that prevent exhaust gas temperatures from being high enough to actively regenerate the aftertreatment particulate trap
  • An engine malfunction that is elevating the engine smoke output.
Refer to Troubleshooting Fault Code t05-1981.

Last Modified: 18-Jan-2011


Aftertreatment Diesel Particulate Filter Missing - Condition Exists

FAULT CODE 1993

Aftertreatment Diesel Particulate Filter Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1993 PID: SPN: 4795 FMI: 31 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Missing - Condition Exists. The aftertreatment diesel particulate filter in the exhaust system is not present. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Electronic Control Module (ECM)

Circuit Description

The engine aftertreatment system monitors for the presence of the aftertreatment diesel particulate filter. This diagnostic checks to make sure that the aftertreatment diesel particulate filter is present and functioning correctly.

Component Location

The aftertreatment particulate filter is located in the exhaust system and is installed by the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

This diagnostic monitors the aftertreatment diesel particulate filter differential pressure sensor. When the differential pressure is below a minimum value and the exhaust flow rate is above a minimum flow rate, the fault code is set.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes for two consecutive trips.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate it at high idle for 1 minute. It is necessary to elevate the exhaust flow for at least 30 seconds to clear this fault code. For certain applications, it may be necessary to drive the vehicle in order to achieve adequate exhaust flow.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment diesel particulate filter has been removed from the vehicle
  • The aftertreatment diesel particulate filter is cracked or otherwise broken
  • The aftertreatment diesel particulate filter differential tubes are installed incorrectly, broken, loose, or have been tampered with
  • The aftertreatment diesel particulate filter differential tubes are installed backwards.
Refer to Troubleshooting Fault Code t05-1993.

Last Modified: 30-Nov-2010


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
GX CM2250 - Accelerator Pedal or Lever Position Sensor Supply

Circuit Description

Sensor supply 4 of the electronic control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor. The accelerator position sensor is a Hall Effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the ECM as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 VDC supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal assembly is located in the cab. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 4 signal voltage is more than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Refer to Troubleshooting Fault Code t05-2185.

Last Modified: 30-Nov-2010


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
GX CM2250 - Accelerator Pedal Position Sensor Supply Voltage Circuit

Circuit Description

Sensor supply 4 of the electronic control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor. The accelerator position sensor is a Hall Effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the ECM as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 VDC supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal is located in the cab. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 4 signal voltage is less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For ON-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Low voltage on the 5 VDC supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code t05-2186.

Last Modified: 30-Nov-2010


EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2272

EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2272 PID: P027 SPN: 27 FMI: 4/4 LAMP: Amber SRT: | EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage has been detected at the EGR position sensor circuit. | EGR valve actuation will be disabled.
GX CM2250 - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The EGR valve performs its own internal diagnostics and reports malfunctions back to the primary engine ECM using the J1939 data link.

The EGR valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve location can vary, depending on engine application.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The EGR valve has detected an internal error in the EGR valve smart device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The diagnostic will clear at initial key ON if the failure condition no longer exits. The ECM will turn off the amber CHECK ENGINE light and enable the EGR valve operation immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, use the following procedure to calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the EGR valve has detected an internal error. An internal position sensor error detected by the EGR valve motor is a possible cause of this fault code

Refer to Troubleshooting Fault Code t05-2272.

Last Modified: 04-Mar-2011


Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2273

Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2273 PID: P411 SPN: 411 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the EGR differential pressure sensor circuit. | EGR valve actuation will be disabled.
GX CM2250 - EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust gas pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The electronic control module (ECM) uses this pressure to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.

Component Location

The EGR differential pressure sensor is located on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR differential pressure signal voltage is greater than 4.8-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the EGR differential pressure sensor is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • An open return circuit in the engine harness, connectors, or sensor
  • A signal wire shorted to sensor supply or battery voltage
  • A damaged EGR differential pressure sensor.
Refer to Troubleshooting Fault Code t05-2273.

Last Modified: 04-Mar-2011


Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2274

Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2274 PID: P411 SPN: 411 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the EGR differential pressure sensor circuit. | EGR valve actuation will be disabled.
GX CM2250 - EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust gas pressure. The sensor outputs a voltage that represents the pressure difference between the two ports. The electronic control module (ECM) uses this pressure to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.

Component Location

The EGR differential pressure sensor is located on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR differential pressure signal voltage is less than 0.26-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the EGR differential pressure sensor is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A supply wire open or shorted to ground
  • A malfunctioning EGR differential pressure sensor.
Refer to Troubleshooting Fault Code t05-2274.

Last Modified: 30-Nov-2010


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2288

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2288 PID: P103 SPN: 103 FMI: 15 LAMP: None SRT: | Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level. High turbocharger speed has been detected by the ECM. | Engine power derate to lower the turbocharger speed.
GX CM2250 - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed is above the maximum calibratible limits.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM will reduce the torque output of the engine to reduce turbocharger speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the engine has taken the necessary action to reduce the turbocharger speed, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating near the maximum turbocharger speed limits.

Refer to Troubleshooting Fault Code t05-2288.

Last Modified: 30-Nov-2010


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2/2 LAMP: SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Crankshaft engine speed sensor intermittent synchronization. | The engine can exhibit misfire as control switches from the primary to the backup speed sensor. Engine power is reduced while the engine operates on the backup speed sensor.
GX CM2250 - Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position, based on the missing tooth on the speed indicator ring.

Component Location

The camshaft position sensor location varies, depending on the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects an intermittent or degraded signal from the crankshaft speed/position sensor over an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • For On-Board Diagnostics (OBD) engines, the ECM illuminates the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and idle the engine. It may take up to 20 minutes of engine run time for this fault code to become inactive.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the degraded signal from the crankshaft speed/position sensor is no longer present and the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

During engine operation, the ECM monitors the primary speed sensor (crankshaft speed sensor) signal. Fault Code 689 will become active and light the yellow lamp if the signal from the primary speed sensor is not present or degraded for more than 3 continuous seconds. Meanwhile, if the primary engine speed sensor signal is not present or is degraded for a moment (less than 3 seconds), the ECM will interrupt injection events based on the primary engine speed sensor and resume injection events using the backup engine speed sensor. Engine power will be reduced while the injection events are based on the backup speed sensor. If the primary speed sensor signal returns, the ECM will automatically interrupt injection events based on the backup speed sensor and resume injection events based on the primary speed sensor. If over a period of time, the ECM detects several incidents of a loss of the primary speed sensor signal, this fault code will become active.

A vehicle operator can notice an intermittent “misfire” if the injection events are interrupted while the ECM switches from control based on the primary and secondary speed sensors. Also, a vehicle operator can notice intermittent “low power” if a “glitch” in the primary speed sensor signal causes the engine to intermittently use the backup speed sensor for injection control.

This fault code becomes active whenever the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

This fault becomes inactive if the ECM does not detect a loss of the primary engine speed sensor signal for at least 20 minutes.

Possible causes of this fault code include:

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems.
  • Sensor air gap that is marginally too small or too large.

Actions to take if this fault code is intermittent:

  • Inspect for intermittent engine harness connections in the primary engine speed sensor circuit.
  • Inspect for loose connections at the ECM connector where the pins can not be locked into the socket.
  • Inspect for places where the engine harness has worn into a nearby component, causing an intermittent short circuit.
  • Inspect for pin wear at the speed sensor.
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code t05-2321.

Last Modified: 01-Dec-2010


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S064 SPN: 723 FMI: 2/2 LAMP: None SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. Camshaft engine speed sensor intermittent synchronization. | None on performance.
GX CM2250 - Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft position sensor location varies, depending on the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects an intermittent loss of the camshaft speed/position sensor signal.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • For On-Board Diagnostics (OBD) engines, the ECM illuminates the the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

During engine operation, the ECM monitors the secondary speed sensor (camshaft speed sensor) signal. Fault Code 778 will become active and light the yellow lamp if the signal from the secondary speed sensor is not present or degraded for more than 3 continuous seconds. If over a period of time the ECM detects several incidents of a loss of the secondary speed sensor signal, but the signal loss is short in duration, this fault code will become active. Since the secondary engine speed signal is not used for normal engine operation, a vehicle operator should not notice any symptoms related to this problem.

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

This fault becomes inactive if the ECM does not detect a loss of the secondary engine speed sensor signal for at least 20 minutes.

Possible causes of this fault code include:

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems
  • Sensor air gap that is marginally too small or too large.
  • Target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

  • Inspect for intermittent engine harness connections in the secondary engine speed sensor circuit
  • Inspect for loose connections at the ECM connector where the pins can not be locked into the socket
  • Inspect for places where the engine harness has worn into a nearby component, causing an intermittent short circuit
  • Inspect for pin wear at the speed sensor
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code t05-2322.

Last Modified: 19-Oct-2011


Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2346

Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2346 PID: S384 SPN: 2789 FMI: 0/15 LAMP: None SRT: | Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. Turbocharger turbine intake temperature has exceeded the engine protection limit. | Fuel is limited in an attempt to decrease the temperature of the exhaust gas entering the turbocharger.
GX CM2250 - Engine Control Module

Circuit Description

The exhaust gas temperature is calculated by the engine control module (ECM). The exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger, and is also known as turbine intake temperature.

Note: Some original equipment manufacturers (OEM) have pyrometer gauges mounted in their chassis. Pyrometers measure turbine outlet exhaust gas temperature leaving the turbocharger and will not equal the value monitored with the exhaust gas temperature parameter with INSITE™ electronic service tool.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the calculated turbine intake temperature is greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the temperature threshold is exceeded.
  • Fuel is limited in an attempt to decrease the temperature of the exhaust gas entering the turbocharger.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is an information fault code, indicating that the engine has been derated for high turbine intake temperature (exhaust temperature). No troubleshooting is necessary for this fault code. It is only an indicator that the engine power was derated to limit the exhaust temperature.

If the condition continues to exist, Fault Code 2451 will become active.

Refer to Troubleshooting Fault Code 2346.

Last Modified: 14-Nov-2014


EGR Valve Control Circuit - Current Below Normal or Open Circuit

FAULT CODE 2349

EGR Valve Control Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2349 PID: S146 SPN: 2791 FMI: 5/5 LAMP: Amber SRT: | EGR Valve Control Circuit - Current Below Normal or Open Circuit. Motor terminal or motor coil open circuit has been detected by the smart EGR controller. | EGR valve actuation will be disabled.
GX CM2250 - EGR Valve Control Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The EGR valve performs its own internal diagnostics and reports malfunctions back to the primary engine ECM using the J1939 data link.

The EGR valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve location can vary, depending on the engine application.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The EGR valve has detected an internal error in the EGR valve smart device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The diagnostic will clear at initial key ON if the malfunction no longer exists. The ECM will turn off the amber CHECK ENGINE light and enable EGR valve operation immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, use the following procedure to calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the EGR valve has detected an internal error. A motor terminal open circuit internal to the EGR valve is a possible cause of this fault code.

Refer to Troubleshooting Fault Code t05-2349.

Last Modified: 01-Mar-2011


EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2351

EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2351 PID: S146 SPN: 2791 FMI: 4/4 LAMP: Amber SRT: | EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source. Motor terminal or motor coil short circuit to ground, or power supply has been detected by the smart EGR controller. | EGR valve actuation will be disabled.
GX CM2250 - EGR Valve Control Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The EGR valve performs its own internal diagnostics and reports malfunctions back to the primary engine ECM using the J1939 data link.

The EGR valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve location can vary, depending on the engine application.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The EGR valve has detected an internal error in the EGR valve smart device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The diagnostic will clear at initial key ON if the malfunction no longer exists. The ECM will turn off the amber CHECK ENGINE light and enable EGR valve operation immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, use the following procedure to calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the EGR valve has detected an internal error. All possible causes listed below are internal to the EGR valve.

Possible causes of this fault code include:

  • Motor terminal short to ground internal to the EGR valve
  • Motor terminal short to battery internal to the EGR valve.
Refer to Troubleshooting Fault Code t05-2351.

Last Modified: 10-Jan-2011


EGR Valve Control Circuit - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 2357

EGR Valve Control Circuit - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2357 PID: S146 SPN: 2791 FMI: 7/7 LAMP: Amber SRT: | EGR Valve Control Circuit - Mechanical System Not Responding Properly or Out of Adjustment. The EGR motor has exceeded the duty cycle limit, indicating a stuck open EGR valve. | EGR valve actuation will be disabled.
GX CM2250 - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The EGR valve performs its own internal diagnostics and reports malfunctions back to the primary engine ECM using the J1939 data link.

The EGR valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve location can vary depending on the engine application.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

This fault code is set when the duty cycle required to open the EGR valve is greater than 95 percent for 3 seconds. The EGR valve controller will try to open the EGR valve again after 10 seconds. The fault code is triggered after three failed attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve will stop responding to commands and the spring will close the EGR valve.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and clear the fault code after the keyswitch is cycled and the diagnostic runs and passes. The fault code will be inactive at key ON. It will only go active if the EGR valve is commanded open and the EGR valve is unable to move to the commanded position.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on Quickserve™ Online for applicable fixes to the calibration stored in the ECM. If necessary, use the following procedure to calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is triggered when the EGR valve motor is unable to move the EGR valve in the open position. This is normally caused by a restriction in the EGR valve not allowing the EGR valve to move to the commanded position.

The fault code will be inactive at key ON. It will only go active if the EGR valve is commanded open and the EGR valve is unable to move to the commanded position.

The ECM calibration contains an automatic EGR valve override test. Thirty seconds after turning the keyswitch ON, the EGR valve all be commanded open to 60 percent and will be held in this position for 1 minute and then it will be commanded to 0 percent open. Turn the keyswitch OFF for 20 seconds and then turn the keyswitch ON and read the fault codes. If Fault Code 1896 is active, this indicates that the EGR valve is stuck in the open position.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the Snap Acceleration Test to check for a damaged diesel particulate filter. Refer to Procedure 014-013 in Section 14.

Refer to Troubleshooting Fault Code t05-2357.

Last Modified: 01-Mar-2011


Westport™ Data Share, Message 8 Fault (Abnormal Update Rate)

FAULT CODE 2361

Westport™ Data Share, Message 8 Fault (Abnormal Update Rate)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2361 PID: SPN: N/A FMI: N/A LAMP: Amber SRT: | Westport™ Data Share, Message 8 Fault (Abnormal Update Rate). The diesel rail pressure message has an abnormal update rate. | None on performance.
GX CM2250 - SAE J1939 Multiplexing Circuit

Circuit Description

The Westport™ engine fuel system CM850 electronic control module (ECM) sends messages to the Cummins® CM2250 ECM through the CEN data link. Message 8 refers to the message that contains the measured diesel rail pressure.

Component Location

The Cummins® CM2250 ECM is located on the left (intake) side of the engine, below the fuel conditioning module. The two Westport™ CM850 controllers are typically mounted above the rear of the valve cover, in the engine compartment.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The CM2250 does not receive a valid Westport™ Data Share message for more than 100 milliseconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Possible causes of this fault code includes:

  • Open or short circuit in the Westport™ converter harness.
  • The Westport™ engine fuel system CM850 controller is not connected.
  • Open or short circuit in the Cummins® Engine Network (CEN).
  • Malfunctioning Westport™ CM850 controller.

This fault code can appear in conjunction with Fault Codes 2771 and 3597.

Refer to Troubleshooting Fault Code t05-2361.

Last Modified: 11-Mar-2011


Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2373

Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2373 PID: P131 SPN: 1209 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas pressure circuit. | None on performance.
GX CM2250 - Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the electronic control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust gas pressure signal voltage is greater than 4.75-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open return circuit in the engine harness, connectors, or sensor
  • A signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-2373.

Last Modified: 10-Dec-2010


Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2374

Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2374 PID: P131 SPN: 1209 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas pressure circuit. | None on performance.
GX CM2250 - Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the electronic control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust gas pressure signal voltage is less than 0.25-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-2374.

Last Modified: 10-Dec-2010


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2375

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2375 PID: P412 SPN: 412 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at EGR temperature circuit. | EGR valve actuation will be disabled.
GX CM2250 - Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor that is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The ECM supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR gas flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature signal voltage is greater than 4.9-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas recirculation temperature reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • An open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-2375.

Last Modified: 30-Nov-2010


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2376

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2376 PID: P412 SPN: 412 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at EGR temperature circuit. | EGR valve actuation will be disabled.
GX CM2250 - Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor that is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The ECM supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR gas flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature signal voltage is less than 0.05-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas recirculation temperature reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • A signal shorted to ground in the harness
  • A signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-2376.

Last Modified: 30-Nov-2010


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S033 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Fan Control Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
GX CM2250 - Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the electronic control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or a return that goes to the engine block or chassis ground.

Component Location

The fan clutch solenoid location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned OFF and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The fan control circuit PWM signal is detected to be greater than 0-VDC when the PWM signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes. For ON/OFF and variable speed fans, the diagnostic runs when the fan is turned OFF. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If Fault Code 2377 is still active after completing all the steps in this fault code troubleshooting tree, consult the OEM service manual for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault include:

  • An open circuit in the engine harness or fan control solenoid
  • A short circuit to voltage source in the OEM harness
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2377.

Last Modified: 30-Nov-2010


Variable Geometry Turbocharger (VGT) Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2387

Variable Geometry Turbocharger (VGT) Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2387 PID: S027 SPN: 641 FMI: 7/7 LAMP: Amber SRT: | VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment. The smart VGT controller has detected incorrect stop limits, or the VGT is unable to move to the closed position. | VGT travel may be limited.
GX CM2250 - VGT Actuator Driver Circuit

Circuit Description

The VGT is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary ECM with the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

The keyswitch must be in the ON position, and the engine coolant temperature must be above 60°C [140°F] before the diagnostic will run.

Conditions for Setting the Fault Codes

This fault code will set when the actual VGT actuator position can not meet the commanded position for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.
  • The VGT actuator will continue to attempt to meet commanded position, even when the CHECK ENGINE lamp is on.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 1 minute. Make sure the engine coolant temperature is above 60°C [ 140°F]. Operate the engine if necessary.
  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer Test, utilize a routine that incorporates acceleration and motoring events, steady state highway operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes. If the fault code does not go inactive after key ON, it may be necessary to drive the vehicle for at least 5 continuous minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Large boost pressure leaks can also cause this fault code.

The aftertreatment system must be inspected for potential damage after making the appropriate repair outlined in the fault code troubleshooting tree. Progressive damage to the aftertreatment system can possibly have occurred.

Inspect the turbocharger vanes for residue, and clean the vanes, if required. Find the source of the residue and repair.

Refer to Troubleshooting Fault Code t05-2387.

Last Modified: 14-Nov-2014


Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2398

Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2398 PID: SPN: 171 FMI: 2 LAMP: Amber SRT: | Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect. The ambient air temperature sensor is reading an erratic value. | The ECM will estimate the ambient air temperature.
GX CM2250 - Ambient Air Temperature Sensor 1 Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The electronic control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The electronic control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of 10 hours before this part of the diagnostic will run.

The second part runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the ambient air temperature reading is higher or lower than the other temperature sensors on the engine after an extended period of engine off time, or the ambient air temperature is not changing over time.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails. A default value for the ambient air temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute. If the fault code does not go inactive, it may be necessary to perform a 10 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range ambient air temperature sensor
  • High resistance in the ambient air temperature sensor signal or return lines
  • ECM malfunction.
Refer to Troubleshooting Fault Code t05-2398.

Last Modified: 30-Nov-2010


Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: P2560 SPN: 111 FMI: 17 LAMP: Maintenance SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level. Low engine coolant level detected. | None on performance.
GX CM2250 - Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch that is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in the coolant versus being out of the coolant. The electronic control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level sensor signal voltage is between 1.75-VDC and 3-VDC for more than 30 seconds, indicating low coolant level.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE light at initial key ON for 30 seconds when low engine coolant level has been detected.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber MAINTENANCE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code t05-2448.

Last Modified: 18-Jan-2011


VGT Actuator Controller - Out of Calibration

FAULT CODE 2449

VGT Actuator Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2449 PID: S027 SPN: 641 FMI: 13 LAMP: Red SRT: | VGT Actuator Controller - Out of Calibration. The VGT actuator has been installed incorrectly. | VGT actuation will be disabled.
GX CM2250 - VGT Actuator Controller Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronic activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM, using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic can run at initial key ON.

Conditions for Setting the Fault Codes

The internal position reference is not detected during the initial power ON due to incorrect installation of the VGT actuator. The actual VGT actuator position is not known.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the keyswitch in the ON position for 1 minute. Note that the keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

This fault code can only be logged after the VGT actuator has been removed or replaced, and then not installed correctly. The gear alignment between the actuator and the turbocharger housing is misaligned. The correct installation procedure must be followed when replacing the VGT actuator.

Refer to Troubleshooting Fault Code 2449.

Last Modified: 14-Nov-2014


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2468

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2468 PID: P190 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine speed has exceeded a critical limit. | Engine will be shut down if equipped with an intake air shutoff valve.
GX CM2250 - Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The air shutoff valve is an OEM-installed component that shuts off the flow of air into the intake of the engine in order to prevent an engine overspeed condition. When activated, the electronic control module (ECM) supplies 12-VDC to the air shutoff solenoid. This solenoid then supplies air to the air shutoff valve and activates the valve, closing a plate over the intake.

Component Location

The air shutoff valve is an OEM-installed component, and is usually located on the air intake connection. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that engine speed was greater than 2500 RPM for 0.25 seconds, or the operator manually tripped the engine air shutoff valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamps immediately when the diagnostic runs and fails.
  • The air shutoff valve closes.
  • Engine fueling is set to zero.
  • The engine starter will be locked out.

Conditions for Clearing the Fault Code

  • To validate the repair, the air shutoff valve must be manually reset to the open position. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine has been shut down via the engine air shutoff valve. This can occur automatically (engine overspeed condition) or manually (activating the engine air shutoff valve switch in the cab). In either case, this fault code will become active until the valve is de-activated.

Refer to Troubleshooting Fault Code t05-2468.

Last Modified: 01-Dec-2010


Exhaust Gas Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2554

Exhaust Gas Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2554 PID: P131 SPN: 1209 FMI: 2 LAMP: Amber SRT: | Exhaust Gas Pressure - Data Erratic, Intermittent, or Incorrect. The exhaust gas pressure sensor is reading an erratic value. | The ECM will estimate the exhaust gas pressure.
GX CM2250 - Exhaust Gas Pressure Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the electronic control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70°C [158°F].
  • The second part runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

  • The ECM detects that the exhaust pressure reading is higher or lower than the other absolute pressure sensors, when the keyswitch is OFF and the engine is not running.
  • The fault code can also be set if the ECM detects that the exhaust pressure is higher or lower than expected during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will estimate the exhaust gas pressure reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, make sure the engine coolant temperature is above 70°C [158°F]. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and let it high idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range exhaust gas pressure sensor reading
  • High resistance in the exhaust gas pressure sensor signal or return lines
  • Plugging or restriction in the exhaust gas pressure sensor tube
  • Leaks in the exhaust system
  • In-range malfunction of the intake manifold temperature sensor, EGR differential pressure sensor, or intake manifold temperature sensor.
Refer to Troubleshooting Fault Code t05-2554.

Last Modified: 10-Dec-2010


VGT Actuator Controller - Bad Intelligent Device or Component

FAULT CODE 2634

VGT Actuator Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2634 PID: S027 SPN: 641 FMI: 12/12 LAMP: Red SRT: | VGT Actuator Controller - Bad Intelligent Device or Component. An internal error has been detected by the smart VGT controller. | VGT actuation will be disabled.
GX CM2250 - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The VGT actuator has detected an internal error in the VGT smart device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the VGT smart actuator detected an internal error within the VGT actuator. The VGT actuator will stop controlling the turbocharger when this fault code is active.

Fault Code 2634 will become active if the VGT actuator is removed from the turbocharger and then the keyswitch is turned to the ON position; or it may be possible for it to become active if the actuator fails the install/calibrate procedure. If this occurs, disconnect the VGT actuator from the engine harness with the keyswitch ON, and connect the VGT actuator to the engine harness. Fault Code 2634 should go inactive. Follow the VGT actuator installation procedure to install the VGT actuator.

Refer to Troubleshooting Fault Code t05-2634.

Last Modified: 14-Nov-2014


VGT Actuator Driver Circuit - Condition Exists

FAULT CODE 2635

VGT Actuator Driver Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2635 PID: SPN: 641 FMI: 31 LAMP: Red SRT: | VGT Actuator Driver Circuit - Condition Exists. A calibration mismatch between the variable geometry turbocharger (VGT) actuator and the ECM has been detected. | VGT actuation will be disabled.
GX CM2250 - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code can be activated for the following reasons:

  • The ECM has detected a calibration incompatibility between the VGT actuator and the ECM calibration.
  • The VGT actuator has detected that the system voltage is incorrect for the installed VGT actuator part number.
  • The ECM has detected an incorrect VGT actuator installed on the turbocharger.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the ECM has detected that an incorrect VGT actuator has been installed on the turbocharger.

Refer to Troubleshooting Fault Code 2635.

Last Modified: 14-Nov-2014


VGT Actuator Driver Circuit - Abnormal Update Rate

FAULT CODE 2636

VGT Actuator Driver Circuit - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2636 PID: S027 SPN: 641 FMI: 9/9 LAMP: Red SRT: | VGT Actuator Driver Circuit - Abnormal Update Rate. No communications on the J1939 data link between the engine control module (ECM) and the smart variable geometry turbocharger (VGT) controller. | The VGT will move to the default open position.
GX CM2250 - VGT Actuator Circuit

Circuit Description

The VGT is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary ECM. The VGT actuator performs its own diagnostics and reports malfunctions back to the primary ECM, using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The primary engine ECM does not receive a valid J1939 message from the VGT actuator for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The VGT will move to the default open position.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Troubleshoot high inactive counts of Fault Code 2636 as an active fault code.

Possible causes of this fault code include:

  • The VGT actuator is not receiving power from the ECM. This can be caused by an open circuit in the power supply wire or low voltage supplied by the primary engine ECM.
  • Rapid cycling of the keyswitch
  • An open return circuit on the VGT actuator circuit
  • An open or short circuit on the J1939 data link circuit between the ECM and VGT actuator
  • Intermittent communications between the VGT actuator and the primary engine ECM on the J1939 data link
  • A damaged termination resistor in the engine data link harness
  • A malfunctioning engine ECM.
Refer to Troubleshooting Fault Code t05-2636.

Last Modified: 14-Nov-2014


Aftertreatment Diesel Oxidation Catalyst Face Plugged - Root Cause Not Known

FAULT CODE 2637

Aftertreatment Diesel Oxidation Catalyst Face Plugged - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2637 PID: S380 SPN: 5018 FMI: 11 LAMP: None SRT: | Aftertreatment Diesel Oxidation Catalyst Face Plugged - Root Cause Not Known. The front face of the aftertreatment diesel oxidation catalyst has been detected to be plugged with soot. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Oxidation Catalyst

Circuit Description

This fault code is set when the intake face of the diesel oxidation catalyst is detected to be plugged with soot.

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and an active regeneration of the aftertreatment is occurring.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the intake face of the diesel oxidation catalyst is plugged with soot.

Action Taken When the Fault Code is Active

  • The fault code is logged immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • This is a no lamp fault code. The fault code will be set to inactive after performing INSITE™ electronic service tool Diesel Oxidation Catalyst Maintenance Reset procedure, found under the Aftertreatment Maintenance section of Advanced ECM Data, or when the conditions for diesel oxidation catalyst face plugging are no longer occurring.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is set when the inlet face of the diesel oxidation catalyst is detected to be plugged with soot.

Possible causes of this fault code include:

  • Engine oil or fuel plugging the front face of the aftertreatment diesel oxidation catalyst.
Refer to Troubleshooting Fault Code t05-2637bcl.

Last Modified: 04-Oct-2013


Aftertreatment Diesel Oxidation Catalyst (DOC) Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2638

Aftertreatment Diesel Oxidation Catalyst (DOC) Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2638 PID: S380 SPN: 5298 FMI: 17 LAMP: None SRT: | Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level. The temperature increase across the aftertreatment diesel oxidation catalyst (DOC) is lower than expected. | Active aftertreatment diesel particulate filter (DPF) regeneration will be disabled
GX CM2250 - Aftertreatment Diesel Oxidation Catalyst (DOC) Conversion Efficiency Circuit

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment DOC intake temperature sensor is located after the turbocharger outlet, at the intake of the aftertreatment system. The aftertreatment DPF intake temperature sensor is located between the aftertreatment DOC and the aftertreatment DPF. The aftertreatment DPF outlet temperature sensor is located after the aftertreatment DPF. The temperature sensors around the aftertreatment DOC are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment DOC is located in the exhaust system. The location of the catalyst can vary, depending on the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

  • Active regeneration of the aftertreatment DPF must be occurring before the diagnostic will run.

Conditions for Setting the Fault Codes

The ECM detects that the temperature differential across the aftertreatment DOC during active regeneration is not matching the expected temperature increase.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails on two consecutive trips.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • The fault code will be set to inactive after performing INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter (DPF) regeneration test, and the DOC efficiency is determined to be above a calibratible threshold.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the malfunction indicator lamp (MIL) for On-Board Diagnostics (OBD) applications

Shop Talk

Possible causes of this fault code include:

  • Soot plugging the front face of the aftertreatment DOC
  • Engine oil or fuel contamination of the aftertreatment DOC
  • Cracked or contaminated aftertreatment DOC
  • Damage in the aftertreatment fuel injection system
  • Leaking exhaust system between the turbocharger and the DOC
  • An in-range malfunction of the aftertreatment DOC or the aftertreatment DPF inlet temperature sensor.

Make sure there are not any fault codes related to the aftertreatment temperature sensors before following this troubleshooting tree.

Refer to Troubleshooting Fault Code t05-2638bcl.

Last Modified: 04-Oct-2013


Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2639

Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2639 PID: S324 SPN: 3251 FMI: 0/15 LAMP: None SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | The aftertreatment diesel particulate filter lamp will be illuminated and will begin to flash as the severity of the soot load increases. Possible engine protection derate based on severity.
GX CM2250 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code can be triggered if the application is not operating at a duty cycle high enough to regenerate the aftertreatment diesel particulate filter. This fault code indicates that the exhaust temperatures exiting the turbocharger are not high enough to actively regenerate the soot that is trapped in the aftertreatment diesel particulate filter. It may be necessary to increase the duty cycle of the application in order to prevent plugging of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the soot load of the aftertreatment diesel particulate filter has reached the first stage of plugging.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the aftertreatment diesel particulate filter lamp immediately after the diagnostic is set.
  • The ECM will flash the aftertreatment dash lamp as the severity of the soot load increases.
  • Torque output of the engine will be reduced as the soot load in the aftertreatment diesel particulate filter increases.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the soot load in the aftertreatment diesel particulate filter has dropped below the least severe level and the diagnostic runs and passes.
  • The ECM will turn off the aftertreatment diesel particulate filter lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the aftertreatment diesel particulate filter requires maintenance by performing a stationary regeneration procedure. This is a maintenance procedure only and is not covered by Cummins Inc. warranty.

Possible causes of this fault code include:

  • The engine has been operating in light load operating conditions that prevent exhaust temperatures from being high enough to regenerate the aftertreatment diesel particulate filter
  • Possible engine damage that causes excessive black smoke to be generated.

The aftertreatment diesel particulate filter soot loading can be classified into four different stages. As the soot load increases, the AFTERTREATMENT lamp and the Cummins® CHECK ENGINE (Amber) or STOP ENGINE (Red) lamp will operate according to the table below. The stationary regeneration procedure can be used to clear the soot from the aftertreatment diesel particulate filter in stages 1, 2, and 3. At stage 4, the aftertreatment diesel particulate filter is completely plugged and must be replaced. Inadequate exhaust temperatures entering the aftertreatment system can be a cause of high soot loads in the aftertreatment diesel particulate filter. The duty cycle of the application may need to be increased in order to prevent excessive soot from accumulating in the filter.

Soot Level Stage | Cummins® Fault Code | Aftertreatment Diesel Particulate Filter Lamp Status | Cummins® Lamp Status | Service Procedure | Engine Protection Strategy
1 | 2639 | Solid | Off | Perform stationary regeneration procedure | No engine protection derate
2 | 2639 | Flashing | Off | Perform stationary regeneration procedure | Mild engine torque derate
3 | 1921 | Flashing | Amber | Perform stationary regeneration procedure | Moderate engine torque and engine speed derate
4 | 1922 | Off | Red | Inspect and clean or replace aftertreatment diesel particulate filter | Severe engine torque and engine speed derate
Refer to Troubleshooting Fault Code t05-2639.

Last Modified: 30-Nov-2010


Engine Coolant Temperature - Condition Exists

FAULT CODE 2646

Engine Coolant Temperature - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2646 PID: P110 SPN: 110 FMI: 31 LAMP: Amber SRT: | Engine Coolant Temperature - Condition Exists. The exhast gas recirculation (EGR) valve was closed to reduce engine coolant temperature. | EGR valve actuation will be disabled.
GX CM2250 - Engine Coolant Temperature Circuit

Circuit Description

When the engine coolant temperature nears the engine protection limits, the EGR valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The fault code is set active when the EGR valve is closed to reduce engine coolant temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

When the engine coolant temperature nears the engine protection limits, the EGR valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed. No malfunction has occurred to cause this fault code. Other engine protection fault codes will be active if the engine coolant temperature has exceeded the engine protection limits.

Refer to Troubleshooting Fault Code t05-2646.

Last Modified: 30-Nov-2010


Engine Coolant Temperature - Condition Exists

FAULT CODE 2659

Engine Coolant Temperature - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2659 PID: P110 SPN: 110 FMI: 31 LAMP: None SRT: | Engine Coolant Temperature - Condition Exists. The EGR valve was closed to reduce engine coolant temperature. | EGR valve actuation will be disabled.
GX CM2250 - Engine Coolant Temperature Circuit

Circuit Description

When the engine coolant temperature nears the engine protection limits, the exhaust gas recirculation (EGR) valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The fault code is set active when the EGR valve is closed, to reduce engine coolant temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the engine coolant temperature nears the engine protection limits, the EGR valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed. No malfunction has occurred to cause this fault code. Other engine protection fault codes will be active if the engine coolant temperature has exceeded the engine protection limits.

Refer to Troubleshooting Fault Code t05-2659.

Last Modified: 10-Dec-2010


Aftertreatment Fuel Drain Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2732

Aftertreatment Fuel Drain Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2732 PID: S338 SPN: 4097 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Fuel Drain Valve Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment fuel drain valve circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Fuel Drain Valve Circuit

Circuit Description

The aftertreatment fuel drain valve is used to relieve the fuel pressure between the aftertreatment fuel shutoff valve 1 and the aftertreatment fuel injector.

Component Location

The aftertreatment fuel drain valve is located in the aftertreatment drain valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs within the first 30 seconds of the engine starting and prior to active regenerations of the diesel particulate filter.

Conditions for Setting the Fault Codes

The aftertreatment fuel drain valve circuit pulse width modulated (PWM) signal is detected to be at system voltage when the PWM voltage is turned off.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The fault code will clear within 30 seconds of starting the engine or prior to an active regeneration event of the diesel particulate filter.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or drain valve
  • Fuel drain valve signal wire shorted to a voltage source in the harness
  • A damaged aftertreatment fuel drain valve.
Refer to Troubleshooting Fault Code t05-2732.

Last Modified: 07-Jan-2011


Aftertreatment Fuel Drain Valve Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2733

Aftertreatment Fuel Drain Valve Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2733 PID: S338 SPN: 4097 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Fuel Drain Valve Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment fuel drain valve circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Fuel Drain Valve Circuit

Circuit Description

The aftertreatment fuel drain valve is used to disable the fuel supply to the aftertreatment system.

Component Location

The aftertreatment fuel drain valve sensor is located in the aftertreatment shutoff valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs within the first 30 seconds of the engine starting and prior to active regenerations of the diesel particulate filter.

Conditions for Setting the Fault Codes

The aftertreatment fuel drain valve circuit pulse width modulated (PWM) signal is detected to be at 0-VDC when the PWM voltage is turned on.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The fault code will clear within 30 seconds of starting the engine or prior to an active regeneration event of the diesel particulate filter.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or shutoff valve
  • A shorted aftertreatment fuel drain valve.
Refer to Troubleshooting Fault Code t05-2733.

Last Modified: 07-Jan-2011


Start Enable Device 1 Circuit (Ether Injection) - Voltage Above Normal or Shorted to High Source

FAULT CODE 2738

Start Enable Device 1 Circuit (Ether Injection) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2738 PID: S237 SPN: 626 FMI: 3/3 LAMP: Amber SRT: | Start Enable Device 1 Circuit (Ether Injection) - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the ether start solenoid circuit. | Ether start functionality will be disabled.
GX CM2250 - Ether Injection Start Circuit

Circuit Description

The ether injection circuit is a device used by the engine to control the ether injection operation. The ether injection circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The ether injection solenoid location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is activated. In some cases, the diagnostic can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The ether injection circuit PWM signal is detected to be greater than 0-VDC when the PWM signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ether injection operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • An open circuit in the engine harness or ether injection solenoid
  • A short circuit to voltage source in the OEM harness
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2738.

Last Modified: 10-Dec-2010


Start Enable Device 1 Circuit (Ether Injection) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2739

Start Enable Device 1 Circuit (Ether Injection) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2739 PID: S237 SPN: 626 FMI: 4/4 LAMP: Amber SRT: | Start Enable Device 1 Circuit (Ether Injection) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the ether start solenoid circuit. | Ether start functionality will be disabled.
GX CM2250 - Ether Injection Circuit

Circuit Description

The ether injection circuit is a device used by the engine to control the ether injection operation. The ether injection circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The control solenoid location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The ether injection circuit PWM signal is not detected to be system voltage when the PWM signal is turned ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ether injection operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is logged when the ECM commands 12-VDC to the ether injection solenoid, but the voltage on the ether injection signal circuit is less than 12-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

Refer to Troubleshooting Fault Code t05-2739.

Last Modified: 10-Dec-2010


Engine Diesel Particulate Filter Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2754

Engine Diesel Particulate Filter Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2754 PID: P081 SPN: 81 FMI: 16 LAMP: Amber SRT: | Engine Diesel Particulate Filter Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. Excessive black smoke has been detected exiting the engine and entering the aftertreatment diesel particulate filter. | None on performance
GX CM2250 - Engine Diesel Particulate Filter

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can become necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code is logged when the sensors in the aftertreatment system indicate soot accumulation inside the diesel particulate filter is happening at a higher rate than under normal conditions. This indicates that the smoke (soot) being produced by the engine is higher than normal.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

This fault code is logged when the soot accumulation inside the diesel particulate filter is happening at a higher rate than under normal conditions.

Action Taken When the Fault Code is Active

  • The fault code is active immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The electronic control module (ECM) will disable the fault code immediately after the diagnostic runs and passes or after a keyswitch cycle.

Shop Talk

Possible causes of this fault code include:

  • Boost leaks in the charge-air cooler plumbing
  • A malfunction of the variable geometry turbocharger (VGT)
  • A malfunction of the exhaust gas recirculation (EGR) valve
  • A malfunctioning in-range EGR differential pressure sensor
  • A malfunctioning in-range boost pressure sensor
  • A malfunctioning in-range barometric pressure sensor
  • A cylinder misfire or overfueling.
Refer to Troubleshooting Fault Code t05-2754x.

Last Modified: 28-Oct-2014


Exhaust Gas Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2764

Exhaust Gas Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2764 PID: P131 SPN: 1209 FMI: 16 LAMP: Amber SRT: | Exhaust Gas Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. High exhaust gas pressure has been detected by the exhaust gas pressure sensor. | Fueling derate to bring exhaust gas pressure below the maximum operating limits.
GX CM2250 - Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the electronic control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation, if equipped. The ECM provides a 5-VDC supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

This fault code is logged when the exhaust gas pressure sensor is reading a value above the engine protection limits.

Action Taken When the Fault Code is Active

An engine derate will be activated to bring exhaust gas pressure below the maximum operating limits.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning variable geometry turbocharger
  • A damaged in-range exhaust gas pressure sensor
  • A plugged or restricted aftertreatment diesel particulate filter
  • A plugged or restricted EGR cooler.
Refer to Troubleshooting Fault Code t05-2764.

Last Modified: 10-Dec-2010


Aftertreatment Outlet NOx Sensor - Abnormal Update Rate

FAULT CODE 2771

Aftertreatment Outlet NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2771 PID: SPN: 3226 FMI: 9 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Abnormal Update Rate. No communications or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor operation will be disabled.
GX CM2250 - Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device that communicates with the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system, at the outlet of the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM loses J1939 communications with the aftertreatment outlet NOx sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 5 miles per hour after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment outlet NOx sensor is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, blown NOx sensor fuse, or low voltage supplied by the battery.
  • Open return circuit on the aftertreatment outlet NOx sensor battery return.
  • Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment outlet NOx sensor.
  • Intermittent communications between the aftertreatment outlet NOx sensor and the primary engine ECM on the J1939 data link.
  • A damaged engine ECM.
Refer to Troubleshooting Fault Code t05-2771.

Last Modified: 10-Dec-2010


Particulate Trap Active Regeneration Inhibited Due to Inhibit Switch - Condition Exists

FAULT CODE 2777

Particulate Trap Active Regeneration Inhibited Due to Inhibit Switch - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2777 PID: S390 SPN: 3703 FMI: 11/31 LAMP: None SRT: | Particulate Trap Active Regeneration Inhibited Due to Inhibit Switch - Condition Exists. Regeneration of the diesel particulate filter has been prevented due to the permit switch being disabled. | None on performance.
GX CM2250 - Aftertreatment System

Circuit Description

The OEM truck manufacturer can install a permit switch in the dash or send an inhibit message via the J1939 data link to the engine ECM. The function of the inhibit message is to prevent the aftertreatment system from performing mobile regenerations. The purpose of this fault code is to inform the technician that the permit switch was disabled when Fault Code 1921, 1922, or 2639 was set active or when the system was requesting an active regeneration of the aftertreatment system. This fault code can indicate the reason that high aftertreatment soot load fault codes are logged.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the OEM. The permit switch can be an actual switch in the vehicle dash or it can be a J1939 message sent via the J1939 data link. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered if the permit switch is disabled when Fault Code 1921, 1922, or 2639 is activated for high soot load levels in the diesel particulate filter, or when the ECM is requesting active regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute with the permit switch enabled.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If this fault code is active and there has been damage to the aftertreatment system, the permit switch can possibly have prevented the aftertreatment system from performing a mobile (active) regeneration.

Consult with the OEM if the aftertreatment system has malfunctioned due to the permit switch.

Refer to Troubleshooting Fault Code t05-2777.

Last Modified: 10-Dec-2010


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2789

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2789 PID: P110 SPN: 110 FMI: 18 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine coolant temperature is below normal operating temperature limits. | None on performance.
GX CM2250 - Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and emissions control.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

Engine coolant temperature has been below 60°C [140°F] for over 1 hour during a period of extended idle.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If this fault indicates that coolant temperature is below a calibratible limit set in the ECM.

  • Refer to Engine Coolant Temperature Below Normal troubleshooting symptom tree in the base engine service manual.
Refer to Troubleshooting Fault Code t05-2789.

Last Modified: 18-Jan-2011


Aftertreatment Fuel Drain Valve - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 2878

Aftertreatment Fuel Drain Valve - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2878 PID: 381 SPN: 4097 FMI: 7 LAMP: Amber SRT: | Aftertreatment Fuel Drain Valve - Mechanical System Not Responding Properly or Out of Adjustment. The aftertreatment fuel shutoff drain valve has been detected to be stuck closed. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Fuel Injector System

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system, as well as malfunctions of the aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started, a diagnostic test on the system is performed. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel injector then briefly opens and relieves some of the fuel pressure trapped between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs:

  • During the first 5 minutes of engine operation.
  • Prior to injecting fuel for an active regeneration, but only if more than 2 hours have elapsed since the previous regeneration event or key ON.
  • After an active regeneration.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects a stuck closed aftertreatment fuel drain valve.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Clear the fault code by starting and idling the engine for 5 minutes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Stuck closed aftertreatment fuel drain valve
  • Restricted aftertreatment fuel drain line
  • Plugged fuel filter.
Refer to Troubleshooting Fault Code t05-2878

Last Modified: 07-Jan-2011


Aftertreatment Fuel Pressure Sensor - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2881

Aftertreatment Fuel Pressure Sensor - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2881 PID: S332 SPN: 3480 FMI: 17 LAMP: None SRT: | Aftertreatment Fuel Pressure Sensor - Data Valid But Below Normal Operating Range - Least Severe Level. Low fuel pressure has been detected in the aftertreatment fuel system. | None on performance.
GX CM2250 - Aftertreatment Fuel Injector System

Circuit Description

The aftertreatment fuel pressure sensor is used to monitor the fuel pressure into the aftertreatment system. The electronic control module (ECM) supplies the aftertreatment fuel pressure sensor a 5 volt reference voltage.

Component Location

The aftertreatment fuel pressure sensor is located in the aftertreatment fuel shutoff manifold.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The aftertreatment fuel pressure is less than 300 kPa [43.5 psi] for more than 15 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled until the next key cycle.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test. Once the temperatures in the aftertreatment system are high enough to inject diesel fuel into the exhaust, the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Plugged or restricted aftertreatment fuel supply line
  • Plugged or restricted aftertreatment fuel shutoff manifold
  • Plugged or restricted pressure side fuel filter
  • Malfunctioning fuel pump gear pump.
Refer to Troubleshooting Fault Code t05-2881.

Last Modified: 18-Jan-2011


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2961

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2961 PID: P412 SPN: 412 FMI: 15 LAMP: None SRT: | Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. EGR temperature has exceeded the engine protection limit. | Slight fueling derate to bring EGR temperature under the maximum limit.
GX CM2250 - Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistance sensor that is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The electronic control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR valve and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature is greater than 274°C [525°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The engine torque will be derated up to 40 percent to limit the EGR temperature.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the EGR temperature falls below 210°C [410°F] and the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Plugged or restricted EGR differential pressure sensor ports
  • Damaged EGR differential pressure tubes
  • A malfunctioning EGR valve
  • A stuck open turbocharger control valve
  • A low reading from the EGR differential pressure sensor
  • A low reading for the EGR valve position sensor
  • High exhaust temperatures
  • Low coolant level
  • High coolant temperature
  • An incorrect coolant/water mixture
  • A stuck closed variable geometry turbocharger
  • A fouled EGR cooler.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code t05-2961.

Last Modified: 18-Jan-2011


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2962

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2962 PID: P412 SPN: 412 FMI: 16 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. EGR temperature has exceeded the engine protection limit. | Severe fueling derate to bring EGR temperature under the maximum limit.
GX CM2250 - Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistance sensor that is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The electronic control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR valve and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature is greater than 293°C [560°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine torque will be derated up to 40 percent to limit the EGR temperature.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the EGR temperature falls below 250°C [482°F] and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A fouled EGR cooler
  • Plugged or restricted EGR differential pressure sensor ports
  • A damaged EGR valve
  • A stuck open turbocharger control valve
  • A low reading from the EGR differential pressure sensor
  • A low reading for the EGR valve position sensor
  • High exhaust temperatures
  • Low coolant level
  • High coolant temperature
  • An incorrect coolant/water mixture
  • A stuck closed variable geometry turbocharger.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code t05-2962.

Last Modified: 18-Jan-2011


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. Engine coolant temperature is above the engine protection warning limit. | Power derate and possible engine shutdown if the engine protection shutdown feature is enabled.
GX CM2250 - Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 VDC to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature..

The engine coolant temperature value is used by the ECM for the engine protection system and for engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than 107°C [225°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE and the torque derate will be removed immediately after the engine coolant temperature falls below 107°C [225°F] and the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the base engine service manual.

Refer to Troubleshooting Fault Code t05-2963.

Last Modified: 18-Jan-2011


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2964

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
GX CM2250 - Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistance sensor that is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the ECM for the engine protection system and engine emissions control.

The electronic control module (ECM) supplies 5-VDC to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The intake manifold 1 temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature is greater than 120°C [248°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE and the torque derate will be removed immediately after the intake manifold temperature falls below 120°C [248°F] and the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Plugged charge-air cooler fins
  • Restricted airflow through the charge-air cooler
  • An undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-2964.

Last Modified: 18-Jan-2011


Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect. The intake manifold pressure sensor is reading an erratic value. | The ECM will estimate the intake manifold pressure. Possible engine power derate.
GX CM2250 - Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70°C [158°F].
  • The other part runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

If the value of the intake manifold pressure is not reading ambient pressure immediately after key OFF, or is higher or lower than expected during normal engine operation, this fault code is logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM estimates the value of the intake manifold pressure reading
  • Diesel exhaust fluid injection into the aftertreatment system is disabled
  • Active and stationary regeneration of the diesel particulate filter will be disabled
  • The exhaust gas recirculation (EGR) valve will be closed
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, first make sure the engine coolant temperature is above 70°C [ 158°F]. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This diagnostic consists of two parts. At key OFF, the sensor readings for intake manifold pressure, barometric air pressure, oil pressure (if available), and exhaust gas pressure are compared to each other. This fault code occurs if the intake manifold pressure sensor reading is different from the other sensor readings. This check is only done once after the keyswitch is turned OFF. This fault can also be set active when the intake manifold pressure is too high or low for the current engine operating conditions when the engine is running. The ECM compares the intake manifold pressure reading to turbocharger speed to determine if the pressure reading is valid.

Possible causes of this fault are:

  • A damaged intake manifold pressure sensor
  • A damaged barometric pressure sensor
  • Leaks in the air intake system between the turbocharger and intake manifold
  • Restriction in the charge-air cooler
  • A damaged turbocharger speed sensor
  • A damaged turbocharger compressor intake temperature sensor.
Refer to Troubleshooting Fault Code t05-2973.

Last Modified: 10-Dec-2010


Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2976

Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2976 PID: SPN: 3361 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect. An internal error has been detected in the aftertreatment diesel exhaust fluid dosing unit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit reports its internal temperature to the diesel exhaust fluid controller via the dosing unit signal wire, and the diesel exhaust fluid controller communicates this information to the primary engine electronic control module (ECM) via the J1939 data link network.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM service manual for component location information.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned to the ON position, and continues until the diesel exhaust fluid dosing unit attempts to prime.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit internal temperature was not communicated to the ECM by the diesel exhaust fluid controller, or the dosing unit temperature reading is erratic.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails for two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Then start the engine and let it idle for up to 10 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning dosing unit
  • Short circuit to ground in the aftertreatment diesel exhaust fluid dosing unit signal / dosing unit temperature wire.
Refer to Troubleshooting Fault Code t05-2976.

Last Modified: 10-Dec-2010


Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 3133

Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3133 PID: SPN: 3610 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel particulate filter outlet pressure sensor circuit. | Active and stationary regeneration of the diesel particulate filter will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter outlet pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter outlet pressure signal voltage is greater than 4.75-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-3133.

Last Modified: 10-Dec-2010


Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 3134

Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3134 PID: SPN: 3610 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel particulate filter outlet pressure sensor circuit. | Active and stationary regeneration of the diesel particulate filter will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter outlet pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter outlet pressure signal voltage is less than 0.25-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-3134.

Last Modified: 10-Dec-2010


Aftertreatment Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent or Incorrect

FAULT CODE 3135

Aftertreatment Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3135 PID: SPN: 3610 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent or Incorrect. The aftertreatment diesel particulate filter outlet pressure sensor is reading an erratic value at initial key ON or during engine operation. | Active and stationary regeneration of the diesel particulate filter will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter outlet pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the OEM service manual for exact location of the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • One part runs when the keyswitch is initially turned ON before the engine is started.
  • The other part runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter outlet pressure is greater than 1.5 kpa [0.22 psi] or less than -1.5 kpa [-0.22 psi] at initial key ON, or is not changing with engine conditions

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, key ON for 1 minute, and then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter outlet pressure sensor reading
  • High resistance in the aftertreatment diesel particulate filter outlet pressure sensor signal or return wires
  • Higher than expected diesel particulate filter outlet pressure
  • Excessive diesel exhaust fluid (DEF) deposits in the aftertreatment decomposition tube
  • Plugged aftertreatment outlet pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned OFF.

Note: It is possible to set this fault in a shop environment by performing a key cycle with the tailpipe connected to an exhaust ventilation system.

Refer to Troubleshooting Fault Code t05-3135.

Last Modified: 01-Dec-2010


Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3139

Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3139 PID: SPN: 3667 FMI: 3/3 LAMP: Amber SRT: | Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the air shutoff circuit. | The engine air shutoff valve will be disabled.
GX CM2250 - Engine Air Shutoff Circuit

Circuit Description

The engine air shutoff valve is an OEM installed device used to shut off air flow to the engine intake. Refer to the OEM service manual.

Component Location

The engine air shutoff valve location can vary, depending on the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine air shutoff driver is shorted to voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open engine air shutoff circuit
  • Short circuit to voltage in the engine air shutoff circuit
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-3139.

Last Modified: 10-Dec-2010


Engine Air Shutoff Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3141

Engine Air Shutoff Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3141 PID: P102 SPN: 3667 FMI: 4/4 LAMP: Amber SRT: | Engine Air Shutoff Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine air shutoff circuit. | The engine air shutoff valve will be disabled.
GX CM2250 - Engine Air Shutoff Sensor Circuit

Circuit Description

The engine air shutoff valve is an OEM installed device used to shut off air flow to the engine intake. Refer to the OEM service manual.

Component Location

The engine air shutoff valve location can vary, depending on the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine air shut off driver is shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short circuit to ground in the engine air shutoff circuit
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-3141.

Last Modified: 10-Dec-2010


Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3142

Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3142 PID: SPN: 4360 FMI: 3 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the SCR intake temperature sensor circuit. | Default temperature value used for SCR intake temperature.
GX CM2250 - Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust gas temperature entering the SCR catalyst. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the diesel particulate filter and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the SCR intake temperature sensor signal voltage is higher than 4.4-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced after 10 hours of engine operation with this fault code active.
  • Vehicle speed will be limited to 8 kph [5 mph] after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The SCR intake temperature sensor shares RETURN wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source
  • Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3142.

Last Modified: 10-Dec-2010


Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3143

Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3143 PID: SPN: 4360 FMI: 4 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the SCR intake temperature sensor circuit. | Default temperature value used for SCR intake temperature.
GX CM2250 - Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust gas temperature entering the SCR catalyst. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the diesel particulate filter (DPF) and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the SCR intake temperature sensor signal voltage is less than 0.13-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips when the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The SCR intake temperature sensor shares RETURN wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor
  • Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3143.

Last Modified: 10-Dec-2010


Aftertreatment SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3144

Aftertreatment SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3144 PID: SPN: 4360 FMI: 2 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect. The SCR intake temperature sensor is not changing with engine operating conditions. | Default temperature value used for SCR intake temperature.
GX CM2250 - Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust gas temperature entering the SCR catalyst. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the diesel particulate filter (DPF) and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature sensors are compared to other engine temperatures during engine operation. The engine coolant temperature must be above 60°C [140°F] before the diagnostic will run.

Conditions for Setting the Fault Codes

This fault code is logged if the value of the SCR intake temperature sensor does not match the engine operating conditions for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.
  • A default value for the SCR catalyst intake temperature is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips when the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range SCR intake temperature sensor
  • High resistance in the SCR intake temperature sensor signal or return lines
  • Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3144.

Last Modified: 10-Dec-2010


Aftertreatment SCR Intake Temperature Sensor - Abnormal Rate of Change

FAULT CODE 3145

Aftertreatment SCR Intake Temperature Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3145 PID: S254 SPN: 4360 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor - Abnormal Rate of Change. The SCR catalyst intake temperature sensor is not responding to a change in engine operating conditions. | Default temperature value used for SCR catalyst intake temperature.
GX CM2250 - Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust gas temperature entering the SCR catalyst. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the diesel particulate filter (DPF) and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic will only run during active regeneration of the DPF.

Conditions for Setting the Fault Codes

The ECM detects that the SCR catalyst intake temperature is not changing to match engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and make certain that the SCR intake temperature is less than 350°C [662°F]. Then perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the malfunction indicator lamp (MIL) after three consecutive trips when the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range SCR catalyst intake temperature sensor reading
  • High resistance in the SCR catalyst intake temperature sensor signal or return lines
  • Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3145.

Last Modified: 10-Dec-2010


Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3146

Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3146 PID: SPN: 4363 FMI: 3 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the SCR outlet temperature sensor circuit. | Default temperature value used for SCR outlet temperature.
GX CM2250 - Aftertreatment SCR Outlet Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) outlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust gas temperature exiting the SCR catalyst. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The SCR outlet temperature sensor is located in the aftertreatment system, after the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the SCR catalyst outlet temperature sensor signal voltage is higher than 4.4-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced after 10 hours of engine operation with this fault code active.
  • Vehicle speed will be limited to 8 kph [5 mph] after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips when the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The SCR outlet temperature sensor shares RETURN wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source
  • Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3146.

Last Modified: 10-Dec-2010


Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3147

Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3147 PID: SPN: 4363 FMI: 4 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the SCR outlet temperature sensor circuit. | Default temperature used for SCR outlet temperature.
GX CM2250 - Aftertreatment SCR Outlet Temperature Sensor Circuit

Circuit Description

The SCR outlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust gas temperature exiting the SCR catalyst. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The SCR outlet temperature sensor is located in the aftertreatment system, after the SCR catalyst.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

  • The ECM detects that the SCR catalyst outlet temperature sensor signal voltage is less than 0.13-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips when the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The SCR outlet temperature sensor shares RETURN wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor
  • Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3147.

Last Modified: 10-Dec-2010


Aftertreatment SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3148

Aftertreatment SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3148 PID: SPN: 4363 FMI: 2 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect. The SCR outlet temperature sensor is not changing with engine operating conditions. | Default temperature value is used for SCR outlet temperature.
GX CM2250 - Aftertreatment SCR Outlet Temperature Circuit

Circuit Description

The SCR outlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust gas temperature exiting the SCR catalyst. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The SCR outlet temperature sensor is located in the aftertreatment system, after the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature sensors are compared to other engine temperatures during engine operation. The engine coolant temperature must be above 60°C [140°F] before the diagnostic will run.

Conditions for Setting the Fault Codes

This fault code is logged if the value of the SCR catalyst outlet temperature sensor does not match the engine operating conditions for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.
  • A default value for the SCR catalyst outlet temperature is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips when the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range SCR outlet temperature sensor
  • High resistance in the SCR outlet temperature sensor signal or return lines
  • Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3148.

Last Modified: 10-Dec-2010


Aftertreatment SCR Outlet Temperature Sensor - Abnormal Rate of Change

FAULT CODE 3149

Aftertreatment SCR Outlet Temperature Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3149 PID: S254 SPN: 4363 FMI: 10/10 LAMP: Red SRT: | Aftertreatment SCR Outlet Temperature Sensor - Abnormal Rate of Change. The selective catalytic reduction (SCR) catalyst outlet temperature sensor is not responding to a change in engine operating conditions. | Default temperature value used for SCR catalyst outlet temperature.
GX CM2250 - Aftertreatment SCR Outlet Temperature Sensor

Circuit Description

The SCR outlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust gas temperature exiting the SCR catalyst. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The SCR outlet temperature sensor is located in the aftertreatment system, the sensor is located after the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic will only run during active regeneration of the diesel particulate filter.

Conditions for Setting the Fault Codes

The ECM detects that the SCR catalyst outlet temperature is not changing to match engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and make sure the SCR outlet temperature is less than 350°C [662°F]. Then perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range SCR catalyst outlet temperature sensor reading
  • High resistance in the SCR catalyst outlet temperature sensor signal or return lines
  • Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3149.

Last Modified: 10-Dec-2010


Aftertreatment SCR Catalyst System Missing - Condition Exists

FAULT CODE 3151

Aftertreatment SCR Catalyst System Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3151 PID: SPN: 4794 FMI: 31 LAMP: Amber SRT: | Aftertreatment SCR Catalyst System Missing - Condition Exists. The aftertreatment SCR catalyst in the exhaust system is not present. | Diesel exhaust fluid solution injection into the aftertreatment system is disabled.
GX CM2250 - Electronic Control Module (ECM)

Circuit Description

The ECM monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system. Critically low NOx conversion efficiency is an indication of a missing SCR catalyst.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter and decomposition tube.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete. NOx sensor data is gathered over varying engine speeds and loads. When enough data has been gathered, the diagnostic will run, make a pass/fail decision, and begin to gather data again.

Conditions for Setting the Fault Codes

The ECM has detected that the NOx conversion efficiency of the SCR catalyst is critically low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 kph [5 mph] after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • After completing a stationary regeneration (as instructed in this fault code troubleshooting tree) and no additional faults become active, the repair has been validated. Note that this fault code will still be active.
  • It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault code and extinguish the amber CHECK ENGINE lamp and/or MIL.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault include:

  • Incorrect calibration revision on INCAL™ CD
  • Tampering with SCR catalyst system, removal of SCR catalyst from vehicle, or malfunctioning SCR catalyst
  • Malfunctioning diesel exhaust fluid dosing system
  • Exhaust system leaks
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Diesel exhaust fluid deposits in decomposition tube.

This fault code can be set as a result of multiple failure modes. All steps of the troubleshooting tree must be completed.

Refer to Troubleshooting Fault Code t05-3151.

Last Modified: 01-Dec-2010


Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3164

Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3164 PID: SPN: 4360 FMI: 15 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. High selective catalytic reduction (SCR) intake temperature has been detected. | Possible engine derate.
GX CM2250 - Aftertreatment SCR Intake Temperature Sensor

Circuit Description

The SCR intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust gas temperature entering the SCR catalyst. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system between the diesel particulate filter and the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the temperature at the SCR catalyst intake is greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code will go inactive immediately after the SCR intake temperature drops below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Malfunctioning in-range SCR intake temperature sensor
  • Upstream exhaust system malfunction.
Refer to Troubleshooting Fault Code t05-3164.

Last Modified: 10-Dec-2010


Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3165

Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3165 PID: SPN: 4363 FMI: 0 LAMP: Red SRT: | Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. The selective catalytic reduction (SCR) outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled. The engine may shut down.
GX CM2250 - Aftertreatment SCR Outlet Temperature Sensor Circuit

Circuit Description

The SCR outlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust gas temperature exiting the SCR catalyst. The ECM monitors the voltage on the signal pin and converts it to a temperature value.

Component Location

The SCR outlet temperature sensor is located in the aftertreatment system, after the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the temperature at the SCR catalyst outlet temperature sensor is greater than 800°C [1472°F] for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine can possibly be shut down.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhuast fluid
  • Malfunctioning in-range SCR outlet temperature sensor.
Refer to Troubleshooting Fault Code t05-3165.

Last Modified: 10-Dec-2010


Aftertreatment Doser - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3167

Aftertreatment Doser - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3167 PID: S382 SPN: 3556 FMI: 18 LAMP: Amber SRT: | Aftertreatment Doser - Data Valid But Below Normal Operating Range - Moderately Severe Level. The ECM detects that the aftertreatment fuel injector has used up all compensation. | Possible ineffective regeneration of the aftertreatment diesel particulate filter.
GX CM2250 - Aftertreatment Doser Circuit

Circuit Description

The aftertreatment fuel injector is electronically controlled by the engine electronic control module (ECM) through a pulse width modulated (PWM) signal. The amount of fuel injected is determined by how long the PWM signal to the injector is on.

Component Location

The aftertreatment fuel injector is located on the turbocharger adapter pipe.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

This fault code becomes active when the ECM detects that the aftertreatment fuel injector can not inject enough fuel for active regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test. Once the temperatures in the aftertreatment system are high enough to inject diesel fuel into the exhaust, the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible cause of this fault:

  • A dirty or damaged aftertreatment fuel injector.
Refer to Troubleshooting Fault Code t05-3167.

Last Modified: 01-Dec-2010


Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3168

Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3168 PID: SPN: 3936 FMI: 16 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level. The system has detected a malfunction in the filtering capability of the aftertreatment diesel particulate filter. | None on performance.
GX CM2250 - Aftertreatment Diesel Particulate Filter System Circuit

Circuit Description

The ECM calculates an aftertreatment diesel particulate filter flow resistance using the aftertreatment diesel particulate filter differential pressure and calculated exhaust flow rate.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic only runs after successful completion of an active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter flow resistance is lower than a threshold for 2 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A damaged aftertreatment diesel particulate filter differential pressure sensor
  • Missing or malfunctioning aftertreatment diesel particulate filter differential pressure sensor tubes
  • Malfunctioning aftertreatment diesel particulate filter.
Refer to Troubleshooting Fault Code t05-3168.

Last Modified: 01-Dec-2010


Tachograph Output Shaft Speed - Abnormal Update Rate

FAULT CODE 3186

Tachograph Output Shaft Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3186 PID: SPN: 1623 FMI: 9/9 LAMP: Amber SRT: | Tachograph Output Shaft Speed - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the tachograph output shaft speed sensor. | None on performance.
GX CM2250 - Tachograph Output Shaft Speed Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Component values and states from components such as sensors, accelerators, and switches can then be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message whick says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning J1939 data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, malfunctioning OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-3186.

Last Modified: 01-Dec-2010


Tachograph Output Shaft Speed - Received Network Data In Error

FAULT CODE 3213

Tachograph Output Shaft Speed - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3213 PID: SPN: 1623 FMI: 19 LAMP: Amber SRT: | Tachograph Output Shaft Speed - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the tachograph output shaft speed sensor. | None on performance.
GX CM2250 - SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM VECU or transmission electronic control unit in the cab. Component values and states from components (such as sensors, accelerators, and switches) can then be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link. Messages sent from the OEM VECU or transmission electronic control unit are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the key switch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determines that there is a malfunction of the tachograph output shaft speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the tachograph output shaft speed sensor.

Refer to Troubleshooting Fault Code t05-3213.

Last Modified: 01-Dec-2010


Aftertreatment Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3228

Aftertreatment Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3228 PID: SPN: 3216 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect. An incorrect NOx sensor reading has been detected by the aftertreatment intake NOx sensor. | Aftertreatment intake NOx sensor operation will be disabled.
GX CM2250 - Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the engine out NOx emissions.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine, near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature at the aftertreatment intake NOx sensor is above 150° C [302° F] and the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the NOx reading is higher or lower than what is expected for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool. The exhaust gas temperature at the aftertreatment intake NOx sensor must be above 150° C [302° F] before the sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • The ECM has detected that the NOx reading is higher or lower than is possible from the engine output
  • Exhaust system leaks
  • An incorrectly installed aftertreatment intake NOx sensor
  • An aftertreatment intake NOx sensor that has carbon buildup on the tip of the sensor
  • Excessive oil consumption
  • Possible engine misfire
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code t05-3228.

Last Modified: 01-Dec-2010


Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3229

Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3229 PID: SPN: 4360 FMI: 0 LAMP: Red SRT: | Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. The selective catalytic reduction (SCR) intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled. The engine can shut down.
GX CM2250 - Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The SCR intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust gas temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts it to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system, between the diesel particulate filter and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the temperature at the SCR catalyst intake temperature sensor is greater than 800°C [1472°F] for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine could be shut down.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code will go inactive immediately after the SCR intake temperature drops below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Malfunctioning in-range SCR intake temperature sensor
  • Upstream exhaust system malfunction.
Refer to Troubleshooting Fault Code t05-3229.

Last Modified: 10-Dec-2010


Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3231

Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3231 PID: SPN: 4360 FMI: 16 LAMP: Red SRT: | Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The SCR intake temperature sensor reading has exceeded the maximum temperature limit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
GX CM2250 - Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The SCR intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts it to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. The sensor is located between the diesel particulate filter and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The ECM detects that the temperature at the SCR catalyst intake temperature sensor is greater than 650°C [1202°F] for more than 60 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault will go inactive immediately after the SCR intake temperature drops below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Malfunctioning in-range SCR intake temperature sensor
  • Upstream exhaust system malfunction.
Refer to Troubleshooting Fault Code t05-3231.

Last Modified: 10-Dec-2010


Aftertreatment Intake NOx Sensor - Abnormal Update Rate

FAULT CODE 3232

Aftertreatment Intake NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3232 PID: SPN: 3216 FMI: 9 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the aftertreatment intake NOx sensor. | Aftertreatment intake NOx sensor operation will be disabled.
GX CM2250 - Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the engine out NOx emissions.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the ECM loses J1939 communications with the aftertreatment intake NOx sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 kph [5 mph] after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment intake NOx sensor is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, blown NOx sensor fuse, or low voltage supplied by the battery.
  • Open return circuit on the aftertreatment intake NOx sensor circuit between the battery circuit aftertreatment intake NOx sensor.
  • Open or short circuit on the J1939 data link circuit between the engine ECM and ther aftertreatment intake NOx sensor.
  • Intermittent communications between the aftertreatment intake NOx sensor and the primary engine ECM on the J1939 data link.
  • A malfunctioning engine ECM.
Refer to Troubleshooting Fault Code t05-3232.

Last Modified: 01-Dec-2010


Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3235

Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3235 PID: SPN: 4363 FMI: 16 LAMP: Red SRT: | Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The SCR outlet temperature sensor reading has exceeded the maximum temperature limit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
GX CM2250 - Aftertreatment SCR Outlet Temperature Sensor Circuit

Circuit Description

The SCR outlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature exiting the SCR catalyst. The ECM monitors the voltage on the signal pin and converts it to a temperature value.

Component Location

The SCR outlet temperature sensor is located in the aftertreatment system. The sensor is located after the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The ECM detects that the temperature at the SCR catalyst outlet temperature sensor is greater than 650°C [1202°F] for more than 60 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Malfunctioning in-range SCR outlet temperature sensor.
Refer to Troubleshooting Fault Code t05-3235.

Last Modified: 10-Dec-2010


Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3236

Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3236 PID: SPN: 4363 FMI: 15 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. High SCR outlet temperature has been detected. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
GX CM2250 - Aftertreatment SCR Outlet Temperature Sensors

Circuit Description

The SCR outlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature exiting the SCR catalyst. The ECM monitors the voltage on the signal pin and converts it to a temperature value.

Component Location

The SCR outlet temperature sensor is located in the aftertreatment system. The sensor is located after the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the temperature at the SCR catalyst outlet is greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhuast fluid
  • Malfunctioning in-range SCR outlet temperature sensor.
Refer to Troubleshooting Fault Code t05-3236.

Last Modified: 10-Dec-2010


Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3237

Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3237 PID: S254 SPN: 4340 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 1 circuit. | Diesel exhaust fluid line heater 1 will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 1 is controlled by the aftertreatment diesel exhaust fluid controller, and receives power through the switch side of the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the heater is commanded ON.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the line heater voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The line heater will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after all three line heaters are commanded ON and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • Short circuit to battery in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3237.

Last Modified: 01-Dec-2010


Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3239

Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3239 PID: SPN: 4342 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 2 circuit. | Diesel exhaust fluid line heater 2 will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 2 is controlled by the aftertreatment diesel exhaust fluid controller, and receives power through the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 2 is located on the return line between the dosing unit and the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the heater is commanded ON.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the line heater voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The line heater will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after all three line heaters are commanded ON and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • Short circuit to battery in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid contoller.
Refer to Troubleshooting Fault Code t05-3239.

Last Modified: 01-Dec-2010


Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3242

Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3242 PID: SPN: 3363 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment. The aftertreatment diesel exhaust fluid temperature did not increase when the aftertreatment diesel exhaust fluid tank heater was commanded ON. | None on performance. Diesel exhaust fluid injection into the aftertreatment system will be disabled if the aftertreatment diesel exhaust fluid is frozen.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve that controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary, depending on the vehicle OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a short time after diesel exhaust fluid tank heating is first commanded ON.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater is commanded ON by the engine ECM, but no corresponding temperature increase in the aftertreatment diesel exhaust fluid tank temperature was recorded by the tank temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diesel exhaust fluid tank heater is able to successfully raise the tank temperature when first activated and the diagnostic runs and passes. If a heating cycle can not be completed, make sure the diesel exhaust fluid tank heater control valve is operating correctly by using the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests in INSITE™ electronic service tool, and then clear the fault using the Reset All Faults command in INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve stuck closed
  • Blockage or restrictions in the coolant plumbing to the diesel exhaust fluid tank heater
  • Engine coolant level low
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve
  • Malfunctioning aftertreatment diesel exhaust fluid controller is unable to command tank heating.
Refer to Troubleshooting Fault Code t05-3242.

Last Modified: 01-Dec-2010


Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3243

Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3243 PID: SPN: 3060 FMI: 18 LAMP: Amber SRT: | Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine is not warming up as expected. | None on performance.
GX CM2250 - Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine, near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running, if the coolant temperature was less than 52°C [126°F] when the engine was started.

Conditions for Setting the Fault Codes

The ECM detects that coolant temperature did not reach 72°C [162°F] in a specified amount of time.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the engine coolant temperature rises above 72°C [162°F] and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level, or air in the cooling system
  • Malfunctioning coolant temperature sensor
  • Malfunctioning engine coolant thermostat.
Refer to Troubleshooting Fault Code t05-3243.

Last Modified: 01-Dec-2010


Aftertreatment Diesel Particulate Filter System - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3245

Aftertreatment Diesel Particulate Filter System - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3245 PID: SPN: 3936 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter System - Mechanical System Not Responding or Out of Adjustment. The aftertreatment diesel particulate filter has been damaged. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter System Circuit

Circuit Description

The aftertreatment diesel particulate filter is located in the exhaust stream and captures the soot that is produced by the engine. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter outlet temperature sensor reading exceeds 950°C [1742°F] for 30 seconds, or the difference between the diesel particulate filter intake temperature and the diesel particulate filter outlet temperature is greater than 1050°C or 1890°F for 30 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails on two consecutive trips.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A malfunctioning engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • The aftertreatment diesel particulate filter outlet temperature sensor malfunctioning in-range
  • A face plugged aftertreatment diesel oxidation catalyst
  • An in-range engine sensor malfunction has occurred, causing excessive fuel to enter the exhaust system.
Refer to Troubleshooting Fault Code t05-3245.

Last Modified: 01-Dec-2010


Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3251

Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3251 PID: S326 SPN: 475 FMI: 16 LAMP: Red SRT: | Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel oxidation catalyst intake temperature sensor reading has exceeded the maximum temperature limit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system, between the outlet of the turbocharger and intake of the exhaust aftertreatment system. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The ECM detects that the temperature at the diesel oxidation catalyst intake is greater than 690°C [1112°F] for 60 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.
  • Active and stationary (parked) regeneration will be disabled.
  • Engine shutdown will occur 30 seconds after the fault code becomes active. In all calibrations, except for emergency vehicle calibrations, engine shutdown will occur after 30 seconds, if engine protection shutdown is enabled or disabled. Engine shutdown will not occur in emergency vehicle calibrations.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is not occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel oxidation catalyst and/or aftertreatment diesel particulate filter.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • The aftertreatment diesel oxidation catalyst intake temperature sensor malfunctioned in-range
  • The aftertreatment diesel particulate filter intake temperature sensor malfunctioned in-range
  • The aftertreatment diesel particulate filter outlet temperature sensor malfunctioned in-range
  • An in-range engine sensor malfunction has occurred, causing excessive fuel to enter the exhaust system.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damage and reuse. Refer to the OEM service manual.

Refer to Troubleshooting Fault Code t05-3251.

Last Modified: 01-Dec-2010


Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3253

Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3253 PID: SPN: 3242 FMI: 16 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The aftertreatment diesel particulate filter intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | Active and stationary aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust gas temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter intake temperature sensor reading exceeds 650°C [1202°F] for 85 seconds, or the difference between the diesel oxidation catalyst intake temperature and the diesel particulate filter intake temperature is greater than 365°C [689°F] for 50 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Active and stationary (parked) regeneration will be disabled.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 2 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is not occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel particulate filter. This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • Damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • Aftertreatment diesel particulate filter outlet temperature sensor malfunctioned in-range
  • Face plugged aftertreatment diesel oxidation catalyst
  • In-range engine sensor malfunction has occurred, causing excessive fuel to enter the exhaust system.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damage and reuse. Refer to the OEM service manual.

Refer to Troubleshooting Fault Code t05-3253.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 3254

Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3254 PID: SPN: 3242 FMI: 15 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid but Above Normal Operating Range - Least Severe Level. The aftertreatment diesel particulate filter intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | Active and stationary aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter intake temperature sensor reading exceeds 675°C [1247°F] for 5 seconds on five separate occasions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • Damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • Aftertreatment diesel particulate filter outlet temperature sensor malfunctioned in-range
  • Face plugged aftertreatment diesel oxidation catalyst
  • In-range engine sensor malfunction has occurred, causing excessive fuel to enter the exhaust system.
Refer to Troubleshooting Fault Code t05-3254.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3255

Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3255 PID: SPN: 3246 FMI: 16 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Active and stationary aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter intake temperature sensor reading exceeds 687°C [1269°F] for 90 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

  • Active and stationary regeneration of the diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • Damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • Aftertreatment diesel particulate filter outlet temperature sensor malfunctioned in-range
  • Face plugged aftertreatment diesel oxidation catalyst
  • In-range engine sensor malfunction has occurred, causing excessive fuel to enter the exhaust system.
Refer to Troubleshooting Fault Code t05-3255.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3256

Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3256 PID: SPN: 3246 FMI: 15 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Active and stationary aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter outlet temperature sensor reading exceeds 675°C [1247°F] for 5 seconds on five separate occasions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • Damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • Aftertreatment diesel particulate filter outlet temperature sensor malfunctioned in-range
  • Face plugged aftertreatment diesel oxidation catalyst
  • In-range engine sensor malfunction has occurred, causing excessive fuel to enter the exhaust system.
Refer to Troubleshooting Fault Code t05-3256.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3258

Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3258 PID: SPN: 4340 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit. Open circuit or short circuit to ground detected in the diesel exhaust fluid line heater 1. | Diesel exhaust fluid line heater 1 will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 1 is controlled by the aftertreatment diesel exhaust fluid controller, and receives power through the switch side of the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line, between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the line heater circuit is open or shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 kph [5 mph] after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after all three line heaters are commanded on and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning line heater relay
  • Malfunctioning line heater
  • Open circuit, short circuit to ground, or blown fuse in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3258.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3261

Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3261 PID: S254 SPN: 4342 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit. Open circuit or short circuit to ground detected in the diesel exhaust fluid line heater 2. | Diesel exhaust fluid line heater 2 will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 2 is controlled by the aftertreatment diesel exhaust fluid controller, and receives power through the switch side of the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 2 is located on the return line between the diesel exhaust fluid dosing unit and diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the line heater circuit is open or shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 kph [5 mph] after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after all three line heaters are commanded on and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater relay
  • Malfunctioning line heater
  • Open circuit, short circuit to ground, or a blown fuse in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3261.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3311

Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3311 PID: SPN: 3242 FMI: 0 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. The aftertreatment diesel particulate filter intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxication catalyst and before the diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter intake temperature reading is greater than 800°C [1472°F] for more than 20 seconds, or the temperature differential across the diesel oxidation catalyst is greater than 500°C [932°F] for more than 120 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve will be closed. Possible engine shutdown if the engine protection shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Malfunctioning fuel injector causing unburned fuel to enter the exhaust system
  • Aftertreatment diesel particulate filter intake temperature sensor malfunctioned in-range
  • Excessive engine oil being introduced into the exhaust system from the engine.
Refer to Troubleshooting Fault Code t05-3311.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3312

Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3312 PID: SPN: 3246 FMI: 0 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system at the outlet of the aftertreatment diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter outlet temperature reading is greater than 800°C [1472°F] for 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve will be closed.
  • Engine will shut down if the engine protection shutdown feature is enabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute. This fault code will stay active until the next key cycle, even if the temperatures fall below the warning limits.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code will go inactive after the aftertreatment temperatures drop below the warning limit and a key cycle has occurred, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Malfunctioning fuel injector causing unburned fuel to enter the exhaust system
  • Aftertreatment diesel particulate filter outlet temperature sensor failed in-range
  • Excessive engine oil being introduced into the exhaust system from the engine.
Refer to Troubleshooting Fault Code t05-3312.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3313

Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3313 PID: SPN: 4765 FMI: 4 LAMP: Red SRT: | Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the catalyst intake sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system, between the outlet of the turbocharger and intake of the exhaust aftertreatment. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel oxidation catalyst intake temperature sensor signal voltage is less than 0.1-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel oxidation catalyst intake temperature sensor shares RETURN wires in the OEM harness with other sensors. A shorted RETURN wire can cause multiple fault codes to be active.

Possible causes of this fault include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor
  • Malfunctioning aftertreatment diesel particulate filter temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3313.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3314

Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3314 PID: SPN: 4765 FMI: 3 LAMP: Red SRT: | Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst intake temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system, between the outlet of the turbocharger and the intake of the exhaust aftertreatment. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel oxidation catalyst intake temperature signal voltage is greater than 4.4-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel oxidation catalyst intake temperature sensor shares RETURN wires in the OEM harness with other sensors. A shorted RETURN wire can cause multiple fault codes to be active.

Possible causes of this fault include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source
  • Malfunctioning aftertreatment diesel particulate filter temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3314.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3315

Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3315 PID: SPN: 4765 FMI: 2 LAMP: Red SRT: | Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel oxidation catalyst intake temperature sensor is not changing with engine operating conditions. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Oxidation Catalyst Intake Temperature Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust gas temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system, between the outlet of the turbocharger and intake of the exhaust aftertreatment system. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the difference between the aftertreatment diesel oxidation catalyst intake temperature sensor data and diesel particulate filter intake temperature sensor data does not match the expected value for the present engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.
  • A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault codeactive.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel oxidation catalyst intake temperature sensor
  • High resistance in the aftertreatment diesel oxidation catalyst intake temperature sensor signal or return lines
  • Malfunctioning aftertreatment diesel particulate filter temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3315.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3316

Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3316 PID: SPN: 3242 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel particulate filter intake temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust gas temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system, at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter intake temperature signal voltage is less than 0.1-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter intake temperature reading is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel particulate filter intake temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor
  • Malfunctioning aftertreatment diesel particulate filter temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3316.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3317

Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3317 PID: SPN: 3242 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the aftertreatment diesel particulate filter intake temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust gas temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system, at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter intake temperature signal voltage is greater than 4.4-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter intake temperature reading is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The diesel particulate filter intake temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source
  • Malfunctioning aftertreatment diesel particulate filter temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3317.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3318

Aftertreatment Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3318 PID: SPN: 3242 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter intake temperature is not changing with engine operating conditions. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust gas temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system, at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the difference between the aftertreatment diesel particulate filter intake temperature sensor data and diesel particulate filter outlet temperature sensor data does not match the expected value for the present engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.
  • A default value for the aftertreatment diesel particulate filter intake temperature sensor reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter intake temperature sensor
  • High resistance in the aftertreatment diesel particulate filter intake temperature sensor signal or return wires
  • Malfunctioning aftertreatment diesel particulate filter temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3318.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3319

Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3319 PID: SPN: 3246 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the aftertreatment diesel particulate filter outlet temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust gas temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor or thermistor resistance is low. The signal pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system, at the outlet of the aftertreatment diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter outlet temperature signal voltage is greater than 4.4-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter outlet temperature reading is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel particulate filter outlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source
  • Malfunctioning aftertreatment diesel particulate filter temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3319.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3321

Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3321 PID: SPN: 3246 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel particulate filter outlet temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust gas temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system, at the outlet of the aftertreatment diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter outlet temperature signal voltage is less than 0.1-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter outlet temperature reading is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel particulate filter outlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor
  • Malfunctioning aftertreatment diesel particulate filter temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3321.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3322

Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3322 PID: SPN: 3246 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter outlet temperature is not changing with engine operating conditions. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust gas temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the voltage on the signal pin and converts it to a temperature value.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system, at the outlet of the aftertreatment diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter outlet temperature sensor reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.
  • A default value for the aftertreatment diesel particulate filter outlet temperature sensor reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The EGR valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 15 minutes. The engine must be running at any speed for 15 minutes and the aftertreatment diesel oxidation catalyst intake temperature must be above 150°C [300°F] before the fault code will clear.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter outlet temperature sensor
  • High resistance in the aftertreatment diesel particulate filter outlet temperature sensor signal or return wires
  • Malfunctioning aftertreatment diesel particulate filter temperature sensor interface module.
Refer to Troubleshooting Fault Code t05-3322.

Last Modified: 13-Dec-2010


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

FAULT CODE 3326

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3326 PID: SPN: 91 FMI: 9 LAMP: Red SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate. The ECM expected information from a multiplexed accelerator pedal or lever sensor but did not receive it soon enough or did not receive it at all. | Engine will only idle.
GX CM2250 - Engine Control Module

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (TECU) in the cab. Then, component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from the multiplexed accelerator pedal or lever sensor for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault code can occur for the following reasons:

  • The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU, or damaged Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.
  • It is possible to use INSITE™ electronic service tool to monitor multiplexed components.
Refer to Troubleshooting Fault Code t05-3326.

Last Modified: 13-Dec-2010


Transmission Output Shaft Speed - Abnormal Update Rate

FAULT CODE 3328

Transmission Output Shaft Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3328 PID: SPN: 191 FMI: 9/9 LAMP: Amber SRT: | Transmission Output Shaft Speed - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the transmission output shaft speed sensor. | None on performance.
GX CM2250 - Transmission Output Shaft Speed Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (TECU) in the cab. Component values and states from components such as sensors, accelerators, and switches can then be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and are used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM didn't receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-3328.

Last Modified: 13-Dec-2010


Engine Exhaust Gas Recirculation Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3342

Engine Exhaust Gas Recirculation Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3342 PID: P091 SPN: 4752 FMI: 18 LAMP: Amber SRT: | Engine Exhaust Gas Recirculation Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level. The EGR cooler is not cooling the recirculated exhaust gas sufficiently. | None on performance.
GX CM2250 - Engine Exhaust Gas Recirculation Cooler

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor that is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The electronic control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The EGR temperature value is used by the ECM to determine the efficiency of the EGR cooler.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR valve and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature is greater than a threshold for 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning EGR temperature sensor
  • A malfunctioning EGR cooler.
Refer to Troubleshooting Fault Code t05-3342.

Last Modified: 13-Dec-2010


Engine Charge-Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3343

Engine Charge-Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3343 PID: SPN: 5285 FMI: 18 LAMP: Amber SRT: | Engine Charge-Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine charge- air cooler is not cooling the intake air flow sufficiently. | None on performance.
GX CM2250 - Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistance sensor that is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

When the intake air is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The intake manifold 1 temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature is greater than 111°C [232°F] for 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • A malfunctioning intake manifold temperature sensor
  • A malfunctioning charge-air cooler.
Refer to Troubleshooting Fault Code t05-3343.

Last Modified: 10-Dec-2010


Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 3348

Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3348 PID: SPN: 1176 FMI: 1/1 LAMP: Red SRT: | Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. The estimated differential pressure across the turbocharger is above the critical level. | Progressive power derate increasing in severity from the time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
GX CM2250 - Turbocharger 1 Compressor Inlet Pressure Circuit

Circuit Description

The ECM calculates a differential pressure across the turbocharger using the intake manifold pressure sensor and the crankcase pressure sensor.

Component Location

The intake manifold pressure sensor is located in the air intake horn. The crankcase pressure sensor is mounted to the crankcase breather filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The calculated differential pressure across the turbocharger is greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • An engine speed derate will occur when the fault is registered.
  • If the problem persists for 5 minutes, an engine shutdown procedure will begin.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Crankcase filter needs to be changed.

  • If the crankcase filter is being replaced frequently for this fault code, reference the Crankcase Coalescing Filter - Frequent Replacement troubleshooting symptom tree.

Air intake filter needs to be changed.

  • Use the following procedure for air intake filter replacement in the approprate service manual. Refer to Procedure 010-031 in Section 10.

A plugged or restricted crankcase ventilation system.

  • Check the tube between the engine and the coalescing filter.
  • Check the draft tube going from the coalescing filter to the atmosphere or intake manifold.
  • Consider the working environment. Ice, snow, or mud can temporarily block the tube and then fall away.

Complete the entire troubleshooting tree whether Fault Code 3348 is active or inactive.

If a problem is found in the early steps, the troubleshooting tree should still be completed.

Refer to Troubleshooting Fault Code t05-3348.

Last Modified: 10-Dec-2010


Intake Manifold 1 Pressure - Abnormal Rate of Change

FAULT CODE 3361

Intake Manifold 1 Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3361 PID: SPN: 102 FMI: 10/10 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Abnormal Rate of Change. The intake manifold pressure sensor reading is not responding with engine conditions. | Possible reduced engine performance.
GX CM2250 - Intake Manifold 1 Pressure Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold.

The ECM uses the intake manifold pressure reading to monitor turbocharger performance.

Component Location

The turbocharger is mounted to the exhaust manifold.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the VGT actuator is slow to meet commanded position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning variable geometry turbocharger (VGT)
  • High exhaust restriction.
Refer to Troubleshooting Fault Code t05-3361.

Last Modified: 10-Dec-2010


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3366

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3366 PID: SPN: 111 FMI: 18 LAMP: None SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. Very low engine coolant level detected. | None on performance.
GX CM2250 - Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch that is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The electronic control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level sensor signal voltage is higher than 3-VDC for more than 30 seconds, indicating severely low coolant level.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • For On-Board Diagnostics (OBD) engines, the ECM illuminates the the malfunction indicator lamp (MIL) immediately after three consecutive trips in which the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code t05-3366.

Last Modified: 13-Dec-2010


Roll Over Protection Brake Control Active - Condition Exists

FAULT CODE 3374

Roll Over Protection Brake Control Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3374 PID: SPN: 1818 FMI: 31/31 LAMP: None SRT: | Roll Over Protection Brake Control Active - Condition Exists. The ECM received a message from the anti-lock braking (ABS) controller, inhibiting cruise control operation. | Cruise control could possibly not operate.
GX CM2250 - Roll Over Protection Brake Control Active Circuit

Circuit Description

Certain anti-lock braking (ABS) controllers communicate with the electronic control module (ECM) through the SAE J1939 data link. Under certain driving conditions, the anti-lock braking (ABS) controller can send a cruise control inhibit message to the ECM and cruise control will temporarily be disabled.

Component Location

The SAE J1939 data link wiring and anti-lock braking (ABS) controller location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is set when cruise control has been inhibited due to certain driving conditions detected by the anti-lock braking (ABS) controller.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Cruise control has temporarily been inhibited.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, cruise control could possibly not function. This is an information only fault code, indicating that the anti-lock braking (ABS) controller detected certain driving conditions and temporarily inhibited cruise control operation. Refer to the OEM service manual.

Refer to Troubleshooting Fault Code t05-3374.

Last Modified: 10-Dec-2010


Aftertreatment Diesel Particulate Filter Regeneration Too Frequent - Condition Exists

FAULT CODE 3375

Aftertreatment Diesel Particulate Filter Regeneration Too Frequent - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3375 PID: S115 SPN: 5397 FMI: 31 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Regeneration Too Frequent - Condition Exists. The system has detected the need for an active regeneration has occurred too soon following the last active regeneration. | N/A
GX CM2250 - Aftertreatment Diesel Particulate Filter Regeneration

Circuit Description

The ECM records the time from the completion of an active regeneration of the aftertreatment diesel particulate filter until the ECM requests another active regeneration of the diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter mounting location is dependent on the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs after completion of a successful active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The time between the completion of a successful active regeneration and the request for another active regeneration is less than a threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

This diagnostic can not be run in the shop enviornment.

To validate the repair, perform the INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.

If no fault codes become active during the aftertreatment diesel particulate filter regeneration test, use INSITE™ electronic service tool "Reset All Faults" to clear the fault code and disable the CHECK ENGINE lamp and/or malfunction indicator lamp (MIL).

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment fuel injector
  • A face plugged aftertreatment diesel oxidation catalyst
  • A malfunctioning aftertreatment diesel particulate filter differential pressure sensor
  • An engine malfunction resulting in high engine out soot.
Refer to Troubleshooting Fault Code t05-3375.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Particulate Filter Incomplete Regeneration - Condition Exists

FAULT CODE 3376

Aftertreatment Diesel Particulate Filter Incomplete Regeneration - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3376 PID: SPN: 5319 FMI: 31 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Incomplete Regeneration - Condition Exists. The system has detected that the aftertreatment diesel particulate filter differential pressure is too high following an active regeneration. | Possible frequent need for aftertreatment regeneration.
GX CM2250 - Electronic Control Module (ECM)

Circuit Description

The ECM calculates an estimated value of the soot load in the aftertreatment diesel particulate filter, using the aftertreatment diesel particulate filter differential pressure sensor.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure.

Conditions for Running the Diagnostics

This diagnostic runs after completion of a successful active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The estimated soot load in the aftertreatment diesel particulate filter, calculated using the differential pressure, is higher than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment fuel injector
  • Malfunctioning aftertreatment temperature sensors
  • Malfunctioning aftertreatment diesel oxidation catalyst
  • A malfunctioning or stuck in range aftertreatment diesel particulate filter differential pressure sensor
  • An engine malfunction resulting in high engine out smoke.
Refer to Troubleshooting Fault Code t05-3376.

Last Modified: 13-Dec-2010


Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3382

Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3382 PID: SPN: 3058 FMI: 18 LAMP: Amber SRT: | Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Below Normal Operating Range - Moderately Severe Level. Measured EGR flow is lower than commanded. | Possible reduced engine performance.
GX CM2250 - Engine Exhaust Gas Recirculation (EGR) System

Circuit Description

The electronic control module (ECM) uses the EGR differential pressure sensor reading to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. The EGR differential pressure sensor measures the pressure drop across the EGR differential pressure orifice using two exhaust ports. The sensor outputs a voltage that represents the pressure difference between the two ports, and the ECM correlates that voltage to an EGR flow rate. This information is used to control the EGR valve for correct emissions levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.

Component Location

The EGR valve and EGR differential pressure sensor are located on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnosic runs when the engine is running and has reached normal operating tempertures (coolant temperature above 60°C [140°F] ), and the EGR valve is open. The EGR valve position can be monitored using INSITE™ electronic service tool.

Conditions for Setting the Fault Codes

The ECM determines that the actual EGR flow is lower than what is being commanded, based on the present engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunciton indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine for at least 5 minutes. The vehicle may need to be driven for a short distance, so that enough EGR flow is being commanded for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code are:

  • Leaks or restrictions in the EGR flow plumbing
  • Internally leaking EGR valve
  • Stuck closed EGR valve
  • Malfunctioning EGR differential pressure sensor.
Refer to Troubleshooting Fault Code t05-3382.

Last Modified: 13-Dec-2010


Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3383

Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3383 PID: P411 SPN: 3058 FMI: 16 LAMP: Amber SRT: | Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Above Normal Operating Range - Moderately Severe Level. Measured EGR flow is higher than commanded. | Possible reduced engine performance.
GX CM2250 - Exhaust Gas Recirculation

Circuit Description

The electronic control module (ECM) uses the EGR differential pressure sensor reading to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. The EGR differential pressure sensor measures the pressure drop across the EGR differential pressure orifice using two exhaust ports. The sensor outputs a voltage that represents the pressure difference between the two ports, and the ECM correlates that voltage to an EGR flow rate. This information is used to control the EGR valve for correct emission levels. The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.

Component Location

The EGR valve and EGR differential pressure sensor locations vary, depending on the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the EGR valve is closed. The EGR valve position can be monitored with INSITE™ electronic service tool.

Conditions for Setting the Fault Codes

The ECM determines that the measured EGR flow is higher than what is being commanded, based on the present engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the ECM determines that the commanded EGR flow target is being met and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code are:

  • Blockage, restrictions, or leaks in the EGR differential pressure sensor ports
  • Leaking EGR valve
  • Stuck open EGR valve
  • Malfunctioning EGR differential pressure sensor.
Refer to Troubleshooting Fault Code t05-3383.

Last Modified: 13-Dec-2010


Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3385

Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3385 PID: P105 SPN: 411 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. The intake manifold temperature is below a critical threshold | None.
GX CM2250 - Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistance sensor that is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the electronic control module (ECM) for the engine protection system and engine emissions control.

The ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount, therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The intake manifold temperature is less than 20°C [68°F] while the engine is operating at idle for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The EGR valve was closed because the engine was operating with cold intake manifold temperatures for an extended period of time. No repair is necessary.

Refer to Troubleshooting Fault Code t05-3385.

Last Modified: 18-Jan-2011


Exhaust Gas Recirculation (EGR) System - Abnormal Rate of Change

FAULT CODE 3389

Exhaust Gas Recirculation (EGR) System - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3389 PID: P411 SPN: 411 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Recirculation (EGR) System - Abnormal Rate of Change. The measured EGR flow is not meeting the commanded EGR flow. | EGR valve actuation will be disabled.
GX CM2250 - Differential Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the EGR differential pressure sensor reading to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. The EGR differential pressure sensor measures the pressure drop across the EGR differential pressure orifice using two exhaust ports. The sensor outputs a voltage that represents the pressure difference between the two ports, and the ECM correlates that voltage to an EGR flow rate. This information is used to control the EGR valve for correct emissions levels.

Component Location

The EGR differential pressure sensor is mounted to the EGR mass measurement assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The measured EGR flow does not meet the commanded EGR flow for 30 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning EGR valve
  • A leaking or malfunctioning EGR differential pressure sensor
  • A malfunctioning VGT.
Refer to Troubleshooting Fault Code t05-3389.

Last Modified: 13-Dec-2010


Transmission Output Shaft Speed - Received Network Data In Error

FAULT CODE 3418

Transmission Output Shaft Speed - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3418 PID: SPN: 191 FMI: 19 LAMP: Amber SRT: | Transmission Output Shaft Speed - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the transmission output shaft speed sensor. | None on performance.
GX CM2250 - SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from the OEM VECU or transmission electronic control unit are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the key switch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determines that there is a malfunction of the transmission output shaft speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the transmission output shaft speed sensor.

Refer to Troubleshooting Fault Code t05-3418.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3422

Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3422 PID: SPN: 4344 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 3 circuit. | Diesel exhaust fluid line heater 3 will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 3 is controlled by the aftertreatment diesel exhaust fluid controller, and receives power through the switch side of the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 3 is located on the suction line between the diesel exhaust fluid tank and diesel exhaust fluid dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the heater is commanded on.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the line heater voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The line heater will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after all three line heaters are commanded on and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • Short circuit to battery in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid contoller.
Refer to Troubleshooting Fault Code t05-3422.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3425

Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3425 PID: S254 SPN: 4344 FMI: 5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit. Open circuit or short circuit to ground detected in the diesel exhaust fluid line heater 3. | Diesel exhaust fluid line heater 3 will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 3 is controlled by the aftertreatment diesel exhaust fluid controller, and receives power through the switch side of the diesel exhaust fluid line heater relay.

Component Location

The aftertreatment diesel exhaust fluid line heater 3 is located on the suction line between the diesel exhaust fluid tank and diesel exhaust fluid dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the line heater circuit is open or shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 km [5 miles] per hour after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after all three line heaters are commanded on and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater relay
  • Malfunctioning line heater
  • Open circuit, short circuit to ground, or a blown fuse in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3425.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3426

Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3426 PID: SPN: 4346 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 4 circuit. | Diesel exhaust fluid line heater 4 will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 4 is powered and controlled by the aftertreatment diesel exhaust fluid controller.

Component Location

The aftertreatment diesel exhaust fluid line heater 4 is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the heater is commanded ON.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the heater voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The line heater will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately the heater is commanded ON and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater internal to the dosing unit
  • Short circuit to battery in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3426.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3429

Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3429 PID: S254 SPN: 4346 FMI: 5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Current Below Normal or Open Circuit. Open circuit or short circuit to ground detected in the diesel exhaust fluid line heater 4. | Diesel exhaust fluid line heater 4 will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater 4 is powered and controlled by the aftertreatment diesel exhaust fluid controller.

Component Location

The aftertreatment diesel exhaust fluid line heater 4 is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the heater circuit is open.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the heater is commanded on and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater internal to the dosing unit
  • Open circuit or short circuit to ground in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3429.

Last Modified: 13-Dec-2010


Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

FAULT CODE 3488

Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3488 PID: SPN: 563 FMI: 9 LAMP: Amber SRT: | Anti-Lock Braking (ABS) Controller - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the anti-lock braking (ABS) controller. | None on performance.
GX CM2250 - SAE J1939 Multiplexing Circuit

Circuit Description

Normally, switches, accelerators and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then, component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the key switch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Potential causes of this fault code include:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault code can also be caused by a malfunctioning J1939 data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, a malfunctioning OEM VECU, or a malfunctioning Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-3488.

Last Modified: 13-Dec-2010


Real Time Clock - Abnormal Rate of Change

FAULT CODE 3492

Real Time Clock - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3492 PID: SPN: 251 FMI: 10 LAMP: Amber SRT: | Real Time Clock - Abnormal Rate of Change. The real time clock indicates a stuck engine off timer. | None on performance.
GX CM2250 - Engine Control Module (ECM)

Circuit Description

The real time clock consists of a timing chip internal to the electronic control module (ECM). It monitors engine off time, i.e., how long the engine has been shut down.

Component Location

The real time clock is a timing chip internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs after initial key ON and takes approximately 15 minutes to complete.

Conditions for Setting the Fault Codes

The engine off timer is not counting correctly and does not match other timers in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will not be able to monitor engine off time accurately.

Conditions for Clearing the Fault Code

  • To validate the repair, turn key OFF for 1 minute, then key ON for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Monitoring the engine off time is necessary to make sure that all other engine sensors and actuators are performing correctly. If the ECM is calibrated or replaced during the repair and the fault code is no longer present, the instructions in the "Conditions for Clearing the Fault Code" section must be followed in order for the diagnostic to run again and validate the repair.

Potential causes of this fault code include:

  • Malfunctioning real time clock chip internal to the ECM
  • Engine calibration issue.
Refer to Troubleshooting Fault Code t05-3492.

Last Modified: 07-Jan-2011


Diesel Particulate Filter Active Regeneration Inhibited Due to Low Exhaust Gas Temperature - Condition Exists

FAULT CODE 3495

Diesel Particulate Filter Active Regeneration Inhibited Due to Low Exhaust Gas Temperature - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3495 PID: SPN: 3711 FMI: 31 LAMP: Amber SRT: | Diesel Particulate Filter Active Regeneration Inhibited Due to Low Exhaust Gas Temperature - Condition Exists. The diesel oxidation catalyst intake temperature is not high enough to actively regenerate the diesel particulate filter. | None on performance.
GX CM2250 - Electronic Control Module (ECM)

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors that change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system, at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the engine has been started.

Conditions for Setting the Fault Codes

The diesel oxidation catalyst intake temperature is less than 150°C [302°F] for 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning variable geometry turbocharger (VGT)
  • An in-range malfunction of the aftertreatment diesel oxidation catalyst intake temperature sensor
  • Exhaust system leaks.
Refer to Troubleshooting Fault Code t05-3495.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3497

Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3497 PID: SPN: 1761 FMI: 17 LAMP: None SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level. The aftertreatment diesel exhaust fluid tank level is low. | None on performance.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Level Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The diesel exhaust fluid level sensor is located in the diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank level is low.

Action Taken When the Fault Code is Active

  • The Diesel Exhaust Fluid Lamp will be illuminated.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diesel exhaust fluid tank is refilled and the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code indicates that the diesel exhaust fluid level is low, and the tank must be refilled at the driver's earliest convenience.

Refer to Troubleshooting Fault Code t05-3497.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Exhaust Fluid (DEF) Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3498

Aftertreatment Diesel Exhaust Fluid (DEF) Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3498 PID: SPN: 1761 FMI: 18 LAMP: None SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. The aftertreatment DEF tank level is very low. | None on performance.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid (DEF) Tank Level Circuit

Circuit Description

The aftertreatment DEF level sensor is used to monitor the DEF level inside the DEF tank.

Component Location

The DEF level sensor is located in the DEF tank. Location of the tank and level sensor is OEM dependent.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF tank level is very low.

Action Taken When the Fault Code is Active

The DEF lamp will be flashing.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the DEF tank is refilled and the diagnostic runs and passes.
  • The ECM will turn off the DEF lamp immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the diesel exhaust fluid level is very low. The diesel exhaust fluid tank must be refilled.

Refer to Troubleshooting Fault Code t05-3498.

Last Modified: 13-Dec-2010


Wheel-Based Vehicle Speed - Received Network Data In Error

FAULT CODE 3525

Wheel-Based Vehicle Speed - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3525 PID: SPN: 84 FMI: 19 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the wheel-based vehicle speed sensor. | None on performance.
GX CM2250 - Vehicle Speed Sensor Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM VECU or transmission electronic control unit (TECU) in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link. Messages sent from the OEM VECU or transmission electronic control unit are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determines that there is a malfunction of the wheel-based vehicle speed sensor.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the wheel-based vehicle speed sensor.

Refer to Troubleshooting Fault Code t05-3525.

Last Modified: 13-Dec-2010


Wheel-Based Vehicle Speed - Abnormal Update Rate

FAULT CODE 3526

Wheel-Based Vehicle Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3526 PID: SPN: 84 FMI: 9 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the wheel-based vehicle speed sensor. | None on performance.
GX CM2250 - Vehicle Speed Sensor Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (TECU) in the cab. Then, component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the key switch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Possible causes of this fault code include:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that a component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, a damaged OEM VECU, or a damaged Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-3526.

Last Modified: 13-Dec-2010


Accelerator Pedal or Lever Idle Validation Switch - Received Network Data In Error

FAULT CODE 3527

Accelerator Pedal or Lever Idle Validation Switch - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3527 PID: P91 SPN: 558 FMI: 19 LAMP: Red SRT: | Accelerator Pedal or Lever Idle Validation Switch - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the accelerator pedal or lever idle validation switch. | The engine will only idle.
GX CM2250 - Accelerator Pedal or Lever Idle Validation Switch

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM VECU or transmission electronic control unit (TECU) in the cab. Then, component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from the OEM vehicle electronic control unit (VECU) or transmission electronic control unit are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswith is in the ON position, or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determines that there is a malfunction of the accelerator pedal or lever idle validation switch.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBC) engines, the ECM will turn off the MIL after three consecutive trips when the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the accelerator pedal or lever idle validation switch.

Refer to Troubleshooting Fault Code t05-3527.

Last Modified: 13-Dec-2010


Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

FAULT CODE 3528

Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3528 PID: SPN: 558 FMI: 9 LAMP: Red SRT: | Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the accelerator pedal or lever idle validation switch. | Engine will only idle.
GX CM2250 - Accelerator Pedal or Lever Idle Validation Switch Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (TECU) in the cab. Then, component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link. Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips when the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, damaged OEM VECU, or damaged Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.
Refer to Troubleshooting Fault Code t05-3528.

Last Modified: 10-Dec-2010


Ambient Air Temperature - Abnormal Update Rate

FAULT CODE 3531

Ambient Air Temperature - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3531 PID: SPN: 171 FMI: 9 LAMP: Amber SRT: | Ambient Air Temperature - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the ambient air temperature sensor. | Diesel exhaust fluid injection into the aftertreatment system may be disabled.
GX CM2250 - J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (TECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that a component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, damaged OEM VECU or damaged Cummins® ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-3531.

Last Modified: 13-Dec-2010


Ambient Air Temperature - Received Network Data In Error

FAULT CODE 3532

Ambient Air Temperature - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3532 PID: SPN: 171 FMI: 19/19 LAMP: Amber SRT: | Ambient Air Temperature - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the ambient air temperature sensor. | Diesel exhaust fluid injection into the aftertreatment system may be disabled.
GX CM2250 - J1939 Multiplexing

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM VECU or transmission electronic control unit (TECU) in the cab. Then, component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link. Messages sent from the OEM VECU or transmission electronic control unit are received by the Cummins® ECM and used for controlling the engine. The Cummins®. ECM and OEM VECU must be configured correctly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determines that there is a malfunction of the ambient air temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The J1939 multiplexing controller has indicated a mulfunction of the ambient air temperature sensor.

Refer to Troubleshooting Fault Code t05-3532.

Last Modified: 13-Dec-2010


Malfunction Indicator Lamp - Abnormal Update Rate

FAULT CODE 3535

Malfunction Indicator Lamp - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3535 PID: SPN: 1213 FMI: 9 LAMP: Amber SRT: | Malfunction Indicator Lamp - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the electronic control module (ECM) and the malfunction indicator lamp (MIL). | None on performance.
GX CM2250 - J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the ECM directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (TECU) in the cab. Then, component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips when the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that a component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, damaged OEM VECU or damaged Cummins® ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-3535.

Last Modified: 13-Dec-2010


NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists

FAULT CODE 3543

NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3543 PID: S115 SPN: 4094 FMI: 31 LAMP: Amber SRT: | NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists. The diesel exhaust fluid (DEF) quality is not sufficient enough to provide adequate NOx reduction. | Possible engine power derate. Vehicle speed may also be limited.
GX CM2250 - NOx Sensor Circuit

Circuit Description

The ECM monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The location of the DEF tank is OEM dependent. The SCR catalyst and aftertreatment NOx sensors are located in the vehicle's exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs after the DEF tank has been refilled. Specific engine and aftertreatment conditions must be met. NOx sensor data is gathered over varying engine speeds and loads. When enough data has been gathered, the diagnostic will run, make a pass/fail decision, and begin to gather data again.

Conditions for Setting the Fault Codes

The ECM detects that the NOx conversion across the SCR catalyst is lower than expected, and that the DEF tank has recently been refilled.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 km [5 miles] per hour after 20 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

After completing a stationary regeneration (as instructed in this fault code troubleshooting tree) and no additional faults become active, the repair has been validated. Note that this fault code will still be active.

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL).

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault codes.

The SCR control system is able to detect when anything other than pure DEF is in the DEF tank.

Possible causes of this fault include:

  • Malfunctioning diesel exhaust fluid dosing system
  • Exhaust system leaks
  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect DEF
  • DEF deposits in the decomposition tube.

This fault code can be set as a result of multiple malfunctions. All steps of the troubleshooting tree must be completed.

Refer to Troubleshooting Fault Code t05-3543.

Last Modified: 13-Dec-2010


Aftertreatment Outlet NOx Sensor - Abnormal Rate of Change

FAULT CODE 3545

Aftertreatment Outlet NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3545 PID: P2202 SPN: 3226 FMI: 10 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Circuit - Abnormal Rate of Change. The aftertreatment outlet NOx sensor reading is not valid. | None on performance.
GX CM2250 - Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature at the aftertreatment outlet NOx sensor is above 150°C [302° F] and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment outlet NOx sensor reading is not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the aftertreatment outlet NOx sensor indicates to the ECM that it is not providing valid data.

Troubleshoot the aftertreatment outlet NOx sensor for Fault Codes 1887, 2771, or 3681 before troubleshooting this fault code.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code t05-3545.

Last Modified: 14-Sep-2012


Aftertreatment Diesel Exhaust Fluid (DEF) Tank Empty - Condition Exists

FAULT CODE 3547

Aftertreatment Diesel Exhaust Fluid (DEF) Tank Empty - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3547 PID: S115 SPN: 4096 FMI: 31 LAMP: None SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Tank Empty - Condition Exists. The DEF tank is empty. | Immediate engine power derate. Possible vehicle speed limit.
GX CM2250 - Aftertreatment DEF Tank Circuit

Circuit Description

The aftertreatment DEF level sensor is used to monitor the DEF level inside the DEF tank.

Component Location

The DEF level sensor is located in the DEF tank. Location of the tank and level sensor is OEM dependent.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF tank is empty and the dosing unit is unable to prime.

Action Taken When the Fault Code is Active

  • The DEF lamp will be flashing.
  • DEF injection into the aftertreatment system is disabled.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 km [5 miles] per hour after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the DEF tank has been refilled, and the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the DEF tank is empty and must be refilled immediately. If the engine has been shut down or has idled for 20 hours after this fault code became active, the STOP ENGINE lamp will also be illuminated, along with the flashing DEF lamp and illuminated WARNING or CHECK ENGINE lamp. Engine power will continue to be reduced automatically. The vehicle will also be limited to 8 km [5 miles] per hour (MPH) speed limit. Normal engine power and vehicle speed will be restored after refilling the DEF tank.

Refer to Troubleshooting Fault Code t05-3547.

Last Modified: 13-Dec-2010


Aftertreatment Diesel Exhaust Fluid Controller - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3557

Aftertreatment Diesel Exhaust Fluid Controller - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3557 PID: SPN: 3360 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid controller has detected an invalid reading. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Controller Circuit

Circuit Description

The aftertreatment diesel exhaust fluid controller is the central control for the selective catalytic reduction (SCR) diesel exhaust fluid dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. The diesel exhaust fluid controller communicates to the electronic control module (ECM) via the J1939 data link connection.

Component Location

The location of the aftertreatment diesel exhaust fluid controller varies by application and OEM. The controller will typically be mounted to the vehicle frame or a suitable rigid bracket, using three or four capscrews. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

A reading that is too high or too low for the operating conditions has been detected on the sensor supply circuit between the diesel exhaust fluid controller and the dosing unit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel exhaust fluid controller is not serviceable, and must be replaced if malfunctioning.

Refer to Troubleshooting Fault Code t05-3557.

Last Modified: 04-Jan-2011


Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3558

Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3558 PID: SPN: 3361 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The diesel exhaust fluid controller provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The controller also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the aftertreatment diesel exhaust fluid dosing unit voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to battery voltage in the diesel exhaust fluid dosing unit
  • Short to battery voltage in the diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3558.

Last Modified: 04-Jan-2011


Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3559

Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3559 PID: SPN: 3361 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The diesel exhaust fluid controller provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The controller also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the aftertreatment diesel exhaust fluid dosing unit voltage is below a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the diesel exhaust fluid dosing unit
  • Short to ground in the diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3559.

Last Modified: 04-Jan-2011


Aftertreatment Diesel Exhaust Fluid Dosing Unit - Current Below Normal or Open Circuit

FAULT CODE 3561

Aftertreatment Diesel Exhaust Fluid Dosing Unit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3561 PID: SPN: 3361 FMI: 5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Current Below Normal or Open Circuit. Open circuit detected at the aftertreatment diesel exhaust fluid dosing unit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate aftertreatment diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The aftertreatment diesel exhaust fluid controller provides a battery voltage supply and a ground to the aftertreatment diesel exhaust fluid dosing unit. The controller also supplies a signal to the dosing unit to control the aftertreatment diesel exhaust fluid output. This signal changes, based on the aftertreatment diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftreatment diesel exhaust fluid controller detects that the diesel exhaust fluid dosing unit circuit is open.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the aftertreatment diesel exhaust fluid dosing unit
  • Open circuit in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3561.

Last Modified: 04-Jan-2011


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

FAULT CODE 3562

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3562 PID: SPN: 5491 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater relay. | Diesel exhaust fluid line heaters 1, 2, and 3 will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay provides the power supply to line heaters 1, 2, and 3, and is controlled by the aftertreatment diesel exhaust fluid controller.

Component Location

The aftertreatment diesel exhaust fluid line heater relay location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the voltage in the diesel exhaust fluid line heater relay circuit is above a calibratible value.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to battery voltage in the diesel exhaust fluid line heater relay circuit
  • Short to battery voltage in the diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3562.

Last Modified: 04-Jan-2011


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3563

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3563 PID: SPN: 5491 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid line heater relay. | Diesel exhaust fluid line heaters 1, 2, and 3 will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay provides the power supply to line heaters 1, 2, and 3, and is controlled by the aftertreatment diesel exhaust fluid controller.

Component Location

The aftertreatment diesel exhaust fluid line heater relay location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs at key OFF. The fault code will be active at the next key ON event.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the voltage in the diesel exhaust fluid line heater relay circuit is below a calibratible value.

Action Taken When the Fault Code is Active

The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the aftertreatment diesel exhaust fluid line heater relay circuit
  • Short to ground in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3563.

Last Modified: 04-Jan-2011


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Current Below Normal or Open Circuit

FAULT CODE 3564

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3564 PID: SPN: 5491 FMI: 5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Current Below Normal or Open Circuit. Open circuit detected at the diesel exhaust fluid line heater relay. | Diesel exhaust fluid line heaters 1, 2, and 3 will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay provides the power supply to line heaters 1, 2, and 3 and is controlled by the aftertreatment diesel exhaust fluid controller.

Component Location

The aftertreatment diesel exhaust fluid line heater relay location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the diesel exhaust fluid line heater relay circuit is open.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 km [5 miles] per hour after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the aftertreatment diesel exhaust fluid line heater relay circuit
  • Open circuit in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3564.

Last Modified: 04-Jan-2011


Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Above Normal or Shorted to High Source

FAULT CODE 3565

Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3565 PID: SPN: 5394 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid dosing valve. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the aftertreatment diesel exhaust fluid controller. When the engine electronic control module (ECM) commands aftertreatment diesel exhaust fluid dosing, the controller sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows diesel exhaust fluid to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the diesel exhaust fluid dosing valve voltage is above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, diesel exhaust fluid dosing must be commanded so that the dosing valve is actuated. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to battery voltage in the diesel exhaust fluid dosing valve
  • Short to battery voltage in the diesel exhaust fluid controller harness
  • Malfunctioning diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3565.

Last Modified: 04-Jan-2011


Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3566

Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3566 PID: SPN: 5394 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid dosing valve. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the aftertreatment diesel exhaust fluid controller. When the engine electronic control module (ECM) commands diesel exhaust fluid dosing, the diesel exhaust fluid controller sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows diesel exhaust fluid to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system and is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the diesel exhaust fluid dosing valve voltage is below a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, diesel exhaust fluid dosing must be commanded so that the dosing valve is actuated. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the diesel exhaust fluid dosing valve
  • Short to ground in the diesel exhaust fluid controller harness
  • Malfunctioning diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3566.

Last Modified: 04-Jan-2011


Aftertreatment Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit

FAULT CODE 3567

Aftertreatment Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3567 PID: SPN: 5394 FMI: 5 LAMP: Warning SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit. Open signal voltage detected at the diesel exhaust fluid dosing valve. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the aftertreatment diesel exhaust fluid controller. When the engine electronic control module (ECM) commands diesel exhaust fluid dosing, the diesel exhaust fluid controller sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows diesel exhaust fluid to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the diesel exhaust fluid dosing valve circuit is open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • An engine torque derate will be activated after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 km [5 mph] after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, diesel exhaust fluid dosing must be commanded so that the dosing valve is actuated. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the diesel exhaust fluid dosing valve
  • Open circuit in the diesel exhaust fluid controller harness
  • Malfunctioning diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3567.

Last Modified: 04-Jan-2011


Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Valve - Mechanical System Not Repsonding or Out of Adjustment

FAULT CODE 3568

Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Valve - Mechanical System Not Repsonding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3568 PID: SPN: 5394 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Valve - Mechanical System Not Responding or Out of adjustment. A mechanical malfunction has been detected in the DEF dosing valve. | DEF injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment DEF Dosing Valve Circuit

Circuit Description

The aftertreatment DEF dosing valve is controlled by the aftertreatment DEF controller. When the engine ECM commands DEF dosing, the DEF controller sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment DEF dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the DEF dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The DEF controller has detected a mechanical failure of the DEF dosing valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.
  • DEF injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, DEF dosing must be commanded so that the dosing valve is actuated. This can be done by performing the Aftertreatment DEF Doser Pump Override Test found under "ECM Diagnostic Tests" in INSITE™ electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault detects a mechanical malfunction of the DEF dosing valve or a pin-to-pin short in the DEF dosing valve circuit.

Contamination of the DEF can be a possible cause for this fault code.

Refer to Troubleshooting Fault Code t05-3568.

Last Modified: 02-Jan-2012


Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3569

Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3569 PID: S254 SPN: 3362 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment. An issue with diesel exhaust fluid delivery has been detected. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the dosing unit and dosing valve, and the other two lines are between the dosing unit and the diesel exhaust fluid tank. These lines can be partially hidden from view by the SCR system and other vehicle components. Line routing will vary, based on aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and dosing is being commanded.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller has detected a mechanical malfunction of the dosing input lines, and diesel exhaust fluid is not being delivered to the dosing valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8km [5 miles] per hour after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, diesel exhaust fluid dosing must be commanded so that the dosing valve is actuated. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault indicates that the diesel exhaust fluid dosing unit was able to build pressure, but could not complete the priming cycle. Troubleshoot all other active SCR related faults before this fault.

Possible causes of this fault code are:

  • Blocked or restricted aftertreatment dosing valve
  • Blocked or restricted aftertreatment dosing valve supply line.
Refer to Troubleshooting Fault Code t05-3569.

Last Modified: 21-Dec-2010


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 3571

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3571 PID: SPN: 4334 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid pressure sensor circuit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid controller provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the aftertreatment diesel exhaust fluid controller on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The aftertreatment diesel exhaust fluid controller will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the diesel exhaust fluid pressure sensor signal voltage is more than 4.75-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • SIGNAL wire shorted to sensor supply or battery voltage
  • Malfunctioning aftertreatment diesel exhaust fluid controller
  • Malfunctioning aftertreatment diesel exhaust fluid controller harness.
Refer to Troubleshooting Fault Code t05-3571.

Last Modified: 12-Jun-2012


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3572

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3572 PID: SPN: 4334 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid pressure sensor circuit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid controller provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the aftertreatment diesel exhaust fluid controller on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The aftertreatment diesel exhaust fluid controller will detect a low signal voltage at low aftertreatment diesel exhaust fluid pressures, and high signal voltage at high aftertreatment diesel exhaust fluid pressures. The aftertreatment diesel exhaust fluid pressure sensor reading is communicated to the engine control module (ECM) via the engine data link.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller detects that the diesel exhaust fluid pressure sensor signal voltage is less than 0.25-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • SIGNAL wire shorted to ground
  • Malfunctioning aftertreatment diesel exhaust fluid controller
  • Malfunctioning aftertreatment diesel exhaust fluid controller harness.
Refer to Troubleshooting Fault Code t05-3572.

Last Modified: 12-Jun-2012


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3574

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3574 PID: SPN: 4334 FMI: 18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low diesel exhaust fluid pressure has been detected in the dosing unit. | Diesel exhaust fluid injection into the aftertreatment system may be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The diesel exhaust fluid controller provides a 5 volt supply and a ground to the diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the diesel exhaust fluid controller on the sensor signal circuit. This sensor signal voltage changes, based on the diesel exhaust fluid pressure supplied by the dosing unit. The diesel exhaust fluid controller will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures. The aftertreatment diesel exhaust fluid pressure sensor reading is communicated to the engine control module (ECM) via the engine data link.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller detects that the dosing unit is unable to build or maintain adequate diesel exhaust fluid line pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 km [5 miles] per hour after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Troubleshoot other active SCR related faults before this fault.

Possible causes of this fault code include:

  • Low diesel exhaust fluid tank level
  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit supply line
  • Blocked or restricted diesel exhaust fluid tank filter
  • Blocked or restricted diesel exhaust fluid dosing unit filter
  • Blocked or restricted diesel exhaust fluid dosing unit supply line fitting
  • Malfunctioning diesel exhaust fluid dosing unit
  • Contaminated diesel exhaust fluid.
Refer to Troubleshooting Fault Code t05-3574.

Last Modified: 15-Jun-2012


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3575

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3575 PID: SPN: 4334 FMI: 16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid dosing unit has detected a blockage in the diesel exhaust fluid return flow. | Diesel exhaust fluid injection into the aftertreatment system can be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The diesel exhaust fluid controller provides a 5 volt supply and a ground to the diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the diesel exhaust fluid controller on the sensor signal circuit. This sensor signal voltage changes, based on the diesel exhaust fluid pressure supplied by the dosing unit. The diesel exhaust fluid controller will detect a low signal voltage at low diesel exhaust fluid pressures, and high signal voltage at high diesel exhaust fluid pressures. The aftertreatment diesel exhaust fluid pressure sensor reading is communicated to the engine control module (ECM) via the engine data link.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhuast fluid controller has detected that the diesel exhuast fluid pressure in the dosing unit is above 1250 kpa [181 PSI] for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 km [5 miles] per hour after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Troubleshoot other active SCR related fault codes before this fault code.

Possible causes of this fault code include:

  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit return line or return line fitting
  • Malfunctioning diesel exhaust fluid dosing unit.
Refer to Troubleshooting Fault Code t05-3575.

Last Modified: 14-Jun-2012


Aftertreatment Diesel Exhaust Fluid Tank Heater - Current Below Normal or Open Circuit

FAULT CODE 3576

Aftertreatment Diesel Exhaust Fluid Tank Heater - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3576 PID: SPN: 3363 FMI: 5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Current Below Normal or Open Circuit. Open circuit detected at the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heating will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Heater Control Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve that controls the flow of engine coolant to a heating coil inside the diesel exhaust tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The aftertreatment diesel exhaust fluid tank heater control valve is located near the aftertreatment diesel exhaust fluid tank. Specific location will vary, depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller detects that the diesel exhaust fluid tank heater circuit is open.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid tank heating will be disabled.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 km [5 miles] per hour after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

The aftertreatment diesel exhaust fluid tank heater control valve may be powered by an OEM suppied power relay, which is connected to the aftertreatment diesel exhaust fluid controller harness. When troubleshooting wiring harness issues, it may be necessary to include the optional line heater relay.

Possible causes of this fault code include:

  • Open circuit in the aftertreatment diesel exhaust fluid controller harness
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve
  • Malfunctioning aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code t05-3576.

Last Modified: 21-Dec-2010


Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

FAULT CODE 3577

Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3577 PID: SPN: 4376 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid return valve. | Aftertreatment diesel exhaust fluid return valve will be disabled. Selective catalytic reduction (SCR) system will not purge.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is controlled by the aftertreatment diesel exhaust fluid controller. The return valve position determines where afterteatment diesel exhaust fluid will flow as it exits the dosing unit. When the return valve is energized, the dosing system will purge and return the aftertreatment diesel exhaust fluid in the lines to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detects that the aftertreatment diesel exhaust fluid return valve voltage is more than a calibratible value for 1 second.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

If this fault code is active, the dosing system may not be able to purge, which means there will be aftertreatment diesel exhaust fluid left in the lines. Care must be taken when removing connections. Also, the lines could freeze and can become damaged in cold weather if the system is not properly purged.

Refer to Troubleshooting Fault Code t05-3577.

Last Modified: 21-Dec-2010


Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3578

Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3578 PID: SPN: 4376 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid return valve. | Diesel exhaust fluid return valve will be disabled. SCR system will not purge.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is controlled by the aftertreatment diesel exhaust fluid controller.The return valve position determines where diesel exhaust fluid will flow as it exits the dosing unit.When the return valve is activated, the dosing system will purge and return the diesel exhaust fluid in the lines to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller detects that the diesel exhaust fluid return valve voltage is less than a calibratible value for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault code is active, the dosing system may not be able to purge, which means there will be diesel exhaust fluid left in the lines. Care must be taken when removing connections. Also, the lines could freeze and become damaged in cold weather if the system is not properly purged.

Refer to Troubleshooting Fault Code t05-3578.

Last Modified: 21-Dec-2010


Aftertreatment Diesel Exhaust Fluid Return Valve - Current Below Normal or Open Circuit

FAULT CODE 3579

Aftertreatment Diesel Exhaust Fluid Return Valve - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3579 PID: SPN: 4376 FMI: 5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Current Below Normal or Open Circuit. Open circuit detected at the diesel exhaust fluid return valve. | Diesel exhaust fluid return valve will be disabled. SCR system will not purge.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is controlled by the aftertreatment diesel exhaust fluid controller. The return valve position determines where diesel exhaust fluid will flow as it exits the dosing unit. When the return valve is activated, the dosing system will purge and return the diesel exhaust fluid in the lines to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller detects that the diesel exhaust fluid return valve circuit is open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed byINSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnotics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault code is active, the dosing system may not be able to purge, which means there will be diesel exhaust fluid left in the lines. Care must be taken when removing connections. Also, the lines could freeze and become damaged in cold weather if the system is not properly purged.

Refer to Troubleshooting Fault Code t05-3579.

Last Modified: 21-Dec-2010


Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3582

Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3582 PID: SPN: 4364 FMI: 18 LAMP: Amber SRT: | Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level. NOx conversion across the SCR catalyst is too low. | None on performance.
GX CM2250 - Aftertreatment SCR Catalyst Conversion

Circuit Description

The engine control module (ECM) monitors the mono-nitrogen oxides (NOx) concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the selective catalystic reduction (SCR) catalyst and dosing system.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter and decomposition tube.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete. NOx sensor data is gathered over varying engine speeds and loads. When enough data has been gathered, the diagnostic will run, make a pass/fail decision, and begin to gather data again.

Conditions for Setting the Fault Codes

The ECM detects that the NOx conversion across the SCR catalyst is lower than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • After completing a stationary regeneration (as instructed in this fault code troubleshooting tree) and no additional faults become active, the repair has been validated.

NOTE: that this fault code will still be active.

  • It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and turn off the amber CHECK ENGINE lamp and/or MIL.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault code include:

  • Malfunctioning diesel exhaust fluid (DEF) dosing system
  • Exhaust system leaks
  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect DEF
  • Diesel exhaust fluid deposits in decomposition tube.

This fault code can be set as a result of multiple failure modes. All steps of the troubleshooting tree must be completed.

Refer to Troubleshooting Fault Code t05-3582.

Last Modified: 28-Mar-2014


Aftertreatment Outlet NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3583

Aftertreatment Outlet NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3583 PID: SPN: 5031 FMI: 10 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Heater - Abnormal Rate of Change. The aftertreatment outlet NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
GX CM2250 - Aftertreatment Outlet NOx Sensor Heater Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device that communicates with the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM, using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. In most cases, the sensor is located in the exhaust system at the outlet, of the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature at the aftertreatment outlet NOx sensor is above 150°C [302°F] and the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the NOx sensor heater is unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration with INSITE™ electronic service tool.
  • The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The" Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

  • A damaged aftertreatment outlet NOx sensor
  • Intermittent power connection to the aftertreatment outlet NOx sensor.
Refer to Troubleshooting Fault Code t05-3583.

Last Modified: 31-Dec-2010


Aftertreatment Diesel Exhaust Fluid (DEF) Pressure Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3596

Aftertreatment Diesel Exhaust Fluid (DEF) Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3596 PID: SPN: 4334 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Pressure Sensor - Data Erratic, Intermittent, or Incorrect. The DEF pressure sensor has reported a reading too high or low for the operating conditions. | DEF injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment DEF Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) controller provides a 5 volt supply and a ground to the DEF pressure sensor. The pressure sensor provides a signal to the DEF controller on the sensor signal circuit. The aftertreatment DEF pressure sensor is internal to the aftertreatment DEF dosing unit and can not be serviced separately. This sensor signal voltage changes, based on the DEF pressure supplied by the dosing unit. The DEF controller will detect a low signal voltage at low DEF pressures, and a high signal voltage at high DEF pressures. The aftertreatment DEF pressure sensor reading is communicated to the ECM via the engine data link.

Component Location

The aftertreatment DEF pressure sensor is internal to the dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs when the DEF dosing unit is fully primed, and is actively maintaining DEF pressure in the dosing system.

Conditions for Setting the Fault Codes

The dosing unit is unable to maintain the commanded DEF pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicaor lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Leaking DEF lines
  • Malfunctioning DEF dosing unit
  • Blocked or restricted DEF dosing unit supply line fitting
  • Blocked or restricted DEF filters
  • Malfunctioning DEF pressure sensor
  • Malfunctioning DEF controller.
Refer to Troubleshooting Fault Code t05-3596.

Last Modified: 31-Dec-2010


Aftertreatment Diesel Exhaust Fluid (DEF) Controller - Abnormal Update Rate

FAULT CODE 3597

Aftertreatment Diesel Exhaust Fluid (DEF) Controller - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3597 PID: SPN: 3360 FMI: 9 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Controller - Abnormal Update Rate. Data Link communications between the ECM and the aftertreatment DEF controller have been interrupted. | DEF injection into the SCR aftertreatment system is disabled.
GX CM2250 - Aftertreatment DEF Controller

Circuit Description

The aftertreatment DEF controller is the central control for the selective catalytic reduction (SCR) DEF dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. It communicates to the engine electronic control module (ECM) via a J1939 data link connection.

Component Location

The location of the aftertreatment DEF controller varies by application and OEM. The controller will typically be mounted to the vehicle frame or a suitable rigid bracket with three or four capscrews. Refer to the OEM service manual.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Data link communications between the ECM and the aftertreatment DEF controller have been lost.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8 km [5 miles] per hour after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn OFF the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Loss of battery voltage to the aftertreatment DEF controller
  • Loss of battery ground to the aftertreatment DEF controller
  • Loss of keyswitch input to the aftertreatment DEF controller
  • Shorted or open J1939 data link wiring between the aftertreatment DEF controller and the primary engine ECM
  • Damaged aftertreatment DEF controller
  • Blown or missing fuses on the battery voltage or keyswitch inputs to the aftertreatment DEF controller.
Refer to Troubleshooting Fault Code t05-3597.

Last Modified: 31-Dec-2010


Aftertreatment Diesel Exhaust Fluid (DEF) Controller - Received Network Data In Error

FAULT CODE 3598

Aftertreatment Diesel Exhaust Fluid (DEF) Controller - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3598 PID: SPN: 3360 FMI: 19 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Controller - Received Network Data In Error. The data being sent from the ECM to aftertreatment DEF controller is unreadable or missing. | DEF injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment DEF Controller

Circuit Description

The aftertreatment DEF controller is the central control for the aftertreatment DEF dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. It communicates to the engine ECM via a J1939 data link connection.

Component Location

The location of the aftertreatment DEF controller varies by application and OEM. The controller will typically be mounted to the vehicle frame or a suitable rigid bracket using 3 or 4 capscrews. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF controller was expecting to see valid J1939 data link messages from the engine ECM, but the actual data received was unreadable or missing.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Active fault codes for engine or aftertreatment sensors that provide inputs to the SCR system for dosing
  • Malfunctioning engine ECM
  • Corrupted engine calibration
  • Malfunctioning DEF controller
  • Corrupted DEF controller calibration
Refer to Troubleshooting Fault Code t05-3598.

Last Modified: 31-Dec-2010


Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3612

Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3612 PID: SPN: 3361 FMI: 7 LAMP: None SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit - Mechanical System Not Responding or Out of Adjustment. An incomplete powerdown has been detected by the SCR system. | None on performance.
GX CM2250 - Aftertreatment DEF Controller

Circuit Description

The DEF dosing unit performs many functions, one of which is to generate adequate DEF pressure in the lines, using a pump, to allow for dosing. The DEF controller provides a battery voltage supply and a ground to the DEF dosing unit. The controller also supplies a signal to the dosing unit to control the DEF output. This signal changes, based on the DEF pressure being commanded.

Component Location

The aftertreatment DEF dosing unit location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The ECM monitors and records occurances of both successful and unsuccessful purge cycles of the DEF dosing system. This fault is set active after a certain number of incomplete purge cycles have been detected.

Action Taken When the Fault Code is Active

  • The fault code will be set active immediately when the diagnostic runs and fails. This is a no lamp fault.

Conditions for Clearing the Fault Code

  • This fault code will not go inactive until the purge counters have been reset to zero using INSITE™ electronic service tool.
  • The purge counter reset function can be found in the "Advanced ECM Data" menu of INSITE™ electronic service tool.
  • Once the purge counters have been reset, the fault code will go inactive and can then be cleared with INSITE™ electronic service tool.

Shop Talk

The SCR system is programmed to automatically purge itself after the engine has been shut down. Immediately following key-OFF, the DEF return valve will be actuated and the dosing unit will pump any DEF left in the lines and dosing unit back to the DEF tank. The purge cycle can take up to 30 seconds.

This is an information only fault code that indicates that something is not allowing the DEF dosing unit to fully complete its purge cycle. Failure to complete the purge cycle could lead to deposits forming in the DEF system or damage to the dosing unit caused by freezing of the DEF. Make sure that battery power is not being removed from the SCR system immediately after engine shutdown via a main battery disconnect switch.

Refer to Troubleshooting Fault Code t05-3612.

Last Modified: 31-Dec-2010


Engine Variable Geometry Turbocharger (VGT) Nozzle Position - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3616

Engine Variable Geometry Turbocharger (VGT) Nozzle Position - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3616 PID: S27 SPN: 2633 FMI: 7 LAMP: None SRT: | VGT Actuator Position - Special Instructions. | Engine power may be derated.
GX CM2250 - Engine VGT Nozzle Position

Circuit Description

The VGT is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM with the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is initially turned to the ON position.

The keyswitch must be turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.

Conditions for Setting the Fault Codes

The ECM has detected an abnormal VGT position at key ON.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code 10 seconds after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.

The fault code will become inactive if the error condition no longer exists.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable corrections to the calibration stored in the ECM. If necessary, calibrate the ECM.

This is an informational fault code indicating that the VGT actuator was unable to go to the desired position at key ON. While active, the ECM will continuously attempt to restore normal VGT operation until the engine coolant temperature reaches 74°C [165°F].

If the condition continues to exist after the coolant reaches 74°C [165°F], Fault Code 2387 will become active and Fault Code 3616 will become inactive. Fault Code 2346 may set due to a resulting fueling derate.

Inspect the turbocharger vanes for residue, and clean the vanes, if required. Find the source of the residue and repair.

Refer to Troubleshooting Fault Code 3616.

Last Modified: 14-Nov-2014


Transmission Output Retarder - Abnormal Update Rate

FAULT CODE 3641

Transmission Output Retarder - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3641 PID: S231 SPN: 748 FMI: 9 LAMP: Amber SRT: | Transmission Output Retarder - Abnormal update rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the transmission output retarder. | None on performance.
GX CM2250 - Transmission Output Retarder

Circuit Description

Normally, switches, accelerators and other components are connected to the electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (TECU) in the cab. Then, component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission TECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn OFF the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips when the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM Vehicle Electronic Control Unit (VECU) source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, malfunctioning OEM VECU or malfunctioning Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use INSITE™ electronic service tool to monitor multiplexed components.
Refer to Troubleshooting Fault Code t05-3641.

Last Modified: 03-Jan-2011


Aftertreatment Diesel Exhaust Fluid (DEF) Controller Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3648

Aftertreatment Diesel Exhaust Fluid (DEF) Controller Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3648 PID: S254 SPN: 5480 FMI: 16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Controller Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The internal temperature of the DEF controller is above the warning limits. | DEF injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment DEF Controller Temperature

Circuit Description

The aftertreatment DEF controller is air cooled, and is equipped with an internal temperature sensor that monitors the temperature inside the controller during operation. This temperature sensor is internal to the DEF controller and can not be serviced separately. The DEF controller communicates this internal temperature reading to the engine ECM via a J1939 data link connection.

Component Location

The temperature sensor is internal to the DEF controller.

Conditions for Running the Diagnostics

This diagnostic runs during normal operation when dosing is being commanded by the SCR system.

Conditions for Setting the Fault Codes

The internal temperature of the DEF controller is above 114°F [238°C] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails for two consecutive trips.
  • DEF injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the DEF controller internal temperature falls below the warning limits and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Troubleshoot high inactive counts of Fault Code 3648 as an active fault code.

Possible causes of this fault code include:

  • Inadequate air flow to cool the DEF controller
  • Improper mounting of the DEF controller
  • Malfunctioning DEF controller.
Refer to Troubleshooting Fault Code t05-3648.

Last Modified: 07-Jan-2011


Aftertreatment Intake NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3649

Aftertreatment Intake NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3649 PID: SPN: 5024 FMI: 10 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor Heater - Abnormal Rate of Change. The aftertreatment intake NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
GX CM2250 - Aftertreatment Intake NOx Sensor Heater

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device that communicates with the engine electronic control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM, using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine, near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs when the exhaust gas temperature at the aftertreatment intake NOx sensor is above 150°C [302°F] and the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the NOx sensor heater is unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.
  • Cruise Control, Gear-Down Protection, and Road Speed Governor features will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool. The exhaust gas temperature at the aftertreatment intake NOx sensor must be above 150°C [302° F] before the sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to inactive immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips, when the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

  • Damaged aftertreatment intake NOx sensor
  • Intermittent power connection to the aftertreatment intake NOx sensor.
Refer to Troubleshooting Fault Code t05-3649.

Last Modified: 31-Dec-2010


Aftertreatment Diesel Exhaust Fluid (DEF) Tank Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3651

Aftertreatment Diesel Exhaust Fluid (DEF) Tank Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3651 PID: S254 SPN: 3031 FMI: 18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Tank Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. The DEF tank temperature is unable to reach its set point. | DEF injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment DEF Tank Temperature

Circuit Description

The aftertreatment DEF temperature sensor is used by the DEF controller to monitor the temperature of the aftertreatment DEF inside the DEF tank. The DEF controller monitors the voltage on the SIGNAL pin, converts it to a temperature value, and communicates that value to the ECM via the engine data link.

Component Location

The aftertreatment DEF temperature sensor is located in the DEF tank. The location of the tank, line heaters, and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the DEF tank temperature is being maintained by using the DEF tank heater or when line heating is being requested.

Conditions for Setting the Fault Codes

This fault code is set when the DEF tank temperature has been at normal operating levels, but is no longer able to maintain the proper temperature and the DEF is in danger of freezing.

This fault code can also set when heating of the DEF lines, tank, or dosing unit can not be achieved.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The DEF dosing unit will purge itself, and DEF injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • The fault code status in INSITE™ electronic service tool will change to INACTIVE immediately after the system is able to adequately heat and the diagnostic runs and passes. If heating can not be completed, use the "DEF Doser System Heater Test" found under "ECM Diagnostic Test" in the INSITE™ electronic service tool to command heating to the tank heater and all line heaters.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can also set if heating of the aftertreatment DEF lines can not be achieved. Troubleshoot all line heater fault codes prior to Fault Code 3651.

Possible causes of this fault code include:

  • Blocked or restricted coolant flow to the DEF tank heater
  • Disconnected or broken tank heater coolant supply hose
  • Malfuntioning or stuck closed DEF tank heater control valve
  • Operation in extremely cold ambient conditions.
Refer to Troubleshooting Fault Code t05-3651.

Last Modified: 31-Dec-2010


Aftertreatment Diesel Exhaust Fluid Dosing Unit - Root Cause Not Known

FAULT CODE 3679

Aftertreatment Diesel Exhaust Fluid Dosing Unit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3679 PID: SPN: 3361 FMI: 11 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Root Cause Not Known. The diesel exhaust fluid dosing unit has failed to initialize. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The diesel exhaust fluid dosing unit monitors its internal temperature and reports it back to the diesel exhaust fluid controller at initial key ON via the aftertreatment diesel exhaust fluid dosing unit signal/dosing unit temperature wire. After the temperature message has been sent from the dosing unit to the controller, this shared wire is switched over to be used for dosing unit pump control.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit and the diesel exhaust fluid controller are not able to acknowledge each other at key ON, and can not initialize.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short or open circuit in the aftertreatment wiring harness
  • Malfunctioning diesel exhaust fluid dosing unit.
Refer to Troubleshooting Fault Code t05-3679.

Last Modified: 21-Dec-2010


Aftertreatment Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3681

Aftertreatment Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3681 PID: P411 SPN: 3228 FMI: 2 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect. The aftertreatment outlet NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance
GX CM2250 - Aftertreatment Outlet NOx Sensor Power Supply

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system, at the outlet of the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature at the aftertreatment outlet NOx sensor is above 150°C [302°F].

Conditions for Setting the Fault Codes

The ECM has detected that the power supply to the outlet NOx sensor is above or below a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150° C [302° F] before the sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to battery or ground in the OEM harness
  • Open NOx sensor power supply circuit in the OEM harness
  • Incorrect system voltage set-up in INSITE™ electronic service tool
  • Internal malfunction of the outlet NOx sensor
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code t05-3681.

Last Modified: 21-Dec-2010


Aftertreatment Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3682

Aftertreatment Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3682 PID: P190 SPN: 3218 FMI: 2 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect. The aftertreatment intake NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance
GX CM2250 - Aftertreatment Intake NOx Sensor Power Supply

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the engine out NOx emissions.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature at the aftertreatment intake NOx sensor is above 150° C [302° F] and the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the power supply to the intake NOx sensor is above or below a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The exhaust gas temperature at the aftertreatment intake NOx sensor must be above 150° C [302° F] before the sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to battery or ground in the OEM harness
  • Open NOx sensor power supply circuit in the OEM harness
  • Incorrect system voltage set-up in INSITE™ electronic service tool
  • Internal malfunction of the intake NOx sensor
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code t05-3682.

Last Modified: 21-Dec-2010


Engine Control Module Calibration Memory - Bad Intelligent Device or Component

FAULT CODE 3697

Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3697 PID: S254 SPN: 630 FMI: 12 LAMP: amber SRT: | Engine Control Module Calibration Memory - Bad Intelligent Device or Component. Error internal to the ECM, related to a software or calibration error. | Engine may not start.
GX CM2250 - Electronic Control Module

Circuit Description

The engine control module (ECM) has internal diagnostics that continuously run and check for software errors or incompatibilities.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a software or calibration error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunction of the ECM software or calibration error.
Refer to Troubleshooting Fault Code t05-3697.

Last Modified: 02-Dec-2013


Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3712

Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3712 PID: P105 SPN: 5246 FMI: 0 LAMP: Red SRT: | Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level. Critical SCR related fault codes have been active for an extended period of time and require immediate attention. | Immediate engine power derate. Vehicle speed will be limited to 8 km [5 miles] per hour.
GX CM2250 - Aftertreatment SCR Operator Inducement

Circuit Description

The electronic control module (ECM) continuously monitors the engine's fault code status to determine if any critical SCR related fault codes are active.

Component Location

The ECM mounting location varies, depending on the engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine has been operated for an extended amount of time with critical SCR faults active, and no repair action has been taken. This amount of time will vary, depending on which SCR faults are active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • Immediate engine power derate.
  • Vehicle speed will be limited to 8 km [5 miles] per hour.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active SCR related fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate and vehicle speed limit have been implemented in order to make sure that the critical SCR related fault codes presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code t05-3712.

Last Modified: 18-Jan-2011


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3713

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3713 PID: S254 SPN: 5491 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment. A short circuit to the battery has been detected on the diesel exhaust fluid line heater power supply circuit. | Diesel exhaust fluid heaters 1, 2, and 3 will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Line Heater

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay provides the power supply to line heaters 1, 2, and 3. It is controlled by the aftertreatment diesel exhaust fluid controller.

Component Location

The aftertreatment diesel exhaust fluid line heater relay location is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs at key OFF.

Conditions for Setting the Fault Codes

Battery voltage has been detected at the diesel exhaust fluid line heaters when the line heater relay is commanded off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid line heating will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the keyswitch in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Switch side of the line heater relay stuck closed
  • Short to battery voltage in the wire between the relay and the line heater elements.
Refer to Troubleshooting Fault Code t05-3713.

Last Modified: 21-Dec-2010


Engine Protection Torque Derate - Condition Exists

FAULT CODE 3714

Engine Protection Torque Derate - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1569 FMI: 31 LAMP: Amber SRT: | Engine Protection Torque Derate - Condition Exists. Critical fault codes related to engine operation are active. | Immediate engine power derate.
GX CM2250 - Engine Protection Torque Derate

Circuit Description

The electronic control module (ECM) continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

For a detailed component location view, refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that certain critical fault codes related to engine operation are active and the engine has continued to operate.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Immediate engine power derate.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate has been implemented in order to make sure that the critical fault codes presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code t05-3714.

Last Modified: 21-Dec-2010


Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level.

FAULT CODE 3715

Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3715 PID: SPN: 188 FMI: 16 LAMP: Amber SRT: | Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine speed at idle has exceeded the governed idle speed. | The engine speed at idle has exceeded the governed idle speed.
GX CM2250 - ECM

Circuit Description

The electronic control module (ECM) continuously monitors the engine speed at idle and adjusts fueling to maintain governed idle speed.

Component Location

The engine speed is monitored by the crankshaft and/or camshaft position sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle and the PTO is not active.

Conditions for Setting the Fault Codes

The ECM detects that engine speed is 50 rpm above governed idle speed for 30 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) after this diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Fuel system malfunction
  • Crankshaft position sensor malfunction
  • Camshaft position sensor malfunction
  • Alternate fuel source entering the intake system
Refer to Troubleshooting Fault Code t05-3715.

Last Modified: 10-Jan-2011


Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3716

Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3716 PID: SPN: 188 FMI: 18 LAMP: Amber SRT: | Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine is not maintaining the governed idle speed. | None on performance.
GX CM2250 - ECM

Circuit Description

The electronic control module (ECM) continuously monitors the engine speed at idle and adjusts fueling to maintain governed idle speed.

Component Location

The engine speed is monitored by the crankshaft and/or camshaft position sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle and the PTO is not active.

Conditions for Setting the Fault Codes

The ECM detects that engine speed is 50 rpm below governed idle speed for 30 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) after this diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Fuel system malfunction
  • Crankshaft position sensor malfunction
  • Camshaft position sensor malfunction
  • Increased engine accessory load.
Refer to Troubleshooting Fault Code t05-3716.

Last Modified: 18-Jan-2011


Aftertreatment Outlet NOx Sensor - Out of Calibration

FAULT CODE 3717

Aftertreatment Outlet NOx Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3717 PID: SPN: 3226 FMI: 13 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Out of Calibration. A calibration mismatch between the aftertreatment outlet NOx sensor and the ECM has been detected. | None on performance.
GX CM2250 - Aftertreatment Outlet NOx Sensor Power Supply

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system, at the outlet of the aftertreatment selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

A mismatch has been detected between the engine's electrical system voltage and the NOx sensor voltage rating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Calibration incompatibility between aftertreatment outlet NOx sensor and ECM calibration
  • System voltage incorrect for installed aftertreatment outlet NOx sensor part number
  • Incorrect aftertreatment outlet NOx sensor is installed in exhaust system.
Refer to Troubleshooting Fault Code t05-3717.

Last Modified: 07-Jan-2011


Aftertreatment Intake NOx - Out of Calibration

FAULT CODE 3718

Aftertreatment Intake NOx - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3718 PID: SPN: 3216 FMI: 13 LAMP: Amber SRT: | Aftertreatment Intake NOx - Out of Calibration. A calibration mismatch between the aftertreatment intake NOx sensor and the ECM has been detected. | None on performance.
GX CM2250 - Aftertreatment Intake NOx Sensor Power Supply

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the engine-out NOx emissions.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine, near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

A mismatch has been detected between the engine's electrical system voltage and the NOx sensor voltage rating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Calibration incompatibility between aftertreatment intake NOx sensor and ECM calibration
  • System voltage is incorrect for the installed aftertreatment intake NOx sensor part number
  • Incorrect aftertreatment intake NOx sensor is installed in exhaust system.
Refer to Troubleshooting Fault Code t05-3718.

Last Modified: 07-Jan-2011


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3724

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3724 PID: P168 SPN: 168 FMI: 17 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Low voltage to the EGR valve device driver has been detected. | EGR valve actuation will be disabled.
GX CM2250 - Battery 1 Voltage - Data Valid But Below Normal Operating Range

Circuit Description

The exhaust gas recirculation (EGR) valve device driver in the electronic control module (ECM) provides power to the EGR valve motor. The EGR valve motor is used to move the EGR valve to the correct position, as commanded by the ECM.

Component Location

The EGR valve device driver is internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects low power at the EGR valve device driver. The ECM is no longer able to control the EGR valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The EGR valve device driver is disabled and can no longer control the EGR valve. The EGR valve will default to the closed position.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the low power condition is no longer present at the EGR valve device driver and the diagnostic runs and passes.

The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.

The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates an internal malfunction in the ECM.

Refer to Troubleshooting Fault Code t05-3724.

Last Modified: 10-Jan-2011


Aftertreatment Intake NOx Sensor - Abnormal Rate of Change

FAULT CODE 3725

Aftertreatment Intake NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3725 PID: P102 SPN: 3216 FMI: 10 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Abnormal Rate of Change. The aftertreatment intake NOx sensor reading is not valid. | None on performance.
GX CM2250 - Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (mono-nitrogen oxides) sensor is a smart device that receives commands from the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine, near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic operates when the diesel oxidation catalyst (DOC) intake temperature at the aftertreatment intake NOx sensor is above 200°C [392°F] and the engine is operating.

Conditions for Setting the Fault Codes

The aftertreatment intake NOx sensor reading is not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration. Use INSITE™ electronic service tool.
  • The DOC intake temperature at the aftertreatment intake NOx sensor must be above 200°C [392°F] before the sensor can perform its internal diagnostics.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • This fault code sets when the aftertreatment intake NOx sensor indicates to the ECM that it is not providing valid data.
  • Troubleshoot the aftertreatment intake NOx sensor for Fault Codes 1885, 3232, or 3682 before troubleshooting this fault code.

Reference the appropriate original engine manufacturer (OEM) wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM power distribution center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code t05-3725.

Last Modified: 14-Nov-2014


Aftertreatment Intake NOx - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3726

Aftertreatment Intake NOx - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3726 PID: SPN: 3216 FMI: 16 LAMP: Amber SRT: | Aftertreatment Intake NOx - Data Valid But Above Normal Operating Range - Moderately Severe Level. A high engine out NOx condition has been detected. | None on performance.
GX CM2250 - Aftertreatment Intake NOx Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the engine out NOx emissions.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine, near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature at the aftertreatment intake NOx sensor is above 150° C [302° F] and the engine is operating.

Conditions for Setting the Fault Codes

The ECM has detected that the engine out NOx levels are higher than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool. The exhaust gas temperature at the aftertreatment intake NOx sensor must be above 150° C [302° F] before the sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible cause of this fault code:

  • Engine performance issue causing increased NOx output.
Refer to Troubleshooting Fault Code t05-3726.

Last Modified: 21-Dec-2010


Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3733

Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3733 PID: SPN: 862 FMI: 3 LAMP: Amber SRT: | Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase breather heater circuit. | None on performance.
GX CM2250 - Crankcase Breather Filter Heater Circuit

Circuit Description

The crankcase breather heater is used to keep the crankcase breather filter housing from freezing. The engine control module (ECM) supplies 12-VDC to the breather heater when heating is commanded.

Component Location

The crankcase breather heater is mounted to the crankcase breather filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase breather heater signal voltage is greater than 1.5-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The crankcase breather heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short circuit to voltage in the crankcase breather heater circuit
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 3733.

Last Modified: 14-Nov-2014


Crankcase Breather Filter Heater Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 3734

Crankcase Breather Filter Heater Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3734 PID: P102 SPN: 862 FMI: 4 LAMP: Amber SRT: | Crankcase Breather Filter Heater Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the crankcase breather heater circuit. | None on performance.
GX CM2250 - Crankcase Breather Filter Heater Circuit

Circuit Description

The crankcase breather heater is used to keep the crankcase breather filter housing from freezing. The engine control module (ECM) supplies 12-VDC to the breather heater when heating is commanded.

Component Location

The crankcase breather heater is mounted to the crankcase breather filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase breather heater signal circuit is shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The crank case breather heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning ECM.
  • Open Crankcase Breather Heater Circuit
Refer to Troubleshooting Fault Code 3734.

Last Modified: 14-Nov-2014


Aftertreatment Diesel Exhaust Fluid Controller - Root Cause Not Known

FAULT CODE 3736

Aftertreatment Diesel Exhaust Fluid Controller - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3736 PID: S027 SPN: 3360 FMI: 11 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Root Cause Not Known. Unexpected data link communications between the ECM and the aftertreatment diesel exhaust fluid controller have occurred. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Controller

Circuit Description

The aftertreatment diesel exhaust fluid controller is the central control for the SCR diesel exhaust fluid dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. It communicates to the engine via an electronic control module (ECM), via a J1939 data link connection.

Component Location

The location of the aftertreatment diesel exhaust fluid controller varies by application and OEM. The controller will typically be mounted to the vehicle frame or a suitable rigid bracket using 3 or 4 capscrews. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

An unexpected data link message was sent from the ECM to the diesel exhaust fluid controller, and was unable to be interpreted.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Possible causes of this fault code include:

  • Incorrect data link termination resistance
  • Open or short circuit on the J1939 data link
  • Malfunctioning engine ECM
  • Corrupted engine calibration
  • Malfunctioning diesel exhaust fluid controller
  • Corrupted diesel exhaust fluid controller calibration.
Refer to Troubleshooting Fault Code t05-3736.

Last Modified: 21-Dec-2010


Aftertreatment Intake NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3748

Aftertreatment Intake NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3748 PID: SPN: 3216 FMI: 20 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Data Not Rational - Drifted High. An offset in the intake NOx sensor reading has been detected. | None on performance.
GX CM2250 - Aftertreatment Intake NOx Sensor

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the engine out NOx emissions.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine, near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part of the diagnostic runs when the exhaust gas temperature at the aftertreatment intake NOx sensor is above 150°C [302°F], and the engine is in a motoring condition. The second part of the diagnostic runs when the exhaust gas temperature at the aftertreatment intake NOx sensor is above 150°C [302°F], and the calculated NOx value is changing.

Conditions for Setting the Fault Codes

The ECM has detected the aftertreatment intake NOx sensor reading is not zero during motoring conditions for two consecutive trips, or the ECM has detected the aftertreatment intake NOx sensor reading is not changing with engine conditions for two consecutive trips.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately and/or malfunction indicator lamp (MIL) after the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The exhaust gas temperature at the aftertreatment intake NOx sensor must be above 150°C [302°F] before the sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn OFF the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment intake NOx sensor
  • Improperly installed aftertreatment intake NOx sensor.
Refer to Troubleshooting Fault Code t05-3748.

Last Modified: 21-Dec-2010


Aftertreatment Outlet NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3749

Aftertreatment Outlet NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3749 PID: S254 SPN: 3226 FMI: 20 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Data Not Rational - Drifted High. An offset in the outlet NOx sensor reading has been detected. | None on performance.
GX CM2250 - Aftertreatment Outlet NOx Sensor

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device that communicates with the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on the engine application. It is usually located in the exhaust system, at the outlet of the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part of the diagnostic runs when the exhaust gas temperature at the aftertreatment outlet NOx sensor is above 150°C [302°F], and the engine is in a motoring condition. The second part of the diagnostic runs when the exhaust gas temperature at the aftertreatment outlet NOx sensor is above 150°C [302°F], and the calculated NOx value is changing.

Conditions for Setting the Fault Codes

The ECM has detected that the aftertreatment outlet NOx sensor reading is not zero during motoring conditions for two consecutive trips, or the ECM has detected the aftertreatment outlet NOx sensor reading is not changing with engine conditions for two consecutive trips.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150° C [302° F] before the sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment outlet NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment outlet NOx sensor.
Refer to Troubleshooting Fault Code t05-3749.

Last Modified: 21-Dec-2010


Aftertreatment SCR Catalyst System - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3751

Aftertreatment SCR Catalyst System - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3751 PID: SPN: 4792 FMI: 7 LAMP: None SRT: | Aftertreatment SCR Catalyst System - Mechanical System Not Responding or Out of Adjustment. The ECM has detected a malfunctioning SCR catalyst. | None on performance.
GX CM2250 - Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using aftertreatment intake NOx and aftertreatment outlet NOx sensors. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter (DPF) and the decomposition tube.

Conditions for Running the Diagnostics

This diagnostic only runs during INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.

Conditions for Setting the Fault Codes

The ECM detects that the NOx conversion across the SCR catalyst is lower than expected, indicating a malfunctioning SCR catalyst.

Action Taken When the Fault Code is Active

The ECM will log the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code is only used to assist in troubleshooting Fault Codes 3151, 3543, and/or 3582.

Note: Do not replace the SCR catalyst if Fault Code 3751 is the only active fault.

Refer to Troubleshooting Fault Code t05-3751.

Last Modified: 09-Aug-2012


Diesel Particulate Filter Active Regeneration Inhibited Due to System Timeout - Condition Exists

FAULT CODE 3753

Diesel Particulate Filter Active Regeneration Inhibited Due to System Timeout - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3753 PID: SPN: 3713 FMI: 31 LAMP: None SRT: | Diesel Particulate Filter Active Regeneration Inhibited Due to System Timeout - Condition Exists. The system was unable to perform an active regeneration of the aftertreatment diesel particulate filter. | None on performance.
GX CM2250 - Electronic Control Module (ECM)

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and the electronic control module (ECM) is requesting active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The ECM detects that the system is requesting an active regeneration of the aftertreatment diesel particulate filter for an extended period of time.

Action Taken When the Fault Code is Active

The ECM will log the fault code immediately when the diagnostic runs and fails. The ECM will illuminate the Aftertreatment Diesel Particulate Filter lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code is an information only fault code indicating that the system was requesting an active regeneration of the aftertreatment system, but was unable to perform an active regeneration.

Refer to Troubleshooting Fault Code t05-3753.

Last Modified: 21-Dec-2010


Aftertreatment Diesel Exhaust Fluid Dosing Valve - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3755

Aftertreatment Diesel Exhaust Fluid Dosing Valve - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3755 PID: SPN: 5394 FMI: 2 LAMP: None SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Data Erratic, Intermittent, or Incorrect. The ECM has detected a problem in the diesel exhaust fluid dosing system. | None on performance.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Controller

Circuit Description

The electronic control module (ECM) monitors the NOx concentration in the engine's exhaust gases using a aftertreatment intake NOx and aftertreatment outlet NOx sensors. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The primary components of the SCR exhaust aftertreatment system are the SCR catalyst, diesel exhaust fluid (DEF) dosing unit, DEF controller, DEF dosing valve, DEF tank, decomposition tube, various DEF lines, intake NOx sensor, and outlet NOx sensor. The locations of these components will vary, depending on the vehicle application and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs only during INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.

Conditions for Setting the Fault Codes

The ECM detects a malfunction in the diesel exhaust fluid dosing system resulting in lower than expected NOx conversion across the SCR catalyst.

Action Taken When the Fault Code is Active

The ECM will log the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code is only used to assist in troubleshooting Fault Codes 3151, 3543, and/or 3582.

Refer to Troubleshooting Fault Code t05-3755.

Last Modified: 21-Dec-2010


Fault Code 3825 - Westport™ Data Share, Message 8 Fault (Stale Message)

FAULT CODE 3825

Fault Code 3825 - Westport™ Data Share, Message 8 Fault (Stale Message)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3825 PID: SPN: N/A FMI: N/A LAMP: Amber SRT: | Westport™ Data Share, Message 8 Fault (Stale Message). The diesel rail pressure data share message is not updating. | None on performance.
GX CM2250 - SAE J1939 Multiplexing Circuit

Circuit Description

The Westport™ engine fuel system CM850 electronic control module (ECM) sends messages to the Cummins® CM2250 ECM through the Cummins® Engine Network (CEN) data link. Message 8 refers to the message that contains the measured diesel rail pressure.

Component Location

The Cummins® CM2250 ECM is located on the cold side of the engine, below the fuel conditioning module. The two Westport™ CM850 controllers are typically mounted above the rear of the valve cover in the engine bay.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Within the data share message, there is a counter value. This fault is set when the Cummins® CM2250 controller has detected that the counter value no longer increments.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit in the Westport™ converter harness
  • Malfunction in the Cummins® engine network (CEN) signals
  • The Westport™ engine fuel system CM850 controller is not functioning properly.
Refer to Troubleshooting Fault Code t05-3825.

Last Modified: 11-Mar-2011


Fault Code 3838 - EEC3 Message Fault - Abnormal Update Rate

FAULT CODE 3838

Fault Code 3838 - EEC3 Message Fault - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3838 PID: SPN: N/A FMI: N/A LAMP: Amber SRT: | EEC3 Message Fault - Abnormal Update Rate. The EEC3 message, which includes parasitic losses percent torque (PLPT), has an abnormal update rate. | The CHECK ENGINE lamp illuminates.
GX CM2250 - SAE J1939 Multiplexing Circuit

Circuit Description

The Westport™ engine fuel system (EFS) CM850 electronic control unit (ECU) sends the EEC3 message to the Cummins® CM2250 engine control module (ECM) through the Cummins® engine network (CEN) data link. The EEC message primarily contains the PLPT data.

Component Location

The Cummins® CM2250 engine controller is located on the cold side of the engine, below the fuel conditioning module. The two Westport™ CM850 controllers are typically mounted above the rear of the valve cover in the engine bay.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECU does not receive a valid EEC3 message from the ECU for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code may appear in conjunction with Fault Codes 2361 and/or 285.

Possible causes of this fault code include:

  • Open or short circuit in the Westport™ converter harness
  • Westport™ engine fuel system ECU controller is not connected
  • Open or short circuit in the CEN
  • Malfunctioned Westport™ engine fuel system ECU controller.
Refer to Troubleshooting Fault Code t05-3838.

Last Modified: 09-Jul-2012


Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4157

Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4157 PID: SPN: 3361 FMI: 12 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment. An error has been detected in the aftertreatment diesel exhaust fluid dosing unit fluid return valve circuit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit precisely measures the amount of aftertreatment diesel exhaust fluid to be injected into the aftertreatment system. The aftertreatment diesel exhaust fluid dosing unit has three primary cycles. A priming cycle makes sure that aftertreatment diesel exhaust fluid is available at the aftertreatment diesel exhaust fluid dosing unit. During the dosing cycle, aftertreatment diesel exhaust fluid is being delivered to the aftertreatment dosing valve. A purge cycle occurs when the engine is turned OFF. The purge cycle makes sure that all the aftertreatment diesel exhaust fluid is removed from the diesel exhaust fluid lines and dosing valve.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid control unit detects that the aftertreatment diesel exhaust fluid dosing unit did not complete a full purge cycle after two attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the Aftertreatment Diesel Exhaust Fluid Leak Test using INSITE™ electronic service tool and allow the aftertreatment diesel exhaust fluid dosing system to prime and complete a purge cycle.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light after the diagnostic runs and passes.
  • For On Board Diagnostic (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Fault Code 4157 is triggered when the aftertreatment diesel exhaust fluid dosing unit has detected an error with the fluid return valve circuit.

Possible causes of this fault code include:

  • Short circuit to ground in the aftertreatment diesel exhaust fluid dosing unit signal/dosing unit fluid return valve wire
  • Malfunctioned or malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted diesel exhaust fluid lines
  • Blocked or restricted diesel exhaust fluid dosing unit supply/return line fittings.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code t05-4157.

Last Modified: 14-Nov-2014


Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4167

Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4167 PID: SPN: 5745 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater - Data Erratic, Intermittent, or Incorrect. An internal error has been detected in the aftertreatment diesel exhaust fluid (DEF) dosing unit. | Diesel exhaust fluid injection into the selective catalyst reduction (SCR) aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature Circuit

Circuit Description

The aftertreatment DEF dosing unit reports its internal temperature to the diesel exhaust fluid controller via the dosing unit SIGNAL wire. The DEF controller communicates this information to the primary engine control module (ECM) via the J1939 data link network.

Component Location

The aftertreatment DEF dosing unit location is original equipment manufacturer (OEM)-dependent. Refer to the OEM service manual for component location information.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned to the ON position, and continues until the diesel exhaust fluid dosing unit attempts to prime.

Conditions for Setting the Fault Codes

The aftertreatment DEF dosing unit internal temperature was not communicated to the ECM by the DEF controller, or the dosing unit temperature reading is erratic.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • After making the repair, use the "Reset All Faults" command in INSITE™ electronic service tool to clear active and inactive faults.
  • Start the engine and let it idle. If, after the engine idles for 10 minutes, the fault code is still not active, the repair has been validated.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning dosing unit
  • Short circuit to ground in the aftertreatment DEF dosing unit SIGNAL/dosing unit temperature wire
  • Aftertreatment DEF controller calibration is not the lastest version.
Refer to Troubleshooting Fault Code t05-4167.

Last Modified: 20-Nov-2014


Aftertreatment Diesel Exhaust Fluid Controller - Out of Calibration

FAULT CODE 4431

Aftertreatment Diesel Exhaust Fluid Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4431 PID: SPN: 3360 FMI: 13 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Out of Calibration. An internal error has been detected in the aftertreatment diesel exhaust fluid controller. | Aftertreatment diesel exhaust fluid dosing will be disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Controller Circuit

Circuit Description

The aftertreatment diesel exhaust fluid controller is the central control for the selective catalytic reduction (SCR) diesel exhaust fluid dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. It communicates with the engine via the engine control module (ECM) via a J1939 data link connection.

Component Location

The location of the aftertreatment diesel exhaust fluid controller varies by application and OEM. The controller will typically be mounted to the vehicle frame or suitable rigid bracket using three or four capscrews. Refer to the OEM service manual for a more detailed component location description.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fault code is activated when an internal error is detected in the aftertreatment diesel exhaust fluid controller and communicated with the ECM via the data link for two consecutive trips.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) when the diagnostic runs and fails for two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel exhaust fluid controller is not serviceable, and must be replaced when malfunctioning.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with aftertreatment omponents, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code t05-4431.

Last Modified: 30-Oct-2014


Aftertreatment 1 Diesel Particulate Filter Ash Load Percent - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5383

Aftertreatment 1 Diesel Particulate Filter Ash Load Percent - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5383 PID: SPN: 3720 FMI: 15 LAMP: Maintenance SRT: | Aftertreatment 1 Diesel Particulate Filter Ash Load Percent - Data Valid But Above Normal Operating Range - Least Severe Level. The aftertreatment diesel particulate filter (DPF) requires exchange or cleaning. | None.
GX CM2250 - Engine Control Module (ECM)

Circuit Description

The engine aftertreatment system monitors the aftertreatment DPF restriction and accumulated mileage and/or hours. The diagnostic alerts the operator of the requirement to clean or exchange the aftertreatment DPF.

Component Location

The aftertreatment DPF is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

This diagnostic monitors the aftertreatment DPF differential pressure sensor, mileage, and/or hours accumulated in the ECM. When the aftertreatment DPF differential pressure is above a maximum value at the end of an aftertreatment regeneration, or the mileage and/or hour limit has expired, the fault code is set.

Action Taken When the Fault Code is Active

The ECM will illuminate the MAINTENANCE lamp immediately after the diagnostic runs and fails for two consecutive trips.

Conditions for Clearing the Fault Code

  • In order to clear the fault code, the aftertreatment DPF must be exchanged or properly cleaned and the INSITE™ electronic service tool must be used to perform an Aftertreatment Diesel Particulate Filter Installation

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment DPF differential tubes are installed incorrectly, broken, loose, or have been tampered with.
  • The aftertreatment DPF differential tubes are installed incorrectly.
  • The aftertreatment DPF differential pressure sensor is malfunctioning.
  • The aftertreatment DPF requires exchange or cleaning.
Refer to Troubleshooting Fault Code t05-5383.

Last Modified: 14-Nov-2014


Aftertreatment Outlet NOx Sensor - Abnormal Rate of Change

FAULT CODE 3545

Aftertreatment Outlet NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

This procedure is not yet available at the time of publication.

Last Modified: 28-Aug-2012


Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668 (2-Wire Sensor)

Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 PID: P203C SPN: 1761 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid (DEF) tank level sensor circuit. | DEF into the selective catalytic reduction (SCR) aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment DEF tank level sensor is used to monitor the aftertreatment DEF level inside the aftertreatment DEF tank. The aftertreatment DEF tank level sensor is a combination sensor with the aftertreatment DEF temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The aftertreatment DEF tank level sensor is located in the aftertreatment DEF tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF controller detects that the DEF tank level signal voltage is less than 0.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or the MIL after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness
  • Signal circuit open or shorted to ground in the sensor
  • Supply line open or shorted to ground.

The type of DEF tank temperature and level sensor used can vary, depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Refer to Troubleshooting Fault Code t05-1668 (2-Wire Sensor).

Last Modified: 30-Nov-2010


Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668 (3-Wire Sensor)

Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 PID: P203C SPN: 1761 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid (DEF) tank level sensor circuit. | DEF injection into the selective catalytic reduction (SCR) aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment DEF tank level sensor is used to monitor the aftertreatment DEF level inside the aftertreatment DEF tank. The aftertreatment DEF tank level sensor is a combination sensor with the aftertreatment DEF temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The aftertreatment DEF tank level sensor is located in the aftertreatment DEF tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF controller detects that the DEF tank level signal voltage is less than 0.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or the MIL after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness
  • Signal circuit open or shorted to ground in the sensor
  • Supply line open or shorted to ground.

The type of DEF tank temperature and level sensor used can vary, depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Refer to Troubleshooting Fault Code t05-1668 (3-Wire Sensor).

Last Modified: 30-Nov-2010


Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669 (2-Wire Sensor)

Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 PID: P203D SPN: 1761 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst tank level sensor circuit. | Diesel exhaust fluid (DEF) injection into the selective catalytic reduction (SCR) aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment DEF tank level sensor is used to monitor the aftertreatment DEF level inside the aftertreatment DEF tank. The aftertreatment DEF tank level sensor is a combination sensor with the aftertreatment DEF temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The aftertreatment DEF tank level sensor is located in the aftertreatment DEF tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF controller detects that the DEF tank level signal voltage is greater than 4.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8km [5 miles] per hour, after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or the MIL after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.

The type of DEF tank temperature and level sensor used can vary, depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Refer to Troubleshooting Fault Code t05-1669 (2-Wire Sensor).

Last Modified: 30-Nov-2010


Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669 (3-Wire Sensor)

Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 PID: P203D SPN: 1761 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst tank level sensor circuit. | Diesel exhaust fluid (DEF) injection into the selective catalyst reduction (SCR) aftertreatment system is disabled.
GX CM2250 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment DEF tank level sensor is used to monitor the aftertreatment DEF level inside the aftertreatment DEF tank. The aftertreatment DEF tank level sensor is a combination sensor with the aftertreatment DEF temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The aftertreatment DEF tank level sensor is located in the aftertreatment DEF tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The DEF controller detects that the DEF tank level signal voltage is greater than 4.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced after 10 hours of engine operation with the fault code active.
  • Vehicle speed will be limited to 8km [5 miles] per hour, after 40 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or the MIL after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.

The type of DEF tank temperature and level sensor used can vary, depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Refer to Troubleshooting Fault Code t05-1669 (3-Wire Sensor).

Last Modified: 30-Nov-2010


Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2182

Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2182 PID: S079 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage or an open circuit detected at the engine brake solenoid 1 signal circuit. | Engine brake on cylinders 1, 2, and 3 can not be activated.
GX CM2250 - Engine Brake Actuator 1 Signal Circuit

Circuit Description

This circuit can be used to control either an exhaust brake or an engine brake, depending on the application. The electronic control module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 1 circuit PWM signal is detected to be greater than 0 volts when the PWM signal is turned OFF by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Short to voltage source in the engine harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2182.

Last Modified: 20-Nov-2014


Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2183

Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2183 PID: S079 SPN: 1072 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid 1 signal circuit. | Engine brake on cylinders 1, 2, and 3 can not be activated.
GX CM2250 - Engine Brake Actuator Driver 1 Circuit

Circuit Description

This circuit can be used to control either an exhaust brake or an engine brake, depending on the application. The electronic control module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the pulse width modulated (PWM) device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 1 circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Possible causes of this fault code include a short circuit to ground in the engine harness, connector, or engine brake solenoids.

Refer to Troubleshooting Fault Code t05-2183.

Last Modified: 20-Nov-2014


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at barometric pressure circuit. | Engine power derate.
GX CM2250 - Barometric Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes are related to the elevation where the engine is presently operating. The ambient air pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The ambient air pressure sensor provides a signal to the electronic control module (ECM) on the ambient air pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Some engines use a combination turbocharger compressor intake pressure/temperature sensor located in the OEM intake air plumbing to determine barometric pressure, rather than a barometric pressure sensor. Refer to the engine wiring diagram to determine which sensor the engine is equipped with.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure signal voltage is greater than 4.75-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the ambient pressure reading is used.
  • Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple faults codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-221.

Last Modified: 23-Nov-2010


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at barometric pressure circuit. | Engine power derate.
GX CM2250 - Barometric Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides the ambient air pressure sensor with a 5 volt supply circuit, a sensor signal voltage circuit, and a return circuit. The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness, near the ECM.

Some engines use a combination turbocharger compressor intake pressure/temperature sensor located in the OEM intake air plumbing to determine barometric pressure rather than a barometric pressure sensor. Refer to the engine wiring diagram to determine which sensor the engine is equipped with.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure signal voltage is less 0.25-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.
  • Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-222.

Last Modified: 23-Nov-2010


Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2363

Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S80 SPN: 1073 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid 2 signal circuit. | Engine brakes on cylinders 4, 5, and 6 can not be activated.
GX CM2250 - Engine Brake Solenoid Number 2 Signal Circuit

Circuit Description

The electronic control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid 2 signal circuit. There is a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 2 circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine brake solenoid 2 will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Possible causes for this fault code include:

  • Short circuit to ground in the engine harness, connectors, or engine brake solenoids
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2363.

Last Modified: 16-Dec-2014


Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2367

Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S80 SPN: 1073 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the engine brake solenoid 2 signal circuit. | Engine brakes on cylinders 4, 5, and 6 can not be activated.
GX CM2250 - Engine Brake Actuator Driver Output 2 Circuit

Circuit Description

The electronic control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid 2 signal circuit. There is a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 2 circuit PWM signal is detected to be system voltage when the PWM signal is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine brake solenoid 2 can not be energized.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Possible causes of this fault code include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Short to voltage source in the engine harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2367.

Last Modified: 16-Dec-2014


Aftertreatment Fuel Drain Valve - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2879

Aftertreatment Fuel Drain Valve - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2879 PID: S381 SPN: 4097 FMI: 2 LAMP: Amber SRT: | Aftertreatment Fuel Drain Valve - Data Erratic, Intermittent, or Incorrect. An internal or external fuel leak has been detected in the aftertreatment fuel system. | Active aftertreatment diesel particulate filter regeneration will be disabled.
GX CM2250 - Aftertreatment Fuel Injector System

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system, as well as malfunctions of the aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started, a diagnostic test on the system is performed. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel injector then briefly opens and relieves some of the fuel pressure trapped between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs:

  • During the first 5 minutes of engine operation.
  • Prior to injecting fuel for an active regeneration, but only if more than 2 hours have elapsed since the previous regeneration event or key ON.
  • After an active regeneration.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects an external fuel leak in the aftertreatment fuel system, internal fuel leakage past the aftertreatment fuel drain valve, or an aftertreatment fuel injector that can be leaking fuel into the exhaust system.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Internal or external leak in the aftertreatment fuel drain valve
  • Internal or external leak in the aftertreatment fuel injector
  • Loose fittings in the aftertreatment fuel system
  • External fuel leaks in the aftertreatment fuel system
  • Third-party aftertreatment fuel shutoff valve manifold
  • Fuel filter plugged.
Refer to Troubleshooting Fault Code t05-2879.

Last Modified: 04-Mar-2011


Barometric Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 295

Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 (ISX) PID: P108 SPN: 108 FMI: 2/2 LAMP: Amber SRT: | Barometric Pressure - Data Erratic, Intermittent, or Incorrect. An error in the barometric pressure sensor signal was detected by the ECM. | Engine power derate.
GX CM2250 - Barometric Pressure Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes are related to the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5 volt supply to the barometric pressure sensor on the sensor supply 2 circuit. The ECM also provides a ground on the sensor return circuit. The barometric pressure sensor provides a signal to the ECM on the barometric pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness, near the ECM.

Conditions for Running the Diagnostics

This diagnostic consists of two parts.

  • One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70°C [158°F].
  • The other part runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the barometric pressure reading is higher or lower than the other absolute pressure sensors on the engine, or an in-range malfunction of the sensor has been detected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the ambient pressure reading is used.
  • Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve will be closed.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, first make sure the engine coolant temperature is above 70°C [158°F]. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and let it idle for 30 seconds.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD engines.

Shop Talk

After key OFF when the engine is warm, the sensor readings for various engine pressure sensors on the engine are compared with the barometric pressure. This fault code occurs if the barometric pressure sensor reading is different from the other sensor readings. This fault code can also be set if a barometric pressure reading higher or lower than what is possible is detected.

Possible causes of this fault code include:

  • Malfunctioning barometric pressure sensor
  • High resistance in the barometric pressure sensor signal or return lines

Plugged or highly restricted air filters can also possibly cause this fault to become active, especially at higher altitudes.

Refer to Troubleshooting Fault Code t05-295.

Last Modified: 23-Nov-2010


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: S253 SPN: 630 FMI: 12 LAMP: Amber SRT: | Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component. Invalid switch configuration adjustable parameter setting have been detected by the engine control module (ECM). | Various optional switch inputs to the ECM may not operate correctly.
GX CM2250 - Engine Control Module (ECM)

Circuit Description

The original equipment manufacturer (OEM) wiring harness connects multiple outputs or switched inputs to the ECM which can be enabled or disabled with INSITE™ electronic service tool. Examples include the accelerator interlock/engine torque limit switch and the clutch/engine protection override switch. Many of the outputs and switched inputs share a common wire on the OEM wiring harness. Refer to the engine wiring diagram to determine which features share common wires in the OEM harness.

Component Location

The output or switched inputs to this diagnostic are found in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON only.

Conditions for Setting the Fault Codes

The ECM detects that features that share a common OEM harness input or output to the ECM are simultaneously enabled at the same time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The ECM will set the fault code active immediately after the diagnostic is set. The features that are in conflict may not operate correctly.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the conflicting features have been adjusted correctly and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If two features that share a common OEM wire are enabled simultaneously in the ECM, this fault code will be logged. To disable the fault code, disable one of the features on the shared OEM wire. For example, if the accelerator interlock switch and powertrain protection torque limit switch are both enabled in the ECM, either disable one of the features with INSITE™ electronic service tool or configure one of the features to be multiplexed using the SAE J1939 multiplexing feature.

Refer to Troubleshooting Fault Code t05-346.

Last Modified: 23-Nov-2010


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect. The engine oil pressure sensor is reading an erratic value. | None on performance. No engine protection for oil pressure.
GX CM2250 - Engine Oil Pressure Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70°C [158°F].

The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure reading is higher or lower than the other absolute pressure sensors on the engine after the keyswitch has been turned OFF and the engine has stopped running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, make sure the engine coolant temperature is above 70°C [158°F]. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Do not start the engine.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • Erratic engine oil pressure sensor reading
  • High resistance in the engine oil pressure sensor signal or return lines.
Refer to Troubleshooting Fault Code t05-435.

Last Modified: 23-Nov-2010


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 111 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 115 - Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 115. | Active or inactive counts of Fault Code 115?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 115.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 115?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete.

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Normal conditions:

  • At least +12 VDC (12 volt systems)
  • At least +24 VDC (24 volt systems).

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Feb-2017


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | IF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | IF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | IF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310840
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367219
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | Signature™ ISX and QSX15 | 3666259
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310840
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 40221704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367219
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | Signature™ ISX and QSX15 | 3666259
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310840
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367219
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Signature™ ISX and QSX15 | 3666259
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intemittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Replace the ECM. Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete.

Last Modified: 28-Apr-2017


FAULT CODE 131 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310840
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367219
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 43367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an active fault code. | Fault Code 131 active?
STEP 2. | Check the accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 131 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2185.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position sensor +5 SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active and Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal or lever.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 132 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310840
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB.ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367219
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310840
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367219
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 or 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 or 2186 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position +5 volt SUPPLY pin to the accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal position +5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active and Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES NO

A damaged accelerator pedal has been detected.

Replace the accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 133 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 or 1696 active?
 | STEP 1B. Check for an active fault code. | Fault Code 133 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 134 active and Fault Code 133 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal or lever condition. | Fault Code 134 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 133 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 or 1696 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Codes 1695 and/or 1696.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit supply voltage and return circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal position sensor +5 volt SUPPLY pin to the remote accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active and Fault Code 133 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal or lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO

A damaged remote accelerator pedal or lever has been detected.

Replace the remote accelerator pedal or lever. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever RETURN pin and the OEM harness remote accelerator pedal RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 134 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 134 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 133 active and Fault Code 134 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal or lever condition. | Fault Code 134 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 134 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal position +5 volt SUPPLY pin to the remote accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the remote accelerator pedal position +5 volt SUPPLY pin and the remote accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Refer the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active and Fault Code 134 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO

A damaged remote accelerator pedal has been detected.

Replace the remote accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SUPPLY pin and the OEM harness remote accelerator pedal or lever connector SUPPLY pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SIGNAL pin and the OEM harness remote accelerator pedal connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Jul-2017


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISM11 CM876 SN | 4022196
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISZ13 CM2150 | 4022133
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2250 | 4022256
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2250 | 4022255
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2250 EC | 2883621
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX15 CM2250 ECF | 2883557
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 | 4310664
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | Marine QSB6.7 CM2250 | 4310611
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9 CM2350 L101 | 4310787
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX12 CM2350 X102 | 4310646
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX15 CM2350 X101 | 4310641
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB6.7 CM2350 B103 | 4332641
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK19 CM2350 K105 | 4326157
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK50 CM2350 K108 | 4332823
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK95 CM2350 K111 | 4358519
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | VTA903 CM2250 V105 | 4332841
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B105 | 4332778
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L102 | 4332796
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 M CM2250 L106 | 4358343
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9 CM2350 L111 | 4367223
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B112 | 4358498
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2350 B106 | 4367376
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K116 | 4367444
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2350 G110 | 4367323
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K117 | 4367449
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK23 CM2250 K109 | 4367358
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2250 B128 | 4388601
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2250 L115 | 4388626
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2250 K112 | 4367454
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L107 | 4367386
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B130 | 4388668
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L118 | 4388673
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSF3.8 CM2350 F118 | 4388708
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSF3.8 CM2350 F119 | 4388703
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K121 | 4388645
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2350 B122 | 4388767
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2250 B131 | 4388774
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB3.3 CM2250 B137 | 5411058
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX15 CM2250 X115 | 4388739
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB6.7 CM2350 B142 | 5411131
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | X15 CM2350 X114B | 5411181
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | X15 CM2350 X116B | 5411186
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L116B | 5411330
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B4.5 CM2350 B129B | 5411247
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B4.5 CM2350 B147B | 5411252
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 CM2350 B135B | 5411257
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 CM2350 B148B | 5411262
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L119B | 5411267
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B145 | 5411273
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L122 | 5411278
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2350 B144 | 5411382
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L123B | 5411465
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSF3.8 CM2350 F125 | 5411494
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX15 CM2350 X118 | 5467247
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISM11 CM876 SN | 4022196
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISZ13 CM2150 | 4022133
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2250 | 4022256
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 | 4022255
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 EC | 2883621
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2250 ECF | 2883557
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 | 4310664
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | Marine QSB6.7 CM2250 | 4310611
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL9 CM2350 L101 | 4310787
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX12 CM2350 X102 | 4310646
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX15 CM2350 X101 | 4310641
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX15 CM2250 SN | 4310736
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB6.7 CM2350 B103 | 4332641
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK19 CM2350 K105 | 4326157
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK78 CM2250 K104 | 4332682
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK95 CM2350 K111 | 4358519
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK50 CM2350 K108 | 4332823
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | VTA903 CM2250 V105 | 4332841
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B105 | 4332778
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L102 | 4332796
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 M CM2250 L106 | 4358343
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL9 CM2350 L111 | 4367223
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B112 | 4358498
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2350 B106 | 4367376
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2350 K116 | 4367444
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSG12 CM2350 G110 | 4367323
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2350 K117 | 4367449
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK23 CM2250 K109 | 4367358
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2250 K112 | 4367454
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L107 | 4367386
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B130 | 4388668
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L118 | 4388673
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSF3.8 CM2350 F118 | 4388708
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSF3.8 CM2350 F119 | 4388703
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2350 K121 | 4388645
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2350 B122 | 4388767
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 B128 | 4388601
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2250 B131 | 4388774
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB3.3 CM2250 B137 | 5411058
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2250 X115 | 4388739
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB6.7 CM2350 B142 | 5411131
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | X15 CM2350 X114B | 5411181
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | X15 CM2350 X116B | 5411186
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L116B | 5411330
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B4.5 CM2350 B129B | 5411247
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B4.5 CM2350 B147B | 5411252
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B6.7 CM2350 B135B | 5411257
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B6.7 CM2350 B148B | 5411262
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L119B | 5411267
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B145 | 5411273
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L122 | 5411278
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2350 B144 | 5411382
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L123B | 5411465
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSF3.8 CM2350 F125 | 5411494
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2350 X118 | 5467247
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Use the following troubleshooting symptom tree, Lubricating Oil Pressure Low or Lubricating Oil Pressure High in Section TS, in the appropriate service manual.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Mar-2013


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 | 4310664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 EC | 2883621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine QSB6.7 CM2250 | 4310611
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK78 CM2250 K104 | 4332682
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L106 | 4358343
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | VTA903 CM2250 V105 | 4332841
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2250 K112 | 4367454
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 | 4310664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 EC | 2883621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine QSB6.7 CM2250 | 4310611
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK78 CM2250 K104 | 4332682
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L106 | 4358343
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | VTA903 CM2250 V105 | 4332841
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2250 K112 | 4367454
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Refer to Procedure 019-043 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS of the appropriate service manual.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate faultcode troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor.

Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISV5.0 CM3230 V104 | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the engine harness intake manifold air temperature sensor connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for QSK78, QSK23, and ISV5.0 engines. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Use the following procedure for all engines except QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4327291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for ISV5.0 and QSK78 engines. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Use the following procedure for all engines except IISV5.0 and QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISM/QSM11 CM570 | 3666266
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Monitor intake manifold air temperature reading.

Guided Step 1A - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in the appropriate service manual.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for all engines except QSM11 and QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.
  • Use the following procedure for QSM11 and QSK78 engines. Refer to Procedure 019-059 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM3250 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISM11 CM876 SN | 4022196
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISZ13 CM2150 | 4022133
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2250 ECF | 2883557
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12 CM2350 X102 | 4310646
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2350 X101 | 4310641
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2350 K116 | 4367444
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2350 K117 | 4367449
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 SN | 4310736
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK95 CM2350 K111 | 4358519
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK23 CM2250 K109 | 4367358
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G110 | 4367323
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2250 K112 | 4367454
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2250 X115 | 4388739
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X114B | 5411181
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X116B | 5411186
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G113 | 5467252
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 212 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 213 active and Fault Code 212 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 is active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active and Fault Code 212 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor RETURN pin and the engine harness engine oil temperature sensor connector RETURN pin.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor SIGNAL pin and the engine harness engine oil temperature sensor connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signalcircuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISM11 CM876 SN | 4022196
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISZ13 CM2150 | 4022133
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2250 ECF | 2883557
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12 CM2350 X102 | 4310646
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2350 X101 | 4310641
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 SN | 4310736
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK95 CM2350 K111 | 4358519
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G110 | 4367323
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2350 K116 | 4367444
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2350 K117 | 4367449
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK23 CM2250 K109 | 4367358
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2250 K112 | 4367454
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2250 X115 | 4388739
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X114B | 5411181
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X116B | 5411186
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G113 | 5467252
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault code. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent and inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 214 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 214. | Fault Code 214 active or inactive with more than one count logged in the last 25 hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 214.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active or inactive with more than one count logged in the last 25 hours?
YES | NO
No Repair | No Repair

Reference the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2017


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Do not operate a diesel engine where there are or can be combustible vapors. These vapors can be sucked through the air intake system and cause engine acceleration and over speeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of over speeding where an engine, due to the application, is operating in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. The equipment owner and operator are responsible for safe operation in a hostile environment. Contact a Cummins® Authorized Repair Location for further information.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring down hill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring down hill?
YES NO
No Repair

Check for engine damage.

  • Electronics are ok.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 3400 rpm, followed by moderate deceleration to 3400 rpm.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is operating.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 1D

Troubleshoot Fault Codes 689 and 778.

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234 when the engine is not operating above 3200 rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test or the vessel in a sea trail to determine if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-May-2017


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K117 | 4367449
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine position sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Check ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 L121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 L121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 active?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 239 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 3 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 241 - Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle settings in INSITE™ electronic service tool. |
 | STEP 1A. Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match. | Settings in INSITE™ electronic service tool match the vehicle configuration?
STEP 2. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the OEM harness pins and the sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the OEM harness connector pins at the ECM. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check for additional OEM devices. |
 | STEP 3A. Check the vehicle speed sensor circuit for additional devices. | Extra devices?
 | STEP 3B. Check for the gear slipping on the shaft. | Gear or tone wheel damaged or slips?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the vehicle settings in INSITE™ electronic service tool.

Guided Step 1A - Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool. Go to Features and Parameters and verify the following parameters match the vehicle configuration.

  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type

The settings in INSITE™ electronic service tool match the vehicle configuration?
YES NO
No Repair

Change the settings in the ECM with INSITE™ electronic service tool to match the vehicle configuration.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness pins and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Repair the damaged connector pins.
  • Repair or replace the engine harness with the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM harness connector pins at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter, check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the ECM connector and engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for additional OEM devices.

Guided Step 3A - Check the vehicle speed sensor circuit for additional devices.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle speed sensor circuit.

  • Inspect the vehicle speed sensor circuit for any additional or extra devices that can interfere with the speed signal.

Extra devices?
YES NO

Remove the device or see equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for the gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • Remove the vehicle speed sensor from the transmission.

Action

Check for the gear slipping.

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal. Make sure the gear or tone wheel is not damaged or slipping on the shaft.

Gear or tone wheel damaged or slips?
YES NO

See equipment manufacturer service information to repair or replace the gear or tone wheel.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Nov-2015


FAULT CODE 242 - Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the feature settings are correct. |
 | STEP 1A. Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled. | Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
 | STEP 1B. Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match. | Setting in INSITE™ electronic service tool matches the speed sensor type on vehicle?
 | STEP 1C. Verify that the Anti-Tampering Sensitivity Level is set correctly for the application. | Sensitivity level set correctly?
STEP 2. | Look for signs or evidence of tampering. |
 | STEP 2A. Inspect the vehicle speed sensor. | Tampering evidence, incorrect installation, or external device present?
 | STEP 2B. Check for open circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check the vehicle speed reporting. |
 | STEP 3A. Use INSITE™ electronic service tool to monitor the vehicle speed signal. | INSITE™ electronic service tool readout and the vehicle speedometer match?
 | STEP 3B. Verify the vehicle speed. | Vehicle speed is accurate?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Verify that the feature settings are correct.

Guided Step 1A - Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled.

Action

Verify that the customer wants Vehicle Speed Sensor Anti-Tampering feature enabled.

Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Vehicle Speed Sensor Anti-Tampering feature.

Go to 1B

Go to 4A

Guided Step 1B - Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.

  • Verify that the Vehicle Speed Sensor Type parameter setting in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

Setting in INSITE™ electronic service tool matches the speed sensor type on vehicle?
YES NO
No Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 1C

Go to 4A

Guided Step 1C - Verify that the Anti-Tampering Sensitivity Level is set correctly for the application.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify that the Vehicle Speed Signal Tampering Sensitivity Level is set correctly for the application.

  • Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.
  • Check the ECM setting for Vehicle Speed Signal Tampering Sensitivity Level.

Sensitivity Level set correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to set the Vehicle Speed Signal Tampering Sensitivity Level to the correct value for the vehicle.

Go to 2A

Go to 4A

Guided Step 2 - Look for signs or evidence of tampering.

Guided Step 2A - Inspect the vehicle speed sensor.

Action

Inspect the vehicle speed sensor for the following:

  • Improper mounting of the vehicle speed sensor
  • Vehicle speed sensor improperly connected to the OEM harness
  • Other external device connected in place of the vehicle speed sensor
  • Any evidence that tampering with the vehicle speed sensor has taken place.

Tampering evidence, incorrect installation, or external device present?
YES NO

Remove the tampering device.

Install the sensor correctly or remove the external device.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the vehicle speed reporting.

Guided Step 3A - Use INSITE™ to monitor the vehicle speed signal.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the vehicle speed.

  • Verify that the vehicle speed is 0 when the vehicle is stationary and the engine is operating.
  • Drive the vehicle or run on a chassis dynamometer. Compare the vehicle speed reading by INSITE™ electronic service tool to the speedometer on the dash.

INSITE™ electronic service tool readout and the vehicle speedometer match?
YES NO
No Repair

Verify that the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correctly in the ECM.

Go to 3B

Go to 4A

Guided Step 3B - Verify the vehicle speed.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Vehicle moving.

Action

Use INSITE™ electronic service tool to verify that the speed reported is accurate or reasonable for the present gear.

  • (For example: 64 km/h [40 mph] in top gear is probably inaccurate data.)

Vehicle speed is accurate?
YES NO
No Repair

Verify that the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correctly in the ECM.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Mar-2017


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60.8 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X105 | 4332667
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X106 | 4332712
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5411484

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control solenoid. | Within the original equipment manufacturer (OEM) resistance specification?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the fan control solenoid. |
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage and supply wire. | Greater than 5 VDC?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 245 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the fan control solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

See equipment manufacturer service information.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage and supply wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and supply line.

  • Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin at the OEM harness actuator connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 249 - Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 249 inactive?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 256 active and Fault Code 249 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 249 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 249 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and the ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the ambient air temperature SIGNAL pin and the ambient air temperature RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active and Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES NO

A damaged ambient air temperature sensor has been detected.

Replace the ambient air temperature sensor. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor RETURN pin and the OEM harness ambient air temperature sensor connector RETURN pin.

Use a wiring diagram for pin identificaton and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor SIGNAL pin and the OEM harness ambient air temperature sensor connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 256 - Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 256 inactive?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 249 active and Fault Code 256 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 256 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 256 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active and Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES NO

Replace the ambient air temperature sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the equipment manufacturer service information, vehicle electronic control unit (VECU), and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES NO
No Repair

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Reference the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the equipment manufacturer service information, VECU, and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper original equipment manufacturer (OEM) VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the equipment manufacturer service information. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES NO
No Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair Complete

Guided Step 2 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jan-2016


FAULT CODE 288 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 288 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the remote accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of 0?
 | STEP 3B. Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than 0?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 288 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the ECM and compare to the engine ECM configuration

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the remote accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the remote throttle switch is ON and the remote accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Status/Idle Validation

Monitor parameters can possibly notappear in the electronic service tool exactly as listed above.

When the remote throttle is released, the Remote Throttle Switch parameter mustdisplay ON and the Percent Throttle parameter mustdisplay a value of 0.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of 0?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, the remote throttle, or the OEM VECU. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the remote throttle switch and or remote throttle parameters are being received properly by the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the remote throttle switch is ON and the remote accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Switch Status

Monitor parameters can possibly notappear in the electronic service tool exactly as shown above.

When the remote throttle is depressed, the Remote Throttle Switch parameter mustdisplay ON and the Percent Throttle parameter mustdisplay a value greater than 0.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than 0?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, or the remote throttle, or the OEM VECU. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Mar-2017


FAULT CODE 319 - Real Time Clock - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2220 F103 | 4310839
Real-Time Clock Battery | Refer to Procedure 019-311 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Real-Time Clock Battery | Refer to Procedure 019-311 | ISL8.9 CM2150 SN | 4022190
Real-Time Clock Battery | Refer to Procedure 019-311 | ISB/ISD4.5 CM2150 B119 | 4358465
Real-Time Clock Battery | Refer to Procedure 019-311 | ISB/ISD6.7 CM2150 B120 | 4358470
Real-Time Clock Battery | Refer to Procedure 019-311 | ISL8.9 CM2150 L110 | 4358475
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2220 F110 | 4358480
Real-Time Clock Battery | Refer to Procedure 019-311 | ISL9 CM2350 L111 | 4367223
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF3.8 CM2350 F109 | 4367218
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF2.8 CM2220 F117 | 4388578
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF2.8 CM2220 F126 | 5411159
Real-Time Clock Battery | Refer to Procedure 019-311 | ISB6.7 CM2350 B142 | 5411131
Real-Time Clock Battery | Refer to Procedure 019-311 | F3.8 CM2350 F120B | 5411237
Real-Time Clock Battery | Refer to Procedure 019-311 | B4.5 CM2350 B129B | 5411247
Real-Time Clock Battery | Refer to Procedure 019-311 | B4.5 CM2350 B147B | 5411252
Real-Time Clock Battery | Refer to Procedure 019-311 | B6.7 CM2350 B135B | 5411257
Real-Time Clock Battery | Refer to Procedure 019-311 | B6.7 CM2350 B148B | 5411262
Real-Time Clock Battery | Refer to Procedure 019-311 | L9 CM2350 L119B | 5411267
Real-Time Clock Battery | Refer to Procedure 019-311 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the real-time clock battery and connections. |
 | STEP 1A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the real-time clock battery voltage at the ECM harness connector. | Between 3.2 and 4.0 VDC??
 | STEP 1B-1. Inspect the real-time clock battery and engine wire harness connector pins. |
 | STEP 1B-2. Check the real-time clock battery voltage at the battery module connector. |
STEP 2. | Check the battery module harness. |
 | STEP 2A. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the real-time clock battery and connections.

Guided Step 1A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab..

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the real-time clock battery voltage at the ECM harness connector.

Conditions

  • Engine equipped with optional real-time clock battery.
  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the real-time clock battery voltage.

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 3.2 and 4.0 VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1B-1

Guided Step 1B-1 - Inspect the real-time clock battery and engine wire harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Inspect the real-time clock battery and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the real-time clock battery or engine harness.

  • Repair or replace the real-time clock battery. Refer to Procedure 019-311 in the Associated Procedures Table.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1B-2

Guided Step 1B-2 - Check the real-time clock battery voltage at the battery module connector.

Conditions

  • Engine equipped with optional real-time clock battery.
  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check the real-time clock battery voltage.

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the real-time clock battery connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 3.2 and 4.0 VDC?
YES NO
No Repair

Replace the real-time clock battery. Refer to Procedure 019-311 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the battery module harness.

Guided Step 2A - Check for an open circuit in the engine harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the following resistance:

  • The resistance between the real-time clock battery SUPPLY pin at the battery connector of the engine harness to the real-time clock battery SUPPLY pin at the ECM harness connector
  • The resistance between the real-time clock battery RETURN (-) pin at the battery connector of the engine harness to the real-time clock battery RETURN (-) pin at the ECM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 27-Apr-2017


FAULT CODE 334 - Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Thermostat | Refer to Procedure 008-013 | ISF2.8 CM2220 AN | 4022178
Coolant Thermostat | Refer to Procedure 008-013 | ISF3.8 CM2220 AN | 4021708
Coolant Thermostat | Refer to Procedure 008-013 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Coolant Thermostat | Refer to Procedure 008-013 | ISL8.9 CM2150 SN | 4022190
Coolant Thermostat | Refer to Procedure 008-013 | ISM11 CM876 SN | 4022196
Coolant Thermostat | Refer to Procedure 008-013 | ISZ13 CM2150 | 4022133
Coolant Thermostat | Refer to Procedure 008-013 | ISB6.7 CM2250 | 4022254
Coolant Thermostat | Refer to Procedure 008-013 | QSB6.7 CM2350 B105 | 4332778
Coolant Thermostat | Refer to Procedure 008-013 | QSL9 CM2350 L102 | 4332796
Coolant Thermostat | Refer to Procedure 008-013 | ISC8.3 and ISL9 CM2250 | 4022257
Coolant Thermostat | Refer to Procedure 008-013 | ISX15 CM2250 and GX CM2250 | 4022250
Coolant Thermostat | Refer to Procedure 008-013 | ISX12/ISX11.9 CM2250 | 2883445
Coolant Thermostat | Refer to Procedure 008-013 | ISL9 CM2350 L101 | 4310787
Coolant Thermostat | Refer to Procedure 008-013 | ISX12 CM2350 X102 | 4310646
Coolant Thermostat | Refer to Procedure 008-013 | ISX15 CM2350 X101 | 4310641
Coolant Thermostat | Refer to Procedure 008-013 | ISB4.5 CM2350 B104 | 4332646
Coolant Thermostat | Refer to Procedure 008-013 | ISB6.7 CM2350 B103 | 4332641
Coolant Thermostat | Refer to Procedure 008-013 | ISV5.0 CM3230 V104 | 4367291
Coolant Thermostat | Refer to Procedure 008-013 | ISL9 CM2350 L111 | 4367223
Coolant Thermostat | Refer to Procedure 008-013 | ISF3.8 CM2350 F109 | 4367218
Coolant Thermostat | Refer to Procedure 008-013 | QSF3.8 CM2350 F107 | 4367316
Coolant Thermostat | Refer to Procedure 008-013 | QSB4.5 CM2350 B106 | 4367376
Coolant Thermostat | Refer to Procedure 008-013 | QSG12 CM2350 G110 | 4367323
Coolant Thermostat | Refer to Procedure 008-013 | ISF3.8 CM2220 F110 | 4358480
Coolant Thermostat | Refer to Procedure 008-013 | ISG11 CM2880 G106 | 4332695
Coolant Thermostat | Refer to Procedure 008-013 | ISG12 CM2880 G106 | 4332690
Coolant Thermostat | Refer to Procedure 008-013 | ISB5.9 CM2880 B127 | 4383645
Coolant Thermostat | Refer to Procedure 008-013 | ISL8.9 CM2880 L112 | 4388493
Coolant Thermostat | Refer to Procedure 008-013 | ISL9.5 CM2150 SN | 4310608
Coolant Thermostat | Refer to Procedure 008-013 | ISB3.9 CM2220 B107 | 4310792
Coolant Thermostat | Refer to Procedure 008-013 | ISB/ISD4.5 CM2150 B119 | 4358465
Coolant Thermostat | Refer to Procedure 008-013 | ISB/ISD6.7 CM2150 B120 | 4358470
Coolant Thermostat | Refer to Procedure 008-013 | ISL8.9 CM2150 L110 | 4358475
Coolant Thermostat | Refer to Procedure 008-013 | ISF3.8 CM2220 F116 | 4383664
Coolant Thermostat | Refer to Procedure 008-013 | QSB6.7 CM2350 B130 | 4388668
Coolant Thermostat | Refer to Procedure 008-013 | QSL9 CM2350 L118 | 4388673
Coolant Thermostat | Refer to Procedure 008-013 | ISB6.7 CM2350 B142 | 5411131
Coolant Thermostat | Refer to Procedure 008-013 | F3.8 CM2350 F120B | 5411237
Coolant Thermostat | Refer to Procedure 008-013 | X15 CM2350 X114B | 5411181
Coolant Thermostat | Refer to Procedure 008-013 | X15 CM2350 X116B | 5411186
Coolant Thermostat | Refer to Procedure 008-013 | B6.7 CM2350 B121B | 5411223
Coolant Thermostat | Refer to Procedure 008-013 | B4.5 CM2350 B129B | 5411247
Coolant Thermostat | Refer to Procedure 008-013 | B4.5 CM2350 B147B | 5411252
Coolant Thermostat | Refer to Procedure 008-013 | B6.7 CM2350 B135B | 5411257
Coolant Thermostat | Refer to Procedure 008-013 | B6.7 CM2350 B148B | 5411262
Coolant Thermostat | Refer to Procedure 008-013 | L9 CM2350 L119B | 5411267
Coolant Thermostat | Refer to Procedure 008-013 | L9 CM2350 L116B | 5411330
Coolant Thermostat | Refer to Procedure 008-013 | QSB6.7 CM2350 B145 | 5411273
Coolant Thermostat | Refer to Procedure 008-013 | QSL9 CM2350 L122 | 5411278
Coolant Thermostat | Refer to Procedure 008-013 | QSB4.5 CM2350 B144 | 5411382
Coolant Thermostat | Refer to Procedure 008-013 | L9 CM2350 L123B | 5411465
Coolant Thermostat | Refer to Procedure 008-013 | QSX15 CM2350 X118 | 5467247
Coolant Thermostat | Refer to Procedure 008-013 | QSG12 CM2350 G113 | 5467252
Coolant Thermostat | Refer to Procedure 008-013 | QSF3.8 CM2350 F125 | 5411494
Coolant Thermostat | Refer to Procedure 008-013 | ISF4.5 CM2220 F123 | 5411320
Coolant Thermostat | Refer to Procedure 008-013 | ISF2.8 CM2220 F101 | 4310846
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 AN | 4021704
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 AN | 4022178
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4388493
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2880 SN | 4310608
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM28880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM28880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4388493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4388493
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 144 and 145. | Fault Code 144 or 145 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the thermostat. |
 | STEP 2A. Check the thermostat. | Thermostat operate correctly?
STEP 3. | Check the engine coolant temperature sensor and circuit. |
 | STEP 3A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 144 active?
 | STEP 3C. Check the circuit response. | Fault Code 145 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 144 active?
 | STEP 4C. Check the circuit response. | Fault Code 145 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 144 and 145.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 or 145 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to Fault Code 144 or 145 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the thermostat.

Guided Step 2A - Check the thermostat.

Conditions

  • Turn keyswitch OFF.

Action

Check the thermostat for correct operation.

Refer to Procedure 008-013 in the Associated Procedures Table.

Thermostat operate correctly?
YES NO
No Repair

Replace the thermostat. Refer to Procedure 008-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine coolant temperature sensor and circuit.

Guided Step 3A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor and connector pins.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 23-May-2017


FAULT CODE 338 - Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and electronic settings. |
 | STEP 1A. Check for active fault codes. | Fault Code 338 active?
 | STEP 1B. Check the ECM setup for idle shutdown accessory relay. | INSITE™ electronic service tool Idle Shutdown feature set up correctly?
STEP 2. | Check the idle shutdown relay and circuit. |
 | STEP 2A. Inspect the idle shutdown relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the idle shutdown relay for an open circuit. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit in the idle shutdown relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins.
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 338 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and electronic setting.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 338 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM setup for idle shutdown accessory relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the Idle Shutdown feature.

  • If the vehicle has an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Installed”.
  • If the vehicle does not have an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Not Installed”.

INSITE™ electronic service tool Idle Shutdown feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the Idle Shutdown feature setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the idle shutdown relay and circuit.

Guided Step 2A - Inspect the idle shutdown relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Inspect the OEM harness and idle shutdown relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the idle shutdown relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check the idle shutdown relay resistance.

  • Measure the resistance between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the idle shutdown relay. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the idle shutdown relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the idle shutdown relay RETURN pin at the idle shutdown relay connector to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Use the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector idle shutdown relay RETURN pin and the OEM harness idle shutdown relay connector RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the idle shutdown SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 338 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 339 - Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and electronic settings. |
 | STEP 1A. Check for active fault codes. | Fault Code 339 active?
 | STEP 1B. Check the ECM setup for idle shutdown accessory relay. | INSITE™ electronic service tool Idle Shutdown feature set up correctly?
STEP 2. | Check the idle shutdown relay and circuit. |
 | STEP 2A. Inspect the idle shutdown relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the idle shutdown relay for an open circuit. | Greater than 6 ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the idle shutdown relay. |
 | STEP 2C. Check the idle shutdown relay diagnostic supply voltage, supply line, and return circuit. | Greater than 3.75 VDC?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 339 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and electronic settings.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 339 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM setup for idle shutdown accessory relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the Idle Shutdown feature.

  • If the vehicle has an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Installed”.
  • If the vehicle does not have an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Not Installed”.

INSITE™ electronic service tool Idle Shutdown feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the Idle Shutdown feature setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the idle shutdown relay and circuit.

Guided Step 2A - Inspect the idle shutdown relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Inspect the OEM harness and idle shutdown relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the idle shutdown relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check the idle shutdown relay resistance.

  • Measure the resistance between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the idle shutdown relay.

See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the idle shutdown relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance and check for a short circuit between the idle shutdown relay SIGNAL pin and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the idle shutdown relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the idle shutdown relay diagnostic supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the idle shutdown relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM harness.

Use the OEM wiring diagram for connector pin identification.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 339 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active or more than three inactive counts?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During Cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Recalibrate the ECM. |
 | STEP 4A. Recalibrate the ECM. | Fault Code 343 active after recalibrating the ECM?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During Cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery supply (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries. See equipment manufacturer service information.

Go to 5A

Go to 5A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input.

  • Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Recalibrate the ECM.

Guided Step 4A - Recalibrate the ECM

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a short circuit to ground.

  • Use INSITE™ electronic service tool to recalibrate the ECM with the latest engine calibration.

Fault Code 343 active after recalibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Low engine oil pressure has been detected.

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS of the appropriate service manual.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Jan-2016


FAULT CODE 421 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 421. | Active or inactive counts of Fault Code 421?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 421.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 421?
YES | NO
No Repair | No Repair

Reference the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS of the appropriate service manual.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Nov-2014


FAULT CODE 425 - Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISZ13 CM2150 | 4022133
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12 CM2350 X102 | 4310646
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2350 X101 | 4310641
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 SN | 4310736
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G110 | 4367323
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X114B | 5411181
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X116B | 5411186
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G113 | 5467252
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 212 and 213. | Fault Code 212 or 213 active?
STEP 2. | Check the oil temperature sensor and circuit. |
 | STEP 2A. Inspect the oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check circuit response. | Fault Code 212 active?
 | STEP 2C. Check circuit response. | Fault Code 213 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check circuit response. | Fault Code 212 active?
 | STEP 3C. Check circuit response. | Fault Code 213 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 212 and 213.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 or 213 active?
YES | NO
No Repair | No Repair

Fault Code 212 or 213 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the oil temperature sensor and circuit.

Guided Step 2A - Inspect the oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor and connector pins.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active?
YES NO
No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil temperature SIGNAL pin and the oil temperature RETURN pin at the oil temperature connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

Replace the oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil temperature SIGNAL pin and oil temperature RETURN pin at the ECM engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair complete.

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 427 - SAE J1939 Data Link - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3163151 - ECM bench calibration harness Part Number 3164185 - ECM bench calibration adapter cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check SAE J1939 communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communications with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with ECM?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check SAE J1939 communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Cummins® INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using a Cummins® INLINE™ II data link adapter (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM service manual for information on troubleshooting the vehicle SAE J1939 network.

 No Repair

Refer to the OEM service manual.

Go to 1B

Guided Step 1B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has ben detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communications with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect Cummins® INLINE™ II data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an Cummins® INLINE™ II data link adapter (J1939) ECM connection.

INSITE™ electronic service tool communicates with ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM service manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

Refer to OEM service manual.

Reference the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree in Section TS.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2012


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the OEM power harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt systems)
  • At least +24 VDC (24 volt systems).

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-ampere fuse is installed correctly.

  • Inspect the 30-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 30-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turnkeyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the SUPPLY wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 active?
STEP 2. | Check the battery system. |
 | STEP 2A. Check the battery connection. | Batteries connected properly for the system voltage required?
 | STEP 2B. Check the alternator. | Alternator charging within equipment manufacturers specifications?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the battery system.

Guided Step 2A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check to make sure batteries are installed correctly.

Batteries connected properly for the system voltage required?
YES NO
No Repair

Install the battery system correctly. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an original equipment manufacturer (OEM) ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within equipment manufacturers specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the equipment manufacturers wiring to the alternator.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Apr-2017


FAULT CODE 477 - Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 477 is active?
 | STEP 1B. Check for active fault codes. | Fault Codes 441, 597, or 598 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller. |
 | STEP 2A. Inspect the aftertreatment DEF controller and harness. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DEF controller. | Voltage is within 1-VDC of battery voltage?
 | STEP 2C. Check for the correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine CPL?
STEP 3. | Check the battery. |
 | STEP 3A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 3B. Verify that the fuse is installed correctly. | Good fuse installed correctly?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 477 is active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF controller.

Guided Step 2A - Inspect aftertreatment DEF controller and harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the 53-pin aftertreatment DEF controller connector from the aftertreatment DEF controller.

Action

Inspect the OEM harness and Aftertreatment DEF controller 53-pin connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the controller or harness connector.

Repair the damaged harness, connector or pins, if possibe.

  • Flush the dirt, debris, or moisture from the connector pins. Us electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM wiring harness.
  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the Aftertreatment DEF controller.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller from the OEM wiring harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuits to the Aftertreatment DEF controller.

  • Measure the voltage between the Aftertreatment DEF controller Battery Voltage SUPPLY circuit and the Aftertreatment DEF controller Battery Voltage RETURN circuit at the OEM harness 53-pin connector

Note: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ is correct for the engine CPL.

Electrical System Voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 4A

Go to 4A

Guided Step 3 - Check the battery.

Guided Step 3A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. Refer to the OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the fuse is installed correctly and is not blown.

  • Inspect the fuse for correct installation and check to see if its blown.

Good fuse installed correctly?
YES NO
No Repair

Install the fuse correctly or replace the blown fuse. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the 53-pin aftertreatment DEF controller OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all aftertreatment DEF controller battery SUPPLY (+) pins, one at a time, in the 53-pin OEM harness connector.
  • Measure the resistance from the negative (-) battery terminal post to all aftertreatment DEF controller battery RETURN (-) pins, one at a time, in the in the 53-pin OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit in the power harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the 53-pin aftertreatment DEF controller OEM harness connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the aftertreatment DEF controller battery SUPPLY (+) pins in the 53-pin OEM harness connector to the aftertreatment DEF controller battery RETURN (-) pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the 53-pin aftertreatment DEF controller OEM harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the aftertreatment DEF controller battery SUPPLY (+) pins in the 53-pin OEM harness connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin-to-pin short circuit.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the 53-pin aftertreatment DEF controller OEM harness connector.
  • Disconnect the 86-pin aftertreatment DEF controller OEM harness connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the aftertreatment DEF controller battery SUPPLY (+) pins in the 53-pin OEM harness connector to all pins in the 53-pin and 86-pin OEM harness connectors.
  • Measure the resistance from one of the aftertreatment DEF controller battery RETURN (-) pins in the 53-pin OEM harness connector to all pins in the 53-pin and 86-pin OEM harness connectors.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • The current ECM code and revision number in the ECM can be found using the INSITE™ service tool. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Feb-2015


FAULT CODE 478 - Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 478 is active?
 | STEP 1B. Check for active fault codes. | Fault Codes 442 or 596 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid controller. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid controller and harness. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment diesel exhaust fluid controller. | Less than +18-VDC for 12-volt system and less than +32-VDC for 24-volt system?
 | STEP 2C. Check for the correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine CPL?
STEP 3. | Check the alternator. |
 | STEP 3A. Check the alternator. | Alternator charging within OEM specifications?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Connect INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 478 is active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch O.N
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 442 or 596 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid controller.

Guided Step 2A - Inspect aftertreatment diesel exhaust fluid controller and harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the 53-pin aftertreatment diesel exhaust fluid controller connector from the aftertreatment diesel exhaust fluid controller.

Action

Inspect the OEM harness and Aftertreatment diesel exhaust fluid controller 53-pin connector pins for the following:

  • Loose connectors
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the controller or harness connector.

Repair the damaged harness, connector, or pins if possible.

  • Flush the dirt, debris. or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment diesel exhaust fluid controller.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller from the OEM harness
  • Turn keyswitch ON.

Action

Check the power supply and return circuits to the aftertreatment diesel exhaust fluid controller.

  • Measure the voltage between the aftertreatment diesel exhaust fluid controller battery voltage SUPPLY circuit and the Aftertreatment diesel exhaust fluid controller battery voltage RETURN circuit at the OEM harness 53-pin connector.

Note: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Less than +18-VDC for 12-volt system and less than +32-VDC for 24-volt system?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for the correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical System Voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 4A

Go to 4A

Guided Step 3 - Check the alternator.

Guided Step 3A - Check the alternator.

Conditions

  • Turn keyswitch OFF
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Note: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the INSITE™ service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2011


FAULT CODE 555 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L102 | 4332796
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2250 | 4022254
Crankcase Breather (External) | Refer to Procedure 003-001 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather (External) | Refer to Procedure 003-001 | ISM11 CM876 SN | 4022196
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 | 4022256
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 | 4022255
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 ECF | 2883557
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L101 | 4310787
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 CM2350 X102 | 4310646
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2350 X101 | 4310641
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L111 | 4367223
Crankcase Breather (External) | Refer to Procedure 003-001 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L115 | 4388626
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L118 | 4388673
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L107 | 4367386
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather (External) | Refer to Procedure 003-001 | B6.7 CM2350 B121B | 5411223
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L122 | 5411278
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L119B | 5411267
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L116B | 5411330
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L123B | 5411465
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2250 | 4022254
Crankcase Breather Tube | Refer to Procedure 003-018 | Marine QSB6.7 CM2250 | 4310611
Crankcase Breather Tube | Refer to Procedure 003-018 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 | 4022256
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 | 4022255
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather Tube | Refer to Procedure 003-018 | QSX11.9 CM2250 | 2883561
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Tube | Refer to Procedure 003-018 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Tube | Refer to Procedure 003-018 | B6.7 CM2350 B121B | 5411223
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L119B | 5411267
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L116B | 5411330
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L123B | 5411465
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Element | Refer to Procedure 003-019 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Element | Refer to Procedure 003-019 | ISM11 CM876 SN | 4022196
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 | 4022256
Crankcase Breather Element | Refer to Procedure 003-019 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 ECF | 2883557
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2350 X101 | 4310641
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 X115 | 4388739
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L116B | 5411330
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L123B | 5411465
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2350 X118 | 5467247
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B105 | 4332778
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L102 | 4332796
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2250 | 4022254
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine QSB6.7 CM2250 | 4310611
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISM11 CM876 SN | 4022196
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 | 4022256
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 | 4022255
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 EC | 2883621
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX11.9 CM2250 ECF | 2883561
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 ECF | 2883557
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 | 4310664
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 EC | 2883647
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B101 | 2883567
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 B101 | 4310787
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12 CM2350 X102 | 4310646
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2350 X102 | 4310641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B103 | 4332641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B112 | 4358498
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B106 | 4367376
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 L111 | 4367223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISV5.0 CM3230 V104 | 4367291
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B128 | 4388601
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L115 | 4388626
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B130 | 4388668
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L118 | 4388673
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L107 | 4367386
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B122 | 4388767
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2250 B131 | 4388774
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 B137 | 5411058
Crankcase Blowby, Measure | Refer to Procedure 014-010 | B6.7 CM2350 B121B | 5411223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 X115 | 4388739
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B145 QSL9 CM2350 L122 | 5411273 5411278
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B144 | 5411382
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L119B | 5411267
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L116B | 5411330
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L123B | 5411465
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2350 X118 | 5467247
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 555 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H20]?
 | STEP 2B. Verify crankcase breather type and maintenance history. | Filter below the maintenance interval or fitted with maintenance free element?
 | STEP 2C. Inspect the crankcase breather element. | Crankcase breather element have contamination or blockage?
 | STEP 2D. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator. | Oil drain tubes, check valves, breather tube, or oil separator plugged?
STEP 3. | Measure the crankcase blowby. |
 | STEP 3A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 555 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate engine.

Action

Use the INSITE™ electronic service tool “Data Monitor/Logger” feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not running.
  • Use INSITE™ electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H20]?

YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Verify crankcase breather type and maintenance history.

Conditions

  • Determine if crankcase breather system is fitted with filter element or maintenance free breather insert.

Action

Check mileage / hours on the crankcase breather filter since last maintenance, if equipped.

Contact a Cummins® Authorized Repair Location for crankcase breather filter maintenance intervals for specific engine application.

Filter below the maintenance interval or fitted with maintenance free element?
YES NO
No Repair

Replace the crankcase breather filter element. Refer to Procedure 003-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase breather element.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the crankcase breather element for contamination or blockage.

Crankcase breather element have contamination or blockage?
YES NO

Inspect the crankcase breather element and clean or replace as necessary.

Refer to Procedure 003-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

Oil drain tubes, check valves, breather tube, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Measure the crankcase blowby.

Guided Step 3A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Do not operate engine.

Action

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engine equipped with automatic transmissions only.

Measure the crankcase blowby. Refer to Procedure 014-010 in the Associated Procedures Table.

Crankcase blowby measurement within specification?
YES NO

Inspect the crankcase breather element and clean or replace as necessary. Refer to Procedure 003-019 in the Associated Procedures Table.

Troubleshoot the possible causes for excessive crankcase gases.

  • Reference the Crankcase Gases (Blowby) Excessive symptom tree in the appropriate service manual for a specific engine application.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 14-Mar-2017


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L102 | 4332796
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2250 | 4022254
Crankcase Breather (External) | Refer to Procedure 003-001 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather (External) | Refer to Procedure 003-001 | ISM11 CM876 SN | 4022196
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 | 4022256
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 | 4022255
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 ECF | 2883557
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L101 | 4310787
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 CM2350 X102 | 4310646
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2350 X101 | 4310641
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L111 | 4367223
Crankcase Breather (External) | Refer to Procedure 003-001 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L115 | 4388626
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L118 | 4388673
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L107 | 4367386
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather (External) | Refer to Procedure 003-001 | B6.7 CM2350 B121B | 5411223
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L122 | 5411278
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L119B | 5411267
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2250 | 4022254
Crankcase Breather Tube | Refer to Procedure 003-018 | Marine QSB6.7 CM2250 | 4310611
Crankcase Breather Tube | Refer to Procedure 003-018 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 | 4022256
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 | 4022255
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather Tube | Refer to Procedure 003-018 | QSX11.9 CM2250 | 2883561
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Tube | Refer to Procedure 003-018 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Tube | Refer to Procedure 003-018 | B6.7 CM2350 B121B | 5411223
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Element | Refer to Procedure 003-019 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Element | Refer to Procedure 003-019 | ISM11 CM876 SN | 4022196
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 | 4022256
Crankcase Breather Element | Refer to Procedure 003-019 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 ECF | 2883557
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2350 X101 | 4310641
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 X115 | 4388739
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2350 X118 | 5467247
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B105 | 4332778
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 CM2350 B101 | 2883567
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 CM2350 B103 | 4332641
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 | 4358498
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B106 | 4367376
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B128 | 4388601
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B130 | 4388668
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B122 | 4388767
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2250 B131 | 4388774
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB3.3 CM2250 B137 | 5411058
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B121B | 5411223
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B145 | 5411273
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B144 | 5411382
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B105 | 4332778
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L102 | 4332796
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2250 | 4022254
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine QSB6.7 CM2250 | 4310611
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISM11 CM876 SN | 4022196
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 | 4022256
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 | 4022255
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 EC | 2883621
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX11.9 CM2250 ECF | 2883561
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 ECF | 2883557
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 | 4310664
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 EC | 2883647
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B101 | 2883567
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 B101 | 4310787
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12 CM2350 X102 | 4310646
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2350 X102 | 4310641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B103 | 4332641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B112 | 4358498
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B106 | 4367376
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 L111 | 4367223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISV5.0 CM3230 V104 | 4367291
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B128 | 4388601
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L115 | 4388626
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B130 | 4388668
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L118 | 4388673
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L107 | 4367386
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B122 | 4388767
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2250 B131 | 4388774
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 B137 | 5411058
Crankcase Blowby, Measure | Refer to Procedure 014-010 | B6.7 CM2350 B121B | 5411223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 X115 | 4388739
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B145 QSL9 CM2350 L122 | 5411273 5411278
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B144 | 5411382
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L119B | 5411267
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2350 X118 | 5467247
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 556 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.28 kPa - G (0 ± 1.13 in H2O)?
 | STEP 2B. Very crankcase breather type and maintenance history. | Filter below the maintenance interval or fitted with maintenance free element?
 | STEP 2C. Inspect the crankcase breather element. | Crankcase breather element have contamination or blockage?
 | STEP 2D. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator. | Oil drain tubes, check valves, breather tubes, or oil separator plugged?
STEP 3. | Measure the crankcase blowby. |
 | STEP 3A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 4. | Check for progressive damage. |
 | STEP 4A. Check for progressive damage. | Progressive damage found due to high crankcase pressure?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate engine.

Action

Use INSITE™ electronic service tool “Data Monitor/Logger” feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not operating.
  • Use INSITE™ electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ± 0.28 kPa - G (0 ± 1.13 in H2O)?

YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Verify crankcase breather type and maintenance history.

Conditions

  • Determine if crankcase breather system is fitted with filter element or maintenance free breather insert.

Action

Check mileage / hours on the crankcase ventilation filter since last maintenance, if equipped.

Contact a Cummins® Authorized Repair Location for crankcase breather filter maintenance interval for a specific engine application.

Filter below the maintenance interval or fitted with maintenance free element?
YES NO
No Repair

Replace the crankcase breather filter element.

Refer to Procedure 003-019 in the Associated Procedures Table.

For QSB6.7 CM2250 B128 engines: Refer to Procedure 003-021 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase breather element.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the crankcase breather element for contamination or blockage.

Crankcase breather element have contamination or blockage?
YES NO

Inspect the crankcase breather element and clean or replace as necessary.

Refer to Procedure 003-019 in the Associated Procedures Table.

For QSB6.7 CM2250 B128 and ISL9 CM2250 L115 engines: Refer to Procedure 003-021 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

Oil drain tubes, check valves, breather tubes, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tubes, or oil separator.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Measure the crankcase blowby.

Guided Step 3A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engines equipped with automatic transmissions only.
  • Measure the crankcase blowby.

Refer to Procedure 014-010 in the Associated Procedures Table.

It may be necessary to disable the fault code in order to operate the engine at rated speed. Use INSITE™ electronic service tool to verify the fault code is inactive.

Crankcase blowby measurement within specification?
YES NO

Inspect the crankcase breather element and clean or replace, as necessary. Refer to Procedure 003-019 in the Associated Procedures Table.

Troubleshoot the possible causes for excessive crankcase gases.

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS in the appropriate service manual for a specific engine application.

Go to 4A

Go to 4A

Guided Step 4 - Check for progressive damage.

Guided Step 4A - Check for progressive damage.

Action

Check for progressive damage:

  • Check for progressive damage to the engine due to the high crankcase pressure.
  • Check for oil leaking from gaskets and seals.

Reference the appropriate service manual for a specific engine application.

Progressive damage found due to high crankcase pressure?
YES NO

Replace the damaged gasket, seal, or other component.

Troubleshoot the possible causes for excessive crankcase gases. Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS in the appropriate service manual for a specific engine application.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. See equipment manufacturer service information.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 14-Mar-2017


FAULT CODE 584 - Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 F | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 584 active?
STEP 2. | Check the starter lockout relay circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Resistance between 30 - 130 ohms (12V systems) or 200 - 400 ohms (24V systems)?
 | STEP 2C. Check for an open circuit in the starter lockout relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 584 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the starter lockout relay circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay pin 85 and the starter lockout relay pin 86.

Reference the OEM wiring diagram for starter relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 30 - 130 ohms (12V systems) or 200 - 400 ohms (24V systems)?
YES NO
No Repair

A malfunctioning starter lockout relay has been detected.

Replace the starter lockout relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector to ground.

Reference the OEM wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the connection malfunction.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the starter lockout relay signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

None.

The removal and installation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 585 - Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 585 active?
STEP 2. | Check starter lockout relay and circuit. |
 | STEP 2A. Inspect starter relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the starter lockout relay resistance. | Resistance between 30 - 130 ohms for 12V systems or 200 - 400 ohms for 24V systems?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the starter lockout relay. |
 | STEP 2C. Check the starter lockout relay diagnostic supply voltage, supply line and return circuit. | Greater than 3.75 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 585 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check starter lockout relay and circuit.

Guided Step 2A - Inspect starter relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the starter lockout relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay pin 85 and the relay pin 86.

Reference the OEM wiring diagram for starter relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 30 - 130 ohms for 12V systems or 200 - 400 ohms for 24V systems?
YES NO
No Repair

Replace the starter lockout relay. See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the starter lockout relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the starter lockout relay diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the starter lockout relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 596 - Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Are the voltages at least (+) 12 VDC (volts of direct current) under normal conditions and at least (+) 6.2 VDC during cranking?
STEP 2. | Check the charging system. |
 | STEP 2A. Inspect the alternator. | Is the alternator charging within original equipment manufacturer (OEM) specifications?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion.
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Are the voltages at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the charging system.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging rate within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator. See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Jul-2014


FAULT CODE 597 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use these test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Is the battery voltage at least (+) 12 VDC (volts of direct current) under normal conditions and at least (+) 6 VDC during cranking?
STEP 2. | Check the alternator and power harness. |
 | STEP 2A. Inspect the alternator. | Is the alternator charging within original equipment manufacturer (OEM) specifications?
 | STEP 2B. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit. | More than 100k ohms?
 | STEP 2D. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Any damaged wires?
 | STEP 2E. Check for a short circuit in the power harness. | More than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Is the battery voltage at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and power harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging rate within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins of the OEM power harness ECM connector and the positive (+) battery terminal.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the battery harness. See equipment manufacturer service information.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins and the ECM battery SUPPLY (-) pins of the ECM power harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit in the SUPPLY wire to the engine block.

Any damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM Battery SUPPLY (+) pins in the OEM power harness connector to all pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Jul-2014


FAULT CODE 598 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Are the voltages at least (+) 12 VDC (volts of direct current) during normal conditions and at least (+) 6.2 VDC during cranking?
STEP 2. | Check the alternator and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the alternator. | Is the alternator charging within OEM specifications?
 | STEP 2B. Inspect the battery power connector. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the power harness. | More than 100k ohms?
 | STEP 2E. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes.. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion.
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Are the voltages at least (+) 12 VDC during normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and OEM harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (ampere).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the battery power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness from the battery at the power connector.

Action

Inspect the battery power connector on both the battery side and the harness side for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the battery power connector.

For location and procedure, see equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM

Action

Check for an open circuit.

  • Measure the resistance of the ECM battery supply (+) circuit between the OEM power harness connector and the positive (+) terminal of the battery.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the ECM battery SUPPLY (+) pins and all other pins of the power harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit at the SUPPLY wire to the engine block ground.

Damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Jul-2014


FAULT CODE 649 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 649. | Fault Code 649 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 649.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 649.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 649 active?
YES NO

Change the engine lubricating oil and filter.

Use INSITE™ electronic service tool to reset the Maintenance Monitor.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Feb-2013


FAULT CODE 686 - Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL8.9 CM2150 SN | 4022190
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2250 | 4022254
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B101 | 2883567

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead and Part Number 3822917 female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an intermittent fault condition. |
 | STEP 1A. Operate the engine at idle and high idle to check for fault activation. | Did Fault Code 686 come active during engine operation?
STEP 2. | Check for a malfunctioning turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Is the connector or pigtail harness damaged?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Resistance within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if the fault code reoccurs. |
 | STEP 4A. Operate the engine at idle and high idle to check for fault activation. | Does Fault Code 686 come active during engine operation?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for an intermittent fault condition.

Guided Step 1A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool and clear inactive fault codes.
  • Start the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Action

Check for fault activation.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

Does Fault Code 686 come active during engine operation?
YES NO
No Repair

An intermittent fault condition exists. The problem can possibly be with the turbocharger speed sensor circuit; however, the intermittent fault condition can possibly be due to electrical noise that is caused by other devices or faulty grounds.

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for a malfunctioning turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Is the connector or pigtail harness damaged?
YES NO

Repair or replace the damaged connector, or turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check the sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to the turbocharger speed RETURN (-) pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

NOTE: The resistance of the turbocharger speed sensor circuit must not be more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance within 10 ohms of the sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector. Otherwise, there is a low resistance (short) across the sensor input pins.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed RETURN (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short between pins of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code reoccurs.

Guided Step 4A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at idle.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

NOTE: This step applies even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Does Fault Code 686 come active during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

An intermittent fault condition exists. The problem may exist in the turbocharger speed sensor circuit or it may exist with other vehicle electronic components. The problem may have been corrected when the harness connections were re-connected.

Be certain that the ECM and chassis grounds are in good condition.

Go to 5A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 687 - Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L102 | 4332796
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL8.9 CM2150 SN | 4022190
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2250 | 4022254
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2250 | 4022256
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 | 4022255
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 EC | 2883621
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX15 CM2250 ECF | 2883557
Turbocharger Speed Sensor | Refer to Procedure 019-390 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Speed Sensor | Refer to Procedure 019-390 | PowerGen QSX15 CM2250 | 4310664
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL9 CM2350 L101 | 4310787
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX12 CM2350 X102 | 4310646
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX15 CM2350 X101 | 4310641
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL9 CM2350 L111 | 4367223
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2250 L115 | 4388626
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L118 | 4388673
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L107 | 4367386
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX15 CM2250 X115 | 4388739
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B4.5 CM2350 B129B | 5411247
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B4.5 CM2350 B147B | 5411252
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B6.7 CM2350 B135B | 5411257
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B6.7 CM2350 B148B | 5411262
Turbocharger Speed Sensor | Refer to Procedure 019-390 | L9 CM2350 L119B | 5411267
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L122 | 5411278
Turbocharger Speed Sensor | Refer to Procedure 019-390 | L9 CM2350 L116B | 5411330
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Speed Sensor | Refer to Procedure 019-390 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 122, 123, 221, or 222 active?
STEP 2. | Check for a malfunctioning turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Resistance between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Continuity within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disabel the fault code. | Fault code inactive?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 122, 123, 221, or 222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check for a malfunction in the turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the turbocharger speed sensor connector or speed sensor.

Repair or replace the damaged connector or turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the turbocharger speed SIGNAL (-) pin of the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

The resistance of the turbocharger speed sensor circuit resistance should be no more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Continuity within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed SIGNAL (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

The turbocharger speed sensor has malfunctioned.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Replace the turbocharger speed sensor. Refer to Procedure 019-030 in the Associated Procedures Table.

A short has been detected in the engine harness.

Inspect the engine harness for a short between two pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Speed Sensor | Refer to Procedure 019-042 | KTA38GC CM558/CM2358 | 4021656
Engine Speed Sensor | Refer to Procedure 019-042 | G5.9, G8.3, G855, and GTA855 CM558/CM2358 | 4021702
Engine Speed Sensor | Refer to Procedure 019-042 | QSL9G CM558/CM2358 | 2883471
Engine Speed Sensor | Refer to Procedure 019-042 | KTA19GC CM558/CM2358 | 4021655
Engine Speed Sensor | Refer to Procedure 019-042 | QSK19G | 4021352
Engine Speed Sensor | Refer to Procedure 019-042 | GTA8.3 CM558/CM2358 | 4021654
Engine Speed Sensor | Refer to Procedure 019-042 | QSK23 CM2250 K109 | 4367358
Engine Speed Sensor | Refer to Procedure 019-042 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F114 | 4383734
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | Marine QSB6.7 CM2250 | 4310611
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 SN | 4310736
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F101 | 4310846
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F103 | 4310839
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5 CM2350 B104 | 4332646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD4.5 CM2150 B119 | 4358465
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2150 B120 | 4358470
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 L110 | 4358475
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F110 | 4358480
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z101 | 4358364
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z102 | 4358369
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2350 F109 | 4367218
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L111 | 4367223
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G110 | 4367323
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 L115 | 4388626
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active or more than one inactive count within the last 25 engine hours?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or more than one inactive count within the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

No repair.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Some natural gas engines are referenced as the engine speed sensor. Refer to Proceduere 019-042 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

  • 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the air gap between the crankshaft position sensor and the tone wheel.
  • Refer to Procedure 001-071 in the Associated Procedures Table or Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?
YES NO
No Repair

Replace the component that is causing the out of specification reading.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 691 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK50 CM2350 K108 | 4332823
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISL8.9 CM2150 SN | 4022190
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISZ13 CM2150 | 4022133
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSX15 CM2250 ECF | 2883557
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12 CM2350 X102 | 4310646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2350 X101 | 4310641
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK19 CM2350 K105 | 4326157
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z101 | 4358364
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z102 | 4358369
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | F3.8 CM2350 F120B | 5411237
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K116 | 4367444
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K121 | 4388645
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X114B | 5411181
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X116B | 5411186
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L111 | 4367223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F107 | 4367316
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F105 | 4358561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 EC | 2883621
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2250 | 4022254
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 | 4310664
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L102 | 4332796
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 | 4022256
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 | 4022255
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L118 | 4388673
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 L115 | 4388626
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L107 | 4367386
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F118 | 4388708
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F119 | 4388703
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B122 | 4388767
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L116B | 5411330
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L122 | 5411278
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B135B | 5411257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B148B | 5411262
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L119B | 5411267
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F124 | 5411484
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F131 | 5411489
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L123B | 5411465
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2350 X118 | 5467247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F125 | 5411494

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 691 active?
STEP 3. | Check the engine control module (ECM), engine harness, and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 3C. Check for an open circuit in the engine harness or OEM harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness or OEM harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness or OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3854510.

Install the appropriate connector seal if it is damaged or missing.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the turbocharger compressor intake temperature SIGNAL pin and the turbocharger compressor intake temperature RETURN pin at the turbocharger compressor intake temperature connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?

YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake air temperature sensor.

  • For engines equipped with a turbocharger compressor intake air temperature sensor: Refer to Procedure 019-395 in the Associated Procedures Table.
  • For engines equipped with a turbocharger compressor intake pressure/temperature sensor: Refer to Procedure 019-466 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM), engine harness, and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM, engine harness, or OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM, engine harness, or OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM, engine harness, or OEM harness connector.

Repair the damaged harness, connector, or pins, if possible.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3854510.

Install the appropriate connector seal if it is damaged or missing.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger compressor intake air temperature sensor SIGNAL pin and the turbocharger compressor intake air temperature sensor RETURN pin at the ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor intake air temperature sensor RETURN pin and the engine harness turbocharger compressor intake air temperature sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor intake air temperature sensor SIGNAL pin and the engine harness turbocharger compressor intake air temperature sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor intake air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 692 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK50 CM2350 K108 | 4332823
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISL8.9 CM2150 SN | 4022190
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISZ13 CM2150 | 4022133
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSL9 CM2250 | 4022256
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSB6.7 CM2250 | 4022255
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSB6.7 CM2250 EC | 2883621
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSX15 CM2250 ECF | 2883557
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12 CM2350 X102 | 4310646
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2350 X101 | 4310641
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK19 CM2350 K105 | 4326157
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z101 | 4358364
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z102 | 4358369
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | F3.8 CM2350 F120B | 5411237
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K116 | 4367444
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K121 | 4388645
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X114B | 5411181
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X116B | 5411186
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L111 | 4367223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F105 | 4358561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F107 | 4367316
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 L115 | 4388626
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L118 | 4388673
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L107 | 4367386
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F118 | 4388708
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F119 | 4388703
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B122 | 4388767
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B135B | 5411257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B148B | 5411262
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L119B | 5411267
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L116B | 5411330
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L122 | 5411278
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F124 | 5411484
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F131 | 5411489
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L123B | 5411465
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2350 X118 | 5467247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F125 | 5411494
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2350 F124 | 5411484

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 692 active?
STEP 3. | Check the engine control module (ECM), engine harness, or original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness or OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake air temperature sensor.

  • Use the following procedure for engines equipped with a turbocharger compresssor intake air temperature sensor. Refer to Procedure 019-395 in the Associated Procedures Table.
  • Use the following procedure for engines equipped with a turbocharger compressor intake pressure/temperature sensor: Refer to Procedure 019-466 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, engine harness, or OEM harness.

Guided Step 3A - Inspect the ECM and engine harness, and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple unrelated faults will become active at this time as well. These can be temporarily ignored.

Fault Code 691 active and Fault Code 692 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine turbocharger compressor intake temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor intake air temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the turbocharger compressor intake air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 693 - Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC and ISL CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC and ISL CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wirng Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISZ13 CM2150 | 4022133
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12 CM2350 X102 | 4310646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2350 X101 | 4310641
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | F3.8 CM2350 F120B | 5411237
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X114B | 5411181
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X116B | 5411186
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B147B | 5411247
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L111 | 4367223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B135B | 5411257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B148B | 5411262
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L119B | 5411267
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L116B | 5411330
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L123B | 5411465
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 693 active?
 | STEP 1B. Check for Fault Codes 691 and 692. | Fault Code 691 or 692 active?
STEP 2. | Check the turbocharger compressor intake temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 691 active?
 | STEP 2C. Check the circuit response. | Fault Code 692 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 691 active?
 | STEP 3C. Check the circuit response. | Fault Code 692 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 693 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for Fault Codes 691 and 692.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 or 692 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine harness.

Action

Inspect the engine harness and turbocharger compressor intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the turbocharger compressor intake temperature SIGNAL pin and the turbocharger compressor intake temperature RETURN pin at the turbocharger compressor intake temperature connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

An in-range malfunction of the turbocharger compressor intake temperature sensor has been detected.

Replace the turbocharger compressor intake temperature sensor.

  • For engines equipped with turbocharger compressor intake air temperature sensors: Refer to Procedure 019-395 in the Associated Procedures Table.
  • For engines equipped with turbocharger compressor intake pressure/temperature sensors: Refer to Procedure 019-466 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) power harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

  • Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the turbocharger compressor intake temperature SIGNAL pin and turbocharger compressor intake temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 697 - ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V014 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 697 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 698 - Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 698 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 699 - ECM Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 699 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 778 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | Westport HD CM2250 | 4021560
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harnes | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2150 SN | 4022190
Camshaft Position Sensor | Refer to Procedure 019-363 | ISZ13 CM2150 | 4022133
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2250 | 4022254
Camshaft Position Sensor | Refer to Procedure 019-363 | ISC8.3 and ISL9 CM2250 | 4022257
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2250 GX CM2250 | 4022250
Camshaft Position Sensor | Refer to Procedure 019-363 | Westport HD CM2250 | 4021560
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12/ISX11.9 CM2250 | 2883445
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2250 | 4022256
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 | 4022255
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 EC | 2883621
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX11.9 CM2250 ECF | 2883561
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2250 ECF | 2883557
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 ECF | 4310661
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 | 4310664
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 EC | 2883647
Camshaft Position Sensor | Refer to Procedure 019-363 | Marine QSB6.7 CM2250 | 4310611
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B101 | 2883567
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9 CM2350 L101 | 4310787
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12 CM2350 X102 | 4310646
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2350 X101 | 4310641
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2250 SN | 4310736
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F101 | 4310846
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 F103 | 4310839
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB4.5 CM2350 B104 | 4332646
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B103 | 4332641
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B105 | 4332778
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L102 | 4332796
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD4.5 CM2150 B119 | 4358465
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD6.7 CM2150 B120 | 4358470
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L102 | 4358475
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L102 | 4358480
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 M CM2250 L106 | 4358343
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9 CM2350 L111 | 4367223
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B112 | 4358498
Camshaft Position Sensor | Refer to Procedure 019-363 | QSZ13 CM2150 Z101 | 4358364
Camshaft Position Sensor | Refer to Procedure 019-363 | QSZ13 CM2150 Z102 | 4358369
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F105 | 4358561
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F114 | 4383734
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F107 | 4367316
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2350 F109 | 4367218
Camshaft Position Sensor | Refer to Procedure 019-363 | F3.8 CM2350 F120B | 5411237
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B106 | 4367376
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2350 G110 | 4367323
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 B128 | 4388601
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2250 L115 | 4388626
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L107 | 4367386
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F117 | 4388578
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B130 | 4388668
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L118 | 4388673
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F118 | 4388708
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F119 | 4388703
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B122 | 4388767
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F126 | 5411159
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2250 B131 | 4388774
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 B137 | 5411058
Camshaft Position Sensor | Refer to Procedure 019-363 | X15 CM2350 X114B | 5411181
Camshaft Position Sensor | Refer to Procedure 019-363 | X15 CM2350 X116B | 5411186
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B121B | 5411223
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B142 | 5411131
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2250 X115 | 4388739
Camshaft Position Sensor | Refer to Procedure 019-363 | B4.5 CM2350 B129B | 5411247
Camshaft Position Sensor | Refer to Procedure 019-363 | B4.5 CM2350 B147B | 5411252
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B135B | 5411257
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B148B | 5411262
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L119B | 5411267
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L116B | 5411330
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B145 | 5411273
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L122 | 5411278
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B144 | 5411382
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F124 | 5411484
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F125 | 5411494
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L123B | 5411465
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F131 | 5411489
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2350 G113 | 5467252
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2350 X118 | 5467247
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for fault code. | Fault Code 778 active or inactive?
STEP 2. | Check the camshaft position sensor and connector. |
 | STEP 2A. Inspect the camshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the camshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the camshaft position sensor circuit. |
 | STEP 3A. Check the camshaft position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open camshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Verify adequate camshaft position sensor air gap. |
 | STEP 3B-4. Check the fault code and verify the camshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify camshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault coe Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active or inactive?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the camshaft position sensor and connector.

Guided Step 2A - Inspect the camshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the camshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Remove the camshaft position sensor from the gear housing. Refer to Procedure 019-363 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed then inspect the camshaft gear and related components. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the camshaft position sensor circuit.

Guided Step 3A - Check the camshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor 1 RETURN pin at the camshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open camshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector to the camshaft position sensor SIGNAL pin at the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the camshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Verify adequate camshaft position sensor air gap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the camshaft position sensor from the gear housing and measure the air gap at several points in the camshaft's revolution. Refer to Procedure 019-363 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the camshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

A damaged camshaft position sensor has been detected.

Replace the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify camshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

For QSB6.7 CM2250 B128 and QSL9 CM2250 L115 engines: If necessary, calibrate the ECM. See equipment manufacturer service information.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 784 - Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the adaptive cruise control hardware. |
 | STEP 1A. Check for installed adaptive cruise control hardware. | Is adaptive cruise control hardware installed on vehicle?
STEP 2. | Check SAE J1939 communication. |
 | STEP 2A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 2B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check ECM communication with the ECM bench calibration harness. | Does INSITE™ electronic service tool communicate with the ECM?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the adaptive cruise control hardware.

Guided Step 1A - Check for installed adaptive cruise control hardware.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle for installed adaptive cruise control hardware.

Is adaptive cruise control hardware installed on the vehicle?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Adaptive Cruise feature.

Go to 2A

Go to 3A

Guided Step 2 - Check SAE J1939 communications.

Guided Step 2A - Check for ECM communication with INSITE™

Conditions

  • Turn keyswitch ON.
  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool.
  • Select INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM service manual for information on troubleshooting the adaptive cruise control unit and the vehicle SAE J1939 network.

No Repair

See equipment manufacturer service information.

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ II data link adapter to the ECM bench calibration harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM. Use an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM service manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

See equipment manufacturer service information.

Reference the Communication Error - Electronic Service Tool or Control Device Symptom Troubleshooting Tree

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2014


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 active?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]. During Cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117 active?
YES NO
No Repair

If high inactive counts of Fault Code 1117 are found in the ECM, check the battery disconnect devices in the vehicle. If the keyswitch and ECM power are disconnected at the same time, Fault Code 1117 will be logged.

Go to 2A

Go to 4A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]

During Cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or battery supply connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the battery supply connector and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Go to 4A

Go to 4A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the battery supply connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the battery supply connector and the negative battery connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch wire.

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO
No Repair

Correct the wiring so the wire is uninterrupted.

Go to 3E

Go to 4A

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete

Go to 1A

Last Modified: 05-Apr-2017


FAULT CODE 1239 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
STEP 2. | Check the accelerator pedal position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1241 active and Fault Code 1239 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 1239 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1239 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Fault Code 1695

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active and Fault Code 1239 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location.

Replace the accelerator pedal or lever. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 1241 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1239 active and Fault Code 1241 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 1241 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1241 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Fault Code 1696.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal position sensor supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the accelerator pedal position 5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active and Fault Code 1241 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active?
YES NO

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 1242 - Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Codes 131, 132, 1239, or 1241 active?
STEP 2. | Check the accelerator pedal position sensor readings. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 132 and 1241 both active?
 | STEP 2C. Check the accelerator pedal position 1 sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the accelerator pedal position 2 sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2E. Check the fault codes. | Fault Code 1242 inactive?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 131, 132, 1239, or 1241 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor readings.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 132 and 1241 both active?
YES NO
No Repair

If Fault Code 132 did not go active, follow Fault Code 132 troubleshooting tree.

If Fault Code 1241 did not go active, follow Fault Code 1241 troubleshooting tree.

Go to 2C

Appropriate fault code troubleshooting tree

Guided Step 2C - Check the accelerator pedal position 1 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

Measure the voltage from the accelerator pedal position 1 sensor +5 volt SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 132 troubleshooting tree.

Go to 2D

Fault Code 132 troubleshooting tree

Guided Step 2D - Check the accelerator pedal position 2 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

Measure the voltage from the accelerator pedal position 2 sensor +5 volt SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 1241 troubleshooting tree.

Go to 2E

Fault Code 1241 troubleshooting tree

Guided Step 2E - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1242 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 1 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged accelerator pedal has been detected.

Replace the accelerator pedal. See equipment manufacturer service information.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Apr-2017


FAULT CODE 1515 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 1515 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and the engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1515 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM vehicle electronic control unit and the ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the Society of Automotive Engineers (SAE) J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the multiplexed accelerator pedal or lever sensor system or OEM vehicle electronic control unit.

See equipment manufacturer service information.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Go to 1A

Last Modified: 07-Apr-2017


FAULT CODE 1664 - Aftertreatment 1 Diesel Oxidation Catalyst Missing - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX12 CM2350 X102 | 4310646
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF2.8 CM2220 F101 | 4310486
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L102 | 4332796
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | L9 CM2350 L119B | 5411267
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12 CM2350 X102 | 4310646
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX15 CM2350 X101 | 4310641

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3313, 3314, 3315, 3316, 3317, or 3318 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1963 active?
 | STEP 1C. Check for the presence of a diesel oxidation catalyst (DOC). | DOC present in the aftertreatment system?
STEP 2. | Check engine control module (ECM) calibration. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 3. | Check the aftertreatment fuel injector, if equipped. |
 | STEP 3A. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector meet the specifications?
 | STEP 3B. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector meet the specifications?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3313, 3314, 3315, 3316, 3317, or 3318 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1963 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for the presence of a diesel oxidation catalyst (DOC).

Conditions

  • Turn keyswitch OFF.
  • Remove the DOC from the vehicle. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Check the DOC.

  • Inspect for the presence of the DOC in the exhaust system.

DOC present in the aftertreatment system?
YES NO
No Repair

Install the proper DOC for the application. See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check engine control module (ECM) calibration.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment fuel injector, if equipped.

Guided Step 3A - Check the flow of the aftertreatment fuel injector, if equipped.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Note: If the aftertreatment fuel injector is not equipped, proceed to Step 4A.

Action

Perform the Aftertreatment System Test.

  • Refer to Procedure 011-054 in the Associated Procedures Table.

Aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Clean the aftertreatment injector.

  • Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 4A

Go to 3B

Guided Step 3B - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Action

Perform the Aftertreatment System Test.

  • Refer to Procedure 011-054 in the Associated Procedures Table.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Replace the aftertreatment injector.

  • Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Oct-2016


FAULT CODE 1843 - Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISX12 G CM2180 EJ | 4310682
Engine Control Module | Refer to Procedure 019-031 | ISL G CM2180 | 4021649
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 G CM2180 EJ | 4310682
Engine Wiring Harness | Refer to Procedure 019-043 | ISL G CM2180 | 4021649
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L102 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | VTA903 CM2250 V105 | 4332841
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 G CM2180 EJ | 4310682
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL G CM2180 | 4021649
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B142 | 5411131
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X114B | 5411181
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X116B | 5411186
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B135B | 5411257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B148B | 5411262
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1843 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active and Fault Code 1843 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor +5 volt SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

A damaged sensor has been detected.

Replace the crankcase pressure sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor +5 volt SUPPLY pin to the crankcase pressure sensor RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 1844 - Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISX12 G CM2180 EJ | 4310682
Engine Control Module | Refer to Procedure 019-031 | ISL G CM2180 | 4021649
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2250 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 G CM2180 EJ | 4310682
Engine Wiring Harness | Refer to Procedure 019-043 | ISL G CM2180 | 4021649
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2250 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L102 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | VTA903 CM2250 V105 | 4332841
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B1O6 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 G CM2180 EJ | 4310682
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL G CM2180 | 4021649
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B142 | 5411131
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X114B | 5411181
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X116B | 5411186
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2250 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B135B | 5411257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B148B | 5411262
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1844 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active and Fault Code 1844 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1844 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the crankcase pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

A damaged sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Datapate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 1866 - Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Connection | Refer to Procedure 010-080 | QSF3.8 CM2350 F107 | 4367316
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2250 | 4022254
Air Intake Connection | Refer to Procedure 010-080 | ISC8.3 ISL9 CM2250 | 4022257
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2250 | 4022256
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2250 | 4022255
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2250 EC | 2883621
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2350 B101 | 2883567
Air Intake Connection | Refer to Procedure 010-080 | ISL9 CM2350 L101 | 4310787
Air Intake Connection | Refer to Procedure 010-080 | ISB4.5 CM2350 B104 | 4332646
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2350 B103 | 4332641
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B105 | 4332778
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L102 | 4332796
Air Intake Connection | Refer to Procedure 010-080 | ISL9 CM2350 L111 | 4367223
Air Intake Connection | Refer to Procedure 010-080 | QSF2.8 CM2880 F105 | 4358561
Air Intake Connection | Refer to Procedure 010-080 | ISV5.0 CM3230 V104 | 4367291
Air Intake Connection | Refer to Procedure 010-080 | QSF2.8 CM2880 F114 | 4383734
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L107 | 4367386
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B130 | 4388668
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L118 | 4388673
Air Intake Connection | Refer to Procedure 010-080 | B6.7 CM2350 B121B | 5411223
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2350 B142 | 5411131
Air Intake Connection | Refer to Procedure 010-080 | L9 CM2350 L116B | 5411330
Air Intake Connection | Refer to Procedure 010-080 | B4.5 CM2350 B129B | 54111247
Air Intake Connection | Refer to Procedure 010-080 | B6.7 CM2350 B135B | 5411257
Air Intake Connection | Refer to Procedure 010-080 | B4.5 CM2350 B147B | 5411252
Air Intake Connection | Refer to Procedure 010-080 | B6.7 CM2350 B148B | 5411262
Air Intake Connection | Refer to Procedure 010-080 | L9 CM2350 L119B | 5411267
Air Intake Connection | Refer to Procedure 010-080 | L9 CM2350 L123B | 5411465
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX12/ISX11.9 CM2250 | 2883445
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX CM2250 GX CM2250 | 4022250
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | QSX11.9 CM2250 ECF | 2883561
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | QSX15 CM2250 ECF | 2883557
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX12 CM2350 X102 | 4310646
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX15 CM2350 X101 | 4310641
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | X15 CM2350 X114B | 5411181
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F14 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2250 | 4022254
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 EC | 2883621
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX11.9 CM2250 ECF | 2883561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2250 ECF | 2883557
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B101 | 2883567
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L101 | 4310787
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12 CM2350 X102 | 4310646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2350 X101 | 4310641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISF3.8 CM2220 F103 | 4310839
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F107 | 4367316
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB4.5 CM2350 B104 | 4332646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B103 | 4332641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B105 | 4332778
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L102 | 4332796
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L111 | 4367223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F105 | 4358561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B106 | 4367376
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F114 | 4383734
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367386
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B130 | 4388668
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L118 | 4388673
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X114B | 5411181
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X116B | 5411186
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B121B | 5411223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B142 | 5411131
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L116B | 5411330
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B129B | 5411247
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B135B | 5411257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B147B | 5411252
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B148B | 5411262
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L119B | 5411267
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 2273 and 2274. | Fault Code 2273 or 2274 active?
STEP 2. | Check the exhaust gas recirculation (EGR) differential pressure sensor ports. |
 | STEP 2A. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure port?
STEP 3. | Check the EGR differential pressure sensor and circuit. |
 | STEP 3A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins.
 | STEP 3B. Check the circuit response. | Fault Code 2274 active?
 | STEP 3C. Check the circuit response. | Fault Code 2273 active?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2274 active?
 | STEP 4C. Check the circuit response. | Fault Code 2273 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes 2273 and 2274.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 or 2274 active?
YES | NO
No Repair | No Repair

Fault Code 2273 or 2274 troubleshooting tree

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) differential pressure sensor ports.

Guided Step 2A - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

Action

Inspect the EGR differential pressure sensor ports and cross drillings for restrictions, soot plugging, and debris plugging.

  • For ISB, ISC, ISL, QSB, and QSL engines, use the following procedure in the appropriate manual. Refer to Procedure 010-080 in the Associated Procedures Table.
  • For ISX and QSX engines, use the following procedure in the appropriate manual. Refer to Procedure 011-066 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the debris or replace the EGR differential pressure tube.

  • For ISB, ISC, ISL, QSB, QSL, B4.5, and B6.7 engines, use the following procedure in the appropriate manual. Refer to Procedure 010-080 in the Associated Procedures Table.
  • For ISX and QSX engines, use the following procedure in the appropriate manual. Refer to Procedure 011-066 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the EGR differential pressure sensor and circuit.

Guided Step 3A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure 5 VOLT SUPPLY pin and the EGR differential pressure SIGNAL pin at the EGR differential pressure sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor.

  • Refer to Procedure 019-370 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure 5 VOLT SUPPLY pin and the EGR differential pressure SIGNAL pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 1879 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2220 F103 | 4310839
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1879 inactive?
STEP 2. | Check the aftertreatment DPF differential pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF differential pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1881 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1879 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1879 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Fault Code 1695 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DPF differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DPF differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment DPF differential pressure sensor SUPPLY pin and the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

None. The removal an installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor RETURN pin and the OEM harness aftertreatment DPF differential pressure sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 1881 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2220 F103 | 4310839
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1881 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) differential pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF differential pressure sensor and electronic connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1879 active?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1881 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1881 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Fault Code 1696 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DPF differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DPF differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment DPF differential pressure SUPPLY pin and the aftertreatment DPF differential pressure RETURN pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DPF differential pressure sensor SUPPLY pin and the aftertreatment DPF differential pressure sensor SIGNAL pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor SUPPLY pin and the OEM harness aftertreatment DPF differential pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor SIGNAL pin and the OEM harness aftertreatment DPF differential pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

The troubleshooting steps need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 1883 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Trap Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L101 | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | PowerGen QSX15 CM2250 ECF | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 ECF2 | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1879 and 1881. | Fault Code 1879 or 1881 active?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) differential pressure sensor tubes. |
 | STEP 2A. Check the aftertreatment DPF differential pressure sensor tubes. | Aftertreatment DPF differential pressure sensor tubes damaged, disconnected, or blocked?
 | STEP 2B. Monitor the aftertreatment DPF differential pressure sensor voltage. | Aftertreatment DPF differential pressure sensor voltage within specifications?
STEP 3. | Check the aftertreatment DPF differential pressure sensor and circuit. |
 | STEP 3A. Inspect the aftertreatment DPF differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1881 active?
 | STEP 3C. Check the circuit response. | Fault Code 1879 active?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect ECM and OEM harness connector pins. | Dirty or damaged?
 | STEP 4B. Check for resistance in the OEM harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 4E. Check the aftertreatment differential pressure sensor voltage value. | Value change?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1879 and 1881.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 or 1881 active?
YES | NO
No Repair | No Repair

Fault Code 1879 or 1881 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor tubes.

Guided Step 2A - Check the aftertreatment DPF differential pressure sensor tubes.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DPF differential pressure sensor tubes.

  • Make sure the tubes are installed correctly (not reversed).
  • Make sure both ends of the tubes are securely connected.
  • Inspect the tubes for leaks or damage.
  • Inspect the tubes for blockage. Refer to Procedure 011-047 in the Associated Procedures Table.

It is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tube in extreme cold ambient temperatures. Ice can form in the differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Aftertreatment DPF differential pressure sensor tubes damaged, disconnected, or blocked?
YES NO

Repair or replace the aftertreatment DPF differential pressure sensor tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Monitor the aftertratment DPF differential pressure sensor voltage.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Do not operate engine.
  • Connect INSITE™ electronic service tool.

Action

Monitor the aftertreatment DPF differential pressure sensor voltage with an electronic service tool.

An exhaust ventilation system connected to the exhaust can cause the differential pressure sensor to read incorrectly. Make sure to remove any ventilation or vacuum equipment from the exhaust before reading the differential pressure sensor value with INSITE™ electronic service tool.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor voltage reading within specifications?
YES NO
No Repair

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment DPF differential pressure sensor and circuit.

Guided Step 3A - Inspect the aftertreatment DPF differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DPF differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DPF differential pressure 5 volt SUPPLY pin and the aftertreatment DPF differential pressure SIGNAL pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1879 active?
YES NO

An in-range malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Replace the aftertreatment DPF differential pressure sensor.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and OEM harness.

Guided Step 4A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for resistance in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for resistance in the circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor SIGNAL pin and the OEM harness aftertreatment DPF differential pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

High resistance in the signal circuit has been detected in the OEM harness.

Troubleshoot each harness connector in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check the aftertreatment differential pressure sensor voltage value.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for a change in the voltage value.

  • Use INSITE™ electronic service tool to monitor the aftertreatment differential pressure sensor voltage.
  • Perform a snap acceleration test.

Value change?
YES NO
No Repair

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 1885 - Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK19 CM2350 K105 | 4326157
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK50 CM2350 K108 | 4332823
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K116 | 4367444
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K117 | 4367449
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K121 | 4388645
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B147B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3232 or 3682 active?
 | STEP 1B. Check for active and inactive fault codes. | Fault Code 1885 active or inactive with more than one count?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3232 or 3682 is active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active and inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885 active or inactive with more than one count?
YES NO

An internal error has been detected in the aftertreatment intake nitrogen oxides (NOx) sensor.

Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 1921 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L119B | 5411267
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | ISL9 CM2350 L111 | 4367223
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSG12 CM2350 G110 | 4367323
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSL9 CM2350 L118 | 4388673
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | F3.8 CM2350 F120B | 5411237
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | B4.5 CM2350 B129B | 5411247
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | B6.7 CM2350 B135B | 5411257
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | B4.5 CM2350 B147B | 5411252
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | B6.7 CM2350 B148B | 5411262
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | L9 CM2350 L119B | 5411267
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B101 | 2883567
Snap Acceleration Test | Refer to Procedure 014-017 | ISF3.8 CM2350 F109 | 4367218
Snap Acceleration Test | Refer to Procedure 014-017 | ISL9 CM2350 L101 | 4310787
Snap Acceleration Test | Refer to Procedure 014-017 | ISB4.5 CM2350 B104 | 4332646
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B103 | 4332641
Snap Acceleration Test | Refer to Procedure 014-017 | ISL9 CM2350 L111 | 4367223
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | QSG12 CM2350 G110 | 4367323
Snap Acceleration Test | Refer to Procedure 014-017 | ISF2.8 CM2220 F117 | 4388578
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B130 | 4388668
Snap Acceleration Test | Refer to Procedure 014-017 | QDL9 CM2350 L118 | 4388673
Snap Acceleration Test | Refer to Procedure 014-017 | ISF2.8 CM2220 F126 | 5411159
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B142 | 5411131
Snap Acceleration Test | Refer to Procedure 014-017 | F3.8 CM2350 F120B | 5411237
Snap Acceleration Test | Refer to Procedure 014-017 | B4.5 CM2350 B129B | 5411247
Snap Acceleration Test | Refer to Procedure 014-017 | B6.7 CM2350 B135B | 5411257
Snap Acceleration Test | Refer to Procedure 014-017 | B4.5 CM2350 B147B | 5411252
Snap Acceleration Test | Refer to Procedure 014-017 | B6.7 CM2350 B148B | 5411262
Snap Acceleration Test | Refer to Procedure 014-017 | L9 CM2350 L119B | 5411267

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes other than 1921 are active?
STEP 2. | Check the duty cycle of the application. |
 | STEP 2A. Check the aftertreatment duty cycle. | Does the duty cycle of the application need to be increased?
STEP 3. | Check the aftertreatment DPF differential tubes. |
 | STEP 3A. Check the aftertreatment DPF differential tubes. | Aftertreatment DPF differential pressure sensor tubes blocked?
STEP 4. | Perform stationary regeneration procedure. |
 | STEP 4A. Perform stationary regeneration procedure. | Fault Code 1921 active after the stationary regeneration has been completed?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes other than 1921 are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the duty cycle of the application.

Guided Step 2A - Check the aftertreatment duty cycle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the duty cycle.

  • Use INSITE™ electronic service tool to view the Duty Cycle of the engine.
  • View the Aftertreatment Trip Information.

Determine if the duty cycle of the application needs to change in order to increase the exhaust temperatures entering the aftertreatment system.

Does the duty cycle of the application need to be increased?
YES NO

Change the duty cycle of the application in order to increase the exhaust temperatures entering the aftertreatment system.

 No Repair

Appropriate base engine troubleshooting procedure

Go to 3A

Guided Step 3 - Check the aftertreatment DPF differential tubes.

Guided Step 3A - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor tubes.

Action

Check for plugged aftertreatment DPF differential pressure sensor tubes.

  • Inspect tubes for blockage. Refer to Procedure 011-047 in the Associated Procedures Table.

It is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tube in extreme cold ambient temperatures. Ice can form in the differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Aftertreatment DPF differential pressure sensor tubes blocked?
YES NO

Repair or replace the aftertreatment DPF differential pressure sensor tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Perform the stationary regeneration procedure.

Guided Step 4A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Perform the aftertreatment stationary regeneration procedure.

Use the following procedure for ISB4.5 CM2350 B104, ISB6.7 CM2350 B101, ISB6.7 CM2350 B103, ISL9 CM2350 L101, ISX12 CM2350 X102, ISX15 CM2350 X101, ISL9 CM2350 L111, B4.5 CM2350 B129B, B6.7 CM2350 B135B, B4.5 CM2350 B147B, B6.7 CM2350 B148B, and L9 CM2350 L119B engines:

  • Refer to Procedure 014-016 in the Associated Procedures Table.

Use the following procedure for ISL9 CM2350 L11 and L9 CM2350 L119B engines:

  • Refer to Procedure 014-015 in the Associated Procedures Table.

Use the following procedure for all other applications:

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Use INSITE™ electronic service tool to perform the aftertreatment DPF regeneration test found in the ECM diagnostic tests.

Fault Code 2639 will become active during the regeneration procedure. This is normal operation as the soot is removed from the aftertreatment DPF.

Fault Code 1921 active after the stationary regeneration has been completed?
YES NO

Check for active fault codes that may have become active during the regeneration event. Troubleshoot any active fault codes.

Perform the Snap Acceleration Test to check for a damaged DPF.

Use the following procedure for ISB4.5 CM2350 B104, ISB6.7 CM2350 B101, ISB6.7 CM2350 B103, ISL9 CM2350 L101, ISX12 CM2350 X102, and ISX15 CM2350 X101, ISL9 CM2350 L111, B4.5 CM2350 B129B, B6.7 CM2350 B135B, B4.5 CM2350 B147B, B6.7 CM2350 B148B, and L9 CM2350 L119B engines:

  • Refer to Procedure 014-017 in the Associated Procedures Table.

Use the following procedure for ISL9 CM2350 L11 and L9 CM2350 L119B engines:

  • Refer to Procedure 014-015 in the Associated Procedures Table.

Use the following procedure for all other applications:

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jun-2017


FAULT CODE 1922 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | L9 CM2350 L119B | 5411267
Snap Acceleration Test | Refer to Procedure 014-017 | ISF2.8 CM2220 F101 | 4310846
Snap Acceleration Test | Refer to Procedure 014-017 | ISF3.8 CM2350 F109 | 4367218
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B101 | 2883567
Snap Acceleration Test | Refer to Procedure 014-017 | ISL9 CM2350 L101 | 4310787
Snap Acceleration Test | Refer to Procedure 014-017 | ISX12 CM2350 X102 | 4310646
Snap Acceleration Test | Refer to Procedure 014-017 | ISX15 CM2350 X101 | 4310641
Snap Acceleration Test | Refer to Procedure 014-017 | ISB4.5 CM2350 B104 | 4332646
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B103 | 4332641
Snap Acceleration Test | Refer to Procedure 014-017 | ISL9 CM2350 L111 | 4367223
Snap Acceleration Test | Refer to Procedure 014-017 | QSG12 CM2350 G110 | 4367323
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISF2.8 CM2220 F117 | 4388578
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B130 | 4388668
Snap Acceleration Test | Refer to Procedure 014-017 | QSL9 CM2350 L118 | 4388673
Snap Acceleration Test | Refer to Procedure 014-017 | ISF2.8 CM2220 F126 | 5411159
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B142 | 5411131
Snap Acceleration Test | Refer to Procedure 014-017 | F3.8 CM2350 F120B | 5411237
Snap Acceleration Test | Refer to Procedure 014-017 | B4.5 CM2350 B129B | 5411247
Snap Acceleration Test | Refer to Procedure 014-017 | B6.7 CM2350 B135B | 5411257
Snap Acceleration Test | Refer to Procedure 014-017 | B4.5 CM2350 B147B | 5411252
Snap Acceleration Test | Refer to Procedure 014-017 | B6.7 CM2350 B148B | 5411262
Snap Acceleration Test | Refer to Procedure 014-017 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9 CM2350 L101 | 4310787
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2350 X101 | 4310641
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9 CM2350 L111 | 4367223
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSG12 CM2350 G110 | 4367323
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L118 | 4388673
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | F3.8 CM2350 F120B | 5411237
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B4.5 CM2350 B129B | 5411247
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B6.7 CM2350 B135B | 5411257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B4.5 CM2350 B147B | 5411252
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B6.7 CM2350 B148B | 5411262
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | L9 CM2350 L119B | 5411267

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1922 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3375 or 3376 active or inactive?
 | STEP 1C. Check for active fault codes. | Fault Code 1922 active?
 | STEP 1D. Review the fault code snapshot information. | Operator ignored aftertreatment diesel particulate filter (DPF) lamps?
 | STEP 1E. Perform the Aftertreatment DPF Reset Procedure. | Aftertreatment Maintenance Reset Procedure completed?
 | STEP 1F. Perform the stationary regeneration procedure. | Fault Code 1922 active after stationary regeneration completed?
STEP 2. | Check the aftertreatment temperature sensors. |
 | STEP 2A. Check for active fault codes. | Fault Code 3313, 3314, 3315, 3316, 3317, 3318, 3319, 3321, or 3322 active?
 | STEP 2B. Monitor the aftertreatment exhaust gas temperature sensors. | Aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 3. | Inspect the aftertreatment DPF differential pressure sensor. |
 | STEP 3A. Verify the aftertreatment DPF differential pressure sensor accuracy. | Aftertreatment DPF differential pressure sensor signal voltage within specification with the keyswitch ON and the engine OFF?
 | STEP 3B. Check the aftertreatment DPF differential pressure sensor tubes for blockage. | Aftertreatment DPF differential pressure sensor supply tubes blocked?
STEP 4. | Check the duty cycle of the application. |
 | STEP 4A. Check the aftertreatment duty cycle. | Duty cycle of the application need to be increased?
STEP 5. | Check for excessive black smoke. |
 | STEP 5A. Inspect the exhaust for excessive black smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
 | STEP 5B. Check aftertreatment diesel particulate filter restriction, if available. | Aftertreatment diesel particulate filter restriction within specifications?
 | STEP 5C. Inspect the aftertreatment diesel particulate filter. | Aftertreatment diesel particulate filter meet reuse guidelines?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1922 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3375 or 3376 active or inactive?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree for Fault Code 3375 or 3376

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1922 active?
YES NO

The aftertreatment DPF has plugged with soot and the stationary regeneration procedure can not be performed until it has been inspected and cleaned in an SPX air pulse cleaning machine, or equivalent machine.

Use the following instructions to remove, inspect, and clean or replace the aftertreatment DPF.

  • Refer to Procedure 011-041 in the Associated Procedures Table.

Use the following procedure if the aftertreatment DPF does not meet the inspection criteria and must be replaced.

  • Refer to Procedure 011-041 in the Associated Procedures Table.

Aftertreatment DPFs that meet the inspection criteria and are cleaned in an SPX air pulse cleaning machine, or equivalent machine, must have a stationary regeneration after the cleaning process is complete.

No Repair

Go to 1D

Repair complete

Guided Step 1D - Review the fault code snapshot information.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Review all fault codes, active or inactive, that are present in the ECM. Determine if any fault codes are present in the ECM that inhibit aftertreatment regeneration. If fault codes are present in the ECM that can inhibit aftertreatment regeneration, review the fault code snapshot information for the fault code(s) and determine if the fault code was active when Fault Codes 1921, 1922, and/or 2639 were active. If the fault(s) inhibiting aftertreatment regeneration were active when Fault Code 1921, 1922 and/or 2639 were active, it is likely the customer was not able to induce a stationary regeneration.
  • Review the ECM timestamps for Fault Codes 1921, 1922, and 2639.
  • If the ECM time stamp between each fault code is greater than 0.5 hour, the operator should be interviewed to determine why a stationary regeneration was not performed.

Fault Code 2777 indicates that the aftertreatment regeneration permit switch was in the inhibit position when Fault Codes 1921, 1922, and/or 2639 were active. Reference the appropriate troubleshooting tree for this fault code and determine if this fault was active at the time Fault Code 1922 was active.

Operator ignored aftertreatment DPF lamps?
YES NO

  • Inform the customer on the proper procedure for initiating a stationary regeneration.

 No Repair

Go to 1E

Go to 1E

Guided Step 1E - Perform the Aftertreatment DPF Procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset Procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment DPF Reset Procedure located in the aftertreatment maintenance selection under the advanced ECM data menu.
  • After clicking the OK button, it may take several minutes for Fault Code 1922 to go inactive, and Fault Code 1921 to go active.

Fault Code 1922 must be active before the Aftertreatment Maintenance Reset Procedure can be performed.

Fault Code 1922 will go inactive and Fault Code 1921 will go active after completing this procedure.

Aftertreatment Maintenance Reset Procedure completed?
YES NO
No Repair

Perform INSITE™ electronic service tool Aftertreatment Maintenance Reset Procedure listed in the Action section of this troubleshooting step.

Go to 1F

Go to 1F

Guided Step 1F - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the stationary regeneration procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment DPF Regeneration Test found in the ECM diagnostic tests.

Some vehicles can be equipped with a stationary regeneration switch in the dash. This switch can also be used to perform the stationary regeneration procedure. Refer to the original equipment manufacturer (OEM) service manual.

  • Refer to Procedure 014-016 in the Associated Procedures Table.

If stationary regeneration will not activate, please reference the Stationary Regeneration - Will Not Activate troubleshooting symptom tree in Section TS of the appropriate service manual.

Fault Code 2639 will become active during the regeneration procedure. This is normal operation as the soot is removed from the aftertreatment DPF.

Fault Code 1922 active after stationary regeneration has been completed?
YES NO

A system issue may be causing Fault Code 1922 to remain active.

Continue to follow the troubleshooting symptom tree to locate the issue causing Fault Code 1922 to remain active.

 No Repair

Go to 2A

Go to 6A

Guided Step 2 - Check the aftertreatment temperature sensors.

Guided Step 2A - Check for active fault codes

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment temperature sensors.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3313, 3314, 3315, 3316, 3317, 3318, 3319, 3321, or 3322 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2B

Guided Step 2B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle engine for greater than 10 minutes

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Inspect the aftertreatment DPF differential pressure sensor.

Guided Step 3A - Verify the aftertreatment DPF differential pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy.

  • Monitor the aftertreatment DPF differential pressure sensor signal voltage reading with INSITE™ electronic service tool.
  • Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor signal voltage within specification with the keyswitch ON and the engine OFF?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn engine OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor supply tubes.

Action

Disconnect the aftertreatment DPF differential pressure sensor supply tubes.

  • Inspect the supply tubes for blockage. Refer to Procedure 011-047 in the Associated Procedures Table.

It is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tube in extreme cold ambient temperatures. Ice can form in the differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Aftertreatment DPF differential pressure sensor supply tubes blocked?
YES NO

Remove and clean the aftertreatment DPF differential pressure sensor supply tubes. Refer to Procedure 011-047 in the Associated Procedures Table.

Check for a short circuit from the SIGNAL pin of the aftertreatment DPF differential pressure sensor to all other pins in the harness. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

If no short circuit is found, replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 4 - Check the duty cycle of the application.

Guided Step 4A - Check the aftertreatment duty cycle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the duty cycle.

  • Use INSITE™ electronic service tool to view the duty cycle of the engine.
  • View the aftertreatment trip information.

Determine if the duty cycle of the application needs to change in order to increase the temperature of the exhaust gases entering the aftertreatment system.

Duty cycle of the application need to be increased?
YES NO

Change the duty cycle of the application in order to increase the temperature of the exhaust gases entering the aftertreatment system.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check for excessive black smoke.

Guided Step 5A - Inspect the exhaust for excessive black smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform the Snap Acceleration - Aftertreatment Disconnected Test. Refer to Procedure 014-017 in the Associated Procedures Table.

To perform a snap acceleration test, it could be necessary to temporarily adjust the maximum engine speed with no vehicle speed sensor parameter in INSITE™ electronic service tool, to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of the excessive black smoke.

  • Reference the appropriate engine performance troubleshooting tree.

 No Repair

Go to 5B

Go to 5B

Guided Step 5B - Check aftertreatment diesel particulate filter restriction, if available.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • If the Aftertreatment Diesel Particulate Filter Restriction Test is not available, skip to Step 5C.

Action

Perform the following sections of the Aftertreatment Diesel Particulate Filter Restriction Test.

Refer to Procedure 011-085 in the Associated Procedures Table.

  • Test.
  • Analyzing the Data.

Aftertreatment diesel particulate filter restriction within specifications?
YES NO
No Repair

Replace the DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 5C - Inspect the aftertreatment diesel particulate filter.

Conditions

  • Remove the aftertreatment diesel particulate filter
  • Refer to Procedure 011-041 in the Associated Procedures Table.

Action

Inspect the aftertreatment diesel particulate filter.

  • Inspect the aftertreatment diesel particulate filter.
  • Refer to Procedure 011-041 in the Associated Procedures Table.

Aftertreatment diesel particulate filter meet reuse guidelines?
YES NO

Clean the aftertreatment diesel particulate filter. Refer to Procedure 011-041 in the Associated Procedures Table.

Remove and replace the aftertreatment diesel particulate filter. Refer to Procedure 011-041 in the Associated Procedures Table.

If the aftertreatment diesel particulate filter required replacement for excessive ash and had not reached the normal ash cleaning interval, further troubleshooting is required. Check for lubricating oil consumption, coolant consumption, or previous repairs that may have corrected an issue resulting in lubricating oil or coolant consumption. Reference the Ash Cleaning - Excessive troubleshooting symptom tree in Section TS, if necessary.

Go to 6A

Go to
Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to 1A

Last Modified: 15-Jun-2017


FAULT CODE 1927 - Aftertreatment Fuel Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Aftertreatment Fuel Pressure Sensor | Refer to Procedure 019-444 | ISX12 CM2350 X102 | 4310646
Aftertreatment Fuel Pressure Sensor | Refer to Procedure 019-444 | ISX15 CM2350 X101 | 4310641

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1927 inactive?
STEP 2. | Check the aftertreatment 1 fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1928 active and Fault Code 1927 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1927 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment 1 fuel pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment 1 fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment 1 fuel pressure sensor connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 active and Fault Code 1927 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 fuel pressure 5 volt SUPPLY pin to the aftertreatment 1 fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment 1 fuel pressure sensor.

  • Refer to Procedure 019-444 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 active and Fault Code 1927 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 fuel pressure 5 volt SUPPLY pin to the aftertreatment 1 fuel pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram and wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-May-2013


FAULT CODE 1928 - Aftertreatment Fuel Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Aftertreatment Fuel Pressure Sensor | Refer to Procedure 019-444 | ISX12 CM2350 X102 | 4310646
Aftertreatment Fuel Pressure Sensor | Refer to Procedure 019-444 | ISX15 CM2350 X101 | 4310641

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™//Metri-Pack™/ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1928 inactive?
STEP 2. | Check the aftertreatment 1 fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1927 active and Fault Code 1928 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1928 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment 1 fuel pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment 1 fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment 1 fuel pressure sensor connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 fuel pressure 5 volt SUPPLY pin to the aftertreatment 1 fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment 1 fuel pressure 5 volt SUPPLY pin and the aftertreatment 1 fuel pressure SIGNAL pin at the aftertreatment 1 fuel pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 active and Fault Code 1928 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment 1 fuel pressure sensor.

  • Refer to Procedure 019-444 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 fuel pressure 5 volt SUPPLY pin to the aftertreatment 1 fuel pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment 1 fuel pressure 5 volt SUPPLY pin and the aftertreatment 1 fuel pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram and wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 active and Fault Code 1928 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-May-2013


FAULT CODE 1938 - ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2150 SN | 4022190
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12 CM2350 X102 | 4310646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2350 X101 | 4310641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F101 | 4310846
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B105 | 4332778
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B106 | 4367376
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B101 | 2883567
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B130 | 4388668
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L118 | 4388673
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B122 | 4388767
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X114B | 5411181
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X116B | 5411186
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B121B | 5411223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B142 | 5411131
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L116B | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L116B | 5411330
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B129B | 5411247
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B135B | 5411257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B147B | 5411252
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B148B | 5411262
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L122 | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B144 | 5411382
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B145 | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L119B | 5411267
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L123B | 5411465
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal conditions?
STEP 2. | Check the variable geometry turbocharger (VGT) actuator and circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the VGT actuator. | Voltage greater than 10 VDC?
STEP 3. | Check the sensor supply voltage at the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the sensor supply voltage at the ECM. |
STEP 4. | Check if an ECM calibration and clear fault codes. |
 | STEP 4A. Compare ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable and clear fault code. |

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery terminals for corrosion or loose connections.

  • Inspect the battery terminal connections on both positive (+) and negative (-) terminals.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code tree

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage.

Normal Conditions:

  • At least 12 VDC (12 VDC systems)
  • At least 24 VDC (24 VDC systems).

Battery voltage acceptable in normal conditions?
YES NO
No Repair

Charge or replace the batteries.

See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check the VGT actuator and circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the VGT actuator or harness connector.

Clean the connector and pins

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the VGT actuator: Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the VGT actuator.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the VGT actuator.

  • Measure the voltage between the VGT actuator voltage SUPPLY pin and the VGT actuator RETURN pin at the VGT actuator wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10 VDC?
YES NO

A malfunctioning VGT actuator has been detected.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the supply voltage at the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Use a digital multimeter to measure the voltage between the VGT actuator SUPPLY pin and the VGT actuator RETURN pin at the ECM.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Voltage greater than 10 VDC?
YES NO

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Feb-2017


FAULT CODE 1942 - Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 G CM2180 EJ | 4310682
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | X15 CM2350 X114B | 5411181
Crankcase Breather (External) | Refer to Procedure 003-001 | X15 CM2350 X116B | 5411186
Crankcase Breather (External) | Refer to Procedure 003-001 | B6.7 CM2350 B121B | 5411223
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L116B | 5411330
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L122 | 5411278
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L119B | 5411267
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L123B | 5411465
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Crankcase Breather Element | Refer to Procedure 003-019 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Element | Refer to Procedure 003-019 | ISM11 CM876 SN | 4022196
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 | 4022256
Crankcase Breather Element | Refer to Procedure 003-019 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 ECF | 2883557
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2350 X101 | 4310641
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L118 | 4388673
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 X115 | 4388739
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L116B | 5411330
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L123B | 5411465
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2350 X118 | 5467247
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 M2350 B103 | 4332641
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B106 | 4367376
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B122 | 4388767
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISV5.0 CM3230 V104 | 4367291
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B128 | 4388601
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B130 | 4388668
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISL G CM2180 | 4021649
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2250 B131 | 4388774
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB3.3 CM2250 B137 | 5411058
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 CM2350 B142 | 5411131
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B121B | 5411330
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B135B | 5411257
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B148B | 5411262
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B144 | 5411382
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISX12 G CM2180 EJ | 4310682
Engine Control Module | Refer to Procedure 019-031 | ISL G CM2180 | 4021649
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 G CM2180 EJ | 4310682
Engine Wiring Harness | Refer to Procedure 019-043 | ISL G CM2180 | 4021649
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411189
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332541
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L102 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 G CM2180 EJ | 4310682
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL G CM2180 | 4021649
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X114B | 5411181
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X116B | 5411189
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B142 | 5411131
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B135B | 5411257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B148B | 5411262
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1843 and 1844. | Fault Code 1843 or 1844 active?
 | STEP 1B. Check the oil fill cap. | Oil fill cap properly installed?
 | STEP 1C. Check the crankcase filter tube, if equipped. | Crankcase breather hose connected properly and free of restrictions?
 | STEP 1D. Check the crankcase breather element, if equipped. | Crankcase breather element installed correctly?
 | STEP 1E. Check the mileage/hours on the crankcase ventilation filter since last maintenance. | Filter below maintenance interval?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1844 active?
 | STEP 3C. Check the circuit response. | Fault Code 1843 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1843 and 1844.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 or 1844 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check the oil fill cap.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil fill cap.

  • Check the oil fill cap for proper installation.

Oil fill cap properly installed?
YES NO
No Repair

Install the oil fill cap properly.

Go to 1C

Go to 1C

Guided Step 1C - Check the crankcase filter tube, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Skip to Step 1D, if the engine is not equipped with a crankcase filter tube.

Action

Check the crankcase breather tube between the engine and the crankcase filter assembly.

Make sure the breather tube is properly connected and there are no kinks or other restrictions present.

Crankcase breather hose connected properly and free of restrictions?
YES NO
No Repair

Properly connect the crankcase breather hose.

Go to 1D

Go to 4A

Guided Step 1D - Check the crankcase breather element, if equipped.

Conditions

  • Turn keyswitch OFF.

Action

Check that the crankcase breather element is correctly installed.

Use the procedure(s) appropriate for your application.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.
  • Refer to Procedure 003-001 in the Associated Procedures Table.

Crankcase breather element installed correctly?
YES NO
No Repair

Install the crankcase breather element correctly.

Use the procedure(s) appropriate for your application.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.
  • Refer to Procedure 003-001 in the Associated Procedures Table.

Go to 1E

Repair complete.

Guided Step 1E - Check the mileage/hours on the crankcase ventilation filter since last maintenance.

Conditions

  • Locate the maintenance record (miles/hours) of the latest crankcase breather filter replacement.

Action

Check the filter maintenance record.

  • Check the mileage/hours on the crankcase breather filter since the last maintenance.

Filter below the maintenance interval?
YES NO
No Repair

Replace the crankcase breather filter.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.

Go to 2A

Go to 4A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure 5 volt SUPPLY pin and the crankcase pressure SIGNAL pin at the crankcase pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1843 active?
YES NO

An in-range malfunction of the crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the crankcase pressure 5 volt SUPPLY pin and the crankcase pressure SIGNAL pin on the ECM.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1843 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 09-Feb-2017


FAULT CODE 1943 - Ambient Air Density - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF2.8 CM2220 F101 | 4310846
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISM11 CM876 SN | 4022196
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX12 CM2350 X102 | 4310646
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX15 CM2250 GX CM2250 | 4022250
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX15 CM2350 X101 | 4310641
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSG12 CM2350 G110 | 4367323
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF2.8 CM2220 F126 | 5411159
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSB3.3 CM2250 B137 | 5411058
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | X15 CM2350 X114B | 5411181
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | X15 CM2350 X116B | 5411186
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSX15 CM2350 X118 | 5467247
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSG12 CM2350 G113 | 5467252
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2250 X115 | 4388739
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2350 X118 | 5467247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 221 or 249 inactive?
 | STEP 1C. Check the barometric pressure sensor reading. | Is the value for the barometric pressure ± 25.4 mm Hg [± 1.0 in Hg]?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES | NO
No Repair | No Repair

Troubleshoot active fault codes

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 221 or 249 inactive?
YES | NO
No Repair | No Repair

Fault Code 221 or 249

Go to 1C

Guided Step 1C - Check the barometric pressure sensor reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor reading.

  • Use INSITE™ electronic service tool to read the value for the barometric pressure.
  • Use the chart in the following procedure for barometric pressure values.

Is the value for the barometric pressure within ± 25.4 mm Hg [± 1 in Hg]?
YES NO
No Repair

Replace the barometric pressure sensor.

  • Use the following procedure for ISM and ISX applications. Refer to Procedure 019-004 in the Associated Procedures Table.
  • Use the following procedure for B6.7, ISB, QSB, and ISC applications. Refer to Procedure 019-004 in the Associated Procedures Table. Refer to Procedure 019-466 in Section 19.
  • Use the following procedure for ISF2.8 CM2220 F101 and ISF2.8 CM2220 F117 applications. Refer to Procedure 019-004 in the Associated Procedures Table.
  • Use the following procedure for X15 CM2350 X114B applications. Refer to Procedure 019-004 in the Associated Procedures Table.
  • Use the following procedure for X115B applications. Refer to Procedure 019-466 in the Associated Procedures Table.
  • Use the following procedure for QSX11.9 CM2250 ECF engines. Refer to Procedure 019-466 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Jun-2017


FAULT CODE 1977 - Aftertreatment Doser Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX12 CM2350 X102 | 4310646
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1977 active?
STEP 2. | Check the aftertreatment fuel injector and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment fuel injector resistance. | Between .5 and 2.0 ohms?
 | STEP 2C. Check for a short to ground in the aftertreatment fuel injector. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open supply circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open return circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3G. Check for an inactive fault code. | Fault Code 1977 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1977 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment fuel injector and circuit.

Guided Step 2A - Inspect the aftertreatment fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment fuel injector resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check the resistance of the aftertreatment fuel injector.

  • Measure the resistance between the aftertreatment fuel injector SIGNAL pin and the aftertreatment fuel injector RETURN pin at the aftertreatment fuel injector connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between .5 and 2.0 ohms?
YES NO
No Repair

Replace the aftertreatment fuel injector.

  • Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short to ground in the aftertreatment fuel injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check for a short to ground.

  • Measure the resistance between the aftertreatment fuel injector SIGNAL pin and the metal case of the aftertreatment fuel injector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment fuel injector.

Replace the aftertreatment fuel injector.

  • Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment fuel injector SUPPLY pin and the engine harness aftertreatment fuel injector connector aftertreatment fuel injector SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open aftertreatment fuel injector supply circuit has been detected in the engine harness.

Repair or replace the wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open return circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment fuel injector RETURN pin and the engine harness aftertreatment fuel injector connector aftertreatment fuel injector RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open aftertreatment fuel injector return circuit has been detected in the engine harness.

Repair or replace the wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment fuel injector SUPPLY pin in the engine harness ECM connector and ground.
  • Measure the resistance between the aftertreatment fuel injector RETURN pin in the engine harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Repair or replace the wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment fuel injector SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the aftertreatment fuel injector SUPPLY wire has been detected in the engine harness.

Repair or replace the wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment fuel injector RETURN pin in the engine harness ECM connector and all other pins in the engine harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the aftertreatment fuel injector RETURN wire has been detected in the engine harness.

Repair or replace the wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3G

Go to 4A

Guided Step 3G - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Check for the appropriate circuit response after 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1977 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Feb-2014


FAULT CODE 1993 - Aftertreatment 1 Diesel Particulate Filter Missing - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2220 F103 | 4310839
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF3.8 CM2220 F103 | 4310839
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2220 F103 | 4310839
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1879, 1881, or 1883 active?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) differential pressure. |
 | STEP 2A. Check the aftertreatment DPF differential pressure sensor tubes. | Aftertreatment DPF differential pressure sensor tubes installed correctly?
STEP 3. | Check the pressure of the DPF. |
 | STEP 3A. Inspect the aftertreatment DPF. | Tampering or removal of the aftertreatment system detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, or 1883 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure.

Guided Step 2A - Check the aftertreatment DPF differential pressure sensor tubes.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DPF differential pressure sensor tubes for the following:

  • Leaks or cracks in the differential pressure sensor tubes.
  • Loose fittings on the differential pressure sensor tubes.
  • Missing or broken differential pressure sensor tubes.
  • Plugged tubes.
  • Make sure the differential pressure sensor tubes are installed correctly. It is possible the differential pressure tubes are connected backwards at the rubber tubes at the sensor connection. Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor tubes installed correctly?
YES NO
No Repair

Repair or replace the aftertreatment DPF differential pressure sensor tubes. Refer to Procedure 011-047 in the Associated Procedures Table

Go to 3A

Go to 4A

Guided Step 3 - Check the presence of the aftertreatment DPF.

Guided Step 3A - Inspect the aftertreatment DPF.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.
  • ISF2.8 CM2220 ECF2 and ISF3.8 CM2220 F103 engines only: Remove the aftertreatment diesel oxidation catalyst (DOC). Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DPF.

Inspect the aftertreatment system to determine if the aftertreatment DPF has been tampered with or has been removed from the exhaust system.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

Tampering or removal of the aftertreatment system detected?
YES NO

Install the correct aftertreatment system for the vehicle.

  • Refer to the Procedure 011-041 in the Associated Procedures Table.
  • ISF2.8 CM2220 ECF2 and ISF3.8 CM2220 F103 engines only: Refer to Procedure 011-049 in the Associated Procedures Table.

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure Refer to Procedure 019-443 in the Asscociated Procedure Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB4.5,ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2150 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Check for a short circuit to battery in the OEM harness. | Greater than 100k ohms?
 | STEP 2B. Check for a short circuit to keyswitch power in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Check for a short circuit to battery in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to battery.

  • Measure the resistance and check for a short circuit between the accelerator pedal position +5 volt SUPPLY pin and the ECM battery SUPPLY (+) pins in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to keyswitch power in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to keyswitch power.

  • Check for a short circuit between the accelerator pedal position +5 volt SUPPLY pin and the ECM keyswitch SIGNAL pin in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ Electronic Service Tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ and test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin-to-ground short circuit in the OEM harness. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the accelerator pedal/lever position sensor. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector or ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal +5 volt SUPPLY and all other pins in the OEM harness ECM connector.

Refer to the circuit art or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator +5 volt SUPPLY pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ Electronic Service Tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Apr-2017


FAULT CODE 2273 - Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2250 | 4022254
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 EC | 2883621
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX11.9 CM2250 ECF | 2883561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2250 ECF | 2883557
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 | 4310664
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B101 | 2883567
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L101 | 4310787
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12 CM2350 X102 | 4310646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2350 X101 | 4310641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISF3.8 CM2220 F103 | 4310839
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F107 | 4367316
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB4.5 CM2350 B104 | 4332646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B103 | 4332641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B105 | 4332778
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L102 | 4332796
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L111 | 4367223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F105 | 4358561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B106 | 4367376
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F114 | 4383734
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367386
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B130 | 4388668
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L118 | 4388673
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F118 | 4388708
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F119 | 4388703
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X114B | 5411181
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X116B | 5411186
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B121B | 5411223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B142 | 5411131
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L116B | 5411330
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B129B | 5411247
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B135B | 5411257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B147B | 5411252
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B148B | 5411262
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L119B | 5411267
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2273 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) differential pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2274 active and Fault Code 2273 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2273 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) differential pressure sensor and circuit.

Guided Step 2A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active and Fault Code 2273 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR differential pressure sensor SUPPLY pin to the EGR differential pressure sensor RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR differential pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active and Fault Code 2273 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR differential pressure sensor SUPPLY pin to the EGR differential pressure sensor RETURN pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related ti this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault the Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2274 - Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2250 | 4022254
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 EC | 2883621
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX11.9 CM2250 ECF | 2883561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2250 ECF | 2883557
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 | 4310664
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B101 | 2883567
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L101 | 4310787
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12 CM2350 X102 | 4310646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2350 X101 | 4310641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISF3.8 CM2220 F103 | 4310839
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F107 | 4367316
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB4.5 CM2350 B104 | 4332646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B103 | 4332641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B105 | 4332778
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L102 | 4332796
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L111 | 4367223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F105 | 4358561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B106 | 4367376
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F114 | 4383734
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367386
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B130 | 4388668
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L118 | 4388673
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F118 | 4388708
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F119 | 4388703
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X114B | 5411181
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X116B | 5411186
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B121B | 5411223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B142 | 5411131
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L116B | 5411330
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B129B | 5411247
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B135B | 5411257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B147B | 5411252
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B148B | 5411262
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L119B | 5411267
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2274 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) differential pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2273 active and Fault Code 2274 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2274 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) differential pressure sensor and circuit.

Guided Step 2A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR differential pressure sensor SUPPLY pin to the EGR differential pressure sensor RETURN pin at the sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor SIGNAL pin at the EGR differential pressure sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active and Fault Code 2274 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR differential pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR differential pressure sensor SUPPLY pin to the EGR differential pressure sensor RETURN pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor SIGNAL pin at the ECM connector.

See the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active and Fault Code 2274 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault the Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2288 - Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2288. | Active or inactive counts of Fault Code 2288?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2288.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive counts of Fault Code 2288.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2288?
YES NO

The engine has been derated due to turbocharger high speed conditions. This is normal operation, but a torque derate was used to protect the engine from exceeding turbocharger high speed limits.

No repair action is necessary.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Jun-2014


FAULT CODE 2321 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 SN | 4310736
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F103 | 4310839
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5 CM2350 B104 | 4332646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD4.5 CM2150 B119 | 4358465
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2150 B120 | 4358470
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 L110 | 4358475
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F110 | 4358480
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2350 F109 | 4367218
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L111 | 4367223
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F114 | 4383734
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 L115 | 4388626
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | 6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 689 active or has a high number of inactive counts?
STEP 2. | Check the primary speed sensor circuit (crankshaft sensor). |
 | STEP 2A. Inspect the primary speed sensor connector pins (crankshaft sensor). | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness engine control module (ECM) connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Does Fault Code 2321 become active during engine operation?
 | STEP 3B. Inspect the air gap and target wheel. | Air gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Fault Code 2321 status change from inactive to active while manipulating the engine harness?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or has a high number of inactive counts?
YES NO

If Fault Code 689 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

No Repair

Fault Code 689 troubleshooting tree

Go to 2A

Guided Step 2 - Check the primary speed sensor circuit (crankshaft sensor).

Guided Step 2A - Inspect the primary speed sensor connector pins (crankshaft sensor).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the primary speed sensor.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the primary speed sensor (crankshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. With the engine operating, accelerate the engine several times.

  • Use INSITE™ electronic service tool to observe fault codes.

Does Fault Code 2321 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Remove the primary engine speed sensor (crankshaft) from the engine block and measure the air gap at several points in the crankshaft's revolution.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.96 mm [0.038 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2321 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backwards from the ECM connector towards the engine speed sensor connector.

Fault Code 2321 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 2322 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | Westport HD CM2250 | 4021560
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F101 | 4310846
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 F103 | 4310839
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2350 F109 | 4367218
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B101 | 2883567
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2150 SN | 4022190
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9 CM2350 L101 | 4310787
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12 CM2350 X102 | 4310646
Camshaft Position Sensor | Refer to Procedure 019-363 | ISZ13 CM2150 | 4022133
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2250 | 4022254
Camshaft Position Sensor | Refer to Procedure 019-363 | ISC8.3 and ISL9 CM2250 | 4022257
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2250 GX CM2250 | 4022250
Camshaft Position Sensor | Refer to Procedure 019-363 | Westport HD CM2250 | 4021560
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12/ISX11.9 CM2250 | 2883445
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 EC | 2883647
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2250 | 4022256
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 | 4022255
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 EC | 2883621
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX11.9 CM2250 ECF | 2883561
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2250 ECF | 2883557
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 ECF | 4310661
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 | 4310664
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2350 X101 | 4310641
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB4.5 CM2350 B104 | 4332646
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B103 | 4332641
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 M CM2250 L106 | 4358343
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B105 | 4332778
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L102 | 4332796
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD4.5 CM2150 B119 | 4358465
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD6.7 CM2150 B120 | 4358470
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2150 L110 | 4358475
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 F110 | 4358480
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B112 | 4358498
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F107 | 4367316
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9 CM2350 L111 | 4367223
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F105 | 4358561
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F114 | 4383734
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B106 | 4367376
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F117 | 4388578
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 B128 | 4388601
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2250 L115 | 4388626
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B130 | 4388668
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L118 | 4388626
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2250 B131 | 4388774
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 B137 | 5411058
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F126 | 5411159
Camshaft Position Sensor | Refer to Procedure 019-363 | X15 CM2350 X114B | 5411181
Camshaft Position Sensor | Refer to Procedure 019-363 | X15 CM2350 X116B | 5411186
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B121B | 5411223
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B142 | 5411131
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2250 X115 | 4388739
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L116B | 5411330
Camshaft Position Sensor | Refer to Procedure 019-363 | F3.8 CM2350 F120B | 5411237
Camshaft Position Sensor | Refer to Procedure 019-363 | B4.5 CM2350 B129B | 5411247
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B135B | 5411257
Camshaft Position Sensor | Refer to Procedure 019-363 | B4.5 CM2350 B147B | 5411252
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B148B | 5411262
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L119B | 5411267
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L122 | 5411278
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B144 | 5411382
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B145 | 5411273
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F124 | 5411484
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F131 | 5411489
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F125 | 5411494
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L123B | 5411465
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 778 active or has a high number of inactive counts?
STEP 2. | Check the secondary speed sensor circuit (camshaft sensor). |
 | STEP 2A. Inspect the secondary speed sensor (camshaft sensor) connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Does Fault Code 2322 become active during engine operation?
 | STEP 3B. Inspect the air gap and target wheel. | Air gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 2322 status change from inactive to active while manipulating the engine harness?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active or has a high number of inactive counts?
YES NO

If Fault Code 778 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

No Repair

Fault Code 778.

Go to 2A

Guided Step 2 - Check the secondary speed sensor circuit (camshaft sensor).

Guided Step 2A - Inspect the secondary speed sensor (camshaft sensor) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the secondary speed sensor.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the secondary speed sensor (camshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

With the engine operating, accelerate the engine several times.

  • Use INSITE™ electronic service tool to observe fault codes.

Does Fault Code 2322 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the secondary engine speed sensor (camshaft sensor) from the gear housing and measure the air gap at several points in the camshaft's revolution. Refer to Procedure 019-363 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2322 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backward from the ECM connector toward the engine speed sensor connector.

Does Fault Code 2322 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 2346 - Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active turbocharger fault codes. | Fault Code 2346 active or high inactive counts?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault codes. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2346 active or high inactive counts?
YES NO

The engine power output was derated to limit the exhaust temperatures. This is normal operation. No repairs are necessary.

 No Repair

Reference Fault Code 2451 troubleshooting procedures.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Jun-2014


FAULT CODE 2373 - Exhaust Gas Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119 | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL8.9 CM2150 SN | 4022190
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISV5.0 CM3230 V104 | 4367291
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 | 4022256
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 | 4022255
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F101 | 4310846
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF3.8 CM2350 F109 | 4367218
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB4.5 CM2350 B104 | 4332646
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B103 | 4332641
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L102 | 4332968
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L107 | 4367386
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L111 | 4367223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G110 | 4367323
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 B128 | 4388601
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 L115 | 4388626
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F117 | 4388578
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F118 | 4388708
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F119 | 4388703
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2250 B131 | 4388774
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F126 | 5411159
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X114B | 5411181
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X116B | 5411186
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B121B | 5411223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B142 | 5411131
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 X115 | 4388739
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L116B | 5411330
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | F3.8 CM2350 F120B | 5411237
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B129B | 5411247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B135B | 5411257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B147B | 5411252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B148B | 5411262
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L119B | 5411267
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L123B | 5411465
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L122 | 5411278
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B144 | 5411382
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B145 | 5411273
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F125 | 5411494
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2350 X118 | 5467247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2373 inactive?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2374 active and Fault Code 2373 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2373 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to the Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 2374 - Exhaust Gas Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM3250 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM3250 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISL8.9 CM2150 SN | 4022190
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISV5.0 CM3230 V104 | 4367291
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 | 4022256
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 | 4022255
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F101 | 4310846
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISF3.8 CM2350 F109 | 4367218
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB4.5 CM2350 B104 | 4332646
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B103 | 4332641
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L102 | 4332796
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L107 | 4367386
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L111 | 4367223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G110 | 4367323
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F117 | 4388578
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F118 | 4388708
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F119 | 4388703
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 B128 | 4388601
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 L115 | 4388626
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2250 F126 | 5411159
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X114B | 5411181
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X116B | 5411186
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B121B | 5411223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2250 B131 | 4388774
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 X115 | 4388739
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM3250 B142 | 5411131
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L116B | 5411330
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | F3.8 CM2350 F120B | 5411237
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B129B | 5411247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B135B | 5411257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B147B | 5411252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B148B | 5411262
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L119B | 5411267
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L123B | 5411465
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L122 | 5411278
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B144 | 5411382
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B145 | 5411273
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F125 | 5411494
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2350 X118 | 5467247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP :1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2374 inactive?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2373 active and Fault Code 2374 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2374 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas pressure sensor SUPPLY pin to the exhaust gas pressure sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 2375 - Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2250 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F017 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2220 F103 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2250 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 43332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | B6.9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2250 | 4022254
EGR Temperature Sensor | Refer to Procedure 019-378 | ISV5.0 CM3230 V104 | 4367291
EGR Temperature Sensor | Refer to Procedure 019-378 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2250 GX CM2250 | 4022250
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12/ISX11.9 CM2250 | 2883445
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2250 | 4022256
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 EC | 2883621
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 | 4022255
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 EC | 2883621
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX11.9 CM2250 ECF | 2883561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX15 CM2250 ECF | 2883557
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 | 4310664
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B101 | 2883567
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L101 | 4310787
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12 CM2350 X102 | 4310646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2350 X101 | 4310641
EGR Temperature Sensor | Refer to Procedure 019-378 | ISF3.8 CM2250 | 4310839
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB4.5 CM2350 B104 | 4332646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B103 | 4332641
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B105 | 4332778
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L102 | 4332796
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L107 | 4367386
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B112 | 4358498
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F107 | 4367316
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L111 | 4367223
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF2.8 CM2880 F105 | 4358561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF2.8 CM2880 F114 | 4383734
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B106 | 4367376
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B130 | 4388668
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L118 | 4388673
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F118 | 4388708
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F119 | 4388703
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B122 | 4388767
EGR Temperature Sensor | Refer to Procedure 019-378 | X15 CM2350 X114B | 5411181
EGR Temperature Sensor | Refer to Procedure 019-378 | X15 CM2350 X116B | 5411186
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B121B | 5411223
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B142 | 5411131
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L116B | 5411330
EGR Temperature Sensor | Refer to Procedure 019-378 | B4.5 CM2350 B129B | 5411247
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B135B | 5411257
EGR Temperature Sensor | Refer to Procedure 019-378 | B4.5 CM2350 B147B | 5411252
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B148B | 5411262
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L119B | 5411267
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2375 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Resistance between 200 ohms to 2.4M ohms?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2375 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2376 active and Fault Code 2375 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2375 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the EGR temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and EGR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the EGR temperature sensor.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 200 ohms to 2.4M ohms?
YES NO
No Repair

Replace the EGR temperature sensor. Refer to Procedure 019-378 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2376 active and Fault Code 2375 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor RETURN pin and the engine harness EGR temperature sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor SIGNAL pin and the engine harness EGR temperature sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedure needs to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2376 - Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V102102 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Temperature Sensor | Refer to Procedure 019-378 | ISV5.0 CM3230 V104 | 4367291
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2250 | 4022254
EGR Temperature Sensor | Refer to Procedure 019-378 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2250 GX CM2250 | 4022250
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12/ISX11.9 CM2250 | 2883445
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2250 | 4022256
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 | 4022255
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 EC | 2883621
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX11.9 CM2250 ECF | 2883561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX15 CM2250 ECF | 2883557
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 | 4310664
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B101 | 2883567
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L101 | 4310787
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12 CM2350 X102 | 4310646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2350 X101 | 4310641
EGR Temperature Sensor | Refer to Procedure 019-378 | ISF3.8 CM2220 F103 | 4310839
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB4.5 CM2350 B104 | 4332646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B103 | 4332641
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B105 | 4332778
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L107 | 4367386
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B112 | 4358498
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L111 | 4367223
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F017 | 4367316
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF2.8 CM2880 F105 | 4358561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B106 | 4367376
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B130 | 4388668
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L118 | 4388673
EFR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F118 | 4388708
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F119 | 4388703
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B122 | 4388767
EGR Temperature Sensor | Refer to Procedure 019-378 | X15 CM2350 X114B | 5411181
EGR Temperature Sensor | Refer to Procedure 019-378 | X15 CM2350 X116B | 5411186
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B121B | 5411223
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B142 | 5411131
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L116B | 5411330
EGR Temperature Sensor | Refer to Procedure 019-378 | B4.5 CM2350 B129B | 5411247
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B135B | 5411257
EGR Temperature Sensor | Refer to Procedure 019-378 | B4.5 CM2350 B147B | 5411252
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B148B | 5411262
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L119B | 5411267
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L123 | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 2376 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2376 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2376 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and EGR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 active?
YES NO

Replace the EGR temperature sensor. Refer to Procedure 019-378 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedure Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A pin-to-pin short on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and ground

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedure needs to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310849
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control solenoid. | Less than 10 ohms?
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage, supply wire, and return circuit. | Greater than 5 VDC?
 | STEP 2D. Check for an open circuit in the fan control solenoid return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan solenoid from the OEM harness.

Action

Inspect the OEM harness and fan solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check fan control solenoid resistance.

  • Measure the resistance between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the fan control solenoid has been detected.

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage, supply wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the fan control solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fan control solenoid return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the fan control solenoid RETURN pin in the OEM harness and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM fan control solenoid SIGNAL pin and the OEM harness fan control solenoid connector fan control solenoid SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fan control solenoid signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fan control solenoid SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Use the following procedure for the ISF2.8 CM2220 E, ISF2.8 CM2220 EN, ISF2.8 CM2220 IAN engines: Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 2448 - Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 SN | 4022190
Cooling System | Refer to Procedure 008-018 | ISM11 CM876 SN | 4022196
Cooling System | Refer to Procedure 008-018 | ISZ13 CM2150 | 4022133
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 EC | 2883647
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 SN | 4310736
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Cooling System | Refer to Procedure 008-018 | ISB/ISD4.5 CM2150 B119 | 4358465
Cooling System | Refer to Procedure 008-018 | ISB/ISD6.7 CM2150 B120 | 4358470
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 L110 | 4358475
Cooling System | Refer to Procedure 008-018 | ISF3.8 CM2220 F110 | 4358480
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z101 | 4358364
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z102 | 4358369
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F105 | 4358561
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F114 | 4383734
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F131 | 5411489
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G110 | 4367323
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 L115 | 4388626
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 B128 | 4388601
Cooling System | Refer to Procedure 008-018 | ISF3.8 CM2220 F116 | 4383664
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F118 | 4388708
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F119 | 4388703
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2250 B131 | 4388774
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 B137 | 5411058
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X116B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 X115 | 4388739
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L116B | 5411330
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L123B | 5411465
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L122 | 5411278
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B144 | 5411382
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B145 | 5411273
Cooling System | Refer to Procedure 008-018 | ISF4.5 CM2220 F123 | 5411320
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F124 | 5411484
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F125 | 5411494
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X118 | 5467247
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2448. | Active or inactive counts of Fault Code 2448?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2448.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2448?
YES NO

Add coolant to the engine.

Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 2448 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

If the vehicle is equipped with dual coolant level sensors, Fault Code 2448 will set for the lowest mounted coolant level sensor in the tank. Only replace the lowest mounted coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Mar-2017


FAULT CODE 2449 - VGT Actuator Controller - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 SN | 4022190
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 ECF | 4310661
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 | 4310664
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 F101 | 4310846
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 B128 | 4388601
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 L115 | 4388626
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 X115 | 4388739
Turbocharger | Refer to Procedure 010-033 | ISL8.9 CM2150 SN | 4022190
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2250 | 4022254
Turbocharger | Refer to Procedure 010-033 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger | Refer to Procedure 010-033 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2250 | 4022256
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 | 4022255
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 EC | 2883621
Turbocharger | Refer to Procedure 010-033 | QSX11.9 CM2250 ECF | 2883561
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 ECF | 2883557
Turbocharger | Refer to Procedure 010-033 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger | Refer to Procedure 010-033 | PowerGen QSX15 CM2250 | 4310664
Turbocharger | Refer to Procedure 010-033 | ISB4.5 CM2350 B104 | 4332646
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2350 B103 | 4332641
Turbocharger | Refer to Procedure 010-033 | ISL9 CM2350 L111 | 4367223
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 B128 | 4388601
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2250 L115 | 4388626
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2150 SN | 4022190
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 ECF | 2883557
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F101 | 4310846
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB4.5 CM2350 B104 | 4332646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B103 | 4332641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L111 | 4367223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and previous service history. |
 | STEP 1A. Check for active fault codes. | Fault Code 2449 active?
 | STEP 1B. Check for previous variable geometry turbocharger (VGT) actuator removals. | VGT actuator has just been removed or replaced?
 | STEP 1C. Check for active fault codes. | Fault Code 1938 or 2636 active?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear broken or damaged on the VGT actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Use the sector gear gauge. Nozzle movement meet the requirements according to Procedure 010-134?
 | STEP 2D. Check the VGT output gear for correct calibration. | VGT actuator gear moves when connected to the engine wiring harness?
 | STEP 2D-1. Check the VGT output gear for manual rotation by hand. |
 | STEP 2E. Check for active Fault Code 2449. | Fault Code 2449 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and previous service history.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2449.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Cycle the keyswitch several times. Wait 30 seconds between each key cycle to see if Fault Code 2449 goes active.

Fault Code 2449 active?
YES NO
No Repair

No troubleshooting is necessary unless Fault Code 2449 is active. Clear the inactive fault code.

Go to 1B

Go to 3A

Guided Step 1B - Check for previous VGT actuator removals.

Action

Determine if the actuator has just been removed or replaced and Fault Code 2449 is active.

VGT actuator has just been removed or replaced?
YES NO

Remove the actuator and install it in the correct position.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1938 or 2636 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting procedure

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Repace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect the VGT actuator.

  • Check for a broken drive gear on the VGT actuator.

Gear is broken or damaged on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove the VGT actuator from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger housing up and down from stop to stop. Check for smooth movement between the stops.

Note: It may take considerable force to move the sector gear. If it can be moved by hand, this is considered acceptable. Do not use any hand tools.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Use the sector gear gauge. Does the nozzle movement meet the requirements according to Procedure 010-134?
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

NOTE: This malfunction can be caused by debris exiting the engine, causing the turbocharger to stop moving. Inspect base engine components for signs of damage.

Replace the turbocharger.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the VGT output gear for correct calibration.

Conditions

  • Disconnect the VGT actuator from the engine wiring harness.
  • Turn keyswitch ON.

Action

Check the VGT actuator output gear operation.

  • Connect the VGT actuator to the engine wiring harness. The VGT actuator gear should rotate.

The VGT actuator output gear will exhibit one of the following movements, depending on the ECM calibration. Make sure to closely observe the VGT actuator gear when the VGT actuator is connected to the engine wiring harness.

  • The actuator output gear could possibly rotate completely in one direction and then rotate completely in the opposite direction, OR
  • The actuator output gear may only move a few degrees in one direction. This movement will be a quick snap when the VGT actuator is connected to the engine wiring harness.
  • If the VGT actuator gear does not move, disconnect the VGT actuator from the engine wiring harness for 1 second and then reconnect.
  • Repeat the above procedure three times, checking for VGT actuator gear movement each time the VGT actuator is connected to the engine wiring harness.

VGT actuator gear moves when connected to the engine wiring harness?
YES NO

Install the VGT actuator back on the turbocharger. Be sure the theft actuator install and calibrate procedues are performed.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check the VGT output gear for manual rotation by hand.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine wiring harness.

Action

Turn the VGT actuator output gear by hand.

  • Try turning the VGT actuator output gear by hand in either direction.

Do not use pliers or any other tool to turn the gear. Only rotate the gear by hand.

VGT actuator output gear rotates by hand?
YES NO

Install the VGT actuator back on the turbocharger. Be sure the theft actuator install and calibrate procedues are performed.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for active Fault Code 2449.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active Fault Code 2449.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2449 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jun-2016


FAULT CODE 2468 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411330
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring downhill?
 | STEP 1B. Check for an alternative fuel source. | Alternative fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. |
 | STEP 1D. Check for an active fault codeat low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 2468 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring downhill?
YES NO
No Repair

Check for engine damage.

  • Electronics are okay.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternative fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternative fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 2000 rpm, followed by moderate deceleration to 2000 rpm.

Alternative fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

1D

Refer to Fault Codes 689 and 778.

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.
  • Start and idle the engine.

Action

Check for active Fault Code 2468 when the engine is not operating above 2000 rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Assoicated Procedures Table.

1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test to check if the overspeed condition is still present.

Fault Code 2468 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jan-2017


FAULT CODE 2554 - Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 F101 | 4310846
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G110 | 4367323
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 F117 | 4388578
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 B128 | 4388601
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 L115 | 4388626
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 F126 | 5411159
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X116B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 X115 | 4388739
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L116B | 5411330
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L123B | 5411465
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B145 | 5411273
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L122 | 5411278
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B144 | 5411382
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X118 | 5467247
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G113 | 5467252
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2250 | 4022254
Turbocharger | Refer to Procedure 010-033 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger | Refer to Procedure 010-033 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2250 | 4022256
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 | 4022255
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 EC | 2883621
Turbocharger | Refer to Procedure 010-033 | QSX11.9 CM2250 ECF | 2883561
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 ECF | 2883557
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2350 B101 | 2883567
Turbocharger | Refer to Procedure 010-033 | ISL9 CM2350 L101 | 4310787
Turbocharger | Refer to Procedure 010-033 | ISX12 CM2350 X102 | 4310646
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2350 X101 | 4310641
Turbocharger | Refer to Procedure 010-033 | ISB4.5 CM2350 B104 | 4332646
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2350 B103 | 4332641
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2350 B105 | 4332778
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2350 L102 | 4332796
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2350 B112 | 4358498
Turbocharger | Refer to Procedure 010-033 | ISL9 CM2350 L111 | 4367223
Turbocharger | Refer to Procedure 010-033 | QSF3.8 CM2350 F107 | 4367316
Turbocharger | Refer to Procedure 010-033 | ISF2.8 CM2220 F101 | 4310846
Turbocharger | Refer to Procedure 010-033 | QSG12 CM2350 G110 | 4367323
Turbocharger | Refer to Procedure 010-033 | ISF2.8 CM2220 F117 | 4388578
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 B128 | 4388601
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2250 L115 | 4388626
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2350 B130 | 4388668
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2350 L118 | 4388673
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2350 B142 | 5411131
Turbocharger | Refer to Procedure 010-033 | ISF2.8 CM2220 F126 | 5411159
Turbocharger | Refer to Procedure 010-033 | X15 CM2350 X114B | 5411181
Turbocharger | Refer to Procedure 010-033 | X15 CM2350 X116B | 5411186
Turbocharger | Refer to Procedure 010-033 | B6.7 CM2350 B121B | 5411223
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 X115 | 4388739
Turbocharger | Refer to Procedure 010-033 | L9 CM2350 L116B | 5411330
Turbocharger | Refer to Procedure 010-033 | B4.5 CM2350 B129B | 5411247
Turbocharger | Refer to Procedure 010-033 | B6.7 CM2350 B135B | 5411257
Turbocharger | Refer to Procedure 010-033 | B4.5 CM2350 B147B | 5411252
Turbocharger | Refer to Procedure 010-033 | B6.7 CM2350 B148B | 5411262
Turbocharger | Refer to Procedure 010-033 | L9 CM2350 L119B | 5411267
Turbocharger | Refer to Procedure 010-033 | L9 CM2350 L123B | 5411465
Turbocharger | Refer to Procedure 010-033 | QSB4.5 CM2350 B106 | 4367376
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2350 B145 | 5411273
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2350 L122 | 5411278
Turbocharger | Refer to Procedure 010-033 | QSB4.5 CM2350 B144 | 5411382
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2350 X118 | 5467247
Turbocharger | Refer to Procedure 010-033 | QSG12 CM2350 G113 | 5467252
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | QSG12 CM2350 G110 | 4367323
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | QSG12 CM2350 G113 | 5467252
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B101 | 2883567
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L101 | 4310787
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12 CM2350 X102 | 4310646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2350 X101 | 4310641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB4.5 CM2350 B104 | 4332646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B103 | 4332641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B105 | 4332778
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L111 | 4367223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B106 | 4367376
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F101 | 4310846
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F117 | 4388578
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QB6.7 CM2350 B130 | 4388668
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L118 | 4388673
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B122 | 4388767
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B142 | 5411131
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F126 | 5411159
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X114B | 5411181
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X116B | 5411186
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B121B | 5411223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L116B | 5411330
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B129B | 5411247
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B135B | 5411257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B147B | 5411252
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B148B | 5411262
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L119B | 5411267
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | CM2350 L119B | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L119B | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L123B | 5411465
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B145 | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L122 | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B144 | 5411382
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2350 X118 | 5467247
Turbocharger, Variable Flow | Refer to Procedure 010-148 | QSB4.5 CM2350 B106 | 4367376
Turbocharger, Variable Flow | Refer to Procedure 010-148 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2250 | 4022256
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2250 | 4022255
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISB4.5 CM2350 B104 | 4332646
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISB6.7 CM2350 B103 | 4332641
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L102 | 4332796
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISL9 CM2350 L111 | 4367223
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSF3.8 CM2350 F107 | 4367316
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISF2.8 CM2220 F101 | 4310846
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSG12 CM2350 G110 | 4367323
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISF2.8 CM2220 F117 | 4388578
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2250 B128 | 4388601
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2250 L115 | 4388626
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISB6.7 CM2350 B142 | 5411131
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISF2.8 CM2220 F126 | 5411159
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | X15 CM2350 X114B | 5411181
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | X15 CM2350 X116B | 5411186
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | B6.7 CM2350 B121B | 5411223
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSX15 CM2250 X115 | 4388739
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | L9 CM2350 L116B | 5411330
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | B4.5 CM2350 B129B | 5411247
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | B6.7 CM2350 B135B | 5411257
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | B4.5 CM2350 B147B | 5411252
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | B6.7 CM2350 B148B | 5411262
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | L9 CM2350 L119B | 5411267
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | L9 CM2350 L123B | 5411465
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B145 | 5411273
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L122 | 5411278
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB4.5 CM2350 B144 | 5411382
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSX15 CM2350 X118 | 5467247
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 | 4022256
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 | 4022255
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB4.5 CM2350 B104 | 4332646
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B103 | 4332641
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L102 | 4332796
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L111 | 4367223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F101 | 4310846
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G110 | 4367323
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F117 | 4388578
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 B128 | 4388601
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 L115 | 4388626
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B142 | 5411131
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F126 | 5411159
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X114B | 5411181
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X116B | 5411186
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B121B | 5411223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 X115 | 4388739
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L116B | 5411330
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B129B | 5411247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B135B | 5411257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B147B | 5411252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B148B | 5411262
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L119B | 5411267
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L123B | 5411465
465Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B145 | 5411273
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L122 | 5411278
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B144 | 5411382
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2350 X118 | 5467247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 2373 and 2374. | Fault Code 2373 or 2374 active?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2374 active?
 | STEP 2C. Check the circuit response. | Fault Code 2373 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Check the exhaust gas pressure sensor tube. |
 | STEP 4A. Check the exhaust gas pressure sensor tube. | Plugging or damage found on the exhaust gas pressure sensor tube?
STEP 5. | Check the variable flow turbocharger actuator motor and circuit. |
 | STEP 5A. Inspect the variable flow turbocharger actuator and connector pins. | Dirty or damaged pins?
 | STEP 5B. Inspect the turbocharger variable flow for binding. | Turbocharger, variable flow linkage bent or is the turbocharger variable flow pivot arm binding or seized?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 2373 and 2374.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 or 2374 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure +5 volt SUPPLY pin and the exhaust gas pressure SIGNAL pin at the exhaust gas pressure sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES NO

An in-range malfunction of the exhaust gas pressure sensor has been detected.

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas pressure sensor from the engine harness

Action

Check for an open circuit

  • Measure the resistance between the exhaust gas pressure sensor SUPPLY pin at the ECM connector and the SUPPLY pin at the exhaust gas pressure sensor connector.
  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the ECM connector and the SIGNAL pin at the exhaust gas pressure sensor connector.
  • Measure the resistance between the exhaust gas pressure sensor RETURN pin at the ECM connector and the RETURN pin at the exhaust gas pressure sensor connector.

Use a circuit or wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19..

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin in the ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin in the ECM connector and ground.

Reference a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the exhaust gas pressure sensor tube.

Guided Step 4A - Check the exhaust gas pressure sensor tube.

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust gas pressure sensor tube. Refer to Procedure 011-027 in the Associated Procedures Table.

Action

Check the exhaust gas pressure sensor tube.

Inspect the inside of the tube. If clogged, use compressed air to remove debris or soot buildup.

Check the tube for cracks and thread damage. Replace the tube if cracks or damage are found. Refer to Procedure 011-027 in the Associated Procedures Table.

Plugging or damage found on the exhaust gas pressure sensor tube?
YES NO

Clean or replace the exhaust gas pressure sensor tube. Refer to Procedure 011-027 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the variable flow turbocharger actuator motor and circuit.

Guided Step 5A - Inspect the variable flow turbocharger actuator motor and connector

Conditions

  • Turn keyswitch OFF
  • Disconnect the variable flow turbocharger actuator from the engine harness.

Action

Inspect the engine harness and variable flow turbocharger actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damage pins

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Inspect the turbocharger variable flow for binding.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger, variable flow linkage from the turbocharger, variable flow actuator.

Action

Inspect the variable flow turbocharger actuator.

  • Inspect the turbocharger, variable flow linkage and actuator arm for debris that could cause binding.
  • Move the turbocharger, variable flow pivot arm on the turbocharger assembly to check for binding/seizure.

Is the turbocharger, variable flow linkage bent or is the turbocharger, variable flow pivot arm binding or seized?
YES NO

Replace the turbocharger, variable flow assembly. Refer to Procedure 010-148 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 11-May-2017


FAULT CODE 2635 - VGT Actuator Driver Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2150 SN | 4022190
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12 CM2350 X102 | 4310646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2350 X101 | 4310641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F101 | 4310846
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B105 | 4332778
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B106 | 4367376
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B101 | 2883567
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B130 | 4388668
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L118 | 4388673
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B122 | 4388767
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X114B | 5411181
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X116B | 5411186
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L119B | 5411330
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B145 | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L122 | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B144 | 5411382
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L123B | 5411465
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM calibration. |
 | STEP 1A. Check the ECM calibration. | ECM code correct for the engine control parts list (CPL)?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM calibration.

Guided Step 1A - Check the ECM calibration.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM calibration and make sure it is correct for the engine CPL.

  • Make sure the ECM code calibration voltage is correct for the application. A 24 volt calibration downloaded into a 12 volt system can cause this fault code.

ECM code correct for the engine control parts list (CPL)?
YES NO

An incorrect variable geometry turbocharger actuator for the voltage application has been detected.

Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

Download the correct ECM code for the engine CPL.

2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 2639 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | L9 CM2350 L119B | 5411267
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | L9 CM2350 L119B | 5411267

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes other than 2639 active?
 | STEP 1B. Check the aftertreatment DPF differential pressure sensor tubes for blockage. | Aftertreatment DPF differential pressure sensor tubes blocked?
STEP 2. | Perform stationary regeneration procedure. |
 | STEP 2A. Perform stationary regeneration procedure. | Fault Code 2639 is active after the stationary regeneration has been completed?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes other than 2639 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor tubes.

Action

Check for plugged aftertreatment DPF differential pressure sensor tubes.

  • Inspect tubes for blockage.
  • Refer to Procedure 011-047 in the Associated Procedures Table.

It is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tube in extreme cold ambient temperatures. Ice can form in the differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Aftertreatment DPF differential pressure sensor tubes blocked?
YES NO

Repair or replace the aftertreatment DPF differential pressure sensor tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Perform the stationary regeneration procedure.

Guided Step 2A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and allow it to idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Use the following procedure for stationary regeneration information. Refer to Procedure 014-013 in the Associated Procedures Table.

For ISF2.8 CM2220 F117, ISB4.5 CM2350 B104, ISB6.7 CM2350 B103, F3.8 CM2350 F120B, and ISV5.0 CM3230 V104 engines:

  • Refer to Procedure 014-016 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to perform the aftertreatment diesel particulate filter regeneration test found in the ECM diagnostic tests.

If active fault codes occur during the regeneration test, abort the test and troubleshoot the active fault code.

Fault Code 2639 active after the stationary regeneration has been completed?
YES NO

Check for active fault codes that have become active during the regeneration event. Troubleshoot any active fault codes.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jun-2017


FAULT CODE 2738 - Start Enable Device 1 Circuit (Ether Injection) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2738 inactive?
STEP 2. | Check the ether injection solenoid and circuit. |
 | STEP 2A. Inspect the ether injection solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the ether injection solenoid. | Less than 10k ohms?
 | STEP 2C. Check the ether injection solenoid diagnostic supply voltage, supply line and return circuit. | Greater than 5.0-VDC?
 | STEP 2D. Check for an open circuit in the ether injection solenoid return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in ether injection signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2738 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2738 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ether injection solenoid and circuit.

Guided Step 2A - Inspect the ether injection solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan solenoid from the OEM harness.

Action

Inspect the OEM harness and ether injection solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the ether injection solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check ether injection solenoid resistance.

  • Measure the resistance between the ether injection solenoid SIGNAL pin and the ether injection solenoid RETURN pin at the ether injection solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open circuit in the ether injection solenoid has been detected.

Replace the ether injection solenoid. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the ether injection solenoid diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the ether injection solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the ether injection solenoid SIGNAL pin and the ether injection solenoid RETURN pin at the ether injection solenoid connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the ether injection solenoid return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ether injection solenoid RETURN pin in the engine harness and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the malfunctioning connection.

Clean, repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ether injection signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM ether injection solenoid SIGNAL pin and the OEM harness ether injection solenoid connector ether injection solenoid SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open ether injection solenoid signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the ether injection solenoid SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2738 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jun-2016


FAULT CODE 2739 - Start Enable Device 1 Circuit (Ether Injection) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2739 active?
STEP 2. | Check the ether injection solenoid and circuit. |
 | STEP 2A. Inspect the ether injection solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the ether injection solenoid. | Greater than 3 ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the ether injection solenoid. |
 | STEP 2C. Check the ether injection solenoid diagnostic supply voltage and supply line. | Greater than 5 VDC?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2739 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2739 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ether injection solenoid and circuit.

Guided Step 2A - Inspect the ether injection solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the ether injection solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check for low internal resistance of the ether injection solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the ether injection solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3 ohms?
YES NO
No Repair

Replace the ether injection solenoid. Refer to the OEM service manual.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the ether injection solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance and check for a short circuit between the ether injection SIGNAL connector pin and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the ether injection solenoid. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the ether injection solenoid diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and supply line.

  • Measure the voltage between the ether injection SIGNAL pin and the ether injection RETURN pin at the OEM harness actuator connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the ether injection SIGNAL pin of the OEM harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the ether injection SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2739 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jun-2016


FAULT CODE 2764 - Exhaust Gas Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Restriction | Refer to Procedure 011-009 | ISB6.7 CM2250 | 4022254
Exhaust Restrictiont | Refer to Procedure 011-009 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Restriction | Refer to Procedure 011-009 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Restriction | Refer to Procedure 011-009 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Restriction | Refer to Procedure 011-009 | QSL9 CM2250 | 4022256
Exhaust Restriction | Refer to Procedure 011-009 | QSB6.7 CM2250 | 4022255
Exhaust Restriction | Refer to Procedure 011-009 | QSB6.7 CM2250 EC | 2883621
Exhaust Restriction | Refer to Procedure 011-009 | QSX11.9 CM2250 ECF | 2883561
Exhaust Restriction | Refer to Procedure 011-009 | QSX15 CM2250 ECF | 2883557
Exhaust Restriction | Refer to Procedure 011-009 | ISX12 CM2350 X102 | 4310646
Exhaust Restriction | Refer to Procedure 011-009 | ISX15 CM2350 X101 | 4310641
Exhaust Restriction | Refer to Procedure 011-009 | QSX15 CM2350 X105 | 4332667
Exhaust Restriction | Refer to Procedure 011-009 | QSX15 CM2350 X106 | 4332712
Exhaust Restriction | Refer to Procedure 011-009 | QSG12 CM2350 G110 | 4367323
Exhaust Restriction | Refer to Procedure 011-009 | X15 CM2350 X114B | 5411181
Exhaust Restriction | Refer to Procedure 011-009 | X15 CM2350 X116B | 5411186
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-015 | ISX12 CM2350 X102 | 4310646
Aftertreatment Testing | Refer to Procedure 014-015 | ISX15 CM2350 X101 | 4310641
Snap Acceleration Test | Refer to Procedure 014-017 | QSX15 CM2350 X105 | 4332667
Snap Acceleration Test | Refer to Procedure 014-017 | QSX15 CM2350 X106 | 4332712
Snap Acceleration Test | Refer to Procedure 014-017 | QSG12 CM2350 G110 | 4367323
Snap Acceleration Test | Refer to Procedure 014-017 | X15 CM2350 X114B | 5411181
Snap Acceleration Test | Refer to Procedure 014-017 | X15 CM2350 X116B | 5411186

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Codes 2373, 2374, or 2554 active?
 | STEP 1B. Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes. | Fault codes related to the VGT or EGR valve operation are active?
 | STEP 1C. Check exhaust restriction. | Exhaust restriction greater than 41 kPa [6 psi]?
 | STEP 1D. Check for intake manifold pressure sensor or EGR differential pressure sensor related fault codes. | Fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor are active?
STEP 2. | Perform the stationary regeneration procedure. |
 | STEP 2A. Check the aftertreatment diesel particulate filter operation. | Fault codes become active during the stationary regeneration?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2373, 2374, or 2554 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting procedure

Go to 1B

Guided Step 1B - Check for VGT and EGR related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the VGT and EGR valve operation.

Fault codes related to the VGT or EGR valve operation are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting procedure

Go to 1C

Guided Step 1C - Check exhaust restriction.

Conditions

  • Install a pressure gauge into the exhaust system.
  • Turn keyswitch ON.
  • Operate engine at rated horsepower and rpm.

Action

Check exhaust restriction by installing a pressure gauge into the exhaust system, just past the turbocharger outlet.

  • If a port is not found in the exhaust system, remove the diesel oxidation catalyst intake temperature sensor and install the pressure gauge in the temperature sensor port.
  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction greater than 41 kPa [6 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1D

Guided Step 1D - Check for intake manifold pressure sensor or EGR differential pressure sensor related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor.

Fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting procedure

Go to 2A

Guided Step 2 - Perform the stationary regeneration procedure.

Guided Step 2A - Check the aftertreatment diesel particulate filter operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Refer to Procedure 014-013 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Test found under ECM Diagnostic Tests.

Fault codes become active during the stationary regeneration?
YES NO
No Repair

Refer to Procedure 014-013 in the Associated Procedures Table.

Appropriate fault code troubleshooting procedure

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Oct-2016


FAULT CODE 2777 - Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12/ISX11.9 CM2250 | 2883345
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2250 | 4022256
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2250 | 4022255
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSX11.9 CM2250 ECF | 2883561
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSX15 CM2250 ECF | 2883557
Exhaust System Diagnostics | Refer to Procedure 011-056 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2350 B101 | 2883567
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISL9 CM2350 L101 | 4310787
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12 CM2350 X102 | 4310646
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2350 X101 | 4310641
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB4.5 CM2350 B104 | 4332646
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISF3.8 CM2350 F109 | 4367218
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSX15 CM2350 X105 | 4332667
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISL9 CM2350 L111 | 4367223
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSG12 CM2350 G110 | 4367323
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2350 B142 | 5411131
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X114B | 5411181
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X116B | 5411186
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B121B | 5411223
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L116B | 5411330
Exhaust System Diagnostics | Refer to Procedure 011-056 | F3.8 CM2350 F120B | 5411237
Exhaust System Diagnostics | Refer to Procedure 011-056 | B4.5 CM2350 B129 | 5411247
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B135B | 5411257
Exhaust System Diagnostics | Refer to Procedure 011-056 | B4.5 CM2350 B147B | 5411252
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B148B | 5411262
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L119B | 5411267
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L123B | 5411465
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSX15 CM2350 X105 | 4332667
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | L9 CM2350 L119B | 5411267

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2777 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2777 active?
YES NO

This fault code indicates that the aftertreatment regeneration permit switch was disabled when the ECM was requesting an active regeneration of the aftertreatment system.

Verify that the permit switch (inhibit switch) has been set up properly for the original equipment manufacturer (OEM) application. Refer to Procedure 011-056 in the Associated Procedures Table.

Refer to the OEM service manual or consult the OEM if the aftertreatment system has malfunctioned due to the permit switch (inhibit switch).

  • Perform the aftertreatment testing procedure to check the performance of the aftertreatment system. Refer to Procedure 014-013 in the Associated Procedures Table. Use the following procedure for ISB4.5 CM2350 B104, ISB6.7 CM2350 B103, ISF3.8 CM2350 F109, QSX15 CM2350 X105, and ISV5.0 CM3230 V104 engines. Refer to Procedure 014-016 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Jan-2017


FAULT CODE 2963 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | GX15 CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F114 | 4383734
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature. |
 | STEP 1A. Monitor coolant temperature. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature.

Guided Step 1A - Monitor coolant temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 2964 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSF2.8 CM2880 F114 | 4383734
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSF2.8 CM2880 F131 | 5411489
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 CM2350 X102 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2350 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold temperature. |
 | STEP 1A. Monitor intake manifold temperature. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor intake manifold temperature.

Guided Step 1A - Monitor intake manifold temperature.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature.

  • Use INSITE™ electronic service tool to monitor the intake manifold temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS.

Replace the intake manifold temperature sensor. Use the following procedure for all except QSF2.8 CM2880 F114, QSF2.8 CM2880 F131, ISV5.0 CM3230 V104, and L9 CM2350 L123B applications. Refer to Procedure 019-159 in the Associated Procedures Table.

Use Procedure 019-059 for QSF2.8 CM2880 F114, QSF2.8 CM2880 F131, ISV5.0 CM3230 V104, and L9 CM2350 L123B applications. Refer to Procedure 019-059 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 3133 - Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 3133 active?
STEP 2. | Check the aftertreatment diesel particulate filter outlet pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter outlet pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Fault Code 3134 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 3133 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3133 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Fault Code 1695

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3133 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel particulate filter outlet pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter outlet pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter outlet pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3134 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel particulate filter outlet pressure sensor SUPPLY pin and the aftertreatment diesel particulate filter outlet pressure sensor RETURN pin at the aftertreatment diesel particulate filter outlet pressure sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter outlet pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3133 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment diesel particulate filter outlet pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter outlet pressure sensor RETURN pin and the OEM harness aftertreatment diesel particulate filter outlet pressure sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet pressure sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3133 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3134 - Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4021257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 3134 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter outlet pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter outlet pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 3133 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3134 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 3134 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Fault Code 1696 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3134 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel particulate filter outlet pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter outlet pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter outlet pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel particulate filter outlet pressure SUPPLY pin and the aftertreatment diesel particulate filter outlet pressure RETURN pin at the aftertreatment diesel particulate filter outlet pressure sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel particulate filter outlet pressure sensor SUPPLY pin and the aftertreatment diesel particulate filter outlet pressure sensor SIGNAL pin at the aftertreatment diesel particulate filter outlet pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3133 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter outlet pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3134 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment diesel particulate filter outlet pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter outlet pressure sensor SUPPLY pin and the OEM harness aftertreatment diesel particulate filter outlet pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter outlet pressure sensor SIGNAL pin and the OEM harness aftertreatment diesel particulate filter outlet pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3134 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

The troubleshooting steps need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 3139 - Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Shutoff Valve | Refer to Procedure 010-143 | QSB6.7 CM2250 | 4022255
Air Shutoff Valve | Refer to Procedure 010-143 | QSB6.7 CM2250 EC | 2883621
Air Shutoff Valve | Refer to Procedure 010-143 | QSL9 CM2250 | 4022256
Air Shutoff Valve | Refer to Procedure 010-143 | ISX15 CM2250 GX CM2250 | 4022250
Air Shutoff Valve | Refer to Procedure 010-143 | ISX12/ISX11.9 CM2250 | 2883445
Air Shutoff Valve | Refer to Procedure 010-143 | ISX12 CM2350 X102 | 4310646
Air Shutoff Valve | Refer to Procedure 010-143 | QSX11.9 CM2250 ECF | 2883561
Air Shutoff Valve | Refer to Procedure 010-143 | QSX15 CM2250 ECF | 2883557
Air Shutoff Valve | Refer to Procedure 010-143 | ISX15 CM2250 SN | 4310736
Air Shutoff Valve | Refer to Procedure 010-143 | QSB6.7 CM2350 B105 | 4332778
Air Shutoff Valve | Refer to Procedure 010-143 | QSL9 CM2350 L102 | 4332796
Air Shutoff Valve | Refer to Procedure 010-143 | QSB4.5 CM2350 B106 | 4367376
Air Shutoff Valve | Refer to Procedure 010-143 | ISX15 CM2350 X101 | 4310641
Air Shutoff Valve | Refer to Procedure 010-143 | QSB6.7 CM2250 B128 | 4388601
Air Shutoff Valve | Refer to Procedure 010-143 | QSL9 CM2250 L115 | 4388626
Air Shutoff Valve | Refer to Procedure 010-143 | QSB6.7 CM2350 B130 | 4388668
Air Shutoff Valve | Refer to Procedure 010-143 | QSL9 CM2350 L118 | 4388673
Air Shutoff Valve | Refer to Procedure 010-143 | QSX15 CM2250 X115 | 4388739
Air Shutoff Valve | Refer to Procedure 010-143 | QSB6.7 CM2350 B145 | 5411273
Air Shutoff Valve | Refer to Procedure 010-143 | QSL9 CM2350 L122 | 5411278
Air Shutoff Valve | Refer to Procedure 010-143 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3139 active?
STEP 2. | Check the engine air shutoff solenoid and circuit. |
 | STEP 2A. Inspect the engine air shutoff solenoid and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine air shutoff solenoid for an open circuit. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3139 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3139 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine air shutoff solenoid and circuit.

Guided Step 2A - Inspect the engine air shutoff solenoid and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Inspect the OEM harness and solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine air shutoff solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid OEM harness connector.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the engine air shutoff solenoid SIGNAL pin to the engine air shutoff solenoid RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

An open circuit has been detected in the engine air shutoff solenoid.

Replace the engine air shutoff solenoid.

  • Use the following procedure for an OEM installed air shutoff solenoid. Refer to OEM service manual.
  • Use the following procedure for a Cummins installed air shutoff solenoid. Refer to 010-143 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine air shutoff solenoid SIGNAL pin in the engine harness ECM connector and the engine air shutoff solenoid SIGNAL pin at the engine air shutoff solenoid OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine air shutoff solenoid SIGNAL circuit.

Troubleshoot the OEM harness, engine harness, and all interconnects for the open circuit.

Repair or replace the damaged component.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine air shutoff solenoid RETURN pin in the engine harness ECM connector and the engine air shutoff solenoid RETURN pin at the engine air shutoff solenoid OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine air shutoff solenoid RETURN circuit.

Troubleshoot the OEM harness, engine harness, and all interconnects for the open circuit.

Repair or replace the damaged component.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine air shutoff solenoid SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine air shutoff solenoid SIGNAL wire has been detected.

Troubleshoot the OEM harness, engine harness, and 14-pin OEM cross-over connector.

Repair or replace the damaged component(s).

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds. Use INSITE™ electronic service tool to read the fault codes.

–

Fault Code 3139 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Nov-2016


FAULT CODE 3141 - Engine Air Shutoff Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Shutoff Valve | Refer to Procedure 010-143 | ISC8.3 and ISL9 CM2250 | 4022257
Air Shutoff Valve | Refer to Procedure 010-143 | QSX11.9 CM2250 ECF | 2883561
Air Shutoff Valve | Refer to Procedure 010-143 | ISX12/ISX11.9 CM2250 | 2883445
Air Shutoff Valve | Refer to Procedure 010-143 | ISX12 CM2350 X102 | 4310646
Air Shutoff Valve | Refer to Procedure 010-143 | ISX15 CM2250 GX CM2250 | 4022250
Air Shutoff Valve | Refer to Procedure 010-143 | ISL9 CM2250 | 4022256
Air Shutoff Valve | Refer to Procedure 010-143 | QSB6.7 CM2250 EC | 2883621
Air Shutoff Valve | Refer to Procedure 010-143 | QSB6.7 CM2250 | 4022255
Air Shutoff Valve | Refer to Procedure 010-143 | ISX15 CM2250 SN | 4310736
Air Shutoff Valve | Refer to Procedure 010-143 | QSB6.7 CM2350 B105 | 4332778
Air Shutoff Valve | Refer to Procedure 010-143 | QSL9 CM2350 L102 | 4332796
Air Shutoff Valve | Refer to Procedure 010-143 | QSB4.5 CM2350 B106 | 4367376
Air Shutoff Valve | Refer to Procedure 010-143 | ISL9 CM2350 L101 | 4310787
Air Shutoff Valve | Refer to Procedure 010-143 | ISX15 CM2350 X101 | 4310641
Air Shutoff Valve | Refer to Procedure 010-143 | QSL9 CM2250 L115 | 4388626
Air Shutoff Valve | Refer to Procedure 010-143 | QSB6.7 CM2250 B128 | 4388601
Air Shutoff Valve | Refer to Procedure 010-143 | QSB6.7 CM2350 B130 | 4388668
Air Shutoff Valve | Refer to Procedure 010-143 | QSL9 CM2350 L118 | 4388673
Air Shutoff Valve | Refer to Procedure 010-143 | QSX15 CM2250 X115 | 4388739
Air Shutoff Valve | Refer to Procedure 010-143 | L9 CM2350 L116B | 5411330
Air Shutoff Valve | Refer to Procedure 010-143 | QSB6.7 CM2350 B145 | 5411273
Air Shutoff Valve | Refer to Procedure 010-143 | QSL9 CM2350 L122 | 5411278
Air Shutoff Valve | Refer to Procedure 010-143 | QSB4.5 CM2350 B144 | 5411382
Air Shutoff Valve | Refer to Procedure 010-143 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 3141 active?
STEP 2. | Check the engine air shutoff solenoid and circuit. |
 | STEP 2A. Inspect the engine air shutoff solenoid and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine air shutoff solenoid for a short to ground. | Greater than 100k ohms?
 | STEP 2C. Check the engine air shutoff solenoid for an internal short. | Less than 5 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 3134 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3141 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine air shutoff solenoid and circuit

Guided Step 2A - Inspect the engine air shutoff solenoid and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Inspect the OEM harness and solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine air shutoff solenoid for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid OEM harness connector.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the engine air shutoff solenoid SIGNAL pin to ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine air shutoff solenoid.

Use the following procedure for an OEM installed air shutoff solenoid. See equipment manufacturer service information.

Use the following procedure for a Cummins™ installed air shutoff solenoid. Refer to Procedure 010-143 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the engine air shutoff solenoid for an internal short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid OEM harness connector.

Action

Check the resistance of the solenoid.

  • Measure the resistance between the engine air shutoff solenoid SIGNAL pin and the engine air shutoff solenoid RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO

An internally shorted engine air shutoff solenoid has been detected.

Replace the engine air shutoff solenoid.

Use the following procedure for an OEM installed air shutoff solenoid. See equipment manufacturer service information.

Use the following procedure for a Cummins™ installed air shutoff solenoid. Refer to Procedure 010-143 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine air shutoff solenoid SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine air shutoff solenoid SIGNAL wire has been detected.

Troubleshoot the OEM harness, engine harness, and 14 pin OEM crossover connector.

Repair or replace the damaged component(s).

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine air shutoff solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine air shutoff solenoid SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine air shutoff solenoid SIGNAL wire has been detected in the OEM harness.

Troubleshoot the OEM harness, engine harness, and 14 pin OEM crossover connector.

Repair or replace the damaged component(s).

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3164 - Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title
Procedure Number
Service Model Name
Bulletin Number
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISF2.8 CM2220 AN
ISF2.8 CM2220 IAN
4022178
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISF2.8 CM2220 F122
5467376
5467376Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISF3.8 CM2220 AN
ISF3.8 CM2220 IAN
4021704
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN
4022188
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISL8.9 CM2150 SN
4022190
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISM11 CM876 SN
4022196
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISB6.7 CM2250
4022254
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISC8.3 and ISL9 CM2250
4022257
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISX15 CM2250
GX CM2250
4022250
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISX12/ISX11.9 CM2250
2883445
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
QSL9 CM2250
4022256
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
QSB6.7 CM2250
4022255
Air Leaks, Air Intake and Exhaust Systems
Refer to Procedure 010-024
ISX15 CM2250 SN
4310736
Turbocharger
Refer to Procedure 010-033
ISF2.8 CM2220 AN
ISF2.8 CM2220 IAN
4022178
Turbocharger
Refer to Procedure 010-033
ISF2.8 CM2220 F122
5467376
5467376
Refer to Procedure 010-033
ISF3.8 CM2220 AN
ISF3.8 CM2220 IAN
4021704
Turbocharger
Refer to Procedure 010-033
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN
4022188
Turbocharger
Refer to Procedure 010-033
ISL8.9 CM2150 SN
4022190
Turbocharger
Refer to Procedure 010-033
ISM11 CM876 SN
4022196
Turbocharger
Refer to Procedure 010-033
ISB6.7 CM2250
4022254
Turbocharger
Refer to Procedure 010-033
ISC8.3 and ISL9 CM2250
4022257
Turbocharger
Refer to Procedure 010-033
ISX15 CM2250
GX CM2250
4022250
Turbocharger
Refer to Procedure 010-033
ISX12/ISX11.9 CM2250
2883445
Turbocharger
Refer to Procedure 010-033
QSL9 CM2250
4022256
Turbocharger
Refer to Procedure 010-033
QSB6.7 CM2250
4022255
Turbocharger
Refer to Procedure 010-033
ISX15 CM2250 SN
4310736
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISF2.8 CM2220 AN
ISF2.8 CM2220 IAN
4022178
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISF2.8 CM2220 F122
5467376
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISF3.8 CM2220 AN
ISF3.8 CM2220 IAN
4021704
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN
4022188
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISL8.9 CM2150 SN
4022190
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISM11 CM876 SN
4022196
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISB6.7 CM2250
4022254
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISC8.3 and ISL9 CM2250
4022257
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISX15 CM2250
GX CM2250
4022250
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISX12/ISX11.9 CM2250
2883445
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
QSL9 CM2250
4022256
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
QSB6.7 CM2250
4022255
Aftertreatment Gas Temperature Sensor
Refer to Procedure 019-449
ISX15 CM2250 SN
4310736

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3142 or 3143 active?
STEP 2. | Check the air handling system for correct operation. |
 | STEP 2A. Check the charge air cooler, clamps, hoses, and piping. | Air leaks present or clamps loose?
 | STEP 2B. Inspect turbocharger compressor and turbine blades. | Damage found on turbocharger blades?
STEP 3. | Inspect the selective catalytic reduction (SCR) inlet temperature sensor. |
 | STEP 3A. Inspect the SCR inlet temperature sensor. | Damage found on SCR inlet temperature sensor?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 or 3143 active?
YES | NO
No Repair | No Repair

Fault Code 3142 or 3143 troubleshooting tree

Go to 2A

Guided Step 2 - Check the air handling system for correct operation.

Guided Step 2A - Check the charge air cooler, clamps, hoses, and piping.

Conditions

  • Turn keyswitch OFF.

Action

Check the charge air cooler, hoses, and piping for leaks.

  • Check the clamps for adequate torque. Refer to Procedure 010-024 in the Associated Procedures Table.

Air leaks present or clamps loose?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Turn keyswitch OFF.
  • Remove the inlet and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Damage found on turbocharger blades?
YES NO

Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Inspect the SCR inlet temperature sensor.

Guided Step 3A - Inspect the SCR inlet temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the SCR inlet temperature sensor from the exhaust system.

Action

Inspect the SCR inlet temperature sensor.

  • Inspect the SCR inlet temperature sensor for damage and signs of excessively high temperature.

Damage found on SCR inlet temperature sensor?
YES NO

Replace the SCR inlet temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-May-2017


FAULT CODE 3165 - Aftertreatment Selective Catalytic Reduction (SCR) Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | ISB6.7 CM2250 | 4022254
Injector | Refer to Procedure 006-026 | ISC8.3 and ISL9 CM2250 | 4022257
Injector | Refer to Procedure 006-026 | ISX15 CM2250 GX CM2250 | 4022250
Injector | Refer to Procedure 006-026 | ISX12/ISX11.9 CM2250 | 2883445
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Aftertreatment SCR Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2250 | 4022254
Aftertreatment SCR Catalyst | Refer to Procedure 011-036 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment SCR Catalyst | Refer to Procedure 011-036 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment SCR Catalyst | Refer to Procedure 011-036 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2250 | 4022254
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2250 | 4022256
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | ISB6.7 CM2250 | 4022254
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | QSB6.7 CM2250 | 4022255

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Do any of the aftertreatment SCR catalyst temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the DEF for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Check the aftertreatment fuel injector. |
 | STEP 5A. Check the operation of the aftertreatment fuel injector (if equipped). | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
STEP 6. | Inspect the aftertreatment DOC. |
 | STEP 6A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 6B. Inspect the aftertreatment DOC for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3142, 3143, 3144, 3145, 3146, 3147, 3148, or 3149 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.
  • Engine idling for greater than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with INSITE™ electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the two aftertreatment SCR catalyst temperature sensors.

Do any of the aftertreatment SCR catalyst temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the signal pin of the temperature sensor in question to all other pins in the harness.

Check for a short circuit in the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

If no short is found replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2A

Guided Step 2 - Check the DEF for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

Diesel exhaust fluid contaminated?
YES NO

Drain the DEF tank and follow the appropriate steps in the service manual. Refer to Procedure 011-056 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector. Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Check for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

  • Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the aftertreatment fuel injector.

Guided Step 5A - Check the operation of the aftertreatment fuel injector (if equipped).

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • If the engine does not have an aftertreatment fuel injector, skip to step 6A.

Action

Check for fuel leaking from the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the Injector Leak Test. Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 014-013 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 011-036 in the Associated Procedures Table.

Perform a snap acceleration test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

If black smoke is present, inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Inspect the aftertreatment DOC.

Guided Step 6A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 6B

Go to 6B

Guided Step 6B - Inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

  • Aftertreatment DOC removed.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell walls. Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 3167 - Aftertreatment Doser - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX12 CM2350 X102 | 4310646
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX15 CM2350 X101 | 4310641
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12 CM2350 X102 | 4310646
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX15 CM2350 X101 | 4310641

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment purge air actuator active?
STEP 2. | Check the aftertreatment fuel injector. |
 | STEP 2A. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector meets the specifications?
 | STEP 2B. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector meets the specifications?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment fuel injector system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment purge air actuator active?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment fuel injector.

Guided Step 2A - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Action

Perform the aftertreatment system test.

Refer to Procedure 011-054 in the Associated Procedures Table.

NOTE: It is only necessary to perform the flow test; the leak test is not necessary.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Clean the aftertreatment injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 3A

Go to 2B

Guided Step 2B - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Action

Perform the aftertreatment system test.

Refer to Procedure 011-054 in the Associated Procedures Table.

NOTE: It is only necessary to perform the flow test; the leak test is not necessary.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Replace the aftertreatment injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 3186 - Tachograph Output Shaft Speed - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3186 active?
STEP 3. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3186 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with the INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

–

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3186 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

NOTE: Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3186 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 3213 - Tachograph Output Shaft Speed - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3213 active?
STEP 2. | Check the original equipment manufacturer (OEM) VECU and engine engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3213 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Dec-2015


FAULT CODE 3231 - Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | ISB6.7 CM2250 | 4022254
Injector | Refer to Procedure 006-026 | ISC8.3 and ISL9 CM2250 | 4022257
Injector | Refer to Procedure 006-026 | ISX15 CM2250 GX CM2250 | 4022250
Injector | Refer to Procedure 006-026 | ISX12/ISX11.9 CM2250 | 2883445
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2250 | 4022254
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2250 | 4022254
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2250 | 4022256
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | ISB6.7 CM2250 | 4022254
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3142, 3143, 3144, 3145, 3146, 3147, 3148, or 3149 active or inactive counts?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the diesel exhaust fluid (DEF) for contamination. | Diesel exhaust fluid (DEF) contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Check for excessive black smoke. |
 | STEP 5A. Inspect the exhaust for excessive black smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 6. | Check the aftertreatment fuel injector. |
 | STEP 6A. Check the operation of the aftertreatment fuel injector (if equipped). | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
STEP 7. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 7A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 7B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell walls. | Any cracks found in the cell walls?
STEP 8. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3142, 3143, 3144, 3145, 3146, 3147, 3148, or 3149 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for greater than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the signal pin of the temperature sensor in question to all other pins in the harness.

Check for a short circuit in the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

If no short is found replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 2A

Guided Step 2 - Check the DEF for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check for excessive black smoke.

Guided Step 5A - Inspect the exhaust for excessive black smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform the Snap Acceleration - Aftertreatment Disconnected Test. Refer to procedure 014-013 in the Associated Procedures Table.

NOTE: To perform a snap acceleration test, it could be necessary to temporarily adjust the maximum engine speed with no vehicle speed sensor parameter in INSITE™ electronic service tool, to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES | NO
No Repair | No Repair

Reference the appropriate engine performance troubleshooting tree.

Go to 6A

Guided Step 6 - Check the aftertreatment fuel injector.

Guided Step 6A - Check the operation of the aftertreatment fuel injector, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Skip to step 6A if the engine does not have an aftertreatment fuel injector.

Action

Check for fuel leaking from the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the Injector Leak Test. Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 014-013 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 011-036 in the Associated Procedures Table.

Perform a snap acceleration test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

  • If black smoke is present, inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 7A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment diesel oxidation catalyst for soot accumulation and/or face plugging.

Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 7B

Go to 7B

Guided Step 7B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell walls.

Conditions

  • Aftertreatment diesel oxidation catalyst removed.

Action

Inspect the aftertreatment diesel oxidation catalyst.

  • Check for cracks in the aftertreatment diesel oxidation catalyst cell walls.

Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 3235 - Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | ISB6.7 CM2250 | 4022254
Injector | Refer to Procedure 006-026 | ISC8.3 and ISL9 CM2250 | 4022257
Injector | Refer to Procedure 006-026 | ISX15 CM2250 GX CM2250 | 4022250
Injector | Refer to Procedure 006-026 | ISX12/ISX11.9 CM2250 | 2883445
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2250 | 4022254
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2250 | 4022254
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2250 | 4022256
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | ISB6.7 CM2250 | 4022254
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3142, 3143, 3144, 3145, 3146, 3147, 3148, or 3149 active or inactive counts?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the diesel exhaust fluid (DEF) for contamination. | Diesel exhaust fluid (DEF) contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Check the aftertreatment fuel injector. |
 | STEP 5A. Check the operation of the aftertreatment fuel injector (if equipped). | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
STEP 6. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 6A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 6B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3142, 3143, 3144, 3145, 3146, 3147, 3148, or 3149 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.
  • Idle engine for greater than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the signal pin of the temperature sensor in question to all other pins in the harness.

Check for a short circuit in the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

If no short is found replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the diesel exhaust fluid (DEF) for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the diesel exhaust fluid (DEF) for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

Diesel exhaust fluid (DEF) contaminated?
YES NO

Drain the diesel exhaust fluid (DEF) tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the aftertreatment fuel injector.

Guided Step 5A - Check the operation of the aftertreatment fuel injector (if equipped).

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • If the engine does not have an aftertreatment fuel injector, skip to step 6A.

Action

Check for fuel leaking from the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the Injector Leak Test. Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 014-013 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 011-036 in the Associated Procedures Table.

Perform a snap acceleration test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

  • If black smoke is present, inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 6A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment diesel oxidation catalyst for soot accumulation and/or face plugging.

Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 6B

Go to 6B

Guided Step 6B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall.

Conditions

  • Aftertreatment diesel oxidation catalyst removed.

Action

Inspect the aftertreatment diesel oxidation catalyst.

  • Check for cracks in the aftertreatment diesel oxidation catalyst cell wall.

Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 3242 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part No. 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, 3237, 3258, 3261, 3422, 3425, 3426, 3429, or 3576 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heating system. |
 | STEP 2A. Inspect the diesel exhaust fluid tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level ok?
STEP 3. | Check the aftertreatment diesel exhaust fluid tank heater operation. |
 | STEP 3A. Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heater control valve operating correctly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for diesel exhaust fluid tank heater or diesel exhaust fluid tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, 3237, 3258, 3261, 3422, 3425, 3426, 3429, or 3576 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heating system

Guided Step 2A - Inspect the diesel exhaust fluid tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines (including the OEM in-line shutoff valve if equipped)
  • Loose connections
  • Leaking seals or gaskets.

Refer to the OEM service manual for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF

Action

Check engine coolant level.

  • Make sure that coolant level is within normal operating levels.

Coolant level ok?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid tank heater operation.

Guided Step 3A - Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.

  • Make sure that the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Refer to the OEM service manual for details on the tank heater control valve.

Diesel exhaust fluid tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the diesel exhaust fluid tank heater control valve.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2011


FAULT CODE 3326 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2150 B119 ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2150 B120 ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3326 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3326 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for engine control module (ECM) communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for ECM communication.

  • Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3326 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connector to all other pins in the OEM connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3326 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Feb-2017


FAULT CODE 3328 - Transmission Output Shaft Speed - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3328 active or inactive with more than one count logged in the last 25 engine hours?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES NO
No Repair

A communication issue between the ECM and data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Reference the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3328 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Reference Service Bulletin Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have ben completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3366 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X116B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L116B | 5411330
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 3366. | Active or inactive counts of Fault Code 3366?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 3366.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 3366?
YES NO

Add coolant to the engine.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 3366 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

If the vehicle is equipped with dual coolant level sensors, Fault Code 3366 will set for the lowest mounted coolant level sensor in the tank. Only replace the lowest mounted coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete

Repair complete.

Last Modified: 21-Feb-2017


FAULT CODE 3374 - Roll Over Protection Brake Control Active - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3374 active or inactive?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 3374.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3374 active or inactive?
YES NO

Cruise control was inhibited temporarily by the anti-lock braking (ABS) controller due to certain driving conditions. No repair is necessary. This fault code is for information only.

Cruise control was inhibited temporarily by the ABS controller due to certain driving conditions. No repair is necessary. This fault code is for information only.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Dec-2015


FAULT CODE 3418 - Transmission Output Shaft Speed - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3418 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3418 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the transmission output shaft speed sensor or OEM vehicle electronic control unit. See equipment manufacturer service information.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3488 - Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3488 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to No Cummunication Troubleshooting Tree in Section TT of the ISX15 CM2250 SN Service Manual, Bulletin 4310736.

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3488 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Use the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Dec-2015


FAULT CODE 3492 - Real Time Clock - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2150 B119 ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2150 B120 ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Verify fault condition and check engine control module (ECM) calibration. |
 | STEP 2A. Perform the diagnostic and verify the fault condition exists. | Fault Code 3492 active?
 | STEP 2B. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 111 troubleshooting tree.

Go to 2A

Guided Step 2 - Verify fault condition and check ECM calibration.

Guided Step 2A - Perform the diagnostic and verify the fault condition exists.

Conditions

  • Turn keyswitch OFF.

Action

Perform the following steps in order to allow the diagnostic to run and complete and verify that the fault condition still exists.

  • Leave keyswitch off for at least 1 minute.
  • Turn keyswitch back on for 15 minutes.
  • At the end of 15 minutes, use INSITE™ electronic service tool to read the fault codes.

Fault Code 3492 active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jun-2017


FAULT CODE 3495 - Diesel Particulate Filter Active Regeneration Inhibited Due to Low Exhaust Gas Temperature - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISX15 CM2250 GX CM2250 | 4022250
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISX12/ISX11.9 CM2250 | 2883445
Charge-Air Cooler | Refer to Procedure 010-027 | ISX15 CM2250 GX CM2250 | 4022250
Charge-Air Cooler | Refer to Procedure 010-027 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger | Refer to Procedure 010-033 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Restriction | Refer to Procedure 011-009 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Restriction | Refer to Procedure 011-009 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3495 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 122, 123, 221, 222, 249, 256, 436, 2398, or 2973 active?
 | STEP 1C. Check for active fault codes. | Fault Codes 3313, 3314, or 3315 active?
 | STEP 1D. Check for active fault codes. | Fault Codes 1898, 2387, 2449, or 3616?
STEP 2. | Check the exhaust system for leaks. |
 | STEP 2A. Check the exhaust system for leaks. | Exhaust leak present?
STEP 3. | Check the variable geometry turbocharger (VGT) actuator. |
 | STEP 3A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the VGT actuator. | Gear is broken or damaged on the VGT actuator?
 | STEP 3C. Inspect the turbocharger shaft movement. | Use the sector gear gauge, does the nozzle movement meet the requirements according to Procedure 010-134?
 | STEP 3D. Check the VGT output gear for correct calibration. | Does the VGT actuator gear move when connected to the engine wiring harness?
 | STEP 3D-1. Check the VGT output gear for manual rotation by hand. |
STEP 4. | Check the air intake system for leaks. |
 | STEP 4A. Check the charge-air cooler for leaks. | Air leak present?
 | STEP 4B. Check the intake manifold inlet and connections for leaks. | Air leak present?
 | STEP 4C. Check for a restricted charge-air cooler. | Within specifications?
STEP 5. | Check the exhaust system for restriction. |
 | STEP 5A. Check exhaust restriction. | Within specifications?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3495 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 6A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes related to the intake manifold pressure sensor, intake manifold temperature sensor, or the barometric pressure sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

  • Fault Codes 122, 123, 221, 222, 249, 256, 436, 2398, or 2973 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes related to the aftertreatment diesel oxidation catalyst intake temperature sensor, aftertreatment diesel particulate filter intake temperature sensor, or aftertreatment diesel particulate filter outlet temperature sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3313, 3314, or 3315, 3316, 3317, 3318, 3319, 3321, or 3322 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes related to the variable geometry turbocharger.

  • Use INSITE™ electronic service tool to read the fault codes.

  • Fault Codes 1898, 2387, 2449, or 3616?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the exhaust system for leaks.

Guided Step 2A - Check the exhaust system for leaks.

Conditions

  • Engine running.

Action

Check the OEM plumbing from the turbocharger outlet to the aftertreatment diesel oxidation catalyst intake for exhaust leaks.

–

Exhaust leak present?
YES NO

Repair or replace the leaking component. Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine idling for greater than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the signal pin of the temperature sensor in question to all other pins in the harness. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the VGT actuator.

Guided Step 3A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Check for active fault codes.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques reference the following procedure. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect the VGT actuator.

Check for a broken drive gear on the VGT actuator.

Gear is broken or damaged on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

  • Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3C

Guided Step 3C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • VGT actuator removed from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger housing up and down from stop to stop. Check for smooth movement between the stops. Use the sector gear gauge to check for complete travel.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever must move to the other stop position by hand. Refer to Procedure 010-134 in the Associated Procedures Table.

Use the sector gear gauge; does the nozzle movement meet the requirements according to Procedure 010-134?
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check the VGT output gear for correct calibration.

Conditions

  • Disconnect the VGT actuator from the engine wiring harness.
  • Turn keyswitch ON.

Action

Check the VGT actuator output gear operation.

  • Connect the VGT actuator to the engine wiring harness. The VGT actuator gear must rotate.

The VGT actuator output gear will exhibit one of the following movements depending on the ECM calibration. Make sure to closely observe the VGT actuator gear when the VGT actuator is connected to the engine wiring harness.

  • The actuator output gear could possibly rotate completely in one direction and then rotate completely in the opposite direction, OR
  • The actuator output gear may only move a few degrees in one direction. This movement will be a quick snap when the VGT actuator is connected to the engine wiring harness.
  • If the VGT actuator gear does not move, disconnect the VGT actuator from the engine wiring harness for 1 second and then reconnect.
  • Repeat the above procedure 3 times, checking for VGT actuator gear movement each time the VGT actuator is connected to the engine wiring harness.

Does the VGT actuator gear move when connected to the engine wiring harness?
YES NO

Install the VGT actuator on the turbocharger, making sure to perform the VGT actuator install and calibrate procedures. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3D-1

Guided Step 3D-1 - Check the VGT output gear for manual rotation by hand.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine wiring harness.

Action

Turn the VGT actuator output gear by hand.

  • Try turning the VGT actuator output gear by hand in either direction.

Do NOT use pliers or any other tool to turn the gear. ONLY rotate the gear by hand.

Can the VGT actuator output gear be rotated by hand?
YES NO

Install the VGT actuator on the turbocharger making sure to perform the actuator install and calibrate procedures. Refer to Procedure 010-134 in the Associated Procedures Table.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the air intake system for leaks.

Guided Step 4A - Check the charge-air cooler for leaks.

Conditions

  • Engine running.

Action

Check the charge-air cooler and connections for air leaks.

Air leak present?
YES NO

Repair or replace the leaking component. Refer to Procedure 010-027 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the intake manifold inlet and connections for leaks.

Conditions

  • Engine running.

Action

Check for air leaks in connections and hoses between the turbocharger and intake manifold inlet.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Air leak present?
YES | NO
No Repair | No Repair

Go to 6A

Go to 4C

Guided Step 4C - Check for a restricted charge-air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running.

Action

Check the pressure differential across the charge-air cooler.

  • Check the pressure differential across the charge-air cooler. Refer to Procedure 010-027 in the Associated Procedures Table.

Within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler, if necessary.

Go to 5A

Go to 6A

Guided Step 5 - Check the exhaust system for restriction.

Guided Step 5A - Check exhaust restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check exhaust restriction.

Refer to Procedure 011-009 in the Associated Procedures Table.

Within specifications?
YES NO
No Repair

Repair or replace the restricted component.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 3497 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3497 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3497 active?
YES NO

A low aftertreatment diesel exhaust fluid (DEF) level has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2015


FAULT CODE 3498 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3498 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3498 active?
YES NO

A low aftertreatment diesel exhaust fluid (DEF) level has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jan-2016


FAULT CODE 3525 - Wheel-Based Vehicle Speed - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3525 is active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3525 is active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the wheel-based vehicle speed sensor or OEM vehicle electronic control unit.

See equipment manufacturer service information.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3526 - Wheel-Based Vehicle Speed - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3526 active or inactive with more than one count logged in the last 25 engine hours?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration matches the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3526 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3526 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 3A

Go to 6A

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Go to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration matches the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3526 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

See the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3527 - Accelerator Pedal or Lever Idle Validation Switch - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3527 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration udate for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3527 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the accelerator pedal or lever idle validation switch or OEM vehicle electronic control unit.

Refer to the equipment manufacturer service information.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair Complete

Go to 1A

Last Modified: 09-Dec-2015


FAULT CODE 3528 - Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3528 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3528 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3528 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connector to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3528 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM, or calibration is causing the fault code.

Go to 6A

The appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Repair complete.

Last Modified: 20-Jan-2017


FAULT CODE 3531 - Ambient Air Temperature - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3531 active?
STEP 3. | Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3531 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connector to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Go to 6A

The appropriate ECM - No Communication troubleshooting symptom tree in Section TT

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Feb-2017


FAULT CODE 3532 - Ambient Air Temperature - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3532 active?
STEP 2. | Check the original equiment manufacturer (OEM) vehicle electronic control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3532 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the ambient air temperature sensor or OEM vehicle electronic control unit.

Refer to the OEM service manual.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Jul-2015


FAULT CODE 3535 - Malfunction Indicator Lamp - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3535 active?
STEP 3. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3535 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Note: Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connector to all other pins in the OEM connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Go to 6A

The appropriate ECM - No Communication troubleshooting symptom tree in Section TT

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Oct-2012


FAULT CODE 3558 - Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3558 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3558 inactive and Fault Code 3561 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition. | Fault Code 3558 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3558 inactive and Fault Code 3561 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3558 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Fault Codes 3429, 3571, and 3579 will be active.

Fault Code 3558 inactive and Fault Code 3561 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3558 active?
YES NO

A damaged aftertreatment diesel exhaust fluid dosing unit has been detected.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Turn keyswitch ON.
  • Turn keyswitch OFF for a minimum of 1 minute.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

NOTE: The key cycle with the controller unplugged (as outlined in the ‘Conditions’ section) must be performed to make sure that the proper fault code is set.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3571, 3576, and 3579 will also be active.

Fault Code 3558 inactive and Fault Code 3561 active?
YES NO

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Feb-2012


FAULT CODE 3559 - Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3559 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3559 inactive and Fault Code 3561 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition. | Fault Code 3559 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3559 inactive and Fault Code 3561 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3559 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Fault Codes 3429, 3571, and 3579 will be active.

Fault Code 3559 inactive and Fault Code 3561 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3559 active?
YES NO

A damaged aftertreatment diesel exhaust fluid dosing unit has been detected.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3571, 3576, and 3579 will also be active.

Fault Code 3559 inactive and Fault Code 3561 active?
YES NO

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Feb-2012


FAULT CODE 3561 - Aftertreatment Diesel Exhaust Fluid Dosing Unit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3561 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid dosing unit and circuit.. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3561 inactive and Fault Code 3558 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition. | Fault Code 3561 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit circuit. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3561 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the engine harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin and the aftertreatment diesel exhaust fluid dosing unit signal/dosing unit temperature SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Codes 3429, 3571, and 3579 will be active.

Fault Code 3561 inactive and Fault Code 3558 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3561 active?
YES NO

A damaged aftertreatment diesel exhaust fluid dosing unit has been detected.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedure Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the harness.

Action

Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the harness connector and the 86-pin controller connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the harness connector and the 86-pin controller connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit signal/dosing unit temperature SIGNAL pin at the harness connector and the 86-pin controller connector.

Less than 10 ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 31-Jul-2015


FAULT CODE 3562 - Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3562 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller and harness. |
 | STEP 2A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 3. | Check the aftertreatment DEF line heater relay. |
 | STEP 3A. Inspect the aftertreatment DEF line heater relay and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance of the aftertreatment DEF line heater relay circuit. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3562 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF controller and harness.

Guided Step 2A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF line heater relay RETURN pin and all other pins in the aftertreatment DEF controller harness 53-pin connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the RETURN wire has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF line heater relay.

Guided Step 3A - Inspect the aftertreatment DEF line heater relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF line heater relay and aftertreatment DEF controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the resistance of the aftertreatment DEF line heater relay circuit.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.
  • Connect the aftertreatment DEF line heater relay to the aftertreatment DEF controller harness.

Action

Check the resistance of the aftertreatment DEF line heater relay circuit.

  • Measure the resistance between the aftertreatment DEF line heater relay SUPPLY pin and the aftertreatment DEF line heater relay RETURN pin at the aftertreatment DEF controller harness 53-pin connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A short circuit has been detected in the aftertreatment DEF line heater relay.

Replace the aftertreatment DEF line heater relay. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Feb-2013


FAULT CODE 3563 - Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted To Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3563 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller and harness. |
 | STEP 2A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 3. | Check the aftertreatment DEF line heater relay. |
 | STEP 3A. Inspect the aftertreatment DEF line heater relay and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3563 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF controller and harness.

Guided Step 2A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF line heater relay RETURN pin and all other pins in the aftertreatment DEF controller harness 53-pin connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the RETURN wire has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness.

Refer to the original equipment manufacturer (OEM) service manual.

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF line heater relay.

Guided Step 3A - Inspect the aftertreatment DEF line heater relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DEF line heater relay RETURN pin at the aftertreatment DEF controller harness 53-pin connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the return wire has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Mar-2013


FAULT CODE 3564 - Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Current Below Normal or Open Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3564 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) line heater relay. |
 | STEP 2A. Inspect the aftertreatment DEF line heater relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3562 active and Fault Code 3564 inactive?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF line heater relay condition. | Fault Code 3564 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller harness line heater relay supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment DEF controller harness line heater relay return circuit. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3564 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater relay.

Guided Step 2A - Inspect the aftertreatment DEF line heater relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF line heater relay and aftertreatment DEF controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.

Action

Perform the following steps to check the circuit response.

  • Place a jumper wire between the aftertreatment DEF line heater relay RETURN pin (pin 85) and the line heater relay SUPPLY pin (pin 86) at the aftertreatment DEF line heater relay harness connector.
  • Turn keyswitch ON.
  • Turn keyswitch OFF and wait 1 minute.
  • Turn the keyswitch ON for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or wiring diagram for connector pin identification.

Note: Fault Codes 3258, 3261, and 3425 will be active.

Fault Code 3562 active and Fault Code 3564 inactive?
YES NO

Note: If both fault codes are active then the keyswitch was not cycled twice as necessary.

No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF line heater relay condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF line heater relay to the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the following steps to check the circuit response.

  • Turn keyswitch ON for 1 minute.
  • Turn keyswitch OFF and wait 1 minute.
  • Turn keyswitch ON for 1 minute.
  • Turn keyswitch OFF and wait 90 seconds and repeat this process one more time to allow all diagnostic checks to complete.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3564 active?
YES NO

An open circuit has been detected in the aftertreatment DEF line heater relay.

Replace the aftertreatment DEF line heater relay.

Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller harness line heater relay supply circuit.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater relay SUPPLY pin at the 53 pin controller harness connector and the aftertreatment DEF line heater relay SUPPLY pin (pin 86) at the line heater relay connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness line heater relay supply circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment DEF controller harness line heater relay return circuit.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment DEF line heater relay from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness 53-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater relay RETURN pin at the 53-pin controller harness connector and the aftertreatment DEF line heater relay RETURN pin at the line heater relay connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness line heater relay return circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jan-2014


FAULT CODE 3565 - Aftertreatment DEF Dosing Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN | 4021704
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3565 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF dosing valve. | Resistance between 11 and 18 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve. | Greater than 100k ohms?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86 pin connector. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3565 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3565 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF controller harness and dosing valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for an internal short or open circuit in the aftertreatment DEF dosing valve by measuring the internal resistance.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the aftertreatment DEF dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 11 and 18 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and the metal case of the aftertreatment DEF dosing valve.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin and the metal case of the aftertreatment DEF dosing valve.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.

Action

Inspect the aftertreatment DEF controller harness and 86 pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin at the 86 pin connector and the aftertreatment DEF dosing valve SIGNAL pin in the dosing valve harness connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin at the 86 pin connector and the aftertreatment DEF dosing valve RETURN pin in the dosing valve harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-Pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86-pin connector and engine block ground.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin of the aftertreatment DEF controller harness 86-pin connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the equipment manufacturer service information.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86-pin connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86 pin connector and all other populated pins in the connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin of the aftertreatment DEF controller harness 86 pin connector and all other populated pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the equipment manufacturer service information.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The dosing valve must be commanded on in order for all dosing valve diagnostics to run.

Before checking the fault codes, perform the Aftertreatment DEF Dosing Unit Override Test in INSITE™ electronic service tool.

Refer to Procedure 011-063 in the Associated Procedures Table.

Fault Code 3556 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Do not install the aftertreatment diesel fluid dosing valve into the selective catalytic reduction (SCR) decompostion tube until the repair validation steps have been completed in step 4B and fault code has been cleared.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 26-Aug-2016


FAULT CODE 3566 - Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To avoid connector damage due to connector expansion, use test lead, Part Number 4919546, for the smaller pins and test lead, Part Number 4919348, for the larger pins.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3566 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF dosing valve. | Resistance between 11 and 18 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve. | Greater than 100k ohms?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86 pin connector. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3566 inactive?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3566 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF controller harness and dosing valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for an internal short or open circuit in the aftertreatment DEF dosing valve by measuring the internal resistance.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pins of the aftertreatment DEF dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 11 and 18 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and the metal case of the aftertreatment DEF dosing valve.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin and the metal case of the aftertreatment DEF dosing valve.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.

Action

Inspect the aftertreatment DEF controller harness and 86 pin connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

CAUTION

To avoid connector damage due to connector expansion, use test lead, Part Number 4919546, for the smaller pins and test lead, Part Number 4919348, for the larger pins.
Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin at the 86 pin connector and the aftertreatment DEF dosing valve SIGNAL pin in the dosing valve harness connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin at the 86 pin connector and the aftertreatment DEF dosing valve RETURN pin in the dosing valve harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the equipment manufacturer service information.

Go to 3C

Go to 4A

CAUTION

To avoid connector damage due to connector expansion, use test lead, Part Number 4919546, for the smaller pins and test lead, Part Number 4919348, for the larger pins.
Guided Step 3C - Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86 pin connector and engine block ground.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin of the aftertreatment DEF controller harness 86 pin connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the equipment manufacturer service information.

Go to 3D

Go to 4A

CAUTION

To avoid connector damage due to connector expansion, use test lead, Part Number 4919546, for the smaller pins and test lead, Part Number 4919348, for the larger pins.
Guided Step 3D - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86 pin connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86 pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86 pin connector and all other populated pins in the connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin of the aftertreatment DEF controller harness 86 pin connector and all other populated pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the equipment manufacturer service information.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The dosing valve must be commanded ON in order for all dosing valve diagnostics to run.

  • Before checking the fault codes, perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test in INSITE™ electronic service tool. Refer to Procedure 011-063 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3566 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Do not install the aftertreatment diesel fluid dosing valve into the selective catalytic reduction (SCR) decomposition tube until the repair validation steps have been completed in step 4B and fault code has been cleared.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2016


FAULT CODE 3567 - Aftertreatment DEF Dosing Valve - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3567 active?
STEP 2. | Check the aftertreatment DEF dosing valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF dosing valve. | Resistance between 11 and 18 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve. | Greater than 100k ohms?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF controller harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86-pin connector. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3567 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3567 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Inspect the aftertreatment DEF controller harness and dosing valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for an internal short or open circuit in the aftertreatment DEF dosing valve by measuring the internal resistance.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the aftertreatment DEF dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 11 and 18 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and the metal case of the aftertreatment DEF dosing valve.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin and the metal case of the aftertreatment DEF dosing valve.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-pin connector.

Action

Inspect the aftertreatment DEF controller harness and 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin at the 86-pin connector and the aftertreatment DEF dosing valve SIGNAL pin in the dosing valve harness connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin at the 86-pin connector and the aftertreatment DEF dosing valve RETURN pin in the dosing valve harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86-pin connector and engine block ground.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin of the aftertreatment DEF controller harness 86-pin connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86-pin connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86-pin connector and all other populated pins in the connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin of the aftertreatment DEF controller harness 86-pin connector and all other populated pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The dosing valve must be commanded on in order for all dosing valve diagnostics to run.

  • Before checking the fault codes, perform the Aftertreatment DEF Dosing Unit Override Test in INSITE™ electronic service tool. Refer to Procedure 011-063 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3567 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 04-Apr-2014


FAULT CODE 3568 - Aftertreatment Diesel Exhaust Fluid Dosing Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2250 | 4022254
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Controller Calibration Code | Refer to Procedure 011-077 | ISX15 CM2250 GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3568 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid controller software phase. |
 | STEP 2A. Check if an aftertreatment diesel exhaust fluid controller software phase update is available. | If a software phase update for this fault code is available, does the aftertreatment diesel exhaust fluid controller contain that revision or higher?
STEP 3. | Check the diesel exhaust fluid dosing valve circuit. |
 | STEP 3A. Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid dosing valve circuit. | Greater than 100k ohms?
STEP 4. | Check the aftertreatment diesel exhaust fluid dosing valve. |
 | STEP 4A. Check the resistance of the aftertreatment diesel exhaust fluid dosing valve. | Resistance between 11 and 18 ohms?
STEP 5. | Check the aftertreatment diesel exhaust fluid dosing unit filter. |
 | STEP 5A. Check the aftertreatment diesel exhaust fluid dosing unit filter. | Aftertreatment diesel exhaust fluid dosing unit filter free from contamination?
STEP 6. | Check the aftertreatment diesel exhaust fluid dosing system operation. |
 | STEP 6A. Check the aftertreatment diesel exhaust fluid dosing system operation. | Dosing valve meets the specifications outlined in Procedure 011-063?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3568 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 6A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid controller software phase.

Guided Step 2A - Check if an aftertreatment diesel exhaust fluid controller software phase update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the aftertreatment diesel exhaust fluid controller software phase to the latest revision published on QuickServe™ Online for applicable changes related to this fault code.

  • Refer to Cummins® aftertreatment diesel exhaust fluid controller software phases, Bulletin 4310705.
  • Use INSITE™ electronic service tool to find the present aftertreatment diesel exhaust fluid controller software phase. The aftertreatment diesel exhaust fluid controller software phase is found in the System Dataplate section of Aftertreatment Diesel Exhaust Fluid Controller in Features and Parameters.

If a software phase update for this fault code is available, does the Aftertreatment Diesel Exhaust Fluid Controller contain that revision or higher?

YES NO
No Repair

If necessary, calibrate the aftertreatment diesel exhaust fluid controller. Refer to Procedure 011-077 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the diesel exhaust fluid dosing valve circuit.

Guided Step 3A - Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid dosing valve circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the 86-pin connector.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment diesel exhaust fluid controller harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin and the RETURN pin of the aftertreatment diesel exhaust fluid controller harness 86-pin connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the aftertreatment diesel exhaust fluid controller harness.

Refer to the equipment manufacturer service information.

Go to 4A

Go to 7A

Guided Step 4 - Check the aftertreatment diesel exhaust fluid dosing valve.

Guided Step 4A - Check the resistance of the aftertreatment diesel exhaust fluid dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment diesel exhaust fluid controller harness.

Action

Check for an internal short or open circuit in the aftertreatment diesel exhaust fluid dosing valve by measuring the internal resistance.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pins of the aftertreatment diesel exhaust fluid dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 11 and 18 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment diesel exhaust fluid dosing valve.

Replace the aftretreatment diesel exhaust fluid dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table. Do not install the aftertreatment diesel fluid dosing valve into the SCR decompostion tube until the repair validation steps have been completed in Step 7B and fault code has been cleared.

Go to 5A

Go to 7A

Guided Step 5 - Check the aftertreatment diesel exhaust fluid dosing unit filter.

Guided Step 5A - Check the aftertreatment diesel exhaust fluid dosing unit filter.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid dosing unit filter for contamination.

Use the following procedure to check for contamination. Refer to Procedure 011-060 in the Associated Procedures Table

Aftertreatment diesel exhaust fluid dosing unit filter free from contamination?
YES NO
No Repair

Clean the aftertreatment diesel exhaust fluid system. Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check the aftertreatment diesel exhaust fluid dosing system operation.

Guided Step 6A - Check the aftertreatment diesel exhaust fluid dosing system operation.

Conditions

  • Turn keyswitch OFF.
  • Remove the diesel exhaust fluid dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck closed or low flowing aftertreatment diesel exhaust fluid dosing valve.

Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override test. Refer to Procedure 011-063 in the Associated Procedures Table.

Dosing valve meets the specifications outlined in Procedure 011-063?
YES NO
No Repair

A damaged aftertreatment diesel exhaust fluid dosing valve has been detected.

Replace the aftertreatment diesel exhaust fluid dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table. Do not install the aftertreatment diesel fluid dosing valve into the SCR decompostion tube until the repair validation steps have been completed in Step 7B and fault code has been cleared

Go to 7A

Go to 7A

Guided Step 7 - Check the ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM.The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 3571 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | IGX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | IGX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 3557 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 3571 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3572 active and Fault Code 3571 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3571 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the circuit response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3557 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 inactive?
YES NO

An inactive or intermittent fault code has been detected. Refer to Procedure 019-362 in Section 19.

No Repair

Go to 1A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment diesel exhaust fluid pressure RETURN pin and the aftertreatment diesel exhaust fluid pressure SIGNAL pin at the diesel exhaust fluid dosing unit connector of the controller harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Note: Fault Codes 3429, 3561, and 3579 will also be active.

Fault Code 3572 active and Fault Code 3571 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment diesel exhaust fluid pressure +5 volt SUPPLY pin to the aftertreatment diesel exhaust fluid pressure RETURN pin at the dosing unit connector of the aftertreatment diesel exhaust fluid controller harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 active?
YES NO

A damaged aftertreatment diesel exhaust fluid pressure sensor has been detected in the aftertreatment diesel exhaust fluid dosing unit.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the diesel exhaust fluid controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment diesel exhaust fluid pressure RETURN pin and the aftertreatment diesel exhaust fluid pressure SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit controller.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Note: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3576, and 3579 may also be active.

Fault Code 3572 active and Fault Code 3571 inactive?
YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 inactive?
YES NO
No Repair

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from aftertreatment diesel exhaust fluid pressure +5 volt SUPPLY pin to the aftertreatment diesel exhaust fluid pressure RETURN pin at the aftertreatment diesel exhaust fluid controller 86-pin connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Last Modified: 16-Jan-2017


FAULT CODE 3572 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2250 | 4022255

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 3557 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 3572 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 3571 active and Fault Code 3572 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3572 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the circuit response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3557 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 inactive?
YES NO

An inactive or intermittent fault code has been detected.

Refer to Procedure 019-362 in Section 19.

No Repair

Go to 1A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from aftertreatment diesel exhaust fluid pressure +5 volt SUPPLY pin to the aftertreatment diesel exhaust fluid pressure RETURN pin at the dosing unit connector of the aftertreatment diesel exhaust fluid controller harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Codes 3429, 3561, and 3579 will also be active.

Fault Code 3571 active and Fault Code 3572 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 active?
YES NO

A damaged aftertreatment diesel exhaust fluid pressure sensor has been detected in the aftertreatment diesel exhaust fluid dosing unit.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from aftertreatment diesel exhaust fluid pressure +5 volt SUPPLY pin to the aftertreatment diesel exhaust fluid pressure RETURN pin at the aftertreatment diesel exhaust fluid controller 86-pin connector.

Use the circuit diagram or the wiring diagram for connector pin identification

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open or short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes

Note: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3576, and 3579 will also be active.

Fault Code 3571 active and Fault Code 3572 inactive?
YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit or shorted signal circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 3574 - Aftertreatment DEF Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 F122 | 5467376
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 F122 | 5467376
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISF2.8 CM2220 F122 | 5467376
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Unit Filter | Refer to Procedure 011-060 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220 F122 | 5467376
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445
Air in the DEF | Refer to Procedure 011-075 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Air in the DEF | Refer to Procedure 011-075 | ISF2.8 CM2220 F122 | 5467376
Air in the DEF | Refer to Procedure 011-075 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Air in the DEF | Refer to Procedure 011-075 | ISB6.7 CM2250 | 4022254
Air in the DEF | Refer to Procedure 011-075 | ISC8.3 and ISL9 CM2250 | 4022257
Air in the DEF | Refer to Procedure 011-075 | ISX15 CM2250 GX CM2250 | 4022250
Air in the DEF | Refer to Procedure 011-075 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3574 active or more than two inactive counts?
 | STEP 1B. Check for low DEF tank level. | DEF tank empty and/or Fault Code 1671, 1673, 3497, or 3498 active?
 | STEP 1C. Check the DEF tank for debris or foreign particles. | Debris or foreign particles found in the DEF tank?
 | STEP 1D. Check for active aftertreatment DEF system fault codes. | Fault Code 1681, 3565, 3566, 3567, 3568, 3571, 3572, 3577, 3578, 3579, 3612, or 3679 active?
 | STEP 1E. Check for active or inactive aftertreatment DEF system fault codes. | Fault Code 1713 active or inactive?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit lines and fittings. | Any damaged, leaking, or restricted connections found?
 | STEP 2B. Check the aftertreatment DEF dosing unit supply line. | DEF dosing unit supply line blocked or restricted?
 | STEP 2C. Check for air in the DEF. | Air detected in the DEF?
STEP 3. | Check the aftertreatment DEF tank filter. |
 | STEP 3A. Inspect the DEF tank filter for blockage. | DEF tank filter blocked?
STEP 4. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 4A. Perform the aftertreatment DEF Doser Pump Override Test. | Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
 | STEP 4B. Perform the aftertreatment DEF dosing unit airless flush. | Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3574 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1671, 1673, 3497, and 3498.

DEF tank empty and/or Fault Code 1671, 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 4A

Go to 1C

Guided Step 1C - Check the DEF tank for debris or foreign particles.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF tank for debris or foreign particles.

Debris or foreign particles found in the DEF tank?
YES NO

Clean the DEF tank thoroughly and refill with certified diesel exhaust fliud.

 No Repair

Go to 1D

Go to 1D

Guided Step 1D - Check for active aftertreatment DEF system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active fault codes relating to the aftertreatment DEF dosing unit, return valve, or dosing valve:
  • 1681, 3565, 3566, 3567, 3568, 3571, 3572, 3577, 3578, 3579, 3612, or 3679.

Fault Code 1681, 3565, 3566, 3567, 3568, 3571, 3572, 3577, 3578, 3579, 3612, or 3679 active?
YES NO

Troubleshoot any active fault codes in this list before troubleshooting Fault Code 3574.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 1E

Guided Step 1E - Check for active aftertreatment DEF system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for active or inactive Fault Code 1713.

Fault Code 1713 active or inactive?
YES NO

If Fault Code 1713 is active or inactive, go to the troubleshooting tree for Fault Code 1713 and complete step 4B.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF dosing unit fittings and lines.

  • Check the dosing unit supply, outlet, and return connectors and fittings for loose or leaking connections.
  • Disconnect the dosing unit supply, outlet, and return connectors and look for signs of buildup or blockage.

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?
YES NO

Repair or replace the leaking DEF line or fitting as necessary. Refer to the OEM service manual.

Repair or replace the aftertreatment DEF dosing unit as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF dosing unit supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit supply line from the dosing unit (suction line between the tank and dosing unit).
  • Disconnect the aftertreatment DEF dosing unit supply line from the DEF tank.

Action

Check the DEF dosing unit supply line for blockage.

  • Look at both ends of the line to check for signs of build-up or blockage.
  • Blow compressed shop air through the supply line to establish/confirm free flow.

DEF dosing unit supply line blocked or restricted?
YES NO

Try to clean the dosing unit supply line using shop air. If necessary, replace the dosing unit supply line.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air detected in the DEF?
YES NO

Check the following components for damage or leaks and repair as necessary:

  • Aftertreatment DEF dosing unit fittings
  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings.

Refer to Procedure 011-075 in the Associated Procedures Table.

Replace DEF dosing unit SUPPLY line and RETURN line fittings.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF tank filter.

Guided Step 3A - Inspect the DEF tank filter for blockage.

Conditions

  • Turn keyswitch OFF.
  • Remove the sending unit from the DEF tank.

Action

Inspect the aftertreatment DEF tank filter for signs of blockage or buildup.

Refer to the OEM service manual.

DEF tank filter blocked?
YES NO

Clean or change the DEF tank filter.

Drain, clean, and fill the DEF tank.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check the aftertreatment DEF dosing unit operation.

Guided Step 4A - Perform the Aftertreatment DEF Doser Pump Override Test.

Conditions

  • Connect the DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

Note: The aftertreatment DEF dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to perform the Aftertreatment DEF Doser Pump Override Test.

Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Perform the aftertreatment DEF dosing unit airless flush.

Conditions

  • Remove the aftertreatment DEF dosing valve removed.
  • Remove the aftertreatment DEF dosing unit.
  • Connect INSITE™ electronic service tool.

Action

Flush the aftertreatment DEF dosing unit with clean water.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-058 in the Associated Procedures Table.

Note: The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-May-2017


FAULT CODE 3575 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3575 active or more than two inactive counts?
 | STEP 1B. Check for active aftertreatment diesel exhaust fluid system fault codes. | Fault Code 1681, 3565, 3566, 3567, 3568, 3571, 3572, 3577, 3578, 3579, 3612, or 3679 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid lines and fittings |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit lines and fittings. | Damaged or restricted diesel exhaust fluid return line, dosing unit, or tank connector detected?
 | STEP 2B. Check the aftertreatment diesel exhaust fluid dosing unit return line. | Diesel exhaust fluid return line blocked or restricted?
STEP 3. | Check aftertreatment diesel exhaust fluid dosing unit operation |
 | STEP 3A. Perform Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test. | Aftertreatment diesel exhaust fluid dosing unit operate according to the specifications in procedure 011-063?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3575 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Inactive or Intermittent Fault Code, Procedure 019-362.

Guided Step 1B - Check for active aftertreatment diesel exhaust fluid system fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active fault codes relating to the aftertreatment diesel exhaust fluid dosing unit, return valve, or dosing valve:
  • Fault Codes 1681, 3565, 3566, 3567, 3568, 3571, 3572, 3577, 3578, 3579, 3612, or 3679.

Are Fault Codes 1681, 3565, 3566, 3567, 3568, 3571, 3572, 3577, 3578, 3579, 3612, or 3679 active?
YES NO

Troubleshoot any active faults in this list before troubleshooting Fault Code 3575.

 No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid lines and fittings

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all three aftertreatment diesel exhaust fluid dosing unit fittings and lines.

  • Check the dosing unit supply, dosing valve supply, and return connectors and fittings for loose or leaking connections.
  • Disconnect the dosing unit supply, dosing valve supply, and return connectors on the dosing unit and look for signs of build-up or blockage.
  • Check the dosing unit supply line for signs of leakage or openings which would allow the dosing unit to suck in air with the diesel exhaust fluid.

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?

YES NO

Repair or replace the leaking diesel exhaust fluid line or fitting as necessary.

Refer to OEM service manual.

Repair or replace the aftertreatment diesel exhaust fluid dosing unit as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the aftertreatment diesel exhaust fluid dosing unit return line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit return line from the dosing unit (return line runs between the tank and dosing unit and returns diesel exhaust fluid to the tank).
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit return line from the diesel exhaust fluid tank.

Action

Check the diesel exhaust fluid return line for blockage.

  • Visually check both ends of the line for signs of build-up or blockage.
  • Blow compressed shop air through the return line to make sure of free flow.

Diesel exhaust fluid return line blocked or restricted?
YES NO

Try to clean the return line using shop air. If necessary, replace the return line.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check aftertreatment diesel exhaust fluid dosing unit operation

Guided Step 3A - Perform Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Conditions

  • Connect all diesel exhaust fluid lines and electrical connectors to the dosing unit and diesel exhaust fluid tank.
  • Remove aftertreatment diesel exhaust fluid dosing valve from decomposition tube.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Tests.

Refer to Procedure 011-063 in the Associated Procedures Table.

Note: The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Does the aftertreatment diesel exhaust fluid dosing unit operate according to the specifications in procedure 011-063?

YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid dosing unit return line fitting.

Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test again with the new fitting. If measure volume of diesel exhaust fluid is still not within specifications, replace the aftertreatment diesel exhaust fluid dosing unit.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Jul-2012


FAULT CODE 3577 - Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3577 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid return valve and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid return valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3577 inactive and Fault Code 3579 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid return valve condition. | Fault Code 3577 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3577 inactive and Fault Code 3579 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3577 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid return valve and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid return valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Note: Fault Codes 3429, 3561, and 3571 will be active.

Fault Code 3577 inactive and Fault Code 3579 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid return valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Turn keyswitch OFF for a minimum of 1 minute.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

Note that the key cycle with the dosing unit connected again (as outlined in the ‘Conditions’ section) must be performed to make sure that the proper fault code is set.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3577 active?
YES NO

A damaged aftertreatment diesel exhaust fluid return valve has been detected in the aftertreatment diesel exhaust fluid dosing unit.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Note: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3571, and 3576 will also be active.

Fault Code 3577 inactive and Fault Code 3579 active?
YES NO

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Feb-2012


FAULT CODE 3578 - Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3578 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid return valve and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid return valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3578 inactive and Fault Code 3579 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid return valve condition. | Fault Code 3578 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3578 inactive and Fault Code 3579 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3578 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid return valve and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid return valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Note: Fault Codes 3429, 3561, and 3571 will be active.

Fault Code 3578 inactive and Fault Code 3579 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid return valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3578 active?
YES NO

A damaged aftertreatment diesel exhaust fluid return valve has been detected in the aftertreatment diesel exhaust fluid dosing unit.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Note: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3571, and 3576 will also be active.

Fault Code 3578 inactive and Fault Code 3579 active?
YES NO

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Feb-2012


FAULT CODE 3579 - Aftertreatment Diesel Exhaust Fluid Return Valve - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445
OEM Wiring Harness | Refer to Procedure 019-071 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
OEM Wiring Harness | Refer to Procedure 019-071 | ISF3.8 CM2220 AN | 4021704
OEM Wiring Harness | Refer to Procedure 019-071 | ISB6.7 CM2250 | 4022254
OEM Wiring Harness | Refer to Procedure 019-071 | ISC8.3 and ISL9 CM2250 | 4022257
OEM Wiring Harness | Refer to Procedure 019-071 | ISX15 CM2250 GX CM2250 | 4022250
OEM Wiring Harness | Refer to Procedure 019-071 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3579 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF)return valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF return valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3579 inactive and Fault Code 3577 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF return valve condition. | Fault Code 3579 active?
STEP 3. | Check the aftertreatment DEF controller and harness. |
 | STEP 3A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF return valve circuit. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3579 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF return valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF return valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.

Action

Inspect the engine harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedured for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DEF return valve SUPPLY pin and the aftertreatment DEF return valve SIGNAL pin at the aftertreatment DEF dosing unit wiring harness connector.
  • Turn keyswitch OFF for a minimum of 1 minute.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to check the fault codes.

Note: Fault Codes 3429, 3561, and 3571 will be active.

Fault Code 3579 inactive and Fault Code 3577 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF return valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF dosing unit to the aftertreatment DEF controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3579 active?
YES NO

A damaged aftertreatment DEF return valve has been detected in the aftertreatment DEF dosing unit.

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF controller and harness.

Guided Step 3A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.

Action

Inspect the aftertreatment DEF controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Component Connector and Pin Inspection. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment DEF controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF return valve circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the controller.
  • Disconnect the aftertreatment DEF dosing unit from the harness.

Action

Check for an open circuit in the aftertreatment DEF return valve circuit.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin at the dosing unit harness connector and the aftertreatment DEF return valve SUPPLY pin at the 86-pin controller connector.
  • Measure the resistance between the aftertreatment DEF return valve SIGNAL pin at the dosing unit harness connector and the aftertreatment DEF return valve SIGNAL pin at the 86-pin controller connector.

Less than 10 ohms?
YES NO

Replace the aftertreatment DEF controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the harness. Refer to the original equipment manufacturer (OEM) service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Mar-2013


FAULT CODE 3583 - Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2250 | 4022254
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L101 | 4310787
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12 CM2350 X102 | 4310646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2350 X101 | 4310641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 SN | 4310736
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L102 | 4332796
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL8.9 CM2880 L112 | 4358493
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2220 F110 | 4358483
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL8.9 CM2150 L110 | 4358478
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB/ISD6.7 CM2150 B120 | 4358473
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB/ISD4.5 CM2150 B119 | 4354868
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSG12 CM2350 G110 | 4367323
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L118 | 4388673
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X114B X15 CM2350 X116B | 5411181 5411186
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B121B | 5411223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L116B | 5411330
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | F3.8 CM2350 F120B | 5411237
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B129B | 5411247
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B135B | 5411257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B147B | 5411252
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B148B | 5411262
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L119B | 5411267
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3583 active?
 | STEP 1B. Check for active fault codes. | Active or inactive counts of Fault Code 1887, 2771, or 3681?
 | STEP 1C. Check for active fault codes. | Fault Code 3144, 3146, 3147, or 3148 active?
STEP 2. | Check the aftertreatment outlet nitrogen oxide (NOx) sensor circuit. |
 | STEP 2A. Inspect the aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1 VDC of battery voltage?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3583 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1887, 2771, or 3681?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3144, 3146, 3147, or 3148 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet nitrogen oxide (NOx) sensor circuit.

Guided Step 2A - Inspect the aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the OEM harness. Refer to Procedure 019-071 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Disconnect the sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreament outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage with keyswitch ON while cranking the engine and with engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

A damaged aftertreatment outlet NOx sensor heater has been detected.

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM harness to the engine block ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3596 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220 F129 | 5411325
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISF2.8 CM2220 F129 | 5411325
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISF2.8 CM2220 F129 | 5411325
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | ISF2.8 CM2220/ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | ISB6.7 CM2250 | 4022254
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | ISC8.3 and ISL9 CM2250 | 4022257
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | ISX15 CM2250 GX CM2250 | 4022250
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | ISX12/ISX11.9 CM2250 | 2883554

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 3571 and 3572. | Fault Code 3571 or 3572 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid pressure sensor. | Aftertreatment diesel exhaust fluid pressure reading in INSITE™ electronic service tool equal to 0 ± 69 KPa [0 ± 10 psi]?
STEP 3. | Check the aftertreatment diesel exhaust fluid lines and fittings |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid dosing unit lines and fittings. | Any damaged, leaking, or restricted connections found?
 | STEP 3B. Check the aftertreatment diesel exhaust fluid dosing unit supply line. | Diesel exhaust fluid dosing unit supply line blocked or restricted?
 | STEP 3C. Check the aftertreatment diesel exhaust fluid dosing unit return line. | Diesel exhaust fluid return line blocked or restricted?
 | STEP 3D. Check for air in the diesel exhaust fluid. | Air in the diesel exhaust fluid detected?
 | STEP 3E. Inspect the aftertreatment diesel exhaust fluid dosing unit supply line fitting. | Dosing unit supply line or return line fitting blocked?
 | STEP 3F. Check the aftertreatment diesel exhaust fluid dosing unit lines and fittings. | Is the aftertreatment diesel exhaust fluid dosing unit pump pressure between 850 kPa (123 psi) and 950 kPa (137 psi)?
STEP 4. | Check the aftertreatment diesel exhaust fluid tank filter |
 | STEP 4A. Inspect the diesel exhaust fluid tank filter for blockage. | Diesel exhaust fluid tank filter blocked?
STEP 5. | Check aftertreatment diesel exhaust fluid dosing unit operation |
 | STEP 5A. Check the aftertreatment diesel exhaust fluid dosing unit for proper operation. | Does the aftertreatment diesel exhaust fluid dosing unit operate according to the specifications in Procedure 011-063?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 3571 and 3572.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 or 3572 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid pressure sensor.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve supply line from the aftertreatment diesel exhaust fluid dosing unit.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment diesel exhaust fluid pressure.

Aftertreatment diesel exhaust fluid pressure reading in INSITE™ electronic service tool equal to 0 ± 69 KPa [0 ± 10 psi]?
YES NO
No Repair

A damaged aftertreatment diesel exhaust fluid pressure sensor has been detected.

Replace the aftertreatment diesel exhaust fluid dosing unit.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid lines and fittings

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

There are three diesel exhaust fluid lines on the SCR dosing system:

  • Dosing unit supply line between the tank and the dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and the dosing valve (pressure line)
  • Return line between the dosing unit and the tank (return line)

Inspect all three diesel exhaust fluid lines and associated fittings/connectors:

  • Check the diesel exhaust fluid tank connections (suction and return lines) for cracks and pitting
  • Check all three dosing unit connections and fittings for loose, leaking, or damaged connections
  • Disconnect the suction line, pressure line, and return line dosing unit connectors and look for signs of buildup or blockage.
  • Check the suction line for signs of leakage or openings which would allow the dosing unit to draw in air with the diesel exhaust fluid.
  • Verify proper sealing at all connection points, including diesel exhaust fluid tank (2 connections), dosing unit (3 connections), and dosing valve (1 connection).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?

YES NO

Repair or replace the leaking diesel exhaust fluid line or fitting as necessary.

Refer to the original equipment manufacturer (OEM) service manual.

Repair or replace the aftertreatment diesel exhaust fluid dosing unit as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the aftertreatment diesel exhaust fluid dosing unit supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit supply line from the dosing unit (this is the suction line between the dosing unit and the diesel exhaust fluid tank).
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit supply line from the diesel exhaust fluid tank.

Action

Check the diesel exhaust fluid dosing unit supply line for blockage.

  • Visually check both ends of the dosing unit supply line for signs of build-up or blockage.
  • Blow compressed shop air through the dosing unit supply line to ensure free flow.

Diesel exhaust fluid dosing unit supply line blocked or restricted?

YES NO

Try to clean the dosing unit supply line using shop air. If necessary, replace the dosing valve supply line.

Refer to OEM service manual.

 No Repair

Go to 6A

Go to 3C

Guided Step 3C - Check the aftertreatment diesel exhaust fluid dosing unit return line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit return line from the dosing unit (return line runs between the tank and dosing unit and returns diesel exhaust fluid to the tank).
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit return line from the diesel exhaust fluid tank.

Action

Check the diesel exhaust fluid return line for blockage.

  • Visually check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the return line to make sure of free flow.

Diesel exhaust fluid return line blocked or restricted?
YES NO

Try to clean the return line using shop air. If necessary, replace the return line.

Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 3D

Guided Step 3D - Check for air in the diesel exhaust fluid.

Conditions

  • Connect the aftertreatment diesel exhaust fluid dosing unit supply and return lines to the diesel exhaust fluid tank.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the diesel exhaust fluid.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the diesel exhaust fluid detected?

YES NO

Check the following components for damage/leaks and repair as necessary:

  • Aftertreatment diesel exhaust fluid dosing unit fittings.
  • Aftertreatment diesel exhaust fluid dosing unit supply line.
  • Aftertreatment diesel exhaust fluid tank fittings.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3E

Guided Step 3E - Inspect the aftertreatment diesel exhaust fluid dosing unit supply line fitting.

Conditions

  • Turn keyswitch OFF.
  • Remove the diesel exhaust fluid dosing supply line and return line fittings.

Action

Inspect the aftertreatment diesel exhaust fluid dosing unit supply line and return line fittings for blockage.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Dosing unit supply line or return line fitting blocked?

YES NO

Replace the blocked fitting.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3F

Guided Step 3F - Check the aftertreatment diesel exhaust fluid dosing unit lines and fittings.

Conditions

  • Connect all diesel exhaust fluid lines and electrical connectors to the dosing unit and diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Test.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

Monitor the aftertreatment diesel exhaust fluid dosing unit pump pressure.

NOTE: The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Is the aftertreatment diesel exhaust fluid dosing unit pump pressure between 850 kPa (123 psi) and 950 kPa (137 psi)?
YES NO
No Repair

If the DEF dosing unit pump pressure is greater than 950 kPa [137 psi].

  • Check the return line for damage or restrictions and repair as necessary.
  • If there is no damage or restrictions with the return line, replace the return line fitting.
  • Refer to Procedure 011-058 in the Associated Procedures Table.

If the DEF dosing unit pump pressure is less than 850 kPa [123 psi].

  • Check the supply line for damage or leaks and repair as necessary.
  • Check the supply line fittings for damage or leaks and replace as necessary.
  • Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the aftertreatment diesel exhaust fluid tank filter

Guided Step 4A - Inspect the diesel exhaust fluid tank filter for blockage.

Conditions

  • Turn keyswitch OFF.
  • Remove the sending unit from the diesel exhaust fluid tank.

Action

Inspect the aftertreatment diesel exhaust fluid tank filter for signs of blockage or buildup.

Refer to the OEM service manual.

Diesel exhaust fluid tank filter blocked?
YES NO

Clean or replace the diesel exhaust fluid tank filter.

Drain, clean, and refill the diesel exhaust fluid tank.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check aftertreatment diesel exhaust fluid dosing unit operation.

Guided Step 5A - Check the aftertreatment diesel exhaust fluid dosing unit for proper operation.

Conditions

  • Connect all diesel exhaust fluid lines and electrical connectors to the dosing unit and the diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Tests.

Refer to Procedure 011-063 in the Associated Procedures Table.

Note: The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Does the aftertreatment diesel exhaust fluid dosing unit operate according to the specifications in Procedure 011-063?

YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid dosing unit filter. (Note that this filter can not be reused and must be replaced upon removal.)

Refer to Procedure 011-060 in the Associated Procedures Table.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test again with the new filter. If the measured volume of diesel exhaust fluid is still not within specifications, replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM Code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 18-May-2017


FAULT CODE 3598 - Aftertreatment Diesel Exhaust Fluid Controller - Received Network Data In Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3598 inactive?
 | STEP 1B. Check for active fault codes. | Any active fault codes other than 3598?
STEP 2. | Check INSITE™ electronic service tool Feature and Parameter settings. |
 | STEP 2A. Check electrical system voltage and diesel exhaust fluid heater configuration settings. | Electrical system voltage and diesel exhaust fluid heater configuration settings are correct?
STEP 3. | Check ECM calibration. |
 | STEP 3A. Calibrate the ECM. | Did Fault Code 3598 become active again?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3598 inactive?
YES | NO
No Repair | No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Any active fault codes other than 3598?
YES NO

Troubleshoot all other active fault codes before troubleshooting Fault Code 3598.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check INSITE™ electronic service tool Feature and Parameter settings.

Guided Step 2A - Check electrical system voltage and diesel exhaust fluid heater configuration settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check electrical system voltage and diesel exhaust fluid heater configuration settings in INSITE™ electronic service tool.

  • Use the Features and Parameters menu in INSITE™ electronic service tool to make sure the electrical system voltage and diesel exhaust fluid heater configuration settings are correct for the vehicle being serviced.

Electrical system voltage and diesel exhaust fluid heater configuration settings are correct?
YES NO
No Repair

Use INSITE™ electronic service tool to update the Feature and Parameter settings accordingly.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration.

Guided Step 3A - Calibrate the ECM.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

After calibrating the ECM, operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Use INSITE™ electronic service tool to check the fault codes.

Did Fault Code 3598 become active again?
YES NO

A damaged or malfunctioning aftertreatment diesel exhaust fluid controller has been detected.

Replace the aftertreatment diesel exhaust fluid controller. Refer to Procedure 011-057 in the Associated Procedures Table.

Calibration of the ECM has corrected the issue.

Go to 4A

Repair complete

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Feb-2012


FAULT CODE 3616 - Engine VGT Nozzle Position - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 EC2CF | 4310846
Cooling System | Refer to Procedure 008-018 | ISC8.3 sand ISL9 CM 2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 ECF | 4310661
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 | 4310664
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 B128 | 4388601
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 L115 | 4388626
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 X115 | 4388739
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Air Intake Manifold | Refer to Procedure 010-023 | ISB6.7 CM2250 | 4022254
Air Intake Manifold | Refer to Procedure 010-023 | ISB6.7 CM2350 B103 | 4332641
Air Intake Manifold | Refer to Procedure 010-023 | ISB6.7 CM2250 EC | 2883621
Air Intake Manifold | Refer to Procedure 010-023 | ISC8.3 sand ISL9 CM 2250 | 4022257
Air Intake Manifold | Refer to Procedure 010-023 | ISX12/ISX11.9 CM2250 | 2883445
Air Intake Manifold | Refer to Procedure 010-023 | ISX15 CM 2250 GX CM2250 | 4022250
Air Intake Manifold | Refer to Procedure 010-023 | QSX15 CM2250 ECF | 2883557
Air Intake Manifold | Refer to Procedure 010-023 | QSX11.9 CM2250 ECF | 2883561
Air Intake Manifold | Refer to Procedure 010-023 | ISX15 CM2350 X101 | 4310846
Air Intake Manifold | Refer to Procedure 010-023 | PowerGen QSX15 CM2250 ECF | 4310661
Air Intake Manifold | Refer to Procedure 010-023 | PowerGen QSX15 CM2250 | 4310664
Air Intake Manifold | Refer to Procedure 010-023 | ISL9 CM2350 L111 | 4367223
Air Intake Manifold | Refer to Procedure 010-023 | QSB6.7 CM2250 B128 | 4388601
Air Intake Manifold | Refer to Procedure 010-023 | QSL9 CM2250 L115 | 4388626
Air Intake Manifold | Refer to Procedure 010-023 | ISB6.7 CM2350 B142 | 5411131
Air Intake Manifold | Refer to Procedure 010-023 | QSX15 CM2250 X115 | 4388739
Air Intake Manifold | Refer to Procedure 010-023 | B4.5 CM2350 B129B | 5411247
Air Intake Manifold | Refer to Procedure 010-023 | B6.7 CM2350 B135B | 5411257
Air Intake Manifold | Refer to Procedure 010-023 | B4.5 CM2350 B147B | 5411252
Air Intake Manifold | Refer to Procedure 010-023 | B6.7 CM2350 B148B | 5411262
Air Intake Manifold | Refer to Procedure 010-023 | L9 CM2350 L119B | 5411267
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2250 | 4022254
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2250 EC | 2883621
Turbocharger | Refer to Procedure 010-033 | ISB4.5 CM2350 B104 | 4332641
Turbocharger | Refer to Procedure 010-033 | ISC8.3 and ISL9 CM 2250 | 4022257
Turbocharger | Refer to Procedure 010-033 | ISF2.8 CM2220 EC2CF | 4310846
Turbocharger | Refer to Procedure 010-033 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger | Refer to Procedure 010-033 | ISX15 CM 2250 GX CM2250 | 4022250
Turbocharger | Refer to Procedure 010-033 | QSX11.9 CM2250 ECF | 2883561
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 ECF | 2883557
Turbocharger | Refer to Procedure 010-033 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger | Refer to Procedure 010-033 | PowerGen QSX15 CM2250 | 4310664
Turbocharger | Refer to Procedure 010-033 | ISL9 CM2350 L111 | 4367223
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 B128 | 4388601
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2250 L115 | 4388626
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2350 B142 | 5411131
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 X115 | 4388739
Turbocharger | Refer to Procedure 010-033 | B4.5 CM2350 B129B | 5411247
Turbocharger | Refer to Procedure 010-033 | B6.7 CM2350 B135B | 5411257
Turbocharger | Refer to Procedure 010-033 | B4.5 CM2350 B147B | 5411252
Turbocharger | Refer to Procedure 010-033 | B6.7 CM2350 B148B | 5411262
Turbocharger | Refer to Procedure 010-033 | L9 CM2350 L119B | 5411267
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B103 | 4332641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 sand ISL9 CM 2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 EC2CF | 4310846
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM 2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 ECF | 2883557
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L111 | 4367223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B142 | 5411131
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B129B | 5411247
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B135B | 5411257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B147B | 5411252
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B148B | 5411262
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L119B | 5411267

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for other active turbocharger fault codes. | Fault Code 2387 active or high inactive counts?
 | STEP 1B. Review claims history for recent turbocharger failures. | Turbocharger replaced in the past three months for the same symptoms?
STEP 2. | Verify the complaint. |
 | STEP 2A. Check the fault code. | Fault Code 3616 active?
 | STEP 2B. Vehicle test drive | Fault Code 2387 active?
 | STEP 2C. Confirm the complaint. | Customer reported a drivability complaint with a cold engine?
 | STEP 2D. Inspect the variable geometry turbocharger actuator. | Use the sector gear travel gauge. Nozzle movement meet the requirements according to Procedure 010-134?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for other active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387 active or high inactive counts?
YES | NO
No Repair | No Repair

Fault Code 2387 troubleshooting symptom tree

Go to 1B

Guided Step 1B - Review claims history for recent turbocharger malfunctions.

Conditions

  • None

Action

Review malfunctions that have occurred over the last six months to see if the engine has been in for the same symptoms.

Has the turbocharger been replaced in the past three months for the same symptoms?
YES NO

Inspect the grid heater for damage or plugging.

If the engine is not equipped with a grid heater, skip to Step 2A.

  • Refer to Procedure 010-023 in the Associated Procedures Table.

Note: If found damaged, replace the grid heater and inspect the air handling system for debris.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Verify the complaint.

Guided Step 2A - Check the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 3616.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3616 active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2C

Guided Step 2B - Vehicle test drive.

Conditions

  • Connect all components.
  • Allow the coolant temperature to cool below 74°C [165°F].
  • NOTE: This test can not be performed if the engine does not start. If the engine does not start, verify there are no other faults that can prohibit the engine from starting. Skip this step, and proceed to Step 2D.

Action

Determine whether the fault goes inactive when operated with a coolant temperature above 74°C [165°F].

  • Start the engine and operate under normal driving conditions for at least 15 minutes, or until the coolant temperature is greater than 74°C [165°F].
  • Use INSITE™ electronic service tool to verify the fault code.

Fault Code 2387 active?
YES NO
No Repair

Fault Code 3616 is an informational fault code indicating that the ECM has taken action to resolve a keyswitch ON condition.

Fault Code 2387 troubleshooting symptom tree

Go to 3A

Guided Step 2C - Confirm the complaint

Conditions

  • Turn keyswitch OFF.

Action

Review the customer complaint.

  • Establish whether the customer reported engine warm-up drivability complaints (low power, poor response, or low braking power).

Customer reported a drivability complaint with a cold engine?
YES NO
No Repair

Fault Code 3616 is an informational fault code indicating that the ECM has taken action to resolve a keyswitch ON condition.

Go to 2D

Go to 3A
Go to

Guided Step 2D - Inspect the variable geometry turbocharger actuator

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.

Action

Remove the variable geometry turbocharger actuator from the turbocharger.

  • Use a sector gear travel gauge, Part Number 4919281, to make sure the sector gear moves through its operational range.
  • Refer to Procedure 010-134 in the Associated Procedures Table.

Note: It may take considerable force to move the sector gear. If it can be moved by hand, this is considered acceptable. Do not use any hand tools.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Use the sector gear travel gauge. Nozzle movement meet the requirements according to Procedure 010-134?
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

Note: Replace the turbocharger assembly.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

NOTE: This malfunction can be caused by debris exiting the engine, causing the turbocharger to stop moving. Inspect the base engine components for damage. The variable geometry turbocharger actuator will be reused with the new turbocharger. Do not install the actuator on the malfunctioning turbocharger.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 3641 - Transmission Output Retarder - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with the INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with the INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3641 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3641 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with the INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3641 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the fault codes.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

NOTE: Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3641 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Go to 6A

The appropriate ECM - No Communication troubleshooting symptom tree in Section TT

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Jan-2013


FAULT CODE 3648 - Aftertreatment Diesel Exhaust Fluid Controller Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 3648 active or more than three inactive counts?
STEP 2. | Check the aftertreatment diesel exhaust fluid controller mounting location. |
 | STEP 2A. Make sure that the aftertreatment diesel exhaust fluid controller is properly mounted. | Aftertreatment diesel exhaust fluid controller properly installed?
 | STEP 2B. Check for obstructed or restricted air flow to the aftertreatment diesel exhaust fluid controller. | Signs of air flow restriction to diesel exhaust fluid controller?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3648 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid controller mounting location.

Guided Step 2A - Make sure that the aftertreatment diesel exhaust fluid controller is properly mounted.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Refer to the OEM service manual to determine the designated mounting location for the aftertreatment diesel exhaust fluid controller, and verify that the controller is mounted at the correct location on the vehicle. Make sure that all fasteners are properly installed and secure.

Aftertreatment diesel exhaust fluid controller properly installed?
YES NO
No Repair

Relocate and/or secure the aftertreatment diesel exhaust controller at the correct mounting location.

Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for obstructed or restricted air flow to the aftertreatment diesel exhaust fluid controller.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Check the aftertreatment diesel exhaust fluid mounting area for air flow obstructions.The diesel exhaust controller is designed to be mounted such that air will flow over it and naturally cool it during operation. Restrictions or blockage of this air flow could cause the controller to overheat.Check for the following:

  • Debris on or around the diesel exhaust fluid controller
  • Aftermarket shields, flaps, or brackets mounted too close to the diesel exhaust fluid controller.

Signs of air flow restriction to diesel exhaust fluid controller?
YES NO

Repair the cause of the restricted air flow. Remove any debris accumulated near the diesel exhaust fluid controller. Relocate any aftermarket accessories that might be restricting air flow.

Contact the vehicle OEM for guidance in diesel exhaust fluid controller mounting.

Go to 3A

Repair Complete

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete.

Go to 1A

Last Modified: 13-Jan-2012


FAULT CODE 3649 - Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB4.5 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B148B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3649 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 1885, 3232, or 3682 active?
 | STEP 1C. Check for active fault codes. | Fault Codes 3313, 3314, or 3315 active?
STEP 2. | Check the aftertreatment intake nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect the aftertreatment intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment intake NOx sensor. | Voltage within 1 VDC of battery voltage?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3649 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1885, 3232, or 3682 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3313, 3314, or 3315 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment intake NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment intake NOx sensor.

Conditions

  • Disconnect the sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment intake NOx sensor.

  • Measure the voltage between the aftertreatment intake NOx sensor battery voltage supply circuit and the aftertreatment intake NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage with keyswitch ON, while cranking the engine and with engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

A damaged aftertreatment intake NOx sensor heater has been detected.

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten any loose connections and clean the terminals.

See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment intake NOx sensor battery voltage SUPPLY pin of the OEM harness to the engine block ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3651 - Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, 1712, 3237, 3239, 3258, 3261, 3422, 3425, 3426, 3429, 3562, 3563, 3564, or 3576 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heating system. |
 | STEP 2A. Inspect the diesel exhaust fluid tank heater coolant lines. | Leaks or damage found in the tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level ok?
STEP 3. | Check the aftertreatment diesel exhaust fluid tank temperature sensor. |
 | STEP 3A. Check the aftertreatment diesel exhaust fluid tank temperature sensor. | INSITE™ electronic service tool reading within 10°C or 18°F of infrared thermometer reading?
 | STEP 3B. Check the aftertreatment diesel exhaust fluid tank temperature sensor. | INSITE™ electronic service tool reading for the aftertreatment diesel exhaust fluid tank temperature rises more than 5°C or 9°F while heating?
STEP 4. | Check the aftertreatment diesel exhaust fluid tank heater operation. |
 | STEP 4A. Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heater control valve operating correctly?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to line or tank heaters.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, 1712, 3237, 3239, 3258, 3261, 3422, 3425, 3426, 3429, 3562, 3563, 3564, or 3576 active?
YES NO

Troubleshoot appropriate active fault codes before troubleshooting Fault Code 3651.

 No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2A - Check the aftertreatment diesel exhaust fluid tank heating system.

Guided Step 2A - Inspect the diesel exhaust fluid tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked or restricted coolant lines
  • Loose connections.

Refer to the OEM service manual for details on coolant line routing and flow.

Leaks or damage found in the tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check engine coolant level.

  • Make sure that the coolant level is within normal operating levels.

Coolant level ok?
YES NO
No Repair

Add coolant to the engine as necessary.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid tank temperature sensor.

Guided Step 3A - Check the aftertreatment diesel exhaust fluid tank temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Measure the temperature of the diesel exhaust fluid in the diesel exhaust fluid tank with an infared thermometer.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer.

INSITE™ electronic service tool reading within 10°C or 18°F of infrared thermometer reading?
YES NO

No repair.

Replace the diesel exhaust fluid tank temperature sensor.

Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check the aftertreatment diesel exhaust fluid tank temperature sensor.

Conditions

NOTE: If the diesel exhaust fluid tank is frozen, it will be necessary to let the tank thaw before performing this step.

  • Thaw the diesel exhaust fluid tank.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger and monitorINSITE™ electronic service tool reading for the aftertreatment diesel exhaust fluid tank temperature sensor.

  • Heat the aftertreatment diesel exhaust fluid tank with a heat gun, Part Number 3822860, to raise the temperature of the diesel exhaust fluid.

INSITE™ electronic service tool reading for the aftertreatment diesel exhaust fluid tank temperature rises more than 5°C or 9°F while heating?

YES NO

No repair.

Replace the diesel exhaust fluid tank temperature sensor.

Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the aftertreatment diesel exhaust fluid tank heater operation.

Guided Step 4A - Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to override the tank heater operation; use the Diesel Exhaust Fluid Doser System Heater Test under the ECM Diagnostic Tests menu.

Make sure that the tank heater control valve is operating correctly, and is not stuck closed or slow to respond. Refer to the OEM service manual for proper diesel exhaust fluid tank heater control valve operation.

Diesel exhaust fluid tank heater control valve operating correctly?
YES NO

No repair.

Replace the diesel exhaust fluid tank heater control valve.

Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2011


FAULT CODE 3679 - Aftertreatment Diesel Exhaust Fluid Dosing Unit - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3679 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit circuit. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
 | STEP 2D. Check for active aftertreatment diesel exhaust fluid dosing unit fault codes. | Fault Code 3558, 3559, or 3561 Active?
 | STEP 2E. Check for an active fault code | Fault Code 3679 Active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3679 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit and electrical connections.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the engine harness and aftertreatment diesel exhaust fluid dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the harness.

Action

Check for an open circuit in the aftertreatment diesel exhaust fluid dosing unit circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the dosing unit harness connector and the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the 86-pin controller connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the dosing unit harness connector and the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the 86-pin controller connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SIGNAL/dosing unit temperature pin at the dosing unit harness connector and the aftertreatment diesel exhaust fluid dosing unit SIGNAL/dosing unit temperature pin at the 86-pin controller connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness. Repair or replace the harness. Refer to the OEM service manual.

Go to 3A

Go to 2C

Guided Step 2C - Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller and the diesel exhaust fluid dosing unit harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between aftertreatment diesel exhaust fluid dosing unit SIGNAL / dosing unit temperature pin at the aftertreatment diesel exhaust fluid controller harness 86-pin connector and chassis ground.

Refer to the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness. Refer to the OEM service manual.

Go to 2D

Go to 3A

Guided Step 2D - Check for active aftertreatment diesel exhaust fluid dosing unit fault codes.

Conditions

  • Connect the aftertreatment diesel exhaust fluid dosing unit to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active aftertreatment diesel exhaust fluid dosing unit fault codes after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3558, 3559, or 3561 active?
YES | NO
No Repair | No Repair

Applicable fault code troubleshooting tree.

Go to 2E

Guided Step 2E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3679 Active?
YES NO

Replace the aftertreatment diesel exhaust fluid dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 09-Mar-2012


FAULT CODE 3681 - Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISF2.8 CM2220 F122 | 5467376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 SN | 4310736
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSG12 CM2350 G110 | 4367323
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L118 | 4388673
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X114B | 5411181
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X116B | 5411186
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B121B | 5411223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L116B | 5411330
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | F3.8 CM2350 F120B | 5411237
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B129B | 5411247
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B135B | 5411257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B147B | 5411252
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B148B | 5411262
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L119B | 5411267
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3681 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment outlet nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for the correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor correct for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3681 active?
 | STEP 2F. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3681 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
 | STEP 3C. Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3681 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Inspect aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2C - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment outlet NOx sensor.

Action

Verify aftertreatment outlet NOx sensor is the correct sensor for the engine configuration.

The aftertreatment outlet NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment outlet NOx sensor is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment SCR catalyst outlet temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3681 active?
YES NO

Use NOx sensor service tool, Part Number 2892467, to test the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 2F

Go to 4A

Guided Step 2F - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment SCR catalyst outlet temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3681 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt system)
  • At least +24 VDC (24 volt system).

Cranking conditions:

  • At least +6.2 VDC (12 volt system)
  • At least +12 VDC (24 volt system).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery (s). See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-May-2017


FAULT CODE 3682 - Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411189
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB64.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B148B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3682 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment intake nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect aftertreatment intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment intake NOx sensor. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment intake NOx sensor. | Aftertreatment intake NOx sensor is the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment intake NOx sensor. | Fault Code 3682 active?
 | STEP 2F. Check the condition of the aftertreatment intake NOx sensor. | Fault Code 3682 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
 | STEP 3C. Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3682 active?
YES NO

No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment intake NOx sensor circuit.

Guided Step 2A - Inspect aftertreatment intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment intake NOx sensor.

  • Measure the voltage between the aftertreatment intake NOx sensor battery voltage supply circuit and the aftertreatment intake NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage at key ON while cranking the engine, and with the engine at idle.

the wiring diagram for connector pin identification.

Use the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment intake NOx sensor.

Action

Verify aftertreatment intake NOx sensor is the correct sensor for the engine configuration.

The aftertreatment intake NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment intake NOx sensor is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment intake NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment diesel oxidation catalyst intake temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment intake NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3682 active?
YES NO

Use NOx sensor service tool, Part Number 2892467, to test aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 2F

Go to 4A

Guided Step 2F - Check the condition of the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment intake NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment diesel oxidation catalyst intake temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment intake NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3682 active?
YES NO

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 FDC (12 volt system)
  • At least +24 VDC (24 volt system)/

Cranking conditions:

  • At least _6.2 VDC (12 volt system)
  • At least +12 VDC (24 volt system).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment intake NOx sensor battery voltage SUPPLY pin of the engine harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage return circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage supply circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 3697 - Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC2CF | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
5467376Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module. | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2350 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Calibrate the engine control module (ECM). |
 | STEP 2A. Calibrate the ECM. | Fault Code 3697 active after calibrating the ECM?
 | STEP 2B. Disable and clear the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Fault Code 111 troubleshooting tree.

Go to 2A

Guided Step 2 - Calibrate the engine control module (ECM).

Guided Step 2A - Calibrate the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to calibrate the ECM with the latest engine calibration. Refer to the calibration revisions listed in the ECM Calibration Revision History to find the latest calibration available for the engine being serviced.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

Fault Code 3697 active after calibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 2B

Go to 2B

Guided Step 2B - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Repair complete.

Last Modified: 22-May-2017


FAULT CODE 3713 - Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3713 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid line heater relay. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid line heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for pin-to-pin short circuit in diesel exhaust fluid line heater relay. | Less than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3713 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid line heater relay.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid line heater relay and connector pins..

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid line heater relay and aftertreatment diesel exhaust fluid controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for pin-to-pin short circuit in diesel exhaust fluid line heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the aftertreatment diesel exhaust fluid controller harness.

Action

Check the resistance of the aftertreatment diesel exhaust fluid line heater relay.

  • Measure the resistance between pin 30 and pin 87 of the aftertreatment diesel exhaust fluid line heater relay.

Use the following precedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 100k ohms?
YES NO

A pin-to-pin short circuit on the switch side of the aftertreatment diesel exhaust fluid line heater relay has been detected.

Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to the OEM service manual.

A short circuit to battery has been detected in the line heater power supply circuit of the aftertreatment diesel exhaust fluid controller harness

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necesssary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 13-Dec-2011


FAULT CODE 3717 - Aftertreatment 1 Outlet NOx Sensor - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2250 | 4022254
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB64.5 CM2350 B104 | 4332646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 X101 | 4310787
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK19 CM2350 K105 | 4326157
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L102 | 4332796
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK50 CM2350 K108 | 4332823
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K116 | 4367444
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K117 | 4367449
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K121 | 4388645
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L118 | 4388673
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | F3.8 CM2350 F120B | 5411237
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B129B | 5411247
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B135B | 5411257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B147B | 5411252
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B148B | 5411262
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L119B | 5411267
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSG12 CM2350 G110 | 4367323
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3681 active?
STEP 2. | Check the aftertreatment outlet nitrogen oxides (NOx) sensor. |
 | STEP 2A. Check the aftertreatment outlet NOx sensor. | Electrical system voltage parameter correct for the engine control parts list (CPL)?
 | STEP 2B. Check for correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor is the correct sensor for the engine CPL?
 | STEP 2C. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3717 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3717 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter setting.

  • Use INSITE™ electronic tool "Features and Parameters" feature to determine electrical system voltage.
  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical system voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 2B

Go to 3A

Guided Step 2B - Check for correct aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment outlet NOx sensor.

Action

Verify the aftertreatment outlet NOx sensor is the correct sensor for the engine CPL.

The aftertreatment outlet NOx sensor is available in 12 or 24 volt versions.

Aftertreatment outlet NOx sensor is the correct sensor for the engine CPL?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch ON.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3717 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Note: The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3718 - Aftertreatment 1 Intake NOx - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK19 CM2350 K105 | 4326157
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK50 CM2350 K108 | 4332823
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K116 QSK60 CM2350 K117 QSK60 CM2350 K121 | 4367444 4367449 4388645
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B148B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3718 active?
STEP 2. | Check the aftertreatment intake nitrogen oxides (NOx) sensor. |
 | STEP 2A. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine control parts list (CPL)?
 | STEP 2B. Check for correct aftertreatment intake NOx sensor. | Aftertreatment intake NOx sensor the correct sensor for the engine CPL?
 | STEP 2E. Check the condition of the aftertreatment intake NOx sensor. | Fault Code 3718 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3718 active?
YES NO

No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment intake NOx sensor.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool "Features and Parameters" feature to determine electrical system voltage.
  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical system voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 2B

Go to 3A

Guided Step 2B - Check for correct aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment intake NOx sensor

Action

Verify aftertreatment intake NOx sensor is the correct sensor for the engine CPL.

Note: The aftertreatment intake NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment intake NOx sensor is the correct sensor for the engine CPL?
YES NO
No Repair

An incorrect aftertreatment outlet NOx sensor for the voltage application has been detected.

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the condition of the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment intake NOx sensor.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 3718 active?
YES NO

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 3724 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the engine control module (ECM). | Fault Code 3724 active?
 | STEP 1B. Check the inactive counts of Fault Code 3724. | Less than three counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.

Start the engine and let it idle for 1 minute.

Fault Code 3724 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the inactive counts of Fault Code 3724.

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 3724.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 3724.

Less than three counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jan-2017


FAULT CODE 3725 - Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB4.3 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2250 | 4022256
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2250 | 4022255
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK19 CM2350 K105 | 4326157
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK50 CM2350 K108 | 4332823
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K116 QSK60 CM2350 K117 QSK60 CM2350 K121 | 4367444 4367449 4388645
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B148B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1885, 3232, or 3682 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3725 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1885, 3232 or 3682 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3725 active?
YES NO

An internal error has been detected in the aftertreatment intake mono-nitrogen oxide (NOx) sensor.

Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 3733 - Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 ECF | 2883557
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 CM2350 X102 | 4310646
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2350 X101 | 4310641
Crankcase Breather (External) | Refer to Procedure 003-001 | X15 CM2350 X114B | 5411181
Crankcase Breather (External) | Refer to Procedure 003-001 | X15 CM2350 X116B | 5411186
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3733 active?
STEP 2. | Check the crankcase breather heater and circuit. |
 | STEP 2A. Inspect the crankcase breather heater and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the crankcase breather heater for an open circuit. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 3733 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3733 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the crankcase breather heater and circuit.

Guided Step 2A - Inspect the crankcase breather heater and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine harness.

Action

Inspect the crankcase breather heater and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the crankcase breather heater for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater engine harness connector.

Action

Check the resistance of the heater.

  • Measure the resistance from the crankcase breather heater SUPPLY pin to the crankcase breather heater RETURN pin.

Refer to the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

An open circuit has been detected in the crankcase breather heater.

Replace the crankcase breather heater. Refer to Procedure 003-001 in the Associated Procedures Table.

For some engine applications, the crankcase breather heater is integral to the crankcase breather cover and the crankcase breather cover assembly must replaced.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankcase breather heater from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the crankcase breather heater SUPPLY pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the crankcase breather heater SIGNAL wire has been detected.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3733 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete

Last Modified: 20-Jan-2017


FAULT CODE 3734 - Crankcase Breather Filter Heater Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 ECF | 2883557
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 CM2350 X102 | 4310646
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2350 X101 | 4310641
Crankcase Breather (External) | Refer to Procedure 003-001 | X15 CM2350 X114B | 5411181
Crankcase Breather (External) | Refer to Procedure 003-001 | X15 CM2350 X116B | 5411186
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3734 active?
STEP 2. | Check the crankcase breather heater and circuit. |
 | STEP 2A. Inspect the crankcase breather heater and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the crankcase breather heater for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C. Check the crankcase breather heater for an internal short. | Less than 5 ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 3734 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3734 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the crankcase breather heater and circuit.

Guided Step 2A - Inspect the crankcase breather heater and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine harness.

Action

Inspect the engine harness and heater connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the heater or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the crankcase breather heater for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater engine harness connector.

Action

Check heater for a short circuit to ground..

  • Measure the resistance from crankcase breather heater SIGNAL pin to ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the crankcase breather heater. Refer to Procedure 003-001 in the Associated Procedures Table.

For some engine applications, the crankcase breather heater is integral to the crankcase breather cover and the crankcase breather cover assembly must be replaced.

Go to 2C

Go to 4A

Guided Step 2C - Check the crankcase breather heater for an internal short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater engine harness connector.

Action

Check the resistance of the heater.

  • Measure the resistance between the crankcase breather heater SIGNAL pin and the crankcase breather heater RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO

An internally shorted crankcase breather heater has been detected.

Replace the crankcase breather heater. Refer to Procedure 003-001 in the Associated Procedures Table.

For some engine applications, the crankcase breather heater is integral to the crankcase breather cover and the crankcase breather cover assembly must be replaced.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankcase breather heater from the engine harness.

Action

Check for a open circuit.

  • Measure the resistance between the crankcase breather heater SUPPLY pin in the engine harness ECM connector and the crankcase breather heater SUPPLY pin at the crankcase breather heater harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the crankcase breather heater supply circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankcase breather heater from the engine harness.

Action

Check for a open circuit

  • Measure the resistance between the crankcase breather heater RETURN pin in the engine harness ECM connector and the crankcase breather heater RETURN pin at the crankcase breather heater harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the crankcase breather heater return circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankcase breather heater from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the crankcase breather heater SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the crankcase breather heater SIGNAL wire has been detected.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankcase breather heater from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the crankcase breather heater SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the crankcase breather heater SIGNAL wire has been detected.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3734 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete

Last Modified: 20-Jan-2017


FAULT CODE 4157 - Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller Calibration Code | Refer to Procedure 011-077 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller Calibration Code | Refer to Procedure 011-077 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller Calibration Code | Refer to Procedure 011-077 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Controller Calibration Code | Refer to Procedure 011-077 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | ISX15 CM2250 GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4157 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid lines and fittings. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit suction and pressure lines. | Any reversed, damaged, leaking, or restricted connections found?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller circuit. |
 | STEP 3A. Inspect aftertreatment diesel exhaust fluid controller and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance of the aftertreatment diesel exhaust fluid dosing unit wiring harness. | Resistance less than 4 ohms?
 | STEP 3C. Check for resistance in the aftertreatment diesel exhaust fluid dosing unit. | Resistance value between 4 ohms and 9 ohms?
 | STEP 3D. Complete an aftertreatment diesel exhaust fluid dosing unit purge cycle. | Fault Code 4157 active?
STEP 4. | Check the aftertreatment diesel exhaust fluid controller software phase. |
 | STEP 4A. Check if an aftertreatment diesel exhaust fluid controller software phase update is available. | If a software phase update for this fault code is available, does the aftertreatment diesel exhaust fluid controller contain that revision or higher?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4157 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid lines and fittings.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit suction and pressure lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the dosing unit supply line between the tank and the dosing unit (suction line) and the dosing valve supply line between the dosing unit and the dosing valve (pressure line).

  • Verify the suction and return line connections are not swapped at the dosing unit or diesel exhaust fluid tank connections. Reversed diesel exhaust fluid line connectors cause the dosing unit to fail to prime.
  • Check the diesel exhaust fluid tank connections for cracks and pitting.
  • Check the suction line and pressure line connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of buildup or blockage.
  • Verify proper sealing at all connection points, including the diesel exhaust fluid tank, the dosing unit, and dosing the dosing valve.

Refer to Procedure 011-058 in the Associated Procedures Table.

Any reversed, damaged, leaking, or restricted connections found?
YES NO

Repair or replace the leaking diesel exhaust fluid line or fitting as necessary.

Refer to the OEM service manual.

Repair or replace the aftertreatment diesel exhaust fluid dosing unit as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller circuit.

Guided Step 3A - Inspect aftertreatment diesel exhaust fluid controller and connector pins.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller from the OEM harness.
  • Disconnect the wiring harness from the aftertreatment diesel exhaust fluid dosing unit.

Action

Inspect the aftertreatment diesel exhaust fluid dosing unit connector, the OEM harness, and the aftertreatment diesel exhaust fluid controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the controller or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the resistance of the aftertreatment diesel exhaust fluid dosing unit wiring harness.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the wiring harness aftertreatment diesel exhaust fluid controller.
  • Disconnect the wiring harness from the aftertreatment diesel exhaust fluid dosing unit.

Action

Check the resistance of the aftertreatment diesel exhaust fluid dosing unit wiring harness.

  • Measure the resistance between the aftertreatment diesel exhaust fluid return valve battery voltage SUPPLY connector at the aftertreatment diesel exhaust fluid dosing unit connector and the aftertreatment diesel exhaust fluid return valve battery voltage SUPPLY connector at the diesel exhaust fluid controller connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid return valve SIGNAL connector at the aftertreatment diesel exhaust fluid dosing unit connector and the aftertreatment diesel exhaust fluid return valve SIGNAL connector at the diesel exhaust fluid controller connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Resistance less than 4 ohms?
YES NO
No Repair

High resistance has been detected in the aftertreatment diesel exhaust fluid return valve circuit.

Troubleshoot the wiring harness and all interconnects for an open circuit.

Repair or replace the damaged component.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for resistance in the aftertreatment diesel exhaust fluid dosing unit.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding. Allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the wiring harness aftertreatment diesel exhaust fluid controller.
  • Disconnect the wiring harness from the aftertreatment diesel exhaust fluid dosing unit.

Action

Check for resistance in the aftertreatment diesel exhaust fluid dosing unit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid return valve battery voltage SUPPLY connector at the aftertreatment diesel exhaust fluid dosing unit connector and the aftertreatment diesel exhaust fluid return valve SIGNAL connector at the diesel exhaust fluid dosing unit connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Resistance value between 4 ohms and 9 ohms?
YES NO
No Repair

A damaged aftertreatment diesel exhaust fluid dosing unit has been detected. Replace the aftertreatment diesel exhaust fluid dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Complete an aftertreatment diesel exhaust fluid dosing unit purge cycle.

Conditions

  • Connect all components.
  • Turn keyswitch ON with the engine OFF.
  • Connect INSITE™ electronic service tool.

Action

Complete an aftertreatment diesel exhaust fluid dosing unit purge cycle.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Leak Test. Refer to Procedure 011-080 in the Associated Procedures Table.
  • Allow INSITE™ electronic service tool to confirm that the system is primed. A message will appear on the screen.
  • Press the STOP button in INSITE™ electronic service tool and turn the keyswitch OFF. Allow the aftertreatment diesel exhaust fluid system to purge for 90 seconds.
  • Turn the keyswitch ON with the engine OFF.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4157 active?
YES NO

A damaged aftertreatment diesel exhaust dosing unit has been detected. Replace the aftertreatment diesel exhaust dosing unit.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check the aftertreatment diesel exhaust fluid controller software phase.

Guided Step 4A - Check if an aftertreatment diesel exhaust fluid controller software phase update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the aftertreatment diesel exhaust fluid controller software phase to the latest revision published on QuickServe™ Online for applicable changes related to the fault code.

Refer to Service Bulletin 4310705.

  • Use INSITE™ electronic service tool to find the present aftertreatment diesel exhaust fluid controller software phase. The aftertreatment diesel exhaust fluid controller software phase is found in the System Dataplate section of the Aftertreatment Diesel Exhaust Fluid Controller in Features and Parameters.

If a software phase update for this fault code is available, does the aftertreatment diesel exhaust fluid controller contain that revision or higher?

YES NO
No Repair

If necessary, calibrate the aftertreatment diesel exhaust fluid controller. Refer to Procedure 011-077 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Oct-2014


FAULT CODE 2636 - VGT Actuator Driver Circuit - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B101 | 2883567
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 M2350 L101 | 4310787
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12 CM2350 X102 | 4310646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX CM2350 X101 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9 CM2350 L101 | 4310787
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12 CM2350 X102 | 4310646
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1962 or 1976 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active J1939 data link fault codes. |
STEP 2. | Check the variable geometry turbocharger (VGT) actuator and circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the VGT actuator internal terminating resistance. | 108 to 132 ohms?
 | STEP 2C. Check the voltage to the VGT actuator at the VGT actuator wiring harness connector. | Voltage is within +/- 1 volt DC of battery voltage?
 | STEP 2C-1. Check the voltage to the VGT actuator at the engine control module (ECM). |
 | STEP 2D. Check J1939 CAN circuit voltage at the VGT actuator wiring harness connector. | Voltage should be between 1.0V and 4.5V?
 | STEP 2E. Check J1939 data link circuit voltage at ECM connector. | Voltage should be between 1.0V and 4.5V?
STEP 3. | Check the J1939 terminating resistance. |
 | STEP 3A. Check the J1939 terminating resistance. | 54 to 66 ohms?
 | STEP 3B. Check the original equipment manufacturer (OEM) terminating resistor. | Between 108 to 132 ohms?
 | STEP 3C. Check the VGT actuator internal terminating resistance. | 108 to 132 ohms?
STEP 4. | Check the equipment battery system. |
 | STEP 4A. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 5. | Check the J1939 components. |
 | STEP 5A. Check the VGT actuator. | Between 1.0 and 4.5 VDC?
 | STEP 5B. Check the intake NOx sensor. | Between 1.0 and 4.5 VDC?
 | STEP 5C. Check the data link aftertreatment diesel exhaust fluid tank level/temperature/quality sensor, if equipped. | Between 1.0 and 4.5 VDC?
 | STEP 5D. Check the diesel particulate filter temperature sensor module. | Between 1.0 and 4.5 VDC?
 | STEP 5E. Check the selective catalytic reduction (SCR) temperature sensor module. | Between 1.0 and 4.5 VDC?
 | STEP 5F. Check the aftertreatment intermediate NH3 sensor, if equipped. | Between 1.0 and 4.5 VDC?
 | STEP 5G. Check the wiring harness. | Between 1.0 and 4.5 VDC?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1962 or 1976 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active J1939 data link fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677, 3682, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the VGT actuator and circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the harness connector and VGT actuator connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the VGT actuator or harness connector.

Some products may contain a jumper harness between the VGT actuator and engine harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the VGT actuator internal terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Check the resistance.

  • Measure the resistance between the Society of Automotive Engineering (SAE) J1939 data link (+) pin and the SAE J1939 data link (-) pin at the VGT actuator connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

108 to 132 ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 6A

Guided Step 2C - Check the voltage to the VGT actuator at the VGT actuator wiring harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the VGT actuator battery voltage SUPPLY pin and the VGT actuator battery voltage RETURN pin at the engine wiring harness connector.
  • Check the voltage at keyswitch ON.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage is within +/- 1 volt DC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the voltage to the VGT actuator at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage from the VGT actuator battery voltage SUPPLY pin on the ECM to the VGT actuator battery voltage RETURN pin on the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage is within +/- 1 volt DC of battery voltage?
YES NO

A malfunctioning engine wiring harness has been detected.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A malfunctioning ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 2D - Check J1939 CAN circuit voltage at the VGT actuator wiring harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin and the battery ground at the engine harness connector.
  • Measure the voltage between the SAE J1939 data link (-) pin and the battery ground at the engine harness connector.

Check the voltage at keyswitch ON.

Some products may contain a jumper harness between the VGT actuator and engine harness. Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage should be between 1.0V and 4.5V?
YES NO

A malfunctioning VGT actuator has been detected.

  • Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2E

Guided Step 2E - Check J1939 CAN circuit voltage at the ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin and the battery ground at the ECM connector.
  • Measure the voltage between the SAE J1939 data link (-) pin and the battery ground at the ECM connector.

Check the voltage at keyswitch ON.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage should be between 1.0V and 4.5V?
YES NO

A malfunctioning engine wiring harness has been detected.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A malfunctioning ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 3 - Check the J1939 terminating resistance.

Guided Step 3A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the VGT actuator.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.

Action

Measure the terminating resistance.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the 3 pin service data link connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

54 to 66 ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the OEM terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

Measure the resistance.

  • Measure the resistance between the pins of the OEM terminating resistor.

The J1939 data link harness is terminated at each end with a 120 ohm resistor. The terminating resistors must be in place to maintain proper communication. One resistor is located in a removable cap on the wiring harness, the other is integrated into the VGT actuator. Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 108 to 132 ohms?
YES NO
No Repair

A malfunctioning OEM terminating resister has been detected.

Replace the OEM terminating resistor. See equipment manufacturer service information.

Go to 3C

Go to 6A

Guided Step 3C - Check the VGT actuator internal terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Measure the resistance.

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the VGT actuator connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

108 to 132 ohms?
YES NO
No Repair

A malfunctioning VGT actuator has been detected.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the equipment battery system.

Guided Step 4A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the batteries and the unswitched battery supply circuit. Make sure the battery cable connections are tight and free of corrosion.

Perform the following checks at the batteries.

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal at keyswitch ON and engine OFF.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine.

Keyswitch ON and engine OFF conditions:

  • At least 12 VDC (12 volt system)
  • At least 24 VDC (24 volt system)

Cranking conditions:

  • At least 18 VDC (24 volt systems)

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 5A

Go to 5A

Guided Step 5 - Check the J1939 components.

Guided Step 5A - Check the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the VGT actuator.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 0.1 and 4.5 volts?
YES NO

A malfunctioning variable geometry turbocharger actuator has been detected.

Replace the variable geometry turbocharger actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the intake NOx sensor.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 0.1 and 4.5 volts?
YES NO

A malfunctioning intake NOx sensor has been detected.

Replace the intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5C

Guided Step 5C - Check the data link aftertreatment diesel exhaust fluid tank level/temperature/quality sensor, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the data link aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 0.1 and 4.5 volts?
YES NO

A malfunctioning data link aftertreatment diesel exhaust fluid tank.

Replace the data link aftertreatment diesel exhaust fluid tank level/temperature/quality sensor. See equipment manufacturer service information.

No Repair

Go to 6A

Go to 5D

Guided Step 5D - Check the diesel particulate filter temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the diesel particulate filter temperature sensor module.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 0.1 and 4.5 volts?
YES NO

A malfunctioning diesel particulate filter temperature sensor module has been detected.

Replace the diesel particulate filter temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5E

Guided Step 5E - Check the SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the SCR temperature sensor module.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 0.1 and 4.5 volts?
YES NO

A malfunctioning diesel particulate filter temperature sensor module has been detected.

Replace the diesel particulate filter temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5F

Guided Step 5F - Check the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the engine harness at the 14 pin cross-over connector.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 0.1 and 4.5 volts?
YES NO

A malfunctioning OEM wiring harness has been detected. See equipment manufacturer service manual.

A malfunctioning engine wiring harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Mar-2017


FAULT CODE 4167 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Controller Calibration Code | Refer to Procedure 011-077 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller Calibration Code | Refer to Procedure 011-077 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller Calibration Code | Refer to Procedure 011-077 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller Calibration Code | Refer to Procedure 011-077 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4167 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller software phase. |
 | STEP 2A. Check if an aftertreatment DEF controller software phase update is available. | If a software phase update for this fault code is available, does the aftertreatment DEF controller contain that revision or higher?
STEP 3. | Check the aftertreatment diesel exhaust fluid dosing unit and harness. |
 | STEP 3A. Inspect the aftertreatment DEF dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86-pin connector. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4167 is active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment DEF controller software phase.

Guided Step 2A - Check if an aftertreatment DEF controller software phase update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the aftertreatment DEF controller software phase to the latest revision published on QuickServe™ Online for applicable changes related to the fault code. Reference Cummins® Aftertreatment DEF Controller Software Phases, Bulletin 4310705.

  • Use INSITE™ electronic service tool to find the present aftertreatment DEF controller software phase. The aftertreatment DEF controller software phase is found in the System Dataplate section of the Aftertreatment Diesel Exhaust Fluid (DEF) Controller in Features and Parameters.

If a software phase update for this fault code is available, does the aftertreatment DEF controller contain that revision or higher?

YES NO
No Repair

If necessary, calibrate the aftertreatment DEF controller. Refer to Procedure 011-077 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF dosing unit and harness.

Guided Step 3A - Inspect the aftertreatment DEF dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.

Action

Inspect the original equipment manufacturer (OEM) harness and dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness from the controller.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SIGNAL (temperature) pin at the harness connector and the 86-pin controller connector.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.
  • Disconnect the aftertreatment DEF controller harness from the controller.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit RETURN pin at the connector and the 86-pin controller connector.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the aftertreatment DEF controller harness 86-pin connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-pin connector.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SIGNAL pin of the aftertreatment DEF controller harness 86-pin connector and all other pins in the connector.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness. Refer to the OEM service manual.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-pin connector.
  • Disconnect the aftertreatment DEF dosing unit from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the aftertreatment DEF controller harness 86-pin connector and ground.

Greater than 100k ohms?
YES NO

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

A short circuit to ground has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Oct-2014


FAULT CODE 4431 - Aftertreatment Diesel Exhaust Fluid Controller - Out of Calibration

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4431 active?
STEP 2. | Check ECM calibration. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Read the fault codes. | Fault Code 4431 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4431 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Start and idle engine.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4431 active?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Nov-2013


FAULT CODE 124 - Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment System | Refer to Procedure 011-050 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment System | Refer to Procedure 011-050 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

Do not use pliers or any other tool to turn the gear. Only rotate the gear by hand. Damage to the VGT actuator can occur.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 124 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1938 or 2636 active?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify the sensor accuracy with a mechanical gauge. | Gear is broken or damaged on the VGT actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | On the sector gear gauge, does the nozzle movement meet the requirements?
 | STEP 2D. Check the VGT output gear for correct calibration. | VGT actuator gear moves when connected to the engine wiring harness?
 | STEP 2D-1. Check the VGT output gear for manual rotation by hand. |
 | STEP 2E. Check for active Fault Code 124. | Fault Code 124 active?
STEP 3. | Check aftertreatment system. |
 | STEP 3A. Check for progressive damage to the aftertreatment system | Progressive damage to the aftertreatment system detected?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 124 active?
YES NO
No Repair

No troubleshooting is necessary unless Fault Code 124 is active.

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1938 or 2636 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch ON
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the VGT actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect the VGT actuator.

  • Check for a broken drive gear on the VGT actuator.

Gear is broken or damaged on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • VGT actuator removed from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever must move to the other stop position by hand.

Refer to Procedure 010-134 in the Associated Procedures Table.

On the sector gear gauge, does the nozzle movement meet the requirements?
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

Note: This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the VGT output gear for correct calibration.

Conditions

  • Disconnect the VGT actuator from the engine wiring harness.
  • Turn keyswitch ON.

Action

Check the VGT actuator output gear operation.

  • Connect the VGT actuator to the engine wiring harness. The VGT actuator gear should rotate.
  • The VGT actuator output gear will exhibit one of the following movements depending on the ECM calibration. Make sure to closely observe the VGT actuator gear when the VGT actuator is connected to the engine wiring harness.
  • The actuator output gear can rotate completely in one direction and then rotate completely in the opposite direction, OR
  • The actuator output gear may only move a few degrees in one direction. This movement will be a quick snap when the VGT actuator is connected to the engine wiring harness.
  • If the VGT actuator gear does not move, disconnect the VGT actuator from the engine wiring harness for 1 second and then connect the engine wiring harness.
  • Repeat the above procedure three times, check for the VGT actuator gear movement each time the VGT actuator is connected to the engine wiring harness.

VGT actuator gear moves when connected to the engine wiring harness?
YES NO

Install the VGT actuator back on the turbocharger making sure to perform the VGT actuator install and calibrate procedures.

Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check the VGT output gear for manual rotation by hand.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine wiring harness.

Action

Turn the VGT actuator output gear by hand.

  • Try turning the VGT actuator output gear by hand in either direction.

Can the VGT actuator output gear be rotated by hand?
YES NO

Install the VGT actuator on the turbocharger, making sure to perform the VGT actuator Install and Calibrate steps.

Refer to Procedure 010-134 in the Associated Procedures Table.

Replace the VGT actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for active Fault Code 124.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active Fault Code 124.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 124 active?
YES NO

Replace the VGT actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check aftertreatment system.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Turn keyswitch OFF.

Action

Check for damage to the aftertreatment system.

Perform the aftertreatment initial check procedure to test for a malfunctioning diesel particulate filter.

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Progressive damage to the aftertreatment system detected?
YES NO

Replace the damaged aftertreatment system component(s).

Refer to Procedure 011-050 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-May-2015


FAULT CODE 125 - Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Charge-Air Cooler | Refer to Procedure 010-027 | ISX CM2250 GX CM2250 | 4022250
Charge-Air Cooler | Refer to Procedure 010-027 | QSX15 CM2250 ECF | 2883557
Charge-Air Cooler | Refer to Procedure 010-027 | ISX12/ISX11.9 CM2250 | 2883445
Charge-Air Cooler | Refer to Procedure 010-027 | QSX11.9 CM2250 ECF | 2883561
Air Intake Restriction | Refer to Procedure 010-031 | ISX CM2250 GX CM2250 | 4022250
Air Intake Restriction | Refer to Procedure 010-031 | QSX15 CM2250 ECF | 2883557
Air Intake Restriction | Refer to Procedure 010-031 | ISX12/ISX11.9 CM2250 | 2883445
Air Intake Restriction | Refer to Procedure 010-031 | QSX11.9 CM2250 ECF | 2883561
Exhaust Restriction | Refer to Procedure 011-009 | ISX CM2250 GX CM2250 | 4022250
Exhaust Restriction | Refer to Procedure 011-009 | QSX15 CM2250 | 2883557
Exhaust Restriction | Refer to Procedure 011-009 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Restriction | Refer to Procedure 011-009 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | High active or inactive counts of Fault Code 122, 123, 221, 222, 295, or 687?
 | STEP 1B. Check for active fault codes. | High active or inactive counts of fault codes that are related to the turbocharger or exhaust gas recirculation (EGR) valve system?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the charge-air cooler and charge-air plumbing for leaks. | Air leaks present in the charge-air system?
 | STEP 2B. Check for a restricted charge-air cooler. | Charge-air cooler restriction within specifications?
 | STEP 2C. Check the EGR system for leaks and restrictions. | Leaks or restrictions present in the EGR system?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Check the intake manifold pressure sensor. | INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
STEP 4. | Check for restriction. |
 | STEP 4A. Check the exhaust system restriction. | Exhaust restriction within specifications?
 | STEP 4B. Check the intake restriction. | Air intake restriction within specifications?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of Fault Code 122, 123, 221, 222, 295, or 687?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the turbocharger or the EGR valve.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of fault codes that are related to the turbocharger or EGR valve system?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the charge-air cooler and charge-air plumbing for leaks.

Conditions

  • Operate the engine.

Action

Check the charge-air cooler and charge-air plumbing for leaks.

  • Check the charge-air cooler connections for leaks between the turbocharger compressor outlet and the charge-air cooler.
  • Check the charge-air cooler connections between the charge-air cooler and the intake manifold.
  • Check the air compressor inlet plumbing connections between the charge-air cooler and air compressor head for leaks.
  • Inspect the intake manifold gasket for leaks.
  • Inspect the charge-air cooler hoses for leaks or loose connections.
  • Inspect the charge-air cooler clamps to make sure they are tight.
  • Inspect the charge-air plumbing for cracks.

Air leaks present in the charge-air system?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a restricted charge-air cooler.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the pressure differential across the charge-air cooler.

  • Refer to Procedure 010-027 in the Associated Procedures Table.

Charge-air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler as necessary.

Go to 2C

Go to 5A

Guided Step 2C - Check the EGR system for leaks and restrictions.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR system plumbing for leaks and restrictions.

  • Check the EGR crossover tube for leaks and restrictions.
  • Check the EGR differential pressure sensor for leaks at the mounting surface. It could be necessary to remove the EGR differential pressure sensor to check the o-rings for damage.
  • Leaks can be easily noted by traces of soot.

Leaks or restrictions present in the EGR system?
YES NO

Repair or replace the malfunctioning component.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold temperature/pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for restriction.

Guided Step 4A - Check the exhaust system restriction.

Conditions

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Check exhaust system restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO
No Repair

Continue to investigate the cause of the high exhaust restriction. Refer to Procedure 011-009 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check the intake restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications?
YES NO

Continue to troubleshoot the cause of low boost pressure.

  • Reference the Intake Manifold Pressure (Boost) is Below Normal troubleshooting symptom tree in Section TS in the appropriate service manual.

Repair or replace the restricted component.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jun-2013


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX CM2250 GX CM2250 | 4022250
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB6.7 CM2250 | 4022254
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX CM2250 GX CM2250 | 4022250
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2250 | 4022256
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 | 4022255
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 EC | 2883621
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2250 ECF | 2883557
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 | 4310664
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2250 | 4022254
Camshaft Position Sensor | Refer to Procedure 019-363 | ISC8.3 and ISL9 CM2250 | 4022257
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX CM2250 GX CM2250 | 4022250
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12/ISX11.9 CM2250 | 2883445
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2250 | 4022256
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 | 4022255
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 EC | 2883621
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX11.9 CM2250 ECF | 2883561
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2250 ECF | 2883557
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 ECF | 4310661
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 | 4310664
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2250 | 4022254
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 | 4022256
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 | 4022255
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 EC | 2883621
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2250 ECF | 2883557
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 | 4310664

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 2 supply and return. |
 | STEP 2A. Inspect the camshaft position sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the intake manifold pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the crankcase pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the turbocharger compressor intake pressure/temperature sensor and circuit connected to the sensor number 2 supply and return, if equipped. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the engine oil pressure sensor and circuit connected to the sensor number 2 supply and return, if equipped. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
 | STEP 2F. Inspect the barometric pressure sensor and circuit connected to the sensor number 2 supply and return, if equipped. | Dirty or damaged pins?
 | STEP 2F-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 2 supply and return.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the camshaft position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the intake manifold pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedurres Table.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the turbocharger compressor intake pressure/temperature sensor and circuit connected to the sensor number 2 supply and return (if equipped).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness, if equipped.

If the engine is not equipped with a turbocharger compressor intake pressure/temperature sensor, skip to Step 2E.

Action

Inspect the engine harness, sensor jumper harness, and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

For ISB6.7 CM2250 and ISC8.3 and ISL9 CM2250 engines, replace the turbocharger compressor intake pressure/temperature sensor.

Refer to Procedure 019-466 in the Associated Procedures Table.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Guided Step 2D-2 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the turbocharger compressor intake pressure/temperature sensor jumper harness from the engine harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

  • For ISB6.7 CM2250 and ISC8.3 and ISL9 CM2250engines, replace the turbocharger compressor intake pressure/temperature sensor jumper harness.
  • Refer to Procedure 019-466 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the engine oil pressure sensor and circuit connected to the sensor number 2 supply and return (if equipped).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness, if equipped.

If the engine is not equipped with an oil pressure sensor, skip to step 2F

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Inspect the barometric pressure sensor and circuit connected to the sensor number 2 supply and return, if equipped).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness, if equipped.

If engine is not equipped with a barometric pressure sensor, skip to step 3A.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2F-1

Guided Step 2F-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

For ISX12/ISX11.9 CM2250 and ISX15 CM2250 engines, replace the barometric air pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jan-2017


FAULT CODE 195 - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISB6.7 CM2250 | 4022254
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISC8.3 AND ISL9 CM2250 | 4022257
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISX15 CM2250 | 4022250
Engine Coolant Level Sensor | Refer to Procedure 019-017 | GX CM2250 | 4022250
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISX11.9 CM2250 | 2883445
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2250 | 4022256
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2250 | 4022255
ECM Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2250 | 4022254
ECM Calibration Code | Refer to Procedure 019-032 | ISC8.3 AND ISL9 CM2250 | 4022257
ECM Calibration Code | Refer to Procedure 019-032 | ISX15 CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | ISX11.9 CM2250 | 2883445
ECM Calibration Code | Refer to Procedure 019-032 | QSL9 CM2250 | 4022256
ECM Calibration Code | Refer to Procedure 019-032 | QSB6.7 CM2250 | 4022255

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 1695

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Dec-2010


FAULT CODE 196 - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISB6.7 CM2250 | 4022254
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISX15 CM2250 | 4022250
Engine Coolant Level Sensor | Refer to Procedure 019-017 | GX CM2250 | 4022250
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISX11.9 CM2250 | 2883445
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2250 | 4022256
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2250 | 4022255
ECM Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2250 | 4022254
ECM Calibration Code | Refer to Procedure 019-032 | ISC8.3 and ISL9 CM2250 | 4022257
ECM Calibration Code | Refer to Procedure 019-032 | ISX15 CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | ISX11.9 CM2250 | 2883445
ECM Calibration Code | Refer to Procedure 019-032 | QSL9 CM2250 | 4022256
ECM Calibration Code | Refer to Procedure 019-032 | QSB6.7 CM2250 | 4022255

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 1696

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

Use circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Dec-2010


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | Marine QSB6.7 CM2250 | 4310611
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 ECF | 4310661
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 | 4310664
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 EC | 2883647
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 EC | 2883647
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 B137 | 5411058
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2250 B131 | 4388774

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

See the Coolant Loss symptom troubleshooting tree.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-May-2016


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX CM2250 GX CM2250 | 4022250
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75-VDC and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 227.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75-VDC and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-May-2012


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX CM2250 GX CM2250 | 4022250
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX12/ISX11.9 CM2250 | 2883445
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric air pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric air pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75-VDC and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric air pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric air pressure +5 volt SUPPLY pin to the barometric air pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the barometric air pressure +5 volt SUPPLY pin and the barometric air pressure SIGNAL pin at the barometric air pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric air pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric air pressure +5 volt SUPPLY pin to the barometric air pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the barometric air pressure +5 volt SUPPLY pin and the barometric air pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jul-2012


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Check ECM calibration and clear fault codes.. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 2 line.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 1A

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-May-2016


FAULT CODE 295 - Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX CM2250 GX CM2250 | 4022250
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX12/ISX11.9 CM2250 | 2883445
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSL9 CM2250 | 4022256
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possiblity of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 221 and Fault Code 222. | Fault Code 221 or Fault Code 222 active?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active?
 | STEP 2C. Check the circuit response. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 222 active?
 | STEP 3C. Check the circuit response. | Fault Code 221 active?
STEP 4. | Verify the repair. |
 | STEP 4A. Verify the repair. | INSITE™ reading within 102 mm-Hg [4 in-Hg] of local barometric pressure?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 221 and Fault Code 222.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 or Fault Code 222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the barometric pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

An in-range malfunction of the barometric pressure sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Verify the repair.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start INSITE™ electronic service tool Data Monitor/Logger.
  • Compare INSITE™ electronic service tool reading for barometric air pressure to the local barometric pressure. Refer to Procedure 018-028 in Section V.

INSITE™ reading within 102 mm-Hg [4 in-Hg] of local barometric pressure?
YES | NO
No Repair | No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 31-May-2012


FAULT CODE 346 - Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 346 is active?
STEP 2. | Check the adjustable parameter settings. |
 | STEP 2A. Check for correct adjustable parameter settings. | Are both accelerator interlock and powertrain protection torque limit switch features enabled, and are both the accelerator interlock switch and powertrain protection torque limit switch features disabled in the SAE J1939 multiplexing feature?
 | STEP 2B. Check for correct adjustable parameter settings. | Are both engine air shutoff valve and idle shutdown accessory relay features enabled?
 | STEP 2C. Check for correct adjustable parameter settings. | Are both switched maximum engine operating speed switch and governor type switch features enabled?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 346 is active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the adjustable parameter settings.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for accelerator interlock switch and powertrain protection torque limit switch.

Are both accelerator interlock and powertrain protection torque limit switch features enabled, and are both the accelerator interlock switch and powertrain protection torque limit switch features disabled in the SAE J1939 multiplexing feature?

YES NO

Disable either the accelerator interlock switch or the powertrain protection torque limit switch features, use INSITE™ electronic service tool.

Configuring either the accelerator interlock switch or the powertrain protection torque limit switch to be multiplexed using the SAE J1939 data link will also clear the fault code.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for clutch pedal position switch and engine protection shutdown manual override switch.

Are both engine air shutoff valve and idle shutdown accessory relay features enabled?
YES NO

Disable either the engine air shutoff valve or the idle shutdown accessory relay features, use INSITE™ electronic service tool.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for switched maximum engine operating speed switch and governor type switch.

Are both switched maximum engine operating speed switch and governor type switch features enabled?
YES NO

Disable either the switched maximum engine operating speed switch or the governor type switch features, use INSITE™ electronic service tool.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2012


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISX15 CM2250 | 4022250
Electronic Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Electronic Control Module (ECM) | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 | 4022256
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 | 4022255
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 | 4310664
Aftertreatment Fuel Pressure Sensor | Refer to Procedure 019-444 | ISX15 CM2250 | 4022250
Aftertreatment Fuel Pressure Sensor | Refer to Procedure 019-444 | GX CM2250 | 4022250
Aftertreatment Fuel Pressure Sensor | Refer to Procedure 019-444 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Pressure Sensor | Refer to Procedure 019-444 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Pressure Sensor | Refer to Procedure 019-444 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Pressure Sensor | Refer to Procedure 019-444 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Pressure Sensor | Refer to Procedure 019-444 | PowerGen QSX15 CM2250 | 4310664
EGR Orifice Pressure Sensor | Refer to Procedure 019-461 | ISX15 CM2250 | 4022250
EGR Orifice Pressure Sensor | Refer to Procedure 019-461 | ISX12/ISX11.9 CM2250 | 2883445
EGR Orifice Pressure Sensor | Refer to Procedure 019-461 | QSX11.9 CM2250 ECF | 2883561
EGR Orifice Pressure Sensor | Refer to Procedure 019-461 | QSX15 CM2250 ECF | 2883557
EGR Orifice Pressure Sensor | Refer to Procedure 019-461 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Orifice Pressure Sensor | Refer to Procedure 019-461 | PowerGen QSX15 CM2250 | 4310664

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the EGR differential pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the exhaust gas pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the EGR valve position sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the EGR orifice pressure sensor and circuit connected to the sensor number 1 supply and return (if equipped). | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Check the aftertreatment fuel pressure sensor and circuit connected to the sensor number 1 supply and return (if equipped). | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the EGR differential pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the EGR differential pressure sensor.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the exhaust gas pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and the exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the exhaust gas pressure sensor.

Refer to Procedure 019-376 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the EGR valve position sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.

Action

Inspect the engine harness and EGR valve position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the EGR valve position sensor.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the EGR orifice pressure sensor and circuit connected to the sensor number 1 supply and return (if equipped).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR orifice pressure sensor from the engine harness (if equipped).
  • If engine is not equipped with an EGR orifice pressure sensor, skip to Step 2E.

Action

Inspect the engine harness and EGR orifice pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR orifice pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the EGR orifice pressure sensor.

Refer to Procedure 019-461 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the aftertreatment fuel pressure sensor and circuit connected to the sensor number 1 supply and return (if equipped).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel pressure sensor from the engine harness (if equipped).
  • If engine is not equipped with an aftertreatment fuel pressure sensor, skip to Step 3A.

Action

Inspect the engine harness and aftertreatment fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the aftertreatment fuel pressure sensor.

Refer to Procedure 019-444 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Sep-2015


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?

YES NO

Relace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 1 wire.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Jun-2016


FAULT CODE 435 (Sensor) - Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISC and ISL CM2250 | 4022257
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISC and ISL CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSL15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISC and ISL CM2250 | 4022257
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX CM2250 GX CM2250 | 4022250
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2250 | 4022256
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2250 ECF | 2883557
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 | 4022255
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 M CM2250 L106 | 4358343

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 135 and Fault Code 141. | Fault Code 135 and Fault Code 141 active?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active?
 | STEP 2C. Check the circuit response. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 141 active?
 | STEP 3C. Check the circuit response. | Fault Code 135 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the repair. | INSITE™ electronic service tool reading for Engine Oil Pressure is 0 kPa [0 psi]?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 135 and Fault Code 141.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 and Fault Code 141 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil pressure +5 volt SUPPLY pin and the engine oil pressure SIGNAL pin at the engine oil pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

An in-range malfunction of the oil pressure sensor has been detected.

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the engine oil pressure +5 volt SUPPLY pin and the engine oil pressure SIGNAL pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 135 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Monitor the INSITE™ electronic service tool Data Monitor/Logger for engine oil pressure.

INSITE™ electronic service tool reading for Engine Oil Pressure is 0 kPa [0 psi]?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 595 - Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2250 | 4022254
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 | 4022255
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 EC | 2883621
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL9 CM2350 L101 | 4310787
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2250 | 4022256
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX12 CM2350 X102 | 4310646
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX15 CM2350 X101 | 4310641
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX15 CM2250 ECF | 2883557
Turbocharger Speed Sensor | Refer to Procedure 019-390 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Speed Sensor | Refer to Procedure 019-390 | PowerGen QSX15 CM2250 | 4310664
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL9 CM2350 L111 | 4367223

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Codes 122, 123, 221, or 222 active?
STEP 2. | Check for an intermittent fault condition. |
 | STEP 2A. Turn engine keyswitch ON and confirm that the turbocharger speed fault becomes active. | Fault Code 595 become active during engine keyswitch ON?
 | STEP 2B. Operate the engine and confirm that the turbocharger speed fault comes active. | Fault Code 595 become active during engine keyswitch ON?
STEP 3. | Check for a damaged turbocharger speed sensor. |
 | STEP 3A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 3B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
 | STEP 3C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the turbocharger speed sensor circuit continuity. | Within 10 ohms of sensor resistance?
 | STEP 4C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 5. | Check the ECM. |
 | STEP 5A. Connect all components and determine if the fault code reoccurs. | Fault Code 595 come active during engine operation?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool, to read the fault codes.

Fault Codes 122, 123, 221, or 222 active?
YES | NO
No Repair | No Repair

Appropriate fault code trouble shooting tree.

Go to 2A

Guided Step 2 - Check for an intermittent fault condition.

Guided Step 2A - Turn engine keyswitch ON and confirm that the turbocharger speed fault becomes active.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear the inactive fault codes.

Action

Start the engine.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 595 become active during engine keyswitch ON?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

An intermittent fault condition exists.

Go to 2B

Guided Step 2B - Operate the engine and confirm that the turbocharger speed fault comes active.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear the inactive fault codes.

Action

Start the engine.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle.
  • Use INSITE™ electronic service tool to read the fault codes.

This step is valid even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Fault Code 595 come active during engine operation?
YES NO
No Repair

An intermittent fault code condition exists.

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check for a damaged turbocharger speed sensor.

Guided Step 3A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510. Replace the engine harness.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor is damaged.

Replace the turbocharger speed sensor.

  • Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch ON.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor.

  • Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance form the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the turbocharger speed SIGNAL (-) pin of the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

The resistance of the turbocharger speed sensor circuit resistance should be no more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 3B.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector.

  • Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance form the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except turbocharger speed SIGNAL (-) pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Inspect the engine harness for a short between two pins.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM.

Guided Step 5A - Connect all components and determine if the fault code occurs again.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Start the engine.

Action

Operate the engine at idle.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle speed.
  • Use INSITE™ electronic service tool to read the fault codes.

This step applies even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Fault Code 595 come active during engine operation?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The faulty condition was repaired when the components were reconnected.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-May-2016


FAULT CODE 629 - Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Charge-Air Cooler | Refer to Procedure 010-027 | ISX12/ISX11.9 CM2250 | 2883445
Charge-Air Cooler | Refer to Procedure 010-027 | ISX12 CM2350 X102 | 4310646
Charge-Air Cooler | Refer to Procedure 010-027 | ISX15 CM2250 GX CM2250 | 4022250
Charge-Air Cooler | Refer to Procedure 010-027 | ISX15 CM2350 X101 | 4310641
Air Intake Restriction | Refer to Procedure 010-031 | ISX12/ISX11.9 CM2250 | 2883445
Air Intake Restriction | Refer to Procedure 010-031 | ISX12 CM2350 X102 | 4310646
Air Intake Restriction | Refer to Procedure 010-031 | ISX15 CM2250 | 4022250
Air Intake Restriction | Refer to Procedure 010-031 | ISX15 CM2350 X101 | 4310641
Turbocharger | Refer to Procedure 010-033 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger | Refer to Procedure 010-033 | ISX12 CM2350 X102 | 4310646
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2350 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 CM2350 X102 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2350 X101 | 4310641

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 629 active?
STEP 2. | Check the crankcase ventilation system. |
 | STEP 2A. Check for crankcase pressure sensor faults. | Fault Code 555 or 556 active or inactive?
 | STEP 2B. Check the crankcase breather system components. | Are any restrictions found?
STEP 3. | Check the intake system. |
 | STEP 3A. Check for intake manifold pressure sensor faults. | Fault Code 125 active or inactive?
 | STEP 3B. Check the intake manifold pressure sensor. | INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
 | STEP 3C. Check the condition of the air intake filter. | Excessive restriction found?
 | STEP 3D. Check the air intake plumbing up to the compressor inlet for restriction. | Excessive restriction found?
STEP 4. | Check for oil in the compressor discharge pipe. |
 | STEP 4A. Remove the compressor discharge pipe for inspection. | Oil residue in the discharge pipe?
 | STEP 4B. Check for oil in the discharge pipe. | Fresh oil in the discharge pipe?
 | STEP 4C. Check for oil in the charge-air cooler. | Oil in the charge-air cooler?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 629 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the crankcase ventilation system.

Guided Step 2A - Check for crankcase pressure sensor faults.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 555 or 556.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 555 or 556 active or inactive?
YES | NO
No Repair | No Repair

Refer to the appropriate troubleshooting tree.

Go to 2B

Guided Step 2B - Check the crankcase breather system components.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankcase breather system.

  • Check for a restriction in the draft tube.
  • Check for a restriction in the tube between the engine and the filter housing.

Are any restrictions found?
YES NO

Remove the restriction.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the intake system.

Guided Step 3A - Check for intake manifold pressure sensor faults.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 125.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 125 active or inactive?
YES | NO
No Repair | No Repair

Fault Code 125 Troubleshooting Tree

Go to 3B

Guided Step 3B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold temperature/pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check the condition of the air intake filter.

Conditions

  • Turn keyswitch ON.
  • Connect all sensors.

Action

Check the condition of the air intake filter.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Excessive restriction found?
YES NO

Replace the air intake filter.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check the air intake plumbing up to the compressor inlet for restriction.

Conditions

  • Turn keyswitch OFF.

Action

Check the intake plumbing for restriction.

  • Remove and inspect each component from the atmosphere to the air filter for restriction.

Excessive restriction found?
YES NO

Remove the restriction.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check for oil in the compressor discharge pipe.

Guided Step 4A - Remove the compressor discharge pipe for inspection.

Conditions

  • Assemble all components.

Action

Remove the compressor discharge pipe for inspection.

  • Operate the engine for 5 minutes at 1000 rpm.
  • Remove the discharge pipe from the compressor.
  • Inspect the discharge pipe for oil.

Oil residue in the discharge pipe?
YES NO

Clean the compressor outlet and discharge pipe.

Assemble the discharge pipe and repeat Step 4A.

 No Repair

Go to 4A

Go to 4B

Guided Step 4B - Check for oil in the discharge pipe.

Conditions

  • Assemble all components.

Action

Check for oil in the discharge pipe.

  • Start the engine and allow it to idle at 600 rpm for 5 minutes.
  • Remove the discharge pipe and check for oil.

Fresh oil in the discharge pipe?
YES NO

If fresh oil is present after the cleaning cycles, replace the turbocharger.

Refer to Procedure 010-033 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for oil in the charge-air cooler.

Conditions

  • Turn keyswitch OFF.

Action

Check for oil in the charge-air cooler.

  • Refer to Procedure 010-027 in the Associated Procedures Table.

Oil in the charge-air cooler?
YES NO

Clean and inspect the charge-air cooler.

  • Refer to Procedure 010-027 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Apr-2015


FAULT CODE 731 - Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Camshaft | Refer to Procedure 001-008 | QSB3.3 CM2250 EC | 2883647
Camshaft | Refer to Procedure 001-008 | ISB6.7 CM2250 | 4022254
Camshaft | Refer to Procedure 001-008 | QSB6.7 CM2250 | 4022255
Camshaft | Refer to Procedure 001-008 | QSB6.7 CM2250 EC | 2883621
Camshaft | Refer to Procedure 001-008 | ISB6.7 CM2350 B101 | 2883567
Camshaft | Refer to Procedure 001-008 | Marine QSB6.7 CM2250 | 4310611
Camshaft | Refer to Procedure 001-008 | ISC8.3 and ISL9 CM2250 | 4022257
Camshaft | Refer to Procedure 001-008 | QSL9 CM2250 | 4022256
Camshaft | Refer to Procedure 001-008 | ISL9 CM2350 L101 | 4310787
Camshaft | Refer to Procedure 001-008 | QSX11.9 CM2250 ECF | 2883561
Camshaft | Refer to Procedure 001-008 | ISX12/ISX11.9 CM2250 | 2883445
Camshaft | Refer to Procedure 001-008 | ISX12 CM2350 X102 | 4310646
Camshaft | Refer to Procedure 001-008 | QSL9 M CM2250 L106 | 4358343
Camshaft | Refer to Procedure 001-008 | ISX12 G CM2180 EJ | 4310682
Camshaft | Refer to Procedure 001-008 | QSB4.5 CM2250 B131 | 4388774
Camshaft | Refer to Procedure 001-008 | QSB3.3 CM2250 B137 | 5411058
Crankshaft | Refer to Procedure 001-016 | QSB3.3 CM2250 EC | 2883647
Crankshaft | Refer to Procedure 001-016 | ISB6.7 CM2250 | 4022254
Crankshaft | Refer to Procedure 001-016 | ISB6.7 CM2350 B101 | 2883567
Crankshaft | Refer to Procedure 001-016 | QSB6.7 CM2250 EC | 2883621
Crankshaft | Refer to Procedure 001-016 | QSB6.7 CM2250 | 4022255
Crankshaft | Refer to Procedure 001-016 | Marine QSB6.7 CM2250 | 4310611
Crankshaft | Refer to Procedure 001-016 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft | Refer to Procedure 001-016 | ISL9 CM2350 L101 | 4310787
Crankshaft | Refer to Procedure 001-016 | QSL9 CM2250 | 4022256
Crankshaft | Refer to Procedure 001-016 | QSX11.9 CM2250 ECF | 2883561
Crankshaft | Refer to Procedure 001-016 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft | Refer to Procedure 001-016 | ISX12 CM2350 X102 | 4310646
Crankshaft | Refer to Procedure 001-016 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft | Refer to Procedure 001-016 | QSX15 CM2250 ECF | 2883557
Crankshaft | Refer to Procedure 001-016 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft | Refer to Procedure 001-016 | PowerGen QSX15 CM2250 | 4310664
Crankshaft | Refer to Procedure 001-016 | ISX15 CM2350 X101 | 4310641
Crankshaft | Refer to Procedure 001-016 | Westport HD CM2250 | 3666239
Crankshaft | Refer to Procedure 001-016 | QSL9 M CM2250 | 4358343
Crankshaft | Refer to Procedure 001-016 | ISX12 G CM2180 EJ | 4310682
Crankshaft | Refer to Procedure 001-016 | QSB4.5 CM2250 B131 | 4388774
Crankshaft | Refer to Procedure 001-016 | QSB3.3 CM2250 B137 | 5411058
Vibration Damper, Viscous | Refer to Procedure 001-052 | ISB6.7 CM2250 | 4022254
Vibration Damper, Viscous | Refer to Procedure 001-052 | ISB6.7 CM2350 B101 | 2883567
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSB6.7 CM2250 | 4022255
Vibration Damper, Viscous | Refer to Procedure 001-052 | Marine QSB6.7 CM2250 | 4310611
Vibration Damper, Viscous | Refer to Procedure 001-052 | ISC8.3 and ISL9 CM2250 | 4022257
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSL9 CM2250 | 4022256
Vibration Damper, Viscous | Refer to Procedure 001-052 | ISL9 CM2350 L101 | 4310787
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSX11.9 CM2250 ECF | 2883561
Vibration Damper, Viscous | Refer to Procedure 001-052 | ISX12/ISX11.9 CM2250 | 2883445
Vibration Damper, Viscous | Refer to Procedure 001-052 | ISX12 CM2350 X102 | 4310646
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSX15 CM2250 ECF | 2883557
Vibration Damper, Viscous | Refer to Procedure 001-052 | PowerGen QSX15 CM2250 ECF | 4310661
Vibration Damper, Viscous | Refer to Procedure 001-052 | PowerGen QSX15 CM2250 | 4310664
Vibration Damper, Viscous | Refer to Procedure 001-052 | ISX15 CM2250 GX CM2250 | 4022250
Vibration Damper, Viscous | Refer to Procedure 001-052 | ISX15 CM2350 X101 | 4310641
Vibration Damper, Viscous | Refer to Procedure 001-052 | Westport HD CM2250 | 3666239
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSL9 M CM2250 L106 | 4358343
Vibration Damper, Viscous | Refer to Procedure 001-052 | ISX12 G CM2180 EJ | 4358343
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 EC | 2883647
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2250 | 4022254
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B101 | 2883567
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 | 4022255
Camshaft Position Sensor | Refer to Procedure 019-363 | Marine QSB6.7 CM2250 | 4310611
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 EC | 2883621
Camshaft Position Sensor | Refer to Procedure 019-363 | ISC8.3 and ISL9 CM2250 | 4022257
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2250 | 4022256
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9 CM2350 L101 | 4310787
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX11.9 CM2250 ECF | 2883561
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12/ISX11.9 CM2250 | 2883445
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12 CM2350 X102 | 4310646
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2250 GX CM2250 | 4022250
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2350 X101 | 4310641
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2250 ECF | 2883557
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 ECF | 4310661
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 | 4310664
Camshaft Position Sensor | Refer to Procedure 019-363 | Westport HD CM2250 | 4021560
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 M CM2250 L106 | 4358343
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12 G CM2180 EJ | 4310682
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2250 B131 | 4388774
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | Marine QSB6.7 CM2250 | 4310611
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | Westport HD CM2250 | 4021560
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 G CM2180 EJ | 4310682
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 731 active only?
STEP 2. | Inspect the tone wheels and speed/position sensors. |
 | STEP 2A. Inspect the engine speed and position sensors for damage. | Any damage?
 | STEP 2B. Inspect the tone wheels for any damage. | Any damage?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Check for correct engine static timing. |
 | STEP 4A. Check static timing. | Engine timed correctly?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active only?

YES NO
No Repair

Troubleshoot any other active fault codes before continuing with this tree.

Go to 2A

Appropriate fault code troubleshooting tree.

Guided Step 2 - Inspect the tone wheels and speed/position sensors.

Guided Step 2A - Inspect the engine speed and position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine speed and position sensors for damage.

Any damage?
YES NO

Replace the speed or position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Refer to Procedure 019-365 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft and camshaft tone wheels for damage.

  • Make sure the component having engine timing marks (typically the vibration damper or pulley) is correctly aligned with the crankshaft by verifying it is properly installed on the dowel or index pin that orients it.
  • Refer to Procedure 001-052 in the Associated Procedures Table.
  • Use the following procedure for ISX engines, remove the oil pan and check by hand for a loose crankshaft tone wheel or damaged teeth.

Any damage?
YES NO

Replace the tone wheel.

Use the following procedure for crankshaft removal and installation. Refer to Procedure 001-016 in the Associated Procedures Table.

Use the following procedure for camshaft removal and installation. Refer to Procedure 001-008 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine block, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

All grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 4A

Guided Step 4 - Check the static timing.

Guided Step 4A - Check static timing.

Conditions

  • Remove the gear cover.

Action

Inspect the timing.

N/A

Engine timed correctly?
YES NO
No Repair

Properly time the engine.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Crankshaft gear slippage can be caused by excessive hydraulic loads on the gear train. Check and correct any excessive hydraulic loading condition on the vehicle.

Replace the crankshaft assembly if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-May-2016


FAULT CODE 1691 (ISX) - Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX15 CM225050 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX15 CM2250 ECF | 2883557

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1691 active?
 | STEP 1B. Read the fault codes. | Fault codes related to the aftertreatment diesel oxidation catalyst temperature sensors or aftertreatment diesel particulate filter temperature sensors active?
 | STEP 1C. Read the fault codes. | Fault Code 3167 active?
STEP 2. | Check the exhaust system for leaks. |
 | STEP 2A. Check the exhaust between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks are found?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Monitor the aftertreatment exhaust gas temperature sensors. | Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C [75°F]?
 | STEP 3B. Inspect th eaftertreatment diesel oxidation catalyst. | Any problems found during the inspection of the aftertreatment diesel oxidation catalyst?
 | STEP 3C. Inspect the turbocharger exhaust outlet for oil, coolant, or fuel. | Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check the aftertreatment fuel injector. |
 | STEP 4A. Check the operation of the aftertreatment fuel injector, if equipped. | Fuel leaking from the aftertreatment fuel injector during the aftertreatment fuel injector leak test?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1691 active?

YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step -

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes related to the aftertreatment diesel oxidation catalyst temperature sensors or aftertreatment diesel particulate filter temperature sensors active?

YES | NO
No Repair | No Repair

Refer to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step -

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3167 active?

YES | NO
No Repair | No Repair

Go to Fault Code 3167 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust system for leaks.

Guided Step 2A - Check the exhaust between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust for leaks.

Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks are found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine idling greater than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool, while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C[75°F]?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness.

  • Check for a short circuit in the aftertreatment diesel particulate filter temperature sensor interface module. Refer to Procedure 019-462 in the Associated Procedures Table.
  • If no short is found replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3B

Guided Step 3B - Inspect the aftertreatment diesel oxidation catalyst.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst from the vehicle. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst..

  • Inspect the aftertreatment diesel oxidation catalyst for plugging from soot or oil contamination.
  • Inspect the aftertreatment diesel oxidation catalyst for cracks or damage of any cells in the catalyst.
  • Inspect the aftertreatment diesel oxidation catalyst for soot plugging the front face of the catalyst.

Refer to Procedure 011-049 in the Associated Procedures Table.

Any problems found during the inspection of the aftertreatment diesel oxidation catalyst?
YES NO

Repair or replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Continue to troubleshoot the system to determine the root cause of the problem.

 No Repair

Go to 3C

Go to 3C

Guided Step 3C - Inspect the turbocharger exhaust outlet for oil, coolant, or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil, coolant, or fuel being introduced into the aftertreatment system from the engine.
  • Look for signs of moisture in the turbocharger exhaust outlet.

Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel, coolant, or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the aftertreatment fuel injector.

Guided Step 4A - Check the operation of the aftertreatment fuel injector, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • If the engine is not equipped with an aftertreatment fuel injector skip to Guided Step 5.

Action

Check the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the aftertreatment fuel injector leak test.
  • Check for fuel leaking from the aftertreatment injector when the aftertreatment fuel shutoff valve is open.

Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel leaking from the aftertreatment fuel injector during the aftertreatment fuel injector leak test?
YES NO

  • Replace the aftertreatment fuel injector. Refer to Procedure 011-054 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2015


FAULT CODE 1695 - Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and QSL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1695 inactive?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ECM battery (+) in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for active or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Disconnect the fan speed sensor from the OEM harness.
  • Disconnect the engine coolant level sensor from the OEM harness, if equipped.
  • Disconnect the remote accelerator position sensor from the OEM harness, if equipped.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor supply 5 pin at the OEM harness ECM connector to all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ECM battery (+) in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Disconnect the fan speed sensor from the OEM harness.
  • Disconnect the engine coolant level sensor from the OEM harness, if equipped.
  • Disconnect the remote accelerator position sensor from the OEM harness, if equipped.

Action

Check for a short circuit to ECM battery (+).

  • Measure the resistance between the Sensor SUPPLY 5 pin at the OEM harness ECM connector to the ECM battery (+) pins at the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-May-2016


FAULT CODE 1696 - Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISB6.7 CM2250 | 4022254
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISX CM2250 GX CM2250 | 4022250
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2250 | 4022256
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2250 | 4022255
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2250 ECF | 2883557
Engine Coolant Level Sensor | Refer to Procedure 019-017 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Level Sensor | Refer to Procedure 019-017 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control molduel (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1696 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 2A. Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the aftertreatment diesel particulate filter differential pressure sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine coolant level sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the remote accelerator pedal/level position sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the fan speed sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
STEP 3. | Check the ECM and original equipment manfacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the accelerator/lever position sensor.

Refer to the OEM service manual.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the aftertreatment diesel particulate filter differential pressure sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the aftertreatment diesel particulate filter differential pressure sensor.

Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the engine coolant level sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the remote accelerator pedal/level position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the remote accelerator pedal/lever.

Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the fan speed sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan speed sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan speed sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the fan speed sensor.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

Refer to Procedure 019-071 in Section 19.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Disconnect the fan speed sensor from the OEM harness.
  • Disconnect the engine coolant level sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator pedal from the OEM harness (if equipped).

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal 5-VDC SUPPLY and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Disconnect the fan speed sensor from the OEM harness.
  • Disconnect the engine coolant level sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator pedal from the OEM harness (if equipped).

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator 5-VDC SUPPLY pin and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2012


FAULT CODE 1867 - Exhaust Gas Recirculation Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 B101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2250 | 4022254
EGR Temperature Sensor | Refer to Procedure 019-378 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX CM2250 GX CM2250 | 4022250
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12/ISX11.9 CM2250 | 2883445
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B101 | 2883567
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L101 | 4310787
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12 CM2350 X102 | 4310646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2350 X101 | 4310641

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 2375 and 2376. | Fault Code 2375 or 2376 active?
STEP 2. | Check the exhaust gas recirculation temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas recirculation temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2375 active?
 | STEP 2C. Check the circuit response. | Fault Code 2376 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2375 active?
 | STEP 3C. Check the circuit response. | Fault Code 2376 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 2375 and 2376.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 or 2376 active?
YES | NO
No Repair | No Repair

Fault Code 2375 or 2376 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas recirculation temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas recirculation temperature sensor and connector pins.

Action

Inspect the engine harness and exhaust gas recirculation temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas recirculation temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine harness and exhaust gas recirculation temperature sensor connector pins for the following:

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 2375 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas recirculation temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the exhaust gas recirculation temperature signal pin and the exhaust gas recirculation temperature return pin at the exhaust gas recirculation temperature connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 active?
YES NO

Replace the exhaust gas recirculation temperature sensor.

Refer to Procedure 019-378 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas recirculation temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the exhaust gas recirculation temperature SIGNAL pin and exhaust gas recirculation temperature RETURN pin at the ECM engine connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 2376 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Apr-2015


FAULT CODE 1898 - VGT Actuator Controller - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 ECF | 4310661
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 ECF | 2883557
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Aftertreatment System | Refer to Procedure 011-050 | ISB6.7 CM2250 | 4022254
Aftertreatment System | Refer to Procedure 011-050 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment System | Refer to Procedure 011-050 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment System | Refer to Procedure 011-050 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment System | Refer to Procedure 011-050 | QSL9 CM2250 | 4022256
Aftertreatment System | Refer to Procedure 011-050 | QSB6.7 CM2250 | 4022255
Aftertreatment System | Refer to Procedure 011-050 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment System | Refer to Procedure 011-050 | QSX15 CM2250 ECF | 2883557
Aftertreatment System | Refer to Procedure 011-050 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1898 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1938 or 2636 active?
 | STEP 1C. Check for active fault codes. | Fault Code 2387 active or high inactive counts?
STEP 2. | Check the variable geometry turbocharger actuator. |
 | STEP 2A. Inspect the variable geometry turbocharger actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear is broken or damaged on the variable geometry turbocharger actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Use the sector gear gauge. Nozzle movement meet the requirements according to Procedure 010-134?
 | STEP 2D. Check the variable geometry turbocharger output gear for correct calibration. | Variable geometry turbocharger actuator gear move when connected to the engine wiring harness?
 | STEP 2D-1. Check the variable geometry turbocharger output gear for manual rotation by hand. |
 | STEP 2E. Check for active Fault Code 1998. | Fault Code 1898 active?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 1898.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Cycle the keyswitch several times, waiting 30 seconds between each key cycle, to see if Fault Code 1898 becomes active.

Fault Code 1898 active?
YES NO
No Repair

No troubleshooting is necessary unless Fault Code 1898 is active. Clear the inactive fault code.

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1938 or 2636 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting procedure

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting steps.

Go to 2A

Guided Step 2 - Check the variable geometry turbocharger actuator.

Guided Step 2A - Inspect the variable geometry turbocharger actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine harness.

Action

Inspect the engine harness and variable geometry turbocharger actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the variable geometry turbocharger actuator hardware.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the variable geometry turbocharger actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect the variable geometry turbocharger actuator.

Check for a broken drive gear on the variable geometry turbocharger actuator.

Gear is broken or damaged on the variable geometry turbocharger actuator?
YES NO

A damaged gear has been detected on the variable geometry turbocharger actuator.

Replace the variable geometry turbocharger actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Variable geometry turbocharger actuator removed from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger housing up and down from stop to stop. Check for smooth movement between the stops.

Note: It may take considerable force to move the sector gear. If it can be moved by hand, this is considered acceptable. Do not use any hand tools.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Use the sector gear gauge. Nozzle movement meet the requirements according to Procedure 010-134?
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Replace the turbocharger.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the variable geometry turbocharger output gear for correct calibration.

Conditions

  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.
  • Turn keyswitch ON.

Action

Check the variable geometry turbocharger actuator output gear operation.

  • Connect the variable geometry turbocharger actuator to the engine wiring harness. The variable geometry turbocharger actuator gear must rotate.

Note: The variable geometry turbocharger actuator output gear will exhibit one of the following movements, depending on the ECM calibration. Make sure to closely observe the variable geometry turbocharger actuator gear when the variable geometry turbocharger actuator is connected to the engine wiring harness.

  • The actuator output gear can possibly rotate completely in one direction and then rotate completely in the opposite direction, OR
  • The actuator output gear may only move a few degrees in one direction. This movement will be a quick snap when the variable geometry turbocharger actuator is connected to the engine wiring harness.
  • If the variable geometry turbocharger actuator gear does not move, disconnect the variable geometry turbocharger actuator from the engine wiring harness for 1 second and then reconnect.
  • Repeat the above procedure three times, checking for variable geometry turbocharger actuator gear movement each time the variable geometry turbocharger actuator is connected to the engine wiring harness.

Does the variable geometry turbocharger actuator gear move when connected to the engine wiring harness?
YES NO

Install the variable geometry turbocharger actuator back on the turbocharger. Make sure to perform the variable geometry turbocharger actuator install and calibrate procedures.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check the variable geometry turbocharger output gear for manual rotation by hand.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

Turn the variable geometry turbocharger actuator output gear by hand.

  • Try turning the variable geometry turbocharger actuator output gear by hand in either direction.

Note: Do NOT use pliers or any other tool to turn the gear. ONLY rotate the gear by hand.

Can the variable geometry turbocharger actuator output gear be rotated by hand?
YES NO

Install the variable geometry turbocharger actuator on the turbocharger, make sure to perform the actuator install and calibrate procedures.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Replace the variable geometry turbocharger actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for active Fault Code 1898.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active Fault Code 1898.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1898 active?
YES NO

Replace the variable geometry turbocharger actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check aftertreatment system.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Action

Check for damage to the aftertreatment system.

Perform the aftertreatment initial check procedure to test for a malfunctioning diesel particulate filter.

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Progressive damage to the aftertreatment system detected?
YES NO

Replace the damaged aftertreatment system component(s).

  • Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 02-Sep-2015


FAULT CODE 1923 - Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module (ECM) | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™AMP™Metri-Pack™test lead and Part Number 3822917 - female Deutsch™AMP™Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1923 inactive?
STEP 2. | Check the aftertreatment fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the aftertreatment fuel shutoff valve. | 4 to 6 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to battery in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1923 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment fuel shutoff valve and circuit.

Guided Step 2A - Inspect the aftertreatment fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedure Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the aftertreatment fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check the aftertreatment fuel shutoff valve resistance.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY pin and the aftertreatment fuel shutoff valve RETURN pin at the aftertreatment fuel shutoff valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4 to 6 ohms?
YES NO
No Repair

Replace the aftertreatment fuel shutoff valve.

Refer to Procedure 011-052 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to battery in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check for a short circuit to battery.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY pin at the aftertreatment fuel shutoff valve harness connector and BATTERY (+).

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to battery (+) has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment fuel shutoff valve SUPPLY pin and all other pins in the ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2015


FAULT CODE 1924 - Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module (ECM) | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1924 inactive?
STEP 2. | Check the aftertreatment fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the aftertreatment fuel shutoff valve. | 4.0 to 6.0 ohms?
 | STEP 2C. Check for a short circuit to ground in the aftertreatment fuel shutoff valve. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open in the supply circuit. | Greater than 100k ohms?
 | STEP 3C. Check for an open in the return circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1924 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1924 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment fuel shutoff valve and circuit.

Guided Step 2A - Inspect the aftertreatment fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the aftertreatment fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check the aftertreatment fuel shutoff valve resistance.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY pin and the aftertreatment fuel shutoff valve RETURN pin at the aftertreatment fuel shutoff valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4 to 6 ohms?
YES NO
No Repair

Replace the aftertreatment fuel shutoff valve.

Refer to Procedure 011-052 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the aftertreatment fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check for a short circuit to ground in the aftertreatment fuel shutoff valve.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY pin at the shutoff valve and block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the aftertreatment fuel shutoff valve.

Refer to Procedure 011-052 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open in the supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY pin at the aftertreatment fuel shutoff valve harness connector and the aftertreatment fuel shutoff valve SUPPLY pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO

An open circuit has been detected in the aftertreatment fuel shutoff valve SUPPLY circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for an open in the return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment fuel shutoff valve RETURN pin at the aftertreatment fuel shutoff valve harness connector and the aftertreatment fuel shutoff valve RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

An open circuit has been detected in the aftertreatment fuel shutoff valve RETURN circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Asociated Proceudures Table.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY pin at the aftertreatmnet purge air actuator harness connector and block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY pin at the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1924 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Call for authorization to replace the ECM. Upon receipt of authoriation, replace the ECM. Refer to Procedure 019-031 in the Assoicated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2015


FAULT CODE 1981 - Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | IISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1981 active?
 | STEP 1B. Check for active or inactive fault codes. | Fault Code 3375 or 3376 active or inactive?
 | STEP 1C. Check for active fault codes. | Fault Code 1879, 1881, or 1883 active?
STEP 2. | Inspect the aftertreatment diesel particulate filter (DPF) differential pressure sensor. |
 | STEP 2A. Verify the aftertreatment DPF differential pressure sensor accuracy. | Aftertreatment DPF differential pressure sensor signal voltage within specification with the keyswitch ON and the engine OFF?
 | STEP 2B. Check the aftertreatment DPF differential pressure sensor tubes for blockage. | Aftertreatment DPF differential pressure sensor supply tubes blocked?
STEP 3. | Check the aftertreatment temperature sensors. |
 | STEP 3A. Check for active fault codes. | Fault Code 3313, 3314, 3315, 3316, 3317, 3318, 3319, 3321, or 3322 active?
 | STEP 3B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 4. | Check the ash cleaning maintenance interval. |
 | STEP 4A. Check the ash cleaning maintenance interval. | Ash cleaning interval has been followed?
STEP 5. | Check for excessive black smoke. |
 | STEP 5A. Inspect the exhaust for excessive black smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
 | STEP 5B. Check aftertreatment DPF restriction. | Aftertreatment DPF restriction within specifications?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1981 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3375 or 3376 active or inactive?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree for Fault Code 3375 or 3376

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment DPF differential pressure sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, or 1883 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Inspect the aftertreatment DPF differential pressure sensor.

Guided Step 2A - Verify the aftertreatment DPF differential pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy.

  • Monitor the aftertreatment diesel particulate filter differential pressure sensor signal voltage reading with INSITE™ electronic service tool.
  • Refer to Procedure 019-443 from the Associated Procedure Table.

Aftertreatment DPF differential pressure sensor signal voltage within specification with the keyswitch ON and the engine OFF?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn engine OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor supply tubes.

Action

Disconnect the aftertreatment DPF differential pressure sensor supply tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

It is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tube in extreme cold ambient temperatures. Ice can form in the differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Aftertreatment DPF differential pressure sensor supply tubes blocked?
YES NO

Remove and clean the aftertreatment DPF differential pressure sensor supply tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

  • Check for a short circuit from the SIGNAL pin of the aftertreatment DPF differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.
  • If no short circuit is found, replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 3 - Check the aftertreatment temperature sensors.

Guided Step 3A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment temperature sensors.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3313, 3314, 3315, 3316, 3317, 3318, 3319, 3321, or 3322 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 3B

Guided Step 3B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle engine for greater than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the ash cleaning maintenance interval.

Guided Step 4A - Check the ash cleaning maintenance interval.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ash cleaning maintenance interval.

  • Check the ash cleaning maintenance interval of the DPF. It is possible the ash cleaning interval has been ignored and the filter needs to be cleaned.

Reference the Operation and Maintenance manual for the recommended ash cleaning interval.

Ash cleaning interval has been followed?
YES NO

Remove and inspect the aftertreatment DPF.

Refer to Procedure 011-041 in the Associated Procedures Table.

Clean or replace the aftertreatment DPF as necessary.

Remove and inspect the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Clean or replace the aftertreatment DPF as necessary.

Go to 5A

Go to 5A

Guided Step 5 - Check for excessive black smoke.

Guided Step 5A - Inspect the exhaust for excessive black smoke.

Conditions

  • Disconect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform the Snap Acceleration - Aftertreatment Disconnected Test. Refer to Procedure 014-013 in the Associated Procedures Table.

To perform a Snap Acceleration Test, it could be necessary to temporarily adjust the Maximum Engine Speed with No Vehicle Speed Sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of the excessive black smoke.

  • Reference the appropriate engine performance troubleshooting tree.

 No Repair

Go to 5B

Go to 5B

Guided Step 5B - Check the aftertreatment DPF restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the following sections of the Aftertreatment Diesel Particulate Filter Restriction Test.

  • Test.
  • Analyzing the Data.

Refer to Procedure 011-085 in the Associated Procedures Table.

Aftertreatment DPF restriction within specifications?
YES NO
No Repair

Replace the DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

  • Reference the appropriate engine performance troubleshooting tree.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM. Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Nov-2015


FAULT CODE 2182 (Heavy Duty) - Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISX CM2250 GX CM2250 | 4022250
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 ECF | 2883557
Rocker Lever Cover | Refer to Procedure 003-011 | ISX12/ISX11.9 CM2250 | 2883445
Rocker Lever Cover | Refer to Procedure 003-011 | QSX11.9 CM2250 ECF | 2883561
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISX CM2250 GX CM2250 | 4022250
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | QSX15 CM2250 ECF | 2883557
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISX12/ISX11.9 CM2250 | 2883445
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | QSX11.9 CM2250 ECF | 2883561
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | QSL9 CM2250 | 4022256

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™/ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active and/or inactive fault codes. | Fault Code 2182 active or multiple inactive counts?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid and circuit. |
 | STEP 3A. Check for an open circuit in the ECM. | Greater than 100k ohms?
 | STEP 3B. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms (12 volt systems) or resistance between 25 and 55 ohms (24 volt systems)?
 | STEP 3C. Check the engine brake solenoid for an open circuit. | Engine brake number 1 operate?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active and/or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active and/or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2182 active or multiple inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pin
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass-through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine brake wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 1 SUPPLY and RETURN wires from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL wire at the engine brake solenoid and the engine brake solenoid number 1 SIGNAL wire at the ECM connector.
  • Measure the resistance between the engine brake solenoid number 1 RETURN wire at the engine brake solenoid and the engine brake solenoid number 1 RETURN wire at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 1 signal or return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3C

Guided Step 2D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 from the engine brake pass-through connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and ground.
  • Measure the resistance between the engine brake solenoid number 1 RETURN pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine brake actuator SIGNAL or RETURN wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3C

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 from the engine brake pass-through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the engine brake solenoid number 1 RETURN pin in the engine harness ECM connector and ground all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL or RETURN wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from the engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance from engine brake number 1 solenoid SIGNAL terminal pin to ground.
  • Measure the resistance from engine brake number 1 solenoid terminal pin to ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3B

Go to 3C

Guided Step 3B - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance of engine brake number 1 solenoid SUPPLY terminal pin to RETURN terminal pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms (12 volt systems) or resistance between 25 and 55 ohms (24 volt systems)?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2.
  • Turn keyswitch ON.
  • Engine Brake Control feature is enabled.
  • Engine Brake Minimum Vehicle Speed set to 0.
  • Delay time set to 0.
  • Select 100 percent braking with the manual dash switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all Engine Brake Output Circuits and Engine Brake Switch Level with the INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the Engine Brake Output Circuits Engine Brake Switch Level and Fault Codes.
  • Make sure that all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 1 operate?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Refer to Procedure 019-362 in the Associated Procedures Table.

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Oct-2016


FAULT CODE 2183 (Heavy Duty) - Engine Brake Actuator 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISX CM2250 GX CM2250 | 4022250
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 ECF | 2883557
Rocker Lever Cover | Refer to Procedure 003-011 | ISX12/ISX11.9 CM2250 | 2883445
Rocker Lever Cover | Refer to Procedure 003-011 | QSX11.9 CM2250 ECF | 2883561
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISX CM2250 GX CM2250 | 4022250
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | QSX15 CM2250 ECF | 2883557
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISX12/ISX11.9 CM2250 | 2883445
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | QSX11.9 CM2250 ECF | 2883561
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | QSL9 CM2250 | 4022256

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active and/or inactive fault codes. | Fault Code 2183 active or multiple inactive counts?
STEP 2. | Check the ECM and engine brake harness pins. |
 | STEP 2A. Inspect the ECM and engine harness pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid and circuit. |
 | STEP 3A. Check the engine brake solenoid for a short to ground. | Greater than 100k ohms?
 | STEP 3B. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms (12 volt systems) or resistance between 25 and 55 ohms (24 volt systems)?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 1 operate?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2183 active or multiple inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass-through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 1 SUPPLY and RETURN wires from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL wire at the engine brake solenoid and the engine brake solenoid number 1 SIGNAL wire at the ECM connector.
  • Measure the resistance between the engine brake solenoid number 1 RETURN wire at the engine brake solenoid and the engine brake solenoid number 1 RETURN wire at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 1 signal or return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3C

Guided Step 2D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 from the engine brake pass-through connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and ground.
  • Measure the resistance between the engine brake solenoid number 1 RETURN pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine brake actuator SIGNAL or RETURN wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3C

Guided Step 2E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 from the engine brake pass-through connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the engine brake solenoid number 1 RETURN pin in the engine harness ECM connector and ground all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL or RETURN wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance from engine brake number 1 solenoid SIGNAL terminal pin to ground.
  • Measure the resistance from engine brake number 1 solenoid terminal pin to ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine brake solenoid

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3B

Go to 3C

Guided Step 3B - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from the engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance of the engine brake number 1 solenoid SUPPLY terminal pin to RETURN terminal pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms (12 volt systems) or resistance between 25 and 55 ohms (24 volt systems)?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2.
  • Turn keyswitch ON.
  • Enable Engine Brake Control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Delay time set to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Check for a pin-to-ground short.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure that all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 1 operate?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Oct-2016


FAULT CODE 2363 (Heavy Duty) - Engine Brake Actuator Driver 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISX CM2250 GX CM2250 | 4022250
Rocker Lever Cover | Refer to Procedure 003-011 | ISX12/ISX11.9 CM2250 | 2883445
Rocker Lever Cover | Refer to Procedure 003-011 | QSX11.9 CM2250 EFC | 2883561
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 EFC | 2883557
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 EFC | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 EFC | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 EFC | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 EFC | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISX CM2250 GX CM2250 | 4022250
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISX12/ISX11.9 CM2250 | 2883445
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX11.9 CM2250 EFC | 2883561
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX15 CM2250 EFC | 2883557
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 | 4022256
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISX CM2250 GX CM2250 | 4022250
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISX12/ISX11.9 CM2250 | 2883445
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | QSX11.9 CM2250 EFC | 2883561
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | QSX15 CM2250 EFC | 2883557
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | QSL9 CM2250 | 4022256

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2363 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the internal actuator wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid and circuit. |
 | STEP 3A. Check the engine brake solenoid for a short to ground. | Greater than 100k ohms?
 | STEP 3B. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms (12 volt systems) or resistance between 25 and 55 ohms (24 volt systems)?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 1 operate?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2363 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jump harness and pass-through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Remove the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 2 SUPPLY and RETURN wires from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL wire at the engine brake solenoid and the engine brake solenoid number 2 SIGNAL wire at the ECM connector.
  • Measure the resistance between the engine brake solenoid number 2 RETURN wire at the engine brake solenoid and the engine brake solenoid number 2 RETURN wire at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 2 signal or return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3C

Guided Step 2D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass-through connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and ground.
  • Measure the resistance between the engine brake solenoid number 2 RETURN pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine brake actuator SIGNAL or RETURN wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3C

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass-through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the engine brake solenoid number 1 RETURN pin in the engine harness ECM connector and ground all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 2 SIGNAL or RETURN wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance from engine brake number 1 solenoid SIGNAL terminal pin to ground.
  • Measure the resistance from engine brake number 1 solenoid terminal pin to ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3B

Go to 3C

Guided Step 3B - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance of engine brake number 2 solenoid SUPPLY terminal pin to RETURN terminal pin.

Refer to the wiring diagram for pin identification and the following procedure for general multimeter usage techniques.

Refer to Procedure 019-359 in Section 19.

Resistance between 5 and 15 ohms (12 volt systems) or resistance between 25 and 55 ohms (24 volt systems)?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3C

Go to 3C

Guided Step 3C - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2.
  • Turn keyswitch ON.
  • Engine Brake Control feature is enabled.
  • Set engine brake minimum vehicle speed to 0.
  • Delay time set to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure that all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 1 operate?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Oct-2016


FAULT CODE 2367 (Heavy Duty) - Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISX CM2250 GX CM2250 | 4022250
Rocker Lever Cover | Refer to Procedure 003-011 | ISX12/ISX11.9 CM2250 | 2883445
Rocker Lever Cover | Refer to Procedure 003-011 | QSX11.9 CM2250 ECF | 2883561
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 ECF | 2883557
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Brake | Refer to Procedure 020-012 | ISX CM2250 GX CM2250 | 4022250
Engine Brake | Refer to Procedure 020-012 | ISX12/ISX11.9 CM2250 | 2883445
Engine Brake | Refer to Procedure 020-012 | QSX11.9 CM2250 ECF | 2883561
Engine Brake | Refer to Procedure 020-012 | QSX15 CM2250 ECF | 2883557
Engine Brake | Refer to Procedure 020-012 | QSL9 CM2250 | 4022256

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active and/or inactive fault codes. | Fault Code 2367 active or multiple inactive counts?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connector or wire insulation?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid and circuit. |
 | STEP 3A. Check the engine brake solenoid for a short to ground. | Greater than 100k ohms?
 | STEP 3B. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms (12 volt systems) or resistance between 25 and 55 ohms (24 volt systems)?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 1 operate?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active and/or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2367 active or multiple inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the solenoid resistance.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedure Table

No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass-through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness. Refer to Procedures 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 1 SUPPLY and RETURN wires from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL wire at the engine brake solenoid and the engine brake solenoid number 1 SIGNAL wire at the ECM connector.
  • Measure the resistance between the engine brake solenoid number 1 RETURN wire at the engine brake solenoid and the engine brake solenoid number 1 RETURN wire at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open engine brake solenoid number 1 signal or return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedures 019-043 in the Associated Procedures Table.

 No Repair

Go to 2D

Go to 3C

Guided Step 2D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 wire from the engine brake pass-through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the engine brake solenoid number 1 RETURN pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL or RETURN wire has been detected in the engine.

Troubleshoot the engine harness, internal actuator harness, and rocker lever housing pass-through connector for a pin-to-pin short.

Repair or replace the malfunctioning component.

 No Repair

Go to 2E

Go to 3C

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 wire from the engine brake pass-through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the engine brake solenoid number 1 RETURN pin in the engine harness ECM connector and ground all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL or RETURN wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Inspect the engine harness and ECM pins for the following:

  • Measure the resistance from engine brake number 1 solenoid SIGNAL terminal pin to ground.
  • Measure the resistance from engine brake number 1 solenoid terminal pin to ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3B

Go to 3C

Guided Step 3B - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance of engine brake number 1 solenoid SUPPLY terminal pin to RETURN terminal pin.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance between 5 and 15 ohms (12 volt systems) or resistance between 25 and 55 ohms (24 volt systems)?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2.
  • Turn keyswitch ON.
  • Engine Brake Control feature is enabled.
  • Engine Brake Minimum Vehicle Speed set to 0.
  • Delay time set to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all Engine Brake Output Circuits and Engine Brake Switch Level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the Engine Brake Output Circuits Engine Brake Switch Level and Fault Codes.
  • Make sure that all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 1 operate?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Feature and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Oct-2016


FAULT CODE 2387 - Variable Geometry Turbocharger Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 ECF | 4310661
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 | 4310664
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2250 | 4022254
Turbocharger | Refer to Procedure 010-033 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger | Refer to Procedure 010-033 | ISX CM2250 GX CM2250 | 4022250
Turbocharger | Refer to Procedure 010-033 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2250 | 4022256
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 | 4022255
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 EC | 2883621
Turbocharger | Refer to Procedure 010-033 | QSX11.9 CM2250 ECF | 2883561
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 ECF | 2883557
Turbocharger | Refer to Procedure 010-033 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger | Refer to Procedure 010-033 | PowerGen QSX15 CM2250 | 4310664
Turbocharger | Refer to Procedure 010-033 | ISB4.5 CM2350 B104 | 4332646
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2350 B103 | 4332641
Turbocharger | Refer to Procedure 010-033 | ISL9 CM2350 L111 | 4367223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 ECF | 2883557
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB4.5 CM2350 B104 | 4332646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B103 | 4332641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L111 | 4367223
Exhaust Restriction | Refer to Procedure 011-009 | ISB6.7 CM2250 | 4022254
Exhaust Restriction | Refer to Procedure 011-009 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Restriction | Refer to Procedure 011-009 | ISX CM2250 GX CM2250 | 4022250
Exhaust Restriction | Refer to Procedure 011-009 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Restriction | Refer to Procedure 011-009 | QSL9 CM2250 | 4022256
Exhaust Restriction | Refer to Procedure 011-009 | QSB6.7 CM2250 | 4022255
Exhaust Restriction | Refer to Procedure 011-009 | QSB6.7 CM2250 EC | 2883621
Exhaust Restriction | Refer to Procedure 011-009 | QSX11.9 CM2250 ECF | 2883561
Exhaust Restriction | Refer to Procedure 011-009 | QSX15 CM2250 ECF | 2883557
Exhaust Restriction | Refer to Procedure 011-009 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Restriction | Refer to Procedure 011-009 | PowerGen QSX15 CM2250 | 4310664
Exhaust Restriction | Refer to Procedure 011-009 | ISB4.5 CM2350 B104 | 4332646
Exhaust Restriction | Refer to Procedure 011-009 | ISB6.7 CM2350 B103 | 4332641
Exhaust Restriction | Refer to Procedure 011-009 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 EC | 2883621
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISL9 CM2350 L111 | 4367223
Aftertreatment System | Refer to Procedure 011-050 | ISB6.7 CM2250 | 4022254
Aftertreatment System | Refer to Procedure 011-050 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment System | Refer to Procedure 011-050 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment System | Refer to Procedure 011-050 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment System | Refer to Procedure 011-050 | QSL9 CM2250 | 4022256
Aftertreatment System | Refer to Procedure 011-050 | QSB6.7 CM2250 | 4022255
Aftertreatment System | Refer to Procedure 011-050 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment System | Refer to Procedure 011-050 | QSX15 CM2250 ECF | 2883557
Aftertreatment System | Refer to Procedure 011-050 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment System | Refer to Procedure 011-050 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment System | Refer to Procedure 011-050 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment System | Refer to Procedure 011-050 | ISL9 CM2350 L111 | 4367223
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223

Cautions and Warnings

CAUTION

To prevent damage to the turbocharger actuator, be sure to drain the coolant before removing the actuator.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and previous service history. |
 | STEP 1A. Check for active fault codes. | Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for previous variable geometry turbocharger actuator removals. | Actuator removed or replaced during the current repair event?
 | STEP 1C. Check for exhaust gas recirculation (EGR) related fault codes. | EGR system fault codes active?
 | STEP 1D. Check exhaust restriction. | Exhaust restriction is greater than 308 mm Hg [12 in Hg]?
STEP 2. | Check the variable geometry turbocharger actuator. |
 | STEP 2A. Inspect the variable geometry turbocharger actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the variable geometry turbocharger actuator. | Gear broken on the variable geometry turbocharger actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Sector gear teeth are not damaged and movement meets the requirements when using the sector gear gauge, according to Procedure 010-134 in Section 10 in the base engine service manual?
STEP 3. | Check aftertreatment system. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and previous service history.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2387.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
YES NO
No Repair

No troubleshooting is necessary. Clear the inactive fault code.

Go to 1B

Go to 3A

Guided Step 1B - Check for previous variable geometry turbocharger actuator removals.

Conditions

Not applicable.

Action

Check for previous replacements.

  • Determine if the actuator has been removed or replaced and Fault Code 2387 is active.

Has the actuator been removed or replaced during the current repair event?
YES NO

Remove the actuator and install it in the correct position.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check for EGR-related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or high inactive EGR valve, EGR temperature, and EGR differential pressure-related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for active Fault Codes 1896, 2357, 2359, 2961, and 2962.

EGR system fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting procedure

Go to 1D

Guided Step 1D - Check exhaust restriction.

Conditions

  • Install a pressure gauge into the exhaust system.
  • Turn keyswitch ON.
  • Operate engine at rated horsepower and rpm.

Action

Check exhaust restriction by installing a pressure gauge into the exhaust system, just past the turbocharger outlet.

If a port is not found in the exhaust system, remove the aftertreatment diesel oxidation catalyst intake sensor and install the pressure gauge in the temperature sensor port.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Is exhaust restriction greater than 308 mm Hg [12 in Hg]?
YES NO

Remove the diesel oxidation catalyst (DOC) from the vehicle and inspect for face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the variable geometry turbocharger actuator.

Guided Step 2A - Inspect the variable geometry turbocharger actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine harness.

Action

Inspect the engine harness and variable geometry turbocharger actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the variable geometry turbocharger actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the variable geometry turbocharger actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the variable geometry turbocharger actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect the variable geometry turbocharger actuator.

Check for a broken drive gear on the variable geometry turbocharger actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Gear is broken on the variable geometry turbocharger actuator?
YES NO

A damaged gear has been detected on the variable geometry turbocharger actuator.

Replace the variable geometry turbocharger actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove the variable geometry turbocharger actuator from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger bearing housing up and down from stop to stop. Check for smooth movement between the stops.

Note: It may take considerable force to move the sector gear. If it can be moved by hand, this is considered acceptable. Do not use any hand tools.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Sector gear teeth are not damaged and movement meets the requirements when using the sector gear gauge, according to Procedure 010-134 in Section 10 in the base engine service manual?

YES NO

Perform variable geometry actuator install and calibration procedure. Refer to Procedure 010-134 in Section 10 in the Associated Procedures Table.

A turbocharger mechanical malfunction has been detected.

NOTE: This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Replace the turbocharger assembly.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check aftertreatment system.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform the Snap Acceleration – Aftertreatment Connected Test to test for a damaged diesel particulate filter (DPF). Refer to Procedure 014-013 in the Associated Procedures Table.

Action

Check for progressive damage to the aftertreatment system.

  • Perform the Snap Acceleration - Aftertreatment Connected Test to test for a damaged DPF. Refer to Procedure 014-013 in the Associated Procedures Table.
  • For ISB4.5 CM2350 B104 and ISB6.7 CM2350 B103 engines: Refer to Procedure 014-016 in the Associated Procedures Table.

Progressive damage to the aftertreatment system detected?
YES NO

Replace the damaged aftertreatment system component(s). Refer to Procedure 011-050 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 29-Jun-2017


FAULT CODE 2398 - Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2398 active?
 | STEP 1B. Check for Fault Codes 249 and 256. | Fault Code 249 or 256 active?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 249 active?
 | STEP 2C. Check the circuit response. | Fault Code 256 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 249 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2398 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for Fault Codes 249 and 256.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 or 256 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the ambient air temperature sensor SIGNAL pin and the ambient air temperature sensor RETURN pin at the ambient air temperature sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES NO

An in-range malfunction of the ambient air temperature sensor has been detected.

Replace the ambient air temperature sensor.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor RETURN pin and the OEM harness ambient air temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor SIGNAL pin and the OEM harness ambient air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 10-Oct-2012


FAULT CODE 2634 - VGT Actuator Controller - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 ECF | 2883557
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB4.5 CM2350 B104 | 4332646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B103 | 4332641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L111 | 4367223
Aftertreatment System | Refer to Procedure 011-050 | ISB6.7 CM2250 | 4022254
Aftertreatment System | Refer to Procedure 011-050 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment System | Refer to Procedure 011-050 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment System | Refer to Procedure 011-050 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment System | Refer to Procedure 011-050 | QSL9 CM2250 | 4022256
Aftertreatment System | Refer to Procedure 011-050 | QSB6.7 CM2250 | 4022255
Aftertreatment System | Refer to Procedure 011-050 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment System | Refer to Procedure 011-050 | QSX15 CM2250 ECF | 2883557
Aftertreatment System | Refer to Procedure 011-050 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment System | Refer to Procedure 011-050 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment System | Refer to Procedure 011-050 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment System | Refer to Procedure 011-050 | ISL9 CM2350 L111 | 4367223
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check Variable Geometry Turbocharger (VGT) actuator installation. |
 | STEP 1A. Check VGT actuator installation. | Fault Codes 2449 and 2634 both active?
 | STEP 1B. Check for previous VGT actuator removals | Was the VGT actuator recently removed from the turbocharger and keyswitch turned ON?
 | STEP 1C. Disconnect and connect VGT actuator connector. | Fault Code 2634 inactive after disconnecting and connecting the VGT actuator connector?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check for progressive damage. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check VGT actuator installation.

Guided Step 1A - Check VGT actuator installation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Fault Codes 2449 and 2634 both active?
YES NO

Remove the actuator and install it in the correct position. Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for previous VGT actuator removals.

Conditions

  • Fault Code 2634 is active.

Action

None.

Was the VGT actuator recently removed from the turbocharger and the keyswitch turned ON?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Disconnect and connect VGT actuator connector.

Conditions

Not applicable

Action

If the VGT actuator is removed from the turbocharger and the keyswitch is turned ON with the wiring harness connected to the VGT actuator, Fault Code 2634 will be active. Follow the procedures below:

  • Turn keyswitch ON.
  • Disconnect the VGT actuator from the engine harness and connect.

Note: Fault Code 2636 will be active temporarily when the turbocharger actuator is disconnected.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Fault Code 2634 is inactive after disconnecting and connecting the VGT actuator connector?
YES | NO
No Repair | No Repair

Repair complete

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

A damaged VGT actuator has been detected.

  • Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check for progressive damage.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform aftertreatment initial check procedure to test for a damaged diesel particulate filter.
  • Connect all components.

Action

Progressive damage to the aftertreatment system may have occurred.

  • Perform aftertreatment initial check procedure to test for a damaged diesel particulate filter. Refer to Procedure Refer to 014-013 in the Associated Procedures Table.
  • For ISB4.5 CM2350 B104 adn ISB6.7 CM2350 B103 engines: Refer to Procedure Refer to 014-016 in the Associated Procedures Table.

Progressive damage to the aftertreatment system is detected?
YES NO

Replace the damaged aftertreatment component. Refer to Procedure 011-050 in the Associated Procedures Table.

Check for active aftertreatment-related fault codes and follow any active aftertreatment fault code troubleshooting trees.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Sep-2014


FAULT CODE 2637 (ISB, ISC, ISL) - Aftertreatment Diesel Oxidation Catalyst Face Plugged - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB CM2100 and CM2150 | 4021578
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2260 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC and ISL CM2150 | 4021569
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB CM2100 and CM2150 | 4021578
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2250 | 4022254
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISC and ISL CM2150 | 4021569
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust System - Overview | Refer to Procedure 011-999 | ISB6.7 CM2250 | 4022254
Exhaust System - Overview | Refer to Procedure 011-999 | ISB CM2100 and CM2150 | 4021578
Exhaust System - Overview | Refer to Procedure 011-999 | ISC and ISL CM2150 | 4021569
Exhaust System - Overview | Refer to Procedure 011-999 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISB CM2100 and CM2150 | 4021578
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC and ISL CM2150 | 4021569
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4021569

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active or inactive counts of other aftertreatment and air handling syste fault codes. | Fault codes found that are related to aftertreatment or air handling system?
STEP 2. | Check ECM Calibration, Features, and Parameters. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Check for excessive aftertreatment regeneration frequency. | Average aftertreatment regeneration frequency 8 hours or less?
 | STEP 2C. Check the OEM or customer selected regeneration inhibit features and parameters. | Features and Parameter settings preventing or interrupting regeneration?
STEP 3. | Check the exhaust system. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil, fuel, or coolant. | Engine oil, fuel, or coolant contamination found in the turbocharger exhaust outlet?
 | STEP 3B. Check the exhaust system between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks found?
STEP 4. | Check for excessive smoke. |
 | STEP 4A. Inspect the exhaust for excessive smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 5A. Clean and inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 6. | Reset aftertreatment, perform a stationary regeneration, and reset fault codes. |
 | STEP 6A. Perform the Aftertreatment Diesel Oxidation Catalyst Reset Procedure. | Aftertreatment Maintenance Reset procedure completed sucessfully?
 | STEP 6B. Perform a stationary regeneration. | Fault Code 2637 inactive after running the stationary regeneration procedure?
 | STEP 6C. Disable and clear the fault code. |

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active or inactive counts of other aftertreatment and air handling system fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for related fault codes.

  • Use INSITE™ electronic service tool to check for active or inactive fault codes that are related to the to the diesel oxidation catalyst (DOC) or aftertreatment temperature sensors.

Other fault codes found active or have high counts inactive?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM Calibration, Features, and Parameters.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Check for excessive aftertreatment regeneration frequency.

Conditions

  • Turn Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for excessive regeneration frequency.

Use INSITE™ electronic service tool to evaluate average time between aftertreatment regenerations. This can be done by determining the average time between regeneration events in the Advance ECM Data tab, under Aftertreatment History. Regeneration frequencies of 8 hours or less are considered excessive and must be investigated

Is the average aftertreatment regeneration frequency 8 hours or less?
YES NO

  • Reference Troubleshooting Symptom Tree t147 in Bulletin 4021578 for ISB CM2150 engines.
  • Reference Troubleshooting Symptom Tree t147 in Bulletin 4021569 for ISC and ISL CM2150 engines.

 No Repair

Go to 6A

Go to 2C

Guided Step 2C - Check the OEM or customer selected regeneration inhibit features and parameters.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check OEM or customer selected inhibit features.

Use INSITE™ electronic service tool to review the settings for automotive mobile regeneration minimum vehicle speed, and active regeneration in PTO and remote modes. Make sure these OEM or customer selected inhibit features are not interrupting or preventing regeneration events.

For ISB engines use the following procedure.Refer to Procedure 011-999 in the Associated Procedures Table.

For ISC and ISL engines use the following procedure. Refer to Procedure 011-999 in the Associated Procedure Table.

Features and Parameter settings preventing or interrupting regeneration?
YES NO

Adjust the Features and Parameters settings such that regenerations are not inhibited or interrupted. Always consult the OEM and Customer prior to making any changes to these settings.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the exhaust system for leaks.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil, fuel, or coolant.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet for signs of oil, fuel, or coolant being introduced into the aftertreatment system from the engine.

Engine oil, fuel, or coolant contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible engine oil, diesel fuel, or coolant being carried from the engine into the aftertreatment system.

For the malfunctioning component(s):

  • For the ISB, reference the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.
  • For the ISC and ISL reference the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

No Repair

Go to 3B

Go to 3B

Guided Step 3B - Check the exhaust system between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn Keyswitch OFF.

Action

Check the exhaust system for leaks.

  • Inspect the exhaust system between the turbocharger and aftertreatment system. Inspect for loose or leaking connections, and damaged exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged or leaking exhaust system components.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check for excessive smoke.

Guided Step 4A - Inspect the exhaust for excessive smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet
  • Operate engine.

Action

Check the exhaust smoke.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.
  • To perform a snap acceleration test, it could be necessary to temporarily adjust the Maximum Engine Speed with No Vehicle Speed Sensor Parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

  • Reference the Smoke, Black - Excessive troubleshooting symptom tree t116 in Section TS of the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.
  • Reference the Smoke, Black - Excessive troubleshooting symptom tree t116 in Section TS of the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Inspect the aftertreatment DOC.

Guided Step 5A - Clean and inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

Remove the aftertreatment DOC.

Clean the DOC and inspect for reuse.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in the Associated Procedures Table.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DOC cell walls for cracks.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in the Associated Procedures Table.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in the Associated Procedures Table.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Reset aftertreatment, perform a stationary regeneration, and reset fault codes.

Guided Step 6A - Perform the Aftertreatment Diesel Oxidation Catalyst Reset procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenancee Reset procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset procedure under the Advanced ECM Data menu. Select the DOC Reset option.

Aftertreatment Maintenance Reset procedure has been sucessfully completed?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service too.
  • Operate engine at idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Use the following procedure for stationary regeneration information in the ISB CM2100 and CM2150 engine in Bulletin 4021578. Refer to Procedure 014-013 in the Associated Procedures Table.
  • Use the following procedure for stationary regeneration information in the ISC and ISL engines in Bulletin 4021569. Refer to Procedure 014-013 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found in the ECM Diagnostics Test menu.

For information regarding appropriate aftertreatment temperature profiles during a stationary regeneration, use the following procedure.

  • For ISB CM2100 and CM2150, Bulletin 4021578. Refer to Procedure 011-056 in the Associated Procedures Tables.
  • For ISC and ISL, Bulletin 4021569. Refer to Procedure 011-056 in the Associated Procedures Tables.

Fault Code 2637 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Replace the aftertreatment DOC.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in the Associated Procedures Table.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in the Associated Procedures Table.

Go to 6C

Go to 6C

Guided Step 6C - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Successful completion of a stationary regeneration without the fault code coming active indicates the condition for clearing the fault code has been met. Use INSITE™ electronic service tool to clear the inactive fault code.

Fault code inactive and cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Jan-2012


FAULT CODE 2638 (ISB, ISC, ISL) - Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB CM2100 and CM2150 | 4021578
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2260 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC and ISL CM2150 | 4021569
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB CM2100 and CM2150 | 4021578
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2250 | 4022254
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISC and ISL CM2150 | 4021569
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust System - Overview | Refer to Procedure 011-999 | ISB6.7 CM2250 | 4022254
Exhaust System - Overview | Refer to Procedure 011-999 | ISB CM2100 and CM2150 | 4021578
Exhaust System - Overview | Refer to Procedure 011-999 | ISC and ISL CM2150 | 4021569
Exhaust System - Overview | Refer to Procedure 011-999 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISB CM2100 and CM2150 | 4021578
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC and ISL CM2150 | 4021569
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4021569

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for EGR valve and VGT related fault codes. | Other fault codes active or have high inactive counts?
STEP 2. | Check ECM Calibration, Features, and Parameters. |
 | STEP 2A. Check if an ECM calibration update is available | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Check for excessive aftertreatment regeneration frequency | Average aftertreatment regeneration frequency 8 hours or less?
 | STEP 2C. Check the OEM or customer selected regeneration inhibit features and parameters. | Features and Parameter settings preventing or interrupting regeneration?
STEP 3. | Check the exhaust system. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil, fuel, or coolant. | Engine oil, fuel, or coolant contamination found in the turbocharger exhaust outlet?
 | STEP 3B. Check the exhaust system between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks found?
 | STEP 3C. Check the charge-air cooler and charger-air plumbing for leaks. | Air leaks present in the charge-air system?
STEP 4. | Check for excessive smoke |
 | STEP 4A. Inspect the exhaust for excessive smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 5. | Inspect the aftertreatment DOC. |
 | STEP 5A. Clean and inspect the aftertreatment diesel oxidation catalyst (DOC) for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 6. | Reset aftertreatment. |
 | STEP 6A. Perform the stationary regeneration maintenance reset procedure. | Aftertreatment Maintenance Reset procedure has been completed?
 | STEP 6B. Perform a stationary regeneration. | Fault Code 2638 inactive after running the stationary regeneration procedure?
 | STEP 6C. Disable and clear the fault code. | Fault code inactive and cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for EGR valve and VGT related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for related fault codes.

  • Use INSITE™ electronic service tool to check for active or inactive fault codes that are related to the air handling system.

Other fault codes active or have high counts inactive?
YES NO

Troubleshoot the EGR or VGT related fault codes. A stuck open EGR valve or a damaged VGT actuator can cause face plugging of the DOC.

No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM Calibration, Features, and Parameters.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check for excessive aftertreatment regeneration frequency.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for excessive regeneration frequency.

Use INSITE™ electronic service tool to evaluate average time between aftertreatment regenerations. This can be done by determining the average time between regeneration events in the Advance ECM Data tab, under Aftertreatment History. Regeneration frequencies of 8 hours or less are considered excessive and must be investigated.

Average aftertreatment regeneration frequency 8 hours or less?
YES NO

  • Reference the Aftertreatment Diesel Particulate Filter - Excessive Automatic and/or Stationary Regeneration troubleshooting symptom tree in Section TS of the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.
  • Reference the Aftertreatment Diesel Particulate Filter - Excessive Automatic and/or Stationary Regeneration troubleshooting symptom tree in Section TS of the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

No Repair

Go to 6A

Go to 2C

Guided Step 2C - Check the OEM or customer selected regeneration inhibit features and parameters.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check OEM or customer selected inhibit features.

Use INSITE™ electronic service tool to review the settings for automotive mobile regeneration minimum vehicle speed, and active regeneration in PTO and remote modes. Make sure these OEM or customer selected inhibit features are not interrupting or preventing regeneration events. Refer to Procedure 011-999 in the Associated Procedure Table.

Features and Parameter settings preventing or interrupting regeneration?
YES NO

Adjust the Features and Parameters settings such that regenerations are not inhibited or interrupted. Always consult the OEM and customer prior to making any changes to these settings.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the exhaust system.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil, fuel, or coolant.

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet for signs of oil, fuel, or coolant being introduced into the aftertreatment system from the engine.

  • Inspect the DOC and diesel particulate filter for signs of oil or fuel contamination. These components must be replaced if soaked with oil or fuel. Refer to the Aftertreatment Diesel Oxidation Catalyst and Aftertreatment Diesel Particulate Filter Reuse Guidelines in Bulletin 4021600.

Engine oil, fuel, or coolant contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible engine oil, diesel fuel, or coolant being carried from the engine into the aftertreatment system.

  • For the ISB, refer to the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.
  • For the ISC and ISL, refer to the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

 No Repair

Go to 3B

Go to 3B

Guided Step 3B - Check the exhaust system between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system for leaks.

  • Inspect the exhaust system between the turbocharger and aftertreatment system. Inspect for loose or leaking connections, and damaged exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged or leaking exhaust system components.

 No Repair

Go to 3C

Go to 3C

Guided Step 3C - Check the charge-air cooler and charge-air plumbing for leaks.

Conditions

  • Operate engine.

Action

Check the charge-air cooler and charge-air plumbing for leaks.

  • Check the charge-air cooler connections for leaks between the turbocharger compressor outlet and the charge-air cooler.
  • Check the charge-air cooler connections between the charge-air cooler and the intake manifold.
  • Inspect the intake manifold gasket for leaks.
  • Inspect the charge-air cooler hoses for leaks or loose connections.
  • Inspect charge-air cooler clamps to make sure they are tight.
  • Inspect the charge-air plumbing for cracks.

Air leaks present in the charge-air system?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check for excessive smoke.

Guided Step 4A - Inspect the exhaust for excessive smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate engine.

Action

Check the exhaust smoke.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.
  • Note: To perform a snap acceleration test, it may be necessary to temporarily adjust the Maximum Engine Speed with No Vehicle Speed Sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

  • Reference the Smoke, Black - Excessive, or Smoke, White - Excessive troubleshooting symptom tree t116 and t118 in Section TS of the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578, and the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment DOC.

Guided Step 5A - Clean and inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

  • Remove the aftertreatment DOC.

Clean the DOC, and inspect for reuse.

  • Use the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in the Associated Procedure Table.
  • Use the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in the Associated Procedure Table.

Action

Check for cracks in the aftertreatment DOC cell wall.

  • Refer to the Aftertreatment Diesel Oxidation Catalyst and Aftertreatment Diesel Particulate Filter Reuse Guidelines in Bulletin 4021600.
  • Use the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in the Associated Procedure Table.
  • Use the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in the Associated Procedure Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC.

  • Use the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in the Associated Procedure Table.
  • Use the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in the Associated Procedure Table.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Reset aftertreatment, perform a stationary regeneration, and reset fault codes.

Guided Step 6A - Perform the stationary regeneration maintenance reset procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Diesel Oxidation Catalyst Reset Procedure

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset procedure under the Aftertreatment Maintenance tab in the Advanced ECM Data menu. Select the DOC Reset option.

Aftertreatment Maintenance Reset procedure has been completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset procedure under the Aftertreatment Maintenance tab in the Advanced ECM Data menu.

Go to 6B

Go to 6B

Guided Step 6B - Perform a stationary regeneration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Use the following procedure for stationary regeneration information in the ISB CM2100 and CM2150 engine in Bulletin 4021578. Refer to Procedure 011-056 in the Associated Procedure Table.

Fault Code 2638 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Replace the aftertreatment DOC.

  • Use the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in the Associated Procedure Table.
  • Use the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in the Associated Procedure Table.

Go to 6C

Go to 6C

Guided Step 6C - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Successful completion of a stationary regeneration without the fault code coming active indicates the condition for clearing the fault code has been met. Use INSITE™ electronic service tool to clear the inactive fault code.

Fault code inactive and cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 18-Jan-2012


FAULT CODE 2646 - Engine Coolant Temperature - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2646 active?
STEP 2. | Check ECM calibration and clear fault. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2646 active?
YES NO

The EGR valve was closed to reduce engine coolant temperature.

No repair is necessary.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Sep-2012


FAULT CODE 2659 - Engine Coolant Temperature - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2659 active?
STEP 2. | Check ECM calibration and clear fault. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2659 active?
YES NO

The EGR valve was closed to reduce engine coolant temperature.

No repair is necessary.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Dec-2011


FAULT CODE 2754 - Engine Diesel Particulate Filter Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Charge-Air Cooler | Refer to Procedure 010-027 | ISB6.7 CM2250 | 4022254
Charge-Air Cooler | Refer to Procedure 010-027 | ISC8.3 and ISL9 CM2250 | 4022257
Charge-Air Cooler | Refer to Procedure 010-027 | ISX12/ISX11.9 CM2250 | 2883445
Charge-Air Cooler | Refer to Procedure 010-027 | QSL9 CM2250 | 4022256
Charge-Air Cooler | Refer to Procedure 010-027 | QSB6.7 CM2250 | 4022255
Charge-Air Cooler | Refer to Procedure 010-027 | QSX11.9 CM2250 ECF | 2883561
Charge-Air Cooler | Refer to Procedure 010-027 | QSX15 CM2250 ECF | 2883557
Charge-Air Cooler | Refer to Procedure 010-027 | PowerGen QSX15 CM2250 ECF | 4310661
Barometric Pressure Sensor | Refer to Procedure 019-004 | QSX11.9 CM2250 | 2883561
Barometric Pressure Sensor | Refer to Procedure 019-004 | QSX15 CM2250 | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2250 | 4022254
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 | 4022256
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 | 4022255
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2250 ECF | 2883557
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 ECF | 4310661

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for VGT and EGR related fault codes. | Fault codes related to the VGT or EGR valve operation active?
 | STEP 1B. Check for intake manifold pressure sensor or EGR differential pressure sensor related fault codes. | Fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor are active?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the charge-air system for leaks. | Air leaks present in the charge-air cooler, charge-air cooler hoses, or the air intake connection?
 | STEP 2B. Check for a restricted charge-air cooler. | Charge-air cooler restriction within specifications?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 127 mm Hg [5 in Hg] of mechanical gauge reading?
STEP 4. | Check the barometric pressure sensor. |
 | STEP 4A. Verify the sensor accuracy. | INSITE™ electronic service tool reading is within 102 mm Hg [4 in Hg] of local barometric pressure?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the VGT and EGR related fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the VGT and EGR valve operation.

Fault codes related to the VGT or EGR valve operation active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for intake manifold pressure sensor or EGR differential pressure sensor related fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor.

Fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the charge-air system for leaks.

Conditions

  • Engine is idling.

Action

Inspect the charge-air cooler and connections for air leaks.

  • Inspect the charge-air cooler connection hoses and clamps. Make sure the clamps are tight and that the hoses are not ruptured.
  • Inspect the air intake connections for air leaks.

Air leaks present in the charge-air cooler, charge-air cooler hoses, or the air intake connection?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a restricted charge-air cooler.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Engine running.

Action

Check the pressure differential across the charge-air cooler.

  • Refer to Procedure 010-027 in the Associated Procedures Table.

Charge-air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge air cooler, if necessary.

Go to 3A

Go to 4A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor.

  • Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.
  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for Intake Manifold Pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 127 mm Hg [5 in Hg] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold pressure sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the barometric pressure sensor.

Guided Step 4A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor.

Note:The Turbocharger Compressor Intake Pressure/Temperature Sensor is used to measure the barometric pressure except on the GX CM2250 engine.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for Barometric Pressure to the local barometric pressure per the table below.

Refer to Procedure 018-028 in Section V.

INSITE™ electronic service tool reading is within 14 kPa [2 psi] of local barometric pressure?
YES NO
No Repair

Replace the barometric pressure sensor.

  • Refer to Procedure 019-004 in the Associated Procedures Table.
  • On all other engines, Refer to 019-466 in the Associated Proceures Table.

Appropriate troubleshooting tree.

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related ti this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overviewsection of this troubleshooting procedure..

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Jun-2012


FAULT CODE 2789 - Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the Coolant Temperature value.

  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

  • Reference the Engine Coolant Temperature Below Normal symptom tree in Section TS in the appropriate service manual.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Sep-2012


FAULT CODE 2961 - Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 ECF | 4310661
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 | 4310664
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 EC | 2883647
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2250 | 4022254
Air Intake Connection | Refer to Procedure 010-080 | ISC8.3 and ISL9 CM2250 | 4022257
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2250 | 4022256
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2250 | 4022255
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2250 EC | 2883621
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2350 B101 | 2883567
Air Intake Connection | Refer to Procedure 010-080 | ISL9 CM2350 L101 | 4310787
Intake Air/Exhaust Gas Mixer | Refer to Procedure 010-147 | QSB3.3 CM2250 EC | 2883647
EGR Cooler | Refer to Procedure 011-019 | ISB6.7 CM2250 | 4022254
EGR Cooler | Refer to Procedure 011-019 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Cooler | Refer to Procedure 011-019 | ISX CM2250 GX CM2250 | 4022250
EGR Cooler | Refer to Procedure 011-019 | ISX12/ISX11.9 CM2250 | 2883445
EGR Cooler | Refer to Procedure 011-019 | QSL9 CM2250 | 4022256
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2250 | 4022255
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2250 EC | 2883621
EGR Cooler | Refer to Procedure 011-019 | QSX11.9 CM2250 ECF | 2883561
EGR Cooler | Refer to Procedure 011-019 | QSX15 CM2250 ECF | 2883557
EGR Cooler | Refer to Procedure 011-019 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Cooler | Refer to Procedure 011-019 | PowerGen QSX15 CM2250 | 4310664
EGR Cooler | Refer to Procedure 011-019 | QSB3.3 CM2250 EC | 2883647
EGR Cooler | Refer to Procedure 011-019 | ISB6.7 CM2350 B101 | 2883567
EGR Cooler | Refer to Procedure 011-019 | ISL9 CM2350 L101 | 4310787
EGR Cooler | Refer to Procedure 011-019 | ISX12 CM2350 X102 | 4310646
EGR Cooler | Refer to Procedure 011-019 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX15 CM2350 X101 | 4310641
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX12/ISX11.9 CM2250 | 2883445
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX CM2250 GX CM2250 | 4022250
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | QSX11.9 CM2250 ECF | 2883561
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | QSX15 CM2250 ECF | 2883557
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX12 CM2350 X102 | 4310646
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX15 CM2350 X101 | 4310641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2250 | 4022254
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 EC | 2883621
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX11.9 CM2250 ECF | 2883561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2250 ECF | 2883557
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 | 4310664
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B101 | 2883567
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L101 | 4310787
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12 CM2350 X102 | 4310646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2350 X101 | 4310641
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2250 | 4022254
EGR Temperature Sensor | Refer to Procedure 019-378 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX CM2250 GX CM2250 | 4022250
EGR Temperature Sensor | Refer to Procedure 019-378 | GX15 CM2250 | 4022250
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12/ISX11.9 CM2250 | 2883445
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2250 | 4022256
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 | 4022255
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 EC | 2883621
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX11.9 CM2250 ECF | 2883561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX15 CM2250 ECF | 2883557
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 | 4310664
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B101 | 2883567
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L101 | 4310787
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12 CM2350 X102 | 4310646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2250 | 4310641

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 2961?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature. |
 | STEP 2A. Check the EGR temperature sensor accuracy. | EGR temperature within 10°C [18°F] of ambient air temperature?
STEP 3. | Check the cooling system. |
 | STEP 3A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 3B. Check the engine coolant level. | Engine coolant level at proper level?
STEP 4. | Check the EGR system. |
 | STEP 4A. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure port?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 2961?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the EGR temperature sensor.

Guided Step 2A - Check the EGR temperature sensor accuracy.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR temperature sensor from the EGR plumbing.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the EGR temperature sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the EGR temperature sensor reading.
  • Compare the EGR temperature sensor reading to ambient air temperature.

Allow the EGR temperature sensor enough time to cool down to ambient temperature before comparing the reading.

EGR temperature within 10°C [18°F] of ambient air temperature?
YES NO
No Repair

A malfunctioning EGR temperature sensor has been detected.

Replace the EGR temperature sensor. Refer to Procedure 019-378 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the cooling system.

Guided Step 3A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.

Check the freeze point of the engine coolant to be sure of a proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Engine coolant is proper mixture?
YES NO
No Repair

Drain the coolant and fill the cooling system with the proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

NOTE: Low engine coolant level can cause erratic coolant flow through the engine and EGR cooler, in turn, causing the EGR temperatures to rise.

Engine coolant level at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant, if necessary.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the EGR system.

Guided Step 4A - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

Action

Inspect the EGR differential pressure sensor ports and cross drillings for restrictions, soot plugging, and debris plugging.

  • For ISB6.7, ISC8.3, and ISL9 engines: Refer to Procedure 010-080 in the Associated Procedures Table.
  • For QSB3.3 engines: Refer to Procedure 010-147 in the Associated Procedures Table.
  • For ISX12, ISX11.9, and ISX15 engines: Refer to Procedure 011-066 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the debris or replace the EGR differential pressure tube.

  • For ISB6.7, ISC8.3, and ISL9 engines: Refer to Procedure 010-080 in the Associated Procedures Table.
  • For QSB3.3 engines: Refer to Procedure 010-147 in the Associated Procedures Table.
  • For ISX12, ISX11.9, and ISX15 engines: Refer to Procedure 011-066 in the Associated Procedures Table.

Clean the EGR cooler.

  • Refer to Procedure 011-019 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-May-2015


FAULT CODE 2962 - Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 ECF | 4310661
Cooling System | Refer to Procedure 008-018 | PowerGen QSX15 CM2250 | 4310664
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2250 | 4022254
Air Intake Connection | Refer to Procedure 010-080 | ISC8.3 and ISL9 CM2250 | 4022257
Air Intake Connection | Refer to Procedure 010-080 | ISX12/ISX11.9 CM2250 | 2883445
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2250 | 4022256
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2250 | 4022255
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2250 EC | 2883621
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2350 B101 | 2883567
Air Intake Connection | Refer to Procedure 010-080 | ISL9 CM2350 L101 | 4310787
Air Intake Connection | Refer to Procedure 010-080 | ISX12 CM2350 X101 | 4310646
Air Intake Connection | Refer to Procedure 010-131 | ISX15 CM2350 X101 | 4310641
EGR Cooler | Refer to Procedure 011-019 | ISB6.7 CM2250 | 4022254
EGR Cooler | Refer to Procedure 011-019 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Cooler | Refer to Procedure 011-019 | ISX CM2250 GX CM2250 | 4022250
EGR Cooler | Refer to Procedure 011-019 | GX15 CM2250 | 4022250
EGR Cooler | Refer to Procedure 011-019 | ISX12/ISX11.9 CM2250 | 2883445
EGR Cooler | Refer to Procedure 011-019 | QSL9 CM2250 | 4022256
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2250 | 4022255
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2250 EC | 2883621
EGR Cooler | Refer to Procedure 011-019 | QSX11.9 CM2250 ECF | 2883561
EGR Cooler | Refer to Procedure 011-019 | QSX15 CM2250 ECF | 2883557
EGR Cooler | Refer to Procedure 011-019 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Cooler | Refer to Procedure 011-019 | PowerGen QSX15 CM2250 | 4310664
EGR Cooler | Refer to Procedure 011-019 | ISB6.7 CM2350 B101 | 2883567
EGR Cooler | Refer to Procedure 011-019 | ISL9 CM2350 L101 | 4310787
EGR Cooler | Refer to Procedure 011-019 | ISX12 CM2350 X102 | 4310646
EGR Cooler | Refer to Procedure 011-019 | ISX15 CM2350 X101 | 4310641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B101 | 2883567
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L101 | 4310787
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12 CM2350 X102 | 4310646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2350 X101 | 4310641
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2250 | 4022254
EGR Temperature Sensor | Refer to Procedure 019-378 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX CM2250 GX CM2250 | 4022250
EGR Temperature Sensor | Refer to Procedure 019-378 | GX15 CM2250 | 4022250
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12/ISX11.9 CM2250 | 2883445
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2250 | 4022256
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 | 4022255
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 EC | 2883621
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX11.9 CM2250 ECF | 2883561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX15 CM2250 ECF | 2883557
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 | 4310664
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B101 | 2883567
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L101 | 4310787
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12 CM2350 X102 | 4310646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2250 | 4310641

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 2962?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature sensor. |
 | STEP 2A. Check the EGR temperature sensor accuracy. | EGR temperature within 10°C [18°F] of ambient air temperature?
STEP 3. | Check the cooling system. |
 | STEP 3A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 3B. Check the engine coolant level. | Engine coolant level at proper level?
STEP 4. | Check the EGR system. |
 | STEP 4A. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure port?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 2962?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the EGR temperature sensor.

Guided Step 2A - Check the EGR temperature sensor accuracy.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR temperature sensor from the EGR plumbing.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the EGR temperature sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the EGR temperature sensor reading.
  • Compare the EGR temperature sensor reading to ambient air temperature.

Allow the EGR temperature sensor enough time to cool down to ambient temperature before comparing the reading.

EGR temperature within 10°C [18°F] of ambient air temperature?
YES NO
No Repair

A malfunctioning EGR temperature sensor has been detected.

Replace the EGR temperature sensor. Refer to Procedure 019-378 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the cooling system.

Guided Step 3A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.

Check the freeze point of the engine coolant to be sure of a proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Engine coolant is proper mixture?
YES NO
No Repair

Drain the coolant and refill the cooling system with the proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

NOTE: Low engine coolant level may cause erratic coolant flow through the engine and EGR cooler, in turn, causing the EGR temperatures to rise.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Engine coolant level at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant, if necessary.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the EGR system.

Guided Step 4A - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

Action

Inspect the EGR differential pressure sensor ports and cross drillings for restrictions, soot plugging, and debris plugging.

  • For ISB6.7, ISC8.3, and ISL9 engines: Refer to Procedure 010-080 in the Associated Procedures Table.
  • For ISX12/ISX11.9 and ISX15 engines: Refer to Procedure 010-066 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the debris or replace the EGR differential pressure tube.

  • For ISB6.7, ISC8.3, and ISL9 engines: Refer to Procedure 010-080 in the Associated Procedures Table.
  • For ISX12/ISX11.9 and ISX15 engines: Refer to Procedure 010-066 in the Associated Procedures Table.

Clean the EGR cooler.

  • Refer to Procedure 011-019 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-May-2015


FAULT CODE 2973 - Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISB6.7 CM2250 | 4022254
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ICS8.3 and ISL9 CM2250 | 4022257
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISX CM2250 GX CM2250 | 4022250
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISX12/ISX11.9 CM2250 | 2883445
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSL9 CM2250 | 4022256
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSB6.7 CM2250 | 4022255
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSB6.7 CM2250 EC | 2883621
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSB3.3 CM2250 EC | 2883647
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISB6.7 CM2350 B101 | 2883567
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISL9 CM2350 L101 | 4310787
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISX12 CM2350 X102 | 4310646
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISX15 CM2350 X101 | 4310641
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSB4.5 CM2250 B131 | 4388774
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSB3.3 CM2250 B137 | 5411058
Charge-Air Cooler | Refer to Procedure 010-027 | ISB6.7 CM2250 | 4022254
Charge-Air Cooler | Refer to Procedure 010-027 | ISC8.3 and ISL9 CM2250 | 4022257
Charge-Air Cooler | Refer to Procedure 010-027 | ISX CM2250 GX CM2250 | 4022250
Charge-Air Cooler | Refer to Procedure 010-027 | ISX12/ISX11.9 CM2250 | 2883445
Charge-Air Cooler | Refer to Procedure 010-027 | QSL9 CM2250 | 4022256
Charge-Air Cooler | Refer to Procedure 010-027 | QSB6.7 CM2250 | 4022255
Charge-Air Cooler | Refer to Procedure 010-027 | QSB6.7 CM2250 EC | 2883621
Charge-Air Cooler | Refer to Procedure 010-027 | QSB3.3 CM2250 EC | 2883647
Charge-Air Cooler | Refer to Procedure 010-027 | PowerGen QSX15 CM2250 ECF | 4310661
Charge-Air Cooler | Refer to Procedure 010-027 | PowerGen QSX15 CM2250 | 4310664
Charge-Air Cooler | Refer to Procedure 010-027 | ISB6.7 CM2350 B101 | 2883567
Charge-Air Cooler | Refer to Procedure 010-027 | ISL9 CM2350 L101 | 4310787
Charge-Air Cooler | Refer to Procedure 010-027 | ISX12 CM2350 X102 | 4310646
Charge-Air Cooler | Refer to Procedure 010-027 | ISX15 CM2350 X101 | 4310641
Charge-Air Cooler | Refer to Procedure 010-027 | QSB4.5 CM2250 B131 | 4388774
Charge-Air Cooler | Refer to Procedure 010-027 | QSB3.3 CM2250 B137 | 5411058
Air Intake Restriction | Refer to Procedure 010-031 | ISB6.7 CM2250 | 4022254
Air Intake Restriction | Refer to Procedure 010-031 | ISC8.3 and ISL9 CM2250 | 4022257
Air Intake Restriction | Refer to Procedure 010-031 | ISX CM2250 GX CM2250 | 4022250
Air Intake Restriction | Refer to Procedure 010-031 | ISX12/ISX11.9 CM2250 | 2883445
Air Intake Restriction | Refer to Procedure 010-031 | QSL9 CM2250 | 4022256
Air Intake Restriction | Refer to Procedure 010-031 | QSB6.7 CM2250 | 4022255
Air Intake Restriction | Refer to Procedure 010-031 | QSB6.7 CM2250 EC | 2883621
Air Intake Restriction | Refer to Procedure 010-031 | QSB3.3 CM2250 EC | 2883647
Air Intake Restriction | Refer to Procedure 010-031 | PowerGen QSX15 CM2250 ECF | 4310661
Air Intake Restriction | Refer to Procedure 010-031 | PowerGen QSX15 CM2250 | 4310664
Air Intake Restriction | Refer to Procedure 010-031 | ISB6.7 CM2350 B101 | 2883567
Air Intake Restriction | Refer to Procedure 010-031 | ISL9 CM2350 L101 | 4310787
Air Intake Restriction | Refer to Procedure 010-031 | ISX12 CM2350 X102 | 4310646
Air Intake Restriction | Refer to Procedure 010-031 | ISX15 CM2350 X101 | 4310641
Air Intake Restriction | Refer to Procedure 010-031 | QSB4.5 CM2250 B131 | 4388774
Air Intake Restriction | Refer to Procedure 010-031 | QSB3.3 CM2250 B137 | 5411058
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2250 | 4022254
Turbocharger | Refer to Procedure 010-033 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger | Refer to Procedure 010-033 | ISX CM2250 GX CM2250 | 4022250
Turbocharger | Refer to Procedure 010-033 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2250 | 4022256
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 | 4022255
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 EC | 2883621
Turbocharger | Refer to Procedure 010-033 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger | Refer to Procedure 010-033 | PowerGen QSX15 CM2250 | 4310664
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2350 B101 | 2883567
Turbocharger | Refer to Procedure 010-033 | ISL9 CM2350 L101 | 4310787
Turbocharger | Refer to Procedure 010-033 | ISX12 CM2350 X102 | 4310646
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2350 X101 | 4310641
Turbocharger, Variable Flow | Refer to Procedure 010-148 | QSB3.3 CM2250 EC | 2883647
Turbocharger, Variable Flow | Refer to Procedure 010-148 | QSB4.5 CM2250 B131 | 4388774
Turbocharger, Variable Flow | Refer to Procedure 010-148 | QSB3.3 CM2250 B137 | 5411058
Exhaust Restriction | Refer to Procedure 011-009 | ISB6.7 CM2250 | 4022254
Exhaust Restriction | Refer to Procedure 011-009 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Restriction | Refer to Procedure 011-009 | ISX CM2250 GX CM2250 | 4022250
Exhaust Restriction | Refer to Procedure 011-009 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Restriction | Refer to Procedure 011-009 | QSL9 CM2250 | 4022256
Exhaust Restriction | Refer to Procedure 011-009 | QSB6.7 CM2250 | 4022255
Exhaust Restriction | Refer to Procedure 011-009 | QSB6.7 CM2250 EC | 2883621
Exhaust Restriction | Refer to Procedure 011-009 | QSB3.3 CM2250 EC | 2883647
Exhaust Restriction | Refer to Procedure 011-009 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Restriction | Refer to Procedure 011-009 | PowerGen QSX15 CM2250 | 4310664
Exhaust Restriction | Refer to Procedure 011-009 | ISB6.7 CM2350 B101 | 2883567
Exhaust Restriction | Refer to Procedure 011-009 | ISL9 CM2350 L101 | 4310787
Exhaust Restriction | Refer to Procedure 011-009 | ISX12 CM2350 X102 | 4310646
Exhaust Restriction | Refer to Procedure 011-009 | ISX15 CM2350 X101 | 4310641
Exhaust Restriction | Refer to Procedure 011-009 | QSB4.5 CM2250 B131 | 4388774
Exhaust Restriction | Refer to Procedure 011-009 | QSB3.3 CM2250 B137 | 5411058
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX CM2250 GX CM2250 | 4022250
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2250 | 4022256
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2250 | 4022255
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB4.5 CM2250 B131 | 4388774
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX CM2250 GX CM2250 | 4022250
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX12/ISX11.9 CM2250 | 2883445
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX15 CM2350 X101 | 4310641
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISX12 CM2350 X102 | 4310646
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 CM2350 X102 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2350 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Exhaust Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Pressure Sensor | Refer to Procedure 019-376 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Pressure Sensor | Refer to Procedure 019-376 | ISX CM2250 GX CM2250 | 4022250
Exhaust Pressure Sensor | Refer to Procedure 019-376 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 | 4022256
Exhaust Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 | 4022255
Exhaust Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 EC | 2883621
Exhaust Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 | 4310664
Exhaust Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B101 | 2883567
Exhaust Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L101 | 4310787
Exhaust Pressure Sensor | Refer to Procedure 019-376 | ISX12 CM2350 X102 | 4310646
Exhaust Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2350 X101 | 4310641
Exhaust Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2250 B131 | 4388774
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2250 | 4022254
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX CM2250 GX CM2250 | 4022250
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2250 | 4022256
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 | 4022255
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 EC | 2883621
Turbocharger Speed Sensor | Refer to Procedure 019-390 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Speed Sensor | Refer to Procedure 019-390 | PowerGen QSX15 CM2250 | 4310664
Turbocharger Speed Sensor | Refer to Procedure 019-390 | 155-tr-isb13 | 2883567
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL9 CM2350 L101 | 4310787
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX12 CM2350 X102 | 4310646
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX15 CM2350 X101 | 4310641
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2250 | 4022254
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 | 4022256
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 | 4022255
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 EC | 2883621
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 | 4310664
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or high inactive counts of Fault Code 122, 123, 221, 222, 295, 595, 687, 691, 692, or 693?
STEP 2. | Check the barometric pressure sensor. |
 | STEP 2A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 51 mm-Hg [2in-Hg] of local barometric pressure?
STEP 3. | Check the exhaust manifold pressure sensor. |
 | STEP 3A. Check the exhaust manifold pressure sensor tube. | Exhaust manifold pressure sensor tube damaged, disconnected, or blocked?
 | STEP 3B. Monitor the exhaust manifold pressure sensor pressure with an electronic service tool. | Exhaust manifold pressure sensor pressure reading within specifications of with key ON and engine OFF?
 | STEP 3C. Monitor the exhaust manifold pressure sensor pressure with an electronic service tool. | Pressure change?
STEP 4. | Check the engine intake manifold pressure/temperature sensor and circuit. |
 | STEP 4A. Inspect the engine intake manifold pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 4B. Verify the sensor accuracy. | INSITE™ electronic service tool reading for intake manifold pressure 0 ±77 mm-Hg [0 ±3 in-Hg]?
 | STEP 4C. Check the circuit response. | Fault Code 123 active?
 | STEP 4D. Check the circuit response. | Fault Code 122 active?
 | STEP 4E. Check for a plugged engine intake manifold pressure/temperature sensor. | Tip of the sensor have soot or carbon buildup?
STEP 5. | Check the engine control module (ECM) and engine harness. |
 | STEP 5A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 123 active?
 | STEP 5C. Check the circuit response. | Fault Code 122 active?
STEP 6. | Check the air intake system for leaks. |
 | STEP 6A. Check the charge-air cooler for leaks. | Air leak present?
 | STEP 6B. Check the intake manifold inlet and connections for leaks. | Air leak present?
 | STEP 6C. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on the turbocharger blades?
 | STEP 6D. Check for a restricted charge-air cooler. | Within specifications?
STEP 7. | Check the turbocharger speed sensor. |
 | STEP 7A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 7B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
STEP 8. | Check for restriction. |
 | STEP 8A. Check exhaust restriction. | Exhaust restriction within specifications?
 | STEP 8B. Check the intake restriction. | Air intake restriction within specifications?
STEP 9. | Check ECM calibration and clear fault codes. |
 | STEP 9A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 9B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 122, 123, 221, 222, 295, 595, 687, 691, 692, or 693?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the barometric pressure sensor.

Guided Step 2A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger and compare the INSITE™ electronic service tool reading for barometric pressure to the local barometric pressure.

For the ISB6.7, ISC8.3, and ISL9 engines, use the following procedure. Refer to Procedure 019-466 in the Associated Procedures Table for specifications.

For the ISX12/ISX11.9 and ISX15 engines, use the following procedure. Refer to Procedure 019-004 in the Associated Procedures Table for specifications.

INSITE™ electronic service tool reading within 51-mm Hg [2 in-Hg] of local barometric pressure?
YES NO
No Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3A

Go to 9A

Guided Step 3 - Check the exhaust manifold pressure sensor.

Guided Step 3A - Check the exhaust manifold pressure sensor tube.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the exhaust manifold pressure sensor tube.

  • Make sure both ends of the tube are securely connected.
  • Inspect the tube for leaks or damage.
  • Inspect the tube for blockage.

Exhaust manifold pressure sensor tube damaged, disconnected, or blocked?
YES NO

Repair or replace the exhaust manifold pressure sensor tube.

  • Refer to Procedure 011-027 in Associated Procedures Table.

No Repair

Go to 9A

Go to 3B

Guided Step 3B - Monitor the exhaust manifold pressure sensor with an electronic service tool.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Engine OFF.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the exhaust manifold pressure sensor.

  • An exhaust ventilation system connected to the exhaust can cause the pressure sensor to read incorrectly. Make sure to remove any ventilation or vacuum equipment from the exhaust before reading the exhaust manifold pressure sensor value with INSITE™ electronic service tool.
  • Refer to Procedure 019-376 in the Associated Procedures Table.

Exhaust manifold pressure sensor pressure reading within specifications of with key ON and engine OFF?
YES NO
No Repair

Replace the exhaust manifold pressure sensor.

  • Refer to Procedure 019-376 in the Associated Procedures Table.

Go to 3C

Go to 9A

Guided Step 3C - Monitor the exhaust manifold pressure sensor with an electronic service tool.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Operate engine.
  • Connect INSITE™ electronic service tool.

Action

Check for a change in value.

  • Use INSITE™ electronic service tool to monitor the exhaust manifold pressure sensor.
  • Perform a snap acceleration.

Pressure change?
YES NO
No Repair

Replace the exhaust manifold pressure sensor.

  • Refer to Procedure 019-376 in the Associated Procedures Table.

Go to 4A

Go to 9A

Guided Step 4 - Check the engine intake manifold pressure/temperature sensor and circuit.

Guided Step 4A - Inspect the engine intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold pressure/temperature sensor connector and the engine harness connector for signs of the following:

  • Loose connector.
  • Corroded pins
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the intake manifold pressure/temperature sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness or damaged intake manifold pressure/temperature sensor. Use the circuit diagram or wiring diagram for all engine harness interconnections.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-159 in the Associated Procedures Table.

No Repair

Go to 9A

Go to 4B

Guided Step 4B - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Turn engine OFF.

Action

With the keyswitch ON and engine OFF, the intake manifold pressure must read 0 ±77 mm-Hg [0 ±3 in-Hg].

  • Start INSITE™ electronic service tool Data Monitor/Logger and read the INSITE™ electronic service tool reading for intake manifold pressure.

INSITE™ electronic service tool reading for intake manifold pressure is 0 ±77 mm-Hg [0 ±3 in-Hg]?
YES | NO
No Repair | No Repair

Go to 6A

Go to 4C

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES | NO
No Repair | No Repair

Go to 4D

Go to 5A

Guided Step 4D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold pressure +5 volt SUPPLY pin and the engine intake manifold pressure SIGNAL pin at the engine intake manifold pressure/temperature connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES | NO
No Repair | No Repair

Go to 4E

Go to 5A

Guided Step 4E - Check for a plugged engine intake manifold pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.

Action

Remove the intake manifold pressure/temperature sensor. Inspect the tip of the sensor for soot or carbon buildup.

  • Refer to Procedure 019-159 in the Associated Procedures Table.

Tip of the sensor have soot or carbon buildup?
YES NO

Use compressed air to remove the soot or carbon build up.

  • Refer to Procedure 019-159 in the Associated Procedures Table.

An in-range malfunction of the intake manifold pressure/temperature sensor has been detected.

Replace the engine intake manifold pressure/temperature sensor.

  • Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 9A

Go to 9A

Guided Step 5 - Check the ECM and engine harness.

Guided Step 5A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector. Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 9A

Go to 5B

Guided Step 5B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5C

Go to 9A

Guided Step 5C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold pressure +5 volt SUPPLY pin and engine intake manifold pressure SIGNAL pin at the engine control module engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 9A

Go to 9A

Guided Step 6 - Check the air intake system for leaks.

Guided Step 6A - Check the charge-air cooler for leaks.

Conditions

  • Operate engine.

Action

Check the charge-air cooler and connections for air leaks.

Air leak present?
YES NO

Repair or replace the leaking component. Refer to Procedure 010-027 in the Associated Procedures Table.

No Repair

Go to 9A

Go to 6B

Guided Step 6B - Check the intake manifold inlet and connections for leaks.

Conditions

  • Operate the engine.

Action

Check for air leaks in connections and hoses between the turbocharger and intake manifold inlet.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Air leak present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 9A

Go to 6C

Guided Step 6C - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

  • Refer to Procedure 010-033 in the Associated Procedures Table.
  • For QSB3.3 engines: Refer to Procedure 010-148 in the Associated Procedures Table.

Damage or wear found on the turbocharger blades?
YES NO

Refer to Procedure 010-033 in the Associated Procedures Table.

For QSB3.3 engines: Refer to Procedure 010-148 in the Associated Procedures Table.

No Repair

Go to 9A

Go to 6D

Guided Step 6D - Check for a restricted charge-air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine.

Action

Check the pressure differential across the charge-air cooler.

Refer to Procedure 010-027 in the Associated Procedures Table.

Differential pressure across the charge-air cooler within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler, if necessary.

Go to 7A

Go to 9A

Guided Step 7 - Check the turbocharger speed sensor.

Guided Step 7A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Only perform this step if the engine is equipped with a turbocharger speed sensor. Inspect the turbocharger or refer to the engine wiring diagram to determine if the engine has a turbocharger speed sensor. If no sensor is present, skip to Step 7.

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 9A

Go to 7B

Guided Step 7B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check the turbocharger speed sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor is damaged.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 8A

Go to 9A

Guided Step 8 - Check for restriction.

Guided Step 8A - Check exhaust restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check exhaust restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO
No Repair

Repair or replace the restricted components.

Go to 8B

Go to 9A

Guided Step 8B - Check the intake restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications?
YES NO
No Repair

Repair or replace the restricted component.

Go to 9A

Go to 9A

Guided Step 9 - Check ECM calibration and clear fault codes.

Guided Step 9A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 9B

Go to 9B

Guided Step 9B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-May-2016


FAULT CODE 3168 - Aftertreatment Diesel Particulate Filter (DPF) System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Particulate Filter (DPF) | Refer to Procedure 011-041 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter (DPF) | Refer to Procedure 011-041 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter (DPF) | Refer to Procedure 011-041 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter (DPF) | Refer to Procedure 011-041 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure Sensor | Refer to Procedure 019-443 | GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1879, 1881, or 1883 active?
STEP 2. | Inspect the aftertreatment DPF differential pressure sensor and tubes. |
 | STEP 2A. Verify the aftertreatment DPF differential pressure sensor accuracy. | Aftertreatment DPF differential pressure sensor reading 0 ± 3 kPa [0 ± 0.89 in Hg] with keyswitch ON and the engine OFF?
 | STEP 2B. Check the aftertreatment DPF differential pressure sensor tubes. | Aftertreatment DPF differential pressure sensor tubes are installed correctly?
STEP 3. | Check the presence of the aftertreatment DPF. |
 | STEP 3A. Inspect the aftertreatment DPF. | Tampering or damage to the aftertreatment DPF?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1879, 1881, or 1883 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Inspect the aftertreatment DPF differential pressure sensor and tubes.

Guided Step 2A - Verify the aftertreatment DPF differential pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy.

  • Monitor the aftertreatment DPF differential pressure sensor reading with INSITE™ electronic service tool.

Aftertreatment DPF differential pressure sensor reading 0 ± 3 kPa [0 ± 0.89 in Hg] with keyswitch ON and the engine OFF?
YES NO
No Repair

  • Check for a short circuit from the SIGNAL pin of the aftertreatment DPF differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.
  • If no short circuit is found, replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the aftertreatment DPF differential pressure sensor tubes.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DPF differential pressure sensor tubes for the following:

  • Leaks or cracks in the differential pressure sensor tubes
  • Loose fittings on the differential pressure sensor tubes
  • Missing or broken differential pressure sensor tubes
  • Plugged tubes
  • Make sure the differential pressure tubes are installed correctly. It is possible the differential pressure tubes are connected backwards at the rubber tubes at the sensor connection. Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor tubes are installed correctly?
YES NO
No Repair

Repair or replace the aftertreatment DPF differential pressure sensor tubes. Refer to Procedure 011-047 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the presence of the aftertreatment DPF.

Guided Step 3A - Inspect the aftertreatment DPF.

Conditions

  • Turn keyswitch OFF
  • Remove the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Action

Inspect the aftertreatment DPF.

  • Inspect the aftertreatment system to determine if the aftertreatment DPF has been tampered with, has been removed from the exhaust system, or has been damaged.

Refer to Procedure 011-041 in the Associated Procedures Table.

Tampering or damage to the aftertreatment DPF?
YES NO

Install the correct aftertreatment system for the vehicle. Refer to Procedure 011-041 in the Associated Procedures Table.

Continue inspecting the aftertreatment systems for signs of tampering.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jun-2012


FAULT CODE 3243 - Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Thermostat | Refer to Procedure 008-013 | ISX CM2250 GX CM2250 | 4022250
Coolant Thermostat | Refer to Procedure 008-013 | ISX12/ISX11.9 CM2250 | 2883445
Coolant Thermostat | Refer to Procedure 008-013 | QSL9 CM2250 | 4022256
Coolant Thermostat | Refer to Procedure 008-013 | QSB6.7 CM2250 | 4022255
Coolant Thermostat | Refer to Procedure 008-013 | ISB6.7 CM2350 B101 | 2883567
Coolant Thermostat | Refer to Procedure 008-013 | ISL9 CM2350 L101 | 4310787
Coolant Thermostat | Refer to Procedure 008-013 | ISX12 CM2350 X102 | 4310646
Coolant Thermostat | Refer to Procedure 008-013 | ISX15 CM2350 X101 | 4310641
Coolant Thermostat | Refer to Procedure 008-013 | ISB4.5 CM2350 B104 | 4332646
Coolant Thermostat | Refer to Procedure 008-013 | ISB6.7 CM2350 B103 | 4332641
Coolant Thermostat | Refer to Procedure 008-013 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310847
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 144, 145, or 334 active?
STEP 2. | Check engine fan operation. |
 | STEP 2A. Verify proper operation of the engine cooling fan. | Engine fan operating correctly?
STEP 3. | Check the thermostat. |
 | STEP 3A. Verify proper thermostat operation. | Engine thermostat operating correctly and not leaking or stuck open?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144, 145, or 334 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check engine fan operation.

Guided Step 2A - Verify proper operation of the engine cooling fan.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool
  • Start the engine and run at low idle.

Action

Check engine cooling fan operation.

  • Use INSITE™ electronic service tool to perform the Fan Override Test.
  • Verify that the fan operates correctly, is not stuck on, and turns ON and OFF as commanded.

Engine fan operating correctly?
YES NO
No Repair

Troubleshoot and repair the cause of the malfunctioning engine fan operation.

Inspect engine fan wiring and OEM harness for short or open circuits. Check engine fan switches for proper operation.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the thermostat.

Guided Step 3A - Verify proper thermostat operation.

Conditions

  • Turn keyswitch OFF.

Action

Check for a leaking or stuck open thermostat.

  • Make sure that the thermostat is not stuck open or leaking, and that it opens at the correct coolant temperature. Refer to Procedure 008-013 in the Associated Procedures Table.

Engine thermostat operating correctly and not leaking or stuck open?

YES NO

A malfunctioning coolant temperature sensor has been detected.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Associated Procedures Table.

Replace the malfunctioning thermostat. Refer to Procedure 008-013 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Aug-2014


FAULT CODE 3245 - Aftertreatment Diesel Particulate Filter System - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISB6.7 CM2250 | 4022254
Injector | Refer to Procedure 006-026 | ISC8.3 and ISL9 CM2250 | 4022257
Injector | Refer to Procedure 006-026 | ISX CM2250 GX CM2250 | 4022250
Injector | Refer to Procedure 006-026 | ISX12/ISX11.9 CM2250 | 2883445
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Injector | Refer to Procedure 006-026 | QSX11.9 CM2250 ECF | 2883561
Injector | Refer to Procedure 006-026 | QSX15 CM2250 ECF | 2883557
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3313, 3314, 3315, 3316, 3317, 3318, 3319, 3321, or 3322 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check the aftertreatment fuel injector, if equipped. |
 | STEP 4A. Check the operation of the aftertreatment fuel injector. | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Injector Leak Test?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment temperature sensors.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3313, 3314, 3315, 3316, 3317, 3318, 3319, 3321, or 3322 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to perform the Cylinder Cutout Test.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a damaged injector.

Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Appropriate fault code troubleshooting tree

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the aftertreatment fuel injector, if equipped.

Guided Step 4A - Check the operation of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Use the following procedure for information on the aftertreatment fuel injector leak test. Refer to Procedure 011-054 in the Associated Procedures Table.
  • ( If the engine does not have an aftertreatment fuel injector, skip to Step 5A.)

Action

Check for fuel leaking from the aftertreatment injector.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Fuel Injector Leak Test.
  • Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Injector Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5 - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Sep-2015


FAULT CODE 3251 - Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISB6.7 CM2250 | 4022254
Injector | Refer to Procedure 006-026 | ISC8.3 and ISL9 CM2250 | 4022257
Injector | Refer to Procedure 006-026 | ISX CM2250 GX CM2250 | 4022250
Injector | Refer to Procedure 006-026 | ISX12/ISX11.9 CM2250 | 2883445
Injector | Refer to Procedure 006-026 | QSX11.9 CM2250 ECF | 2883561
Injector | Refer to Procedure 006-026 | QSX15 CM2250 ECF | 2883557
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 ECF | 4310661
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISB6.7 CM2250 | 4022254
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISC8.3 and ISL9 CM2250 | 4022257
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISX CM2250 GX CM2250 | 4022250
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISX12/ISX11.9 CM2250 | 4022250
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSX11.9 CM2250 ECF | 2883561
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSX15 CM2250 ECF | 2883557
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2250 | 4022254
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Fuel Injection Performance Test | Refer to Procedure 014-014 | ISC8.3 and ISL9 CM2250 | 4022257
Fuel Injection Performance Test | Refer to Procedure 014-014 | ISX CM2250/GX CM2250 | 4022250
Fuel Injection Performance Test | Refer to Procedure 014-014 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 1963, 1925, 3313, 3314, or 3315 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the intake air system. |
 | STEP 2A. Inspect the intake air system for leaks. | Air leak detected?
STEP 3. | Check the fuel system. |
 | STEP 3A. Perform the Fuel Injector Performance Test | Fuel Injector Performance Test identify malfunctioning injector(s)?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Check the aftertreatment fuel injector. |
 | STEP 5A. Check the operation of the aftertreatment fuel injector, if equipped. | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1963, 1925, 3313, 3314, or 3315 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness.Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the intake air system.

Guided Step 2A - Inspect the intake air system for leaks.

Conditions

  • Start the engine and run at high idle.

Action

Check hoses, clamps, and pipes for leaks.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Air leak detected?
YES NO

Repair or replace any damaged components. Refer to Procedure 010-024 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Perform the Fuel Injector Performance Test

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Use INSITE™ electronic service tool to run the Fuel Injector Performance Test (IPT). Refer to Procedure 14-014 in Section 14 in the Associated Procedures Table.

Fuel Injector Performance Test identify malfunctioning injector(s)?
YES NO

Replace the malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to the appropriate troubleshooting tree

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

  • Inspect for a sign of moisture in the turbocharger exhaust outlet.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check the aftertreatment fuel injector.

Guided Step 5A - Check the operation of the aftertreatment fuel injector, if equipped.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

(If the engine does not have an aftertreatment fuel injector, skip to Step 5A.)

Action

Check the operation of the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Shutoff Valve and Injector Override Test.
  • Perform the Aftertreatment Fuel Injector Leak Test. Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel found leaking during the Aftertreatment Fuel Injector Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 014-013 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 011-036 in the Associated Procedures Table.

Perform a Snap Acceleration Test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

If black smoke is present, inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 3253 - Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISB6.7 CM2250 | 4022254
Injector | Refer to Procedure 006-026 | ISC8.3 and ISL9 CM2250 | 4022257
Injector | Refer to Procedure 006-026 | ISX CM2250 GX CM2250 | 4022250
Injector | Refer to Procedure 006-026 | ISX12/ISX11.9 CM2250 | 2883445
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Injector | Refer to Procedure 006-026 | QSX11.9 CM2250 ECF | 2883561
Injector | Refer to Procedure 006-026 | QSX15 CM2250 ECF | 2883557
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2250 | 4022254
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Engine Brake Functional Test | Refer to Procedure 014-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Brake Functional Test | Refer to Procedure 014-019 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 1963, 1925, 3316, 3317, or 3318 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Run the Fuel Injector Performance Test. | Fuel Injector Performance Test identify malfunctioning injector(s)?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Perform the Fuel Injector Performance Test. | Fuel Injector Performance Test identify malfunctioning injector(s)?
STEP 4. | Check the aftertreatment fuel injector. |
 | STEP 4A. Check the operation of the aftertreatment fuel injector, if equipped. | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 5A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment DOC for cracks in the cell wall. | Cracks found in cell walls?
STEP 6. | Check engine brake operation. |
 | STEP 6A. Check the engine brakes for proper operation. | Engine brakes functioning properly?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1963, 1925, 3316, 3317, or 3318 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Run the Fuel Injector Performance Test.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to run the Fuel Injector Performance Test. Refer to Procedure 014-014 in the Associated Procedures Table.

Fuel Injector Performance Test identify malfunctioning injector(s)?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the malfunctioning component identified by Procedure 014-014 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-014 in the Associated Procedures Table.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the aftertreatment fuel injector.

Guided Step 4A - Check the operation of the aftertreatment fuel injector, if equipped.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

(If the engine does not have an aftertreatment fuel injector, skip to Step 5A.)

Action

Check the operation of the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Shutoff Valve and Injector Override Test.
  • Perform the Aftertreatment Fuel Injector Leak Test. Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel found leaking during the Aftertreatment Fuel Injector Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 014-013 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 011-036 in the Associated Procedures Table.

Perform a Snap Acceleration Test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

If black smoke is present, inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment DOC.

Guided Step 5A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell wall.

Refer to Procedure 011-049 in the Associated Procedures Table.

Cracks found in cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check engine brake operation.

Guided Step 6A - Check the engine brakes for proper operation.

Conditions

  • Engine at operating temperature.

Action

Perform the Engine Brake Functional Test.

  • Refer to Procedure 014-019 in the Associated Procedures Table.

Engine brakes functioning properly?
YES NO
No Repair

Repair or replace the malfunctioning component identified by the Engine Brake Functional Test. Refer to Procedure 014-019 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Sep-2015


FAULT CODE 3254 - Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISB6.7 CM2250 | 4022254
Injector | Refer to Procedure 006-026 | ISC8.3 and ISL9 CM2250 | 4022257
Injector | Refer to Procedure 006-026 | ISX CM2250 GX CM2250 | 4022250
Injector | Refer to Procedure 006-026 | ISX12/ISX11.9 CM2250 | 2883445
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Injector | Refer to Procedure 006-026 | QSX11.9 CM2250 ECF | 2883561
Injector | Refer to Procedure 006-026 | QSX15 CM2250 ECF | 2883557
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2250 | 4022254
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Fuel Injection Performance Test | Refer to Procedure 014-014 | ISC8.3 and ISL9 CM2250 | 4022257
Fuel Injection Performance Test | Refer to Procedure 014-014 | ISX CM2250/GX CM2250 | 4022250
Fuel Injection Performance Test | Refer to Procedure 014-014 | ISX12/ISX11.9 CM2250 | 2883445
Engine Brake Functional Test | Refer to Procedure 014-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Brake Functional Test | Refer to Procedure 014-019 | ISX12/ISX11.9 CM2250 | 2883445
Dynamic Engine System Analysis | Refer to Procedure 014-020 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 1963, 1925, 3316, 3317, or 3318 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Run the Fuel Injector Performance Test. | Fuel Injector Performance Test identify malfunctioning injector(s)?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check the aftertreatment fuel injector. |
 | STEP 4A. Check the operation of the aftertreatment fuel injector, if equipped. | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 5A. Check the aftertreatment diesel oxidation catalyst (DOC) for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment DOC for cracks in the cell wall. | Cracks found in the cell walls?
STEP 6. | Check engine brake operation. |
 | STEP 6A. Check the engine brakes for proper operation. | Engine brakes functioning properly?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1963, 1925, 3316, 3317, or 3318 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Run the Fuel Injector Performance Test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

Use INSITE™ electronic service tool to run the Fuel Injector Performance Test. Refer to Procedure 014-014 in the Associated Procedures Table.

Fuel Injector Performance Test identify malfunctioning injector(s)?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to the appropriate troubleshooting tree.

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the aftertreatment fuel injector.

Guided Step 4A - Check the operation of the aftertreatment fuel injector, if equipped.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

If the engine does not have an aftertreatment fuel injector, skip to Step 5A.

Action

Check the operation of the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the aftertreatment shutoff valve and injector override test.
  • Perform the Aftertreatment Fuel Injector Leak Test. Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel found leaking during the Aftertreatment Fuel Injector Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Perform a Snap Acceleration Test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

If black smoke is present, inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment DOC.

Guided Step 5A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment diesel oxidation catalyst for soot accumulation and/or face plugging.

Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell wall.

Refer to Procedure 011-049 in the Associated Procedures Table.

Cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check engine brake operation.

Guided Step 6A - Check the engine brakes for proper operation.

Conditions

  • Engine at operating temperature.

Action

Perform the Engine Brake Functional Test.

  • Refer to Procedure 014-019 in the Associated Procedures Table.

Engine brake functioning properly?
YES NO
No Repair

Repair or replace the malfunctioned component identified by the engine brake functional test. Refer to Procedure 014-019 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2016


FAULT CODE 3255 - Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISB6.7 CM2250 | 4022254
Injector | Refer to Procedure 006-026 | ISC8.3 and ISL9 CM2250 | 4022257
Injector | Refer to Procedure 006-026 | ISX CM2250 GX CM2250 | 4022250
Injector | Refer to Procedure 006-026 | ISX12/ISX11.9 CM2250 | 2883445
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Injector | Refer to Procedure 006-026 | QSX11.9 CM2250 ECF | 2883561
Injector | Refer to Procedure 006-026 | QSX15 CM2250 ECF | 2883557
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2250 | 4022254
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Engine Brake Functional Test | Refer to Procedure 014-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Brake Functional Test | Refer to Procedure 014-019 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 1963, 1925, 3321, 3319, or 3322 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Run the Fuel Injection Performance Test. | Fuel Injection Performance Test identify malfunctioning injector(s)?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check the aftertreatment fuel injector, if equipped. |
 | STEP 4A. Check the operation of the aftertreatment fuel injector. | Fuel found leaking during the Aftertreatment Fuel Injection Leak Test?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 5A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment DOC for cracks in the cell wall. | Cracks found in cell walls?
STEP 6. | Check engine brake operation. |
 | STEP 6A. Check the engine brakes for proper operation. | Engine brakes functioning properly?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1963, 1925, 3321, 3319, or 3322 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Run the Fuel Injection Performance Test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

Use INSITE™ electronic service tool to run the Fuel Injection Performance Test. Refer to Procedure 14-014 in Section 14.

Fuel Injection Performance Test identify malfunctioning injector(s)?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the malfunctioning component identified by Procedure 014-014 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 14-014 in Section 14.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the aftertreatment fuel injector, if equipped.

Guided Step 4A - Check the operation of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • (If the engine does not have an aftertreatment fuel injector, skip to Step 5A.)

Action

Check the operation of the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the aftertreatment shutoff valve and injector override test.
  • Perform the Aftertreatment Fuel Injection Leak Test. Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel found leaking during the Aftertreatment Fuel Injection Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 014-013 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 011-036 in the Associated Procedures Table.

Perform a Snap Acceleration Test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

If black smoke is present, inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment DOC.

Guided Step 5A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell wall. Refer to Procedure 011-049 in the Associated Procedures Table.

Cracks found in cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check engine brake operation.

Guided Step 6A - Check the engine brakes for proper operation.

Conditions

  • Engine at operating temperature.

Action

Perform the Engine Brake Functional Test.

  • Refer to Procedure 014-019 in the Associated Procedures Table.

Engine brakes functioning properly?
YES NO
No Repair

Repair or replace the malfunctioned component identified by the Engine Brake Functional Test. Refer to Procedure 014-019 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Sep-2015


FAULT CODE 3256 - Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISB6.7 CM2250 | 4022254
Injector | Refer to Procedure 006-026 | ISC8.3 and ISL9 CM2250 | 4022257
Injector | Refer to Procedure 006-026 | ISX CM2250 GX CM2250 | 4022250
Injector | Refer to Procedure 006-026 | ISX12/ISX11.9 CM2250 | 2883445
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Injector | Refer to Procedure 006-026 | QSX11.9 CM2250 ECF | 2883561
Injector | Refer to Procedure 006-026 | QSX15 CM2250 ECF | 2883557
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2250 | 4022254
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Engine Brake Functional Test | Refer to Procedure 014-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Brake Functional Test | Refer to Procedure 014-019 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 1963, 1925, 3321, 3319, or 3322 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Run the Fuel Injector Performance Test. | Fuel Injector Performance Test identify malfunctioning injector(s)?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check the aftertreatment fuel injector, if equipped. |
 | STEP 4A. Check the operation of the aftertreatment fuel injector. | Fuel found leaking during the Aftertreatment Fuel Injector Leak Test?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 5A. Check the aftertreatment diesel oxidation catalyst (DOC) for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment DOC for cracks in the cell wall. | Cracks found in cell walls?
STEP 6. | Check engine brake operation. |
 | STEP 6A. Check the engine brakes for proper operation. | Engine brakes functioning properly?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1963, 1925, 3321, 3319, or 3322 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Run the Fuel Injector Performance Test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

Use INSITE™ electronic service tool to run the Fuel Injector Performance Test. Refer to Procedure 014-014 in Section 14.

Fuel Injector Performance Test identify malfunctioning injector(s)?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the malfunctioned component identified by Procedure 014-014 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the aftertreatment fuel injector, if equipped.

Guided Step 4A - Check the operation of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

(If the engine does not have an aftertreatment fuel injector, skip to Step 5A.)

Action

Check the operation of the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the aftertreatment shutoff valve and injector override test.
  • Perform the Aftertreatment Fuel Injector Leak Test. Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel found leaking during the Aftertreatment Fuel Injector Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 014-013 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 011-036 in the Associated Procedures Table.

Perform a Snap Acceleration Test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

If black smoke is present, inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment DOC.

Guided Step 5A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

Are more than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell wall. Refer to Procedure 011-049 in the Associated Procedures Table.

Cracks found in cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check engine brake operation.

Guided Step 6A - Check the engine brakes for proper operation.

Conditions

  • Engine at operating temperature.

Action

Perform the Engine Brake Functional Test.

  • Refer to Procedure 014-019 in the Associated Procedures Table.

Engine brakes functioning properly?
YES NO
No Repair

Repair or replace the malfunctioned component identified by the engine brake functional test. Refer to Procedure 014-019 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Sep-2015


FAULT CODE 3311- Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2250 | 4022254
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Injector Performance Test | Refer to Procedure 014-014 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 1963, 1925, 3316, 3317, or 3318 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Run the Fuel Injector Performance Test. | Fuel Injector Performance Test identify malfunctioning injector(s)?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check the aftertreatment fuel injector. |
 | STEP 4A. Check the operation of the aftertreatment fuel injector, if equipped. | Fuel found leaking during the Aftertreatment Fuel Injector Leak Test?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 5A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 6. | Check engine brake operation. |
 | STEP 6A. Check the engine brakes for proper operation. | Engine brakes function properly?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1963, 1925, 3316, 3317, or 3318 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment exhaust gas temperature sensors while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness.

  • Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors.

  • Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Run the Fuel Injector Performance Test.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to run the Fuel Injector Performance Test. Refer to Procedure 014-014 in the Associated Procedures Table.

Fuel Injector Performance Test identify malfunctioning injector(s)?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the malfunctioning component identified. Refer to Procedure 014-014 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage.

  • Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. See equipment manufacturer service information.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage.

  • Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the aftertreatment fuel injector.

Guided Step 4A - Check the operation of the aftertreatment fuel injector, if equipped.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

(If the engine does not have an aftertreatment fuel injector, skip to Step 5A.)

Action

Check the operation of the aftertreatment injector.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Shutoff Valve and Injector Override Test.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel found leaking during the Aftertreatment Fuel Injector Leak Test?
YES NO

Replace the aftertreatment fuel injector.

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage.

  • Refer to Procedure 011-036 in the Associated Procedures Table.

Perform a Snap Acceleration Test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

If black smoke is present, inspect the aftertreatment system for possible damage.

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 5A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment diesel oxidation catalyst for soot accumulation and/or face plugging.
  • Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst.

  • Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment diesel oxidation catalyst.

  • Check for cracks in the aftertreatment diesel oxidation catalyst cell wall.
  • Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst.

  • Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check engine brake operation.

Guided Step 6A - Check the engine brakes for proper operation.

Conditions

  • Run engine at operating temperature.

Action

Perform the Engine Brake Functional Test.

  • Refer to Procedure 014-019 in the Associated Procedures Table.

Engine brakes function properly?
YES NO
No Repair

Repair or replace the component identified by the engine brake functional test. Refer to Procedure 014-019 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 3312 - Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2250 | 4022254
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Fuel Injector Performance Test | Refer to Procedure 014-014 | ISX CM2250 GX CM2250 | 4022250
Engine Brake Functional Test | Refer to Procedure 014-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Brake Functional Test | Refer to Procedure 014-019 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system |
 | STEP 1A. Check for active fault codes. | Fault Code 1925, 1963, 3319, 3321, or 3322 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Run the Fuel Injection Performance Test. | Fuel Injection Performance Test identify malfunctioning injector(s)?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check the aftertreatment fuel injector, if equipped. |
 | STEP 4A. Check the operation of the aftertreatment fuel injector. | Fuel found leaking during the Aftertreatment Fuel Injector Leak Test?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 5A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 6. | Check engine brake operation. |
 | STEP 6A. Check the engine brake for proper operation. | Engine brakes function properly?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1925, 1963, 3319, 3321, or 3322 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with INSITE™ electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Run the Fuel Injection Performance Test.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to run the Fuel Injector Performance Test. Refer to Procedure 014-014 in the Associated Procedures Table.

Fuel Injection Performance Test identify malfunctioning injector(s)?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the malfunctioning component. Refer to Procedure 014-014 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. See equipment manufacturer service information.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the aftertreatment fuel injector, if equipped.

Guided Step 4A - Check the operation of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

(If the engine does not have an aftertreatment fuel injector, skip to Step 5A.)

Action

Check the operation of the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Fuel Shutoff Valve and Injector Override Test.
  • Perform the Aftertreatment Fuel Injector Leak Test. Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel found leaking during the Aftertreatment Fuel Injector Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Perform a Snap Acceleration Test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

If black smoke is present, inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 5A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment diesel oxidation catalyst.

  • Check the intake face of the aftertreatment diesel oxidation catalyst for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment diesel oxidation catalyst.

  • Check for cracks in the aftertreatment diesel oxidation catalyst cell wall. Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the engine brake operation.

Guided Step 6A - Check the engine brakes for proper operation.

Conditions

  • Run engine at operating temperature.

Action

Perform the Engine Brake Functional Test.

  • Refer to Procedure 014-019 in the Associated Procedures Table.

Engine brakes function properly?
YES NO
No Repair

Repair or replace the component identified by the engine brake functional test. Refer to Procedure 014-019 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Sep-2015


FAULT CODE 3313 - Aftertreatment Diesel Oxidation Catalyst (DOC) Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source.

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module (ECM) | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISB6.7 CM2250 | 4022254
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSL9 CM2250 | 4022256
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSB6.7 CM2250 | 4022255
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX15 CM2250 ECF | 2883557
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSB6.7 CM2250 | 4022255
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSL9 CM2250 | 4022256

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 3313 inactive?
STEP 2. | Check the aftertreatment diesel oxidation catalyst (DOC) intake temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DOC intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3314 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3313 active?
STEP 3. | Check the aftertreatment DPF temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment DPF temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DPF temperature sensor interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module. | Greater than 100k ohms?
STEP 4. | Check the aftertreatment interface harness if equipped. |
 | STEP 4A. Inspect the aftertreatment interface harness. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the aftertreatment interface harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the aftertreatment interface harness. | Greater than 100k ohms?
STEP 5. | Check the ECM and OEM harness. |
 | STEP 5A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 5C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3313 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3313 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DOC intake temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DOC intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the interface module and aftertreatment DOC intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor from the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3314 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DOC intake temperature sensor to the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE ™ electronic service tool to read the active fault codes.

–

Fault Code 3313 active?
YES NO

Replace the aftertreatment DOC intake temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 6A

Go to 6A

Guided Step 3 - Check the aftertreatment DPF temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment DPF temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DPF temperature sensor interface module.

Clean the connector and pins if possible.

Replace the interface module if the pins can not be cleaned. Refer to Procedure 019-462 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment DPF temperature sensor interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module. Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module. Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the aftertreatment interface harness if equipped.

Guided Step 4A - Inspect the aftertreatment interface harness.

Conditions

  • If the engine is not equipped with an aftertreatment interface harness, proceed to Step 5A.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment interface harness.

Clean the connector and pins if possible.

Replace the interface harness if the pins can not be cleaned. Refer to Procedure 019-477 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatmet interface harness.

Replace the aftertreatment interface harness. Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-pin short circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface harness to all pins in all other connectors of the interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness. Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and OEM harness.

Guided Step 5A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DOC intake temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the aftertreatment DOC intake temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3313 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 3314 - Aftertreatment Diesel Oxidation Catalyst (DOC) Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX15 CM2250 | 4022250
Engine Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module (ECM) | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSB6.7 CM2250 | 4022255
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX15 CM2250 ECF | 2883557
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSB6.7 CM2250 | 4022255
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSL9 CM2250 | 4022256

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 3314 inactive?
STEP 2. | Check the aftertreatment diesel oxidation catalyst intake temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DOC intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3313 active and Fault Code 3314 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3314 active?
STEP 3. | Check the aftertreatment DPF temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment DPF temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DPF temperature sensor interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module. | Greater than 100k ohms?
STEP 4. | Check the aftertreatment interface harness, if equipped. |
 | STEP 4A. Inspect the aftertreatment interface harness. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the aftertreatment interface harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the aftertreatment interface harness. | Greater than 100k ohms?
STEP 5. | Check the ECM and OEM harness. |
 | STEP 5A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 5B-1. Check for an open circuit in the OEM harness. |
 | STEP 5C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3314 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3314 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DOC intake temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DOC intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the interface module and aftertreatment DOC intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor from the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment DOC intake temperature SIGNAL pin and the aftertreatment DOC intake temperature RETURN pin at the sensor connector of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3313 active and Fault Code 3314 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DOC intake temperature sensor to the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3314 active?
YES NO

A damaged aftertreatment DOC intake temperature sensor has been detected.

Replace the aftertreatment DOC intake temperature sensor.

  • Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 6A

Go to 6A

Guided Step 3 - Check the aftertreatment DPF temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or the aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment DPF temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DPF temperature sensor interface module.

Clean the connector and pins, if possible.

Replace the interface module if the pins cannot be cleaned.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or the aftertreatment interface harness if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment DPF temperature sensor interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or the aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the aftertreatment interface harness if equipped.

Guided Step 4A - Inspect the aftertreatment interface harness.

Conditions

  • If the engine is not equipped with an aftertreatment interface harness, proceed to Step 5A.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment interface harness.

Clean the connector and pins, if possible.

Replace the interface harness if the pins can not be cleaned.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatmet interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-pin short circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface harness to all pins in all other connectors of the interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and OEM harness.

Guided Step 5A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DOC intake temperature sensor RETURN pin and the OEM harness aftertreatment DOC intake temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5B-1

Go to 6A

Guided Step 5B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness if equipped) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DOC intake temperature sensor SIGNAL pin and the OEM harness aftertreatment DOC intake temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DOC intake temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3314 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 1A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Sep-2013


FAULT CODE 3315 - Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISB6.7 CM2250 | 4022254
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSL9 CM2250 | 4022256
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSB6.7 CM2250 | 4022255
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX15 CM2250 ECF | 2883557
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSB6.7 CM2250 | 4022255
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSL9 CM2250 | 4022256

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 3313 or 3314 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the aftertreatment diesel oxidation catalyst (DOC) intake temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DOC intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3314 active?
 | STEP 2C. Check the circuit response. | Fault Code 3313 active?
STEP 3. | Check the aftertreatment diesel particulate filter (DPF) temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment DPF temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DPF temperature sensor interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module. | Greater than 100K ohms?
STEP 4. | Check the aftertreatment interface harness, if equipped. |
 | STEP 4A. Inspect the aftertreatment interface harness. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the aftertreatment interface harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the aftertreatment interface harness. | Greater than 100k ohms?
STEP 5. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 5A. Inspect the ECM and OEM harness connectors pins. | Dirty or damaged pins?
 | STEP 5B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 5C. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 5D. Check for an open circuit in the OEM harness | Less than 10 ohms?
 | STEP 5D-1. Check for an open circuit in the OEM harness |
STEP 6. | Inspect the aftertreatment DOC. |
 | STEP 6A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the inlet face completely blocked by soot?
 | STEP 6B. Inspect the aftertreatment DOC for cracks in the cell walls. | Any cracks found in the cell walls?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3313 or 3314 active?
YES | NO
No Repair | No Repair

Fault Code 3313 or 3314 troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment exhaust gas temperature sensors while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel oxidation catalyst (DOC) intake temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DOC intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the interface module and aftertreatment DOC intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor from the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3314 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor from the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment DOC intake temperature SIGNAL pin and the aftertreatment DOC intake temperature RETURN pin at the aftertreatment DOC intake temperature connector of the interface module.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3313 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment DOC intake temperature sensor.

  • Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the aftertreatment diesel particulate filter (DPF) temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment DPF temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DPF temperature sensor interface module.

Clean the connector and pins, if possible.

Replace the aftertreatment DPF temperature sensor interface module if the pins can not be cleaned.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment DPF temperature sensor interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the aftertreatment interface harness, if equipped.

Guided Step 4A - Inspect the aftertreatment interface harness.

Conditions

  • If the engine is not equipped with an aftertreatment interface harness, proceed to Step 5A.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment interface harness.

Clean the connector and pins, if possible.

Replace the interface harness if the pins can not be cleaned.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check for an open circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 4C

Go to 7A

Guided Step 4C - Check for a pin-to-pin short circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface harness to all pins in all other connectors of the interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check the ECM and OEM harness.

Guided Step 5A - Inspect the ECM and OEM harness connectors pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel oxidation catalyst intake temperature SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment diesel oxidation catalyst intake temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 7A

Guided Step 5D - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or the aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel oxidation catalyst intake temperature sensor RETURN pin and the OEM harness aftertreatment diesel oxidation catalyst intake temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D-1

Go to 6A

Guided Step 5D-1 - Check for an open circuit in OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the aftertreatment DPF temperature sensor interface module (or the aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel oxidation catalyst intake temperature sensor SIGNAL pin and the OEM harness aftertreatment diesel oxidation catalyst intake temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Inspect the aftertreatment DOC.

Guided Step 6A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the inlet face of the aftertreatment diesel oxidation catalyst for soot accumulation.

Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the inlet face completely blocked by soot?
YES NO

Clean the aftertreatment DOC.

  • Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 6B

Guided Step 6B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell walls.

Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC.

  • Refer to Procedure 011-049 in the Associated Procedures Table.

A damaged sensor has been detected.

Replace the aftertreatment DOC inlet temperature sensor.

  • Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 3316 - Aftertreatment Diesel Particulate Filter (DPF) Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module (ECM) | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISB6.7 CM2250 | 4022254
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSL9 CM2250 | 4022256
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSB6.7 CM2250 | 4022255
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX15 CM2250 ECF | 2883557
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSB6.7 CM2250 | 4022255
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSL9 CM2250 | 4022256

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 3316 inactive?
STEP 2. | Check the aftertreatment DPF intake temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3317 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3316 active?
STEP 3. | Check the aftertreatment DPF temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment DPF temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DPF temperature sensor interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module. | Greater than 100K ohms?
STEP 4. | Check the aftertreatment interface harness if equipped. |
 | STEP 4A. Inspect the aftertreatment interface harness. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the aftertreatment interface harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the aftertreatment interface harness. | Greater than 100k ohms?
STEP 5. | Check the ECM and OEM harness. |
 | STEP 5A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 5C. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3316 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3316 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF intake temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DPF intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF intake temperature sensor from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the interface module and aftertreatment DPF intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF intake temperature sensor from the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3317 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DPF intake temperature sensor to the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3316 active?
YES NO

Replace the aftertreatment DPF intake temperature sensor.

  • Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 6A

Go to 6A

Guided Step 3 - Check the aftertreatment DPF temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment DPF temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DPF temperature sensor interface module.

Clean the connector and pins, if possible.

Replace the aftertreatment DPF temperature sensor interface module if the pins can not be cleaned.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment DPF temperature sensor interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the aftertreatment interface harness, if equipped.

Guided Step 4A - Inspect the aftertreatment interface harness.

Conditions

  • If the engine is not equipped with an aftertreatment interface harness, proceed to Step 5A.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment interface harness.

Clean the connector and pins, if possible.

Replace the interface harness if the pins can not be cleaned.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatmet interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-pin short circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface harness to all pins in all other connectors of the interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and OEM harness.

Guided Step 5A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF intake temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the aftertreatment DPF intake temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3316 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 1A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-Jun-2012


FAULT CODE 3317 - Aftertreatment Diesel Particulate Filter (DPF) Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module (ECM) | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSB6.7 CM2250 | 4022255
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSL9 CM2250 | 4022256

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 3317 inactive?
STEP 2. | Check the aftertreatment DPF intake temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3316 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3317 active?
STEP 3. | Check the aftertreatment DPF temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment DPF temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DPF temperature sensor interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module. | Greater than 100k ohms?
STEP 4. | Check the aftertreatment interface harness, if equipped. |
 | STEP 4A. Inspect the aftertreatment interface harness. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the aftertreatment interface harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the aftertreatment interface harness. | Greater than 100k ohms?
STEP 5. | Check the ECM and OEM harness. |
 | STEP 5A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 5B-1. Check for an open circuit in the OEM harness. |
 | STEP 5C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3317 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3317 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF intake temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DPF intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF intake temperature sensor from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the interface module and aftertreatment DPF intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF intake temperature sensor from the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment DPF intake temperature SIGNAL pin and the aftertreatment DPF intake temperature RETURN pin at the sensor connector of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3316 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DPF intake temperature sensor to the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3317 active?
YES NO

A damaged aftertreatment DPF intake temperature sensor has been detected.

Replace the aftertreatment DPF intake temperature sensor.

  • Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 6A

Go to 6A

Guided Step 3 - Check the aftertreatment DPF temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or the aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment DPF temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DPF temperature sensor interface module.

Clean the connector and pins, if possible.

Replace the interface module if the pins can not be cleaned.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or the aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment DPF temperature sensor interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or the aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the aftertreatment interface harness, if equipped.

Guided Step 4A - Inspect the aftertreatment interface harness.

Conditions

  • If the engine is not equipped with an aftertreatment interface harness, proceed to Step 5A.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment interface harness.

Clean the connector and pins, if possible.

Replace the interface harness if the pins can not be cleaned.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatmet interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-pin short circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface harness to all pins in all other connectors of the interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and OEM harness.

Guided Step 5A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or the aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF intake temperature sensor RETURN pin and the OEM harness aftertreatment DPF intake temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5B-1

Go to 6A

Guided Step 5B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or the aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF intake temperature sensor SIGNAL pin and the OEM harness aftertreatment DPF intake temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or the aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF intake temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3317 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 1A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-Jun-2012


FAULT CODE 3318 - Aftertreatment Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSB6.7 CM2250 | 4022255
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSL9 CM2250 | 4022256

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 3316 or 3317 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) intake temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3317 active?
 | STEP 2C. Check the circuit response. | Fault Code 3316 active?
STEP 3. | Check the aftertreatment DPF temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment DPF temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DPF temperature sensor interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module. | Greater than 100K ohms?
STEP 4. | Check the aftertreatment interface harness, if equipped. |
 | STEP 4A. Inspect the aftertreatment interface harness. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the aftertreatment interface harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the aftertreatment interface harness. | Greater than 100k ohms?
STEP 5. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 5A. Inspect the ECM and OEM harness connectors pins. | Dirty or damaged pins?
 | STEP 5B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 5C. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 5D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 5D-1. Check for an open circuit in the OEM harness. |
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3316 or 3317 active?
YES | NO
No Repair | No Repair

Fault Code 3316 or 3317 troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment exhaust gas temperature sensors while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter (DPF) intake temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DPF intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF intake temperature sensor from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the interface module and aftertreatment DPF intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF intake temperature sensor from the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3317 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF intake temperature sensor from the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment DPF intake temperature SIGNAL pin and the aftertreatment DPF intake temperature RETURN pin at the aftertreatment DPF intake temperature connector of the interface module.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3316 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment DPF intake temperature sensor.

  • Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the aftertreatment DPF temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst (DOC) intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment DPF temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DPF temperature sensor interface module.

Clean the connector and pins, if possible.

Replace the aftertreatment DPF temperature sensor interface module if the pins can not be cleaned.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment DPF temperature sensor interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the aftertreatment interface harness, if equipped.

Guided Step 4A - Inspect the aftertreatment interface harness.

Conditions

  • If the engine is not equipped with an aftertreatment interface harness, proceed to Step 5A.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment interface harness.

Clean the connector and pins, if possible.

Replace the aftertreatment interface harness if the pins can not be cleaned.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-pin short circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface harness to all pins in all other connectors of the interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and OEM harness.

Guided Step 5A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF intake temperature SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DPF intake temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or the aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF intake temperature sensor RETURN pin and the OEM harness aftertreatment DPF intake temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D-1

Go to 6A

Guided Step 5D-1 - Check for an open circuit in OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the aftertreatment DPF temperature sensor interface module (or the aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF intake temperature sensor SIGNAL pin and the OEM harness aftertreatment DPF intake temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 3319 - Aftertreatment Diesel Particulate Filter (DPF) Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Electronic Control Module (ECM) | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISB6.7 CM2250 | 4022254
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSL9 CM2250 | 4022256
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSB6.7 CM2250 | 4022255
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX15 CM2250 ECF | 2883557
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSB6.7 CM2250 | 4022255
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSL9 CM2250 | 4022256

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 3319 inactive?
STEP 2. | Check the aftertreatment DPF outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3321 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3319 active?
STEP 3. | Check the aftertreatment DPF temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment DPF temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DPF temperature sensor interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module. | Greater than 100k ohms?
STEP 4. | Check the aftertreatment interface harness, if equipped. |
 | STEP 4A. Inspect the aftertreatment interface harness. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the aftertreatment interface harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the aftertreatment interface harness. | Greater than 100k ohms?
STEP 5. | Check the ECM and OEM harness. |
 | STEP 5A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 5B-1. Check for an open circuit in the OEM harness. |
 | STEP 5C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3319 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3319 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DPF outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet temperature sensor from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the interface module and aftertreatment DPF outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet temperature sensor from the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment DPF outlet temperature SIGNAL pin and the aftertreatment DPF outlet temperature RETURN pin at the sensor connector of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3321 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DPF outlet temperature sensor to the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3319 active?
YES NO

A damaged aftertreatment DPF outlet temperature sensor has been detected.

Replace the aftertreatment DPF outlet temperature sensor.

  • Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 6A

Go to 6A

Guided Step 3 - Check the aftertreatment DPF temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or the aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment DPF temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DPF temperature sensor interface module.

Clean the connector and pins, if possible.

Replace the interface module if the pins can not be cleaned.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or the aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment DPF temperature sensor interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or the aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the aftertreatment interface harness if equipped.

Guided Step 4A - Inspect the aftertreatment interface harness.

Conditions

  • If the engine is not equipped with an aftertreatment interface harness, proceed to Step 5A.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment interface harness.

Clean the connector and pins if possible.

Replace the interface harness if the pins can not be cleaned.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-pin short circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface harness to all pins in all other connectors of the interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and OEM harness.

Guided Step 5A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or the aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF outlet temperature sensor RETURN pin and the OEM harness aftertreatment DPF outlet temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5B-1

Go to 6A

Guided Step 5B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or the aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF outlet temperature sensor SIGNAL pin and the OEM harness aftertreatment DPF outlet temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or the aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3319 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 1A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 3321 - Aftertreatment Diesel Particulate Filter (DPF) Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Electronic Control Module (ECM) | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2250 | 4022256
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2250 | 4022255
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSX15 CM2250 ECF | 2883557
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISB6.7 CM2250 | 4022254
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSL9 CM2250 | 4022256
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSB6.7 CM2250 | 4022255
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX15 CM2250 ECF | 2883557
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSB6.7 CM2250 | 4022255
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSL9 CM2250 | 4022256

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 3321 inactive?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3319 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3321 active?
STEP 3. | Check the aftertreatment DPF temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment DPF temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DPF temperature sensor interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module. | Greater than 100K ohms?
STEP 4. | Check the aftertreatment interface harness, if equipped. |
 | STEP 4A. Inspect the aftertreatment interface harness. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the aftertreatment interface harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the aftertreatment interface harness. | Greater than 100k ohms?
STEP 5. | Check the ECM and OEM harness. |
 | STEP 5A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 5C. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3321 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3321 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment exhaust gas temperature sensors while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 2A

Guided Step 2 - Check the aftertreatment DPF outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DPF outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet temperature sensor from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the interface module and aftertreatment DPF outlet temperature sensor sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet temperature sensor from the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3319 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DPF outlet temperature sensor to the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3321 active?
YES NO

Replace the aftertreatment DPF outlet temperature sensor.

  • Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 6A

Go to 6A

Guided Step 3 - Check the aftertreatment DPF temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst (DOC) intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment DPF temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DPF temperature sensor interface module.

Clean the connector and pins, if possible.

Replace the aftertreatment DPF temperature sensor interface module if the pins can not be cleaned.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment DPF temperature sensor interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the aftertreatment interface harness, if equipped.

Guided Step 4A - Inspect the aftertreatment interface harness.

Conditions

  • If the engine is not equipped with an aftertreatment interface harness, proceed to Step 5A.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment interface harness.

Clean the connector and pins, if possible.

Replace the interface harness if the pins can not be cleaned.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-pin short circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface harness to all pins in all other connectors of the interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and OEM harness.

Guided Step 5A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DPF outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3321 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 1A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 3322 - Aftertreatment Diesel Particulate Filter (DPF) Outlet Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX CM2250 GX CM2250 | 4022250
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Particulate Filter Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter (DPF) Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter (DPF)Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter (DPF)Temperature Sensor Interface Module | Refer to Procedure 019-462 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter (DPF)Temperature Sensor Interface Module | Refer to Procedure 019-462 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSB6.7 CM2250 | 4022255
Aftertreatment Interface Harness | Refer to Procedure 019-477 | QSL9 CM2250 | 4022256

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 3319 or 3321 active?
STEP 2. | Check the aftertreatment DPF outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3319 active?
 | STEP 2C. Check the circuit response. | Fault Code 3321 active?
STEP 3. | Check the aftertreatment DPF temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment DPF temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DPF temperature sensor interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module. | Greater than 100K ohms?
STEP 4. | Check the aftertreatment interface harness, if equipped. |
 | STEP 4A. Inspect the aftertreatment interface harness. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the aftertreatment interface harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the aftertreatment interface harness. | Greater than 100k ohms?
STEP 5. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 5A. Inspect the ECM and OEM harness connectors pins. | Dirty or damaged pins?
 | STEP 5B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 5C. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 5D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 5D-1. Check for an open circuit in the OEM harness. |
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3319 or 3321 active?
YES | NO
No Repair | No Repair

Fault Code 3319 or 3321 troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DPF outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DPF outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet temperature sensor from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the interface module and aftertreatment DPF outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet temperature sensor from the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3319 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet temperature sensor from the aftertreatment DPF temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response.

  • Place a jumper wire between the aftertreatment DPF outlet temperature SIGNAL pin and the aftertreatment DPF outlet temperature RETURN pin at the aftertreatment DPF outlet temperature connector of the interface module.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3321 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment DPF outlet temperature sensor.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the aftertreatment DPF temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment DPF temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DPF temperature sensor interface module.

Clean the connector and pins, if possible.

Replace the aftertreatment DPF temperature sensor interface module if the pins can not be cleaned.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment DPF temperature sensor interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment DPF temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC intake temperature sensor, aftertreatment DPF intake temperature sensor, aftertreatment DPF outlet temperature sensor, and the OEM harness (or aftertreatment interface harness, if equipped) from the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DPF temperature sensor interface module.

Replace the aftertreatment DPF temperature sensor interface module.

  • Refer to Procedure 019-462 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the aftertreatment interface harness, if equipped.

Guided Step 4A - Inspect the aftertreatment interface harness.

Conditions

  • If the engine is not equipped with an aftertreatment interface harness, proceed to Step 5A.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Inspect the aftertreatment interface harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment interface harness.

Clean the connector and pins, if possible.

Replace the interface harness if the pins can not be cleaned.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatmet interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-pin short circuit in the aftertreatment interface harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment interface harness from the OEM harness and the aftertreatment DPF temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface harness to all pins in all other connectors of the interface harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment interface harness.

Replace the aftertreatment interface harness.

  • Refer to Procedure 019-477 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and OEM harness.

Guided Step 5A - Inspect the ECM and OEM harness connectors pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF outlet temperature SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DPF outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF temperature sensor interface module (or the aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF outlet temperature sensor RETURN pin and the OEM harness aftertreatment DPF outlet temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D-1

Go to 6A

Guided Step 5D-1 - Check for an open circuit in OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the aftertreatment DPF temperature sensor interface module (or the aftertreatment interface harness, if equipped) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF outlet temperature sensor SIGNAL pin and the OEM harness aftertreatment DPF outlet temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 3342 - Engine Exhaust Gas Recirculation Cooler Efficiency - Data Valid But Normal Operating Range - Moderately Severe Range

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISX CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
EGR Cooler | Refer to Procedure 011-019 | ISX CM2250 GX CM2250 | 4022250
EGR Cooler | Refer to Procedure 011-019 | ISX12/ISX11.9 CM2250 | 2883445
EGR Cooler | Refer to Procedure 011-019 | QSL9 CM2250 | 4022256
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2250 | 4022255
EGR Cooler | Refer to Procedure 011-019 | ISB6.7 CM2350 B101 | 2883567
EGR Cooler | Refer to Procedure 011-019 | ISL9 CM2350 L101 | 4310787
EGR Cooler | Refer to Procedure 011-019 | ISX12 CM2350 X102 | 4310646
EGR Cooler | Refer to Procedure 011-019 | ISX15 CM2350 X101 | 4310641
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX CM2250 GX CM2250 | 4022250
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX12/ISX11.9 CM2250 | 2883445
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX12 CM2350 X102 | 4310646
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B101 | 2883567
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L101 | 4310787
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12 CM2350 X102 | 4310646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2350 X101 | 4310641
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX CM2250 GX CM2250 | 4022250
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12/ISX11.9 CM2250 | 2883445
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2250 | 4022256
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 | 4022255
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B101 | 2883567
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L101 | 4310787
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12 CM2350 X102 | 4310646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2350 X101 | 4310641

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 3342?
STEP 2. | Check the cooling system. |
 | STEP 2A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 2B. Check the engine coolant level. | Engine coolant level at proper level?
STEP 3. | Check the exhaust gas recirculation (EGR) system. |
 | STEP 3A. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure sensor ports?
STEP 4. | Check the EGR temperature sensor. |
 | STEP 4A. Check the EGR temperature sensor accuracy. | EGR temperature within 10° C [18° F] of ambient air temperature?
 | STEP 4B. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the circuit response. | Fault Code 2375 active?
 | STEP 4D. Check the circuit response. | Fault Code 2375 active?
STEP 5. | Check the ECM and engine harness. |
 | STEP 5A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the circuit response. | Fault Code 2375 active?
 | STEP 5C. Check the circuit response. | Fault Code 2376 active?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 3342?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the cooling system.

Guided Step 2A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.

Check the freeze point of the engine coolant to be sure of a proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Engine coolant is proper mixture?
YES NO
No Repair

Drain the coolant and refill the cooling system with the proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 2B

Go to 6A

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

Refer to Procedure 008-018 in the Associated Procedures Table.

Note: Low engine coolant level can cause erratic coolant flow through the engine and EGR cooler, in turn, causing the EGR temperatures to rise.

Engine coolant level at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant if necessary.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Check the EGR system.

Guided Step 3A - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor.
  • Refer to Procedure 019-370 in the Associated Procedures Table.

Action

Inspect the EGR differential pressure sensor ports and cross drillings for restrictions, soot plugging, and debris plugging.

  • Refer to Procedure 011-066 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure sensor ports?
YES NO

Clear the debris.

  • Refer to Procedure 011-066 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the EGR temperature sensor.

Guided Step 4A - Check the EGR temperature sensor accuracy.

Conditions

  • Turn keyswitch OFF
  • Remove the EGR temperature sensor from the EGR plumbing
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the EGR temperature sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the EGR temperature sensor reading
  • Compare the EGR temperature sensor reading to ambient air temperature.

Note: Allow the EGR temperature sensor enough time to cool down to ambient temperature before comparing the reading.

EGR temperature within 10° C [18° F] of ambient air temperature?
YES NO

Inspect the EGR cooler for fouling.

Clean or replace the EGR cooler.

Refer to Procedure 011-019 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and EGR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4C

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the EGR temperature sensor from the engine harness.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool..

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active?
YES | NO
No Repair | No Repair

Go to 4D

Go to 5A

Guided Step 4D - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the EGR temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the EGR temperature sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 active?
YES NO

A malfunctioning EGR temperature sensor has been detected.

Replace the EGR temperature sensor.

Refer to Procedure 019-378 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the ECM and engine harness.

Guided Step 5A - Inspect the ECM and engine harness connector pins.

Conditions

Turn keyswitch OFF

Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5C

Go to 6A

Guided Step 5C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Feb-2016


FAULT CODE 3343 - Engine Charge Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 CM2350 X102 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2350 X101 | 4310641

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify intake manifold temperature sensor condition |
 | STEP 1A. Check for active fault codes. | Fault Codes 153, 154, or 436 active?
 | STEP 1B. Monitor the intake manifold air temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Verify intake manifold temperature sensor condition.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 153, 154, or 436 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Intake Manifold Air Temperature Above Specification symptom tree in the appropriate service manual.

Replace the intake manifold air temperature sensor.

  • Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Sep-2014


FAULT CODE 3348 - Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Charge Air Cooler | Refer to Procedure 010-027 | ISX CM2250 GX CM2250 | 4022250
Charge Air Cooler | Refer to Procedure 010-027 | ISX12/ISX11.9 CM2250 | 2883445
Charge Air Cooler | Refer to Procedure 010-027 | ISX12 CM2350 X102 | 4310646
Charge Air Cooler | Refer to Procedure 010-027 | ISX15 CM2350 X101 | 4310641
Turbocharger | Refer to Procedure 010-033 | ISX CM2250 GX CM2250 | 4022250
Turbocharger | Refer to Procedure 010-033 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger | Refer to Procedure 010-033 | ISX12 CM2350 X102 | 4310646
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2350 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 CM2350 X102 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2350 X101 | 4310641

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 3348 active?
STEP 2. | Check the crankcase ventilation system. |
 | STEP 2A. Check for crankcase pressure sensor faults. | Fault Code 555 or 556 active or inactive?
 | STEP 2B. Check the crankcase breather system components. | Any restrictions found?
STEP 3. | Check the intake system. |
 | STEP 3A. Check the intake manifold pressure sensor. | INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
 | STEP 3B. Check the condition of the air intake filter. | Excessive restriction found?
 | STEP 3C. Check the air intake plumbing up to the compressor inlet for a restriction. | Excessive restriction found?
STEP 4. | Check for oil in the compressor discharge pipe. |
 | STEP 4A. Remove the compressor discharge pipe for inspection. | Oil residue in the discharge pipe?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3348 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the crankcase ventilation system.

Guided Step 2A - Check for crankcase pressure sensor faults.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 555 or 556.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 555 or 556 active or inactive?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 2B

Guided Step 2B - Check the crankcase breather system components.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankcase breather system.

  • Check for a restriction in the draft tube.
  • Check for a restriction in the tube between the engine and the filter housing.

Any restrictions found?
YES NO

Remove the restriction.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the intake system.

Guided Step 3A - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold temperature/pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the condition of the air intake filter.

Conditions

  • Turn keyswitch ON.
  • Connect all sensors.

Action

Check the condition of the air intake filter.

  • Refer to Procedure 010-027 in the Associated Procedures Table.

Excessive restriction found?
YES NO

Replace the air intake filter.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the air intake plumbing up to the compressor intake for a restriction.

Conditions

  • Turn keyswitch OFF.

Action

Check the intake plumbing for restriction.

  • Remove and inspect each component from the atmosphere to the air filter for a restriction.

Excessive restriction found?
YES NO

Remove the restriction.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check for oil in the compressor discharge pipe.

Guided Step 4A - Remove the compressor discharge pipe for inspection.

Conditions

  • Assemble all components.

Action

Remove the compressor discharge pipe for inspection.

  • Operate the engine for 5 minutes at 1000 rpm.
  • Remove the discharge pipe from the compressor.
  • Inspect the discharge pipe for oil.

Oil residue in the discharge pipe?
YES NO

Clean the compressor outlet and discharge pipe.

Assemble the discharge pipe and repeat Step 4A.

After five cleaning cycles, if there is still oil in the discharge pipe, replace the turbocharger.

Refer to Procedure 010-033 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Mar-2016


FAULT CODE 3361 - Intake Manifold 1 Pressure - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment System | Refer to Procedure 011-050 | ISX15 CM2250 | 4022250
Aftertreatment System | Refer to Procedure 011-050 | GX CM2250 | 4022250
Aftertreatment System | Refer to Procedure 011-050 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

Do NOT use pliers or any other tool to turn the gear. ONLY rotate the gear by hand. Damage to the VGT actuator can occur.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3361 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1938 or 2636 is active?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear is broken or damaged on the VGT actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | On the sector gear gauge, does the nozzle movement meet the requirements? 010-134 in the Associated Procedures Table.
 | STEP 2D. Check the VGT output gear for correct calibration. | Does the VGT actuator gear move when connected to the engine wiring harness?
 | STEP 2D-1. Check the VGT output gear for manual rotation by hand. |
 | STEP 2E. Check for active Fault Code 3361. | Fault Code 3361 active?
STEP 3. | Check aftertreatment system. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 3361.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3361 active?
YES NO
No Repair

No troubleshooting is necessary unless Fault Code 3361 is active.

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1938 or 2636 is active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Secion 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the VGT actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect the VGT actuator.

  • Check for a broken drive gear on the VGT actuator.

Gear is broken or damaged on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • VGT actuator removed from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever must move to the other stop position by hand.

Refer to Procedure 010-134 in the Associated Procedures Table.

On the sector gear gauge, does the nozzle movement meet the requirements? 010-134 in the Associated Procedures Table.
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

NOTE: This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2D

Go to 3A

CAUTION

Do NOT use pliers or any other tool to turn the gear. ONLY rotate the gear by hand. Damage to the VGT actuator can occur.
Guided Step 2D - Check the VGT output gear for correct calibration.

Conditions

  • Disconnect the VGT actuator from the engine wiring harness.
  • Turn keyswitch ON.

Action

Check the VGT actuator output gear operation.

  • Connect the VGT actuator to the engine wiring harness. The VGT actuator gear should rotate.

NOTE: The VGT actuator output gear will exhibit one of the following movements depending on the ECM calibration. Make sure to closely observe the VGT actuator gear when the VGT actuator is connected to the engine wiring harness.

  • The actuator output gear could possibly rotate completely in one direction and then rotate completely in the opposite direction, OR
  • The actuator output gear may only move a few degrees in one direction. This movement will be a quick snap when the VGT actuator is connected to the engine wiring harness.
  • If the VGT actuator gear does not move, disconnect the VGT actuator from the engine wiring harness for 1 second and then reconnect.
  • Repeat the above procedure three times, checking for VGT actuator gear movement each time the VGT actuator is connected to the engine wiring harness.

Does the VGT actuator gear move when connected to the engine wiring harness?
YES NO

Install the VGT actuator back on the turbocharger making sure to perform the VGT actuator install and calibrate procedures.

Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 2E

Go to 2D-1

CAUTION

Do NOT use pliers or any other tool to turn the gear. ONLY rotate the gear by hand. Damage to the VGT actuator can occur.
Guided Step 2D-1 - Check the VGT output gear for manual rotation by hand.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine wiring harness.

Action

Turn the VGT actuator output gear by hand.

  • Try turning the VGT actuator output gear by hand in either direction.

Can the VGT actuator output gear be rotated by hand?
YES NO

Install the VGT actuator back on the turbocharger making sure to perform theft actuator install and calibrate procedures.

Refer to Procedure 010-134 in the Associated Procedures Table.

Replace the VGT actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for active Fault Code 3361.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active Fault Code 3361.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3361 active?
YES NO

Replace the VGT actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check aftertreatment system.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Action

Check for damage to the aftertreatment system.

Perform the aftertreatment initial check procedure to test for a malfunctioning diesel particulate filter.

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Progressive damage to the aftertreatment system detected?
YES NO

Replace the damaged aftertreatment system component(s).

Refer to Procedure 011-050 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 3375 - Aftertreatment Diesel Particulate Filter Regeneration Too Frequent - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISX15 CM2250 | 4022250
Fuel System Diagnostics | Refer to Procedure 005-236 | ISX12/ISX11.9 CM2250 | 2883445
Injector | Refer to Procedure 006-026 | ISX15 CM2250 | 4022250
Injector | Refer to Procedure 006-026 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Connector (Head Mounted) | Refer to Procedure 006-052 | ISX15 CM2250 | 4022250
Fuel Connector (Head Mounted) | Refer to Procedure 006-052 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISX15 CM2250 | 4022250
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX15 CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Injector Performance Testing | Refer to Procedure 014-014 | ISX15 CM2250 | 4022250
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 | 4022250
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3375 active or inactive?
 | STEP 1B. Check for active or inactive aftertreatment diesel particulate filter (DPF) differential pressure sensor related fault codes. | Fault Code 1879, 1881, 1883, 3133, 3134 or 3135 active or inactive?
 | STEP 1C. Check for active or inactive high engine out soot related fault codes. | Fault Code 2754 active or inactive?
 | STEP 1D. Check engine control module calibration software phase level. | Engine control module calibration software revision level 0770053 or higher?
 | STEP 1E. Check for active or inactive fuel system related fault codes. | Fault Code 322, 323, 324, 325, 331, 332, 351, 559, 1139, 1141, 1142, 1143, 1144, 1145, 1654, 1655, 1656, 1657, 1658, 1659, 1718, 2311, or 2372 active or inactive?
 | STEP 1F. Check for active or inactive air handling system related fault codes. | Fault Code 125, or 2973 active or inactive?
 | STEP 1G. Check for aftertreatment fuel injector system related fault codes. | Fault Code 1664, 1925, 1926, 1932, 1963, 1964, or 3167 active or inactive?
 | STEP 1H. Check for exhaust gas recirculation (EGR) or related fault codes. | Fault Code 1866, 2273, 2274, 2961, 2962, 3136, 3137, 3138, 3342, 3382, or 3383 active or inactive?
 | STEP 1I. Check for EGR or variable geometry turbocharger (VGT) system related fault codes. | Fault Code 1228, 1896, 1898, 2198, 2272, 2349, 2353, 2357, 2387, 2449, 2634, 2635, 2636 or 3616 active or inactive?
 | STEP 1J. Check for aftertreatment system related fault codes. | Fault Code 1691, 2637, 2638, 3168, 3315, 3318, or 3322 active or inactive?
 | STEP 1K. Check for aftertreatment DPF related fault codes. | Fault Code 1921, 1922, 1981, or 2639 active or inactive?
STEP 2. | Check the aftertreatment DPF differential pressure sensor. |
 | STEP 2A. Monitor the aftertreatment DPF differential pressure sensor signal voltage with INSITE™ electronic service tool. | Aftertreatment DPF differential pressure sensor signal voltage reading 0.69-VDC (+/- 0.1-VDC at 25° C [77° F] or below or 0.69-VDC +/- 0.06-VDC at 26° C [78° F] or greater) at key ON, engine off and does not fluctuate while moving the associated wiring harness and connector?
 | STEP 2B. Check the aftertreatment DPF differential pressure sensor tubes for blockage. | Aftertreatment DPF differential pressure sensor tubes blocked, kinked, or leaking?
 | STEP 2C. Check the aftertreatment DPF differential pressure sensor circuit response. | Fault Codes 1881 and 3134 active?
 | STEP 2D. Check the aftertreatment DPF differential pressure sensor wiring. | Fault Codes 1879 and 3134 active?
STEP 3. | Complete the low-pressure fuel system. |
 | STEP 3A. Complete the low-pressure fuel system checks. | Low-pressure system checks meet specifications?
STEP 4. | Complete the High-Pressure Fuel System Leak Down Test. |
 | STEP 4A. Complete the High-Pressure System Leak Down Test. | High-Pressure Fuel System Leak Down Test meets specifications?
STEP 5. | Check the high-pressure fuel system. |
 | STEP 5A. Measure the fuel rail pressure relief valve return flow. | High-pressure fuel rail return flow within specifications?
 | STEP 5B. Check the high-pressure connector torque. | Injector high-pressure fuel connector torque meets specifications?
 | STEP 5C. Check for individual leaking injectors. | High-pressure System Leak Down Test within specifications with an injector capped off?
STEP 6. | Perform the Fuel Injector Performance Test. |
 | STEP 6A. Perform the Fuel Injector Performance Test. | Injector performance within specifications?
STEP 7. | Check aftertreatment DPF restriction. |
 | STEP 7A. Check aftertreatment DPF restriction. | Aftertreatment DPF restriction within specifications?
STEP 8. | Check the exhaust system. |
 | STEP 8A. Check the exhaust system for excessive black smoke | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 9. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 9A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 9B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3375 active or inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for active or inactive aftertreatment diesel particulate filter (DPF) differential pressure sensor related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment DPF differential pressure sensor related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, 1883, 3133, 3134 or 3135 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1C

Guided Step 1C - Check for active or inactive high engine out soot related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive high engine out soot related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2754 active or inactive?
YES | NO
No Repair | No Repair

Go to 1E

Go to 1D

Guided Step 1D - Check engine control module calibration software phase level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check engine control module calibration software phase level.

  • Use INSITE™ electronic service tool to read the engine control module calibration software phase level.

Note: The engine control module calibration software phase level can be found in the Features and Parameters section of INSITE™ electronic service tool under the heading; System ID and Dataplate and Calibration Information.

Electronic control module calibration software revision level 0770053 or higher?
YES | NO
No Repair | No Repair

Go to 7A

Go to 1E

Guided Step 1E - Check for active or inactive fuel system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fuel system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 323, 324, 325, 331, 332, 351, 559, 1139, 1141, 1142, 1143, 1144, 1145, 1654, 1655, 1656, 1657, 1658, 1659, 1718, 2311, or 2372 active or inactive?

YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1F

Guided Step 1F - Check for active or inactive air handling system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive air handling system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 125, or 2973 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1G

Guided Step 1G - Check for aftertreatment fuel injector system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment fuel injector system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1664, 1925, 1926, 1932, 1963, 1964, or 3167 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1H

Guided Step 1H - Check for exhaust gas recirculation (EGR) system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive EGR system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1866, 2273, 2274, 2961, 2962, 3136, 3137, 3138, 3342, 3382, or 3383 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1I

Guided Step 1I - Check for EGR or variable geometry turbocharger (VGT) system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive EGR or VGT system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1228, 1896, 1898, 2198, 2272, 2349, 2353, 2357, 2387, 2449, 2634, 2635, 2636 or 3616 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1J

Guided Step 1J - Check for aftertreatment system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1691, 2637, 2638, 3168, 3315, 3318, or 3322 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1K

Guided Step 1K - Check for aftertreatment DPF related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment DPF related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1921, 1922, 1981, or 2639 active or inactive?
YES NO

NOTE: Possible causes for Fault Codes 1921, 1981, and 2639 can be identified using this troubleshooting tree. It is not necessary to troubleshoot these fault codes first if they are associated with Fault Code 3375.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor.

Guided Step 2A - Monitor the aftertreatment DPF differential pressure sensor with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.
  • Connect aftertreatment DPF differential pressure sensor.

Action

Monitor the aftertreatment DPF differential pressure sensor with INSITE™ electronic service tool.

Aftertreatment DPF differential pressure sensor signal voltage reading 0.69-VDC (+/- 0.1-VDC at 25° C [77° F] or below or 0.69-VDC +/- 0.06-VDC at 26° C [78° F] or greater) at key ON, engine off and does not fluctuate while moving the associated wiring harness and connector?

YES NO
No Repair

An issue with the aftertreatment DPF differential pressure sensor or associated wiring has been found.

  • Check for a short circuit from the SIGNAL pin of the aftertreatment DPF differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.
  • Check for high resistance on the RETURN pin of the aftertreatment DPF differential pressure sensor harness. Refer to Procedure 019-360 in Section 19.
  • Replace the aftertreatment DPF differential pressure sensor if the wiring checks are okay. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn engine OFF.

Action

Check the aftertreatment DPF differential pressure sensor tubes for plugging, kinks, or leakage.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor tubes blocked, kinked, or leaking?
YES NO

Clean or replace the aftertreatment DPF differential pressure sensor tubes. Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check the aftertreatment DPF differential pressure sensor circuit response.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.
  • Disconnect aftertreatment DPF differential pressure sensor wiring harness connector.

Action

Use the INSITE™ electronic service tool to verify that Fault Codes 1881 and 3134 are active.

Fault Codes 1881 and 3134 active?
YES NO
No Repair

An issue with the aftertreatment DPF differential pressure sensor or associated wiring has been found.

Check for proper pin-to-pin location in the harness between the ECM and the aftertreatment DPF differential pressure sensor wiring harness connector. Reference the ISX15 CM2250 Wiring Diagram, Bulletin 4022234, ISX12/11.9 CM2250 Wiring Diagram, Bulletin 2883476, QSX15 CM2250 ECF Wiring Diagram, Bulletin 2883558, QSX11.9 CM2250 ECF Wiring Diagram, Bulletin 2883562, PowerGen QSX15 CM2250 ECF Wiring Diagram, Bulletin 4310660; or the original equipment manufacturer (OEM) service manual.

Go to 2D

Go to 2D

Guided Step 2D - Check the aftertreatment DPF differential pressure sensor wiring.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.
  • Disconnect aftertreatment DPF differential pressure sensor wiring harness connector.

Action

Use the Framatome™ Male Test Lead, Part Number 3164596, or equivalent, to short the aftertreatment DPF differential pressure sensor 5-VDC SUPPLY (pin 4 of the wiring harness connector) to the aftertreatment DPF differential pressure sensor SIGNAL (pin 2 of the wiring harness connector).

Fault Codes 1879 and 3134 active?
YES NO
No Repair

An issue with the aftertreatment DPF differential pressure sensor or associated wiring has been found.

Check for proper pin-to-pin location in the harness between the ECM and the aftertreatment DPF differential pressure sensor wiring harness connector. Reference the ISX15 CM2250 Wiring Diagram, Bulletin 4022234, ISX12/11.9 CM2250 Wiring Diagram, Bulletin 2883476, QSX15 CM2250 ECF Wiring Diagram, Bulletin 2883558, QSX11.9 CM2250 ECF Wiring Diagram, Bulletin 2883562, PowerGen QSX15 CM2250 Wiring Diagram, Bulletin 4310661, or the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check the low-pressure fuel system.

Guided Step 3A - Complete the low-pressure system checks.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.

Make sure the engine is at operating temperature before performing the test.

Action

Complete the low-pressure system checks.

  • Air in fuel
  • Fuel inlet restriction
  • Fuel pressure
  • Fuel drain line restriction

Refer to Procedure 005-236 in the Associated Procedures Table.

Low-pressure system checks meet specifications?
YES NO
No Repair

Correct the issue(s) identified during low-pressure fuel system check. Refer to the OEM service manual.

Note: The remaining diagnostic steps should be completed, even if an incorrect fuel filter was installed.

Go to 4A

Go to 4A

Guided Step 4 - Complete the High-Pressure System Leak Down Test.

Guided Step 4A - Complete the High-Pressure System Leak Down Test.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Connect INSITE™ electronic service tool.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.
  • Monitor INSITE™ electronic service tool parameters Fuel Rail Pressure Measured and Fuel Rail Pressure Commanded.

This test can not be performed if the engine will not start. If the engine does not start, refer to the appropriate troubleshooting tree.

Action

Complete the High-Pressure System Leak Down Test. Use the INSITE™ electronic service tool Fuel System Leakage Test, to perform the high-pressure system leak down test.

Refer to Procedure 005-236 in the Associated Procedures Table.

  • Start the engine
  • Connect INSITE™ electronic service tool
  • Monitor INSITE™ electronic service tool parameters Fuel Rail Pressure Measured and Fuel Rail Pressure Commanded
  • Perform INSITE™ electronic service tool Fuel System Leakage Test. Note: Allow the Fuel Rail Pressure - Measured to rise above 1724 bar (25,005 psi] before shutting the engine OFF
  • Stop the engine
  • Wait until the engine has stopped
  • Turn keyswitch ON quickly (do not start engine)
  • Use INSITE™ electronic service tool to monitor Fuel Rail Pressure - Measured for 60 seconds
  • Record the amount of drop in Fuel Rail Pressure - Measured and compare to specification.

High-Pressure System Leak Down Test meets specifications?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the high-pressure fuel system.

Guided Step 5A - Measure the fuel rail pressure relief valve return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

Make sure that the engine is at operating temperature before performing the test.

Action

Check for excessive fuel rail pressure relief valve return flow.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

High-pressure fuel rail return flow within specifications?
YES NO

Make sure all high-pressure fuel lines are tightened to the correct specification. Refer to Procedure 006-052 in the Associated Procedures Table.

Perform the High-Pressure System Leak Down Test again. If the test did not pass, identify the source of the leak in the high-pressure system. If no leaks are identified from the injectors or rail after the second test, continue to the next step. Refer to Procedure 005-236 in the Associated Procedures Table.

Replace the fuel rail pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Determine the reason for the fuel rail pressure relief valve leakage.

Examples:

  • Operation with the electronic fuel control valve unplugged.
  • Operation with a plugged fuel filter or excessive inlet restriction.

Go to 5B

Go to 4A

Guided Step 5B - Check the high-pressure connector torque.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector high-pressure connector torque.

  • Refer to Procedure 006-052 in the Associated Procedures Table.

Injector high-pressure connector torque meets specifications?
YES NO
No Repair

Tighten the injector high-pressure connector(s). Refer to Procedure 006-052 in the Associated Procedures Table.

Go to 5C

Go to 4A

Guided Step 5C - Check for individual leaking injectors.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool, Fuel System Leakage Test.

Make sure the engine is at operating temperature before performing the test.

Action

Check for fuel leaks at individual injectors.

  • Cap off each injector, one at a time, with the injector leakage isolation tool. The service tool must be installed with the engine OFF. Refer to Procedure 005-236 in the Associated Procedures Table.

High-Pressure System Leak Down Test within specifications with an injector capped off?
YES NO

Replace the high-pressure connector and injector for the cylinder that is causing the high-pressure system leak down. Refer to Procedure 006-026 in the Associated Procedures Table.

Cap off additional injectors to identify the source of the high-pressure system leak down. Replace the high-pressure connector and injector for the cylinder(s) causing the high-pressure system leak down. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 6 - Perform the Fuel Injector Performance Test.

Guided Step 6A - Perform the Fuel Injector Performance test.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel Injector Performance Test.

Make sure that the engine is at operating temperature before performing the test.

Action

Check for malfunctioning injector(s) using the INSITE™ electronic service tool Fuel Injector Performance Test, if available.

  • Refer to Procedure 014-014 in the Associated Procedures Table.

Injector performance within specifications?
YES NO
No Repair

A fuel injector issue has been identified.

Replace the high-pressure connector and injector for the cylinder(s) that do not meet specifications. Refer to Procedure 006-026 in the Associated Procedures Table.

Upon completion of repair, repeat the Fuel Injector Performance Test to verify the injector is performing properly.

Go to 7A

Go to 7A

Guided Step 7 - Check aftertreatment DPF restriction.

Guided Step 7A - Check aftertreatment DPF restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Diesel Particulate Filter Restriction Test.

Refer to Procedure 011-085 in the Associated Procedures Table.

Aftertreatment DPF restriction within specifications?
YES NO
No Repair

Remove and replace the aftertreatment DPF . Refer to Procedure 011-041 in the Associated Procedures Table.

Note: If the aftertreatment DPF required replacement for excessive ash and had not reached the normal ash cleaning interval, further troubleshooting is required. Check for lubricating oil consumption, coolant consumption, or previous repairs that may have corrected an issue resulting in lubricating oil or coolant consumption. Refer to the Ash Cleaning - Excessive troubleshooting symptom tree, if necessary.

Go to 8A

Go to 8A

Guided Step 8 - Check the exhaust system.

Guided Step 8A - Inspect the exhaust for excessive smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke by performing the Snap Acceleration - Aftertreatment Disconnected Test.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.
  • To perform a snap acceleration test, it may be necessary to use the INSITE™ electronic service tool “Setup for Dynamometer” found under the Diagnostic Tests menu to allow the engine to reach high idle.

Refer to Procedure 014-013 in the Associated Procedures Table.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of the excessive black smoke.

 No Repair

Appropriate engine performance troubleshooting symptom tree

Go to 9A

Guided Step 9 - Check ECM calibration and clear fault codes.

Guided Step 9A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 9B

Go to 9B

Guided Step 9B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Note: If the aftertreatment DPF was replaced and the ECM was not recalibrated, the Aftertreatment Maintenance Filter Installation procedure must be performed. The Aftertreatment Maintenance Filter Installation procedure is located in the INSITE™ electronic service tool in the Advanced ECM Data menu.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Oct-2013


FAULT CODE 3376 - Aftertreatment Diesel Particulate Filter Incomplete Regeneration - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISX15 CM2250 | 4022250
Fuel System Diagnostics | Refer to Procedure 005-236 | ISX12/ISX11.9 CM2250 | 2883445
Injector | Refer to Procedure 006-026 | ISX15 CM2250 | 4022250
Injector | Refer to Procedure 006-026 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Connector (Head Mounted) | Refer to Procedure 006-052 | ISX15 CM2250 | 4022250
Fuel Connector (Head Mounted) | Refer to Procedure 006-052 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISX15 CM2250 | 4022250
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX15 CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Injector Performance Testing | Refer to Procedure 014-014 | ISX15 CM2250 | 4022250
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 | 4022250
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3376 active or inactive?
 | STEP 1B. Check for aftertreatment diesel particulate filter (DPF) differential pressure sensor related fault codes. | Fault Code 1879, 1881, 1883, 3133, 3134 or 3135 active or inactive?
 | STEP 1C. Check for high engine out soot related fault codes. | Fault Code 2754 active or inactive?
 | STEP 1D. Check engine control module (ECM) calibration software phase level. | ECM calibration software phase level at required level or greater?
 | STEP 1E. Check for fuel system related fault codes. | Fault Code 322, 323, 324, 325, 331, 332, 351, 559, 1139, 1141, 1142, 1143, 1144, 1145, 1654, 1655, 1656, 1657, 1658, 1659, 1718, 2311, or 2372 active or inactive?
 | STEP 1F. Check for air handling system related fault codes. | Fault Code 125 or 2973 active or inactive?
 | STEP 1G. Check for aftertreatment fuel injector system related fault codes. | Fault Code 1664, 1925, 1926, 1932, 1963, 1964, or 3167 active or inactive?
 | STEP 1H. Check for exhaust gas recirculation system related fault codes. | Fault Code 1866, 2273, 2274, 2961, 2962, 3136, 3137, 3138, 3342, 3382, or 3383 active or inactive?
 | STEP 1I. Check for exhaust gas recirculation or variable geometry turbocharger system related fault codes. | Fault Code 1228, 1896, 1898, 2198, 2272, 2349, 2353, 2357, 2387, 2449, 2634, 2635, 2636, or 3616 active or inactive?
 | STEP 1J. Check for aftertreatment system related fault codes. | Fault Code 1691, 2637, 2638, 3168, 3315, 3318, or 3322 active or inactive?
 | STEP 1K. Check for aftertreatment DPF related fault codes. | Fault Code 1921, 1922, 1981, or 2639 active or inactive?
STEP 2. | Check the aftertreatment DPF differential pressure sensor. |
 | STEP 2A. Monitor the aftertreatment DPF differential pressure sensor signal voltage with an electronic service tool. | Aftertreatment DPF differential pressure sensor signal voltage reading 0.69 VDC (+/- 0.1 VDC at 25° C [77° F] or below or 0.69 VDC +/- 0.06 VDC at 26° C [78° F] or greater) at key ON, engine OFF?
 | STEP 2B. Check the aftertreatment DPF differential pressure sensor tubes for blockage. | Aftertreatment DPF differential pressure sensor tubes blocked, kinked, or leaking?
 | STEP 2C. Check the aftertreatment DPF differential pressure sensor circuit response. | Fault Codes 1881 and 3134 active?
 | STEP 2D. Check the aftertreatment DPF differential pressure sensor wiring. | Fault Codes 1879 and 3134 active?
STEP 3. | Complete the low-pressure fuel system checks. |
 | STEP 3A. Complete the low-pressure fuel system checks. | Low-pressure system checks meet specifications?
STEP 4. | Complete the High-Pressure Fuel System Leak Down Test. |
 | STEP 4A. Complete the High-Pressure Fuel System Leak Down Test. | High-Pressure Fuel System Leak Down Test meets specifications?
STEP 5. | Check the high-pressure fuel system. |
 | STEP 5A. Measure the fuel rail pressure relief valve return flow. | High-pressure fuel rail return flow within specifications?
 | STEP 5B. Check the high-pressure connector torque. | Injector high-pressure fuel connector torque meets specifications?
 | STEP 5C. Check for individual leaking injectors. | High-pressure fuel system leak down test within specifications with an injector capped off?
STEP 6. | Perform the Fuel Injector Performance Test. |
 | STEP 6A. Perform the Fuel Injector Performance Test. | Injector performance within specifications?
STEP 7. | Check aftertreatment DPF restriction. |
 | STEP 7A. Check aftertreatment DPF restriction. | Aftertreatment DPF restriction within specifications?
STEP 8. | Check the exhaust system. |
 | STEP 8A. Check the exhaust system for excessive smoke | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 9. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 9A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 9B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3376 active or inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for active or inactive aftertreatment diesel particulate filter differential pressure sensor related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment diesel particulate filter differential pressure sensor related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, 1883, 3133, 3134, or 3135 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1C

Guided Step 1C - Check for active or inactive high engine out soot related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive high engine out soot fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2754 active or inactive?
YES | NO
No Repair | No Repair

Go to 1E

Go to 1D

Guided Step 1D - Check ECM calibration software phase level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check ECM calibration software phase level.

  • Use INSITE™ electronic service tool to read the ECM calibration software phase level.

Note: The ECM calibration software phase level can be found in the Features and Parameters section of INSITE electronic service tool under the heading System ID and Dataplate and Calibration Information.

ECM calibration software revision level 0770053 or higher?
YES | NO
No Repair | No Repair

Go to 7A

Go to 1E

Guided Step 1E - Check for active or inactive fuel system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fuel system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 323, 324, 325, 331, 332, 351, 559, 1139, 1141, 1142, 1143, 1144, 1145, 1654, 1655, 1656, 1657, 1658, 1659, 1718, 2311, or 2372 active or inactive?

YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1F

Guided Step 1F - Check for active or inactive air handling system related fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive air handling system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 125 or 2973 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1G

Guided Step 1G - Check for aftertreatment fuel injector system related fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment fuel injector system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1664, 1925, 1926, 1932, 1963, 1964, or 3167 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1H

Guided Step 1H - Check for exhaust gas recirculation system related fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive exhaust gas recirculation system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1866, 2273, 2274, 2961, 2962, 3136, 3137, 3138, 3342, 3382, or 3383 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1I

Guided Step 1I - Check for exhaust gas recirculation or variable geometry turbocharger system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive exhaust gas recirculation or variable geometry turbocharger system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1228, 1896, 1898, 2198, 2272, 2349, 2353, 2357, 2387, 2449, 2634, 2635, 2636, or 3616 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1J

Guided Step 1J - Check for aftertreatment system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1691, 2637, 2638, 3168, 3315, 3318, or 3322 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1K

Guided Step 1K - Check for aftertreatment DPF related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment DPF related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1921, 1922, 1981, or 2639 active or inactive?
YES NO

NOTE: Possible causes for Fault Codes 1921, 1922, 1981, and 2639 can be identified using this troubleshooting tree. It is not necessary to troubleshoot these fault codes first if they are associated with Fault Code 3376.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor.

Guided Step 2A - Monitor the aftertreatment DPF differential pressure sensor with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.
  • Connect aftertreatment DPF differential pressure sensor.

Action

Monitor the aftertreatment DPF differential pressure sensor with INSITE™ electronic service tool.

Aftertreatment DPF differential pressure sensor signal voltage reading 0.69 VDC (+/- 0.1 VDC at 25° C [77° F] or below or 0.69 VDC +/- 0.06 VDC at 26° C [78° F] or greater) at key ON, engine OFF and does not fluctuate while moving the associated wiring harness and connector?

YES NO
No Repair

An issue with the aftertreatment DPF differential pressure sensor or associated wiring has been found.

  • Check for a short circuit from the SIGNAL pin of the aftertreatment DPF differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.
  • Check for high resistance on the RETURN pin of the aftertreatment DPF differential pressure sensor harness. Refer to Procedure 019-360 in Section 19.
  • Replace the aftertreatment DPF differential pressure sensor if the wiring checks are okay. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn engine OFF.

Action

Check the aftertreatment DPF differential pressure sensor tubes for plugging, kinks, or leakage.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor tubes blocked, kinked, or leaking?
YES NO

Clean or replace the aftertreatment DPF differential pressure sensor tubes. Refer to Procedure 011-047 in the Associated Procedures Table.

No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check the aftertreatment DPF differential pressure sensor circuit response.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.
  • Disconnect aftertreatment DPF differential pressure sensor wiring harness connector.

Action

Use INSITE™ electronic service tool to verify that Fault Codes 1881 and 3134 are active.

Fault Codes 1881 and 3134 active?
YES NO
No Repair

An issue with the aftertreatment DPF differential pressure sensor or associated wiring has been found.

Check for proper pin-to-pin location in the harness between the ECM and the aftertreatment DPF differential pressure sensor wiring harness connector. Reference the ISX15 CM2250 Wiring Diagram, Bulletin 4022234, ISX12/11.9 CM2250 Wiring Diagram, Bulletin 2883476; QSX15 CM2250 ECF Wiring Diagram, Bulletin 2883558; QSX11.9 CM2250 ECF Wiring Diagram, Bulletin 2883562; PowerGen QSX15 CM2250 ECF Wiring Diagram, Bulletin 4310660; or the original equipment manufacturer (OEM) service manual.

Go to 2D

Go to 2D

Guided Step 2D - Check the aftertreatment DPF differential pressure sensor wiring.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.
  • Disconnect aftertreatment DPF differential pressure sensor wiring harness connector.

Action

Use the Framatome™ Male Test Lead, Part Number 3164596, or equivalent, to short the aftertreatment DPF differential pressure sensor 5-VDC SUPPLY pin (pin 4 of the wiring harness connector) to the aftertreatment DPF differential pressure sensor SIGNAL pin (pin 2 of the wiring harness connector).

Fault Code 1879 and 3134 active?
YES NO
No Repair

An issue with the aftertreatment DPF differential pressure sensor or associated wiring has been found.

Check for proper pin-to-pin location in the harness between the ECM and the aftertreatment DPF differential pressure sensor wiring harness connector. Reference the ISX15 CM2250 Wiring Diagram, Bulletin 4022234, ISX12/11.9 CM2250 Wiring Diagram, Bulletin 2883476, QSX15 CM2250 ECF Wiring Diagram, Bulletin 2883558, QSX11.9 CM2250 ECF Wiring Diagram, Bulletin 2883562, PowerGen QSX15 CM2250 Wiring Diagram, Bulletin 4310660 or the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check the low-pressure fuel system.

Guided Step 3A - Complete the low-pressure system checks.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.

Make sure the engine is at operating temperature before performing the test.

Action

Complete the low-pressure system checks.

  • Air-in-fuel
  • Fuel inlet restriction
  • Fuel pressure
  • Fuel drain line restriction

Refer to Procedure 005-236 in the Associated Procedures Table.

Low-pressure system checks meet specifications?
YES NO
No Repair

Correct the issue(s) identified during low pressure fuel system checks. Refer to the OEM service manual.

NOTE: The remaining diagnostic steps should be completed, even if a low pressure fuel system was identified and corrected.

Go to 4A

Go to 4A

Guided Step 4 - Complete the High-Pressure System Leak Down Test.

Guided Step 4A - Complete the High-Pressure System Leak Down Test.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Connect INSITE™ electronic service tool.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.
  • Monitor INSITE™ electronic service tool parameters Fuel Rail Pressure Measured and Fuel Rail Pressure Commanded.

This test can not be performed if the engine will not start. If the engine does not start, refer to the appropriate troubleshooting tree.

Action

Complete the High-Pressure System Leak Down Test. Use INSITE™ electronic service tool “Fuel System Leakage Test” to run the high-pressure system leak down test.

Refer to Procedure 005-236 in the Associated Procedures Table.

  • Start the engine
  • Connect INSITE™ electronic service tool.
  • Monitor INSITE™ electronic service tool parameters Fuel Rail Pressure Measured and Fuel Rail Pressure Commanded
  • Perform INSITE™ electronic service tool Fuel System Leakage Test. NOTE: Allow the Fuel Rail Pressure – Measured to rise above 25,000 [1724 bar] before shutting off the engine
  • Stop the engine
  • Wait until the engine has stopped.
  • Turn keyswitch ON quickly (do not start engine)
  • Use INSITE™ electronic service tool to monitor Fuel Rail Pressure - Measured for 60 seconds.
  • Record the amount of drop in Fuel Rail Pressure - Measured and compare to specification.

High-Pressure System Leak Down Test meets specifications?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the high-pressure fuel system.

Guided Step 5A - Measure the fuel rail pressure relief valve return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

Make sure that the engine is at operating temperature before performing the test.

Action

Check for excessive fuel rail pressure relief valve return flow.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

High-pressure fuel rail return flow within specifications?
YES NO

Make sure all high-pressure fuel lines are tightened to the correct specification.Refer to Procedure 006-052 in the Associated Procedures Table.

Run the High-Pressure System Leak Down Test again. If failed, identify the source of the leak in the high-pressure system. If no leaks are identified from the injectors or rail after the second test, continue to the next step. Refer to Procedure 005-236 in the Associated Procedures Table.

Replace the fuel rail pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Determine the reason for the fuel rail pressure relief valve leakage.

Examples:

  • Operation with the electronic fuel control valve unplugged.
  • Operation with a plugged fuel filter or excessive inlet restriction.

Go to 5B

Go to 4A

Guided Step 5B - Check the high-pressure connector torque.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector high-pressure connector torque.

  • Refer to Procedure 006-052 in the Associated Procedures Table.

Injector high-pressure connector torque meets specifications?
YES NO
No Repair

Tighten the injector high-pressure connector(s). Refer to Procedure 006-052 in the Associated Procedures Table.

Go to 5C

Go to 4A

Guided Step 5C - Check for individual leaking injectors.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

Make sure the engine is at operating temperature before performing the test.

Action

Check for fuel leaks at individual injectors.

  • Cap off each injector, one at a time, with the injector leakage isolation tool. The service tool must be installed with the engine OFF. Refer to Procedure 005-236 in the Associated Procedures Table.

High-Pressure System Leak Down Test within specifications with an injector capped off?
YES NO

Replace the high-pressure connector and injector for the cylinder that is causing the high-pressure system leak down. Refer to Procedure 006-026 in the Associated Procedures Table.

Cap off additional injectors to identify the source of the high-pressure system leak down. Replace the high-pressure connector and injector for the cylinder(s) causing the high-pressure system leak down. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 6 - Perform the Fuel Injector Performance Test.

Guided Step 6A - Perform the Fuel Injector Performance Test.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel Injector Performance Test.

Make sure that the engine is at operating temperature before performing the test.

Action

Check for malfunctioning injector(s) using the INSITE™ electronic service tool Fuel Injector Performance Test, if available.

  • Refer to Procedure 014-014 in the Associated Procedures Table.

Injector performance within specifications?
YES NO
No Repair

A fuel injector issue has been identified.

Replace the high-pressure connector and injector for the cylinder(s) that do not meet specification. Refer to Procedure 006-026 in the Associated Procedures Table.

Upon completion of repair, repeat the Fuel Injector Performance Test to verify the injector is performing properly.

Go to 7A

Go to 7A

Guided Step 7 - Check the aftertreatment DPF restriction.

Guided Step 7A - Check the aftertreatment DPF restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment DPF Restriction Test.

Refer to Procedure 011-085 in the Associated Procedures Table.

Aftertreatment DPF restriction within specifications?
YES NO
No Repair

Remove and replace the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

NOTE: If the aftertreatment DPF required replacement for excessive ash and had not reached the normal ash cleaning interval, further troubleshooting is required. Check for lubricating oil consumption, coolant consumption, or previous repairs that may have corrected an issue resulting in lubricating oil or coolant consumption. Refer to the Ash Cleaning - Excessive troubleshooting symptom tree in Section TS, if necessary.

Go to 8A

Go to 8A

Guided Step 8 - Check the exhaust system.

Guided Step 8A - Inspect the exhaust for excessive smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke by performing the Snap Acceleration - Aftertreatment Disconnected Test.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.
  • To perform a Snap Acceleration Test, it may be necessary to use INSITE™ electronic service tool Setup for Dynamometer found under the Diagnostic Tests menu to allow the engine to reach high idle.

Refer to Procedure 014-013 in the Associated Procedures Table.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of the excessive black smoke.

 No Repair

Appropriate Engine Performance troubleshooting symptom tree

Go to 9A

Guided Step 9 - Check ECM calibration and clear fault codes.

Guided Step 9A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 9B

Go to 9B

Guided Step 9B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

NOTE: If the Aftertreatment DPF was replaced and the ECM was not recalibrated, the Aftertreatment Maintenance Filter Installation procedure must be performed. The Aftertreatment Maintenance Filter Installation is located in INSITE™ electronic service tool in the Advanced ECM Data menu.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 24-Oct-2013


FAULT CODE 3382 - Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Air Intake Manifold | Refer to Procedure 010-023 | ISB6.7 CM2250 | 4022254
Air Intake Manifold | Refer to Procedure 010-023 | ISC8.3 and ISL9 CM2250 | 4022257
Air Intake Manifold | Refer to Procedure 010-023 | ISX12/ISX11.9 CM2250 | 2883445
Air Intake Manifold | Refer to Procedure 010-023 | QSL9 CM2250 | 4022256
Air Intake Manifold | Refer to Procedure 010-023 | QSB6.7 CM2250 | 4022255
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2250 | 4022254
Air Intake Connection | Refer to Procedure 010-080 | ISC8.3 and ISL9 CM2250 | 4022257
Air Intake Connection | Refer to Procedure 010-080 | ISX12/ISX11.9 CM2250 | 2883445
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2250 | 4022256
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2250 | 4022255
EGR Cooler | Refer to Procedure 011-019 | ISB6.7 CM2250 | 4022254
EGR Cooler | Refer to Procedure 011-019 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Cooler | Refer to Procedure 011-019 | ISX15 CM2250 GX CM2250 | 4022250
EGR Cooler | Refer to Procedure 011-019 | ISX12/ISX11.9 CM2250 | 2883445
EGR Cooler | Refer to Procedure 011-019 | QSL9 CM2250 | 4022256
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2250 | 4022255
EGR Valve | Refer to Procedure 011-022 | ISB6.7 CM2250 | 4022254
EGR Valve | Refer to Procedure 011-022 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Valve | Refer to Procedure 011-022 | ISX15 CM2250 GX CM2250 | 4022250
EGR Valve | Refer to Procedure 011-022 | ISX12/ISX11.9 CM2250 | 2883445
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2250 | 4022256
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2250 | 4022255
EGR Connection Tubes | Refer to Procedure 011-025 | ISB6.7 CM2250 | 4022254
EGR Connection Tubes | Refer to Procedure 011-025 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Connection Tubes | Refer to Procedure 011-025 | QSL9 CM2250 | 4022256
EGR Connection Tubes | Refer to Procedure 011-025 | QSB6.7 CM2250 | 4022255
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX15 CM2250 GX CM2250 | 4022250
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX12/ISX11.9 CM2250 | 2883445
EGR Crossover Tube | Refer to Procedure 011-070 | ISX15 CM2250 GX CM2250 | 4022250
EGR Crossover Tube | Refer to Procedure 011-070 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2250 | 4022254
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2250GX CM2250 | 4022250
EGR Orifice Pressure Sensor | Refer to Procedure 019-461 | ISX15 CM2250 | 4022250
EGR Orifice Pressure Sensor | Refer to Procedure 019-461 | ISX12/ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control moduel (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active exhaust gas recirculation (EGR) valve fault codes. | Fault Code 1228, 1896, 2272, 2349, or 2353 active?
 | STEP 1B. Check for active EGR differential pressure sensor fault codes. | Fault Code 1866, 2273, or 2274 active?
 | STEP 1C. Check for active variable geometry turbocharger (VGT) fault codes. | Fault Code 1898 or 2387 active?
 | STEP 1D. Check for active fault codes. | Fault Code 125 active?
STEP 2. | Check the EGR orifice pressure sensor, if equipped. |
 | STEP 2A. Check the EGR orifice pressure sensor accuracy, if equipped. | INSITE™ electronic service tool reading within 102 mm-Hg [4 in-Hg] of local barometric pressure?
STEP 3. | Check the EGR system for leaks or restrictions. |
 | STEP 3A. Check the EGR system for leaks. | Leaks detected?
 | STEP 3B. Check the EGR differential pressure ports for plugging. | Debris or soot found in either EGR differential pressure port?
 | STEP 3C. Check the air intake manifold heater, if equipped. | Air intake manifold heater plugged or soot buildup?
 | STEP 3D. Check the EGR mass measurement assembly for leaks. | Leaks detected at the EGR mass measurement assembly?
 | STEP 3E. Check the EGR crossover tube for restriction. | Restriction or damage to the EGR crossover tube?
 | STEP 3F. Check the EGR valve for restriction. | Restriction or damage to the EGR valve?
 | STEP 3G. Check the EGR cooler for restriction. | Restriction or damage to the EGR cooler?
STEP 4. | Check the EGR delta pressure sensor and circuit. |
 | STEP 4A. Inspect the EGR delta pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2274 active?
STEP 5. | Check the engine control module (ECM) and engine harness. |
 | STEP 5A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the circuit response. | Fault Code 2274 active?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active EGR valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR valve fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1228, 1896, 2272, 2349, or 2353 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active EGR differential pressure sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR differential pressure sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1866, 2273, or 2274 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active VGT fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active VGT fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1898 or 2387 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 125 active?
YES | NO
No Repair | No Repair

Fault code 125 troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR orifice pressure sensor, if equipped.

Guided Step 2A - Check the EGR orifice pressure sensor accuracy, if equipped.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the EGR orifice pressure sensor accuracy, if equipped.

  • Start INSITE™ electronic service tool Data Monitor/Logger.

Compare INSITE™ electronic service tool reading for EGR orifice pressure to the local barometric pressure. Refer to Procedure 018-028 in Section V.

INSITE™ electronic service tool reading within 102 mm-Hg [4 in-Hg] of local barometric pressure?
YES NO
No Repair

Replace the EGR orifice pressure sensor. Refer to Procedure 019-461 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Check the EGR system for leaks or restrictions.

Guided Step 3A - Check the EGR system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR plumbing for leaks.

  • Leaks can be easily noted by traces of soot.

Leaks detected?
YES NO

Repair or replace the leaky component.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the EGR differential pressure ports for plugging.

Conditions

  • Turn keyswitch OFF.

Action

Remove the EGR differential pressure sensor.

Insect the EGR differential pressure ports for debris or soot plugging.

Use the following procedure for ISX15 CM2250. Refer to Procedure 011-066 in the Associated Procedures Table.

Use the following procedure for ISB6.7 CM2250, ISC8.3 and ISL9 CM2250. Refer to Procedure 010-080 in the Associated Procedures Table.

Note: Complete Step 3C before installing the air intake connection.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the restriction.

 No Repair

Go to 6A

Go to 3C

Guided Step 3C - Check the Air Intake Manifold Heater, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Note: If the engine is not equipped with a grid heater then skip to Step 3D.

Action

Inspect the air intake manifold heater for plugging or soot buildup.

  • Use the following procedure for ISB6.7 CM2250, ISC8.3, and ISL9 CM2250. Refer to Procedure 010-023 in the Associated Procedures Table.

Air intake manifold heater plugged or soot buildup?
YES NO

Clean or replace air intake manifold heater.

Refer to Procedure 010-023 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3D

Guided Step 3D - Check the EGR differential pressure sensor mounting surface for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR differential pressure sensor mounting surface for leaks.

  • Leaks can be easily noted by traces of soot. However, the EGR differential pressure sensor may need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Leaks detected at the EGR differential pressure sensor mounting surface?
YES NO

Repair or replace the leaking component.

Refer to Procedure 011-066 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3E

Guided Step 3E - Check the EGR crossover tube for restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR crossover tube for restrictions, kinks, or any other damage.

Use the following procedure for ISX CM2250. Refer to Procedure 011-070 in the Associated Procedures Table.

Use the following procedure for ISB6.7 CM2250, ISC8.3, and ISL9 CM2250. Refer to Procedure 011-025 in the Associated Procedures Table.

Restriction or damage to the EGR crossover tube?
YES NO

Clear the restriction or replace the EGR tube.

 No Repair

Go to 6A

Go to 3F

Guided Step 3F - Check the EGR valve for restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR valve for restrictions.

  • Refer to Procedure 011-022 in the Associated Procedures Table.

Restriction or damage to the EGR valve?
YES NO

Clear the restriction or replace the EGR valve.

Refer to Procedure 011-022 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3G

Guided Step 3G - Check the EGR cooler for restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR cooler for restrictions.

  • Refer to Procedure 011-019 in the Associated Procedures Table.

EGR cooler restricted?

YES NO

For ISX12/ISX11.9 CM2250 and ISX15 CM2250 engines:

Clear the restriction or replace the EGR cooler.

Refer to Procedure 011-019 in the Associated Procedures Table.

For ISB6.7 CM2250, ISC8.3 CM2250, and ISL9 CM2250 engines:

Replace the EGR cooler.

Refer to Procedure 011-019 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the EGR delta pressure sensor and circuit.

Guided Step 4A - Inspect the EGR delta pressure sensor and connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the EGR delta pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4B

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

A damaged sensor has been detected.

Replace the EGR delta pressure sensor.

Refer to Procedure 019-370 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the ECM and engine harness.

Guided Step 5A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 3383 - Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2250 | 4022254
Air Intake Connection | Refer to Procedure 010-080 | ISC8.3 and ISL9 CM2250 | 4022257
Air Intake Connection | Refer to Procedure 010-080 | ISX12/ISX11.9 CM2250 | 2883445
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2250 | 4022256
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2250 | 4022255
Exhaust Restriction | Refer to Procedure 011-009 | ISB6.7 CM2250 | 4022254
Exhaust Restriction | Refer to Procedure 011-009 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Restriction | Refer to Procedure 011-009 | ISX CM2250 GX CM2250 | 4022250
Exhaust Restriction | Refer to Procedure 011-009 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Restriction | Refer to Procedure 011-009 | QSL9 CM2250 | 4022256
Exhaust Restriction | Refer to Procedure 011-009 | QSB6.7 CM2250 | 4022255
EGR Valve | Refer to Procedure 011-022 | ISB6.7 CM2250 | 4022254
EGR Valve | Refer to Procedure 011-022 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Valve | Refer to Procedure 011-022 | ISX CM2250 GX CM2250 | 4022250
EGR Valve | Refer to Procedure 011-022 | ISX12/ISX11.9 CM2250 | 2883445
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2250 | 4022256
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2250 | 4022255
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX CM2250 GX CM2250 | 4022250
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2250 | 4022254
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for EGR valve fault codes. | Active or inactive counts of Fault Code 1228, 1896, 2272, 2349, or 2353?
 | STEP 1B. Check for VGT fault codes. | Fault Codes 1898, 2387, 3361, or 3616 active?
STEP 2. | Check the EGR differential pressure sensor and mounting surfaces for leaks or debris plugging. |
 | STEP 2A. Check the EGR differential pressure ports for leaks. | Leaks detected?
 | STEP 2B. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure sensor port?
STEP 3. | Check the EGR valve and exhaust restriction. |
 | STEP 3A. Inspect the EGR valve | Damaged or stuck open EGR valve?
 | STEP 3B. Check the exhaust system restriction. | Exhaust restriction within specifications?
STEP 4. | Check the EGR differential pressure sensor and circuit. |
 | STEP 4A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2274 active?
 | STEP 4C. Check the circuit response. | Fault Code 2273 active?
STEP 5. | Check the ECM and engine harness. |
 | STEP 5A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the circuit response. | Fault Code 2274 active?
 | STEP 5C. Check the circuit response. | Fault Code 2273 active?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for EGR valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1228, 1896, 2272, 2349, or 2353?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for VGT fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1898, 2387, 3361, or 3616 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR differential pressure sensor and mounting surfaces for leaks or debris plugging.

Guided Step 2A - Check the EGR differential pressure ports for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR differential pressure sensor and mounting surfaces for leaks.

  • Check the EGR differential pressure sensor for leaks. The sensor may need to be removed to inspect the o-ring.
  • On the ISX15 CM2250, check the EGR mass measurement assembly plugs for leaks. Refer to Procedure 011-066 in the Associated Procedures Table.
  • Leaks can be easily noted by traces of soot.

Leaks detected?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure sensor ports for plugging.

  • For ISX15 CM2250: Refer to Procedure 011-066 in the Associated Procedures Table.
  • For ISB6.7 CM2250 and ISC8.3 and ISL9 CM2250: Refer to Procedure 010-080 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure sensor port?
YES NO

Clear the debris.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the EGR valve and exhaust restriction.

Guided Step 3A - Inspect the EGR valve

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR valve from the engine.

Action

Inspect the EGR valve.

  • Check for a stuck open EGR valve
  • Check for a damaged EGR valve that allows flow when closed.
  • Refer to Procedure 011-022 in the Associated Procedures Table.

Damaged or stuck open EGR valve?
YES NO

Replace the EGR valve.

Refer to Procedure 011-022 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the exhaust system restriction.

Conditions

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Check exhaust system restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO
No Repair

Continue to investigate the cause of the high exhaust restriction.

Refer to Procedure 011-009 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the EGR differential pressure sensor and circuit.

Guided Step 4A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR valve differential pressure sensor SUPPLY pin and the EGR valve differential pressure sensor SIGNAL pin at the EGR valve differential pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

  • Fault Code 2273 active?
YES NO

A malfunctioning EGR differential pressure sensor has been detected.

Replace the EGR differential pressure sensor.

Refer to Procedure 019-370 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the ECM and engine harness.

Guided Step 5A - Inspect the ECM and engine harness connector pins.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5C

Go to 6A

Guided Step 5C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR valve differential pressure sensor SUPPLY pin and the EGR valve differential pressure sensor SIGNAL pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clean fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to 1A

Last Modified: 25-Nov-2013


FAULT CODE 3385 - Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Intake Manifold Temperature Sensor | Refer to Procedure 019-159 | ISX CM2250 GX CM2250 | 4022250
Intake Manifold Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold temperature. |
 | STEP 1A. Monitor intake manifold temperature. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Monitor intake manifold temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

The EGR valve was closed because the engine was operating with cold intake manifold temperatures for an extended period of time.

No repair is necessary

Replace the intake manifold temperature sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Jun-2012


FAULT CODE 3389 - Engine Exhaust Gas Recirculation (EGR) System - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISX CM2250 GX CM2250 | 4022250
EGR Valve | Refer to Procedure 011-022 | ISX12/ISX11.9 CM2250 | 2883445
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2250 | 4022256
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2250 | 4022255
EGR Mass Measurement Assembly | Refer to Procedure 011-066 | ISX CM2250 GX CM2250 | 4022250
EGR Mass Measurement Assembly | Refer to Procedure 011-066 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for EGR valve fault codes. | Active or inactive counts of Fault Codes 1228, 1896, 2272, 2349, or 2353?
 | STEP 1B. Check for VGT fault codes. | Fault Code 1898, 2387, 3361, or 3616 active?
 | STEP 1C. Check for sensor fault codes. | Fault codes related to the EGR differential pressure sensor, intake manifold pressure sensor, EGR orifice pressure sensor, or exhaust pressure sensor active?
STEP 2. | Check the EGR differential pressure sensor and mounting surfaces for leaks or debris plugging. |
 | STEP 2A. Check the EGR differential pressure ports for leaks. | Leaks detected at either the low or high EGR differential pressure tubes?
 | STEP 2B. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure sensor port?
STEP 3. | Check the EGR delta pressure sensor and circuit. |
 | STEP 3A. Check for air intake system leaks. | Leaks present?
STEP 4. | Check the EGR valve. |
 | STEP 4A. Inspect the EGR valve. | Damaged or stuck open EGR valve?
STEP 5. | Check the EGR delta pressure sensor and circuit. |
 | STEP 5A. Inspect the EGR delta pressure sensor and connector pins.. | Dirty or damaged pins?
 | STEP 5B. Check the circuit response. | Fault Code 2274 active?
 | STEP 5C. Check the circuit response. | Fault Code 2273 active?
STEP 6. | Check the ECM and engine harness |
 | STEP 6A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 6B. Check the circuit response. | Fault Code 2274 active?
 | STEP 6C. Check the circuit response. | Fault Code 2273 active?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active EGR valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Codes 1228, 1896, 2272, 2349, or 2353?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for VGT fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1898, 2387, 3361, or 3616 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the EGR differential pressure sensor, intake manifold pressure sensor, EGR orifice pressure sensor, or exhaust pressure sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the EGR differential pressure sensor, intake manifold pressure sensor, EGR orifice pressure sensor, or exhaust pressure sensor active?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR differential pressure sensor and mounting surfaces for leaks or debris plugging.

Guided Step 2A - Check the EGR differential pressure ports for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR mass measurement assembly for leaks.

  • Check the EGR differential pressure sensor for leaks. The sensor may need to be removed to inspect the o-rings between the EGR differential pressure sensor and the EGR mass measurement assembly for proper sealing
  • Check the EGR mass measurement assembly plugs for leaks.
  • Leaks should be easily noted by traces of soot.
  • Refer to Procedure 011-066 in the Associated Procedures Table.

Leaks detected?
YES | NO
No Repair | No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure sensor ports for plugging.

  • Refer to Procedure 011-066 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure sensor ports?
YES NO

Clear the debris.

  • Refer to Procedure 011-066 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the air intake system for leaks.

Guided Step 3A - Check for air intake system leaks.

Conditions

  • Engine operating.

Action

Check the air intake system for leaks.

  • Check the charge air cooler and connections for air leaks.
  • Check for air leaks in connections between the turbocharger and the intake manifold.

Leaks present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check the EGR valve.

Guided Step 4A - Inspect the EGR valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR valve from the engine.

Action

Inspect the EGR valve

  • Check for a stuck open EGR valve.
  • Check for a damaged EGR valve that allows flow when closed.
  • Refer to Procedure 011-022 in the Associated Procedures Table.

Dirty or damaged pins?
YES NO

Replace the EGR valve.

  • Refer to Procedure 011-022 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the EGR delta pressure sensor and circuit.

Guided Step 5A - Inspect the EGR dealta pressure sensor and pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 2359 inactive?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR valve delta pressure sensor SUPPLY pin and the EGR valve delta pressure sensor SIGNAL pin at the EGR valve delta pressure sensor connector of th engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 2273 active?
YES NO

A malfunctioning EGR differential pressure sensor has been detected. Replace the EGR differential pressure sensor.

  • Refer to Procedure 019-370 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the ECM and engine harness.

Guided Step 6A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harnes from the ECM connectos.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5B

Guided Step 6B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harnes from the ECM connectos.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 2274 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 6C

Go to 7A

Guided Step 6C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harnes from the EC Mconnectors.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR valve delta pressure sensor SUPPLY pin and the EGR valve delta pressure sensor SIGNAL pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 2273 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 3753 - Diesel Particulate Filter Active Regeneration Inhibited Due to System Timeout - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active faults. |
 | STEP 1A. Check for active faults. | Any fault codes other than Fault Code 3753 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Any fault codes other than Fault Code 3753 active?

After completion of troubleshooting any other active fault code, perform an INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test (unless this test was directed to be performed while troubleshooting any other active fault code).

YES NO
No Repair

This is an information only fault code, indicating that the ECM is requesting active regeneration of the aftertreatment but is unable to perform active regeneration of the aftertreatment system.

It is possible to perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test with this Fault Code active.

No repair is necessary.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Jun-2012


FAULT CODE 5383 - Aftertreatment 1 Diesel Particulate Filter Ash Load Percent - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX15 CM2250 GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 1879, 1881, or 1883 active or inactive?
STEP 2. | Determine the aftertreatment diesel particulate filter (DPF) mileage and/or hours remaining. |
 | STEP 2A. Determine the aftertreatment DPF mileage and/or hours remaining. | One or more aftertreatment DPF maintenance indicators reached specification?
 | STEP 2B. Check aftertreatment DPF restriction. | Aftertreatment DPF restriction within specifications?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, or 1883 active or inactive?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Determine the aftertreatment diesel particulate filter (DPF) mileage and/or hours remaining.

Guided Step 2A - Determine the aftertreatment DPF mileage and/or hours remaining.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the following parameters with INSITE™ electronic service tool:

  • Aftertreatment Diesel Particulate Filter Remaining Distance
  • Aftertreatment Diesel Particulate Filter Remaining Hours
  • Diesel Particulate Filter Ash Adjustment Factor.

Determine if the following parameters have reached specification:

  • Aftertreatment Diesel Particulate Filter Remaining Distance - 0 miles [0 kilometers] (starting value of 200,000 miles [321,869 kilometers]
  • Aftertreatment Diesel Particulate Filter Remaining Hours - 0 hours [starting value of 4,500 hours]
  • Diesel Particulate Filter Ash Adjustment Factor - 4.5 g/L.

One or more aftertreatment DPF maintenance indicators reached specification?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check the aftertreatment DPF restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Diesel Particulate Filter Restriction Test.

  • Refer to Procedure 011-085 in the Associated Procedures Table.

Aftertreatment DPF restriction within specifications?
YES NO
No Repair

Remove and replace or properly clean the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table. Note: If the aftertreatment DPF required replacement for excessive ash and had not reached the normal ash cleaning interval, further troubleshooting is required. Check for lubricating oil consumption, coolant consumption, or previous repairs that may have corrected an issue resulting in lubricating oil or coolant consumption. Refer to the Coolant Loss - Internal troubleshooting symptom tree in Section TS, if necessary.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Oct-2014


FAULT CODE 436 - Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 436 active?
 | STEP 1B. Check for Fault Codes 153 and 154. | Fault Code 153 or 154 active?
STEP 2. | Check the engine intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the engine intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active?
 | STEP 2C. Check the circuit response. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 153 active?
 | STEP 3C. Check the circuit response. | Fault Code 154 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Intake manifold temperature and ambient air temperature reading within 5.6°C or 10°F of each other?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 436 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for Fault Codes 153 and 154.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 or 154 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the engine intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the OEM wiring harness.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 will also be active when the intake manifold temperature sensor is disconnected.

Fault Code 153 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold temperature SIGNAL pin and the engine intake manifold temperature RETURN pin at the engine intake manifold temperature connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

An in-range malfunction of the intake manifold temperature sensor has been detected.

Replace the engine intake manifold temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 is active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold temperature SIGNAL pin and engine intake manifold temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger.

  • Compare INSITE™ electronic service tool reading for intake manifold temperature to ambient air temperature.

Intake manifold temperature and ambient air temperature reading within 5.6°C or 10°F of each other?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Jul-2012


FAULT CODE 1668 (2-Wire Sensor) - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Aftertreatment Adapter Pipe | Refer to Procedure 019-043 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inative fault code. | Fault Code 1668 is inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1669 active and Fault Code 1668 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1668 is active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to ground short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault code inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 is inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in the Associated Procedures Table.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and aftertreatment diesel exhaust fluid tank level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftetreatment diesel exhaust fluid tank level sensor from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after one minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid tank level sensor to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 is active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to the OEM service manual.

None. The removal and reinstallation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the aftertreatment diesel exhaust fluid controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the diesel exhaust fluid controller harness and or the connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller connector from the controller.
  • Turn keyswitch ON.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the aftertreatment diesel exhaust fluid level SIGNAL pin at the aftertreatment diesel exhaust fluid controller connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure and a wiring diagram for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to ground short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin short to ground.

  • Measure the resistance and check for a short circuit between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin at the aftertreatment diesel exhaust fluid controller harness connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure and a wiring diagram for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Repair or replace the harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after one minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A damaged aftertreatment diesel exhaust fluid controller has been detected.

Replace the aftertreatment diesel exhaust fluid controller. Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Jul-2012


FAULT CODE 1668 (3-Wire Sensor) - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 3557 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1668 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1669 active and Fault Code 1668 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1668 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1668 inactive?
STEP 4. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3557 active?
YES | NO
No Repair | No Repair

Reference the Fault Code 3557 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid level sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel exhaust fluid level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel exhaust fluid level SUPPLY pin and the aftertreatment diesel exhaust fluid level RETURN pin at the aftertreatment diesel exhaust fluid level sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid level sensor SUPPLY pin and the aftertreatment diesel exhaust fluid level sensor SIGNAL pin at the aftertreatment diesel exhaust fluid level sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active?
YES NO

A damaged sensor has been detected.

  • Replace the aftertreatment diesel exhaust fluid level sensor. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and OEM harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 86-pin harness connector from the aftertreatment diesel exhaust fluid controller.

Action

Inspect the OEM harness and aftertreatment diesel exhaust fluid controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment diesel exhaust fluid controller connector or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment diesel exhaust fluid controller.
  • Disconnect the aftertreatment diesel exhaust fluid level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between aftertreatment diesel exhaust fluid level sensor SIGNAL pin at the 86-pin connector and the aftertreatment diesel exhaust fluid level sensor SIGNAL pin at the harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure and a wiring diagram for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the open return circuit.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment diesel exhaust fluid controller.
  • Disconnect the aftertreatment diesel exhaust fluid level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid level sensor SIGNAL pin in the aftertreatment diesel exhaust fluid controller 86-pin connector and all other pins in the 86-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure and a wiring diagram for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment diesel exhaust fluid controller.
  • Disconnect the aftertreatment diesel exhaust fluid level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid level sensor SIGNAL pin in the aftertreatment diesel exhaust fluid controller 86-pin connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure and a wiring diagram for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal wire has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Feb-2013


FAULT CODE 1669 (2-Wire Sensor) - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1669 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 1668 active and fault code 1669 inactive?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the aftertreatment diesel exhaust fluid harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1669 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhuast fluid tank level sensor from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and aftertreatment diesel exhaust fluid tank level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 1 minute.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank level SIGNAL pin and the aftertreatment diesel exhaust fluid tank level RETURN pin at the aftertreatment diesel exhaust fluid tank level OEM harness connector.
  • Use INSITE™ electronic service tool to read the active fault codes.

Fault code 1668 active and fault code 1669 inactive?
YES NO

Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment diesel exhaust fluid controller harness or controller connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the aftertreatment diesel exhaust fluid controller harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank level sensor RETURN pin at the controller connector and the aftertreatment diesel exhaust fluid tank level sensor connector RETURN pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the aftertreatment diesel exhaust fluid harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin at the controller connector and the aftertreatment diesel exhaust fluid tank level sensor connector SIGNAL pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank level SIGNAL pin in the controller connector and all other pins in the controller connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Jul-2012


FAULT CODE 1669 (3-Wire Sensor) - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3557 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1669 inactive
STEP 2. | Check the aftertreatment diesel exhaust fluid level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1668 active and Fault Code 1669 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1669 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1669 inactive?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3557 active?

YES | NO
No Repair | No Repair

Refer to Fault Code 3557

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 inactive?

YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhuast fluid level sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel exhaust fluid level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 1 minute.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1668 active and Fault Code 1669 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel exhaust fluid level sensor SUPPLY pin and the aftertreatment diesel exhaust fluid level sensor RETURN pin at the aftertreatment diesel exhaust fluid level sensor connector of the OEM harness.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1669 active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and OEM harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the 86-pin connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment diesel exhaust fluid controller.
  • Disconnect the aftertreatment diesel exhaust fluid level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid level sensor RETURN pin at the aftertreatment diesel exhaust fluid controller 86-pin connector and the aftertreatment diesel exhaust fluid level sensor harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment diesel exhaust fluid controller.
  • Disconnect the aftertreatment diesel exhaust fluid level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid level sensor SIGNAL pin in the 86-pin connector and all other pins in the 86-pin connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment diesel exhaust fluid controller.
  • Disconnect the aftertreatment diesel exhaust fluid level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid level sensor SUPPLY pin in the 86-pin connector and all other pins in the 86-pin connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Feb-2013


FAULT CODE 1673 - Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module (ECM) Calibration | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1673 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1673 active?
YES NO

A low aftertreatment diesel exhaust fluid (DEF) level has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2015


FAULT CODE 1677 - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead AND Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1677 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1678 active and Fault Code 1677 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1677 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1678 active and Fault Code 1677 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and aftertreatment diesel exhaust fluid tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1678 active and Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid tank temperature sensor to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 is active?
YES NO

Replace the aftertreatment diesel exhaust fluid tank temperature sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Codes 1669, 3258, 3261, 3425, 3429, 3561, 3571, 3576, and 3579 will also be active.

Fault Code 1678 is active and Fault Code 1677 inactive?
YES NO

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1678 - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1678 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit resistance. | Fault code 1677 active and fault code 1678 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1678 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1677 active and Fault Code 1678 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and aftertreatment diesel exhaust fluid tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank temperature SIGNAL pin and the aftertreatment diesel exhaust fluid tank temperature RETURN pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1677 active and fault code 1678 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid tank temperature sensor to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES NO

Replace the aftertreatment diesel exhaust fluid tank temperature sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller connector.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin and the aftertreatment diesel exhaust fluid tank temperature sensor RETURN pin at the controller.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

NOTE: Fault Codes 1669, 3258, 3261, 3425, 3429, 3561, 3571, 3576, and 3579 will also be active.

Fault Code 1677 active and Fault Code 1678 inactive?
YES NO

A short or open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1679 - Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1677 or 1678 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1678 active?
 | STEP 2C. Check the circuit response. | Fault Code 1677 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1678 active?
 | STEP 3C. Check the circuit response. | Fault Code 1677 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 or 1678 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and aftertreatment diesel exhaust fluid tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment diesel exhaust fluid tank temperature SIGNAL pin and the aftertreatment diesel exhaust fluid tank temperature RETURN pin at the aftertreatment diesel exhaust fluid tank temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES NO

Replace the aftertreatment diesel exhaust fluid tank temperature sensor.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment diesel exhaust fluid controller harness connector or controller.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid controller.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment diesel exhaust fluid tank temperature SIGNAL pin and aftertreatment diesel exhaust fluid tank temperature RETURN pin at the controller connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES NO

High resistance or a short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the aftertreatment diesel exhaust fluid controller harness.

Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1681 - Aftertreatment Diesel Exhaust Fluid Dosing Unit - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1681 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1681 active?
YES NO

Replace the aftertreatment diesel exhaust fluid dosing unit.

  • Refer to 011-058 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1682 - Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit Input Lines - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | GX CM2250 | 4022250
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | GX CM2250 | 4022250
Engine Control Module Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

WARNING

To reduce the possibility of personal injury to the eyes, wear appropriate eye protection when removing the reagent nozzle line. Air pressure may be present in the reagent nozzle line if there is a fault in the system.
WARNING

The exhaust and exhaust components can become heated during troubleshooting. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning any procedure or repair and make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1682 active or more than two inactive counts?
 | STEP 1B. Check for low aftertreatment DEF tank level. | Aftertreatment DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1C. Check for related fault codes. | Fault Code 3574, 3575, 3569, or 3596 active or more than two inactive counts?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Perform the aftertreatment DEF system test. | Any leaking lines, fittings, or connections found?
 | STEP 2B. Inspect the aftertreatment DEF dosing unit lines and fittings. | Any reversed, damaged, leaking, or restricted connections found?
 | STEP 2C. Check the aftertreatment DEF dosing unit supply line. | DEF dosing unit supply line blocked or restricted?
 | STEP 2D. Check for air in the aftertreatment DEF. | Air in the DEF detected?
 | STEP 2E. Inspect the aftertreatment DEF dosing unit supply line fitting. | Dosing unit supply line fitting blocked?
STEP 3. | Check the DEF dosing valve circuit. |
 | STEP 3A. Check for a pin-to-pin short circuit in the aftertreatment DEF dosing valve circuit. | Greater than 100k ohms?
STEP 4. | Check the aftertreatment DEF tank filter. |
 | STEP 4A. Inspect the aftertreatment DEF tank filter for blockage. | Aftertreatment DEF tank filter blocked?
STEP 5. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 5A. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063 in the Associated Procedures Table?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1682 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty, and the level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Codes: 1673, 3497, and 3498.

Aftertreatment DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the aftertreatment DEF tank.

 No Repair

Go to 5A

Go to 1C

Guided Step 1C - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3574, 3575, 3569, or 3596 active or more than two inactive counts?
YES NO

Troubleshoot occurrences of Fault Code 3574, 3575,3569, or 3596 before troubleshooting Fault Code 1682.

 No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Perform the aftertreatment DEF system leak test.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF System Leak Test, under ECM Diagnostic Tests.

  • Refer to Procedure 011-080 in the Associated Procedures Table.

While the test is running, inspect all DEF lines, fittings, and connections for external leaks.

Any leaking lines, fittings, or connections found?
YES NO

Repair or replace the leaking DEF line or fitting, as necessary. Refer to the original equipment manufacturer (OEM) service manual.

Repair or replace the aftertreatment DEF dosing unit, as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Inspect the aftertreatment DEF dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

There are three aftertreatment DEF lines on the SCR dosing system:

1. Dosing unit supply line between the tank and the dosing unit (suction line).

2. Dosing valve supply line between the dosing unit and the dosing valve (pressure line)

3. Return line between the dosing unit and the tank (return line).

Inspect all three aftertreatment DEF lines and associated fittings/connectors:

  • Verify the suction and return line connections are not swapped at the dosing unit or aftertreatment DEF tank connections. Reversed aftertreatment DEF line connectors cause the dosing unit to fail to prime.
  • Check the aftertreatment DEF tank connections (suction and return lines) for cracks and pitting.
  • Check all three dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line, pressure line, and return line dosing unit connectors and look for signs of buildup or blockage.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the aftertreatment DEF.
  • Verify proper sealing at all connection points, including aftreatment DEF tank (2 connections), dosing unit (3 connections), and dosing valve (1 connection).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any reversed, damaged, leaking, or restricted connections found?

YES NO

Repair or replace the leaking aftertreatment DEF line or fitting as necessary.

Refer to the original equipment manufacturer (OEM) service manual.

Repair or replace the aftertreatment DEF dosing unit as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the aftertreatment DEF dosing unit supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit supply line from the dosing unit (this is the suction line between the dosing unit and the aftertreatment DEF tank).
  • Disconnect the aftertreatment DEF dosing unit supply line from the aftertreatment DEF tank.

Action

Check the aftertreatment DEF dosing unit supply line for blockage.

  • Check both ends of the dosing unit supply line for signs of buildup or blockage.
  • Blow compressed shop air through the dosing unit supply line to make sure of free flow.

Aftreatment DEF dosing unit supply line blocked or restricted?
YES NO

Try to clean the dosing unit supply line with shop air. If necessary, replace the dosing unit supply line.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check for air in the diesel exhaust fluid.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the aftertreatment DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the aftertreatment DEF detected?
YES NO

Check the following components for damage/leaks and repair as necessary:

  • Aftertreatment DEF dosing unit fittings
  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2E

Guided Step 2E - Inspect the aftertreatment DEF dosing unit supply line fitting.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DEF dosing supply line and fitting.

Action

Inspect the aftertreatment DEF dosing unit supply line fitting for blockage.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Dosing unit supply line fitting blocked?
YES NO

Replace the aftreatment DEF dosing unit supply line fitting.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftreatment DEF dosing valve circuit.

Guided Step 3A - Check for a pin-to-pin short circuit in the aftertreatment DEF dosing valve circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness from the 86-pin connector.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and RETURN pin of the aftertreatment DEF controller harness 86-pin connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness.

Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the aftertreatment DEF tank filter.

Guided Step 4A - Inspect the aftertreatment DEF tank filter for blockage.

Conditions

  • Turn keyswitch OFF.
  • Remove the tank level and temperature sensor from the aftreatment DEF tank.

Action

Inspect the aftertreatment DEF tank filter for signs of blockage or buildup.

Refer to the OEM service manual.

Aftreatment DEF tank filter blocked?
YES NO

Clean or replace the aftreatment DEF tank filter.

Drain, clean, and refill the aftreatment DEF tank.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check the aftreatment DEF dosing unit operation.

Guided Step 5A - Check the aftreatment DEF dosing unit for proper operation.

Conditions

  • Connect all aftreatment DEF lines and electrical connectors to the dosing unit and aftreatment DEF tank.
  • Remove aftertreatment DEF fluid dosing valve from decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

NOTE: The aftreatment DEF dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Aftreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftreatment DEF dosing unit filter. (Note that this filter can not be reused and must be changed upon removal.)

Refer to Procedure 011-060 in the Associated Procedures Table.

Perform the Aftreatment DEF Doser Pump Override Test again with the new filter. If the measured volume of aftertreatment DEF is still not within specifications, replace the aftreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2013


FAULT CODE 1683 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1683 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1683 inactive and Fault Code 3576 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid tank heater control valve condition. | Fault Code 1683 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1683 inactive and Fault Code 3576 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the engine harness and aftertreatment diesel exhaust fluid tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1683 inactive and Fault Code 3576 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid tank heater control valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid tank heater control valve to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1683 active?
YES NO

A malfunctioning aftertreatment diesel exhaust fluid tank heater control valve has been detected.

Replace the aftertreatment diesel exhaust fluid tank heater control valve. Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3571, and 3579 will also be active.

Fault Code 1683 inactive and Fault Code 3576 active?
YES NO

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1684 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1684 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1684 inactive and Fault Code 3576 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid tank heater control valve condition. | Fault Code 1684 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1684 inactive and Fault Code 3576 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for active or intermittent fault code.Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and aftertreatment diesel exhaust fluid tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 inactive and Fault Code 3576 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid tank heater control valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid tank heater control valve to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 active?
YES NO

A malfunctioning aftertreatment diesel exhaust fluid tank heater control valve has been detected.

Replace the aftertreatment diesel exhaust fluid tank heater control valve.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3571, and 3579 will also be active.

Fault Code 1684 inactive and Fault Code 3576 active?
YES NO

A short circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1688 - Aftertreatment Diesel Exhaust Fluid Controller - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2250 | 4022254
ECM Calibration Code | Refer to Procedure 019-032 | ISC8.3 and QSL9 CM2250 | 4022257
ECM Calibration Code | Refer to Procedure 019-032 | ISX15 CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1688 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components
  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1688 active?
YES NO

Replace the aftertreatment diesel exhaust fluid controller. Refer to Procedure 011-057 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1694 - Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | GX CM2250 | 4022250
Aftertreatment Intake Nox Sensor | Refer to Procedure 019-463 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1694 active?
 | STEP 1B. Check for active fault codes. | Fault codes 1887, 2771, 3545, 3583, 3681, or 3749 active?
 | STEP 1C. Check the SCR catalyst dosing control unit for proper operation. | Fault codes 1885, 3228, 3232, 3649, 3682, 3725, or 3748 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid decomposition tube. |
 | STEP 2A. Check the decomposition tube for crystallization. | Fault Code 1694 active?
STEP 3. | Verify the condition of the aftertreatment NOx sensors. |
 | STEP 3A. Verify the condition of the aftertreatment NOx sensors. | Fault Code 1694 active?
 | STEP 3B. Disable the fault code. | Fault code inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1694 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment outlet NOx sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes 1887, 2771, 3545, 3583, 3681, or 3749 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment intake NOx sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes 1885, 3228, 3232, 3649, 3682, 3725, or 3748 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid decomposition tube.

Guided Step 2A - Check the decomposition tube for crystallization.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid decomposition tube. Refer to Procedure 011-062 in the Associated Procedures Table.

Action

Check for diesel exhaust fluid crystallization.

  • Inspect the decomposition tube for crystallization.
  • Refer to Procedure 011-062 in the Associated Procedures Table.

Crystallization build up in the decomposition tube?
YES NO

Remove the crystallization build up.

Refer to Procedure 011-062 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Verify the condition of the aftertreatment NOx sensors.

Guided Step 3A - Verify the condition of the aftertreatment NOx sensors.

Conditions

  • Turn keyswitch ON.
  • Start and run the engine at idle.
  • Connect INSITE™ electronic service tool.
  • Perform the Aftertreatment Diesel Particulate Filter Regeneration Test under the ECM Diagnostics Tests menu. Refer to Procedure 014-013 in the Associated Probedures Table.

Action

Verify the sensor condition.

  • Use INSITE™ electronic service tool to read the active faults.

Fault Code 1694 active?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment intake NOx sensor.

  • Use INSITE™ electronic service tool to read the fault code.

Fault code 3228 active?
YES NO

Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1712 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, or 3576 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heating system. |
 | STEP 2A. Inspect the diesel exhaust fluid tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level correct?
STEP 3. | Check the aftertreatment diesel exhaust fluid tank heater operation. |
 | STEP 3A. Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heater control valve operating correctly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for diesel exhaust fluid tank heater or diesel exhaust fluid tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, or 3576 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heating system.

Guided Step 2A - Inspect the diesel exhaust fluid tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines (including OEM in-line shutoff valve, if equipped)
  • Loose connections
  • Leaking seals or gaskets.

Refer to the OEM service manual for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check engine coolant level.

  • Make sure that the coolant level is within normal operating levels.

Coolant level correct?
YES NO
No Repair

Add coolant to the engine as necessary.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid tank heater operation.

Guided Step 3A - Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.

  • Make sure the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Refer to OEM service manual for details on the tank heater control valve.

Diesel exhaust fluid tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the diesel exhaust fluid tank heater control valve.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1713 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, or 3576 active or high inactive counts?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heating system. |
 | STEP 2A. Inspect the diesel exhaust fluid tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level correct?
STEP 3. | Check the aftertreatment diesel exhaust fluid tank temperature sensor. |
 | STEP 3A. Check the aftertreatment diesel exhaust fluid tank temperature sensor. | INSITE™ electronic service tool reading within 10°C or 18°F of infared thermometer reading?
STEP 4. | Check the aftertreatment diesel exhaust fluid tank heater operation. |
 | STEP 4A. Verify that the aftertreatment diesel exhaust fluid tank heater control valve is installed correctly. | Diesel exhaust fluid tank heater control valve installed correctly?
 | STEP 4B. Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heater control valve operating correctly?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for diesel exhaust fluid tank heater or diesel exhaust fluid tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, or 3576 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heating system.

Guided Step 2A - Inspect the diesel exhaust fluid tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines
  • Loose connections
  • Leaking seals or gaskets.

Refer to the OEM service manual for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check engine coolant level.

  • Make sure that coolant level is within normal operating levels.

Coolant level correct?
YES NO
No Repair

Add coolant to engine as necessary.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid tank temperature sensor.

Guided Step 3A - Check the aftertreatment diesel exhaust fluid tank temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Measure the temperature of the diesel exhaust fluid in the diesel exhaust fluid tank with an infrared thermometer.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer.

INSITE™ electronic service tool reading within 10°C or 18°F of infared thermometer reading?
YES NO
No Repair

Replace the diesel exhaust fluid tank temperature sensor.

  • Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the aftertreatment diesel exhaust fluid tank heater operation.

Guided Step 4A - Verify that the aftertreatment diesel exhaust fluid tank heater control valve is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the installation of the tank heater control valve.

  • Make sure that the tank heater control valve is installed correctly, and not reversed.

Refer to the OEM service manual for details on the tank heater control valve.

Diesel exhaust fluid tank heater control valve installed correctly?
YES NO
No Repair

Remove the diesel exhaust fluid tank heater control valve, and install it in the correct position. Make sure the valve is not reversed according to the coolant flow direction (where applicable).

Refer to the OEM service manual.

Go to 4B

Go to 5A

Guided Step 4B - Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.

  • Make sure the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Make sure the tank heater control valve is installed correctly, and not reversed.

Refer to the OEM service manual for details on the tank heater control valve.

Diesel exhaust fluid tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the diesel exhaust fluid tank heater control valve.

Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1887 - Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | GX CM2250 | 4022250

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault code 2771 or 3681 is active?
 | STEP 1B. Check for active fault codes. | Fault Code 1887 is active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 2771 or 3681 is active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887 is active?
YES NO

An internal error has been detected in the aftertreatment outlet NOx sensor.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1893 - EGR Valve Control Circuit - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | Westport HD CM2250 | 3666239
Engine Control Module (ECM) | Refer to Procedure 019-031 | Westport HD CM2250 | 4022250
Calibration Code | Refer to Procedure 019-032 | Westport HD CM2250 | 4021560
Engine Wiring Harness | Refer to Procedure 019-043 | Westport HD CM2250 | 4021560

Cautions and Warnings

WARNING

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1893 inactive?
STEP 2. | Check the EGR valve circuit. |
 | STEP 2A. Inspect the EGR valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the EGR valve ground circuit. | Wiring harness eyelet tightly connected to the engine block ground stud?
 | STEP 2C. Check the voltage to the EGR valve. | Voltage greater than +11-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the EGR valve voltage at the ECM. |
 | STEP 3A-2. Check the voltage to the ECM. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the SAE J1939 data link termination resistor. |
 | STEP 3B-2. Check for an open circuit in the SAE J1939 data link harness. |
 | STEP 3B-3. Check for a short circuit in the SAE J1939 data link harness. |
 | STEP 3B-4. Check for a short circuit to ground in the SAE J1939 data link harness. |
 | STEP 3B-5. Check the fault codes. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent active and inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the EGR valve circuit.

Guided Step 2A - Inspect the EGR valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected at the EGR valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the EGR valve ground circuit.

Conditions

  • Turn keyswitch OFF.

Action

Check to make sure the engine wiring harness ground eyelet is tightly connected to the engine block ground.

The grounding stud is located behind the starter.

Wiring harness eyelet tightly connected to the engine block ground stud?
YES NO
No Repair

A loose ground circuit has been detected at the engine block.

Tighten the ground connection.

Go to 2C

Go to 4A

Guided Step 2C - Check the voltage to the EGR valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the EGR valve.

  • Measure the voltage between the EGR valve 12 volt SUPPLY circuit and the EGR valve RETURN circuit at the engine harness connector.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than +11-VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the EGR valve voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the EGR valve.

  • Measure the voltage between the EGR valve power SUPPLY circuit at the ECM connector and engine block ground.

Check the voltage at key ON and while cranking the engine.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than +11-VDC?
YES NO

An open circuit in the EGR valve power SUPPLY or RETURN circuit has been detected in the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-2

Guided Step 3A-2 - Check the voltage to the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the ECM.

  • Measure the voltage between the ECM power SUPPLY circuit and the ECM RETURN circuit at the OEM power harness connector.

Check the voltage at key ON and while cranking the engine.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than +11-VDC?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Low voltage has been detected at the ECM power connector.

Check the battery voltage and the OEM wiring between the battery and the ECM power harness connector.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the SAE J1939 data link termination resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link termination resistor from the engine harness.

Action

Check the SAE J1939 data link termination resistor.

  • Measure the resistance between SAE J1939 data link (+) and SAE J1939 data link (-) at the SAE J1939 termination resistor.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 110 and 130 ohms?
YES NO
No Repair

Replace the SAE J1939 data link termination resistor.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an open circuit in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the SAE J1939 data link termination resistor from the engine harness.

Action

Check for an open circuit in the SAE J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the EGR valve engine harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the EGR valve engine harness connector and the SAE J1939 data link (-) wire at the ECM engine harness connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the SAE J1939 data link harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check for a short circuit in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Disconnect the VGT actuator from the harness.
  • Disconnect the engine harness from the ECM connector.
  • Remove the SAE J1939 data link termination resistor from the engine harness.

Action

Check for a short circuit in the SAE J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

A value of 120 ohms will be read when the resistance is measured between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire. This is the resistance of the data link termination resistor and is a normal reading.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check for a short circuit to ground in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the VGT actuator from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the SAE J1939 data link harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-5

Go to 4A

Guided Step 3B-5 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the EGR valve to the engine harness.
  • Connect the VGT actuator to the engine harness.
  • Connect the SAE J1939 data link termination resistor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES NO

Replace the EGR valve motor. Refer to Procedure 011-022 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1895 - EGR Valve Controller - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Exhaust Gas Recirculation (EGR) Valve | Refer to Procedure 011-022 | Westport HD CM2250 | 3666239
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | Westport HD CM2250 | 4021560

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the EGR valve. |
 | STEP 1A. Check the part number of the EGR valve. | EGR valve part number correct for application?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the EGR valve.

Guided Step 1A - Check the part number of the EGR valve.

Conditions

  • Turn keyswitch OFF.

Action

Check the part number.

  • Check the part number of the EGR valve and make sure the part number is correct for the application.

EGR valve part number correct for the application?
YES NO
No Repair

An incorrect EGR valve has been installed on the engine.

Replace the EGR valve. Refer to Procedure 011-022 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1896 - EGR Valve Controller - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Exhaust Gas Recirculation (EGR) Valve | Refer to Procedure 011-022 | Westport HD CM2250 | 3666239
Aftertreatment Testing | Refer to Procedure 014-013 | Westport HD CM2250 | 3666239
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | Westport HD CM2250 | 4021560

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1893 active?
STEP 2. | Check the EGR valve operation. |
 | STEP 2A. Check for active fault codes. | Fault Code 1896 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 1893 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the EGR valve operation.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Turn the keyswitch OFF for 10 seconds and then turn the keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES NO

A stuck open EGR valve has been detected.

  • Clean the EGR valve assembly, if possible. If not, replace if necessary. Refer to Procedure 011-022 in the Associated Procedures Table.
  • Perform the Snap-Acceleration Test to check for a damaged diesel particulate filter. Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1925 - Aftertreatment Fuel Shutoff Valve 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | GX CM2250 | 4022250
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | GX CM2250 | 4022250
Aftertreatment Purge Air Actuator | Refer to Procedure 011-065 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1926, 1927, or 1928 active?
STEP 2. | Inspect the aftertreatment fuel pressure sensor. |
 | STEP 2A. Verify the sensor accuracy. | INSITE™ electronic service tool reading for aftertreatment fuel pressure is within 77 mm-Hg [3 in-Hg] of local barometric pressure?
STEP 3. | Inspect the aftertreatment fuel shutoff valve. |
 | STEP 3A. Check for a stuck open or leaking aftertreatment fuel shutoff valve. | Fuel leaking from the aftertreatment fuel injector supply line extension?
STEP 4. | Inspect the aftertreatment purge air actuator. |
 | STEP 4A. Check for a stuck open or leaking aftertreatment purge air actuator. | Air flowing from the end of the extension line?
STEP 5. | Inspect the aftertreatment fuel injector. |
 | STEP 5A. Check the flow of the aftertreatment fuel injector. | Does the aftertreatment fuel injector meet the specifications?
 | STEP 5B. Check the flow of the aftertreatment fuel injector. | Does the aftertreatment fuel injector meet the specifications?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Disable the fault code.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment fuel injector system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1926, 1927, or 1928 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Inspect the aftertreatment fuel pressure sensor.

Guided Step 2A - Verify the sensor accuracy.

Conditions

  • Disconnect the aftertreatment fuel supply line from the aftertreatment fuel injector.
  • Connect the fuel extension line, Part Number 4918519.
  • Place the end of the line in an empty fuel container.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

With keyswitch ON and engine OFF, the aftertreatment fuel pressure and barometric pressure readings must agree.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for aftertreatment fuel pressure to the reading for barometric pressure.

INSITE™ electronic service tool reading for aftertreatment fuel pressure is within 77 mm-Hg [3 in-Hg] of local barometric pressure?

YES NO
No Repair

A damaged aftertreatment fuel pressure sensor has been detected.

Replace the aftertreatment fuel pressure sensor.

Refer to Procedure 011-052 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Inspect the aftertreatment fuel shutoff valve.

Guided Step 3A - Check for a stuck open or leaking aftertreatment fuel shutoff valve.

Conditions

  • Disconnect the aftertreatment fuel supply line from the aftertreatment fuel injector.
  • Connect the fuel extension line, Part Number 4918519.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Action

Check for a stuck open or leaking aftertreatment fuel shutoff valve.

Check for fuel leaking from the supply line extension. There must not be any fuel coming out of the aftertreatment fuel injector supply line extension.

Fuel leaking from the aftertreatment fuel injector supply line extension?
YES NO

A leaking aftertreatment fuel shutoff valve has been detected.

Replace the aftertreatment fuel shutoff valve.

Refer to Procedure 011-052 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Inspect the aftertreatment purge air actuator.

Guided Step 4A - Check for a stuck open or leaking aftertreatment purge air actuator.

Conditions

  • Disconnect the aftertreatment fuel supply line from the aftertreatment fuel injector.
  • Connect the fuel extension line, Part Number 4918519.
  • Place the end of the line in an empty fuel container.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Action

Check for a stuck open or leaking aftertreatment purge air actuator.

Check for air flowing from the supply line. There must not be any air flowing from the supply line.

Air flowing from the end of the extension line?
YES NO

A leaking aftertreatment purge air actuator has been detected.

Replace the aftertreatment purge air actuator.

Refer to Procedure 011-065 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Inspect the aftertreatment fuel injector.

Guided Step 5A - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Action

Perform the aftertreatment system test.

Refer to Procedure 011-054 in the Associated Procedures Table.

NOTE: It is only necessary to perform the flow test; the leak test is not necessary.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Clean the aftertreatment injector.

Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 6A

Go to 5B

Guided Step 5B - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Action

Perform the aftertreatment system test.

Refer to Procedure 011-054 in the Associated Procedures Table.

NOTE: It is only necessary to perform the flow test; the leak test is not necessary.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Replace the aftertreatment injector.

Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1926 - Aftertreatment Fuel Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Aftertreatment Fuel Pressure Sensor | Refer to Procedure 019-444 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1927 and 1928. | Fault Code 1927 or 1928 active?
STEP 2. | Check the aftertreatment fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1928 active?
 | STEP 2C. Check the circuit response. | Fault Code 1927 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1928 active?
 | STEP 3C. Check the circuit response. | Fault Code 1927 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1927 and 1928.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 or 1928 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment fuel pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment fuel pressure 5 volt SUPPLY pin and aftertreatment fuel pressure SIGNAL pin at the aftertreatment fuel pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 active?
YES NO

An in-range malfunction of the aftertreatment fuel pressure sensor has been detected.

Replace the aftertreatment fuel pressure sensor.

Refer to Procedure 019-444 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Assoicated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 active?
YES NO
No Repair

Replace ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the aftertreatment fuel pressure 5 volt SUPPLY pin and the aftertreatment fuel pressure SIGNAL pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedure Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1932 - Aftertreatment Doser - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX15 CM2250 | 4022250
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | GX CM2250 | 4022250
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | ISX15 CM2250 | 4022250
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | GX CM2250 | 4022250
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX15 CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | ISX15 CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes, other than 1932, related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment purge air actuator are active?
STEP 2. | Check the aftertreatment fuel injector and fuel shutoff valve system. |
 | STEP 2A. Check for fuel leaks. | Fuel leaks found in the aftertreatment fuel system?
 | STEP 2B. Check for fuel leaks. | Check for a leaking aftertreatment fuel shutoff manifold.
 | STEP 2C. Check for a leaking aftertreatment fuel injector. | Aftertreatment fuel injector leakage within the specifications?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes, other than 1932, related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment purge air actuator are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment fuel injector and fuel shutoff valve system.

Guided Step 2A - Check for fuel leaks.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Start the engine and operate at idle speed.
  • Refer to Procedure 011-054 in the Associated Procedures Table.

Action

Use INSITE™ electronic service tool to pressurize the aftertreatment fuel injection system.

  • Use INSITE™ electronic service tool to select the aftertreatment shutoff valve and injector override test under the ECM diagnostics test menu.
  • Choose aftertreatment injector leak test in the test modes selection box.

Performing this test will pressurize the aftertreatment fuel system, but will not inject fuel into the aftertreatment system.

  • Refer to Procedure 011-054 in the Associated Procedures Table.
  • Inspect the aftertreatment fuel shutoff valve assembly, aftertreatment fuel lines, and aftertreatment fuel line connections for external leaks.

Fuel leaks found in the aftertreatment fuel system?
YES NO

Tighten any loose fuel line fittings.

Replace the malfunctioning component if fuel is found leaking externally.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a leaking aftertreatment fuel shutoff manifold.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment purge air supply line between that aftertreatment purge air actuator and the aftertreatment fuel shutoff manifold.
  • Refer to Procedure 011-052 in the Associated Procedures Table.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Start the engine and operate at idle speed.
  • Refer to Procedure 011-054 in the Associated Procedures Table.

Action

Use INSITE™ electronic service tool to pressurize the aftertreatment fuel injection system.

  • Use INSITE™ electronic service tool to select the aftertreatment shutoff valve and injector override test under the ECM diagnostics test menu.
  • Choose aftertreatment injector leak test in the test modes selection box.

Performing this test will pressurize the aftertreatment fuel system, but will not inject fuel into the aftertreatment system.

  • Refer to Procedure 011-054 in the Associated Procedures Table.
  • Inspect the aftertreatment fuel shutoff valve assembly, aftertreatment fuel lines, and aftertreatment fuel line connections for external leaks.

Fuel found leaking from the aftertreatment fuel shutoff manifold?
YES NO

Replace the aftertreatment fuel shutoff valve manifold.

Refer to Procedure 011-052 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for a leaking aftertreatment fuel injector.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment fuel injector and install the aftertreatment fuel line extension.
  • Refer to Procedure 011-054 in the Associated Procedures Table.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Start the engine and operate at idle speed.

Action

Use INSITE™ electronic service tool to pressurize the aftertreatment fuel injection system.

  • Use INSITE™ electronic service tool to select the aftertreatment shutoff valve and injector override test under the ECM diagnostics test menu.
  • Choose aftertreatment injector leak test in the test modes selection box.

Performing this test will pressurize the aftertreatment fuel system, but will not inject fuel into the aftertreatment system.

  • Inspect the aftertreatment fuel injector for fuel leaks.
  • Refer to Procedure 011-054 in the Associated Procedures Table.

Aftertreatment fuel injector leakage within the specifications?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

A leaking aftertreatment fuel injector has been detected.

Replace the aftertreatment fuel injector.

Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 1A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1935 - Exhaust Gas Recirculation (EGR) Actuator Driver Circuit - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | Westport HD CM2250 | 3666239
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | Westport HD CM2250 | 3666239
Engine Control Module (ECM) | Refer to Procedure 019-031 | Westport HD CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | Westport HD CM2250 | 4021560

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1893 active?
STEP 2. | Check the EGR valve circuit. |
 | STEP 2A. Inspect the EGR valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1893 active?
 | STEP 2C. Check the fault codes and verify the EGR valve connector condition. | Fault Code 1935 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1935 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES | NO
No Repair | No Repair

Go to Fault Code 1893 troubleshooting steps.

Go to 2A

Guided Step 2 - Check the EGR valve circuit.

Guided Step 2A - Inspect the EGR valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the EGR valve connector condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1935 active?
YES NO
No Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the EGR valve engine harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the EGR valve engine harness connector and the SAE J1939 data link (-) wire at the ECM engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link harness.

Repair or replace the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Disconnect the VGT actuator from the harness.
  • Disconnect the engine harness from the ECM connector.
  • Remove the SAE J1939 termination resistor from the engine harness.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the VGT actuator from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1935 active?
YES NO

  • Replace the EGR valve motor.

Refer to Procedure 011-022 in the Associated Procedures Table.

NOTE: The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1936 - Data Link EGR Valve Relay Power Signal - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1936 active?
STEP 2. | Check the Exhaust Gas Recirculation (EGR) valve relay. |
 | STEP 2A. Inspect the EGR valve relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Measure the EGR valve relay resistance. | Resistance between pin-85 and pin-86 more than 50 ohms?
STEP 3. | Check the Westport™ converter harness and Westport™ modified base engine harness. |
 | STEP 3A. Check the Westport™ converter harness. | Resistance between pin-J1-01 and the engine ground terminal more than 100k ohms?
 | STEP 3B. Check the Westport™ modified base engine harness. | Resistance between pin-27 and the engine ground terminal more than 100k ohms?
STEP 4. | Check for a short circuit to low source in the Westport™ converter harness and Westport™ modified base engine harness. |
 | STEP 4A. Check the Westport™ converter harness. | Resistance between pin-J1-01 and all other pins more than 100k ohms?
 | STEP 4B. Check the Westport™ modified base engine harness. | Resistance between pin-27 and all other pins more than 100k ohms?
STEP 5. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1936 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve relay circuit.

Guided Step 2A - Inspect the EGR valve relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR valve relay from its base on the Westport™ modified base engine harness.

Action

Inspect the EGR relay and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the EGR valve relay.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the EGR valve relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR valve relay from its base on the Westport™ modified base engine harness.

Action

Check the EGR valve relay resistance.

  • Measure the resistance between the terminals of pin-85 and pin-86 of the EGR valve relay.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between pin-85 and pin-86 more than 50 ohms?
YES NO
No Repair

Replace the EGR valve relay. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the Westport™ converter harness and Westport™ modified base engine harness.

Guided Step 3A - Check the Westport™ converter harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Westport™ converter harness from the Cummins® CM2250 ECM and the Westport™ modified base engine harness bulkhead connector.

Action

Check the converter harness resistance.

  • Measure the resistance between pin-J1-01 on the Cummins® CM2250 ECM and an engine block ground terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between pin-J1-01 and the engine ground terminal more than 100k ohms?
YES NO
No Repair

Replace the Westport™ converter harness. Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check the Westport™ modified base engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Westport™ modified base engine harness from the Westport™ modified base engine harness bulkhead connector.
  • Remove the EGR valve relay from its base on the modified base engine harness.

Action

Check the Westport™ modified base engine harness harness bulkhead connector resistance.

  • Measure the resistance between pin-27 on the Westport™ modified base engine harness bulkhead connector and an engine block ground terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between pin-27 and the engine ground terminal more than 100k ohms?
YES NO
No Repair

Replace the Westport™ modified base engine harness. Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 4 - Check for a short circuit to low source in the Westport™ converter harness and Westport™ modified base engine harness.

Guided Step 4A - Check the Westport™ converter harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Westport™ converter harness from the Cummins® CM2250 ECM and the Westport™ modified base engine harness bulkhead connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between pin-J1-01 in the Westport™ converter harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between pin-J1-01 and all other pins more than 100k ohms?
YES NO
No Repair

Replace the Westport™ converter harness. Refer to the OEM service manual.

Go to 4B

Go to 5A

Guided Step 4B - Check the Westport™ modified base engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Westport™ modified base engine harness from the Westport™ modified base engine harness bulkhead connector.
  • Remove the EGR valve relay from its base on the modified base engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between pin-27 on the Westport™ modified base engine harness and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Restriction between pin-27 and all other pins more than 100k ohms?
YES NO
No Repair

Replace the Westport™ modified base engine harness. Refer to the OEM service manual.

Contact Westport™ service at 1-888-978-4734 for additional troubleshooting information.

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1937 - Data Link EGR Valve Relay Power Signal - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1937 active?
STEP 2. | Check the EGR valve relay. |
 | STEP 2A. Inspect the EGR valve relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Measure the EGR valve relay resistance. | Resistance between pin-85 and pin-86 more than 50 ohms?
 | STEP 2C. Check for an open circuit in the EGR valve relay return circuit. | Resistance between pin-86 and the engine block ground terminal less than 10 ohms?
STEP 3. | Check the Westport™ converter harness and Westport™ modified base engine harness for continuity. |
 | STEP 3A. Check the Westport™ converter harness. | Resistance between pin-J1-01 and pin-27 less than 10 ohms?
 | STEP 3B. Check the Westport™ modified base engine harness. | Resistance between pin-27 and pin-85 less than 10 ohms?
STEP 4. | Check for a short circuit to high source in the Westport™ converter harness and Westport™ modified base engine harness. |
 | STEP 4A. Check the Westport™ converter harness. | Resistance between pin-J1-01 and all other pins more than 100k ohms?
 | STEP 4B. Check the Westport™ modified base engine harness. | Resistance between pin-27 and all other pins more than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1937 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve relay circuit.

Guided Step 2A - Inspect the EGR valve relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR valve relay from its base on the Westport™ modified base engine harness.

Action

Inspect the EGR relay and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the EGR valve relay.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the EGR valve relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR valve relay from its base on the Westport™ modified base engine harness.

Action

Check the EGR valve relay resistance.

  • Measure the resistance between the terminals of pin-85 and pin-86 of the EGR valve relay.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between pin-85 and pin-86 more than 50 ohms?
YES NO
No Repair

Replace the EGR valve relay. Refer to the OEM service manual.

Go to 2C

Go to 5A

Guided Step 2C - Check for an open circuit in the EGR valve relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR valve relay from its base on the Westport™ modified base engine harness.

Action

Check the continuity.

  • Measure the resistance between pin-86 on the EGR valve relay on the Westport™ modified base engine harness and the engine block ground terminal (C29).

Resistance between pin-86 and the engine block ground terminal less than 10 ohms?
YES NO
No Repair

Replace the Westport™ converter harness. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the Westport™ converter harness and Westport™ modified base engine harness.

Guided Step 3A - Check the Westport™ converter harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Westport™ converter harness from the Cummins® CM2250 ECM and the Westport™ modified base engine harness bulkhead connector.

Action

Check the converter harness resistance.

  • Measure the resistance between pin-J1-01 on the Cummins® CM2250 ECM and pin-27 on the Westport™ modified base engine harness bulkhead connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between pin-J1-01 and pin-27 less than 10 ohms?
YES NO
No Repair

Replace the Westport™ converter harness. Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check the Westport™ modified base engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Westport™ modified base engine harness from the Westport™ modified base engine harness bulkhead connector.
  • Remove the EGR valve relay from its base on the Westport™ modified base engine harness.

Action

Check the Westport™ modified base engine harness bulkhead connector resistance.

  • Measure the resistance between pin-27 on the Westport™ modified base engine harness bulkhead connector and pin-85 on the EGR valve relay base.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Restriction between pin-27 and pin-85 less than 100k ohms?
YES NO
No Repair

Replace the Westport™ modified base engine harness. Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 4 - Check for a short circuit to high source in the Westport™ converter harness and Westport™ modified base engine harness.

Guided Step 4A - Check the Westport™ converter harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Westport™ converter harness from the Cummins® CM2250 ECM and the Westport™ modified base engine harness bulkhead connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between pin-J1-01 in the Westport™ converter harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between pin-J1-01 and all other pins more than 100k ohms?
YES NO
No Repair

Replace the Westport™ converter harness. Refer to the OEM service manual.

Go to 4B

Go to 5A

Guided Step 4B - Check the Westport™ modified base engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Westport™ modified base engine harness from the Westport™ modified base engine harness bulkhead connector.
  • Remove the EGR valve relay from its base on the Westport™ modified base engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between pin-27 on the Westport™ modified base engine harness and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Restriction between pin-27 and all other pins more than 100k ohms?
YES NO
No Repair

Replace the Westport™ modified base engine harness. Refer to the OEM service manual.

Contact Westport™ service at 1-888-978-4734 for additional troubleshooting information.

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1961 - EGR Valve Control Circuit Calculated Over Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | Westport HD CM2250 | 4021560

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1961 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1961 active?
YES NO

The Exhaust Gas Recirculation (EGR) actuator internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 1A

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 1963 - Aftertreatment Fuel Shutoff Valve 1 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | GX CM2250 | 4022250
Pressure Fuel Filter | Refer to Procedure 006-065 | GX CM2250 | 4022250
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1923, 1924, 1926, 1927, or 1928 active?
 | STEP 1B. Check for active fault codes. | Fault Code 559 or 2372 active or inactive?
 | STEP 1C. Check fuel filter restriction. | Fuel filter restriction within specifications?
STEP 2. | Check the aftertreatment fuel shutoff valve. |
 | STEP 2A. Check for a stuck closed aftertreatment fuel shutoff valve. | Fuel flowing from the supply line extension?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment fuel injector system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1923, 1924, 1926, 1927, or 1928 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the fuel system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 559 or 2372 active or inactive?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1C

Guided Step 1C - Check fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check for a plugged fuel filter.

  • Check fuel filter restriction.
  • Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel filter restriction within specifications?
YES NO
No Repair

Replace the fuel filter.

Refer to Procedure 006-065 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment fuel shutoff valve.

Guided Step 2A - Check for a stuck closed aftertreatment fuel shutoff valve.

Conditions

  • Disconnect the aftertreatment fuel supply line from the aftertreatment fuel injector.
  • Connect the fuel extension line, Part Number 4918519.
  • Place the end of the line in an empty fuel container.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Action

Check for a stuck closed aftertreatment fuel shutoff valve.

  • Start INSITE™ electronic service tool.
  • Select the Aftertreatment Shutoff Valve and Injector Override test in the ECM Diagnostics Tests menu.
  • Perform the injector leak test.
  • Fuel should flow continuously from the supply line extension during the 60 second test.

Fuel flowing from the supply line extension?
YES NO
No Repair

A stuck closed aftertreatment fuel shutoff valve has been detected.

Replace the aftertreatment fuel shutoff valve.

Refer to Procedure 011-052 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 2272 - EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | Westport HD CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | Westport HD CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1893 active?
 | STEP 1B. Check the fault codes. | Fault Code 2272 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES | NO
No Repair | No Repair

Go to Fault Code 1893 troubleshooting tree.

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

Replace the EGR valve motor. Refer to Procedure 011-057 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 2349 - Exhaust Gas Recirculation (EGR) Valve Control Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | Westport HD CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | Westport HD CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1893 active?
 | STEP 1B. Check the fault codes. | Fault Code 2349 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES | NO
No Repair | No Repair

Go to Fault Code 1893 troubleshooting tree.

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2349 active?
YES NO

Replace the EGR valve motor. Refer to Procedure 011-057 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 2351 - Exhaust Gas Recirculation (EGR) Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | Westport HD CM2250 | 3666239
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | Westport HD CM2250 | 4021560
Engine Wiring Harness | Refer to Procedure 019-043 | Westport HD CM2250 | 4021560

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1893 active?
STEP 2. | Check the EGR valve. |
 | STEP 2A. Inspect the EGR valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes. | Fault Code 2351 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES | NO
No Repair | No Repair

Fault Code 1893 troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR valve.

Guided Step 2A - Inspect the EGR valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness connector pins and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspections techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2351 active?
YES NO

Replace the EGR valve motor. Refer to Procedure 011-022 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 1A

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 2357 - Exhaust Gas Recirculation (EGR) Valve Control Circuit - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | Westport HD CM2250 | 3666239
Aftertreatment System | Refer to Procedure 011-050 | Westport HD CM2250 | 3666239
Aftertreatment Testing | Refer to Procedure 014-013 | Westport HD CM2250 | 3666239
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | Westport HD CM2250 | 4021560
Engine Wiring Harness | Refer to Procedure 019-043 | Westport HD CM2250 | 4021560

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1893 active?
STEP 2. | Check the EGR valve. |
 | STEP 2A. Inspect the EGR valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for active fault codes. | Fault Code 1896 active?
STEP 3. | Check the EGR valve operation. |
 | STEP 3A. Monitor the EGR valve operation. | Fault Code 1896 becomes active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system found during the inspection?
 | STEP 4B. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4C. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES | NO
No Repair | No Repair

Fault Code 1893 troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR valve circuit.

Guided Step 2A - Inspect the EGR valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness connector and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the EGR valve sensor. Refer to Procedure 011-022 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Connect all components.
  • Keyswitch OFF for 10 seconds.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES NO

A stuck open EGR valve has been detected.

Replace the EGR valve assembly. Refer to Procedure 011-022 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the EGR valve operation.

Guided Step 3A - Monitor the EGR valve position.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Turn the keyswitch ON and wait 3 minutes.

  • The EGR valve will be commanded open and closed automatically by the ECM. An automatic diagnostic test will be performed.
  • Turn the keyswitch OFF for 30 seconds, then turn the keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 becomes active?
YES NO

Replace the EGR valve assembly. Refer to Procedure 011-022 in the Associated Procedures Table.

The restriction in the EGR valve has been removed. No repair is necessary.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check for progressive damage to the aftertreatment system.

Conditions

  • Connect all components.

Action

Check for damage to the aftertreatment system.

Perform the Snap Acceleration Test to check for damage to the aftertreatment diesel particulate filter. Progressive damage to the aftertreatment system may have occurred. The aftertreatment system must be inspected for reuse. Refer to Procedure 014-013 in the Associated Procedures Table.

Progressive damage to the aftertreatment system found during the Snap Acceleration Test?
YES NO

  • Replace the damaged aftertreatment component. Refer to Procedure 011-050 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4B

Guided Step 4B - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4C

Go to 4C

Guided Step 4C - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 2361 - Westport™ Data Share, Message 8 Fault (Abnormal Update Rate)

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2361 active?
STEP 2. | Check the J1939 data link. |
 | STEP 2A. Inspect the Westport™ converter harness, the Westport™ modified base engine harness, and the Westport™ engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the Westport™ converter harness. | Resistance less than 10 ohms?
 | STEP 2C. Check for an open circuit in the Westport™ modified base engine harness. | Resistance less than 10 ohms?
 | STEP 2D. Check for an open circuit in the Westport™ engine harness. | Resistance less than 10 ohms?
 | STEP 2E. Check for an open circuit on the OEM harness. | Resistance less than 10 ohms?
STEP 3. | Flash and replace the ECM and Westport™ CM850 engine fuel system controller. |
 | STEP 3A. Flash ECM and Westport™ CM850 engine fuel system controller. | Fault Code 2361 active after software update?
 | STEP 3B. Replace the Westport™ CM850 engine fuel system controller. | Fault Code 2361 active after controller replacement?
 | STEP 3C. Replace the Cummins® ECM. | Fault Code 2361 active after ECM replacement?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2361 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the J1939 data link.

Guided Step 2A - Inspect the Westport™ converter harness, the Westport™ modified base engine harness, and the Westport™ eninge harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1 (C112) connector on the converter harness.
  • Disconnect the C106 connector on the converter harness.
  • Disconnect the C104 connector on the Westport™ modified base engine harness.
  • Disconnect the C7 connector on the Westport™ modified base engine harness.
  • Disconnect the C7 connector on the Westport™ engine harness.
  • Disconnect the C16 connector on the Westport™ engine harness.

Action

Inspect the connectors and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the Westport™ converter harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1 (C112) connector on the Westport™ converter harness.
  • Disconnect the Westport™ modified base engine harness bulkhead connector (C106) on the Westport™ converter harness.

Action

Check for an open circuit in the J1939 data link:

  • Measure the resistance between pin J1-08 on the Cummins® CM2250 connector and pin-25 on the Westport™ modified base engine harness bulkhead connector (C106).
  • Measure the resistance between pin J1-18 on the Cummins® CM2250 connector and pin-26 on the Westport™ modified base engine harness bulkhead connector (C106).

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance less than 10 ohms?
YES NO
No Repair

Replace the Westport™ converter harness. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the Westport™ modified base engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Westport™ modified base engine harness bulkhead connector (C104) on the Westport™ modified base engine harness.
  • Disconnect the C7 connector on the Westport™ modified base engine harness.

Action

Check for an open circuit in the J1939 data link.

  • Measure the resistance between pin-25 on the Westport™ modified base engine harness bulkhead connector (C104) and pin-A on the C7 connector on the Westport™ modified base engine harness.
  • Measure the resistance between pin-26 on the Westport™ modified base engine harness bulkhead connector (C104) and pin-B on the C7 connector on the Westport™ modified base engine harness.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance less than 10 ohms?
YES NO
No Repair

Replace the Westport™ modified base engine harness. Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit in the Westport™ engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the C16 connector on the Westport™ engine harness.
  • Disconnect the C7 connector on the Westport™ engine harness.

Action

Check for an open circuit in the J1939 data link.

  • Measure the resistance between pin-A of the C16 connector and pin-20 on the C7 connector of the Westport™ engine harness.
  • Measure the resistance between pin-B of the C16 connector and pin-21 on the C7 connector of the Westport™ engine harness.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use te following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance less than 10 ohms?
YES NO
No Repair

Replace the Westport™ engine harness. Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Check for an open circuit on the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1 60-pin connector on the Westport™ CM850 engine fuel system (EFS) controller.
  • Disconnect the engine harness bulkhead connector on the OEM harness, which connects to the C7 connector on the Westport™ engine harness.

Action

Check for an open circuit in the J1939 data link.

  • Measure the resistance between pin-8 on the Westport™ CM850 EFS controller J1 60-pin connector and the corresponding pin on the OEM harness, which connects to pin-20 on the Westport™ engine harness.
  • Measure the resistance between pin-6 on the Westport™ CM850 EFS controller J1 60-pin connector and the corresponding pin on the OEM harness, which connects to pin-21 on the Westport™ engine harness.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Flash and replace the ECM and Westport™ CM850 EFS controller.

Guided Step 3A - Flash the ECM and Westport™ CM850 EFS controller.

Conditions

  • Turn keyswitch OFF.

Action

Flash the ECM and the Westport™ CM850 EFS controller.

  • Flash the ECM and the Westport™ CM850 EFS controller with the latest calibration, downloaded from the Westport™ HD service website.

Fault Code 2361 active after software update?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Replace the Westport™ CM850 EFS controller.

Conditions

  • Turn keyswitch OFF.

Action

Replace the Westport™ CM850 EFS controller.

  • Refer to the OEM service manual.

Fault Code 2361 active after controller replacement?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Replace the Cummins® ECM.

Conditions

  • Turn keyswitch OFF.

Action

Replace the Cummins™ CM2250 controller.

  • Refer to the OEM service manual.

Fault Code 2361 active after ECM replacement?
YES | NO
No Repair | No Repair

Contact Westport™ HD service at 1-888-WPT-HPDI for further troubleshooting steps.

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 2732 - Aftertreatment Fuel Drain Valve Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | Westport HD CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | Westport HD CM2250 | 4021560
Engine Wiring Harness | Refer to Procedure 019-043 | Westport HD CM2250 | 4021560
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | Westport HD CM2250 | 3666239

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2732 inactive?
STEP 2. | Check the aftertreatment fuel drain valve and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel drain valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the aftertreatment fuel drain valve. | 5.0 to 7.0 ohms?
 | STEP 2C. Check the fuel drain valve diagnostic supply voltage and signal circuit. | 4.75 to 6.75-VDC?
 | STEP 2D. Check for an open circuit in the aftertreatment fuel drain valve return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the fuel drain valve diagnostic supply voltage and signal circuit. | 4.75 to 6.75-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2732 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Clear the inactive fault codes. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2732 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment fuel drain valve and circuit.

Guided Step 2A - Inspect the aftertreatment fuel drain valve and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel drain valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check the aftertreatment fuel drain valve resistance.

  • Measure the resistance between the aftertreatment fuel drain valve SUPPLY pin and the aftertreatment fuel drain valve RETURN pin at the aftertreatment fuel drain valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5.0 to 7.0 ohms?
YES NO
No Repair

Replace the aftertreatment fuel drain valve.

Refer to Procedure 011-052 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel drain valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment fuel drain valve from the engine harness
  • Turn keyswitch ON.

Action

Check the diagnostic voltage and return circuit.

  • Measure the voltage between the aftertreatment fuel drain valve SUPPLY pin and the aftertreatment fuel drain valve RETURN pin at the aftertreatment fuel drain valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 6.75-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the aftertreatment fuel drain valve return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment fuel drain valve RETURN pin at the aftertreatment fuel drain valve connector of the engine harness and the metal case of the aftertreatment fuel drain valve.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness return circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the fuel drain valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON.

Action

Check the diagnostic supply voltage.

  • Measure the voltage from the aftertreatment fuel drain valve SUPPLY pin and the aftertreatment fuel drain valve RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 6.75-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment fuel drain valve SUPPLY pin at the engine harness ECM connector and the aftertreatment fuel drain valve connector SUPPLY pin at the aftertreatment fuel drain valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment fuel drain valve SUPPLY pin and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2732 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 2733 - Aftertreatment Fuel Drain Valve Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | Westport HD CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | Westport HD CM2250 | 4021560
Engine Wiring Harness | Refer to Procedure 019-043 | Westport HD CM2250 | 4021560
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | Westport HD CM2250 | 3666239

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2733 inactive?
STEP 2. | Check the aftertreatment fuel drain valve and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel drain valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the aftertreatment fuel drain valve. | 5.0 to 7.0 ohms?
 | STEP 2B-1. Check for a short circuit to ground in the aftertreatment fuel drain valve. |
 | STEP 2C. Check the fuel drain valve diagnostic supply voltage and signal circuit. | 4.75 to 6.75-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the fuel drain valve diagnostic supply voltage and signal circuit. | 4.75 to 6.75-VDC?
 | STEP 3C. Check for a pin-to-pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2733 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2733 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment fuel drain valve and circuit.

Guided Step 2A - Inspect the aftertreatment fuel drain valve and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel drain valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check the aftertreatment fuel drain valve resistance.

  • Measure the resistance between the aftertreatment fuel drain valve SUPPLY pin and the aftertreatment fuel drain valve RETURN pin at the sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5.0 to 7.0 ohms?
YES NO
No Repair

Replace the aftertreatment fuel drain valve.

Refer to Procedure 011-052 in the Associated Procedures Table.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a short circuit to ground in the aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check the aftertreatment fuel drain valve resistance.

  • Measure the resistance between the aftertreatment fuel drain valve SUPPLY and the metal case of the aftertreatment fuel drain valve.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the aftertreatment fuel drain valve.

Refer to Procedure 011-052 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel drain valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment fuel drain valve from the engine harness
  • Turn keyswitch ON.

Action

Check the diagnostic voltage and return circuit.

  • Measure the voltage between the aftertreatment fuel drain valve SUPPLY pin and the aftertreatment fuel drain valve RETURN pin at the aftertreatment fuel drain valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 6.75-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the fuel drain valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON.

Action

Check the diagnostic supply voltage.

  • Measure the voltage from the aftertreatment fuel drain valve SUPPLY pin and ground at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 6.75-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the aftertreatment fuel drain valve SUPPLY pin at the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the aftertreatment fuel drain valve SUPPLY wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment fuel drain valve SUPPLY pin at the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2733 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 2771 - Aftertreatment Outlet NOx Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM) , all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 2771 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 2636, 3232, and 3597 all active?
STEP 2. | Check the aftertreatment outlet NOx sensor circuit. |
 | STEP 2A. Inspect the aftertreatment outlet NOx sensor and connector pins. | Damaged or dirty pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage is within 1-VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine CPL?
 | STEP 2D. Check for correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor is the correct sensor for the engine CPL?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply. | Voltage is within 1-VDC of battery voltage?
STEP 4. | Check the J1939 data link. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 4F. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4G. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4H. Check the fault codes. | Fault Code 2771 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2636, 3232, and 3597 all active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor return circuit at the NOx sensor wiring harness connector.

Note: Check the voltage at keyswitch ON, while cranking the engine, and with the engine at idle.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for corrrect adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical System Voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 2D

Go to 5A

Guided Step 2D - Check for correct aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment outlet NOx sensor.

Action

Verify aftertreatment outlet NOx sensor is the correct sensor for the engine CPL.

Note: The aftertreatment outlet NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment outlet NOx sensor is the correct sensor for the engine CPL?
YES NO
No Repair

Replace the aftertreatment outlet NOx sensor.

Refer to procedure 019-451 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals.

Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage is within 1-VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage return circuit.

Repair or replace the OEM harness.

Refer to the OEM service manual.

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage supply circuit.

Check for blown or missing fuses. Check for damaged or missing relays. Troubleshoot all interconnects. Repair or replace the damaged component(s) as necessary.

Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the aftertreatment outlet NOx sensor OEM harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (−) wire at the aftertreatment outlet NOx sensor OEM harness connector and the SAE J1939 data link (−) wire at the ECM engine harness connector.

Refer the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid (DEF) controller to completely power down.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the aftertreatment DEF controller 53-pin connector.
  • Disconnect the variable geometry turbocharger (VGT) actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

Note: Disregard any resistance between 110 and 130 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the aftertreatment DEF controller 53-pin connector.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • A short circuit to ground has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.
  • Repair or replace the malfunctioning component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Connect other components.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the J1939 data link (-) wire at the aftertreatment outlet NOx sensor OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES | NO
No Repair | No Repair

Go to 4H

Go to 4F

Guided Step 4F - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 14-pin OEM connector from the engine harness.
  • Connect other components.

Action

Measure the terminating resistance of the engine harness.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the 14-pin connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the OEM harness.

Repair or replace the terminating resistor in the OEM harness.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 4G

Guided Step 4G - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Measure the terminating resistance of the VGT actuator.

  • Measure the resistance between the VGT actuator J1939 data link (+) wire and the VGT actuator J1939 data link (-) wire at the VGT actuator connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the engine harness.

Remove the additional terminating resistance or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Incorrect terminating resistance has been detected in VGT actuator.

Replace the VGT actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4H - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM.
  • Connect the aftertreatment outlet NOx sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 is active?
YES NO

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Nov-2012


FAULT CODE 2878 - Aftertreatment Fuel Drain Valve - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | Westport HD CM2250 | 4021560
Aftertreatment Injector Lines | Refer to Procedure 011-051 | Westport HD CM2250 | 3666239
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | Westport HD CM2250 | 3666239

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive counts of Fault Code 2215. | Active or inactive counts of Fault Code 2215?
 | STEP 1B. Check for active fault codes. | Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?
STEP 2. | Inspect the aftertreatment fuel drain valve. |
 | STEP 2A. Check for a stuck closed or plugged aftertreatment fuel drain valve. | Fault Code 2878 inactive and Fault Code 1963 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active counts of Fault Code 2215.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to check for active counts of Fault Code 2215.

It is possible to swap the connections between the aftertreatment fuel pressure sensor and the fuel delivery pressure sensor. If this occurs, Fault Code 2215 will intermittently go active and the engine will run very rough and will surge at low idle. If these symptoms are present, make sure the fuel pressure connections are connected properly.

Active or inactive counts of Fault Code 2215?
YES NO

Properly connect the aftertreatment fuel pressure sensor and fuel delivery pressure sensor wiring harness connections.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Inspect the aftertreatment fuel drain valve.

Guided Step 2A - Check for a stuck closed or plugged aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Swap the aftertreatment fuel shutoff valve (1) and aftertreatment fuel drain valve (2) locations in the aftertreatment fuel shutoff valve manifold. These valves are the exact same part number so swapping the valve locations will determine if the fault follows the valve.

  • Remove the aftertreatment fuel shutoff valve (1) and the aftertreatment fuel drain valve (2) from the aftertreatment fuel shutoff manifold. Refer to Procedure 011-052 in the Associated Procedures Table.
  • Swap the valve locations by installing the valve that was removed from the aftertreatment fuel shutoff valve into the aftertreatment fuel drain valve location.
  • Install the valve that was removed from the aftertreatment fuel drain valve into the aftertreatment fuel shutoff valve location.
  • Start the engine and idle for 5 minutes.

Note: Do not swap the electrical connections. Make sure the electrical connection remains in the original location.

The ISX aftertreatment fuel shutoff valve manifold is pictured on the left.

Fault Code 2878 inactive and Fault Code 1963 active?
YES NO

A stuck closed aftertreatment fuel drain valve has been detected.

Replace the valve that is presently installed in the aftertreatment fuel shutoff valve location (valve mounted below the aftertreatment fuel pressure sensor).

Refer to Procedure 011-052 in the Associated Procedures Table.

A restriction has been detected in the aftertreatment fuel drain line.

Disconnect the fuel return line from the fuel shutoff manifold and the fuel return tee fitting, located in front of the engine control module. Check the fuel line for restriction.

Refer to Procedure 011-051 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


Aftertreatment Fuel Drain Valve - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | Westport HD CM2250 | 3666239
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | Westport HD CM2250 | 3666239
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | Westport HD CM2250 | 4021560

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active counts of Fault Code 2215. | Active or inactive counts of Fault Code 2215?
 | STEP 1B. Check for active fault codes. | Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?
STEP 2. | Check the aftertreatment fuel injector and fuel shutoff valve system. |
 | STEP 2A. Check for fuel leaks. | Fuel leaks found in the aftertreatment fuel system?
 | STEP 2B. Check for a leaking aftertreeatment fuel drain valve. | Fault Code 2879 inactive and Fault Code 1925 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active counts of Fault Code 2215.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to check for active counts of Fault Code 2215.

It is possible to swap the connections between the aftertreatment fuel pressure sensor and the fuel delivery pressure sensor. If this occurs, Fault Code 2215 will intermittently go active and the engine will run very rough and will surge at low idle. If these symptoms are present, make sure the fuel pressure connections are connected properly.

Active or inactive counts of Fault Code 2215?
YES NO

Properly connect the aftertreatment fuel pressure sensor and fuel delivery pressure sensor wiring harness connections.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment fuel injector and fuel shutoff valve system.

Guided Step 2A - Check for fuel leaks.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Start the engine and run at idle speed.

Action

Use INSITE™ electronic service tool to pressurize the aftertreatment fuel injection system.

  • Use INSITE™ electronic service tool to select the Aftertreatment Shutoff Valve and Injector Override Test under the ECM Diagnostics Test Menu.
  • Choose Aftertreatment Injector Leak Test in the Test Modes selection box.

Performing this test will pressurize the aftertreatment fuel system, but will not inject fuel into the aftertreatment system.

Inspect the aftertreatment fuel shutoff valve assembly, aftertreatment fuel lines, and aftertreatment fuel line connections for external leaks.

Fuel leaks found in the aftertreatment fuel system?
YES NO

Tighten any loose fuel line fittings.

Replace the malfunctioning component if fuel is found leaking externally.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a leaking aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the aftertreatment fuel shutoff valve (1) and aftertreatment fuel drain valve (2) locations in the aftertreatment fuel shutoff valve manifold. These valves are the exact same part number so swapping the valve locations will determine if the fault follows the valve.

  • Remove the aftertreatment fuel shutoff valve (1) and the aftertreatment fuel drain valve (2) from the aftertreatment fuel shutoff manifold. Refer to Procedure 011-052 in the Associated Procedures Table.
  • Swap the valve locations by installing the valve that was removed from the aftertreatment fuel shutoff valve into the aftertreatment fuel drain valve location.
  • Install the valve that was removed from the aftertreatment fuel drain valve into the aftertreatment fuel shutoff valve location.
  • Start the engine and idle for 5 minutes.

Do not swap the electrical connections. Make sure the electrical connection remains in the original location.

The Westport HD aftertreatment fuel shutoff valve manifold is shown on the left.

Fault Code 2879 inactive and Fault Code 1925 active?
YES NO

A leaking aftertreatment fuel drain valve has been detected.

Replace the valve that is presently installed in the aftertreatment fuel shutoff valve location (valve mounted below the aftertreatment fuel pressure sensor). Refer to Procedure 011-052 in the Associated Procedures Table.

A leaking aftertreatment fuel injector has been detected.

Replace the aftertreatment fuel injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 2881 - Aftertreatment Fuel Pressure Sensor - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump Gear Pump | Refer to Procedure 005-025 | GX CM2250 | 4022250
Fuel System Diagnostics | Refer to Procedure 005-236 | GX CM2250 | 4022250
Pressure Fuel Filter | Refer to Procedure 006-065 | GX CM2250 | 4022250
Aftertreatment Injector Lines | Refer to Procedure 011-051 | GX CM2250 | 4022250
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment purge air actuator are active?
 | STEP 1B. Check for active fault codes. | Fault Codes 559 or 2372 active?
STEP 2. | Check the aftertreatment fuel system. |
 | STEP 2A. Check for fuel leaks. | Fuel leaks found in the aftertreatment fuel system?
 | STEP 2B. Inspect the aftertreatment fuel shutoff manifold. | Debris found in the fuel ports or aftertreatment fuel shutoff manifold?
 | STEP 2C. Inspect the aftertreatment fuel lines. | Debris or restrictions found in the aftertreatment fuel supply line?
 | STEP 2D. Inspect the fuel rifle supply port. | Debris or restrictions found in the fuel rifle supply line?
STEP 3. | Check the fuel filter restriction. |
 | STEP 3A. Measure the pressure drop at the pressure side fuel filter. | Is the fuel pressure drop within the specifications outlined in Procedure 005-236 of the service manual?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment purge air actuator are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 559 or 2372 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment fuel system.

Guided Step 2A - Check for fuel leaks.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON
  • Start the engine and run at idle speed
  • Refer to Procedure 011-054 in the Associated Procedures Table.

Action

Use INSITE™ electronic service tool to pressurize the Aftertreatment Fuel Injection System.

  • Use INSITE™ electronic service tool to select the Aftertreatment Shutoff Valve and Injector Override Test under the ECM diagnostics test menu.
  • Choose Aftertreatment Injector Leak Test in the test modes selection box.

Inspect the aftertreatment fuel shutoff valve assembly, aftertreatment fuel lines, and aftertreatment fuel line connections for external leaks.

Fuel leaks found in the aftertreatment fuel system?
YES NO

Tighten any loose fuel line fittings.

Replace the malfunctioning component if fuel is found leaking externally.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the aftertreatment fuel shutoff manifold.

Conditions

  • Turn keyswitch OFF
  • Remove the aftertreatment fuel shutoff manifold. Refer to Procedure 011-052 in the Associated Procedures Table.

Action

Inspect the aftertreatment fuel shutoff manifold.

  • Inspect the fuel inlet and outlet ports of the aftertreatment fuel shutoff manifold for debris.

Debris found in the fuel ports or aftertreatment fuel shutoff manifold?
YES NO

Remove the debris from the ports of the aftertreatment fuel shutoff manifold.

Refer to Procedure 011-052 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the aftertreatment fuel lines.

Conditions

  • Turn keyswitch OFF
  • Remove the aftertreatment fuel supply line. Refer to Procedure 011-051 in the Associated Procedures Table.

Action

Inspect the aftertreatment fuel lines.

  • Remove the aftertreatment fuel supply line between the fuel rifle and the aftertreatment fuel shutoff manifold. Refer to Procedure 011-051 in the Associated Procedures Table.
  • Inspect the aftertreatment fuel supply line for plugging or restrictions.

Debris or restrictions found in the aftertreatment fuel supply line?
YES NO

Replace the aftertreatment fuel supply line.

Refer to Procedure 011-051 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the fuel rifle supply port.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment injector fuel supply line from the supply outlet of the fuel rifle. Refer to Procedure 011-051 in the Associated Procedures Table.

Action

Inspect the fuel rifle support port.

  • Inspect the fuel rifle port for debris that may be restricting the fuel flow to the aftertreatment system.

Debris or restrictions found in the fuel rifle supply line?
YES NO

Replace the aftertreatment fuel supply line.

  • Refer to Procedure 011-051 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel filter restriction.

Guided Step 3A - Measure the pressure drop at the pressure side fuel filter.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Operate the engine.

Action

Measure the pressure drop.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Is the fuel pressure drop within the specifications outlined in Procedure 005-236 of the service manual?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Make sure the gear pump pressure into the filter is within specifications.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

If the pressure from the gear pump is within specifications, replace the fuel filter and prime the fuel system.

  • Refer to Procedure 006-065 in the Associated Procedures Table.

If the pressure from the gear pump is not within specifications, replace the gear pump.

  • Refer to Procedure 005-025 in the Associated Procedures Table.

Go to 1A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jul-2012


FAULT CODE 2976 - Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Unit | Refer to Procedure 011-058 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2976 is active?
 | STEP 1B. Check for a pin-to-ground short circuit in the aftertreatment DEF controller harness. | Greater than 100k ohms?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2976 is active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SIGNAL / dosing unit temperature pin at the aftertreatment diesel exhaust fluid controller harness 86-pin connector and ground.

Refer to the circuit diagram and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

A pin to ground short circuit on the SIGNAL wire has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness. Refer to the OEM service manual.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedure Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3135 - Aftertreatment Diesel Particulate Filter (DPF) Outlet Pressure - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Exhaust Restriction | Refer to Procedure 011-009 | GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter (DPF) Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | GX CM2250 | 4022250
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | GX CM2250 | 4022250
Engine Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 3133 and 3134. | Fault Code 3133 or 3134 active?
STEP 2. | Check the aftertreatment system. |
 | STEP 2A. Check the aftertreatment diesel particulate filter (DPF) differential pressure sensor tubes for blockage. | Are the aftertreatment diesel particulate filter (DPF) differential pressure sensor tubes blocked?
 | STEP 2B. Monitor the aftertreatment DPF outlet pressure sensor with an electronic service tool. | Is the aftertreatment diesel particulate filter outlet pressure sensor reading 0 ± 1.5 kPa [0 ± 0.44 in Hg] with key ON and engine OFF?
 | STEP 2C. Check for deposits in the decomposition tube. | Excessive DEF deposits found inside the decomposition tube?
STEP 3. | Check the aftertreatment DPF outlet pressure sensor and circuit. |
 | STEP 3A. Inspect the aftertreatment DPF outlet pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3134 active?
 | STEP 3C. Check the circuit response. | Fault Code 3133 active?
STEP 4. | Check the ECM and OEM harness. |
 | STEP 4A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for resistance in the OEM harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 3135 inactive?
STEP 5. | Check exhaust system restriction. |
 | STEP 5A. Check exhaust system restriction. | Exhaust restriction within specifications?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 3133 and 3134.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3133 or 3134 active?
YES | NO
No Repair | No Repair

Fault Code 3133 or 3134 troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment system.

Guided Step 2A - Check the aftertreatment diesel particulate filter differential pressure sensor tubes for blockage.

Conditions

  • Engine OFF
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor tubes.

Action

Check for plugged aftertreatment diesel particulate filter differential pressure sensor tubes.

  • Inspect the tubes for blockage.
  • Refer to Procedure 011-047 in the Associated Procedures Table.

Are the aftertreatment diesel particulate filter differential pressure sensor tubes blocked?
YES NO

Repair or replace the aftertreatment diesel particulate filter differential pressure sensor tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Monitor the aftertreatment diesel particulate filter outlet pressure sensor with an electronic service tool.

Conditions

  • Connect all components
  • Keyswitch ON
  • Engine OFF
  • Connect INSITE™ electronic service tool.

Action

Monitor the aftertreatment diesel particulate filter outlet pressure sensor with an electronic service tool.

Note: An exhaust ventilation system connected to the exhaust can cause the outlet pressure sensor to read incorrectly. Be sure to remove any ventilation or vacuum equipment from the exhaust before reading the outlet pressure sensor value with INSITE™ electronic service tool.

Is the aftertreatment DPF outlet pressure sensor reading 0 ± 1.5 kPa [0 ± 0.44 in Hg] with key ON and engine OFF?
YES NO
No Repair

Replace the aftertreatment DPF differential pressure sensor.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 2C

Go to 6A

Guided Step 2C - Check for deposits in the decomposition tube.

Conditions

  • Keyswitch OFF
  • Engine not operating.

Action

Inspect the decomposition tube for deposits.

  • Remove the aftertreatment decomposition tube from the vehicle
  • Inspect for excessive DEF deposits
  • Refer to Procedure 011-062 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and re-install the decomposition tube. Refer to Procedure 011-062 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the aftertreatment DPF outlet pressure sensor and circuit.

Guided Step 3A - Inspect the aftertreatment DPF outlet pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and aftertreatment DPF outlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 1881 will also be active.

Fault Code 3134 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DPF outlet pressure 5 volt SUPPLY pin and the aftertreatment DPF outlet pressure SIGNAL pin at the aftertreatment DPF outlet pressure sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 1881 will also be active.

Fault Code 3133 active?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and OEM harness.

Guided Step 4A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for resistance in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for resistance in the circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF outlet pressure sensor SIGNAL pin and the OEM harness aftertreatment DPF outlet pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

High resistance in the signal circuit has been detected in the OEM harness.

Troubleshoot each harness connector in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 5 - Check exhaust system restriction.

Guided Step 5A - Check exhaust system restriction.

Conditions

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Check exhaust system restriction

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO

Replace the aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443 in the Associated Procedures Table.

Continue to investigate the cause of the high exhaust restriction.

Refer to Procedure 011-009 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3142 - Aftertreatment SCR Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | GX CM2250 | 4022250
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3142 inactive?
STEP 2. | Check the aftertreatment SCR catalyst intake temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment SCR catalyst intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3143 active and Fault Code 3142 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3142 active?
STEP 3. | Check the aftertreatment SCR catalyst temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment SCR catalyst temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR catalyst temperature interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module. | Greater than 100K ohms?
STEP 4. | Check the ECM, engine harness, and OEM harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 3143 active and Fault Code 3142 is inactive?
 | STEP 4C. Check for an open circuit in the engine harness or OEM harness. | Less than 10 ohms?
 | STEP 4C-1. Check for an open circuit in the engine harness or OEM harness.` |
 | STEP 4D. Check for a pin-to-pin short circuit in the engine harness or OEM harness. | Greater than 100K ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 3142 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment SCR catalyst intake temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment SCR catalyst intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the aftertreatment SCR catalyst temperature sensor interface module connector pins and aftertreatment SCR catalyst intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment SCR catalyst intake temperature SIGNAL pin and the aftertreatment SCR catalyst intake temperature RETURN pin at the sensor connector of the aftertreatment SCR catalyst temperature sensor interface module.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 3143 active and Fault Code 3142 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment SCR catalyst intake temperature sensor to the aftertreatment SCR catalyst temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES NO

A damaged aftertreatment SCR catalyst intake temperature sensor has been detected.

Replace the aftertreatment SCR catalyst intake temperature sensor

Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment SCR catalyst temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment SCR catalyst temperature sensor interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the aftertreatment SCR catalyst temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Clean the connector and pins, if possible.

Replace the interface module if the pins can not be cleaned.

Refer to Procedure 019-464 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment SCR catalyst temperature sensor interface module. Refer to the wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module.

Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for a pin to pin short.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module

Replace the aftertreatment SCR catalyst temperature sensor interface module.

Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM, engine harness, and OEM harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment SCR catalyst intake temperature sensor SIGNAL pin and the aftertreatment SCR catalyst intake temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 3143 active and Fault Code 3142 inactive?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the aftertreatment SCR catalyst temperature sensor interface module from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment SCR catalyst intake temperature sensor RETURN pin and the engine harness aftertreatment SCR catalyst intake temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness or OEM harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to the OEM service manual.

Go to 4C-1

Go to 5A

Guided Step 4C-1 - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the aftertreatment SCR catalyst temperature sensor interface module from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector SCR catalyst intake temperature sensor SIGNAL pin and the engine harness SCR catalyst intake temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness or OEM harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to the OEM service manual.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin to pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the aftertreatment SCR catalyst temperature sensor interface module from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment SCR catalyst intake temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to the OEM service manual.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3143 - Aftertreatment SCR Inlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-445 | GX CM2250 | 4022250
Aftertreatment SRC Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3143 inactive?
STEP 2. | Check the SCR catalyst intake temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment SCR catalyst intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3142 active and Fault Code 3143 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3143 active?
STEP 3. | Check the aftertreatment SCR catalyst temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment SCR catalyst temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR catalyst temperature interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the aftertreatment SCR catalyst temperature interface module. | Greater than 100k ohms?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 3142 is active and Fault Code 3143 is inactive?
 | STEP 4C. Check for a pin to pin short circuit in the engine harness or OEM harness. | Greater than 100K ohms?
 | STEP 4D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 3143 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the SCR catalyst intake temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment SCR catalyst intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the interface module and aftertreatment SCR catalyst intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active and Fault Code 3143 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment SCR catalyst intake temperature sensor to the aftertreatment SCR catalyst temperature sensor interface module
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 active?
YES NO

Replace the SCR inlet temperature sensor.

Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment SCR catalyst temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment SCR catalyst temperature sensor interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the aftertreatment SCR catalyst temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Clean the connector and pins, if possible.

Replace the interface module if the pins can not be cleaned. Refer to Procedure 019-464 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment SCR catalyst temperature sensor interface module. Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for a pin-to-pin short.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins, if possible.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 is active and Fault Code 3143 is inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the aftertreatment SCR catalyst temperature sensor interface module from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment SCR catalyst intake temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to the OEM service manual.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the aftertreatment SCR catalyst temperature sensor interface module from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment SCR catalyst intake temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness or OEM harness.

Refer to Procedure 019-464 in the Associated Procedures Table.

Refer to the OEM service manual.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3144 - Aftertreatment SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | GX CM2250 | 4022250
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes 3142 or 3143. | Fault Code 3142 or 3143 active?
STEP 2. | Check the SCR catalyst intake temperature sensor and circuit. |
 | STEP 2A. Inspect the SCR catalyst intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3142 active?
 | STEP 2C. Check the circuit response. | Fault Code 3143 active?
STEP 3. | Check the aftertreatment SCR catalyst temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment SCR catalyst temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR catalyst temperature interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module. | Greater than 100K ohms?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 3142 active?
 | STEP 3C. Check the circuit response. | Fault Code 3143 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes 3142 or 3143.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 or 3143 active?
YES | NO
No Repair | No Repair

Fault Code 3142 or 3143 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the SCR catalyst intake temperature sensor and circuit.

Guided Step 2A - Inspect the SCR catalyst intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the SCR catalyst intake temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the interface module connector pins and aftertreatment SCR catalyst intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the SCR catalyst intake temperature sensor from the interface module.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the SCR catalyst intake temperature sensor from the interface module
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the SCR catalyst intake temperature SIGNAL pin and the SCR catalyst intake temperature RETURN pin at the SCR catalyst intake temperature connector of the interface module.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 active?
YES NO

Replace the aftertreatment SCR catalyst intake temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment SCR catalyst temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment SCR catalyst temperature sensor interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the aftertreatment SCR catalyst temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the interface module if the pins can not be cleaned. Refer to Procedure 019-464 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment SCR catalyst temperature sensor interface module. Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for a pin-to-pin short.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the aftertreatment SCR catalyst intake temperature SIGNAL pin and aftertreatment SCR catalyst intake temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 active?
YES NO

High resistance or a short circuit has been detected in the aftertreatment SCR catalyst intake temperature circuit has been detected. Troubleshoot the engine harness, OEM harness, and 14-pin crossover connector. Repair or replace the damaged component. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3145 - Aftertreatment SCR Intake Gas Temperature - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | GX CM2250 | 4022250
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes 3142 or 3143. | Fault Code 3142 or 3143 active?
STEP 2. | Check the SCR catalyst intake temperature sensor and circuit. |
 | STEP 2A. Inspect the SCR catalyst intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3142 active?
 | STEP 2C. Check the circuit response. | Fault Code 3143 active?
STEP 3. | Check the aftertreatment SCR catalyst temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment SCR catalyst temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR catalyst temperature interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module. | Greater than 100K ohms?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 3142 active?
 | STEP 3C. Check the circuit response. | Fault Code 3143 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes 3142 or 3143.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 or 3143 active?
YES | NO
No Repair | No Repair

Fault Code 3142 or 3143 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the SCR catalyst intake temperature sensor and circuit.

Guided Step 2A - Inspect the SCR catalyst intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the SCR catalyst intake temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the interface module connector pins and aftertreatment SCR catalyst intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the SCR catalyst intake temperature sensor from the interface module.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the SCR catalyst intake temperature sensor from the interface module
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the SCR catalyst intake temperature SIGNAL pin and the SCR catalyst intake temperature RETURN pin at the SCR catalyst intake temperature connector of the interface module.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 active?
YES NO

Replace the aftertreatment SCR catalyst intake temperature sensor. Refer to Procedure 019-449 in Section 19.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment SCR catalyst temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment SCR catalyst temperature sensor interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the aftertreatment SCR catalyst temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the interface module if the pins can not be cleaned. Refer to Procedure 019-464 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment SCR catalyst temperature sensor interface module. Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for a pin-to-pin short.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the aftertreatment SCR catalyst intake temperature SIGNAL pin and aftertreatment SCR catalyst intake temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 active?
YES NO

High resistance or a short circuit has been detected in the aftertreatment SCR catalyst intake temperature circuit has been detected. Troubleshoot the engine harness, OEM harness, and 14-pin crossover connector. Repair or replace the damaged component. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-May-2012


FAULT CODE 3146 - Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | GX CM2250 | 4022250
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3146 inactive?
STEP 2. | Check the aftertreatment SCR catalyst outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment SCR catalyst outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3147 active and Fault Code 3146 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3146 active?
STEP 3. | Check the aftertreatment SCR catalyst temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment SCR catalyst temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR catalyst temperature interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module. | Greater than 100K ohms?
STEP 4. | Check the ECM, engine harness, and OEM harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 3147 active and Fault Code 3146 inactive?
 | STEP 4C. Check for an open circuit in the engine harness or OEM harness. | Less than 10 ohms?
 | STEP 4C-1. Check for an open circuit in the engine harness or OEM harness. |
 | STEP 4D. Check for a pin-to-pin short circuit in the engine harness or OEM harness. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 3146 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment SCR catalyst outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment SCR catalyst outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst outlet temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module.

Action

IInspect the aftertreatment SCR catalyst temperature sensor interface module connector pins and aftertreatment SCR catalyst outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst outlet temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment SCR catalyst outlet temperature SIGNAL pin and the aftertreatment SCR catalyst outlet temperature RETURN pin at the sensor connector of the aftertreatment SCR catalyst temperature sensor interface module.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 3147 active and Fault Code 3146 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment SCR catalyst outlet temperature sensor to the aftertreatment SCR catalyst temperature sensor interface module
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active?
YES NO

A damaged aftertreatment SCR catalyst outlet temperature sensor has been detected.

Replace the aftertreatment SCR catalyst outlet temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 3 - Check the aftertreatment SCR catalyst temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment SCR catalyst temperature sensor interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the aftertreatment SCR catalyst temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Clean the connector and pins.

Replace the interface module if the pins can not be cleaned. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst outlet temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment SCR catalyst temperature sensor interface module. Refer to the wiring diagram for connector pin identification.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment SCR catalyst outlet temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for a pin-to-pin short.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM, engine harness, and OEM harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment SCR catalyst outlet temperature sensor SIGNAL pin and the aftertreatment SCR catalyst outlet temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 3147 active and Fault Code 3146 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the aftertreatment SCR catalyst temperature sensor interface module from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment SCR catalyst outlet temperature sensor RETURN pin and the engine harness aftertreatment SCR catalyst outlet temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness or OEM harness.

Repair or replace the engine harness or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to the OEM service manual.

Go to 4C-1

Go to 5A

Guided Step 4C-1 - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the aftertreatment SCR catalyst temperature sensor interface module from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector SCR catalyst outlet temperature sensor SIGNAL pin and the engine harness SCR catalyst outlet temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment SCR catalyst temperature sensor interface module from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the SCR catalyst outlet temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to the OEM service manual.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault should have been detected.

Go to 5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3147 - Aftertreatment SCR Catalyst Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | GX CM2250 | 4022250
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3147 inactive?
STEP 2. | Check the SCR catalyst outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment SCR catalyst outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3146 active and Fault Code 3147 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 3147 active?
STEP 3. | Check the aftertreatment SCR catalyst temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment SCR catalyst temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR catalyst temperature interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module. | Greater than 100k ohms?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 3146 active and Fault Code 3147 inactive?
 | STEP 4C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 3147 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3147 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the SCR outlet temperature sensor and circuit.

Guided Step 2A - Inspect the SCR catalyst outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst outlet temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the engine harness and SCR outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst outlet temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active and Fault Code 3147 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment SCR catalyst outlet temperature sensor to the aftertreatment SCR catalyst temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3147 active?
YES NO

Replace the aftertreatment SCR catalyst outlet temperature sensor.

Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment SCR catalyst temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment SCR catalyst temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the aftertreatment SCR catalyst temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

  • Clean the connector and pins, if possible.
  • Replace the interface module if the pins can not be cleaned. Refer to Procedure 019-464 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment SCR catalyst temperature sensor interface module. Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

  • Replace the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for a pin-to-pin short.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

  • Replace the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active and Fault Code 3147 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment SCR catalyst temperature sensor interface module from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment SCR catalyst outlet temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

  • Repair or replace the engine harness or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to the OEM service manual.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment SCR catalyst temperature sensor interface module from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment SCR catalyst outlet temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

  • Repair or replace the engine harness or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to the OEM service manual.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3147 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-May-2012


FAULT CODE 3148 - Aftertreatment SCR Catalyst Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | GX CM2250 | 4022250
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 3146 and 3147. | Fault Code 3146 or 3147 active?
STEP 2. | Check the aftertreatment SCR catalyst outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment SCR catalyst outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3146 active?
 | STEP 2C. Check the circuit response. | Fault Code 3147 active?
STEP 3. | Check the aftertreatment SCR catalyst temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment SCR catalyst temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR catalyst temperature interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module. | Greater than 100K ohms?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 3146 active?
 | STEP 4C. Check the circuit response. | Fault Code 3147 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 3146 and 3147.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3146 and 3147 active?
YES | NO
No Repair | No Repair

Fault Codes 3146 and 3147 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment SCR catalyst outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment SCR catalyst outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst outlet temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the interface module connector pins and aftertreatment SCR catalyst outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst outlet temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the SCR catalyst outlet temperature sensor from the interface module
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the SCR catalyst outlet temperature SIGNAL pin and the SCR catalyst outlet temperature RETURN pin at the SCR catalyst outlet temperature connector of the interface module.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3147 active?
YES NO

Replace the aftertreatment SCR outlet gas temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the aftertreatment SCR catalyst temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment SCR catalyst temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the aftertreatment SCR catalyst temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Clean the connector and pins, if possible.

Replace the interface module if the pins can not be cleaned. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment SCR catalyst temperature sensor interface module.

Reference the appropriate circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment SCR catalyst outlet temperature SIGNAL pin and aftertreatment SCR catalyst outlet temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3147 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-May-2012


FAULT CODE 3149 - Aftertreatment SCR Catalyst Outlet Temperature Sensor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 3146 or 3147 active?
STEP 2. | Check the aftertreatment SCR catalyst outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment SCR catalyst outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3146 active?
 | STEP 2C. Check the circuit response. | Fault Code 3147 active?
STEP 3. | Check the aftertreatment SCR catalyst temperature sensor interface module. |
 | STEP 3A. Inspect the aftertreatment SCR catalyst temperature sensor interface module. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR catalyst temperature interface module. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module. | Greater than 100K ohms?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 3146 active?
 | STEP 4C. Check the circuit response. | Fault Code 3147 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 or 3147 active?
YES | NO
No Repair | No Repair

Fault Code 3146 or 3147 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment SCR catalyst outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment SCR catalyst outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst outlet temperature sensor from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the interface module connector pins and SCR catalyst outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst outlet temperature sensor from the interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR catalyst outlet temperature sensor from the interface module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the SCR catalyst outlet temperature SIGNAL pin and the SCR catalyst outlet temperature RETURN pin at the SCR catalyst outlet temperature connector of the interface module.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3147 active?
YES NO

Replace the aftertreatment SCR outlet gas temperature sensor.

  • Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the aftertreatment SCR catalyst temperature sensor interface module.

Guided Step 3A - Inspect the aftertreatment SCR catalyst temperature sensor interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and the OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Inspect the aftertreatment SCR catalyst temperature sensor interface module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Clean the connector and pins.

Replace the interface module if the pins can not be cleaned.

  • Refer to Procedure 019-464 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and the OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for an open circuit.

  • Measure the resistance of each circuit contained within the aftertreatment SCR catalyst temperature sensor interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module.

  • Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment SCR catalyst temperature interface module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR catalyst intake temperature sensor, aftertreatment SCR catalyst outlet temperature sensor, and the OEM harness from the aftertreatment SCR catalyst temperature sensor interface module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between each pin in each connector in the interface module to all pins in all other connectors of the interface module.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment SCR catalyst temperature sensor interface module.

Replace the aftertreatment SCR catalyst temperature sensor interface module.

  • Refer to Procedure 019-464 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the aftertreatment SCR catalyst outlet temperature SIGNAL pin and aftertreatment SCR catalyst outlet temperature RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3147 active?
YES NO

High resistance or a short circuit has been detected in the aftertreatment SCR catalyst outlet temperature circuit.

Troubleshoot the engine harness, OEM harness, and the 14-pin crossover connector.

Repair or replace the damaged component.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-071 in Section 19.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-May-2012


FAULT CODE 3151 - Aftertreatment SCR Catalyst System Missing - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | GX CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | GX CM2250 | 4022250
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes.. | Fault Code 3251 active?
 | STEP 1B. Check for active aftertreatment NOx sensor fault codes. | Fault Code 1694, 3228, 3748, or 3749 active?
 | STEP 1C. Check for active DEF dosing system fault codes. | Troubleshoot all active DEF dosing system related fault codes before fault code 3251.
STEP 2. | Check the diesel exhaust fluid dosing system. |
 | STEP 2A. Inspect the diesel exhaust fluid dosing system for external leaks. | External leaks detected in the system?
 | STEP 2B. Check the diesel exhaust fluid quality | Diesel exhaust fluid free from contamination and within the specifications outlined in Procedure 011-058?
 | STEP 2C. Check the aftertreatment diesel exhaust fluid dosing unit for proper operation. | The aftertreatment diesel exhaust fluid dosing unit operates correctly during INSITE™ electronic service tool override tests?
STEP 3. | Check the aftertreatment system |
 | STEP 3A. Check the exhaust system for leaks. | Exhaust system leaks found?
 | STEP 3B. Check for deposits in the decomposition tube. | Excessive DEF deposits found inside the decomposition tube?
STEP 4. | Check for active fault codes |
 | STEP 4A. Perform a stationary regeneration and check for active fault codes | Fault Code 1694 active?
 | STEP 4B. Check for active fault codes | Fault Code 3751 active?
 | STEP 4C. Check for active fault codes. | Fault Code 3755 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3251 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active aftertreatment NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1694, 3228, 3748, or 3749 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1C

Guided Step 1C - Check for active DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for active fault codes relating to the DEF dosing system.

  • Use INSITE™ electronic service tool to read the fault codes.

Any DEF dosing related fault codes active?
YES NO

Troubleshoot all active DEF dosing system related fault codes before Fault Code 3251.

 No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid dosing system.

Guided Step 2A - Inspect the diesel exhaust fluid dosing system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all components of the aftertreatment diesel exhaust fluid dosing system for signs of external leaks, including:

  • Diesel exhaust fluid tank connectors
  • Diesel exhaust fluid dosing unit and dosing unit connectors
  • Diesel exhaust fluid lines
  • Diesel exhaust fluid dosing valve

Note: Diesel exhaust fluid will form white deposits around leaky fittings.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check the diesel exhaust fluid quality

Conditions

  • Turn keyswitch OFF.

Action

Check the diesel exhaust fluid quality.

  • Visually inspect the diesel exhaust fluid in the tank for signs of debris or contamination
  • Use the Cummins Diesel Exhaust Fluid Refractometer Service Tool Part Number 4919554, to test the diesel exhaust fluid concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

Diesel exhaust fluid free from contamination and within the specifications outlined in Procedure 011-056?
YES NO
No Repair

The fluid in the diesel exhaust fluid tank is not pure diesel exhaust fluid, or the diesel exhaust fluid is diluted or degraded.

Completely drain the diesel exhaust fluid tank, and rinse the tank with water.

Refill the diesel exhaust fluid tank with pure diesel exhaust fluid.

Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2C

Go to 2C

Guided Step 2C - Check the aftertreatment diesel exhaust fluid dosing unit for proper operation.

Conditions

  • Connect all diesel exhaust fluid lines and electrical connectors to the dosing unit and diesel exhaust fluid tank.
  • Remove aftertreatment diesel exhaust fluid dosing valve from decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test found under ECM Diagnostic Tests.

Refer to Procedure 011-063 in the Associated Procedure Table.

Note: The diesel exhaust fluid dosing valve must be removed and placed in a measuring container in order to run the Diesel Exhaust Fluid Doser Pump Override Test. Make sure the diesel exhaust fluid dosing unit is not plugged and diesel exhaust fluid is flowing from all holes.

Does the aftertreatment diesel exhaust fluid dosing unit operate according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid dosing unit filter. (Note that this filter can not be reused and must be changed upon removal.)

Refer to Procedure 011-060 in the Associated Procedures Table.

Perform the aftertreatment diesel exhaust fluid doser pump override test again with the new filter. If the dosing unit still does not operate according to the specifications, replace the aftertreatment diesel exhaust fluid dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system

Guided Step 3A - Check the exhaust system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust for leaks.

  • Inspect the entire exhaust system between the turbocharger outlet and the SCR outlet. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 3B

Go to 3B

Guided Step 3B - Check for deposits in the decomposition tube.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Inspect the decomposition tube for deposits.

  • Remove the decomposition tube from the vehicle.
  • Inspect for excessive DEF deposits.
  • Refer to procedure 011-062 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and install the decomposition tube.

Refer to Procedure 011-062 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check for active fault codes

Guided Step 4A - Perform a stationary regeneration and check for active fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON and start engine.
  • Connect INSITE™ electronic service tool.

Action

Perform a stationary regeneration of the aftertreatment system using the INSITE™ electronic service tool.

Check for active fault codes upon completion of the stationary regeneration.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1694 active?
YES NO

Refer to the Fault Code 1694 troubleshooting tree.

 No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 4B

Guided Step 4B - Check for active fault codes.

Conditions

  • Keyswitch ON.
  • Engine running.
  • Connect INSITE electronic service tool.

Action

Check for active fault codes upon completion of the stationary regeneration.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3751 active?
YES NO

Replace the aftertreatment SCR catalyst. Refer to procedure 011-036 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for active fault codes.

Conditions

  • Keyswitch ON.
  • Engine running.
  • Connect INSITE electronic service tool.

Action

Check for active fault codes upon completion of the stationary regeneration.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3755 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Refer to "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3228 - Aftertreatment Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3228 active?
 | STEP 1B. Check for active fault codes. | Fault codes 1885, 3232, 3649, 3682, or 3748 active?
STEP 2. | Check EGR system for leaks. |
 | STEP 2A. Check the EGR system for leaks. | Leaks detected in the EGR system?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3228 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes 1885, 3232, 3649, 3682, or 3748 active?
YES | NO
No Repair | No Repair

Go to Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check EGR system for leaks.

Guided Step 2A - Check the EGR system for leaks.

Conditions

  • Turn keyswitch ON.

Action

Inspect the EGR system for external leaks.

  • Leaks should be easily noted by traces of soot.
  • If necessary, run the engine at idle speed to help detect any EGR leaks.

Leaks detected in the EGR system?
YES NO

Repair or replace the leaky EGR system component.

A damaged aftertreatment intake NOx sensor has been detected.

Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-May-2012


FAULT CODE 3229 - Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | GX CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | GX CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | GX CM2250 | 4022250
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3142, 3143, 3144, 3145, 3146, 3147, 3148, or 3149 active or inactive counts?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the diesel exhaust fluid (DEF) for contamination. | Diesel exhaust fluid (DEF) contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Check the aftertreatment fuel injector. |
 | STEP 5A. Check the operation of the aftertreatment fuel injector (if equipped). | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
STEP 6. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 6A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 6B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3142, 3143, 3144, 3145, 3146, 3147, 3148, or 3149 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.
  • Engine idling for greater than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the signal pin of the temperature sensor in question to all other pins in the harness.

Check for a short circuit in the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

If no short is found replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the diesel exhaust fluid (DEF) for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the diesel exhaust fluid (DEF) for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

Diesel exhaust fluid (DEF) contaminated?
YES NO

Drain the diesel exhaust fluid (DEF) tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the aftertreatment fuel injector.

Guided Step 5A - Check the operation of the aftertreatment fuel injector (if equipped).

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • If the engine does not have an aftertreatment fuel injector, skip to step 6A.

Action

Check for fuel leaking from the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the Injector Leak Test. Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 014-013 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 011-036 in the Associated Procedures Table.

Perform a snap acceleration test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

  • If black smoke is present, inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 6A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment diesel oxidation catalyst for soot accumulation and/or face plugging.

Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 6B

Go to 6B

Guided Step 6B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall.

Conditions

  • Aftertreatment diesel oxidation catalyst removed.

Action

Inspect the aftertreatment diesel oxidation catalyst.

  • Check for cracks in the aftertreatment diesel oxidation catalyst cell wall.

Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3232 - Aftertreatment Intake NOx Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | GX CM2250 | 4022250
Engine Control Module Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3232 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 2636, 2771, and 3597 all active?
STEP 2. | Check the aftertreatment intake NOx sensor circuit. |
 | STEP 2A. Inspect aftertreatment intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment intake NOx sensor. | Voltage is within 1-VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine control parts list (CPL)?
 | STEP 2D. Check for correct aftertreatment intake NOx sensor. | Aftertreatment intake NOx sensor is the correct sensor for the engine CPL?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply. | Voltage is within 1-VDC of battery voltage?
STEP 4. | Check the J1939 data link. |
 | STEP 4A. Inspect engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 4F. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4G. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4H. Check the fault codes. | Fault Code 3232 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3232 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2636, 2771, and 3597 all active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment intake NOx sensor circuit.

Guided Step 2A - Inspect aftertreatment intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment intake NOx sensor from the engine harness
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment intake NOx sensor.

  • Measure the voltage between the aftertreatment intake NOx sensor battery voltage SUPPLY circuit and the aftertreatment intake NOx sensor battery voltage RETURN circuit at the NOx sensor wiring harness connector.

Note: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical System Voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 2D

5A.

Guided Step 2D - Check for correct aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF
  • Remove aftertreatment intake NOx sensor.

Action

Verify aftertreatment intake NOx sensor is the correct sensor for the engine CPL.

Note: The aftertreatment intake NOx sensor is available in 12-volt or 24-volt versions.

Aftertreatment intake NOx sensor is the correct sensor for the engine CPL?
YES NO
No Repair

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections, and clean the terminals. Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment intake NOx sensor from the engine harness
  • Turn keyswitch ON.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment intake NOx sensor battery voltage SUPPLY pin of the engine harness to engine block ground.

Note: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage RETURN circuit.

Check for blown or missing fuses. Check for damaged or missing relays. Troubleshoot the engine harness, OEM harness, and all interconnects. Repair or replace the damaged component(s) as necessary.

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage SUPPLY circuit.

Check for blown or missing fuses. Troubleshoot the engine harness, OEM harness, and all interconnects. Repair or replace the damaged component(s) as necessary.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment intake NOx sensor from the engine harness
  • Disconnect the engine harness connector 1 from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness

  • Measure the resistance between the SAE J1939 data link (+) wire at the aftertreatment intake NOx sensor engine harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector 1.
  • Measure the resistance between the SAE J1939 data link (−) wire at the aftertreatment intake NOx sensor engine harness connector and the SAE J1939 data link (−) wire at the ECM engine harness connector 1.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open or short has been detected on the J1939 data link.

Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid (DEF) controller to completely power down.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness
  • Disconnect the VGT actuator from the engine harness
  • Disconnect the aftertreatment DEF controller 53-pin connector
  • Disconnect the engine harness connector 1 from the ECM connector.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector 1 and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (−) wire at the ECM engine harness connector 1 and all other pins in the connector.

Disregard any resistance between 110 and 130 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (−) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment DEF controller to completely power down.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness
  • Disconnect the VGT DEF actuator from the engine harness
  • Disconnect the aftertreatment DEF controller 53-pin connector
  • Disconnect the engine harness connector 1 from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector 1 and ground.
  • Measure the resistance between the SAE J1939 data link (−) wire at the ECM engine harness connector 1 and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness
  • Connect all other components, including the diesel exhaust controller, ECM, and VGT.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE 1939 data link (+) wire and the SAE J1939 data link (-) wire at the aftertreatment intake NOx sensor OEM harness connector.

50 to 70 ohms?
YES | NO
No Repair | No Repair

Go to 4H

Go to 4F

Guided Step 4F - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 14-pin OEM connector from the engine harness.

Action

Measure the terminating resistance of the engine harness

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the 14-pin connector of the engine harness.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the OEM harness.

Repair or replace the terminating resistor in the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 4G

Guided Step 4G - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine harness.

Action

Measure the terminating resistance of the VGT actuator

  • Measure the resistance between the VGT actuator J1939 data link (+) wire and the VGT actuator J1939 data link (-) wire at the VGT actuator connector.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the engine harness.

Remove the additional terminating resistance or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Incorrect terminating resistance has been detected in VGT actuator.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4H - Check the fault codes.

Conditions

  • Turn keyswitch OFF
  • Connect the engine harness to the ECM
  • Connect the aftertreatment intake NOx sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3232 active?
YES NO

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Nov-2012


FAULT CODE 3236 - Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | GX CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | GX CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | GX CM2250 | 4022250
Aftertreatment SCR Catalyst Temperature Sensor Interface Module | Refer to Procedure 019-464 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3142, 3143, 3144, 3145, 3146, 3147, 3148, or 3149 active or inactive counts?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the diesel exhaust fluid (DEF) for contamination. | Diesel exhaust fluid (DEF) contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Check the aftertreatment fuel injector. |
 | STEP 5A. Check the operation of the aftertreatment fuel injector (if equipped). | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
STEP 6. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 6A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 6B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3142, 3143, 3144, 3145, 3146, 3147, 3148, or 3149 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.
  • Idle engine for greater than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Do any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the signal pin of the temperature sensor in question to all other pins in the harness.

Check for a short circuit in the aftertreatment SCR catalyst temperature sensor interface module. Refer to Procedure 019-464 in the Associated Procedures Table.

If no short is found replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the diesel exhaust fluid (DEF) for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the diesel exhaust fluid (DEF) for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

Diesel exhaust fluid (DEF) contaminated?
YES NO

Drain the diesel exhaust fluid (DEF) tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the aftertreatment fuel injector.

Guided Step 5A - Check the operation of the aftertreatment fuel injector (if equipped).

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • If the engine does not have an aftertreatment fuel injector, skip to step 6A.

Action

Check for fuel leaking from the aftertreatment fuel injector.

  • Use INSITE™ electronic service tool to perform the Injector Leak Test. Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 014-013 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 011-036 in the Associated Procedures Table.

Perform a snap acceleration test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

  • If black smoke is present, inspect the aftertreatment system for possible damage. Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 6A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment diesel oxidation catalyst for soot accumulation and/or face plugging.

Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 6B

Go to 6B

Guided Step 6B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall.

Conditions

  • Aftertreatment diesel oxidation catalyst removed.

Action

Inspect the aftertreatment diesel oxidation catalyst.

  • Check for cracks in the aftertreatment diesel oxidation catalyst cell wall.

Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3237 - Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3237 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid line heater 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid line heater 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment diesel exhaust fluid line heater 1. | Greater than 2 ohms?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3237 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid line heater 1 and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 1 from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid line heater 1 and aftertreatment diesel exhaust fluid controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater 1 or harness connector.

  • Clean the connector and pins
  • Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment diesel exhaust fluid line heater 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 1 from the aftertreatment diesel exhaust fluid controller harness.

Action

Check the resistance of the aftertreatment diesel exhaust fluid line heater 1.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 1 SIGNAL pin and the aftertreatment diesel exhaust fluid line heater 1 SUPPLY pin at the aftertreatment diesel exhaust fluid line heater 1 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 2 ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment diesel exhaust fluid line heater 1, or the line heater 1 resistance is too low.

  • Replace the aftertreatment diesel exhaust fluid line heater 1. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connectors, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 1 from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 1 SIGNAL pin and all other pins in the aftertreatment diesel exhaust fluid controller harness 86-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

  • Refer to Procedure 011-057 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the aftertreatment diesel exhaust fluid controller harness.

  • Repair or replace the harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedure Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3239 - Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3239 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid line heater 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid line heater 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check resistance of the aftertreatment diesel exhaust fluid line heater 2. | Greater than 2 ohms?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3239 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid line heater 2 and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid line heater 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 2 from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid line heater 2 and aftertreatment diesel exhaust fluid controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater 2 or harness connector.

Clean the connector and pins

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check resistance of the aftertreatment diesel exhaust fluid line heater 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 2 from the aftertreatment diesel exhaust fluid controller harness.

Action

Check the resistance of the aftertreatment diesel exhaust fluid line heater 2.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 2 SIGNAL pin and the aftertreatment diesel exhaust fluid line heater 2 SUPPLY pin at the aftertreatment diesel exhaust fluid line heater 2 connector.

Refer to the circuit diagram and a wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 2 ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment diesel exhaust fluid line heater 2, or the line heater 2 resistance is too low.

Replace the aftertreatment diesel exhaust fluid line heater 2.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 2 from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 2 SIGNAL pin and all other pins in the aftertreatment diesel exhaust fluid controller harness 86-pin connector.

Refer to the circuit diagram and a wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the aftertreatment diesel exhaust fluid controller harness

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3258 - Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3258 inactive?
 | STEP 1B. Check for active diesel exhaust fluid line heater relay fault codes. | Fault Codes 3562, 3563, or 3564 active?
 | STEP 1C. Check for multiple active diesel exhaust fluid line heater fault codes. | Fault Codes 3258, 3261, and 3425 all active?
STEP 2. | Check the aftertreatment diesel exhaust fluid line heater 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid line heater 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3237 active and Fault Code 3258 inactive?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition. | Fault Code 3258 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness line heater supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness line heater signal circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3258 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for active diesel exhaust fluid line heater relay fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for line heater relay fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3562, 3563, or 3564 active?
YES NO

Refer to appropriate fault code troubleshooting tree.

 No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple active diesel exhaust fluid line heater fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active line heater fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3258, 3261, and 3425 all active?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment diesel exhaust fluid controller harness line heater power supply circuit.

This can possibly be caused by:

  • Switch side of line heater relay stuck open
  • Burned out in-line fuse on the line heater power supply circuit (if equipped)
  • Open circuit or short to ground in the aftertreatment diesel exhaust fluid controller harness line heater power supply circuit.

Repair or replace the damaged component.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid line heater 1 and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid line heater 1 from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid line heater 1 and aftertreatment diesel exhaust fluid controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid line heater 1 from the aftertreatment diesel exhaust fluid controller harness.

Action

Perform the following steps to check the circuit response.

  • With the keyswitch off, place a jumper wire between the aftertreatment diesel exhaust fluid line heater 1 SIGNAL pin and the aftertreatment diesel exhaust fluid line heater 1 SUPPLY pin at the aftertreatment diesel exhaust fluid line heater 1 harness connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test and manually command line heaters 1, 2, and 3 ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 3237 active and Fault Code 3258 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment diesel exhaust fluid line heater 1 to the aftertreatment diesel exhaust fluid controller harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Perform the following steps to check the circuit response.

  • Turn keyswitch ON, start engine, and allow the engine to idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Shut down the engine and repeat this process one more time to allow all diagnostic checks to complete.

Fault Code 3258 active?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment diesel exhaust fluid line heater 1.

Replace the aftertreatment diesel exhaust fluid line heater 1.

Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness line heater supply circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid line heater 1 from the aftertreatment diesel exhaust fluid controller harness
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay.

Action

Check for an open circuit.

  • Measure the resistance of the aftertreatment diesel exhaust fluid controller harness between the aftertreatment diesel exhaust fluid line heater 1 SUPPLY pin and pin 87 of the aftertreatment diesel exhaust fluid line heater relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness line heater power supply circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness line heater signal circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid line heater 1 from the aftertreatment diesel exhaust fluid controller harness
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 1 SIGNAL pin at the 86 pin controller harness connector and the aftertreatment diesel exhaust fluid line heater 1 SIGNAL pin at the line heater 1 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness line heater signal circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid line heater 1 from the aftertreatment diesel exhaust fluid controller harness
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for a pin to ground short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 1 SIGNAL pin at the aftertreatment diesel exhaust fluid controller harness 86-pin connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin to ground short circuit on the SIGNAL wire has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3261 - Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3261 inactive?
 | STEP 1B. Check for active diesel exhaust fluid line heater relay fault codes. | Fault Codes 3562, 3563, or 3564 active?
 | STEP 1C. Check for multiple active diesel exhaust fluid line heater fault codes. | Fault Codes 3258, 3261, and 3425 all active?
STEP 2. | Check the aftertreatment diesel exhaust fluid line heater 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid line heater 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3239 active and Fault Code 3261 inactive?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition. | Fault Code 3261 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness line heater supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness line heater supply circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3261 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for active diesel exhaust fluid line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for line heater relay fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3562, 3563, or 3564 active?
YES NO

Refer to appropriate fault code troubleshooting tree.

 No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple active diesel exhaust fluid line heater fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active line heater fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3258, 3261, and 3425 all active?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment diesel exhaust fluid controller harness line heater power supply circuit.

This could be caused by:

  • Switch side of line heater relay stuck open
  • Burned out in-line fuse on the line heater power supply circuit (if equipped)
  • Open circuit or short to ground in the aftertreatment diesel exhaust fluid controller harness line heater power supply circuit.

Repair or replace the malfunctioning component. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid line heater 2 and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid line heater 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 2 from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid line heater 2 and aftertreatment diesel exhaust fluid controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 2 from the aftertreatment diesel exhaust fluid controller harness.

Action

Perform the following steps to check the circuit response.

  • With the keyswitch off, place a jumper wire between the aftertreatment diesel exhaust fluid line heater 2 SIGNAL pin and the aftertreatment diesel exhaust fluid line heater 2 SUPPLY pin at the aftertreatment diesel exhaust fluid line heater 2 harness connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test and manually command line heaters 1, 2, and 3 ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 3239 active and Fault Code 3261 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid dosing unit condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid line heater 2 to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the following steps to check the circuit response.

  • Turn keyswitch ON, start engine, and allow the engine to idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Shut down the engine and repeat this process one more time to allow all diagnostic checks to complete.

Fault Code 3261 active?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment diesel exhaust fluid line heater 2.

  • Replace the aftertreatment diesel exhaust fluid line heater 2. Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness line heater supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 2 from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay.

Action

Check for an open circuit.

  • Measure the resistance of the aftertreatment diesel exhaust fluid controller harness between the aftertreatment diesel exhaust fluid line heater 2 SUPPLY pin and pin 87 of the aftertreatment diesel exhaust fluid line heater relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness line heater power supply circuit.

  • Repair or replace the harness. Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness line heater signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 2 from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 2 SIGNAL pin at the 86 pin controller harness connector and the aftertreatment diesel exhaust fluid line heater 2 SIGNAL pin at the line heater 2 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness line heater signal circuit.

  • Repair or replace the harness. Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 2 from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 2 SIGNAL pin at the aftertreatment diesel exhaust fluid controller harness 86-pin connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid controller. Refer to Procedure 011-057 in the Associated Procedures Table.

A pin-to-ground short circuit on the SIGNAL wire has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3422 - Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3422 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid line heater 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid line heater 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment diesel exhaust fluid line heater 3. | Greater than 2 ohms?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3422 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid line heater 3 and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid line heater 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 3 from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid line heater 3 and aftertreatment diesel exhaust fluid controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in line heater 3, or the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check resistance of the aftertreatment diesel exhaust fluid line heater 3.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 3 from the aftertreatment diesel exhaust fluid controller harness.

Action

Check the resistance of the aftertreatment diesel exhaust fluid line heater 3.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 3 SIGNAL pin and the aftertreatment diesel exhaust fluid line heater 3 SUPPLY pin at the aftertreatment diesel exhaust fluid line heater 3 connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 2 ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment diesel exhaust fluid line heater 3, or the line heater 3 resistance is too low.

Replace the aftertreatment diesel exhaust fluid line heater 3.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 3 from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 3 SIGNAL pin and all other pins in the aftertreatment diesel exhaust fluid controller harness 86-pin connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3425 - Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3425 inactive?
 | STEP 1B. Check for active diesel exhaust fluid line heater relay fault codes. | Fault Codes 3422 active?
 | STEP 1C. Check for multiple active diesel exhaust fluid line heater fault codes. | Fault Codes 3258, 3261, and 3425 all active?
STEP 2. | Check the aftertreatment diesel exhaust fluid line heater 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid line heater 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3422 active and Fault Code 3425 inactive?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid line heater 3 dosing unit condition. | Fault Code 3425 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness line heater supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness line heater signal circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3425 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code Procedure. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for active diesel exhaust fluid line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for line heater relay fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3562, 3563, or 3564 active?
YES NO

Refer to appropriate fault code troubleshooting tree.

 No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple active diesel exhaust fluid line heater fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active line heater fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3258, 3261, and 3425 all active?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment diesel exhaust fluid controller harness line heater power supply circuit.

This could be caused by:

  • Switch side of line heater relay stuck open
  • Burned out in-line fuse on the line heater power supply circuit (if equipped)
  • Open circuit or short to ground in the aftertreatment diesel exhaust fluid controller harness line heater power supply circuit.

Repair or replace the malfunctioning component.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid line heater 3 and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid line heater 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 3 from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid line heater 3 and aftertreatment diesel exhaust fluid controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater 3, or the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 3 from the aftertreatment diesel exhaust fluid controller harness.

Action

Perform the following steps to check the circuit response.

  • With the keyswitch OFF, place a jumper wire between the aftertreatment diesel exhaust fluid line heater 3 SIGNAL pin and the aftertreatment diesel exhaust fluid line heater 3 SUPPLY pin at the aftertreatment diesel exhaust fluid line heater 3 harness connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test and manually command line heaters 1, 2, and 3 ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 3422 active and Fault Code 3425 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid line heater 3 condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid line heater 3 to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the following steps to check the circuit response.

  • Turn keyswitch ON, start engine, and allow the engine to idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Shut down the engine and repeat this process one more time to allow all diagnostic checks to complete.

Fault Code 3425 active?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment diesel exhaust fluid line heater 3.

Replace the aftertreatment diesel exhaust fluid line heater 3.

Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness line heater supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 3 from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay.

Action

Check for an open circuit.

  • Measure the resistance of the aftertreatment diesel exhaust fluid controller harness between the aftertreatment diesel exhaust fluid line heater 3 SUPPLY pin and pin 87 of the aftertreatment diesel exhaust fluid line heater relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness line heater power SUPPLY circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness line heater SIGNAL circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 3 from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 3 SIGNAL pin at the 86 pin controller harness connector and the aftertreatment diesel exhaust fluid line heater 3 SIGNAL pin at the line heater 3 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness line heater signal circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater 3 from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for a pin to ground short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 3 SIGNAL pin at the aftertreatment diesel exhaust fluid controller harness 86-pin connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin-to-ground short circuit on the SIGNAL wire has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3426 - Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3426 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid line heater 4 and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid line heater 4 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check resistance of the aftertreatment diesel exhaust fluid line heater 4. | Greater than 2 ohms?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3426 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid line heater 4 and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid line heater 4 and the aftertreatment diesel exhaust fluid controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater 4, or the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check resistance of the aftertreatment diesel exhaust fluid line heater 4.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Check resistance of the aftertreatment diesel exhaust fluid line heater 4.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 4 SIGNAL pin and the aftertreatment diesel exhaust fluid line heater 4 SUPPLY pin at the aftertreatment diesel exhaust fluid dosing unit connector.

Greater than 2 ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment diesel exhaust fluid line heater 4, or the line heater 4 resistance is too low.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 4 SIGNAL pin and all other pins in the aftertreatment diesel exhaust fluid controller harness 86-pin connector.

Greater than 100k ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - A Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number i the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3429 - Aftertreatment Diesel Exhaust Fluid Line Heater 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3429 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid line heater 4 and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3426 active and Fault Code 3429 inactive?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness signal circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3429 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code Procedure 019-362.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid line heater 4 and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid dosing unit and aftertreatment diesel exhaust fluid controller harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Perform the following steps to check the circuit response.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid line heater 4 SIGNAL pin and the aftertreatment diesel exhaust fluid line heater 4 SUPPLY pin at the aftertreatment diesel exhaust fluid dosing unit harness connector.
  • Turn keyswitch ON, start engine, and allow the engine to idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault codes 3561, 3579, and 3571 will also be active.

Fault code 3426 active and Fault Code 3429 inactive?
YES NO

An open circuit or short circuit to ground has been detected in the aftertreatment diesel exhaust fluid line heater 4, which is internal to the aftertreatment diesel exhaust fluid dosing unit.

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid dosing unit and aftertreatment diesel exhaust fluid controller harness connections for the following: Check the intake manifold pressure sensor.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance of the aftertreatment diesel exhaust fluid controller harness between the aftertreatment diesel exhaust fluid line heater 4 SUPPLY pin at the dosing unit connector and the aftertreatment diesel exhaust fluid line heater 4 SUPPLY pin at the 86-pin controller harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness line heater 4 supply circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment diesel exhaust fluid controller harness signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for an open circuit.

  • Measure the resistance of the aftertreatment diesel exhaust fluid controller harness between the aftertreatment diesel exhaust fluid line heater 4 SIGNAL pin at the dosing unit connector and the aftertreatment diesel exhaust fluid line heater 4 SIGNAL pin at the 86-pin controller harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness line heater signal circuit.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 86-pin connector from the controller.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 4 SIGNAL pin at the aftertreatment diesel exhaust fluid controller harness 86-pin connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

A pin-to-ground short circuit on the SIGNAL wire has been detected in the aftertreatment diesel exhaust fluid controller harness.

Repair or replace the harness.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3543 - NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2250 | 4022254
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX15 CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | GX CM2250 | 4022250
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX11.9 CM2250 | 2883445
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2250 | 4022254
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | GX CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISX11.9 CM2250 | 2883445
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | ISB6.7 CM2250 | 4022254
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | ISX15 CM2250 | 4022250
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | GX CM2250 | 4022250
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Pump Override Test | Refer to Procedure 011-063 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Pump Override Test | Refer to Procedure 011-063 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Pump Override Test | Refer to Procedure 011-063 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Pump Override Test | Refer to Procedure 011-063 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Pump Override Test | Refer to Procedure 011-063 | ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2250 | 4022254
ECM Calibration Code | Refer to Procedure 019-032 | ISC8.3 and ISL9 CM2250 | 4022257
ECM Calibration Code | Refer to Procedure 019-032 | ISX15 CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3543 active?
 | STEP 1B. Check for active aftertreatment NOx sensor fault codes. | Fault Code 1694, 3228, 3748, or 3749 active?
 | STEP 1C. Check for active DEF dosing system fault codes. | Any DEF dosing related fault codes active?
STEP 2. | Check the diesel exhaust fluid dosing system. |
 | STEP 2A. Inspect the diesel exhaust fluid dosing system for external leaks. | External leaks detected in the system?
 | STEP 2B. Check the diesel exhaust fluid quality. | Diesel exhaust fluid free from contamination and within the specifications outlined in Procedure 011-056?
 | STEP 2C. Check the aftertreatment diesel exhaust fluid dosing unit for proper operation. | Does the aftertreatment diesel exhaust fluid dosing unit operate according to the specifications in procedure 011-063?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Check the exhaust system for leaks. | Exhaust system leaks found?
 | STEP 3B. Check for deposits in the decomposition tube. | Excessive DEF deposits found inside the decomposition tube?
STEP 4. | Check for active fault codes. |
 | STEP 4A. Perform a stationary regeneration and check for active fault codes. | Fault Code 1694 active?
 | STEP 4B. Check for active fault codes. | Fault Code 3751 active?
 | STEP 4C. Check for active fault codes. | Fault Code 3755 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3543 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active aftertreatment NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1694, 3228, 3748, or 3749 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1C

Guided Step 1C - Check for active DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes relating to the DEF dosing system.

  • Use INSITE™ electronic service tool to read the fault codes.

Any DEF dosing related fault codes active?
YES NO

Troubleshoot all active DEF dosing system related fault codes before Fault Code 3543.

 No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid dosing system.

Guided Step 2A - Inspect the diesel exhaust fluid dosing system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all components of the aftertreatment diesel exhaust fluid dosing system for signs of external leaks, including:

  • Diesel exhaust fluid tank connectors
  • Diesel exhaust fluid dosing unit and dosing unit connectors
  • Diesel exhaust fluid lines
  • Diesel exhaust fluid dosing valve.

Note: Diesel exhaust fluid will form white deposits around leaky fittings.

External leaks detected in the system?
YES NO

Repair the source of the external leak

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check the diesel exhaust fluid quality.

Conditions

  • Turn keyswitch OFF.

Action

Check the diesel exhaust fluid quality.

  • Visually inspect the diesel exhaust fluid in the tank for signs of debris or contamination.
  • Use the Cummins® Diesel Exhaust Fluid Refractometer Service Tool, Part Number 4919554, to test the diesel exhaust fluid concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

Diesel exhaust fluid free from contamination and within the specifications outlined in Procedure 011-056?
YES NO
No Repair

The fluid in the diesel exhaust fluid tank is not pure diesel exhaust fluid, or the diesel exhaust fluid is diluted or degraded.

Completely drain the diesel exhaust fluid tank, and rinse the tank with water.

Refill the diesel exhaust fluid tank with pure diesel exhaust fluid. Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2C

Go to 2C

Guided Step 2C - Check the aftertreatment diesel exhaust fluid dosing unit for proper operation.

Conditions

  • Connect all diesel exhaust fluid lines and electrical connectors to the dosing unit and diesel exhaust fluid tank.
  • Remove aftertreatment diesel exhaust fluid dosing valve from decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test found under ECM Diagnostic Tests.

Refer to Procedure 011-063 in the Associated Procedures Table.

Note: The diesel exhaust fluid dosing valve must be removed and placed in a measuring container in order to run the Diesel Exhaust Fluid Doser Pump Override Test. Make sure the diesel exhaust fluid dosing unit is not plugged and diesel exhaust fluid is flowing from all holes.

Does the aftertreatment diesel exhaust fluid dosing unit operate according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid dosing unit filter.

Note: This filter can not be reused (it must be changed upon removal).

Refer to Procedure 011-060 in the Associated Procedures Table.

Perform the aftertreatment diesel exhaust fluid doser pump override test again with the new filter. If the dosing unit still does not operate according to the specifications, replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Check the exhaust system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust for leaks.

  • Inspect the entire exhaust system between the turbocharger outlet and the SCR outlet. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 3B

Go to 3B

Guided Step 3B - Check for deposits in the decomposition tube.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Inspect the decomposition tube for deposits.

  • Remove the decomposition tube from the vehicle. Inspect for excessive DEF deposits.
  • Inspect for excessive DEF deposits.
  • Refer to Procedure 011-062 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and install the decomposition tube.

Refer to Procedure 011-062 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check for active fault codes.

Guided Step 4A - Perform a stationary regeneration and check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON and start engine.
  • Connect INSITE™ electronic service tool.

Action

Perform a stationary regeneration of the aftertreatment. Use INSITE™ electronic service tool.

Check for active fault codes upon completion of the stationary regeneration.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1694 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 4B

Guided Step 4B - Check for active fault codes.

Conditions

  • Keyswitch ON.
  • Engine running.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes upon completion of the stationary regeneration.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3751 active?
YES NO

Replace the aftertreatment SCR catalyst. Refer to procedure 011-036 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for active fault codes.

Conditions

  • Keyswitch ON.
  • Engine running.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes upon completion of the stationary regeneration.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3755 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Refer to "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3547 - Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2250 | 4022254
ECM Calibration Code | Refer to Procedure 019-032 | ISC8.3 and ISL9 CM2250 | 4022257
ECM Calibration Code | Refer to Procedure 019-032 | ISX15 CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3547 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3547 active?
YES NO

Diesel exhaust fluid has not been detected in the diesel exhaust fluid tank.

Add diesel exhaust fluid to the diesel exhaust fluid tank.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3557 - Aftertreatment Diesel Exhaust Fluid Controller - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2250 | 4022254
ECM Calibration Code | Refer to Procedure 019-032 | ISC8.3 and ISL9 CM2250 | 4022257
ECM Calibration Code | Refer to Procedure 019-032 | ISX15 CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | ISX11.9 CM2250 | 2883445

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3557 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid pressure sensor and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3557 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 3A. Inspect the aftertreatement diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3557 active?
 | STEP 3C. Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness. | Resistance greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 3557 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3557 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid pressure sensor and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and aftertreatment diesel exhaust fluid pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Codes 3429, 3561, 3571, and 3577 will be active.

Fault Code 3557 active?
YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatement diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the aftertreatment diesel exhaust fluid controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the contoller or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 86-pin connector from the aftertreatment diesel exhaust fluid controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Codes 1669, 1678, 3258, 3261, 3425, 3429, 3561, 3571, 3576, and 3579 will be active.

Fault Code 3557 active?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 86-pin connector from the aftertreatment diesel exhaust fluid controller.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the aftertreatment diesel exhaust fluid controller.

Action

Check for a pin-to-pin short circuit in the aftertreatment diesel exhaust fluid controller harness.

  • Measure the resistance from the aftertreatment diesel exhaust fluid pressure 5 volt SUPPLY pin at the 86-pin connector and all other pins in the 86-pin connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment diesel exhaust fluid pressure sensor 5 volt SUPPLY line.

Repair or replace the aftertreatment diesel exhaust fluid controller harness.

Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3557 active?
YES NO

The removal and installation of the connector corrected the fault.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3569 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3569 active or more than two inactive counts?
STEP 2. | Check the aftertreatment diesel exhaust fluid lines and fittings. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit lines and fittings. | Any damaged, leaking, or restricted connections found?
 | STEP 2B. Check the aftertreatment diesel exhaust fluid dosing valve supply line. | Diesel exhaust fluid dosing valve supply line blocked or restricted?
STEP 3. | Check the aftertreatment diesel exhaust fluid dosing valve. |
 | STEP 3A. Inspect the diesel exhaust fluid dosing valve for blockage. | Does the diesel exhaust fluid dosing valve show signs of blockage or restrictions?
 | STEP 3B. Perform the aftertreatment diesel exhaust fluid doser pump override test. | Measured volume of diesel exhaust fluid from doser pump override test within specifications outlined in Procedure 011-058 and diesel exhaust fluid dosing valve providing uniform spray pattern?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes..

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3569 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

An inactive or intermittent fault codes has been detected. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid lines and fittings.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all three aftertreatment diesel exhaust fluid dosing unit fittings and lines.

  • Check the dosing unit supply, dosing valve supply, and return connectors and fittings for loose or leaking connections.
  • Disconnect the dosing unit supply, dosing valve supply, and return connectors. Look for signs of build-up or blockage.
  • Check the dosing unit supply line for signs of leakage or openings which would allow the dosing unit to suck in air with the diesel exhaust fluid.

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?

YES NO

Repair or replace the leaking diesel exhaust fluid line or fitting as necessary.

Refer to the OEM service manual.

Repair or replace the aftertreatment diesel exhaust fluid dosing unit as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the aftertreatment diesel exhaust fluid dosing valve supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve supply line from the dosing unit (this is the pressure line between the dosing unit and the dosing valve)
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve supply line from the dosing valve.

Action

Check the diesel exhaust fluid dosing unit supply line for blockage.

  • Visually check both ends of the line for signs of build-up or blockage.
  • Blow compressed shop air through the supply line to make sure of free flow.

Diesel exhaust fluid dosing valve supply line blocked or restricted?
YES NO

Try to clean the dosing valve supply line with shop air. If necessary, replace the dosing valve supply line.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid dosing valve.

Guided Step 3A - Inspect the diesel exhaust fluid dosing valve for blockage.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment diesel exhaust fluid dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Action

Inspect the aftertreatment diesel exhaust fluid dosing valve for signs of build-up, blockage, or restrictions.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

Does the diesel exhaust fluid dosing valve show signs of blockage or restrictions?
YES NO

Clean or replace the diesel exhaust fluid dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3B

Guided Step 3B - Perform the aftertreatment diesel exhaust fluid doser pump override test.

Conditions

  • Connect all diesel exhaust fluid lines and electrical connectors to the dosing unit and diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the exhaust pipe.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at operate at low idle.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Tests.

Refer to Procedure 011-063 in the Associated Procedures Table.

Note: The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Make sure the diesel exhaust fluid dosing valve is providing a uniform spray pattern while dosing.

Measured volume of diesel exhaust fluid from doser pump override test within specifications outlined in Procedure 011-058 and diesel exhaust fluid dosing valve providing uniform spray pattern?

YES NO
No Repair

Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3576 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3576 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3576 inactive and Fault Code 1683 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment diesel exhaust fluid tank heater control valve condition. | Fault Code 3576 active?
STEP 3. | Check the aftertreatment diesel exhaust fluid controller and harness. |
 | STEP 1A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment diesel exhaust fluid tank heater control valve circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3576 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code. Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the aftertreatment diesel exhaust fluid controller harness.

Action

Inspect the engine harness and aftertreatment diesel exhaust fluid tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank heater control valve SIGNAL pin and the aftertreatment diesel exhaust fluid tank heater control valve RETURN pin at the aftertreatment diesel exhaust fluid tank heater control valve wiring harness connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3576 inactive and Fault Code 1683 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment diesel exhaust fluid tank heater control valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid tank heater control valve to the aftertreatment diesel exhaust fluid controller harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3576 active?
YES NO

A damaged aftertreatment diesel exhaust fluid tank heater control valve has been detected.

  • Replace the aftertreatment diesel exhaust fluid tank heater control valve.
  • Refer to the OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid controller and harness.

Guided Step 3A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and controller 86-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques, refer to Component Connector and Pin Inspection. Refer to Procedure Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller connector or the aftertreatment diesel exhaust fluid controller harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid controller harness from the controller
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the harness.

Action

Check for an open circuit in the aftertreatment diesel exhaust fluid tank heater control valve circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid control valve SIGNAL pin at the harness connector and the 86-pin controller connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid control valve RETURN pin at the harness connector and the 86-pin controller connector.

Greater than 100k ohms?
YES NO

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller harness.

  • Repair or replace the harness.
  • Refer to the OEM service manual.

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3582 - Aftertreatment Selective Catalytic Reduction (SCR) Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | GX15 CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | GX15 CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | GX15 CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | GX15 CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | GX15 CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Pump Override Test | Refer to Procedure 011-063 | GX15 CM2250 | 4022250
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | GX15 CM2250 | 4022250
Dynamic Engine System Analysis | Refer to Procedure 014-020 | GX15 CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | GX15 CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3582 active or one or more counts of inactive?
 | STEP 1B. Check for active or inactive aftertreatment mono-nitrogen oxides (NOx) sensor fault codes. | Fault Code 1885, 1887, 2771, 3228, 3232, 3545, 3583, 3649, 3681, 3682, 3717, 3718, 3725, 3726, 3748, or 3749 (NOx sensor related fault codes) active or one or more counts of inactive?
 | STEP 1C. Check for active or inactive diesel exhaust fluid (DEF) dosing system fault codes. | Fault Code 1681, 1682, 3547, 3568, 3569, 3574, 3575, or 3596 (DEF dosing system related fault codes) active or one or more counts of inactive?
 | STEP 1D. Check for active or inactive aftertreatment regeneration limiting fault codes. | Fault Code 1664, 1691, 1879, 1881, 1883, 1922, 1923, 1924, 1925, 1926, 1927, 1928, 1932, 1963, 1964, 1977, 1981, 1993, 2637, 2638, 2881, 3165, 3223, 3224, 3225, 3229, 3245, 3251, 3253, 3254, 3255, 3256, 3311, 3312, 3313, 3314, 3315, 3316, 3317, 3318, 3319, 3321, or 3322 active or one or more counts of inactive?
STEP 2. | Check the diesel exhaust fluid (DEF) dosing system. |
 | STEP 2A. Inspect the DEF dosing system for external leaks. | External leaks detected in the system?
 | STEP 2B. Check the DEF quality. | DEF free from contamination and within the specifications outlined in Procedure 011-056 in Section 11?
 | STEP 2C. Check the aftertreatment DEF dosing unit filter. | DEF dosing unit filter contaminated?
STEP 3. | Check engine control module (ECM) calibration. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Check the exhaust system. |
 | STEP 4A. Clean the diesel oxidation catalyst (DOC). | DOC been cleaned?
STEP 5. | Check the aftertreatment NOx sensors. |
 | STEP 5A. Check for correct aftertreatment inlet NOx sensor and outlet NOx sensor. | Aftertreatment NOx sensors are the correct sensors for the engine configuration and in the correct locations?
STEP 6. | Check the DEF dosing system operation. |
 | STEP 6A. Check for air in the DEF. | Air detected in the DEF?
 | STEP 6B. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063 in Section 11?
STEP 7. | Check for active fault codes. |
 | STEP 7A. Perform a stationary regeneration and check for active fault codes. | Fault Code 1694 active?
 | STEP 7B. Check for active fault codes. | Fault Code 3751 active?
STEP 8. | Check SCR part number. |
 | STEP 8A. Verify DEF system repairs. | Repairs made to the DEF dosing system at Steps 4D and/or 4E?
 | STEP 8B. SCR part number verification. | Does the SCR catalyst part number match one in this list? 4329015 , 4329016 , 4329017 , 4329018 , 4329019, 4329020, 4329061, 4329062, 4329063, 4329064, 4329065, 4329066, 4329067, 4329068, 4329069, 4329070, 4329071, 4329072, 4329073, 4329074, 4329075, 4329076, 4329091, 4329092, 4329093, 4329094, 4329096, 4329097, 4329098, 4329099, 4329100, 4329101, 4329102, 4329103, 4329104, 4329105, 4329106, 4329107, 4329108, 4329109, 4329110, or 4329111?
STEP 9. | Clear fault codes. |
 | STEP 9A. Disable the fault code. | Fault code cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3582 active or one or more counts of inactive?
YES | NO
No Repair | No Repair

Go to 1B

No Repair

Guided Step 1B - Check for active or inactive aftertreatment mono-nitrogen oxides (NOx) sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885, 1887, 2771, 3228, 3232, 3545, 3583, 3649, 3681, 3682, 3717, 3718, 3725, 3726, 3748, or 3749 (NOx sensor related fault codes) active or one or more counts of inactive?

YES NO

Troubleshoot all active or inactive NOx sensor fault codes and then return to Fault Code 3582.

 No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1C

Guided Step 1C - Check for active or inactive DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1681, 1682, 3547, 3568, 3569, 3574, 3575, or 3596 (DEF dosing system related fault codes) active or one or more counts of inactive?

YES NO

Troubleshoot all active or inactive DEF dosing system fault codes and then return to Fault Code 3582.

 No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1D

Guided Step 1D - Check for active or inactive aftertreatment regeneration limiting fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1664, 1691, 1879, 1881, 1883, 1922, 1923, 1924, 1925, 1926, 1927, 1928, 1932, 1963, 1964, 1977, 1981, 1993, 2637, 2638, 2881, 3165, 3223, 3224, 3225, 3229, 3245, 3251, 3253, 3254, 3255, 3256, 3311, 3312, 3313, 3314, 3315, 3316, 3317, 3318, 3319, 3321, or 3322 active or one or more counts of inactive?

YES NO

Troubleshoot all active or inactive aftertreatment regeneration limiting fault codes and then return to Fault Code 3582.

 No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Inspect the DEF dosing system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all components of the aftertreatment DEF dosing system for signs of external leaks, including:

  • DEF tank connectors
  • DEF dosing unit and dosing unit connectors
  • DEF lines
  • DEF dosing valve

White DEF deposits will form around leaky fittings.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check the DEF quality.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Inspect the DEF in the tank for signs of debris or contamination.
  • Reference the Aftertreatment Diesel Exhaust Fluid Dosing and Selective Catalytic Reduction System Reuse Guidelines, Bulletin 4325971.
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 2919552, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056?
YES NO
No Repair

The fluid in the DEF tank is not pure DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank, and rinse the tank and internal tank components with water.

Rinse the DEF inlet and return lines with water.

Refill the DEF tank with pure DEF.

Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2C

Go to 2C

Guided Step 2C - Check the aftertreatment DEF dosing unit filter.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DEF dosing unit filter. Refer to Procedure 011-060 in the Associated Procedures Table.

Action

Inspect the aftertreatment DEF dosing unit filter for signs of contamination or blockage.

  • Reference the Aftertreatment Diesel Exhaust Fluid Dosing and Selective Catalytic Reduction System Reuse Guidelines, Service Bulletin 4325971.

DEF dosing unit filter contaminated?
YES NO

The fluid in the DEF tank is contaminated.

Remove and clean the DEF tank, flush the DEF lines, and replace the DEF dosing unit filter. Reference the following procedure for contamination/incorrect fluid.

Refer to Procedure 011-056 in the Associated Procedures Table.

Replace the aftertreatment DEF dosing unit filter. This filter can not be reused and must be changed upon removal.

Refer to Procedure 011-060 in the Associated Procedures Table.

Replace the aftertreatment DEF dosing unit filter. This filter can not be reused and must be changed upon removal.

Refer to Procedure 011-060 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check the exhaust system.

Guided Step 4A - Clean the DOC.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Clean the DOC.

  • Refer to Procedure 011-049 in the Associated Procedures Table.

DOC been cleaned?
YES NO
No Repair

Clean the DOC.

  • Refer to Procedure 011-049 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check the aftertreatment NOx sensors.

Guided Step 5A - Check for correct aftertreatment inlet NOx sensor and outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment inlet NOx sensor and outlet NOx sensor.

Action

Verify aftertreatment inlet NOx sensor and outlet NOx sensor are the correct sensors for the engine configuration and that they are not swapped.

NOTE: The aftertreatment NOx sensors are available in 12-VDC or 24-VDC versions

Aftertreatment NOx sensors are the correct sensors for the engine configuration and in the correct locations?
YES NO
No Repair

Replace the incorrect aftertreatment NOx sensor(s). Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check the DEF dosing system operation.

Guided Step 6A - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air detected in the DEF?
YES NO

Check the following components for damage or leaks and repair as necessary:

  • Aftertreatment DEF dosing unit fittings.
  • Aftertreatment DEF dosing unit supply line.
  • Aftertreatment DEF tank fittings.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 6B

Go to 6B

Guided Step 6B - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Dosing Unit Override Test found under ECM Diagnostic Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Dosing Unit Override Test.

Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063 in Section 11?
YES NO
No Repair

Clean and inspect the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Perform the Aftertreatment DEF Dosing Unit Override Test again after cleaning the dosing valve. If the Dosing Unit Override Test does not operate according to specification, replace the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

Perform the Aftertreatment DEF Dosing Unit Override Test again after replacing the dosing valve. Aftertreatment DEF dosing unit must operate according to the specifications in Procedure 011-063 in Section 11 before moving to the next step.

Go to 7A

Go to 7A

Guided Step 7 - Check for active fault codes.

Guided Step 7A - Perform a stationary regeneration and check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON and start engine.
  • Connect INSITE™ electronic service tool.

Action

Perform a stationary regeneration of the aftertreatment system. Use INSITE™ electronic service tool.

Check for active fault codes upon completion of the stationary regeneration.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1694 active?
YES NO

Troubleshoot Fault Code 1694 and then return to Fault Code 3582.

Appropriate Fault Code Troubleshooting Tree

Go to 7B

Guided Step 7B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes upon completion of the stationary regeneration.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3751 active?
YES NO

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 8 - Check SCR part number.

Guided Step 8A - Verify DEF system repairs.

Conditions

  • Turn keyswitch OFF.

Action

None.

Repairs made to the DEF dosing system at Steps 7A and/or 7B?
YES | NO
No Repair | No Repair

Go to 9A

Go to 8B

Guided Step 8B - SCR part number verification.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Action

Locate the seven digit numeric part number on the aftertreatment SCR catalyst can.

Does the SCR catalyst part number match one in this list? 4329015 , 4329016 , 4329017 , 4329018 , 4329019 , 4329020 , 4329061 , 4329062 , 4329063 , 4329064 , 4329065 , 4329066 , 4329067 , 4329068 , 4329069 , 4329070 , 4329071 , 4329072 , 4329073 , 4329074 , 4329075 , 4329076 , 4329091 , 4329092 , 4329093 , 4329094 , 4329096 , 4329097 , 4329098 , 4329099 , 4329100 , 4329101 , 4329102 , 4329103 , 4329104 , 4329105 , 4329106 , 4329107 , 4329108 , 4329109, 4329110, or 4329111.

YES NO
No Repair

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Follow Appropriate Tech Escalation Process or Contact RAPIDSERVE™ for assistance

Go to 9A

Guided Step 9 - Clear fault codes.

Guided Step 9A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Refer to "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Dec-2014


FAULT CODE 3597 - Aftertreatment Diesel Exhaust Fluid Controller - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
VGT Actuator | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
VGT Actuator | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
VGT Actuator | Refer to Procedure 010-134 | ISX15 CM2250 | 4022250
VGT Actuator | Refer to Procedure 010-134 | GX CM2250 | 4022250
VGT Actuator | Refer to Procedure 010-134 | ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | ISX11.9 CM2250 | 2883445
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2250 | 4022254
ECM Calibration Code | Refer to Procedure 019-032 | ISC8.3 and QSL9 CM2250 | 4022257
ECM Calibration Code | Refer to Procedure 019-032 | ISX15 CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault codes. | Fault Code 3597 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 2636, 2771, and 3232 all active?
STEP 2. | Check the aftertreatment diesel exhaust fluid controller circuit. |
 | STEP 2A. Inspect aftertreatment diesel exhaust fluid controller and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment diesel exhaust fluid controller. | Voltage is within 1-VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine CPL?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment diesel exhaust fluid controller battery voltage supply. | Voltage is within 1-VDC of battery voltage?
STEP 4. | Check the J1939 data link |
 | STEP 4A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 datalink harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 4F. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4G. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4H. Check the fault codes. | Fault Code 3597 is active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3597 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 for Inactive or Intermittent fault code.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2636, 2771, and 3232 all active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid controller circuit.

Guided Step 2A - Inspect aftertreatment diesel exhaust fluid controller and connector pins.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel exhaust fluid controller 53-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the controller or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment diesel exhaust fluid controller.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller 53-pin connector.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment diesel exhaust fluid controller.

  • Measure the voltage between the aftertreatment diesel exhaust fluid controller battery voltage SUPPLY circuit and the aftertreatment diesel exhaust fluid controller battery voltage RETURN circuit at the 53-pin OEM wiring harness connector.

Note: Check the voltage at key-ON, while cranking the engine, and with the engine at idle.

Note: Place a load on the circuit to verify the voltage measurement to complete the testing of the circuit. Connecting a 12-VDC headlight or an equivalent load capable of drawing 10 to 12 ampheres wil be required.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the keyswitch signal voltage to the aftertreatment diesel exhaust fluid controller.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller 53-pin connector.
  • Turn keyswitch ON.

Action

Check the keyswitch signal circuit to the aftertreatment diesel exhaust fluid controller.

  • Measure the voltage between the aftertreatment diesel exhaust fluid controller keyswitch input SIGNAL circuit at the 53-pin connector and block ground.

Note: Check the voltage at key-ON, while cranking the engine, and with the engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES NO
No Repair

Check for an open or short circuit in the aftertreatment diesel exhaust fluid controller keyswitch input SIGNAL circuit.

Check for blown or missing fuses.

Repair or replace the OEM harness.

Go to 2D

Go to 5A

Guided Step 2D - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical System Voltage parameter correct for the engine CPL?
YES NO
No Repair

Configure the electrical system voltage to match the engine CPL using INSITE™ electronic service tool.

Go to 4A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections, and clean the terminals.

Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the aftertreatment diesel exhaust fluid controller battery voltage supply.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller 53-pin connector.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment diesel exhaust fluid controller battery voltage SUPPLY pin of the 53-pin OEM harness connector to engine block ground.

Note: Check the voltage at key-ON, while cranking the engine, and with the engine at idle.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller battery voltage RETURN circuit.

Repair or replace the OEM harness.

Refer to the OEM service manual.

An open circuit has been detected in the aftertreatment diesel exhaust fluid controller battery voltage RETURN circuit.

Check for missing or blown fuses. Troubleshoot all interconnects. Repair or replace the damaged component(s) as necessary.

Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller 53-pin connector.
  • Disconnect the engine harness connector 1 from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

Measure the resistance between the SAE J1939 data link (+) wire at the aftertreatment diesel exhaust fluid controller 53-pin wiring harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector 1.

Measure the resistance between the SAE J1939 data link (-) wire at the aftertreatment diesel exhaust fluid controller 53-pin wiring harness connector and the SAE J1939 data link (-) wire at the ECM engine harness connector 1.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link.

Troubleshoot the engine wiring harness and all interconnects for an open circuit.

Repair or replace the damaged component.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller 53-pin connector.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness connector 1 from the ECM connector.

Action

Check for a short circuit in the J1939 data link harness.

Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector 1 and all other pins in the connector.

Measure the resistance between the SAE J1939 data link (−) wire at the ECM engine harness connector 1 and all other pins in the connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (−) pins.

Use the following procedure for the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the damaged component.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller 53-pin connector.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness connector 1 from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector 1 and ground.

Measure the resistance between the SAE J1939 datal ink (−) wire at the ECM engine harness connector 1 and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the damaged component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding to allow sufficient time for the aftertreatment diesel exhaust fluid controller to completely power down.
  • Disconnect the aftertreatment diesel exhaust fluid controller 53-pin connector
  • Connect all other components, including NOx sensors, ECM, and VGT.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the aftertreatment diesel exhaust fluid controller 53-pin OEM harness connector.

50 to 70 ohms?
YES | NO
No Repair | No Repair

Go to 4H

Go to 4F

Guided Step 4F - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 14-pin OEM connector from the engine harness.

Action

Measure the terminating resistance of the engine harness.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the 14-pin connector of the engine harness.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the OEM harness.

Repair or replace the terminating resistor in the OEM harness.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 4G

Guided Step 4G - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Measure the terminating resistance of the VGT actuator.

  • Measure the resistance between the VGT actuator J1939 data link (+) wire and the VGT actuator J1939 (-) wire at the VGT actuator connector.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the engine harness.

Remove the additional terminating resistance or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Incorrect terminating resistance has been detected in VGT actuator.

Replace the VGT actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4H - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM.
  • Connect the aftertreatment diesel exhaust fluid controller 53-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3597 active?
YES NO

Replace the aftertreatment diesel exhaust fluid controller.

Refer to Procedure 011-057 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number and found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3612 - Aftertreatment Diesel Exhaust Fluid Dosing Unit - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2250 | 4022254
ECM Calibration Code | Refer to Procedure 019-032 | ISC8.3 and ISL9 CM2250 | 4022257
ECM Calibration Code | Refer to Procedure 019-032 | ISX15 CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1117, 3577, 3578, or 3579 active?
STEP 2. | Check main battery disconnect switch operation. |
 | STEP 2A. Check main battery disconnect switch (if equipped). | Battery disconnect switch and shut down sequence ok?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for diesel exhaust fluid return valve fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117, 3577, 3578, or 3579 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check main battery disconnect switch operation.

Guided Step 2A - Check main battery disconnect switch (if equipped).

Conditions

  • Turn keyswitch OFF.

Action

Check the main battery disconnect switch for the following:

  • If the vehicle is equipped with an automatic main battery disconnect the switch, make sure it has a built-in delay device to prevent power-down of the dosing unit until the purge sequence is complete.
  • Make sure that the operator is shutting down the engine using the keyswitch and not the main battery disconnect.
  • Make sure the dosing unit remains powered for at least 30 seconds after key OFF.

Battery disconnect switch and shutdown sequence ok?
YES NO
No Repair

Repair the wiring so the diesel exhaust fluid dosing unit remains powered for at least 30 seconds after key OFF.

Consult with the OEM if necessary.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3712 - Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3712 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active SCR related fault codes in the ECM.

Fault Code 3712 active?
YES NO

This is an information only fault code that will only become active if other SCR related fault codes are active in the ECM for an extended amount of time.

Troubleshoot all other active SCR related fault codes.

This fault code will become inactive when all other active SCR related fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jul-2012


FAULT CODE 3714 - Engine Protection Torque Derate - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | ISB6.7 CM2250 | 4022254
ECM Calibration Code | Refer to Procedure 019-032 | ISC8.3 and ISL9 CM2250 | 4022257
ECM Calibration Code | Refer to Procedure 019-032 | ISX15 CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3714 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 3714

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes in the ECM.

Fault Code 3714 active?
YES NO

This is an information-only fault code that will only become active if other critical engine performance fault codes are active in the ECM for an extended amount of time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jul-2012


FAULT CODE 3715 - Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISX15 CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3715 active?
 | STEP 1B. Check for active fault codes. | Fault codes related to the fuel system active or inactive counts?
STEP 2. | Check the engine rpm. |
 | STEP 2A. Check for active fault codes. | Fault codes related to the crankshaft position sensor or camshaft position sensor active or inactive counts?
 | STEP 2B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 2C. Check for an alternate fuel source. | Alternate fuel source?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3715 active?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the fuel system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the fuel system active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the engine rpm.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the crankshaft position sensor or camshaft position sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the crankshaft position sensor or camshaft position sensor active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2B

Guided Step 2B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is operating.

Action

Check the engine rpm with INSITE™ electronic service tool.

Note: Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft position sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 2C

Fault Codes 689 and 778

Guided Step 2C - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check the oil contamination in the intake piping
  • Malfunctioning Ether Start
  • Malfunctioning cold weather atarting aids
  • Malfunctioning aftermarket devices.

Alternate fuel source?
YES NO

Repair or replace the damaged component.

Continue to investigate the cause of the high or surging idle. Refer to the engine performance troubleshooting tree.

Go to 3A

Appropriate engine performance troubleshooting tree.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Dec-2010


FAULT CODE 3716 - Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | ISX15 CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
ECM Calibration Code | Refer to Procedure 019-032 | ISX11.9 CM2250 | 2883445

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3716 active?
 | STEP 1B. Check for active fault codes. | Active or inactive counts of fault codes related to the fuel system?
STEP 2. | Check the engine rpm. |
 | STEP 2A. Check for active fault codes. | Fault codes related to the crankshaft position sensor or camshaft position sensor active or inactive counts?
 | STEP 2B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 2C. Check the accessory load. | Damaged or additional acessories found on the engine?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3716 active?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the fuel system.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of fault codes related to the fuel system?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the engine rpm.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the crankshaft position sensor or camshaft position sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the crankshaft position sensor or camshaft position sensor active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2B

Guided Step 2B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine operating.

Action

Check the engine rpm with INSITE™ electronic service tool.

Note: Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 2C

Fault Codes 689 and 778

Guided Step 2C - Check the accessory load.

Conditions

  • Turn keyswitch OFF.

Action

Check the accessory load on the engine.

  • Inspect the engine for damaged or marginal accessories such as alternators, refrigerant pumps, hydraulic pumps, air compressors, etc.
  • Inspect for additional engine accessories that could increase the load on the engine.

Damaged or additional accessories found on the engine?
YES NO

Repair or replace the damaged component or remove the additional accessory load.

Continue to investigate the cause of the low or surging idle. Refer to the engine performance troubleshooting tree.

Go to 3A

Appropriate engine performance troubleshooting tree

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jul-2012


FAULT CODE 3726 - Aftertreatment Intake NOx - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3726 active?
 | STEP 1B. Check for active fault codes. | Fault codes related to the aftertreatment diesel exhaust fluid controller, aftertreatment diesel exhaust fluid dosing unit, or aftertreatment diesel exhaust fluid dosing valve active?
 | STEP 1C. Check for active fault codes. | Fault Codes 1885, 3228, 3232, 3649, 3682, 3725, or 3748 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3726 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment diesel exhaust fluid dosing system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment diesel exhaust fluid controller, aftertreatment diesel exhaust fluid dosing unit, or aftertreatment diesel exhaust fluid dosing valve active?

YES | NO
No Repair | No Repair

Go to Appropriate Fault Code Troubleshooting Tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment intake NOx sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1885, 3228, 3232, 3649, 3682, 3725, or 3748 active?
YES NO
No Repair

Investigate the cause of engine out NOx emissions above normal.

Go to Appropriate Fault Code Troubleshooting Tree

Go to the Engine Performance TT Tree

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jul-2012


FAULT CODE 3736 - Aftertreatment Diesel Exhaust Fluid Controller - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Controller | Refer to Procedure 011-057 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3597 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid controller. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3597 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 3736 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 3736 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3597 active?
YES | NO
No Repair | No Repair

Fault Code 3597 troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid controller.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 53-pin connector from the controller.

Action

Inspect the aftertreatment diesel exhaust fluid controller harness and 53-Pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid controller harness 53-pin connector from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3597 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid controller harness 53-pin connector to the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3736 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3736 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the aftertreatment diesel exhaust fluid controller. Refer to Procedure 011-057 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jul-2012


FAULT CODE 3748 - Aftertreatment Intake NOx Sensor - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3748 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 1885, 3232, 3649, or 3682 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3748 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1885, 3232, 3649, or 3682 active?
YES NO
No Repair

Verify the aftertreatment intake NOx sensor is present and has been installed properly.

If the aftertreatment intake NOx sensor is present and installed properly, a damaged aftertreatment intake NOx sensor is a possible cause.

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-May-2012


FAULT CODE 3749 - Aftertreatment Outlet NOx Sensor - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | GX CM2250 | 4022250
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3749 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 1887, 2771, 3583, or 3681 active?
 | STEP 1C. Verify proper installation of the aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor properly installed?
STEP 2. | Check the aftertreatment diesel exhaust fluid decomposition tube. |
 | STEP 2A. Check the decomposition tube for crystallization. | Crystallization buildup in the decomposition tube?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3749 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1887, 2771, 3583, or 3681 active?
YES | NO
No Repair | No Repair

Go to Appropriate Fault Code Troubleshooting Tree

Go to 1C

Guided Step 1C - Verify proper installation of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.

Action

Verify proper installation of the aftertreatment outlet NOx sensor.

  • Inspect the aftertreatment outlet NOx sensor for proper installation. Refer to Procedure 019-451 in the Associated Procedures Table.

Aftertreatment outlet NOx sensor properly installed?
YES NO
No Repair

Properly install the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid decomposition tube.

Guided Step 2A - Check the decomposition tube for crystallization.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid decomposition tube. Refer to Procedure 011-062 in the Associated Procedures Table.

Action

Check for diesel exhaust fluid crystallization.

  • Inspect the decomposition tube for crystallization. Refer to Procedure 011-062 in the Associated Procedures Table.

Crystallization buildup in the decomposition tube?
YES NO

Remove the crystallization buildup.

Refer to Procedure 011-062 in the Associated Procedures Table.

A damaged aftertreatment outlet NOx sensor has been detected.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibraton Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete.

Go to 1A

Last Modified: 18-Jul-2012


FAULT CODE 3751 - Aftertreatment SCR Catalyst System - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3751 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3543 or 3582 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3751 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3543 or 3582 active?
YES NO

This fault code is only used to assist in troubleshooting Fault Code 3543 and/or 3582.

Use Fault Code 3543 or 3582 troubleshooting tree for repair instructions.

This fault code is only used to assist in troubleshooting Fault Code 3543 and/or 3582. Do not replace the SCR catalyst.

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Aug-2012


FAULT CODE 3755 - Aftertreatment Diesel Exhaust Fluid Dosing Valve - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration Code | Refer to Procedure 019-032 | GX CM2250 | 4022250

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3755 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 3543 or 3582 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3755 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3543 or 3582 active?
YES NO

This fault code is only used to assist in troubleshooting Fault Codes 3543 and/or 3582.

Go to Fault Code 3543 or 3582 troubleshooting tree for repair instructions.

 No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jul-2012


FAULT CODE 3825 - Westport™ Data Share, Message 8 Fault (Stale Message)

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) Calibration | Refer to Procedure 019-032 | GX CM2250 | 4022250

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3825 active?
 | STEP 1B. Check for additional active fault codes. | Additional active fault codes related to the data link?
STEP 2. | Flash and replace the ECM and Westport™ CM850 engine fuel system (EFS) controller. |
 | STEP 2A. Flash the ECM and Westport™ CM850 EFS controller. | Fault Code 3825 active after software update?
 | STEP 2B. Replace the Westport™ CM850 EFS controller. | Fault Code 3825 active after controller replacement?
 | STEP 2C. Replace the Cummins® ECM. | Fault Code 3825 active after ECM replacement?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3825 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for additional active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for data link fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Additional active fault codes related to the data link?
YES NO

Troubleshoot additional active fault codes first.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Flash and replace the ECM and Westport™ CM850 engine fuel system (EFS) controller.

Guided Step 2A - Flash the ECM and Westport™ CM850 EFS controller.

Conditions

  • Turn keyswitch OFF.

Action

Flash the ECM and Westport™ CM850 EFS controller.

  • Flash the ECM and the Westport™ CM850 EFS controller with the latest calibration, downloaded from the Westport™ HD service website.

Fault Code 3825 active after software update?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Replace the Westport™ CM850 EFS controller.

Conditions

  • Turn keyswitch OFF.

Action

Replace the Westport™ CM850 EFS controller.

  • Refer to the OEM service manual.

Fault Code 3825 active after controller replacement?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Replace the Cummins® ECM.

Conditions

  • Turn keyswitch OFF.

Action

Replace the Cummins® CM2250 controller.

  • Refer to the OEM service manual.

Fault Code 3825 active after ECM replacement?
YES | NO
No Repair | No Repair

Contact Westport™ HD service at 1-888-WPT-HPDI for further troubleshooting steps.

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jul-2012


FAULT CODE 3838 - EEC3 Message Fault - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GX CM2250 | 4022250

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3838 active?
STEP 2. | Check the J1939 data link. |
 | STEP 2A. Inspect the Westport™ converter harness, Westport™ modified base engine harness, and connectors. | Dirty or damaged pins?
STEP 3. | Check the Westport™ converter, Westport™ modified base harness, Westport™ engine, and OEM harness for continuity. |
 | STEP 3A. Check the Westport™ converter harness. | Resistance between pin J1-08 and pin C106-25 and between pin J1-18 and pin C106-26 less than 10 ohms?
 | STEP 3B. Check the Westport™ modified engine harness. | Resistance between pin C104-25 and pin C7-A and between pin C104-26 and pin C7-B less than 10 ohms?
 | STEP 3C. Check the Westport™ engine harness. | Resistance between pin C16-A and pin C7-20 and between pin C16-B and pin C7-21 less than 10 ohms?
 | STEP 3D. Check the system/chassis harness. | Resistance between pin J1-08 and pin C8-20 and between pin J1-06 and pin C8-21 less than 10 ohms)?
STEP 4. | Check for a short circuit to high source in Westport™ modified base engine harness. |
 | STEP 4A. Check the Westport™ modified base engine harness. | Resistance between pin C16-A and pin C16-B greater than 50 ohms?
STEP 5. | Flash software and replace the ECM and Westport™ CM850 engine fuel system controller. |
 | STEP 5A. Flash and replace the ECM and Westport™ CM850 engine fuel system (EFS) controller. | Fault Code 3838 active after upgrade?
 | STEP 5B. Replace the Westport™ CM850 EFS controller. | Fault Code 3838 active after controller replacement?
 | STEP 5C. Replace the Cummins® ECM. | Fault Code 3838 inactive after ECM replacement?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3838 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the J1939 data link.

Guided Step 2A - Inspect the Westport™ converter harness, Westport™ modified engine harness, and connectors.

Conditions

  • Turn keyswitch OFF
  • Disconnect the Westport™ converter harness and the Westport™ modified base engine harness.

Action

Inspect the harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the Westport™ converter, Westport™ modified base harness, Westport™ engine and OEM harness continuity.

Guided Step 3A - Check the Westport™ converter harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the Westport™ converter harness from the Cummins® CM2250 controller and the modified base engine harness bulkhead connector.

Action

Check the converter harness continuity.

  • Test continuity between pin J1-08 on the Cummins® CM2250 connector and pin 25 on the modified base engine harness bulkhead connector.
  • Test continuity between pin J1-18 on the Cummins® CM2250 connector and pin 26 on the modified base engine harness bulkhead connector.

Resistance between pin J1-08 and pin C106-25 and between pin J1-18 and pin C106-26 less than 10 ohms?
YES NO
No Repair

Replace the Westport™ converter harness.

Go to 3B

Go to 6A

Guided Step 3B - Check the Westport™ modified engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the modified base engine harness from the modified base engine harness bulkhead connector and Cummins® Engine Network (CEN) connector.

Action

Check the modified base engine harness continuity.

  • Test continuity between pin A on the CEN connector and pin 25 on the modified base engine harness bulkhead connector.
  • Test continuity between pin B on the CEN connector and pin 26 on the modified base engine harness bulkhead connector.

Resistance between pin C104-25 and pin C7-A and between pin C104-26 and pin C7-B less than 10 ohms?
YES NO
No Repair

Replace the Westport™ modified engine harness.

Go to 3C

Go to 6A

Guided Step 3C - Check the Westport™ engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the Westport™ engine harness bulkhead connector and the CEN connector.

Action

Check the Westport™ engine harness continuity.

  • Test continuity between pin 20 on the engine harness bulkhead connector and pin A on the CEN connector.
  • Test continuity between pin 21 on the engine harness bulkhead connector and pin B on the CEN connector.

Resistance between pin C16-A and pin C7-20 and between pin C16-B and pin C7-21 less than 10 ohms?
YES NO
No Repair

Replace the Westport™ engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check the system/chassis harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the system/chassis harness from the Cummins® CM850 EFS controller and the system/chassis bulkhead connector.

Action

Check the system/chassis harness continuity.

  • Test continuity between pin J1-08 on the Cummins® CM850 EFS connector and pin 20 on the system/chassis connector.
  • Test continuity between pin J1-06 on the Cummins® CM850 EFS connector and pin 21 on the system/chassis connector.

Resistance between pin J1-08 and pin C8-20 and between pin J1-06 and pin C8-21 less than 10 ohms?
YES NO
No Repair

Replace the system/chassis harness. Refer to the OEM service manual.

Go to 4A

Go to 6A

Guided Step 4A - Check for a short circuit to high source in the Westport™ modified base engine harness.

Guided Step 4A - Check the Westport™ modified base engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the modified base engine harness from the Westport™ converter harness bulkhead and the CEN connector.

Action

Check for a pin-to-pin short circuit in the C16 connector.

  • Measure the resistance between pin A and pin B in the CEN connector C16.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Resistance between pin C16-A and pin C16-B greater than 50 ohms?
YES NO
No Repair

Replace the Westport™ modified base engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Flash software and replace the ECM and Westport™ CM850 EFS controller.

Guided Step 5A - Flash the ECM and the Westport™ CM850 EFS and HPGS controllers.

Conditions

  • Turn keyswitch OFF.

Action

Flash the ECM and Westport™ CM850 controllers.

  • Flash the ECM and the Westport™ CM850 EFS and HPGS controllers with the latest calibration suite.

Fault Code 3838 active after software update?
YES | NO
No Repair | No Repair

Go to 5B

Go to 6A

Guided Step 5B - Replace the Westport™ CM850 EFS controller.

Conditions

  • Turn keyswitch OFF.

Action

Replace and flash the Westport™ CM850 EFS controller.

  • Refer to the OEM service manual.

Fault Code 3838 active after controller replacement?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Replace the Cummins® ECM.

Conditions

  • Turn keyswitch OFF.

Action

Replace and flash the Cummins® CM2250 controller.

  • Refer to the OEM service manual.

Fault Code 3838 active after ECM replacement?
YES | NO
No Repair | No Repair

Contact Westport™ HD service at 1-888-WPT-HPDI for further troubleshooting steps.

Go to 6A

Guided Step 6 - Clear fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jul-2012


INDEX
157-fc111.htm

00-t05-111.htm

157-fc115.htm

00-t05-115.htm

157-fc122.htm

00-t05-122.htm

157-fc123.htm

00-t05-123.htm

157-fc124.htm

148-t05-124.htm

157-fc125.htm

148-t05-125.htm

157-fc131.htm

00-t05-131.htm

157-fc132.htm

00-t05-132.htm

157-fc133.htm

00-t05-133.htm

157-fc134.htm

00-t05-134.htm

157-fc135.htm

00-t05-135.htm

157-fc141.htm

00-t05-141.htm

157-fc143.htm

00-t05-143.htm

157-fc144.htm

00-t05-144.htm

157-fc145.htm

00-t05-145.htm

157-fc146.htm

00-t05-146.htm

157-fc151.htm

00-t05-151.htm

157-fc153.htm

00-t05-153.htm

157-fc154.htm

00-t05-154.htm

157-fc155.htm

00-t05-155.htm

157-fc187.htm

148-t05-187.htm

157-fc195.htm

148-t05-195.htm

157-fc196.htm

148-t05-196.htm

157-fc197.htm

148-t05-197.htm

157-fc212.htm

00-t05-212.htm

157-fc213.htm

00-t05-213.htm

157-fc214.htm

00-t05-214.htm

157-fc221x.htm

148-t05-221x.htm

157-fc222x.htm

148-t05-222x.htm

157-fc227.htm

148-t05-227.htm

157-fc234.htm

00-t05-234.htm

157-fc238.htm

00-t05-238.htm

157-fc239.htm

00-t05-239.htm

157-fc241.htm

00-t05-241.htm

157-fc242.htm

00-t05-242.htm

157-fc245.htm

00-t05-245.htm

157-fc249.htm

00-t05-249.htm

157-fc256.htm

00-t05-256.htm

157-fc285.htm

00-t05-285.htm

157-fc286.htm

00-t05-286.htm

157-fc288.htm

00-t05-288.htm

157-fc295x.htm

148-t05-295x.htm

157-fc319.htm

00-t05-319.htm

157-fc334.htm

00-t05-334.htm

157-fc338.htm

00-t05-338.htm

157-fc339.htm

00-t05-339.htm

157-fc343.htm

00-t05-343.htm

157-fc346hd.htm

148-t05-346hd.htm

157-fc352.htm

148-t05-352.htm

157-fc386.htm

148-t05-386.htm

157-fc415.htm

00-t05-415.htm

157-fc421.htm

00-t05-421.htm

157-fc425.htm

00-t05-425.htm

157-fc427.htm

00-t05-427.htm

157-fc435sensor.htm

148-t05-435sensor.htm

157-fc436.htm

157-t05-436.htm

157-fc441.htm

00-t05-441.htm

157-fc442.htm

00-t05-442.htm

157-fc477.htm

00-t05-477.htm

157-fc478.htm

00-t05-478.htm

157-fc555.htm

00-t05-555.htm

157-fc556.htm

00-t05-556.htm

157-fc584.htm

00-t05-584.htm

157-fc585.htm

00-t05-585.htm

157-fc595.htm

148-t05-595.htm

157-fc596.htm

00-t05-596.htm

157-fc597.htm

00-t05-597.htm

157-fc598.htm

00-t05-598.htm

157-fc629.htm

148-t05-629.htm

157-fc649.htm

00-t05-649.htm

157-fc686.htm

00-t05-686.htm

157-fc687.htm

00-t05-687.htm

157-fc689.htm

00-t05-689.htm

157-fc691.htm

00-t05-691.htm

157-fc692.htm

00-t05-692.htm

157-fc693.htm

00-t05-693.htm

157-fc697.htm

00-t05-697.htm

157-fc698.htm

00-t05-698.htm

157-fc699.htm

00-t05-699.htm

157-fc731.htm

148-t05-731.htm

157-fc778.htm

00-t05-778.htm

157-fc784.htm

00-t05-784.htm

157-fc1117.htm

00-t05-1117.htm

157-fc1239.htm

00-t05-1239.htm

157-fc1241.htm

00-t05-1241.htm

157-fc1242.htm

00-t05-1242.htm

157-fc1515.htm

00-t05-1515.htm

157-fc1664.htm

00-t05-1664.htm

157-fc1668.htm

157-fc1668-2wire.htm

157-t05-1668-2wire.htm

157-fc1668-3wire.htm

157-t05-1668-3wire.htm

157-fc1669.htm

157-fc1669-2wire.htm

157-t05-1669-2wire.htm

157-fc1669-3wire.htm

157-t05-1669-3wire.htm

157-fc1673.htm

157-t05-1673.htm

157-fc1677.htm

157-t05-1677.htm

157-fc1678.htm

157-t05-1678.htm

157-fc1679.htm

157-t05-1679.htm

157-fc1681.htm

157-t05-1681.htm

157-fc1682.htm

157-t05-1682.htm

157-fc1683.htm

157-t05-1683.htm

157-fc1684.htm

157-t05-1684.htm

157-fc1688.htm

157-t05-1688.htm

157-fc1691.htm

148-t05-1691x.htm

157-fc1694.htm

157-t05-1694.htm

157-fc1695.htm

148-t05-1695.htm

157-fc1696.htm

148-t05-1696.htm

157-fc1712.htm

157-t05-1712.htm

157-fc1713.htm

157-t05-1713.htm

157-fc1843.htm

00-t05-1843.htm

157-fc1844.htm

00-t05-1844.htm

157-fc1866.htm

00-t05-1866.htm

157-fc1867.htm

148-t05-1867.htm

157-fc1879.htm

00-t05-1879.htm

157-fc1881.htm

00-t05-1881.htm

157-fc1883.htm

00-t05-1883.htm

157-fc1885.htm

00-t05-1885.htm

157-fc1887.htm

157-t05-1887.htm

157-fc1893.htm

157-t05-1893.htm

157-fc1895.htm

157-t05-1895.htm

157-fc1896.htm

157-t05-1896.htm

157-fc1898.htm

148-t05-1898.htm

157-fc1921.htm

00-t05-1921.htm

157-fc1922.htm

00-t05-1922.htm

157-fc1923.htm

148-t05-1923.htm

157-fc1924.htm

148-t05-1924.htm

157-fc1925.htm

157-t05-1925.htm

157-fc1926.htm

157-t05-1926.htm

157-fc1927.htm

00-t05-1927.htm

157-fc1928.htm

00-t05-1928.htm

157-fc1932.htm

157-t05-1932.htm

157-fc1935.htm

157-t05-1935.htm

157-fc1936.htm

157-t05-1936.htm

157-fc1937.htm

157-t05-1937.htm

157-fc1938.htm

00-t05-1938.htm

157-fc1942.htm

00-t05-1942.htm

157-fc1943.htm

00-t05-1943.htm

157-fc1961.htm

157-t05-1961.htm

157-fc1963.htm

157-t05-1963.htm

157-fc1977.htm

00-t05-1977.htm

157-fc1981.htm

148-t05-1981.htm

157-fc1993.htm

00-t05-1993.htm

157-fc2182hd.htm

148-t05-2182hd.htm

157-fc2183hd.htm

148-t05-2183hd.htm

157-fc2185.htm

00-t05-2185.htm

157-fc2186.htm

00-t05-2186.htm

157-fc2272.htm

157-t05-2272.htm

157-fc2273.htm

00-t05-2273.htm

157-fc2274.htm

00-t05-2274.htm

157-fc2288.htm

00-t05-2288.htm

157-fc2321.htm

00-t05-2321.htm

157-fc2322.htm

00-t05-2322.htm

157-fc2346.htm

00-t05-2346.htm

157-fc2349.htm

157-t05-2349.htm

157-fc2351.htm

157-t05-2351.htm

157-fc2357.htm

157-t05-2357.htm

157-fc2361.htm

157-t05-2361.htm

157-fc2363hd.htm

148-t05-2363hd.htm

157-fc2367hd.htm

148-t05-2367hd.htm

157-fc2373.htm

00-t05-2373.htm

157-fc2374.htm

00-t05-2374.htm

157-fc2375.htm

00-t05-2375.htm

157-fc2376.htm

00-t05-2376.htm

157-fc2377.htm

00-t05-2377.htm

157-fc2387.htm

148-t05-2387.htm

157-fc2398.htm

148-t05-2398.htm

157-fc2448.htm

00-t05-2448.htm

157-fc2449.htm

00-t05-2449.htm

157-fc2468.htm

00-t05-2468.htm

157-fc2554.htm

00-t05-2554.htm

157-fc2634.htm

148-t05-2634.htm

157-fc2635.htm

00-t05-2635.htm

157-fc2636.htm

145-t05-2636.htm

157-fc2637.htm

148-t05-2637bcl.htm

157-fc2638.htm

148-t05-2638bcl.htm

157-fc2639.htm

00-t05-2639.htm

157-fc2646.htm

148-t05-2646.htm

157-fc2659.htm

148-t05-2659.htm

157-fc2732.htm

157-t05-2732.htm

157-fc2733.htm

157-t05-2733.htm

157-fc2738.htm

00-t05-2738.htm

157-fc2739.htm

00-t05-2739.htm

157-fc2754.htm

148-t05-2754.htm

157-fc2764.htm

00-t05-2764.htm

157-fc2771.htm

157-t05-2771.htm

157-fc2777.htm

00-t05-2777.htm

157-fc2789.htm

148-t05-2789.htm

157-fc2878.htm

157-t05-2878.htm

157-fc2879isx.htm

157-t05-2879isx.htm

157-fc2881.htm

157-t05-2881.htm

157-fc2961.htm

148-t05-2961.htm

157-fc2962.htm

148-t05-2962.htm

157-fc2963.htm

00-t05-2963.htm

157-fc2964.htm

00-t05-2964.htm

157-fc2973.htm

148-t05-2973.htm

157-fc2976.htm

157-t05-2976.htm

157-fc3133.htm

00-t05-3133.htm

157-fc3134.htm

00-t05-3134.htm

157-fc3135.htm

157-t05-3135.htm

157-fc3139.htm

00-t05-3139.htm

157-fc3141.htm

00-t05-3141.htm

157-fc3142.htm

157-t05-3142.htm

157-fc3143.htm

157-t05-3143.htm

157-fc3144.htm

157-t05-3144.htm

157-fc3145.htm

157-t05-3145.htm

157-fc3146.htm

157-t05-3146.htm

157-fc3147.htm

157-t05-3147.htm

157-fc3148.htm

157-t05-3148.htm

157-fc3149.htm

157-t05-3149.htm

157-fc3151.htm

157-t05-3151.htm

157-fc3164.htm

00-t05-3164.htm

157-fc3165.htm

00-t05-3165.htm

157-fc3167.htm

00-t05-3167.htm

157-fc3168.htm

148-t05-3168.htm

157-fc3186.htm

00-t05-3186.htm

157-fc3213.htm

00-t05-3213.htm

157-fc3228.htm

157-t05-3228.htm

157-fc3229.htm

157-t05-3229.htm

157-fc3231.htm

00-t05-3231.htm

157-fc3232.htm

157-t05-3232.htm

157-fc3235.htm

00-t05-3235.htm

157-fc3236.htm

157-t05-3236.htm

157-fc3237.htm

157-t05-3237.htm

157-fc3239.htm

157-t05-3239.htm

157-fc3242.htm

00-t05-3242.htm

157-fc3243.htm

148-t05-3243.htm

157-fc3245.htm

148-t05-3245.htm

157-fc3251.htm

148-t05-3251.htm

157-fc3253.htm

148-t05-3253.htm

157-fc3254.htm

148-t05-3254.htm

157-fc3255.htm

148-t05-3255.htm

157-fc3256.htm

148-t05-3256.htm

157-fc3258.htm

157-t05-3258.htm

157-fc3261.htm

157-t05-3261.htm

157-fc3311.htm

148-t05-3311.htm

157-fc3312.htm

148-t05-3312.htm

157-fc3313.htm

148-t05-3313.htm

157-fc3314.htm

148-t05-3314.htm

157-fc3315.htm

148-t05-3315.htm

157-fc3316.htm

148-t05-3316.htm

157-fc3317.htm

148-t05-3317.htm

157-fc3318.htm

148-t05-3318.htm

157-fc3319.htm

148-t05-3319.htm

157-fc3321.htm

148-t05-3321.htm

157-fc3322.htm

148-t05-3322.htm

157-fc3326.htm

00-t05-3326.htm

157-fc3328.htm

00-t05-3328.htm

157-fc3342.htm

148-t05-3342.htm

157-fc3343.htm

148-t05-3343.htm

157-fc3348.htm

148-t05-3348.htm

157-fc3361.htm

148-t05-3361.htm

157-fc3366.htm

00-t05-3366.htm

157-fc3374.htm

00-t05-3374.htm

157-fc3375.htm

148-t05-3375.htm

157-fc3376.htm

148-t05-3376.htm

157-fc3382.htm

148-t05-3382.htm

157-fc3383.htm

148-t05-3383.htm

157-fc3385.htm

148-t05-3385.htm

157-fc3389.htm

148-t05-3389.htm

157-fc3418.htm

00-t05-3418.htm

157-fc3422.htm

157-t05-3422.htm

157-fc3425.htm

157-t05-3425.htm

157-fc3426.htm

157-t05-3426.htm

157-fc3429.htm

157-t05-3429.htm

157-fc3488.htm

00-t05-3488.htm

157-fc3492.htm

00-t05-3492.htm

157-fc3495.htm

00-t05-3495.htm

157-fc3497.htm

00-t05-3497.htm

157-fc3498.htm

00-t05-3498.htm

157-fc3525.htm

00-t05-3525.htm

157-fc3526.htm

00-t05-3526.htm

157-fc3527.htm

00-t05-3527.htm

157-fc3528.htm

00-t05-3528.htm

157-fc3531.htm

00-t05-3531.htm

157-fc3532.htm

00-t05-3532.htm

157-fc3535.htm

00-t05-3535.htm

157-fc3543.htm

157-t05-3543.htm

157-fc3545.htm

00-t05-fc3545.htm

157-fc3547.htm

157-t05-3547.htm

157-fc3557.htm

157-t05-3557.htm

157-fc3558.htm

00-t05-3558.htm

157-fc3559.htm

00-t05-3559.htm

157-fc3561.htm

00-t05-3561.htm

157-fc3562.htm

00-t05-3562.htm

157-fc3563.htm

00-t05-3563.htm

157-fc3564.htm

00-t05-3564.htm

157-fc3565.htm

00-t05-3565.htm

157-fc3566.htm

00-t05-3566.htm

157-fc3567.htm

00-t05-3567.htm

157-fc3568.htm

00-t05-3568.htm

157-fc3569.htm

157-t05-3569.htm

157-fc3571.htm

00-t05-3571.htm

157-fc3572.htm

00-t05-3572.htm

157-fc3574.htm

00-t05-3574.htm

157-fc3575.htm

00-t05-3575.htm

157-fc3576.htm

157-t05-3576.htm

157-fc3577.htm

00-t05-3577.htm

157-fc3578.htm

00-t05-3578.htm

157-fc3579.htm

00-t05-3579.htm

157-fc3582.htm

157-t05-3582.htm

157-fc3583.htm

00-t05-3583.htm

157-fc3596.htm

00-t05-3596.htm

157-fc3597.htm

157-t05-3597.htm

157-fc3598.htm

00-t05-3598.htm

157-fc3612.htm

157-t05-3612.htm

157-fc3616.htm

00-t05-3616.htm

157-fc3641.htm

00-t05-3641.htm

157-fc3648.htm

00-t05-3648.htm

157-fc3649.htm

00-t05-3649.htm

157-fc3651.htm

00-t05-3651.htm

157-fc3679.htm

00-t05-3679.htm

157-fc3681.htm

00-t05-3681.htm

157-fc3682.htm

00-t05-3682.htm

157-fc3697.htm

00-t05-3697.htm

157-fc3712.htm

157-t05-3712.htm

157-fc3713.htm

00-t05-3713.htm

157-fc3714.htm

157-t05-3714.htm

157-fc3715.htm

157-t05-3715.htm

157-fc3716.htm

157-t05-3716.htm

157-fc3717.htm

00-t05-3717.htm

157-fc3718.htm

00-t05-3718.htm

157-fc3724.htm

00-t05-3724.htm

157-fc3725.htm

00-t05-3725.htm

157-fc3726.htm

157-t05-3726.htm

157-fc3733.htm

00-t05-3733.htm

157-fc3734.htm

00-t05-3734.htm

157-fc3736.htm

157-t05-3736.htm

157-fc3748.htm

157-t05-3748.htm

157-fc3749.htm

157-t05-3749.htm

157-fc3751.htm

157-t05-3751.htm

157-fc3753.htm

148-t05-3753.htm

157-fc3755.htm

157-t05-3755.htm

157-fc3825.htm

157-t05-3825.htm

157-fc3838.htm

157-t05-3838.htm

157-fc4157.htm

00-t05-4157.htm

157-fc4167.htm

145-t05-4167.htm

157-fc4431.htm

145-t05-4431.htm

157-fc5383.htm

148-t05-5383.htm