QSL9 G CM558/CM2358

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Magnetic Crankshaft Speed/Position Lost One or Two Signals - Abnormal Rate of Change

FAULT CODE 121

Engine Magnetic Crankshaft Speed/Position Lost One or Two Signals - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10 LAMP: Yellow SRT: | Engine Magnetic Crankshaft Speed/Position Lost One or Two Signals - Abnormal Rate of Change. Invalid engine speed signal detected on the engine speed sensor signal pins at the ECM connector. | Engine is shut down and will not start.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor monitors the engine speed, then passes this information to the electronic control module (ECM) through the engine harness. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Component Location

The engine speed sensor is located on the flywheel housing on the left side of the engine.

Shop Talk

The engine speed sensor is a magnetic sensor that senses the ring gear teeth on the flywheel to determine engine speed.

Refer to Troubleshooting Fault Code 121.

Last Modified: 21-May-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the engine oil pressure sensor pin at the ECM. | No engine protection for engine oil rifle pressure 1.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Component Location

The engine oil pressure sensor is located on the left side of the block, below the ignition control module.

Shop Talk

  • Does the fault code occur only in cold weather? If so, allow the lubricating oil to warm up and see if the fault code becomes inactive.
Refer to Troubleshooting Fault Code 135.

Last Modified: 21-May-2010


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the engine oil pressure sensor pin at the ECM. | No engine protection for engine oil rifle pressure 1.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The lubricating oil pressure value is used by the ECM for the engine protection system. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Component Location

The engine oil pressure sensor is located on the left side of the block, below the ignition control module.

Shop Talk

  • Does the fault code occur only in cold weather? If so, allow the lubricating oil to warm up and see if the fault code becomes inactive.
Refer to Troubleshooting Fault Code 141.

Last Modified: 21-May-2010


Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 142

Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 142 PID: P100 SPN: 100 FMI: 16 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure above the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Component Location

The engine oil pressure sensor is located on the left side of the block, below the ignition control module.

Shop Talk

Does the fault code occur only in cold weather? If so, allow the lubricating oil to warm up and see if the fault code becomes inactive.

Refer to Troubleshooting Fault Code 142.

Last Modified: 21-May-2010


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure below the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil pressure sensor is located on the left side of the block, below the ignition control module (ICM).

Shop Talk

Use INSITE™ electronic service tool to verify the engine speed at which the fault occurs. If the engine is being operated at a speed too low, the oil pressure can drop below the engine protection limits.

Possible causes of this fault code include:

  • Low oil level
  • Low operation speeds
  • Oil dilution
  • Oil filter needs replaced.
Refer to Troubleshooting Fault Code 143.

Last Modified: 21-May-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No engine protection for coolant temperature 1.
Engine Coolant Temperature Sensor 1 Circuit

Circuit Description

The electronic control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the left side of the block, above the ignition control module (ICM). Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the specifications on the wiring diagram if the sensor is functioning properly.
  • This fault code can log in extremely cold weather.
Refer to Troubleshooting Fault Code 144.

Last Modified: 27-May-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No engine protection for engine coolant temperature 1.
Engine Coolant Temperature Sensor 1 Circuit

Circuit Description

The electronic control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the left side of the block, above the ignition control module (ICM). Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the specifications on the wiring diagram if the sensor is functioning properly.
Refer to Troubleshooting Fault Code 145.

Last Modified: 21-May-2010


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High coolant temperature warning. | Progressive power derate increasing in severity from time of alert.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the left side of the block, above the ignition control module (ICM). Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the specifications on the wiring diagram if the sensor is functioning properly.
Refer to Troubleshooting Fault Code 146.

Last Modified: 21-May-2010


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. High coolant temperature critical. | Engine is shut down.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the left side of the block, above the ignition control module (ICM). Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the specifications on the wiring diagram if the sensor is functioning properly.
Refer to Troubleshooting Fault Code 151.

Last Modified: 21-May-2010


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold air temperature sensor pin at the ECM. | Possible reduced engine performance.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with pressure). Use the following procedure for a detailed component location view of each sensor. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the wiring diagram sensor specification if the sensor is functioning properly.
Refer to Troubleshooting Fault Code 153.

Last Modified: 21-May-2010


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced engine performance.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with pressure). Use the following procedure for a detailed component location view of each sensor. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature.
  • See sensor specifications on the wiring diagram.
Refer to Troubleshooting Fault Code 154.

Last Modified: 21-May-2010


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold temperature above engine protection critical limit. | Engine is shut down.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the temperature of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure). Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature
  • Refer to the wiring diagram for sensor specifications.

This sensor can control the engine fan if the original equipment manufacturer (OEM) utilizes this feature within the ECM. The engine protection shutdown feature is customer-enabled and will require enabling at the customer's request.

Refer to Troubleshooting Fault Code 155.

Last Modified: 17-May-2010


Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 177

Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 177 PID: SPN: 698 FMI: 7 LAMP: Red SRT: | Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment. The throttle plate has moved unexpectedly. | Engine will shut down.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the electronic throttle control actuator; it is both an input and output device.

Component Location

The electronic throttle control actuator is located after the turbocharger and before the intake manifold inlet. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The electronic throttle control actuator is a pulse-width modulated component. Within the actuator is the throttle position sensor circuit. This is a non-repairable sensor and requires replacement of the actuator when damaged.

Refer to Troubleshooting Fault Code 177.

Last Modified: 21-May-2010


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 3510 FMI: 4 LAMP: Yellow SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 2 Circuit

Circuit Description

This circuit is the voltage supply for engine oil temperature/pressure sensor and the pre-catalyst and post-catalyst temperature sensors.

Component Location

The sensor supply 2 circuit is contained in the wiring harness. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The voltage supply on the engine is split into Sensor Supply 1 and Sensor Supply 2.

Refer to Troubleshooting Fault Code 187.

Last Modified: 21-May-2010


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected on the oil temperature signal pin at the ECM. | None on performance. No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block on the fuel system side of the engine. Use the following procedure for a detailed component location. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the wiring diagram specifications if the sensor is functioning properly.
Refer to Troubleshooting Fault Code 212.

Last Modified: 10-Mar-2011


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: FMI: 4 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the oil temperature signal pin at the ECM. | None on performance. No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block on the fuel system side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the wiring diagram specifications if the sensor is to function properly.
Refer to Troubleshooting Fault Code 213.

Last Modified: 14-Jun-2010


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: SPN: P175 FMI: 0 LAMP: Red SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. | Progressive power derate increasing in severity from the time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red stop lamp starts flashing.
Engine Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block, on the fuel system side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the wiring diagram specifications if the sensor is functioning properly.
Refer to Troubleshooting Fault Code 214.

Last Modified: 27-May-2010


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: SPN: S211 FMI: 3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on sensor supply number 2 circuit. | Possible reduced engine performance, shutdown, or loss of engine protection.
Sensor Supply 2 Circuit

Circuit Description

This circuit is the voltage supply for the exhaust gas stack temperature sensor and the air intake humidity/temperature sensor.

Component Location

The sensor supply voltage 5 volt circuit is contained in the wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The voltage supply on the QSL9 G CM558/CM2358 engine voltage supplies is split into Sensor Supply 1 and Sensor Supply 2.

Refer to Troubleshooting Fault Code 227.

Last Modified: 23-Sep-2013


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: 190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Engine is shutdown.
Crankshaft Speed Sensors Circuit

Circuit Description

The crankshaft (primary) engine speed sensor provides engine speed information to the ECM through the engine harness.

Component Location

The crankshaft speed sensor is located on the flywheel housing on the left side of the engine, under the filter bracket. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • Engine governor damage
  • Tampering of the speed sensors

Make sure the correct operation conditions are followed when operating the engine as described in the operation and maintenance manual. To check for valid overspeed, check the fault code snapshot information for the speed reached. This fault will activate at 1980 rpm.

Refer to Troubleshooting Fault Code 234.

Last Modified: 01-Apr-2011


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: SPN: 232 FMI: 4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on sensor supply voltage +5-VDC (3). | Possible reduced performance.
Sensor Supply Voltage Number 3 Circuit

Circuit Description

Sensor Supply Voltage 3 circuit consists of a +14 volt supply.

Component Location

The sensor supply circuit number 3 circuit is contained in the engine wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

NOTE: The Sensor Supply 3 pins are not populated in the present wiring harness. If this fault occurs, the cause is most likely dirty/damaged pins in the ECM connector.

When testing the resistance of the wires, make sure the ECM and OEM connectors are disconnected.

The Sensor Supply 3 Fault Code indicates an internal issue with the ECM or wiring harness.

Refer to Troubleshooting Fault Code 238.

Last Modified: 11-Jun-2010


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: FMI: 3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 3 circuit. | Possible reduced performance.
Sensor Supply Voltage Number 3 Circuit

Circuit Description

Sensor Supply Voltage 3 circuit consists of a +14 volt supply.

Component Location

The sensor supply circuit number 3 circuit is contained in the engine wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

NOTE: The Sensor Supply 3 pins are not populated in the present wiring harness. If this fault occurs, the cause is most likely dirty/damaged pins in the ECM connector.

When testing the resistance of the wires, make sure the ECM and OEM connectors are disconnected.

Sensor Supply 3 Fault Code indicates an internal issue with the ECM or wiring harness.

Refer to Troubleshooting Fault Code 239.

Last Modified: 10-Jun-2010


Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 244

Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 244 PID: SPN: 623 FMI: 4 LAMP: Amber SRT: | Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source. Short to ground detected on red stop lamp driver pin of ECM connector B. | Red lamp will light without fault code (always illuminated).
Red Stop Lamp Driver Circuit

Circuit Description

The electronic control module (ECM) uses the diagnostic lamp to indicate when there is a fault in the system.

Component Location

The diagnostic lamp is an original equipment manufacturer (OEM) component that is located on the OEM control panel.

Shop Talk

Proper diagnostic lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

The red stop lamp is an option that the OEM could possibly use in the OEM control panel.

Refer to Troubleshooting Fault Code 244.

Last Modified: 14-Jun-2010


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: SPN: 632 FMI: 4 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the signal return pin of the fuel control valve. | Engine is shut down or engine will not start.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve receives the control signal from CM558/CM2358. The electronic control module (ECM) operates relays that power the respective solenoids in the fuel shutoff valve.

Component Location

Refer to the engine wiring diagram, QSL9 G CM558/CM2358, Bulletin 2883396, and the OEM panel diagrams for circuit description.

Shop Talk

The batteries supply 24 volts to the fuel shutoff valve through a series of normally open relay control contacts. The fuel shutoff valve to battery negative also goes through a series of normally open relay control contacts.

The fuel shutoff valve is often connected as part of the OEM wiring. Make sure to check terminal connections at the valve.

Refer to Troubleshooting Fault Code 254.

Last Modified: 23-Sep-2013


Electronic Fuel Control Valve Circuit - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 277

Electronic Fuel Control Valve Circuit - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 277 PID: SPN: 633 FMI: 7 LAMP: Amber SRT: | Electronic Fuel Control Valve Circuit - Mechanical System Not Responding Properly or Out of Adjustment | Possible reduced engine performance or shutdown.
Electronic Fuel Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the ECM that controls the electronic fuel control valve. The ECM varies the commanded duty cycle to this valve to provide the correct fuel flow to the air/fuel mixer, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing in the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can become active for any of the following reasons:

  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Electronic fuel control valve or engine harness that has shorted to ground
  • The electronic fuel control valve being physically stuck or unable to move freely.

If an intermittent electrical circuit problem of the electronic fuel control valve circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open momentarily while the circuit is faulty.

Refer to Troubleshooting Fault Code 277.

Last Modified: 14-Jun-2010


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: SPN: FMI: 12 LAMP: Yellow SRT: | Engine Control Module (ECM) Warning Internal Hardware Failure - Bad Intelligent Device or Component. | Possible reduced performance.
Engine Control Module (ECM)

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can only be caused by an internal ECM malfunction. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code 343.

Last Modified: 05-Aug-2013


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: SPN: 630 FMI: 12 LAMP: Yellow SRT: | Engine Control Module (ECM) Calibration Memory Software - Bad Intelligent Device or Component. | Possible reduced performance.
Engine Control Module (ECM)

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can be caused by an internal ECM malfunction. This can also be caused if battery power is disconnected before the power-down sequence is completed. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code 346.

Last Modified: 05-Aug-2013


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: SPN: 3509 FMI: 4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 1 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold 1 pressure/temperature sensor.

Component Location

The sensor supply voltage 5 volt (1) circuit is contained in the wiring harness, QSL9 G CM558/CM2358, Bulletin 2883396.

Shop Talk

The voltage supply for these engines is split up into sensor supply 1 and sensor supply 2.

Apart from the intake manifold 1 pressure/temperature sensor, the speed bias potentiometer is also using the sensor 1 supply, but it is not a part of the engine harness. If this fault code goes active, the ability to manually control the engine speed will be lost and the customer may have to investigate the speed bias potentiometer.

Refer to Troubleshooting Fault Code 352.

Last Modified: 23-Sep-2013


Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 354

Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 354 PID: SPN: 3563 FMI: 3 LAMP: Amber SRT: | Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the sensor signal pin at the ECM. | Possible reduced performance or shutdown, no engine protection for intake manifold pressure 1.
Intake Manifold Pressure 1 Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold 1 pressure/temperature sensor input to determine the pressure of the air/fuel charge mixture entering the engine. This sensor is used to determine the fueling calculation into the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with temperature) on the left front side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

This sensor detects the pressure and temperature of the air/fuel mixture entering the engine. The pressure sensor on this engine is an absolute sensor.

Refer to Troubleshooting Fault Code 354.

Last Modified: 14-Jun-2010


Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 355

Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 355 PID: P106 SPN: FMI: 4 LAMP: Amber SRT: | Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage (short to ground) detected on the sensor signal pin at the ECM. | Possible reduced performance or shutdown, no engine protection for intake manifold pressure 1.
Intake Manifold Pressure 1 Sensor Circuit

Circuit Description

The ECM uses the intake manifold 1 pressure/temperature sensor input to determine the pressure of the air/fuel charge mixture entering the engine. This sensor is used to determine the fueling calculation into the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with temperature) on the left front side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

This sensor detects the pressure and temperature of the air/fuel mixture entering the engine. The pressure sensor on this engine is an absolute sensor.

Refer to Troubleshooting Fault Code 355.

Last Modified: 10-Jun-2010


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: SPN: 3509 FMI: 3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 1 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold 1 pressure/temperature sensor and OEM speed bias potentiometer.

Component Location

The sensor supply voltage 5 volt (1) circuit is contained in the wiring harness. The intake manifold 1 pressure/temperature sensor is located in the intake manifold on the left side of the engine above the ignition control module (ICM). Refer to Procedure 100-002 in Section E.

Shop Talk

The voltage supply for this engine is composed of sensor supply 1 and sensor supply 2.

Apart from the intake manifold 1 pressure/temperature sensor, the speed bias potentiometer is also using the sensor supply 1, but the potentiometer is not supplied by Cummins Inc. If this fault code goes active, the ability to manually control the engine speed will be lost. The OEM speed bias potentiometer could possibly have to be examined according to OEM troubleshooting guidelines.

Refer to Troubleshooting Fault Code 386.

Last Modified: 10-Jun-2010


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: SPN: 100 FMI: 1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Engine is shut down.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the left side of the engine block. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Use INSITE™ electronic service tool or ED3 Display to verify the engine speed at which the fault occurs. If the engine is being operated at a speed that is too low, the oil pressure can drop below the engine protection limits.

Possible causes:

  • Incorrect oil level
  • Low operation speeds
  • Oil dilution
  • Oil filter needs to be changed.
  • Oil temperature not within specifications
  • Incorrect oil.
Refer to Troubleshooting Fault Code 415.

Last Modified: 25-May-2010


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 16 LAMP: Amber SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level | No effect on engine performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located on the left side of the block below the ignition control module (ICM). Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed should compare to the sensor specifications given on the back of the appropriate wiring diagram, if the sensor is functioning properly.
Refer to Troubleshooting Fault Code 421.

Last Modified: 27-May-2010


SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2 LAMP: None SRT: | SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect. Communication between the ECM and another device on the SAE J1939 data link has been lost. | None on performance. SAE J1939 data link devices possibly do not operate.
SAE J1939 Data Link Circuit

Circuit Description

The SAE J1939 data link is a public data link that broadcasts engine operating data as well as fault codes.

Component Location

The electronic control module (ECM) is located on the intake side of the engine. The SAE J1939 data link wiring and the SAE J1939 data link devices vary by the original equipment manufacturer (OEM) options. Use the following procedure for component location or the wiring diagram for the data link location. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault occurs when the ECM starts communicating with any other device using the SAE J1939 data link and then can no longer transmit on the data link.

Possible causes of this fault code include:

  • Unplugging an electronic service tool before keying OFF the ECM
  • SAE 1939 data link having an intermittent electrical problem
  • ECM (or another SAE J1939 data link device) tying up communications because of an electrical problem or sending too many messages without stopping.
Refer to Troubleshooting Fault Code 426.

Last Modified: 17-Jun-2010


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: SPN: 168 FMI: 18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | ECM voltage supply approaching a level at which unpredictable operation will occur. Engine will possibly shut down or hard-start.
Battery Supply 1 Circuit

Circuit Description

The battery circuit provides a nominal 24-VDC supply to the electronic control module (ECM).

Component Location

The battery voltage circuit is located in the wiring harness and in the customer interface box (CIB). Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

The system requires a nominal 24-VDC power source. It is required to run three separate power leads directly from the power source to each of the three battery (+) connections to the CIB. It is not acceptable to run one wire from the power source to the physical connection strip and distribute the connections to each of the three battery (+) connections. For the battery (-) there is a fourth wire wired to earth ground.

The ECM unswitched power should be coming from the batteries, not the starter.

Refer to Troubleshooting Fault Code 441.

Last Modified: 14-Jun-2010


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: SPN: 168 FMI: 16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | ECM damage will occur. Possible electrical damage to all other electronic components.
Battery Supply 1 Circuit

Circuit Description

The battery circuit provides a nominal 24 volt supply to the electronic control module (ECM).

Component Location

The battery voltage circuit is located in the wiring harness and CIB. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The system requires a nominal 24-VDC power source, and it is required to run three separate power leads directly from the power source to each of the three battery (+) connection in the customer interface box (CIB). It is not acceptable to run one wire from the power source to the physical connection strip and distribute the connections to each of the three battery (+) connections. For the battery (-) there is another wire to earth ground.

The ECM unswitched power should be coming from the batteries and not the starter.

Refer to Troubleshooting Fault Code 442.

Last Modified: 14-Jun-2010


Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 477

Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 477 PID: SPN: 444 FMI: 18 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. ECM supply voltage is approaching a level at which unpredictable operation will occur. Engine will possibly shut down or hard-start. | ECM voltage supply approaching a level in which unpredictable operation will occur. Engine will possibly be shut down or hard to start.
Battery Supply 2 Circuit

Circuit Description

The battery circuit provides a nominal 24-VDC supply to the engine components, such as the electronic control module (ECM).

Component Location

The battery voltage circuit is located in the wiring harness and customer interface box (CIB). Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The system requires a nominal 24-VDC power source, supplied by a battery or a suitable power supply with a functional range of 18 to 32-VDC. It is required to run three separate power leads directly from the power source to each of the three battery (+) connections in the CIB. It is not acceptable to run one wire from the power source to the physical connection strip and distribute the connections to each of the three battery (+) connections. For the battery (-) connections, there is a fourth wire wired to earth ground.

Refer to Troubleshooting Fault Code 477.

Last Modified: 14-Jun-2010


Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 478

Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 478 PID: P168 SPN: 444 FMI: 16 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | ECM damage will occur.
Battery Supply 2 Circuit

Circuit Description

The battery circuit provides nominal 24-VDC supply to the engine components such as the electronic control module (ECM).

Component Location

The battery voltage circuit is located in the wiring harness and customer interface box (CIB). Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

The system requires a nominal 24-VDC power source, supplied by a battery or a suitable power supply with a functional range of 18 to 32-VDC. It is required to run three separate power leads directly from the power source to each of the three battery (+) connections in the CIB. It is not acceptable to run one wire from the power source to the physical connection strip and distribute the connections to each of the three battery (+) connections. For the battery (-) connections, there is a fourth wire wired to earth ground.

Refer to Troubleshooting Fault Code 478.

Last Modified: 14-Jun-2010


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 16 LAMP: None SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Intake manifold air temperature signal indicates intake manifold temperature above engine protection critical limit. | Possible reduced engine performance.
Intake Pressure/Temperature Sensor Circuit

Circuit Description

The ECM uses the intake pressure/temperature sensor input to determine the temperature of the fuel mixture.

Component Location

The intake pressure/temperature sensor is located in the intake manifold housing (combination sensor with absolute pressure) on the left front side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed should compare to the appropriate wiring diagram specifications, if the sensor is functioning properly.
Refer to Troubleshooting Fault Code 488.

Last Modified: 01-Apr-2011


Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 512

Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 512 PID: P51 SPN: 51 FMI: 3 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the ECM. | Possible reduced performance.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the electronic throttle actuator. The electronic throttle actuator takes inputs from the ECM and provides feedback on throttle position.

Component Location

The electronic throttle actuator is located after the fuel housing and before the intake manifold inlet on the top left side of the engine. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

The fault will become active if the throttle actuator shorts to a high source on the throttle plate position feedback circuit.

Refer to Troubleshooting Fault Code 512.

Last Modified: 10-Jun-2010


Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 513

Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 513 PID: SPN: 51 FMI: 4 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage (shorted to ground) detected at the ECM. | Possible reduced performance.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the electronic throttle actuator. The electronic throttle actuator takes inputs from the ECM and provides feedback on throttle position.

Component Location

The electronic throttle actuator is located after the air/fuel mixer and before the intake manifold inlet on the top left side of the engine. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The fault will become active if the ECM detects low voltage on the throttle plate position feedback circuit.

Refer to Troubleshooting Fault Code 513.

Last Modified: 14-Jun-2010


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The engine control module (ECM) has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Speed/ Position Sensor

Circuit Description

The ECM provides a 5-VDC supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor location varies depending on the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the crankshaft speed/position sensor while the engine is running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The camshaft speed sensor is used to provide engine speed and position information to the ECM.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it operate for 1 minute.

  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code:

  • Open or short circuit of the +5-VDC SUPPLY, SIGNAL, or RETURN wire in the engine harness.
  • Damaged or malfunctioning engine speed sensor
Refer to Troubleshooting Fault Code 689.

Last Modified: 03-Sep-2014


ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: SPN: 1136 FMI: 3 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. The internal signal for the ECM temperature is reading abnormally high voltage. | No effect on engine performance.
CM558/CM2358

Circuit Description

The CM558 contains an internal air temperature sensor. The circuit is entirely internal to the electronic control module (ECM).

Component Location

The ECM internal air temperature sensor is inside the ECM. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The ECM monitors the internal air temperature to protect the engine from the ECM overheating.

Refer to Troubleshooting Fault Code 697.

Last Modified: 23-Sep-2013


ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: SPN: 1136 FMI: 4 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The internal signal for the ECM temperature is reading abnormally low voltage. | No effect on engine performance.
CM558/CM2358

Circuit Description

The CM558 contains an internal air temperature sensor. The circuit is entirely internal to the electronic control module (ECM).

Component Location

The ECM internal air temperature sensor is inside the ECM. Refer to Procedure 100-002 in Section E for a detailed component location.

Shop Talk

The ECM monitors the internal air temperature to protect the engine from the ECM overheating.

Refer to Troubleshooting Fault Code 698.

Last Modified: 23-Sep-2013


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 783

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 783 PID: SPN: 105 FMI: 10 LAMP: Red SRT: | Intake Manifold 1 Temperature - Abnormal Rate of Change | Engine is shut down.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The intake manifold pressure/temperature sensor is located on the left side of the engine in the intake manifold. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This feature provides protection for the engine when a rapid increase in intake manifold temperature occurs. The ECM monitors the change in the intake manifold temperature over a period of time and then logs a fault and requests a shut down due to excessive temperature change.

NOTE: The sensor used in this circuit also monitors the intake manifold pressure.

Possible causes of this fault include:

  • Restricted air flow through the charge-air cooler
  • LTA cooling circuit temperature too high
  • Damaged valves
  • Air intake manifold overpressure event
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 783.

Last Modified: 14-Jun-2010


Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1665

Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1665 PID: S326 SPN: 3241 FMI: 4/4 LAMP: SRT: | Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the catalyst inlet sensor circuit. | No effect on performance.
Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment catalyst inlet temperature sensor is located in the aftertreatment system. It is located at the inlet of the aftertreatment catalyst. Refer to Procedure 100-002 in Section E.

Shop Talk

The aftertreatment catalyst inlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return wire can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 1665.

Last Modified: 11-May-2010


Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1666

Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1666 PID: S326 SPN: 3241 FMI: 3 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst inlet temperature sensor circuit. | Possible loss of engine performance.
Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or high temperature. When the exhaust gas temperature is high, the sensor resistance is high. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a low temperature.

Component Location

The pre-catalyst temperature sensor is located in the aftertreatment system. It is located at the inlet of the aftertreatment catalyst. Refer to the OEM service manual.

Shop Talk

Conditions for running the diagnostics:

  • The diagnostic run continuously.

Conditions for setting the fault code:

  • The ECM detects that the pre-catalyst temperature signal voltage is greater than 4.75-VDC for more than three seconds.

Action taken when the fault code is active:

  • The ECM illuminates the amber warning light immediately when the diagnostic runs and fails.
  • A default value for the pre-catalyst temperature reading is used.

Conditions for clearing the fault code:

  • The ECM will stop annuniciating the fault immediately after the diagnostic runs and passes.

The pre-catalyst temperature sensor shares return wires in the OEM harness with other sensors. A shorted return wire can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source
  • Malfunction in resistor pack
  • Damaged ECM.
Refer to Troubleshooting Fault Code 1666.

Last Modified: 11-Jun-2010


Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1674

Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1674 PID: S327 SPN: 3249 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment outlet temperature sensor circuit. | Loss of performace may occur.
Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor or thermistor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst. Refer to Procedure 100-002 in Section E.

Shop Talk

The aftertreatment outlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 1674.

Last Modified: 11-May-2010


Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1675

Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1675 PID: SPN: 3249 FMI: 3 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source. | Possible loss of engine performance.
Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust gas temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this voltage change to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or high temperature. When the exhaust gas temperature is high, the sensor resistance is high. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a low temperature.

Component Location

The post catalyst temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst.

Shop Talk

Conditions for running the diagnostics:

  • The diagnostic run continuously.

Conditions for setting the fault codes:

  • The ECM detects that the post catalyst temperature signal voltage is greater than 4.75-VDC for more than three seconds.

Action taken when the fault code is active:

  • The ECM illuminates the amber warning light immediately when the diagnostic runs and fails.
  • A default value for the post catalyst temperature reading is used.

Conditions for clearing the fault code:

  • The ECM will stop annuniciating the fault immediately after the diagnostic runs and passes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source
  • Malfunction in the resistor pack
  • Damaged ECM.
Refer to Troubleshooting Fault Code 1675.

Last Modified: 11-Jun-2010


Engine Throttle Control Actuator - Condition Exists

FAULT CODE 1739

Engine Throttle Control Actuator - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1739 PID: SPN: 3464 FMI: 31 LAMP: Amber SRT: | Engine Throttle Control Actuator - Condition Exists. Problem detected in the engine throttle actuator or the circuitry connected to it. | Possible reduced engine performance, engine shutdown, or engine will possibly not start.
Engine Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the electronic throttle actuator. The electronic throttle actuator takes inputs from the ECM and provides feedback on throttle position.

Component Location

The electronic throttle actuator is located after the air/fuel mixer and before the intake manifold inlet on the top left side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can be caused by a problem with the resistor pack in the engine wiring harness. Check the resistor pack thoroughly while completing these troubleshooting steps.

Refer to Troubleshooting Fault Code 1739.

Last Modified: 10-Jun-2010


Electrical Load - Failure to Meet Load and/or Speed Demand - Condition Exists

FAULT CODE 1791

Electrical Load - Failure to Meet Load and/or Speed Demand - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1791 PID: SPN: 1204 FMI: 31 LAMP: Red SRT: | Electrical Load - Failure to Meet Load and/or Speed Demand - Condition Exists. The engine was unable to meet the required speed or load demand. | Engine is shut down.
Electrical Load

Circuit Description

N/A

Component Location

N/A

Shop Talk

This fault code will commonly occur in parallel with other faults. If the troubleshooting does not resolve the fault, the cause could be related to another engine system. A misfire in the ignition system is a common cause for this fault as the unburned fuel will enter the exhaust and cause the exhaust oxygen sensor to sense a rich mixture and command the air/fuel to lean out. This will then result in a loss of power and cause the engine to shut down.

Possible causes of this fault code include:

  • Improper air/fuel mixture
  • Intake restriction
  • Failed throttle, fuel control valve, or turbocharger.
  • Engine load beyond published limit.
Refer to Troubleshooting Fault Code 1791.

Last Modified: 10-Jun-2010


Engine Oil Temperature Sensor 1 Circuit, Too Cold For High Idle - Condition Exists

FAULT CODE 1824

Engine Oil Temperature Sensor 1 Circuit, Too Cold For High Idle - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1824 PID: SPN: FMI: 31 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit, Too Cold For High Idle - Condition Exists. The oil has not warmed up sufficiently for the engine to increase speed. | The engine will not increase speed beyond low idle.
Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block on the left side of the engine below the ignition control module (ICM). Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code protects the engine from operating at high speeds with cold engine oil. The engine will remain at low idle and not go to commanded speed until the oil reaches a minimum temperature. Running an engine without allowing the engine oil to heat causes over-pressurization in the oil system. High oil pressure can damage engine components.

This fault is often seen in winter or at cold ambient temperatures. Make sure the oil is allowed to reach 38°C or 100°F before troubleshooting this fault code.

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the specifications on the wiring diagram.
Refer to Troubleshooting Fault Code 1824.

Last Modified: 11-Jun-2010


Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1858

Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1858 PID: SPN: 3217 FMI: 3 LAMP: Amber SRT: | Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance or emissions change.
Inlet Oxygen Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The oxygen concentration sensors are located on either side of the three-way catalyst. Refer to the OEM service manual for a detailed component location view.

Shop Talk

The oxygen sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed loop operation of the engine.

Refer to Troubleshooting Fault Code 1858.

Last Modified: 25-May-2010


Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1859

Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1859 PID: SPN: 3217 FMI: 4 LAMP: Amber SRT: | Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced performance or emissions change.
Aftertreatment Inlet Oxygen Concentration Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The aftertreatment oxygen concentration sensors are located on either side of the three-way catalyst. Refer to the OEM service manual for a detailed component location view.

Shop Talk

The aftertreatment inlet oxygen concentration sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed loop operation of the engine.

Refer to Troubleshooting Fault Code 1859.

Last Modified: 25-May-2010


Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1862

Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1862 PID: SPN: 3227 FMI: 3 LAMP: Amber SRT: | Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance or emissions change.
Aftertreatment Outlet Oxygen Concentration Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The post catalyst oxygen concentration sensor is located in the exhaust tubing after the catalyst. Refer to the OEM service manual for a detailed component location view.

Shop Talk

The aftertreatment outlet oxygen concentration sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed loop operation of the engine.

Refer to Troubleshooting Fault Code 1862.

Last Modified: 27-May-2010


Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1863

Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1863 PID: SPN: 3227 FMI: 4 LAMP: Amber SRT: | Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced performance.
Aftertreatment Outlet Oxygen Concentration Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The aftertreatment outlet oxygen concentration sensor is located in the exhaust tubing after the catalyst. Refer to the OEM service manual for a detailed component location view.

Shop Talk

The oxygen sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed loop operation of the engine.

Refer to Troubleshooting Fault Code 1863.

Last Modified: 25-May-2010


Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1965

Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1965 PID: 326 SPN: 3241 FMI: 16 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Possible catalyst damage.
Aftertreatment Exhaust Gas Temperature Sensor

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is low. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or high temperature. When the exhaust gas temperature is high, the sensor resistance is high. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a low temperature.

Component Location

The pre-catalyst temperature sensor is located in the aftertreatment system. It is located at the inlet of the catalyst. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

  • The diagnostic run continuously.

Conditions for Setting the Fault Codes

  • The pre-catalyst temperature sensor reading exceeds a specified temperature for a specified amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the post catalyst temperature reading is used.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp and the fault code will be set to inactive when the keyswitch is cycled or the temperature drops below a specified temperature.

Shop Talk

Possible causes of this fault code include:

  • Pre-catalyst outlet temperature sensor malfunctioned in-range
  • Excessive engine oil or diesel fuel is being introduced into the exhaust system from the engine
  • The engine is operating too rich.
Refer to Troubleshooting Fault Code t05-1965.

Last Modified: 04-Aug-2014


Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1966

Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1966 PID: 326 SPN: 3241 FMI: 0 LAMP: Red SRT: | Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level. Engine exhaust gas temperatures entering the aftertreatment system are above the engine protection limits. | Possible catalyst damage.
Exhaust Gas Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust gas temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this voltage change to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is low. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or high temperature. When the exhaust gas temperature is high, the sensor resistance is high. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a low temperature.

Component Location

The pre-catalyst temperature sensor is located in the aftertreatment system. It is located at the inlet of the catalyst. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

  • The diagnostic run continuously.

Conditions for Setting the Fault Codes

  • The pre-catalyst temperature sensor reading exceeds a specified temperature for a specified amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the post catalyst temperature reading is used.
  • The engine will shut down if the high temperature condition continues to exist.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red CHECK ENGINE lamp and the fault code will be set to inactive when the keyswitch is cycled or the temperature drops below a specified temperature.

Shop Talk

Possible causes of this fault code include:

  • Pre-catalyst outlet temperature sensor malfunctioned in-range
  • Excessive engine oil or diesel fuel is being introduced into the exhaust system from the engine
  • The engine is operating too rich.
Refer to Troubleshooting Fault Code t05-1966.

Last Modified: 05-Aug-2014


Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1968

Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1968 PID: 327 SPN: 3249 FMI: 16 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Possible catalyst damage.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is low. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a high temperature. When the exhaust gas temperature is high, the sensor resistance is high. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a low temperature.

Component Location

The post catalyst temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst. See equipment manufacturer service information for a detailed component location view.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously.

Conditions for Setting the Fault Codes

  • The post catalyst temperature sensor reading exceeds a specified temperature for a specified amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp and the fault code will be set to inactive when the keyswitch is cycled or the temperature drops below a specified temperature.

Shop Talk

Possible causes of this fault code include:

  • Post catalyst outlet temperature sensor malfunctioned in-range
  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • The engine is operating too rich.
Refer to Troubleshooting Fault Code t05-1968.

Last Modified: 04-Aug-2014


Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1969

Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1969 PID: SPN: FMI: 16 LAMP: Red SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Most Severe Level. | Possible catalyst damage.
Aftertreatment Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is low. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or high temperature. When the exhaust gas temperature is high, the sensor resistance is high. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a low temperature.

Component Location

The post catalyst temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst. See equipment manufacturer service information.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously.

Conditions for Setting the Fault Codes

  • The post catalyst temperature sensor reading exceeds a specified temperature for a specified amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will shut down if the high temperature condition continues to exist.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red CHECK ENGINE lamp and the fault code will be set to inactive when the keyswitch is cycled or the temperature drops below a specified temperature.

Shop Talk

Possible causes of this fault code include:

  • Post catalyst outlet temperature sensor malfunctioned in-range.
Refer to Troubleshooting Fault Code t05-1969.

Last Modified: 05-Aug-2014


Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1978

Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1978 PID: SPN: 3938 FMI: 3 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source. Above normal voltage detected in the generator speed/load governing bias circuit. | Possible reduced engine performance.
Generator Speed/Load Governing Bias Circuit

Circuit Description

The electronic control module (ECM) uses the signal from this circuit to determine the commanded engine speed, and equates this to a throttle position, which it commands to the throttle.

Component Location

The customer supplied voltage governing device is located in the OEM control panel. Refer to the OEM service manual for detailed component location view.

Shop Talk

This is a 0 to 5 volt engine speed signal circuit that is controlled by a customer-supplied voltage governing device, such as a speed potentiometer or a digital controller (PLC). This 0 to 5 volt signal is sent to the ECM, which uses it to determine a commanded engine speed. The ECM sends a signal to the throttle to either open or close until the desired engine speed is met. In order to diagnose this issue the ECM, engine wiring, customer interface box wiring, OEM wiring, and the customer-supplied voltage governing device will need to be checked.

Refer to Troubleshooting Fault Code 1978.

Last Modified: 25-May-2010


Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1979

Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1979 PID: SPN: 3938 FMI: 4 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source. Below normal voltage detected in the generator speed/load governing bias circuit. | Possible reduced engine performance.
Generator Speed/Load Governing Bias Circuit

Circuit Description

The electronic control module (ECM) uses the signal from this circuit to determine the commanded engine speed, and equates this to a throttle position, which it commands to the throttle.

Component Location

The customer supplied voltage governing device is located in the OEM control panel. Refer to the OEM service manual for detailed component location view.

Shop Talk

This is a 0 to 5 volt engine speed signal circuit that is controlled by a customer-supplied voltage governing device, such as a speed potentiometer or a digital controller (PLC). This 0 to 5 volt signal is sent to the ECM, which uses it to determine a commanded engine speed. The ECM sends a signal to the throttle to either open or close until the desired engine speed is met. In order to diagnose this issue the ECM, engine wiring, customer interface box wiring, OEM wiring, and the customer-supplied voltage governing device will need to be checked.

Refer to Troubleshooting Fault Code 1979.

Last Modified: 25-May-2010


Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1982

Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1982 PID: None FMI: 0 LAMP: Red SRT: | Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Most Severe Level | Engine shut down. Possible catalyst damage.
Pre and Post Catalyst Temperature Sensors Circuit

Circuit Description

The electronic control module (ECM) uses the aftertreatment exhaust gas inlet and outlet temperature sensors to determine the temperature difference between the inlet and outlet of the three-way catalyst.

Component Location

The aftertreatment exhaust gas inlet and outlet temperature sensors are located in the exhaust tubing on each side of the three-way catalyst. Refer to the OEM service manual for a detailed component location view.

Shop Talk

Conditions for Running the Diagnostics:

  • It is normal for the temperature of the exhaust gases to increase as they flow through the three-way catalyst element. If the rise in temperature is too great, catalyst damage can result.

Conditions for Setting the Fault Codes:

  • The difference between the aftertreatment catalyst outlet temperature sensor reading and the aftertreatment catalyst inlet temperature reading exceeds 10°C [50°F] for 10 seconds.

Action Taken When the Fault Code is Active:

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will shut down if the high temperature condition exists for a calibratible amount of time.

This fault can be caused by:

  • One or more cylinders misfiring
  • Engine operating too rich.
Refer to Troubleshooting Fault Code 1982.

Last Modified: 27-May-2010


Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1983

Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1983 PID: SPN: 3050 FMI: 16 LAMP: Amber SRT: | Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level | Engine shut down. Possible catalyst damage.
Pre and Post Catalyst Temperature Sensors Circuit

Circuit Description

The electronic control module (ECM) uses the aftertreatment exhaust gas inlet and outlet temperature sensors to determine the temperature difference between the inlet and outlet of the three-way catalyst.

Component Location

The aftertreatment exhaust gas inlet and outlet temperature sensors are located in the exhaust tubing on each side of the three-way catalyst. Refer to the OEM service manual for a detailed component location view.

Shop Talk

Conditions for Running the Diagnostics:

  • It is normal for the temperature of the exhaust gases to increase as they flow through the three-way catalyst element. If the rise in temperature is too great, catalyst damage can result.

Conditions for Setting the Fault Codes:

  • The difference between the aftertreatment catalyst outlet temperature sensor reading and the aftertreatment catalyst inlet temperature reading exceeds the calibrated limit for a calibrated time.

Action Taken When the Fault Code is Active:

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will shut down if the high temperature condition exists for a calibratible amount of time.

This fault may be caused by:

  • One or more cylinders misfiring
  • Engine operating too rich.
Refer to Troubleshooting Fault Code 1983.

Last Modified: 27-May-2010


Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

FAULT CODE 2217

Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2217 PID: SPN: 630 FMI: 31 LAMP: Amber SRT: | Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists. Internal ECM error. | Possible engine shutdown, loss of performance, or engine will possibly not start.
Electronic Control Module (ECM) 24 Volt Power Supply System

Circuit Description

The electronic control module (ECM) is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM). Use the following procedure for a detailed component location. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can be caused by an intermittent power supply to the ECM or an internal ECM problem. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code 2217.

Last Modified: 25-May-2010


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: SPN: 633 FMI: 31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. | Possible reduced engine performance.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the electronic control module (ECM) that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the air/fuel mixer, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing in the rear of the engine, just after the on-engine fuel pressure regulator. Refer to the OEM service manual for a detailed component location view.

Shop Talk

If this fault code occurs during a test, verify that all connectors are clean and free of corrosion before replacing components. This fault code can become active for any of the following reasons:

  • Electronic fuel control valve high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Electronic fuel control valve with low internal resistance
  • Electronic fuel control valve or engine harness that has shorted to ground.

If an intermittent electrical circuit problem of the electronic fuel control valve circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is malfunctioning.

Refer to Troubleshooting Fault Code 2311.

Last Modified: 25-May-2010


Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2315

Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2315 PID: SPN: 623 FMI: 3 LAMP: Amber SRT: | Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source. | Red lamp will not illuminate.
Red Stop Lamp Driver Circuit

Circuit Description

The ECM uses the red stop lamp to inform the operator about active faults on the engine.

Component Location

The red stop lamp is an original equipment manufacturer (OEM) component that is typically located in the OEM control panel. Refer to the OEM service manual for a detailed component location view.

Shop Talk

Proper lamp operation can be verified by checking to see that the red stop lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code 2315.

Last Modified: 27-May-2010


Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2316

Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2316 PID: SPN: 624 FMI: 3 LAMP: Amber SRT: | Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source. | Amber lamp will not illuminate.
ECM Diagnostic Lamp Circuit

Circuit Description

The electronic control module (ECM) uses the amber warning lamp to inform the operator about active faults on the engine.

Component Location

The lamp is an original equipment manufacturer (OEM) component that is typically located in the OEM control panel.

Shop Talk

Proper lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code 2316.

Last Modified: 27-May-2010


Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2317

Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2317 PID: SPN: 624 FMI: 4 LAMP: Amber SRT: | Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source. | Amber lamp will be illuminated constantly.
ECM Diagnostic Lamp Circuit

Circuit Description

The electronic control module (ECM) uses the amber warning lamp to inform the operator about active faults on the engine.

Component Location

The lamp is an original equipment manufacturer (OEM) component that is typically located on the OEM control panel.

Shop Talk

Proper lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code 2317.

Last Modified: 27-May-2010


External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

FAULT CODE 2455

External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2455 PID: SPN: 3938 FMI: 5 LAMP: Amber SRT: | External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit. Below normal current detected in the external governor speed or frequency bias circuit. | Possible reduced engine performance.
External Governor Speed or Frequency Bias Signal Circuit

Circuit Description

The electronic control module (ECM) uses the signal from this circuit to determine the OEM commanded engine speed.

Component Location

Not applicable.

Shop Talk

This is a 4-20 milliampere engine speed signal circuit that is controlled by a customer-supplied governing device, such as a programmable logic controller (PLC). This 4-20 milliampere signal is then sent to the ECM, which uses it to determine a commanded engine speed. The ECM then sends a signal to the throttle to either open or close until the desired engine speed is met. In order to diagnose this issue, the ECM, engine wiring, OEM control panel wiring, the OEM wiring, and the customer-supplied governing device.

Refer to Troubleshooting Fault Code 2455.

Last Modified: 27-May-2010


External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit

FAULT CODE 2456

External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2456 PID: SPN: 3939 FMI: 6 LAMP: Amber SRT: | External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit. Above normal current detected in the external governor speed or frequency bias circuit. | Possible reduced engine performance.
External Governor Speed or Frequency Bias Circuit

Circuit Description

The electronic control module (ECM) uses the signal from this circuit to determine the OEM commanded engine speed.

Component Location

Not applicable.

Shop Talk

This is a 4-20 milliamp engine speed signal circuit that is controlled by a customer-supplied governing device, such as a programmable logic controller (PLC). This 4-20 milliamp signal is then sent to the ECM, which uses it to determine a commanded engine speed. The ECM then sends a signal to the throttle to either open or close until the desired engine speed is met. In order to diagnose this issue, check the ECM, the engine wiring, OEM control panel wiring, the OEM wiring, and the customer-supplied governing device.

Refer to Troubleshooting Fault Code 2456.

Last Modified: 27-May-2010


Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2544

Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2544 PID: SPN: 1136 FMI: 0 LAMP: Red SRT: | Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. The electronic control module (ECM) internal temperature has exceeded the high shut down threshold. | Engine is shut down.
Electronic Control Module (ECM)

Circuit Description

The CM558/CM2358 contains an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside the ECM. Refer to the OEM service manual for a detailed component location view.

Shop Talk

The ECM monitors its internal air temperature to protect the engine from overheating.

Refer to Troubleshooting Fault Code 2544.

Last Modified: 23-Sep-2013


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2661 PID: SPN: 629 FMI: 31 LAMP: Red SRT: | At Least One Unacknowledged Most Severe Fault - Condition Exists. | Engine will possibly not start.
Unacknowledged Fault

Circuit Description

Not applicable for this fault code.

Component Location

The reset button or switch location depends on the OEM. Refer to the OEM service manual.

Shop Talk

This fault code is generated by red/shutdown lamp faults. This fault code occurs as a result of other red lamp faults becoming active. The light is an indicator that will remain lit to inform the operator that there has been a red lamp fault generated, even when conditions are met to allow the other red lamp faults to become inactive. The light will only be available if it is offered by the OEM. Fault Code 2661 will remain active until it has been reset.

Other fault codes need to be corrected before acknowledging this fault code, otherwise this fault code will become active again after a calibrated period of time, if other fault codes are still active.

Refer to Troubleshooting Fault Code 2661.

Last Modified: 27-May-2010


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2789

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2789 PID: FMI: 18 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine coolant temperature is below normal operating temperature limits. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the engine coolant temperature. The electronic control module (ECM) supplies 5-VDC to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is located on the left side of the engine, above the ignition control module. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault indicates that coolant temperature is below a calibration limit set in the ECM.

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the specifications in the following procedure, if the sensor is functioning properly. Reference the Specifications information in Section V.
Refer to Troubleshooting Fault Code 2789.

Last Modified: 15-Jun-2010


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2793

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2793 PID: SPN: 110 FMI: 1 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level. Engine coolant temperature is below normal operating temperature limits. | Engine is shut down.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the engine coolant temperature. The electronic control module (ECM) supplies 5-VDC to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is located on the left side of the engine, above the ignition control module. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault indicates that coolant temperature is below the minimum calibration limit set in the ECM.

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the specifications in the following procedure if the sensor is functioning properly. Reference the Specifications information in Section V.
Refer to Troubleshooting Fault Code 2793.

Last Modified: 14-Jun-2010


Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2864

Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2864 PID: SPN: 632 FMI: 3 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the signal return pin of the fuel control valve. | Engine is shut down and engine will not start.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve coil is connected across the fuel shutoff control supply contact and the fuel shutoff control return contact in the original equipment manufacturer (OEM) control panel. When the engine control system commands zero fuel flow to the engine, the fuel shutoff control supply contact and fuel shutoff control return contact will both be open circuited. The fuel shutoff (FSO) is controlled by a relay operated by the electronic control module (ECM).

Component Location

The FSO circuit is in the ECM, wiring harness, OEM control panel, and fuel shutoff valve. Use the following procedure for a detailed the component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff control supply contact is directly connected to the FSO solenoid (+) wire and the fuel shutoff control return contact is directly connected to the FSO solenoid (-) wire. The engine shutdowns are commanded via interruption of system battery voltage to the customer normal shutdown contact or the customer ignition shutdown contact.

If the packager or customer desires to install a component that will open circuit the wire connecting the fuel shutoff control supply contact the FSO solenoid (+) wire or the wire connecting the fuel shutoff control return contact to the FSO solenoid (-) wire. Then, it is required the controlling element commanding the open circuit also simultaneously interrupts battery voltage to the customer normal shutdown contact. This approach makes sure the engine control system is made aware of the commanded shutdown. Failure to do so will result in less than optimal engine control system performance.

Refer to Troubleshooting Fault Code 2864.

Last Modified: 14-Jun-2010


Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2866

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2866 PID: SPN: 1422 FMI: 3 LAMP: Amber SRT: | Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No effect on engine performance.
Electronic Fuel Control Valve Circuit

Circuit Description

The electronic fuel control valve communicates its position by means of an output voltage. The output voltage is sent to the electronic control module (ECM) which translates the output voltage into a measured value position between 0-100.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing on the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 in Section E for a detailed component location.

Shop Talk

The electronic fuel control valve is not repairable, so if the valve is determined to be failed after following the troubleshooting steps, it will be necessary to replace the entire electronic fuel control valve assembly.

Refer to Troubleshooting Fault Code 2866.

Last Modified: 15-Jun-2010


Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2867

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2867 PID: SPN: 1442 FMI: 4 LAMP: Amber SRT: | Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No effect on engine performance.
Electronic Fuel Control Valve Circuit

Circuit Description

The electronic fuel control valve communicates the position by means of an output voltage. This output voltage is sent to the electronic control module (ECM) which translates the output voltage into a measured value position between 0-100.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing on the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

The electronic fuel control valve is not repairable, so if the valve is determined to be failed after following the troubleshooting steps, it will be necessary to replace the entire electronic fuel control valve assembly.

Refer to Troubleshooting Fault Code 2867.

Last Modified: 10-Jun-2010


Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2995

Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2995 PID: SPN: 3563 FMI: 0 LAMP: Red SRT: | Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Most Severe Level. Intake manifold air pressure signal indicates intake manifold pressure above engine protection critical limit. | Engine is shut down.
Intake Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor monitors intake manifold air pressure and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The intake manifold pressure/temperature sensor is located in the left side of the engine in the intake manifold. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E .

Shop Talk

This fault can be activated by the following issues:

  • Sensor damage
  • Intake manifold overpressure event
  • Engine overloaded/proper derates not applied
  • Engine timing incorrect.
Refer to Troubleshooting Fault Code 2995.

Last Modified: 14-Jun-2010


Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2996

Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2996 PID: SPN: 3563 FMI: 16 LAMP: Amber SRT: | Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level. Intake manifold air pressure signal indicates intake manifold pressure above engine protection normal limit. | Possible reduced engine performance.
Intake Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor monitors intake manifold air pressure and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The intake pressure/temperature sensor is located on the left side of the engine in the intake manifold. Refer to Procedure 100-002 in Section E .

Shop Talk

Possible causes of this fault code include:

  • Sensor damage
  • Intake manifold over-pressure event
  • Engine overloaded
  • Engine timing incorrect.
Refer to Troubleshooting Fault Code 2996.

Last Modified: 10-Jun-2010


Aftertreatment Outlet Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3288

Aftertreatment Outlet Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3288 PID: None SPN: 3233 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Outlet Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance or emissions change.
Aftertreatment Outlet Oxygen Concentration Sensor

Circuit Description

The electronic control module (ECM) uses the aftertreatment outlet oxygen concentration sensor to determine the amount of oxygen in the exhaust to the three-way catalyst. The power to the oxygen sensor heater is supplied by a DC/DC converter through a normally open contact on the aftertreatment outlet oxygen concentration sensor power relay.

Component Location

The ECM is located on the side of the engine. The aftertreatment outlet oxygen concentration sensors are located on both sides of the three-way catalyst. The aftertreatment outlet oxygen concentration sensor power relay driver is in the original equipment manufacturer (OEM) panel. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously.

Conditions for Setting the Fault Codes

The ECM detects a sufficiently high voltage above ground potential on the relay driver circuit when the ECM relay driver is commanded OFF. The ECM internally monitors the relay driver command and the actual voltage at the ECM relay driver output pin.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber warning light or displays on the customer interface immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detects a voltage sufficiently close to the ground potential level on the relay driver circuit when the ECM relay driver is commanded OFF. The ECM relay driver is commanded OFF when the engine is not running.
  • The engine will need to be at 0 rpm to reset the fault.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the relay driver circuit
  • ECM internal damage
  • Relay damage
  • Relay driver circuit shorted to a voltage source.
Refer to Troubleshooting Fault Code 3288.

Last Modified: 23-Jun-2010


Aftertreatment Outlet Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3289

Aftertreatment Outlet Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3289 PID: None SPN: 3223 FMI: LAMP: Amber SRT: | Aftertreatment Outlet Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced performance or emissions change.
Aftertreatment Outlet Oxygen Concentration Sensor

Circuit Description

The electronic control module (ECM) uses the aftertreatment outlet oxygen sensor to determine the amount of oxygen in the exhaust gas subsequent to the three-way catalyst. The power to the oxgen sensor heater is supplied by a DC/DC converter through a normally open contact on the aftertreatment outlet oxygen concentration sensor power relay. The relay is energized when the ECM based aftertreatment outlet oxygen concentration sensor power relay driver is turned on.

Component Location

The aftertreatment outlet oxygen concentration sensors are located on both sides of the three-way catalyst. The aftertreatment outlet oxygen concentration sensor power relay is in the original equipment manufacturer (OEM) panel.

Conditions for Running the Diagnostics

This diagnostic runs continuously.

Conditions for Setting the Fault Codes

The ECM detects a voltage significantly lower than the system supply voltage on the relay driver circuit when the ECM relay driver is commanded on. The ECM internally monitors the relay driver command and the actual voltage at the ECM relay driver output pin.

Action Taken When the Fault Code is Active

The ECM illuminates the amber warning light or displays on customer interface immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM must detect the aftertreatment outlet oxygen concentration sensor driver signal voltage has returned to normal operating conditions for more than a calibratible period.
  • The engine will need to be running for calibrated period to clear.

Shop Talk

Possible causes of this fault code include:

  • Relay driver circuit between the ECM and relay coil shorted to a ground source
  • ECM internal damage
  • Relay damage
  • Low system voltage. Low voltage or damaged batteries.
Refer to Troubleshooting Fault Code 3289.

Last Modified: 15-Jun-2010


Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3291

Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3291 PID: None SPN: 3223 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance or emissions change.
Aftertreatment Inlet Oxygen Concentration Sensor

Circuit Description

The electronic control module (ECM) uses the aftertreatment inlet oxygen concentration sensor to determine the amount of oxygen in the exhaust gas prior to the three-way catalyst. The power to the oxygen sensor heater is supplied by a DC/DC converter powered through a normally open contact on the aftertreatment inlet oxygen concentration sensor power relay. The relay is energized when the ECM based aftertreatment inlet oxygen concentration sensor power relay driver is turned on.

Component Location

The aftertreatment inletoxygen concentration sensors are located on both sides of the three-way catalyst. The aftertreatment outlet oxygen concentration sensor power relay is in the original equipment manufacturer (OEM) panel.

Conditions for Running the Diagnostics

This diagnostic runs continuously.

Conditions for Setting the Fault Codes

The ECM detects a sufficiently high voltage above ground potential on the relay driver circuit when the ECM relay driver is commanded on. The ECM internally monitors the relay driver command and the actual voltage at the ECM relay driver output pin.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber warning light or displays on customer interface immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detects that the oxygen sensor driver signal voltage has returned to normal operating conditions for more than a calibratible period while the engine is running.

Shop Talk

Possible causes of this fault code include:

  • Portion of the relay driver circuit shorted to a ground between the ECM and the relay circuit
  • ECM internal damage
  • Relay damage.
Refer to Troubleshooting Fault Code 3291.

Last Modified: 14-Jun-2010


Aftertreatment Intake Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3292

Aftertreatment Intake Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3292 PID: SPN: 3223 FMI: 4 LAMP: Amber SRT: | Aftertreatment Intake Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced performance or emissions change.
Aftertreatment Inlet Oxygen Concentration Sensor

Circuit Description

The electronic control module (ECM) uses the aftertreatment inlet oxygen concentration sensor to determine the amount of oxygen in the exhaust gas prior to the three-way catalyst. The power to the oxygen sensor heater is supplied by a DC:DC converter powered through a normally open contact on the aftertreatment inlet oxygen concentration sensor power relay. The relay is energized when the ECM based aftertreatment inlet oxygen concentration sensor power relay driver is turned on.

Component Location

The aftertreatment inlet oxygen concentration sensors are located on both sides of the three-way catalyst. The aftertreatment inlet oxygen concentration sensor power relay driver is in the original equipment manufacturer (OEM) panel.

Conditions for Running the Diagnostics

This diagnostic runs continuously.

Conditions for Setting the Fault Codes

The ECM detects a voltage significantly lower than the system supply voltage on the relay driver circuit when the ECM relay driver is commanded off. The ECM internally monitors the relay driver command and the actual voltage at the ECM relay driver output pin.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber warning light or displays on customer interface immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The engine is not running.
  • The ECM detects the oxygen sensor driver signal voltage has returned to normal operating conditions for more than calibratible period when the engine is OFF.
  • The engine will need to be at 0 RPM to reset the fault and started again.

Shop Talk

Possible causes of this fault code include:

  • Open circuit or circuit shorted to a ground in the relay driver circuit
  • ECM internal damage
  • Relay damage
  • OEM fuses damage
  • Low or no system supply voltage due to weak or failed batteries.
Refer to Troubleshooting Fault Code 3292.

Last Modified: 14-Jun-2010


Engine Electrical System Power Conservation Control - Voltage Above Normal or Shorted to High Source

FAULT CODE 3362

Engine Electrical System Power Conservation Control - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3362 PID: SPN: 3603 FMI: 3 LAMP: Amber SRT: | Engine Electrical System Power Conservation Control - Voltage Above Normal or Shorted to High Source. | Electronic fuel control valve or throttle powered regardless of keyswitch position. Possible drained battery.
Engine Electrical System Power Conservation Control

Circuit Description

The electronic control module (ECM) uses the battery conservation relay driver circuit to control power to the electronic fuel control valve and the throttle actuator.

Component Location

The battery conservation relay driver circuit is located in the wiring harness, ECM, and original equipment manufacturer (OEM) control panel.

Shop Talk

Ten seconds after the ECM has detected the engine has been shut down, it will de-energize the battery conservation relay which will disconnect power to the electronic fuel control valve and throttle actuator. This fault code occurs when the ECM battery conservation relay driver is commanded OFF, but still sees 24-VDC at the battery conservation relay supply pin in the ECM. This fault code also occurs if there is an open in this circuit.

Refer to Troubleshooting Fault Code 3362.

Last Modified: 10-Jun-2010


Engine Electrical System Power Conservation Control - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3363

Engine Electrical System Power Conservation Control - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3363 PID: SPN: 3603 FMI: 4 LAMP: Amber SRT: | Engine Electrical System Power Conservation Control - Voltage Below Normal or Shorted to Low Source. | Engine will shut down or engine will not start.
Engine Electrical System Power Conservation Control

Circuit Description

The electronic control module (ECM) uses the battery conservation relay driver circuit to control power to the electronic fuel control valve and the throttle actuator.

Component Location

The battery conservation relay driver circuit is located in the wiring harness, ECM, and original equipment manufacturer (OEM) control panel.

Shop Talk

Ten seconds after the ECM has detected the engine has been shut down, it will de-energize the battery conservation relay which will disconnect power to the electronic fuel control valve and throttle actuator. This fault code occurs when the ECM battery conservation relay driver is commanded ON, but there is low voltage at the battery conservation relay supply pin in the ECM.

Refer to Troubleshooting Fault Code 3363.

Last Modified: 14-Jun-2010


Engine Electrical System Power Conservation Control - Diagnostics Has Detected An Error - Condition Exists

FAULT CODE 3364

Engine Electrical System Power Conservation Control - Diagnostics Has Detected An Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3364 PID: SPN: 3603 FMI: 31 LAMP: Amber SRT: | Engine Electrical System Power Conservation Control Diagnostics Has Detected An Error - Condition Exists | Possible drained battery. Possible engine shut down or hard start.
Engine Electrical System Power Conservation Control

Circuit Description

The electronic control module (ECM) uses the battery conservation relay driver circuit to control power to the electronic fuel control valve and the throttle actuator.

Component Location

The battery conservation relay driver circuit is located in the wiring harness, ECM, and original equipment manufacturer (OEM) control panel.

Shop Talk

The ECM has detected that there is a malfunction with the operation of the battery conservation relay circuit. This fault code usually occurs in conjunction with Fault Codes 3362 and 3363.

Refer to Troubleshooting Fault Code 3364.

Last Modified: 24-May-2010


Intake Manifold 1 Temperature - Special Instructions

FAULT CODE 3644

Intake Manifold 1 Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3644 PID: SPN: 105 FMI: 14 LAMP: Red SRT: | Intake Manifold 1 Temperature - Special Instructions. Intake manifold temperature signal is out of range high or low. | Engine is shut down.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the temperature and pressure of the air/fuel charge mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold on the left side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code indicates the intake manifold temperature sensor signal is out of range. It is more likely there are other intake manifold related fault codes present when Fault Code 3644 is active. The other fault codes to look for are Fault Codes 153 and 154. Refer to the troubleshooting procedures for all other intake manifold related fault codes first. If Fault Code 3644 is active, the engine can not be restarted.

Refer to Troubleshooting Fault Code 3644.

Last Modified: 10-Jun-2010


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Speed Sensor | Refer to Procedure 019-042 | KTA38GC CM558/CM2358 | 4021656
Engine Speed Sensor | Refer to Procedure 019-042 | G5.9, G8.3, G855, and GTA855 CM558/CM2358 | 4021702
Engine Speed Sensor | Refer to Procedure 019-042 | QSL9G CM558/CM2358 | 2883471
Engine Speed Sensor | Refer to Procedure 019-042 | KTA19GC CM558/CM2358 | 4021655
Engine Speed Sensor | Refer to Procedure 019-042 | QSK19G | 4021352
Engine Speed Sensor | Refer to Procedure 019-042 | GTA8.3 CM558/CM2358 | 4021654
Engine Speed Sensor | Refer to Procedure 019-042 | QSK23 CM2250 K109 | 4367358
Engine Speed Sensor | Refer to Procedure 019-042 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F114 | 4383734
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | Marine QSB6.7 CM2250 | 4310611
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 SN | 4310736
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F101 | 4310846
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F103 | 4310839
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5 CM2350 B104 | 4332646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD4.5 CM2150 B119 | 4358465
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2150 B120 | 4358470
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 L110 | 4358475
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F110 | 4358480
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z101 | 4358364
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z102 | 4358369
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2350 F109 | 4367218
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L111 | 4367223
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G110 | 4367323
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 L115 | 4388626
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active or more than one inactive count within the last 25 engine hours?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or more than one inactive count within the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

No repair.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Some natural gas engines are referenced as the engine speed sensor. Refer to Proceduere 019-042 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

  • 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the air gap between the crankshaft position sensor and the tone wheel.
  • Refer to Procedure 001-071 in the Associated Procedures Table or Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?
YES NO
No Repair

Replace the component that is causing the out of specification reading.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 121 - Engine Magnetic Crankshaft Speed/Position Lost One or Two Signals - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather Pack™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 121 active?
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the engine harness and engine speed sensor connector pins. | Damaged or dirty pins?
 | STEP 2B. Inspect the sensor for damage. | Damage found?
 | STEP 2C. Read the fault codes. | Fault Code 121 active?
 | STEP 2D. Check the resistance of the sensor. | Resistance between 1000 and 2000 ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Damaged or dirty pins?
 | STEP 3B. Read the fault codes. | Fault Code 121 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the engine speed sensor.

Guided Step 2A - Inspect the engine harness and engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the engine harness and engine speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the engine speed sensor for the following:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by the engine gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damage found?
YES NO

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 4B

Guided Step 2D - Check the resistance of the sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine speed sensor positive pin to the engine speed sensor negative pin in the engine speed sensor connector.
  • Measure the resistance from the engine speed sensor backup positive pin to the engine speed sensor backup negative pin in the engine speed sensor connector.

Resistance between 1000 and 2000 ohms?
YES NO
No Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensor
  • Make sure the sensor is installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine speed sensor positive pin in the engine speed sensor connector, sensor side, to engine block ground.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine speed sensor connector, sensor side, to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Disconnect engine harness connector A from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor positive pin in the engine harness sensor connector to the engine speed sensor positive pin in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness sensor connector to the engine speed sensor backup positive pin in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor negative pin in the engine harness sensor connector to the engine speed sensor negative pin in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor backup negative pin in the engine harness sensor connector to the engine speed sensor backup negative pin in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Disconnect the engine harness connector A from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance from the engine speed sensor positive pin in the engine harness ECM connector to the engine block ground.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness ECM connector to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.
  • Disconnect the engine harness connector A and connector B from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the engine speed sensor positive pin in the engine harness ECM connector A to all other pins in the connector.
  • Measure the resistance from the engine speed sensor positive pin in the engine harness ECM connector A to all the pins in engine harness connector B.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness ECM connector A to all other pins in the connector.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness ECM connector A to all the pins in engine harness connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 121 is inactive.

Fault Code 121 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 15-Aug-2012


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault code. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Voltage between 4.5 and 5.25-VDC?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine oil pressure sensor. Refer to Procedure 019-155 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 volt SUPPLY pin and the oil pressure RETURN pin on the engine oil pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.5 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil pressure sensor. Refer to Procedure 019-155 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector B RETURN pin and the engine oil pressure sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins, or repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness and all other pins in the engine connector B.
  • Measure the resistance between the oil pressure SIGNAL pin in engine harness connector B and all other pins in the engine connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the oil pressure 5 volt SUPPLY pin in engine harness connector B and all other pins in the ECM connector B.
  • Measure the resistance between the oil pressure 5 volt SUPPLY pin in engine harness connector B and all other pins in the ECM connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair the damaged pins, or repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 15-Aug-2012


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault code. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Voltage between 4.5 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine oil pressure sensor. Refer to Procedure 019-155 Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 volt SUPPLY pin and the oil pressure RETURN pin on the engine oil pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.5 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil pressure SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil pressure sensor. Refer to Procedure 019-155 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness,or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector B SUPPLY pin and the engine harness engine oil pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins, or repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector B SIGNAL pin and the engine harness engine oil pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair the damaged pins, or repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector B and all other pins in connector B.
  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector B and all other pins in connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins, or repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector B and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins, or repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to appropriate troubleshooting charts.

Last Modified: 15-Aug-2012


FAULT CODE 142 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1. Read the fault codes. | Fault Code 142 active?
STEP 2. | Check the oil pressure sensor accuracy. |
 | STEP 2A. Check the sensor accuracy. | Sensor reading is correct?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 142 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 142 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the oil pressure sensor accuracy.

Guided Step 2A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge.

NOTE: If necessary, increase the engine rpm to make it easier to see differences in the readings.

Sensor reading within ± 69 kPa [± 10 PSI] of mechanical gauge?
YES NO
No Repair

Replace the sensor if electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 142 is inactive.

NOTE: If the fault occurred at a particular speed, run the engine at that speed to verify the problem is corrected.

Fault Code 142 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 16-Aug-2012


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading correct?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Oil pressure greater than 69 kPa [10 psi]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 143 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute. Add atmospheric pressure to the gauge reading.

Sensor reading correct?
YES NO
No Repair

Replace the sensor if electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-155 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check the engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical oil pressure gauge.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the engine oil pressure.

  • Use the following procedure in Service Manual, QSL9 G CM558/CM2358, Bulletin 2883375. Refer to Procedure 007-052 in Section 7.

Oil pressure greater than 69 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Service Manual, QSL9 G CM558/CM2358, Bulletin 2883375, in Section TS.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 143 is inactive.

NOTE: If the fault occurred at a particular speed, run the engine at that speed to verify the problem is corrected.

Fault Code 143 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 144 inactive?
STEP 2. | Check the coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Resistance between 175 ohms and 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant temperature sensor and circuit.

Guided Step 2A - Inspect the coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the coolant temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 175 ohms and 274k ohms?
YES NO
No Repair

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature RETURN pin and the ECM connector A RETURN pin.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair the damaged pins, or repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature sensor SIGNAL pin and the ECM connector B SIGNAL pin.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair the damaged pins, or repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the coolant temperature SIGNAL pin in engine harness to all other pins in the engine ECM connector B.
  • Measure the resistance between the coolant temperature SIGNAL pin in engine harness and all pins in engine ECM connector A.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the signal pin has been detected in the engine harness.

Repair the damaged pins, or repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive faults.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 16-Aug-2012


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female WeatherPack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault code and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A and connector B from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector B and all other pins in the engine connector B.
  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector B and all other pins in the engine connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector B and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 16-Aug-2012


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 146 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the temperature differ more than 5°C or 10°F?
STEP 3. | Check the coolant temperature sensor. |
 | STEP 3A. Inspect the coolant temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 146 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 146 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the coolant temperature reading on INSITE™ electronic service tool, to the reading from the temperature probe.

NOTE: If there is not a temperature measuring device available, answer “NO” to this step.

Does the temperature differ more than 5°C or 10°F?
YES NO

Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the coolant temperature sensor.

Guided Step 3A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it run for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146 active?
YES NO

Reference the Coolant Temperature Above Normal troubleshooting symptom tree in Service Manual, QSL9 G CM558/CM2358, Bulletin 2883375, in Section TS.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 146 is inactive.

Fault Code 146 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 151 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Temperature differs more than 5°C or 10°F?
STEP 3. | Check the coolant temperature sensor. |
 | STEP 3A. Inspect the coolant temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 151 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 151 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the coolant temperature reading on INSITE™ electronic service tool to the reading from the temperature probe.

NOTE: If there is not a temperature measuring device available, answer “NO” to this step.

Temperature differs more than 5°C or 10°F?
YES NO

Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the coolant temperature sensor.

Guided Step 3A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it run for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151 inactive?
YES NO

Reference the Coolant Temperature Above Normal troubleshooting symptom tree in Service Manual, QSL9 G CM558/CM2358, Bulletin 2883375, in Section TS.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 151 is inactive.

Fault Code 151 active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold 1 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance | Resistance between 175 and 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 1 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold 1 temperature sensor.

Action

Inspect the engine harness and intake manifold 1 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or damaged pins, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold absolute pressure and temperature sensor. Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the intake manifold 1 temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Resistance between 175 and 274k ohms?
YES NO

Reference the appropriate wiring diagram for resistance and temperature.

Replace the intake manifold absolute pressure and temperature sensor. Refer to Procedure 019-354 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the temperature RETURN pin and the ECM connector A RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine intake manifold 1 temperature sensor SIGNAL pin and the ECM connector A SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature SIGNAL pin in the engine harness and all other pins in the ECM connector A.
  • Measure the resistance between the intake manifold temperature SIGNAL pin in the engine harness and all other pins in the ECM connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 153 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts

Last Modified: 17-Aug-2012


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and intake manifold air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold absolute pressure and temperature sensor. Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold absolute pressure and temperature sensor. Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A and connector B from the ECM.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold absolute pressure and temperature sensor SIGNAL pin in the engine harness ECM engine connector B and all other pins in the engine connector B.
  • Measure the resistance between the intake manifold absolute pressure and temperature sensor SIGNAL pin in the engine harness ECM engine connector B and all other pins in the engine connector A.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold absolute pressure and temperature sensor SIGNAL pin in engine harness ECM connector B and ground.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 17-Aug-2012


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 155 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Temperature differs more than 5°C or 10°F?
STEP 3. | Check the intake manifold absolute pressure and temperature sensor. |
 | STEP 3A. Inspect the intake manifold absolute pressure and temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 155 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 155 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the intake manifold temperature reading on INSITE™ electronic service tool to the reading from the probe.

NOTE: If a temperature measuring device is not available, answer “NO” to this step.

Temperature differs more than 5°C or 10°F?
YES NO

Replace the intake manifold absolute pressure and temperature sensor. Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the intake manifold absolute pressure and temperature sensor.

Guided Step 3A - Inspect the intake manifold absolute pressure and temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold absolute pressure and temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES NO

Reference the Intake Manifold Air Temperature Above Normal troubleshooting symptom tree in Service Manual, QSL9 CM558/CM2358, Bulletin 2883375, in Section TS.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 155 is inactive.

Fault Code 155 inactive?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 177 - Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test leads when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 177 active?
STEP 2. | Check the electronic throttle control actuator. |
 | STEP 2A. Inspect the electronic throttle control actuator and engine harness connector pins. | Damaged or dirty pins?
 | STEP 2B. Read the fault codes. | Fault Code 177 active?
STEP 3. | Verify the throttle operation. |
 | STEP 3A. Verify the throttle operation. | Gas throttle control passed test?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Damaged or dirty pins?
 | STEP 4B. Read the fault codes. | Fault Code 177 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 4E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 4F. Check the throttle actuator for an obstruction or damage. | Obstruction or damage?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 177 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Read the fault codes.

Fault Code 177 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the electronic throttle control actuator.

Guided Step 2A - Inspect the electronic throttle control actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic throttle control actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair or replace the engine harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure to replace the throttle actuator in Service Manual, QSL9 CM558/CM2358, Bulletin 2883375. Refer to Procedure 005-052 in Section 5.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 177 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 5B

Guided Step 3 - Verify the throttle operation.

Guided Step 3A - Verify the throttle operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify proper throttle operation.

  • Use INSITE™ electronic service tool to activate the gas throttle control test.

Gas throttle control passed test?
YES NO
No Repair

Use the following procedure to replace the throttle actuator in Service Manual, QSL9 CM558/CM2358, Bulletin 2883375. Refer to Procedure 005-052 in Section 5.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Damaged or dirty pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 177 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the throttle actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the throttle plate position FEEDBACK pin in the engine harness connector to the throttle plate position FEEDBACK pin in the engine harness actuator connector.
  • Measure the resistance from the throttle command SUPPLY pin in the engine harness connector to the throttle command SUPPLY pin in the engine harness actuator connector.
  • Measure the resistance from the throttle command RETURN pin in the engine harness connector to the throttle command RETURN pin in the engine harness actuator connector.
  • Measure the resistance from the throttle command RETURN pin in the engine harness connector to the throttle command RETURN pin in the engine harness actuator connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the throttle actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the throttle position (+) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance from the throttle actuator (+) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance from the throttle position (-) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance from the throttle actuator (-) pin in the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the throttle actuator.
  • Disconnect the engine harness from the OEM harness at the 47-pin OEM connectors.
  • Disconnect engine harness connector B and connector A from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle position (+) pin in engine harness connector B and all pins in engine harness ECM connector A.
  • Measure the resistance between the throttle actuator (+) pin in engine harness connector B and all pins in engine harness ECM connector A.
  • Measure the resistance between the throttle position (-) pin in engine harness connector B and all pins in engine harness ECM connector A.
  • Measure the resistance between the throttle actuator (-) pin in engine harness connector B and all pins in engine harness ECM connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check the throttle actuator for an obstruction or damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the throttle actuator for an obstruction or damage.

  • Check the throttle plate for straightness.
  • If the plate is bent, replace the throttle actuator.

Obstruction or damage?
YES NO

Use the following procedure to replace the throttle actuator in Service Manual, QSL9 CM558/CM2358, Bulletin 2883375. Refer to Procedure 005-052 in Section 5.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 177 is inactive.

Fault Code 177 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts

Last Modified: 11-Jun-2014


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 187 active?
STEP 2. | Check the oil rifle pressure/temperature sensors and sensor supply circuit. |
 | STEP 2A. Inspect the engine oil rifle pressure/temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 187 active?
STEP 3. | Check the 47-pin OEM connector. |
 | STEP 3A. Inspect the 47-pin OEM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Check the catalyst extension harness. |
 | STEP 4A. Inspect the pre-catalyst temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 4A-1. Check the circuit response. |
 | STEP 4A-2. Check for a pin-to-pin short circuit. |
 | STEP 4A-3. Check for a pin-to-ground short circuit. |
 | STEP 4B. Inspect the post-catalyst temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 4B-1. Check the circuit response. |
 | STEP 4B-2. Check for a pin-to-pin short circuit. |
 | STEP 4B-3. Check for a pin-to-ground short circuit. |
 | STEP 4C. Check the customer terminal strip. | Greater than 100k ohms?
STEP 5. | Check the ECM and engine harness. |
 | STEP 5A. Check the ECM and engine harness. | Dirty or damaged pins?
 | STEP 5B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 5C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 5D. Inspect the engine harness and resistor pack connector pins. | Dirty or damaged pins?
 | STEP 5E. Check for an inactive fault code. | Fault Code 187 inactive?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil rifle pressure/temperature sensors and sensor supply circuit.

Guided Step 2A - Inspect the engine oil rifle pressure/temperature sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil rifle pressure/temperature sensor from the engine harness.

Action

Inspect the oil rifle pressure/temperature sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil rifle pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil rifle pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged sensor has been detected.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Replace the oil rifle pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the 47-pin OEM Connector.

Guided Step 3A - Inspect the 47-pin OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin OEM connector from the engine harness.

Action

Inspect the 47-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector.

Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin OEM connector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 2 pin and all other pins in the 47-pin OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply line number 2 line has been detected in the OEM connector.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin OEM connector from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor SUPPLY 2 pin in the 47-pin OEM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply line number 2 line has been detected in the OEM connector.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the catalyst extension harness.

Guided Step 4A - Inspect the pre-catalyst temperature sensor and connector pins connected to sensor SUPPLY number 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-catalyst temperature sensor from the OEM harness.

Action

Inspect the pre-catalyst temperature sensor harness and OEM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the aftertreatment exhaust gas temperature sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 6A

Go to 4A-1

Guided Step 4A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-catalyst temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the aftertreatment exhaust gas temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 4A-2

Go to 6A

Guided Step 4A-2 - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin OEM connector from the engine harness.
  • Disconnect the aftertreatment exhaust gas temperature sensor from the extension harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor temperature SUPPLY pin and the rest of the pins on the four catalyst sensor connectors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply line 2 line has been detected in the OEM connector.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4A-3

Go to 6A

Guided Step 4A-3 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin OEM connector from the engine harness.
  • Disconnect the aftertreatment exhaust gas temperature sensor from the extension harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor temperature SUPPLY pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor SUPPLY 2 wire has been detected in the OEM connector

Repair or replace the engine harness

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4B

Go to 6A

Guided Step 4B - Inspect the post-catalyst temperature sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-catalyst temperature sensor from the OEM harness.

Action

Inspect the post-catalyst temperature sensor harness and OEM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-218 in Section 19.
  • Replace the harness. Refer to the OEM service manual.
  • Replace the aftertreatment exhaust gas temperature sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 6A

Go to 4B-1

Guided Step 4B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-catalyst temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the aftertreatment exhaust gas temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 4B-2

Go to 6A

Guided Step 4B-2 - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin OEM connector from the engine harness.
  • Disconnect the post-catalyst temperature sensor from the extension harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor temperature SUPPLY pin and the rest of the pins on the four catalyst sensor connectors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor SUPPLY 2 wire has been detected in the OEM connector.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4B-3

Go to 6A

Guided Step 4B-3 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin OEM connector from the engine harness.
  • Disconnect the aftertreatment exhaust gas temperature sensor from the extension harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor temperature SUPPLY pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply line 2 line has been detected in the OEM connector

Repair or replace the engine harness

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4C

Go to 6A

Guided Step 4C - Check the customer terminal strip.

Conditions

  • Disconnect the 47-pin OEM connector from the engine harness
  • Disconnect the pre and post-catalyst oxygen and aftertreatment exhaust gas temperature sensors (four altogether) from the catalyst extension harnesses.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment exhaust gas temperature supply (sensor SUPPLY 2) terminal on the customer terminal strip and ground.
  • Measure the resistance between the aftertreatment exhaust gas temperature supply (sensor SUPPLY 2) terminal on the customer terminal strip and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor SUPPLY 2 wire has been detected in the customer terminal strip.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the customer terminal strip . Refer to the OEM service manual.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and engine harness.

Guided Step 5A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Disconnect the oil rifle pressure/temp sensor from the engine harness.
  • Disconnect the resistor pack from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector B and all other pins in the engine connector B.
  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector B and all other pins in the engine connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor SUPPLY wire number 2 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Disconnect the oil rifle pressure/temperature sensor from the engine harness.
  • Disconnect the resistor pack from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector B and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the resistor pack. Refer to Procedure 019-482 in Section 19.

A pin-to-ground short circuit on the sensor SUPPLY number 2 wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5D

Go to 5E

Guided Step 5D - Inspect the engine harness and resistor pack connector pins

Conditions

  • Turn keyswitch OFF.
  • Disconnect the resistor pack from the engine harness connector.

Action

Check the resistor pack resistance. Inspect the engine harness and resistor pack connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the resistor pack connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the resistor pack, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the resistor pack. Refer to Procedure 019-482 in Section 19.

No Repair

Go to 5E

Go to 6A

Guided Step 5E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

6B

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 187 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Aug-2012


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 2. | Check the oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Resistance between 175 ohms and 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 212 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil temperature sensor and circuit.

Guided Step 2A - Inspect the oil pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Inspect the engine harness and oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or damaged pins, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repalce the sensor. Refer to Procedure 019-155 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the oil temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 175 and 274k ohms?
YES NO
No Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair or replace the engine harness or damaged pins, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the oil temperature RETURN pin and the ECM connector A RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the ECM connector A SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the oil temperature SIGNAL pin in engine harness and all other pins in the ECM connector A.
  • Measure the resistance between the oil temperature SIGNAL pin in engine harness and all other pins in the ECM connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 212 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 17-Aug-2012


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 213 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-155 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil temperature sensor.

  • Refer to Procedure 019-155 in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B and connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature SIGNAL pin in engine harness ECM connector B and all other pins in the engine connector B.
  • Measure the resistance between the engine oil temperature SIGNAL pin in engine harness ECM connector B and all other pins in the engine connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine oil temperature SIGNAL pin in the engine harness ECM connector A and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-ground short circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 213 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 17-Aug-2012


FAULT CODE 214 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 214 active?
STEP 2. | Check the engine oil pressure/temperature sensor. |
 | STEP 2A. Inspect the engine harness and engine oil pressure/temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 214 active?
 | STEP 2C. Verify engine oil temperature sensor. | Does temperature differ more than 5°C or 10°F?
 | STEP 2D. Check the resistance of the sensor. | 300 to 90k ohms?
 | STEP 2E. Read the fault codes. | Fault Code 214 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 214 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil pressure/temperature sensor.

Guided Step 2A - Inspect the engine harness and engine oil pressure/temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure/temperature sensor.

Action

Inspect the engine harness and engine oil pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-155 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Verify engine oil temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify engine oil temperature sensor.

  • Verify the engine oil temperature measurement by comparing the INSITE™ electronic service tool reading to the thermocouple reading.

Does temperature differ more than 5°C or 10°F?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the resistance of the sensor.

Conditions

  • Disconnect engine harness connector B from the ECM.
  • Disconnect the engine oil pressure/temperature sensor from the engine harness.

Action

Check the resistance of the sensor.

  • Measure the resistance from the oil temperature SIGNAL pin to the oil pressure/temperature RETURN pin in the engine oil pressure/temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

300 to 90k ohms?
YES NO
No Repair

Replace the sensor.

  • Refer to Procedure 019-155 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 3B

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 214 is inactive.

Fault Code 214 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Aug-2012


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 227 active?
STEP 2. | Check the oil rifle pressure/temperature sensors and sensor supply circuit. |
 | STEP 2A. Inspect the engine oil rifle pressure/temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Check the 47-pin OEM connector. |
 | STEP 3A. Inspect the 47-pin OEM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Check the catalyst extension harness. |
 | STEP 4A. Inspect the pre-catalyst temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 4A-1. Check the circuit response. |
 | STEP 4A-2. Check for a pin-to-ground short circuit. |
 | STEP 4B. Inspect the post-catalyst temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 4B-1. Check the circuit response. |
 | STEP 4B-2. Check for a pin-to-ground short circuit. |
 | STEP 4C. Check the customer terminal strip. | Greater than 100k ohms?
STEP 5. | Check the ECM and engine harness. |
 | STEP 5A. Check the ECM and engine harness. | Dirty or damaged pins?
 | STEP 5B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 5C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 5D. Inspect the engine harness and resistor pack connector pins. | Dirty or damaged pins?
 | STEP 5E. Check for an inactive fault code. | Fault Code 227 inactive?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil rifle pressure/temperature sensors and sensor supply circuit.

Guided Step 2A - Inspect the engine oil rifle pressure/temperature sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil rifle pressure/temperature sensor from the engine harness.

Action

Inspect the oil rifle pressure/temperature sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil rifle pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil rifle pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO
No Repair

A damaged sensor has been detected.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Replace the oil rifle pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the 47-pin OEM connector.

Guided Step 3A - Inspect the 47-pin OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin OEM connector from the engine harness.

Action

Inspect the 47-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector.

Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin OEM connector from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor SUPPLY 2 pin in the 47-pin OEM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor SUPPLY wire number 2 wire has been detected in the OEM connector.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the catalyst extension harness

Guided Step 4A - Inspect the pre-catalyst temperature sensor and connector pins connected to sensor SUPPLY number 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-catalyst temperature sensor from the OEM harness.

Action

Inspect the pre-catalyst temperature sensor harness and OEM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the aftertreatment exhaust gas temperature sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 6A

Go to 4A-1

Guided Step 4A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment exhaust gas temperature sensor from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the aftertreatment exhaust gas temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 4A-2

Go to 6A

Guided Step 4A-2 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin OEM connector from the engine harness.
  • Disconnect the pre-catalyst temperature sensor from the extension harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor temperature SUPPLY pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply line 2 line has been detected in the OEM connector

Repair or replace the engine harness

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4B

Go to 6A

Guided Step 4B - Inspect the aftertreatment exhaust gas temperature sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment exhaust gas temperature sensor from the OEM harness.

Action

Inspect the post-catalyst temperature sensor harness and OEM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-218 in Section 19.
  • Replace the harness. Refer to the OEM service manual.
  • Replace the aftertreatment exhaust gas temperature sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 6A

Go to 4B-1

Guided Step 4B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-catalyst temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the aftertreatment exhaust gas temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 4B-2

Go to 6A

Guided Step 4B-2 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin OEM connector from the engine harness.
  • Disconnect the post-catalyst temperature sensor from the extension harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor temperature SUPPLY pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor SUPPLY 2 wire has been detected in the OEM connector

Repair or replace the engine harness

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4C

Go to 6A

Guided Step 4C - Check the customer terminal strip.

Conditions

  • Disconnect the 47-pin OEM connector from the engine harness.
  • Disconnect the pre and post-catalyst oxygen and aftertreatment exhaust gas temperature sensors (four altogether) from the catalyst extension harnesses.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the pre-catalyst temperature supply (sensor SUPPLY 2) terminal on the customer terminal strip and ground.
  • Measure the resistance between the post-catalyst temperature supply (sensor SUPPLY 2) terminal on the customer terminal strip and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor SUPPLY 2 wire has been detected in the customer terminal strip.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the customer terminal strip. Refer to the OEM service manual.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and engine harness.

Guided Step 5A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Disconnect the oil rifle pressure/temperature sensor from the engine harness.
  • Disconnect the resistor pack from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector B and all other pins in the engine connector B.
  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector B and all other pins in the engine connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor SUPPLY number 2 wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Disconnect the oil rifle pressure/temperature sensor from the engine harness.
  • Disconnect the resistor pack from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector B and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the resistor pack. Refer to Procedure 019-482 in Section 19.

A pin-to-ground short circuit on the sensor SUPPLY line number 2 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5D

Go to 5E

Guided Step 5D - Inspect the engine harness and resistor pack connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the resistor pack from the engine harness connector.

Action

Check the resistor pack resistance. Inspect the engine harness and resistor pack connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the resistor pack connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the resistor pack, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the resistor pack. Refer to Procedure 019-482 in Section 19.

No Repair

Go to 5E

Go to 6A

Guided Step 5E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

6B

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Aug-2012


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

If the engine speed stays above 2000 rpm, the engine must be shut off immediately or engine damage will occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for governor faults. | Did a governor malfunction cause this issue?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine speed sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an inactive fault code at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed

Guided Step 1A - Check for governor faults.

Conditions

  • Turn keyswitch OFF.

Action

Check for governor faults.

  • Reference the Master Repair Manual, QSL9 G CM558/CM2358 Panel System, Bulletin 2883471, for information on how to complete the check.

Did a governor malfunction cause this issue?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Check the engine rpm with INSITE™ electronic service tool.

  • Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the panel tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor as outlined in Fault Code 121.

Go to 1C

Fault Code 121

Guided Step 1C - Inspect the engine harness and engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensors.

Action

Inspect the engine harness and engine speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged connector pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an inactive fault code at low engine rpm.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code at low engine rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Inactive fault code at low rpm?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test the engine.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 234 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning. A fault mode should have been detected.

Go to 2B

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 234 is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-Jun-2014


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 238 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2B-1. Check for a short circuit to ground. |
 | STEP 2C. Check for an inactive fault code. | Fault Code 238 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Make sure all components connected to sensor supply number 3 circuit are disconnected.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 3 pin in engine harness ECM connector B and all other pins in the engine connector B.
  • Measure the resistance between the sensor SUPPLY number 3 pin in engine harness ECM connector B and all other pins in the engine connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 3 circuit line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Make sure all components connected to sensor supply number 3 circuit are disconnected.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor SUPPLY voltage number 3 pin in the engine harness ECM connector B and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply number 3 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 238 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Aug-2012


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 239 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 239 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 239 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A and connector B from the ECM.
  • Make sure all components connected to sensor supply number 3 circuit are disconnected.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 3 pin in engine harness ECM connector B and all other pins in the engine connector B.
  • Measure the resistance between the sensor SUPPLY number 3 pin in engine harness ECM connector B and all other pins in the engine connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 3 circuit line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 239 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Aug-2012


FAULT CODE 244 - Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the 47-pin harness to the OEM panel. |
 | STEP 1A. Inspect the 47-pin harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1C. Check the OEM control panel relays. | Any issues?
 | STEP 1D. Check the OEM control panel wiring. | Wiring damaged?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 244 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the 47-pin harness to the OEM panel.

Guided Step 1A - Inspect the 47-pin harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel connector.

Action

Inspect the 47-pin harness to the OEM panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair the 47-pin harness to the OEM panel connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel connector.
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from red stop lamp driver pin on the 47-pin harness to the OEM panel connector to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

  • Repair or replace the 47-pin harness to the OEM panel. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check the OEM control panel relays.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM control panel.
  • Remove the engine shutdown relay (CR5).

Action

Check the engine shutdown relay resistance in the OEM control panel across the coil.

64 to 475 ohms?
YES NO
No Repair

Replace the relay.

  • Refer to the OEM service manual.

Go to 1D

Go to 3A

Guided Step 1D - Check the OEM control panel wiring.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel from engine harness.

Action

Check the red stop lamp driver circuit wiring in the OEM control panel.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Wiring damaged?
YES NO

Replace or repair damaged wiring connectors.

  • Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel connector from the engine harness.
  • Disconnect the engine harness from the engine connector A.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from red stop lamp driver in the ECM connector to all of the other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel connector from the engine harness.
  • Disconnect the engine harness from engine connector A.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from red lamp driver pin in the engine connector A to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let it idle for 1 minute.

Fault Code 244 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 17-Aug-2012


FAULT CODE 254 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441 and 442 or 477 and 478 active?
STEP 2. | Check the 47-pin harness to the OEM panel. |
 | STEP 2A. Inspect the 47-pin harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C. Check the OEM control panel relays. | Any issues?
 | STEP 2D. Check the OEM control panel wiring. | Wiring damaged?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 254 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 254 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the 47-pin harness to the OEM panel.

Guided Step 2A - Inspect the 47-pin harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel connector from engine harness.

Action

Inspect the 47-pin harness to the OEM panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair the 47-pin harness to the OEM panel connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the 47pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel connector from engine harness.
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from the red stop lamp driver pin on the 47-pin harness to the OEM panel connector to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the 47-pin harness to the OEM panel. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check the OEM control panel relays.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to OEM control panel.
  • Remove the engine shutdown relay.

Action

Check the engine shutdown relay resistance in the OEM control panel across the coil.

64 to 475 ohms?
YES NO
No Repair

Replace the relay.

  • Refer to the OEM service manual.

Go to 2D

Go to 5A

Guided Step 2D - Check the OEM control panel wiring.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel from engine harness.

Action

Check the red stop lamp driver circuit wiring in the OEM control panel.

Use a wiring diagram for connector pin identification.

Wiring damaged?
YES NO

Replace or repair damaged wiring connectors.

  • Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the engine harness from the 47-pin harness to the OEM panel and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the engine harness from the 47-pin harness to the OEM panel.
  • Disconnect the power to the OEM control panel.
  • Disconnect the ECM connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine fuel shutoff valve driver pin on the 47-pin engine harness connector to all other pins in the 47-pin engine harness connector.
  • Also perform these checks on the 47-pin harness to OEM panel connector engine fuel shutoff valve driver pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the engine harness from the 47-pin harness.
  • Disconnect the ECM connectors.
  • Disconnect the power to the OEM control panel.

Action

Check for an open circuit in the SUPPLY and RETURN wires.

  • Measure the resistance from the engine fuel shutoff valve driver pin on the 47-pin engine harness connector to the engine fuel shutoff valve driver pin the engine connector A.
  • Measure the restance from the engine fuel shutoff valve driver pin on the engine connector A to the engine fuel shutoff valve driver pin the 47-pin engine harness connector.
  • Also perform these checks on the 47-pin harness to OEM panel connector engine fuel shutoff valve driver pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in RUN mode and crank engine.

Action

Check for the appropriate CM558/CM2358 response.

  • Monitor for 24-VDC at the relay coil.
  • Use the electronic service tool to verify the fault codes.

24-VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in RUN mode and operate engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 254 is inactive.

Fault Code 254 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Jun-2014


FAULT CODE 277 - Electronic Fuel Injection Control Valve Circuit - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 277 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
 | STEP 2D. Check the butterfly valve. | Debris found or valve difficult to move?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 277 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 277 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 277 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2B - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

  • Refer to Procedure 019-102 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the butterfly valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the butterfly valve.

Remove the electronic fuel control valve assembly from the engine fuel supply. Refer to Procedure 019-102 in Section 19.

Inspect the butterfly valve and housing for the following:

  • Debris
  • Mineral buildup
  • Difficult movement of the butterfly valve.

Debris found or valve difficult to move?
YES NO

Remove the blockage and clean the electronic fuel control valve, if possible. If the electronic fuel control valve is damaged or not repairable, replace the fuel control valve assembly unit.

  • Refer to Procedure 019-102 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the electronic fuel control valve connector to the engine harness connector.
  • Disconnect the engine harness connector from the ECM 47-pin connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 47-pin connector.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Codes 277 active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the harness.

  • Refer to Procedure 019-043 in Section 19.

Replace the electronic fuel control valve.

  • Refer to Procedure 019-102 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 277 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 17-Aug-2012


FAULT CODE 343 - Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active?
 | STEP 1B. Check the power supply. | Constant +24-VDC power supply to the ECM?
 | STEP 1C. Check the ECM for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1D. Calibrate the ECM. | ECM calibrated successfully?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 343 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use the keyswitch to recycle the power to the ECM.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Disconnect the 47-pin harness to the OEM panel connector from the engine harness.
  • Inspect the power supply to the ECM.
  • Check the 47-pin harness as a possible source of an intermittent power supply.
  • Shake the connections and harness and monitor the 24 volt supply for intermittent connections.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Constant +24-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 47-pin harness connector.

  • Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check the ECM for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

ECM calibrated successfully?
YES NO
No Repair

Active fault codes present.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 343 is inactive.

Fault Code 343 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Feb-2017


FAULT CODE 346 - Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 346 active?
 | STEP 1B. Check the power supply. | Constant +24-VDC power supply to the ECM?
 | STEP 1C. Check the ECM short to ground. | Greater than 100k ohms?
 | STEP 1D. Calibrate the ECM. | Fault Code 346 active after recalibration?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 346 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 346 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2B

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Disconnect the 47-pin harness to the OEM panel connector from the engine harness.
  • Inspect the power supply to the ECM
  • Check the 47-pin harness as a possible source of an intermittent power supply
  • Make certain the power supply to the ECM is constant and not intermittent.
  • Shake the connections and harness and monitor the 24 volt supply for intermittent connections.

Refer to the engine diagram and the OEM panel diagrams for connector pin identification.

Constant +24-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 47-pin harness connector.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to the OEM service manual.

Go to 1C

Go to 2A

Guided Step 1C - Check the ECM short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

Fault Code 346 active after recalibration?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 346 is inactive.

Fault Code 346 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Feb-2017


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 2. | Check the sensor and sensor supply circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure/temperature sensor and connector pins connected to sensor supply 1. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure/temperature sensor and connector pins connected to sensor supply number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold 1 pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the intake manifold 1 pressure/temperature sensor.

  • Refer to Procedure 019-354 in Section 19.

Go to 2B

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A and connector B from the ECM.
  • Disconnect the intake manifold 1 pressure/temperature sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector A and all other pins in the engine connector A.
  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector A and all pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the intake manifold 1 pressure/temperature sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin short to ground.

  • Measure the resistance between the sensor supply number 1 pin in the engine harness ECM connector A and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Fault Codes 352 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Aug-2012


FAULT CODE 354 - Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 386. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 354 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 355 active and Fault Code 354 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 354 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 354 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 354 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 386.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Replace the intake manifold pressure sensor. Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 355 active and Fault Code 354 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the SUPPLY voltage and RETURN circuit.

  • Measure the voltage between the 5-VDC SUPPLY pin and the intake manifold pressure RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector RETURN pin and the intake manifold pressure sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in the engine harness to all other pins in the engine connector A.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in the engine harness connector A to all pins in engine harness ECM connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure sensor 5-VDC SUPPLY pin in engine harness connector A and all other pins in the ECM connector A.
  • Measure the resistance between the intake manifold pressure 5-VDC SUPPLY pin in engine harness connector A and all pins in engine harness ECM connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 354 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Aug-2012


FAULT CODE 355 - Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 355 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 354 active and Fault Code 355 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 355 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness signal circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 355 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 355 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure 1 sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure 1 sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure 1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure 1 sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the SUPPLY voltage and RETURN circuit.

  • Measure the voltage between the 5-VDC SUPPLY pin and the intake manifold pressure RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure 1 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake pressure SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 354 active and Fault Code 355 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure 1 sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins.

Repair or replace the harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector B SUPPLY pin and the intake manifold pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector B SIGNAL pin and the intake manifold pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector A and all other pins in the connector A.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector A and all pins in connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector A and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 355 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Aug-2012


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engne control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 386 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 386 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine connector A and connector B from the ECM.
  • Disconnect intake manifold 1 pressure/temperature sensor from the engine harness.
  • Disconnect all components connected to sensor supply 1.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 1 pin in the engine connector A and all other pins in the engine connector A.
  • Measure the resistance between the sensor SUPPLY 1 pin in the engine connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the sensor supply 1 circuit has been detectd in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Aug-2012


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading within 69 kPa [10 psi] of mechanical gauge?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Oil pressure greater than 69 kPa [10 psi]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 415 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge.

Sensor reading within 69 kPa [10 psi] of mechanical gauge?
YES NO
No Repair

Replace the sensor if the electronic service tool reading differs, more than allowed, from the mechanical gauge reading. Refer to Procedure 019-155 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check the engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical oil pressure gauge
  • Connect INSITE™ electronic service tool
  • Engine running at idle speed.

Action

Check the engine oil pressure.

  • Use the following procedure in Service Manual, QSL9 G CM558/CM2358, Bulletin 2883375. Refer to Procedure 007-052 in Section 7.

Oil pressure greater than 69 kPa [10 psi]?
YES NO
No Repair

Reference the Low Oil Pressure troubleshooting symptom tree in Service Manual, QSL9 G CM558/CM2358, Bulletin 2883375, in Section TS.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 415 is inactive.

NOTE: If the fault was at a particular speed, run the engine at that speed to verify the problem is corrected.

Fault Code 415 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 421 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 421 active?
 | STEP 1B. Verify engine oil temperature is high. | Engine oil temperature high?
STEP 2. | Check the engine oil pressure/temperature sensor. |
 | STEP 2A. Inspect the engine harness and engine oil pressure/temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 421 active?
 | STEP 2C. Check the resistance of the sensor. | Resistance between 300 and 90k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 421 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 421 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3B

Guided Step 1B - Verify engine oil temperature is high.

Conditions

  • Turn keyswitch ON.

Action

Verify engine oil temperature is high.

  • Verify engine oil temperature by using the mechanical gauge.

Use the following procedure for oil temperature specifications in Service Manual, QSL9 G CM558/CM2358, Bulletin 2883375. Refer to Procedure 018-017 in Section V.

Engine oil temperature high?
YES NO

Reference the Engine Oil Temperature Specification troubleshooting symptom tree in Service Manual, QSL9 G CM558/CM2358, Bulletin 2883375 in Section TS.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine oil pressure/temperature sensor.

Guided Step 2A - Inspect the engine harness and engine oil pressure/temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the engine harness from the engine oil pressure/temperature sensor.

Action

Inspect the engine harness and oil pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-155 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 421 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the resistance of the sensor.

Conditions

  • Disconnect engine harness connector B from the ECM.
  • Disconnect the engine oil pressure/temperature sensor from the engine harness.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine oil temperature SIGNAL pin to the engine oil pressure/temperature RETURN pin in the engine oil pressure/temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 300 and 90k ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 421 is inactive.

Fault Code 421 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 426 - SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement: Part Number 3163151 - ECM Bench Top Calibration Harness and Part Number 3164185 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check SAE J1939 data link communication. |
 | STEP 1A. Check for engine control module (ECM) communication with INSITE™ electronic service tool. | INSITE™ electronic service tool communicates with ECM?
 | STEP 1B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communication with the ECM bench calibration harness. | INSITE™ electronic service tool communicate with the ECM?
 | STEP 1D. Check terminating resistors and harness for opens or shorts. | Resistance between 50 and 70 ohms?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the SAE J1939 data link communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to communicate with the ECM.

  • Start INSITE™ electronic tool and connect to the ECM using INLINE™ II (J1939) ECM connection.
  • Use INSITE™ electronic service tool to communicate with the ECM.

INSITE™ electronic service tool communicates with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

 No Repair

Refer to the OEM service manual for information on troubleshooting and vehicle SAE J1939 data link network.

Go to 1B

Guided Step 1B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connector A.

Action

Inspect the OEM harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damaged
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connectors and pins.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the harness. Refer to Procedure 019-043 in Section 19.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector A.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using INLINE™ (J1939) ECM connection.

INSITE™ electronic service tool communicates with the ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM service manual for information on troubleshooting the vehicle SAE J1939 data link network.

 No Repair

Refer to the OEM service manual.

Reference the ECM - No Communication Troubleshooting Tree

Guided Step 1D - Check terminating resistors and harness for opens or shorts.

Conditions

  • Turn keyswitch OFF.

Action

Check for open or shorts.

  • Measure the resistance across the J1939- and J1939+ at the 9-pin service port connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An open or short in the engine wiring harness, or damaged terminating resistor, has been detected.

Determine damaged section of harness or which terminating resistor (in the engine harness or CIB) is damaged.

  • Repair or replace the harness or resistor.

Contact a Cummins® Authorized Repair Location.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Dsable the fault code.

  • Verify Fault Code 426 is inactive.

Fault Code 426 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

  • Go to the appropriate troubleshooting steps.

Last Modified: 17-Aug-2012


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 2. | Check for a malfunctioning voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
 | STEP 2B. Determine battery voltage. | Battery voltage between 11.5 and 15.0-VDC?
STEP 3. | Check the 47-pin harness to the OEM control panel. |
 | STEP 3A. Inspect the 47-pin harness to the OEM control panel. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the OEM control panel. | Damaged fuse?
 | STEP 4A-1. Check fuse for appropriate rating |
 | STEP 4A-2. Check the alternator. |
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin-to-pin short in the unswitched battery supplies in the engine harness. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for a malfunctioning voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay or power lockout switch.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay or power lockout switch.

Refer to the OEM service manual.

Relay or lockout switch installed?
YES NO

Inspect the voltage shutoff relay or lockout switch.

Refer to the OEM service manual.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal during keyswitch ON and cranking conditions.

Turn keyswitch ON.

  • At least 23-VDC

Cranking condition:

  • At least 18-VDC.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Battery voltage acceptable in keyswitch ON and cranking conditions?
YES NO
No Repair

A damaged battery has been detected.

Replace the damaged battery or batteries. Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 3 - Check the 47-pin harness to the OEM control panel.

Guided Step 3A - Inspect the 47-pin harness to the OEM control panel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the 47-pin OEM control panel connector.

Action

Inspect the 47-pin harness to the OEM control panel and connector pins.

  • Refer to the OEM service manual.

Dirty or damaged pins?
YES NO

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 4B

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the OEM control panel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuses in the OEM control panel.

Refer to service literature for the OEM control panel to perform the following:

  • Open the OEM control panel
  • Locate the glass fuses
  • Inspect the fuses.

Damaged fuse?
YES NO

A damaged or blown fuse has been located.

  • Replace the fuse. Refer to OEM control panel service literature.

 No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check the fuse for appropriate rating.

Conditions

  • Disconnect the 47-pin harness to the OEM control panel.

Action

Inspect the fuse rating.

  • Refer to OEM control panel service literature for fuse location, removal, and installation instructions.

Fuse rated at 10 amperes?
YES NO
No Repair

Replace with 10 amp fuse. Refer to the OEM control panel service literature for removal and installation instructions.

Go to 5A

Go to 5A

Guided Step 4A-2 - Check the alternator

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

NOTE: Place a load on the battery, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connectors or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine connector A from the ECM.
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery 1 voltage SUPPLY pins in the engine connector A and the 47-pin harness to the OEM control panel connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine connector A and connector B from the ECM.
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the unswitched battery 1 voltage SUPPLY pins in engine connector A and all other pins in the engine connector A.
  • Measure the resistance between the unswitched battery 1 voltage SUPPLY pins in engine connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 17-Aug-2012


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 2. | Check for a defective voltage source. |
 | STEP 2A. Determine battery voltage. | Less than 32-VDC?
STEP 3. | Check the fuse rating. |
 | STEP 3A. Check fuse for appropriate rating. | Fuse rated at 10 amperes?
STEP 4. | Check the alternator. |
 | STEP 4A. Check the alternator. | Alternator charging within OEM specifications?
 | STEP 4B. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4C. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for a defective voltage source.

Guided Step 2A - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Less than 32-VDC?
YES NO
No Repair

Install the battery system correctly. Refer to the OEM service manual.

Go to 4C-2

Go to 5A

Guided Step 3 - Check fuse rating.

Guided Step 3A - Check fuse for appropriate rating.

Conditions

  • Disconnect the 47-pin harness to the OEM control panel.

Action

Inspect fuse rating.

  • Refer to the OEM control panel service literature for fuse location, removal, and installation instructions.

Fuse rated at 10 amperes?
YES NO
No Repair

Replace with 10 amperes fuse. Refer to the OEM control panel service literature for removal and installation instructions.

Go to 5A

Go to 5A

Guided Step 4 - Check the alternator.

Guided Step 4A - Check the alternator.

Conditions

  • Turn keyswitch OFF
  • Use an OEM ammeter, or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

NOTE: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 4B

Go to 5A

Guided Step 4B - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine connector A and connector B from the ECM.
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the unswitched battery 1 voltage SUPPLY pins in engine connector A and all other pins in the engine connector A.
  • Measure the resistance between the unswitched battery 1 voltage SUPPLY pins in engine connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 442 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 20-Aug-2012


FAULT CODE 477 - Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 477 inactive?
STEP 2. | Check for a malfunctioning voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay or power lock out switch. | Relay installed?
 | STEP 2B. Determine battery voltage. | Battery voltage acceptable in key ON and cranking conditions?
STEP 3. | Check the 47-pin harness and OEM control panel. |
 | STEP 3A. Inspect the 47-pin harness and OEM control panel. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the OEM control panel. | Damaged fuses?
 | STEP 4A-1. Check fuse for appropriate rating. |
 | STEP 4A-2. Check the alternator. |
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4D. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 477 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 477 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 477 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for a malfunctioning voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay or power lock out switch.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay or power lock out switch.

  • Refer to the OEM control panel service literature.

Relay or lockout switch installed?
YES NO

Inspect voltage shutoff relay or power lockout switch.

Refer to the OEM control panel service literature.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal during key ON and cranking conditions:

Key ON conditions:

  • At least 23-VDC

Cranking conditions:

  • At least 18-VDC.

Battery voltage acceptable in keyswitch ON and cranking conditions?
YES NO
No Repair

A malfunctioning battery has been detected.

Replace the malfunctioning battery or batteries. Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 3 - Check the 47-pin harness to the OEM control panel.

Guided Step 3A - Inspect the 47-pin harness to the OEM control panel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the 47-pin harness to the OEM control panel connector.

Action

Inspect the 47-pin harness to the OEM control panel and connector pins.

  • Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the OEM control panel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuses in the OEM control panel.

Refer to the OEM control panel service literature to perform the following:

  • Open the OEM control panel
  • Locate the glass fuses
  • Inspect the fuses.

Damaged fuse?
YES NO

A damaged or blown fuse has been located.

  • Replace the fuse. Refererence the OEM control panel service literature.

 No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuse for appropriate rating.

Conditions

  • Disconnect the 47-pin harness to the OEM control panel.

Action

Inspect fuse rating.

  • Refer to the OEM control panel service literature for fuse location, removal and installation instructions.

Fuse rated at 10 amperes?
YES NO
No Repair

Replace with 10 amp fuse. Reference the OEM control panel service literature for removal and installation instructions.

Go to 5A

Go to 5A

Guided Step 4A-2 - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter, or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

NOTE: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging withing OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine connector A from the ECM.
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery 2 voltage SUPPLY pins in engine connector A and the 47 pin OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine connector A and connector B from the ECM.
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the unswitched battery 2 voltage SUPPLY pins in engine connector A and all other pins in engine connector A.
  • Measure the resistance between the unswitched battery 2 voltage SUPPLY pins in engine connector A and all other pins in engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 477 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 477 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 20-Aug-2012


FAULT CODE 478 - Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 478 inactive?
STEP 2. | Check for a malfunctioning voltage source. |
 | STEP 2A. Determine battery voltage. | Less than 32-VDC?
STEP 3. | Check fuse rating. |
 | STEP 3A. Check fuse for appropriate rating. | Fuse rated at 10 amperes?
STEP 4. | Check the alternator. |
 | STEP 4A. Check the alternator. | Alternator charging within OEM specifications?
 | STEP 4B. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4C. Check for an inactive fault code. | Fault Code 478 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 478 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 478 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for a malfunctioning voltage source.

Guided Step 2A - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Less than 32-VDC?
YES NO
No Repair

Install the battery system correctly. Refer to the OEM service manual.

Go to 4C-2

Go to 5A

Guided Step 3 - Check fuse rating.

Guided Step 3A - Check fuse for appropriate rating.

Conditions

  • Disconnect the 47-pin harness to the OEM control panel.

Action

Inspect the fuse rating.

  • Refer to the OEM control panel service literature for fuse location, removal, and installation instructions.

Fuse rated at 10 amperes?
YES NO
No Repair

Replace damaged fuse with 10 amp fuse.

Reference the OEM control panel service literature for removal and installation instructions.

Go to 4B

Go to 5A

Guided Step 4 - Check the alternator.

Guided Step 4A - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter, or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

NOTE: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 4B

Go to 5A

Guided Step 4B - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine connector A and connector B from the ECM.
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine connector A and all other pins in the engine connector A.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 478 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 478 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 20-Aug-2012


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 488 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Temperature within 3°C [5°F]?
STEP 3. | Check the intake manifold 1 pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold 1 pressure/temperature sensor and engine harness connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 488 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 488 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the intake manifold 1 pressure/temperature sensor reading from INSITE™ electronic service tool to the reading from the probe.

NOTE: If no temperature measuring device is available, answer “NO” to this step.

Temperature within 3°C [5°F]?
YES NO

Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the intake manifold 1 pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold 1 pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold 1 pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 488 is inactive.

Fault Code 488 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Aug-2012


FAULT CODE 512 - Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 2. | Check the throttle actuator and circuit. |
 | STEP 2A. Inspect the throttle actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 512 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the throttle actuator and circuit.

Guided Step 2A - Inspect the throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic throttle actuator from the engine harness.

Action

Inspect the engine harness and throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Repair the damaged pins. Repair or replace the harness, or replace the throttle actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure to replace the throttle actuator in Service Manual, QSL9 G CM558, Bulletin 2883375. Refer to Procedure 005-052 in Section 5.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both engine connectors A and B from the ECM.

Action

Inspect the engine harness and both ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness.

Repair or replace the harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A and connector B from the ECM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle plate position feedback pin in engine connector A and all other pins in engine connector A.
  • Measure the resistance between the throttle plate position feedback pin in engine connector A and all pins in engine connector B.

Use to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle actuator command supply line or position signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 512 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 20-Aug-2012


FAULT CODE 513 - Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 2. | Check the throttle actuator and circuit. |
 | STEP 2A. Inspect the throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle actuator battery voltage and ground. | Voltage greater than 12-VDC?
 | STEP 2C. Check the resistance in the switched battery and ground. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 513 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM control panel and 47-pin harness to the OEM control panel.

Guided Step 2A - Inspect the 47-pin connection to the OEM control panel and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle actuator from the 47-pin connector to the OEM control panel.

Action

Inspect the engine harness 47-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or 47-pin harness to the OEM control panel, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the 47-pin connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the OEM control panel wiring and connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the 47-pin connector to the OEM control panel.

Action

Check the OEM control panel for the following:

  • Improper battery voltage
  • Blown/incorrect fuse
  • Incorrect relay functionality
  • Improper wiring
  • Open circuits
  • Short circuits
  • Dirty or damaged connector pins.

Damaged OEM control panel wiring or connections?
YES NO

Replace blown or incorrect fuses.

Correct improper wiring.

Replace broken or damaged relay.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic conact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the throttle actuator and circuit.

Guided Step 3A - Inspect the throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle actuator from the engine harness.

Action

Inspect the engine harness and throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the throttle actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure to replace the throttle actuator in Service Manual, QSL9 G CM558/CM2358, Bulletin 2883375. Refer to Procedure 005-052 in Section 5.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the throttle actuator battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Use a break-out harness or piercing probe, so a load is on the voltage supply.
  • Turn keyswitch ON.

Action

Check the throttle actuator battery voltage.

  • Check for battery voltage on the governor power 24 volt pin of the throttle actuator connector on the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 24-VDC?
YES NO
No Repair

Determine the root cause for no or insufficient switch battery voltage.

Go to 4B

Go to 3C

Guided Step 3C - Check the resistance between the throttle actuator power supply and ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the throttle actuator battery voltage to ground.

  • Measure the resistance between the throttle actuator governer power 24 volt pin and ground at the throttle actuator connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Use the following procedure to replace the throttle actuator in Service Manual, QSL9 G CM558/CM2358, Bulletin 2883375. Refer to Procedure 005-052 in Section 5.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both engine connectors A and B from the ECM.

Action

Inspect the engine harness and both engine connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine connectors or the engine harness.

Repair or replace the harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine connecter A from the ECM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine connector A throttle plate position FEEDBACK pin and the throttle actuator connector throttle plate position FEEDBACK in the engine harness.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal. If it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both engine connectors A and B from the ECM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the throttle position FEEDBACK pin in the engine connector A and ground.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the throttle actuator supply or the throttle position signal lines has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both engine connectors A and B from the ECM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle plate position FEEDBACK pin in the engine connector A ans all other pins in the engine connector A.
  • Measure the resistance between the throttle plate position FEEDBACK pin in the engine connector A and all other pins in the engine connector B.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle actuator position signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

  • 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 513 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 06-Oct-2014


FAULT CODE 697 - ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Operate engine for more than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 697 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 20-Aug-2012


FAULT CODE 698 - ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Operate engine for more than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 698 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 20-Aug-2012


FAULT CODE 783 - Intake Manifold 1 Temperature - Abnormal Rate of Change

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 1 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 783 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 1 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • If possible, complete this step with the engine running.

Action

Verify the intake manifold pressure/temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold pressure/temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 1 temperature reading on the INSITE™ service tool monitor screen to the reading from the temperature probe.

If the probe can not be inserted into the intake manifold near enough to the sensor, or the engine can not be running, remove the sensor and compare to ambient temperature.

Does the thermocouple reading agree with the intake manifold 1 temperature reading in INSITE™ electronic service tool within 4°C or 8°F?

YES NO
No Repair

A damaged intake manifold pressure/temperature sensor has been detected.

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-354 in Section 19.

Go to

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 783 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 20-Aug-2012


FAULT CODE 1665 - Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1665 inactive?
STEP 2. | Check the aftertreatment exhaust gas temperature 1 sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment exhaust gas temperature 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1666 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1665 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1665 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1665 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment exhaust gas temperature 1 sensor and circuit.

Guided Step 2A - Inspect the aftertreatment exhaust gas temperature 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment exhaust gas temperature 1 sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment exhaust gas temperature 1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or connector.

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

Repair or replace the sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment exhaust gas temperature 1 sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment exhaust gas temperature 1 sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 active?
YES NO

Replace the aftertreatment exhaust gas temperature 1 sensor. Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment exhaust gas temperature 1 sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment exhaust gas temperature 1 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment exhaust gas temperature 1 sensor from the wiring harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the aftertreatment exhaust gas temperature 1 sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1665 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 20-Aug-2012


FAULT CODE 1666 - Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1666 inactive?
STEP 2. | Check the aftertreatment catalyst inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment catalyst inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify sensor accuracy. | Fault Code 1665 active and Fault Code 1666 inactive?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the 47 pin harness to OEM panel, engine harness, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the sensor harness. | Less than 10 ohms?
 | STEP 3B-1. Check for a pin-to-pin short circuit in the sensor harness. |
 | STEP 3C. Check for an open circuit in the 47 pin harness to OEM panel. | Greater than 100k ohms?
 | STEP 3C-1. Check for a pin-to-pin short circuit in the 47 pin harness to OEM panel. |
 | STEP 3D. Check for an open circuit in the engine harness. | Fault Code 1665 inactive?
 | STEP 3D-1. Check for a pin-to-pin short circuit in the engine harness. |
 | STEP 3E. Check for resistor pack condition. | Resistance 1k ohm?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1666 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1666 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the pre-catalyst temperature sensor and circuit.

Guided Step 2A - Inspect the pre-catalyst temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-catalyst temperature sensor from the wiring harness.

Action

Inspect the wiring harness and pre-catalyst temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replair or replace the sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Verify sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor reading on INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to monitor the pre-catalyst temperature.
  • Place a temperature probe or similar device near the pre-catalyst temperature sensor to verify sensor accuracy.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Sensor reading within -12°C [10°F]?
YES NO
No Repair

Replace the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449 in Section 19.

Go to 2C

Go to 3A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the 47-pin harness to OEM panel, engine harness, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect 47-pin harness to OEM panel.
  • Disconnect ECM connectors A and B.

Action

Inspect the 47 pin harness to OEM panel, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-catalyst temperature sensor from the wiring harness.
  • Disconnect the pre-catalyst temperature sensor harness from the customer terminal strip in the OEM panel.

Use a wiring diagram for connector pin identification.

Action

Check for an open circuit.

  • Measure the resistance between the pre-catalyst temperature sensor harness connector catalyst temperature SUPPLY pin and the pre-catalyst temperature sensor SUPPLY pin in the sensor harness at the customer terminal strip end in the OEM panel.
  • Measure the resistance between the pre-catalyst temperature sensor harness connector catalyst temperature SIGNAL pin and the pre-catalyst temperature sensor SIGNAL pin in the sensor harness at the customer terminal strip end in the OEM panel.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open has been detected in the harness.

Repair or replace the sensor harness. Refer to the OEM service manual.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin-to-pin short circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre catalyst temperature sensor from the wiring harness.
  • Disconnect the pre catalyst temperature sensor harness from the customer terminal strip in the OEM panel.

Use a wiring diagram for connector pin identification.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the pre catalyst temperature sensor harness connector catalyst temperature SUPPLY pin and all the other pins in the pre catalyst temperature sensor harness connector.
  • Measure the resistance between the pre catalyst temperature sensor harness connector catalyst temperature SIGNAL pin and all the other pins in the pre catalyst temperature sensor harness connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the sensor harness.

  • Repair or replace the sensor harness. Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the 47-pin harness to OEM panel

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to OEM panel from the engine harness
  • Disconnect the pre catalyst temperature SUPPLY and SIGNAL wires in the 47-pin harness to OEM panel from the customer terminal strip in the OEM panel.

Use a wiring diagram for connector pin identification.

Action

Check for an open circuit.

  • Measure the resistance between the 47-pin harness to OEM panel connector pre-catalyst temperature SUPPLY pin and the pre-catalyst temperature sensor SUPPLY pin in the 47-pin harness to OEM panel at the customer terminal strip end in the OEM panel.
  • Measure the resistance between the 47 pin harness to OEM panel connector pre-catalyst temperature SIGNAL pin and the pre- catalyst temperature sensor SIGNAL pin in the 47 pin harness to OEM panel at the customer terminal strip end in the OEM panel.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open has been detected in the harness.

  • Repair or replace the 47-pin harness to OEM panel. Refer to the OEM service manual.

Go to 3B-1

Go to 4A

Guided Step 3C-1 - Check for a pin-to-pin short circuit in the 47-pin harness to OEM panel

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to OEM panel from the engine harness
  • Disconnect the pre catalyst temperature supply and signal wires in the 47-pin harness to OEM panel from the customer terminal strip in the OEM panel.

Use a wiring diagram for connector pin identification.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the 47-pin harness to OEM panel connector pre catalyst temperature SUPPLY pin and all the other pins in the 47-pin harness to OEM panel connector.
  • Measure the resistance between the 47-pin harness to OEM panel connector pre catalyst temperature SIGNAL pin and all the other pins in the 47-pin harness to OEM panel connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the 47-pin harness to OEM panel.

  • Repair or replace the 47-pin harness to OEM panel harness. Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel from he engine harness.
  • Disconnect the engine harness connector from the resistor pack.
  • Dsconnect the engine harness from ECM.

Use a wiring diagram for connector pin identification.

Action

Check for an open circuit.

  • Measure the resistance between the pre-catalyst temperature SIGNAL pin in the engine harness 47 pin connector and the pre-catalyst temperature sensor SIGNAL pin in the engine harness connector to the resistor pack.
  • Measure the resistance between the pre-catalyst temperature SIGNAL pin in the engine harness 47 pin connector and the pre-catalyst temperature sensor SIGNAL pin in the ECM connector B.
  • Measure the resistance between the sensor SUPPLY 2 pin in the ECM connector B and the pre-catalyst temperature sensor SUPPLY pin in the engine harness 47-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open has been detected in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D-1

Go to 4A

Guided Step 3D-1 - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to OEM panel from the engine harness
  • Disconnect the resistor pack from the engine harness.
  • Disconnect the engine harness from the ECM.

Use a wiring diagram for connector pin identification.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the pre-catalyst temperature SUPPLY pin in the engine harness 47-pin connector to all the other pins in the engine harness 47-pin connector.
  • Measure the resistance between the pre-catalyst temperature SIGNAL pin in the engine harness 47-pin connector to all the other pins in the engine harness 47-pin connector.
  • Measure the resistance between the pre-catalyst temperature sensor SUPPLY 2 pin in the engine harness connector at ECM to all the other pins in the engine harness connector at ECM.
  • Measure the resistance between the pre catalyst temperature sensor RETURN 2 pin in the engine harness connector at ECM to all the other pins in the engine harness connector at ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for resistor pack condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel from he engine harness.
  • Disconnect the engine harness connector from the resistor pack.

Use a wiring diagram for connector pin identification.

Action

Check for a short in the resistor pack in the engine harness.

  • Measure resistance across 1.00k ohm, 1/4 watt resistor in resistor pack.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance 1k ohms?
YES NO
No Repair

A short has been detected in the resistor pack.

Replace the resistor pack.

Go to 3D

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1666 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 20-Aug-2012


FAULT CODE 1674 - Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1674 inactive?
STEP 2. | Check the aftertreatment exhaust gas temperature 2 circuit. |
 | STEP 2A. Inspect the aftertreatment exhaust gas temperature 2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1675 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1674 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1674 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1674 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fautl codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment exhaust gas temperature 2 sensor and circuit.

Guided Step 2A - Inspect the aftertreatment exhaust gas temperature 2 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment exhaust gas temperature 2 sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment exhaust gas temperature 2 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-071 in Section 19.
  • Repair or replace the aftertreatment exhaust gas temperature 2 sensor.
  • Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment exhaust gas temperature 2 sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment exhaust gas temperature 2 sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 active?
YES NO

Replace the aftertreatment exhaust gas temperature 2 sensor. Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment exhaust gas temperature 2 sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment exhaust gas temperature 2 sensor SIGNAL pin in the OEM harness ECM connector an all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment exhaust gas temperature 2 sensor from the wiring harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the aftertreatment exhaust gas temperature 2 sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1674 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Aug-2012


FAULT CODE 1675 - Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1675 inactive?
STEP 2. | Check the aftertreatment catalyst inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment catalyst inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify sensor accuracy. | Fault Code 1674 active and Fault Code 1675 inactive?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the 47 pin harness to OEM panel, engine harness, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the sensor harness. | Less than 10 ohms?
 | STEP 3B-1. Check for a pin-to-pin short circuit in the sensor harness. |
 | STEP 3C. Check for an open circuit in the 47 pin harness to OEM panel. | Greater than 100k ohms?
 | STEP 3C-1. Check for a pin-to-pin short circuit in the 47 pin harness to OEM panel. |
 | STEP 3D. Check for an open circuit in the engine harness. | Fault Code 1665 inactive?
 | STEP 3D-1. Check for a pin-to-pin short circuit in the engine harness. |
 | STEP 3E. Check for resistor pack condition. | 1k ohm?
 | STEP 3F. Check for an inactive fault code. | Fautl Code 1675 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1675 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post catalyst temperature sensor from the wiring harness.

Action

Inspect the wiring harness and post catalyst temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Verify sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor reading on INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to monitor the post catalyst temperature.
  • Place a temperature probe or similar device near the post catalyst temperature sensor to verify sensor accuracy.

Use a wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Sensor reading within -12°C [10°F]?
YES NO
No Repair

Replace the post catalyst temperature sensor.

  • Refer to Procedure 019-449 in Section 19.

Go to 2C

Go to 3A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the 47-pin harness to OEM panel, engine harness, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect 47-pin harness to OEM panel.
  • Disconnect ECM connectors A and B.

Action

Inspect the 47 pin harness to OEM panel, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

  • Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-204 in Section 19.

Repair or replace 47 pin harness to OEM panel.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post catalyst temperature sensor from the wiring harness.
  • Disconnect the post catalyst temperature sensor harness from the customer terminal strip in the OEM panel.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Action

Check for an open circuit.

  • Measure the resistance between the post catalyst temperature sensor harness connector catalyst temperature SUPPLY pin and the post catalyst temperature sensor SUPPLY pin in the sensor harness at the customer terminal strip end in the OEM panel.
  • Measure the resistance between the post catalyst temperature sensor harness connector catalyst temperature SIGNAL pin and the post catalyst temperature sensor SIGNAL pin in the sensor harness at the customer terminal strip end in the OEM panel.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open has been detected in the harness.

  • Repair or replace the sensor harness. Refer to the OEM service manual.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin-to-pin short circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post catalyst temperature sensor from the wiring harness.
  • Disconnect the post catalyst temperature sensor harness from the customer terminal strip in the OEM panel.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the post catalyst temperature sensor harness connector catalyst temperature SUPPLY pin and all the other pins in the post catalyst temperature sensor harness connector.
  • Measure the resistance between the post catalyst temperature sensor harness connector catalyst temperature SIGNAL pin and all the other pins in the post catalyst temperature sensor harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the sensor harness.

  • Repair or replace the sensor harness. Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the 47-pin harness to OEM panel

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to OEM panel from the engine harness.
  • Disconnect the post catalyst temperature supply and signal wires in the 47-pin harness to OEM panel from the customer terminal strip in the OEM panel.

Action

Check for an open circuit.

  • Measure the resistance between the 47-pin harness to OEM panel connector post catalyst temperature SUPPLY pin and the post catalyst temperature sensor SUPPLY pin in the 47-pin harness to OEM panel at the customer terminal strip end in the OEM panel.
  • Measure the resistance between the 47 pin harness to OEM panel connector post catalyst temperature SIGNAL pin and the post catalyst temperature sensor SIGNAL pin in the 47 pin harness to OEM panel at the customer terminal strip end in the OEM panel.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open has been detected in the harness.

  • Repair or replace the 47-pin harness to OEM panel. Refer to the OEM service manual.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for a pin-to-pin short circuit in the 47-pin harness to OEM panel

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to OEM panel from the engine harness.
  • Disconnect the post catalyst temperature supply and signal wires in the 47-pin harness to OEM panel from the customer terminal strip in the OEM panel.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the 47-pin harness to OEM panel connector catalyst temperature SUPPLY pin and all the other pins in the 47-pin harness to OEM panel connector.
  • Measure the resistance between the 47-pin harness to OEM panel connector catalyst temperature SIGNAL pin and all the other pins in the 47-pin harness to OEM panel connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the 47-pin harness to OEM panel.

  • Repair or replace the 47-pin harness to OEM panel harness. Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel from he engine harness.
  • Disconnect the engine harness connector from the resistor pack.
  • Disconnect the engine harness from ECM.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Action

Check for an open circuit.

  • Measure the resistance between the post catalyst temperature SIGNAL pin in the engine harness 47 pin connector and the post catalyst temperature sensor SIGNAL pin in the engine harness connector to the resistor pack.
  • Measure the resistance between the post catalyst temperature SIGNAL pin in the engine harness 47 pin connector and the post catalyst temperature sensor SIGNAL pin in the ECM connector B.
  • Measure the resistance between the sensor supply 2 pin in the ECM connector B and the post catalyst temperature sensor SUPPLY pin in the engine harness 47-pin connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open has been detected in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D-1

Go to 4A

Guided Step 3D-1 - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to OEM panel from the engine harness
  • Disconnect the resistor pack from the engine harness.
  • Disconnect the engine harness from the ECM.

Use a wiring diagram for connector pin identification.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the post catalyst temperature SUPPLY pin in the engine harness 47-pin connector to all the other pins in the engine harness 47-pin connector.
  • Measure the resistance between the post catalyst temperature SIGNAL pin in the engine harness 47-pin connector to all the other pins in the engine harness 47-pin connector.
  • Measure the resistance between the post catalyst temperature sensor SUPPLY 2 pin in the engine harness connector at ECM to all the other pins in the engine harness connector at ECM.
  • Measure the resistance between the post catalyst temperature sensor RETURN 2 pin in the engine harness connector at ECM to all the other pins in the engine harness connector at ECM.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for resistor pack condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel from he engine harness.
  • Disconnect the engine harness connector from the resistor pack.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Action

Check for a short in the resistor pack in the engine harness.

  • Measure resistance across 1.00k ohm, 1/4 watt resistor in resistor pack.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A short has been detected in the resistor pack.

Replace the resistor pack.

Go to 3D

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response.

  • Start the engine and idle with engine speed greater than 1200 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1675 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 20-Aug-2012


FAULT CODE 1739 - Engine Throttle Control Actuator - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1739 active?
STEP 2. | Check the engine harness connectors. |
 | STEP 2A. Inspect the engine harness, ECM, throttle control actuator, and resistor pack connector pins. | Damaged or dirty pins?
STEP 3. | Check the resistor pack. |
 | STEP 3A. Check the resistance across the resistor pack pins. | Resistance between 265 and 296 ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 4D. Check for an inactive fault code. | Fault Code 1739 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1739 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1739 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine harness connectors.

Guided Step 2A - Inspect the engine harness, ECM, throttle control actuator, and resistor pack connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the throttle control actuator.
  • Disconnect the engine harness from the resistor pack.

Action

Inspect the engine harness, ECM , throttle control actuator, and resistor pack connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair or replace the engine harness, or replace the ECM or resistor pack, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the resistor pack.

Guided Step 3A - Check the resistance across the resistor pack pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the resistor pack from the engine harness.

Action

Check the resistance across the parallel 560 ohm resistor pins in the resistor pack connector.

Refer to circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Resistance between 265 and 269 ohms?
YES NO
No Repair

Replace the resistor pack.

  • Refer to Procedure 019-482 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the throttle control actuator.
  • Disconnect the engine harness from the resistor pack.

Action

Check for an open circuit.

  • Measure the resistance between the throttle command SUPPLY pin in the ECM connector and the throttle command SUPPLY pin in the throttle actuator connector.
  • Measure the resistance between the throttle command RETURN pin in the ECM connector and the throttle command RETURN pin in the throttle actuator connector.
  • Measure the resistance between the throttle command SUPPLY pin in the ECM connector and the throttle command SUPPLY pin in the resistor pack connector.
  • Measure the resistance between the throttle command SUPPLY pin in the ECM connector and the throttle command SUPPLY pin in the resistor pack connector.

Refer to circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4B

Go to 5A

Guided Step 4B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the throttle control actuator.
  • Disconnect the engine harness from the resistor pack.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the throttle command SUPPLY pin in the ECM connector B and all other pins in the ECM connector B.
  • Measure the resistance between the throttle command SUPPLY pin in the ECM connector B and all other pins in the ECM connector A.
  • Measure the resistance between the throttle command RETURN pin in the ECM connector B and all other pins in the ECM connector B.
  • Measure the resistance between the throttle command RETURN pin in the ECM connector B and all other pins in the ECM connector A.

Refer to circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the throttle control actuator.
  • Disconnect the engine harness from the resistor pack.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the throttle command SUPPLY pin in the engine harness connector and ground.
  • Measure the resistance between the throttle command RETURN pin in the engine harness connector and ground.

Refer to the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1739 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1739 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 20-Aug-2012


FAULT CODE 1791 - Electrical Load - Failure to Meet Load and/or Speed Demand - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1791 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to check for active or inactive fault codes.

Active or inactive fault codes?
YES NO

One or more active fault codes.

Reference the appropriate troubleshooting tree.

Complete the appropriate engine performance troubleshooting trees and check ignition system.

Reference the Engine Transient Response Poor troubleshooting symptom tree and Engine Will Not Reach Rated Speed (RPM) troubleshooting symptom tree in Service Manual, QSL9 G CM558/CM2358, Bulletin 2883375 in Section TS.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Operate engine and let idle for 1 minute.

Fault Code 1791 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 11-Jun-2014


FAULT CODE 1824 - Engine Oil Temperature Sensor 1 Circuit, Too Cold For High Idle - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the oil temperature. |
 | STEP 1A. Check oil temperature in the oil rifle. | Oil above 38°C [100°F]?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an inactive fault code. | Fault Code 1824 inactive?
STEP 3. | Check the oil temperature sensor and resistor pack. |
 | STEP 3A. Inspect the engine oil temperature sensor connector and resistor connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the sensor resistance. | Resistance between 175 ohms and 274k ohms?
 | STEP 3C. Check the resistance across the resistor pack pins. | Resistance between 1.98k and 2.02k ohms?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for an inactive fault code. | Fault Code 1824 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1824 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the oil temperature.

Guided Step 1A - Check oil temperature in the oil rifle.

Conditions

  • Turn keyswitch OFF.

Action

Use a temperature probe or thermocouple to check the oil temperature in the main oil rifle.

Oil above 38°C [100°F]?
YES | NO
No Repair | No Repair

Go to 2A

Idle the engine or use a block heater to heat the engine oil above minimum temperature.

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1824 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 3A

Guided Step 3 - Check the oil temperature sensor and resistor pack.

Guided Step 3A - Inspect the oil pressure/temperature sensor connector and resistor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor from the engine harness.
  • Disconnect the resistor pack from the engine harness.

Action

Inspect the engine harness, oil temperature sensor, and resistor pack connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, resistor pack, or harness connector.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure/temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the engine oil pressure/temperature sensor connector.
  • Make sure the engine has idled for a sufficient amount of time to allow the oil to reach normal operating temperatures at idle.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 175 and 274k ohms?
YES NO

Refer to the circuit diagram or wiring diagram for connector pin identification.

Replace the engine oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the resistance across the resistor pack pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the resistor pack from the engine harness.

Action

Check the resistance across the 2.00K ohm 1/4 watt pins in the resistor pack.

Refer to the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 1.98k and 2.02k ohms?
YES NO
No Repair

Replace the resistor pack.

  • Refer to Procedure 019-482 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.
  • Disconnect the resistor pack from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the oil temperature SIGNAL pin at ECM connector B and the engine oil pressure/temperature SIGNAL pin at the sensor.
  • Measure the resistance between the oil temperature RETURN pin at ECM connector B and the sensor RETURN 2 pin at the resistor pack connector.
  • Measure the resistance between the sensor SUPPLY 2 pin at ECM connector B and R2 at the resistor pack connector.
  • Measure the resistance between the sensor RETURN 2 pin at ECM connector B and RETURN pin at the engine oil rifle pressure/temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.
  • Disconnect the resistor pack from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the oil temperature SIGNAL pin in the engine harness and all other pins in the ECM connector B.
  • Measure the resistance between the oil temperature SIGNAL pin in the engine harness and all other pins in the ECM connector A.
  • Measure the resistance between the 2.00K ohm 1/4 watt pins and all other pins in the resistor pack connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for an inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1824 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1824 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 20-Aug-2012


FAULT CODE 1858 - Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male and Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault code. | Fault Code 1858 active?
STEP 2. | Check the heated oxygen sensor and sensor harness. |
 | STEP 2A. Inspect the sensor harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the catalyst inlet oxygen sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2C. Check for an open circuit in the sensor harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the sensor harness. | Greater than 100k ohms?
STEP 3. | Check the engine harness and 47 pin harness to the OEM panel. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 1858 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1858 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1858 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the heated oxygen sensor and sensor harness.

Guided Step 2A - Inspect the sensor harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the sensor harness.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the catalyst inlet oxygen sensor heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated aftertreatment inlet oxygen concentration sensor from the sensor harness.

Action

Check the heated oxygen sensor heater.

  • Measure the resistance between the pre-catalyst oxygen heater supply and the pre-catalyst oxygen heater return at the heated oxygen connector.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the heated aftertreatment inlet oxygen concentration sensor.

  • Refer to Procedure 019-100 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the sensor harness.
  • Disconnect the pre-catalyst oxygen sensor SIGNAL and RETURN wires from the OEM terminal strips in the OEM panel.

Action

Check for an open circuit.

  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin on the oxygen sensor connector and the pre-catalyst oxygen SIGNAL wire at the OEM terminal strip.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin on the oxygen sensor connector and the pre-catalyst oxygen RETURN wire at the OEM terminal strip.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the sensor harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the sensor harness
  • Disconnect the pre-catalyst oxygen signal and pre-catalyst oxygen return wires from the OEM terminal strips in the OEM panel.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the pre-catalyst oxygen signal pin on the oxygen sensor connector and all other pins in the sensor harness.
  • Measure the resistance between the pre-catalyst oxygen return pin on the oxygen sensor connector and all other pins in the sensor harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the sensor harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine sensor. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness and 47 pin harness to the OEM panel.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the 47 pin connector.

Action

Inspect the ECM connector pins and the 47 pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the 47 pin connector to the OEM panel.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the 47 pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the 47 pin connector.
  • Disconnect the pre-catalyst oxygen signal and pre-catalyst oxygen return wires in the 47-pin harness from the terminal strips in the OEM panel.

Action

Check for an open circuit.

  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin in ECM connector A and the pre-catalyst oxygen RETURN pin in the 47-pin connector.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin in ECM connector A and the pre-catalyst oxygen RETURN pin in the 47-pin connector.
  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin in 47-pin connector and the pre-catalyst oxygen SIGNAL wire at the OEM terminal strip.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin in 47-pin connector and the pre-catalyst oxygen RETURN wire at the OEM terminal strip.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the 47-pin connector.
  • Disconnect the pre-catalyst oxygen SIGNAL and pre-catalyst oxygen REURN wires in the 47-pin harness from the terminal strips in the OEM panel.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin in ECM connector A and all other pins in both ECM connector A and ECM connector B.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin in ECM connector A and all other pins in both ECM connector A and ECM connector B.
  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin in 47-pin connector and all other pins in the 47-pin harness to OEM control panel.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin in 47-pin connector and all other pins in the 47-pin harness to OEM control panel.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1858 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1858 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Aug-2012


FAULT CODE 1859 - Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the aftertreatment inlet oxygen concentration sensor until it has cooled. The aftertreatment inlet oxygen concentration sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the aftertreatment inlet oxygen concentration sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1859 active?
STEP 2. | Check the aftertreatment inlet oxygen concentration sensor. |
 | STEP 2A. Inspect the OEM harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage is greater than 13.6 to 14.0-VDC?
 | STEP 2C. Check the aftertreatment inlet oxygen concentration sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check for an open circuit in the sensor harness. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit to ground in the sensor harness. | Greater than 100k ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the sensor harness. | Greater than 100k ohms?
STEP 3. | Check the engine harness and 47-pin harness to the OEM panel. |
 | STEP 3A. Inspect the OEM harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for inactive fault codes. | Fault Code 1859 inactive?
STEP 4. | Check the OEM control panel |
 | STEP 4A. Check the OEM terminal strip supply voltage. | Supply voltage 13.6 to 14.0-VDC?
 | STEP 4B. Check the switched mode 24 to 13.8-VDC converter. | Supply voltage 24-VDC?
 | STEP 4C. Check the OEM supply voltage. | Issues or damage found?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1859 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1859 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment inlet oxygen concentration sensor.

Guided Step 2A - Inspect the sensor harness and aftertreatment inlet oxygen concentration sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the sensor harness.

Action

Inspect the sensor harness and aftertreatment oxygen concentration sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the sensor harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the aftertreatment inlet oxygen concentration sensor.Refer to Procedure 019-100 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Engine running for more than 45 seconds.
  • Disconnect the pre-catalyst oxygen sensor from the sensor harness.

Action

Measure the aftertreatment inlet oxygen concentration sensor heater supply voltage.

  • Measure the voltage between pre-catalyst oxygen heater SUPPLY pin and pre-catalyst oxygen RETURN pin in the sensor harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Supply voltage 13.6 to 14.0-VDC?
YES NO
No Repair

There is an issue in the sensor supply voltage circuit. The sensor is not getting enough voltage to function properly.

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment inlet oxygen concentration sensor heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-catalyst oxygen sensor from the sensor harness.

Action

Check the heated aftertreatment inlet oxygen concentration heater.

  • Measure the resistance between the pre-catalyst oxygen heater supply and the pre-catalyst oxygen heater return at the heated oxygen connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the aftertreatment inlet oxygen concentration sensor.

  • Refer to Procedure 019-100 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the sensor harness.
  • Disconnect the pre-catalyst oxygen SIGNAL and pre-catalyst oxygen RETURN sensor wires from the OEM terminal strips in the OEM panel.

Action

Check for an open circuit.

  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin on the oxygen sensor connector and the pre-catalyst oxygen SIGNAL wire at the OEM terminal strip.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin on the oxygen sensor connector and the pre-catalyst oxygen RETURN wire at the OEM terminal strip.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 1.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the sensor harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check for a short circuit to ground in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the sensor harness.
  • Disconnect the pre-catalyst oxygen sgnal and re-catalyst oxygen return sensor wires from the OEM terminal strips in the OEM panel.

Action

Check for a short circuit to ground.

  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin on the oxygen sensor connector and ground.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin on the oxygen sensor connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the sensor harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 5A

Guided Step 2F - Check for a pin-to-pin short circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the sensor harness.
  • Disconnect the pre-catalyst oxygen SIGNAL and pre-catalyst oxygen RETURN sensor wires from the OEM terminal strips in the OEM panel.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin on the oxygen sensor connector and all other pins in the sensor harness.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin on the oxygen sensor connector and all other pins in the sensor harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 1.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the sensor harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness and the 47 pin harness to the OEM panel.

Guided Step 3A - Inspect the OEM harness and panel connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the 47-pin connector.

Action

Inspect the ECM connector pins and the 47-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the 47-pin connector to the OEM panel.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the 47-pin connector.
  • Disconnect the pre-catalyst oxygen SIGNAL and pre-catalyst oxygen RETURN wires in the 47-pin harness from the terminal strips in the OEM panel.

Action

Check for an open circuit.

  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin in ECM connector A and the pre-catalyst oxygen SUPPLY pin in the 47-pin connector.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin in ECM connector A and the pre-catalyst oxygen RETURN pin in the 47-pin connector.
  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin in 47-pin connector and the pre-catalyst oxygen SIGNAL wire at the OEM terminal strip.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin in 47-pin connector and the pre-catalyst oxygen RETURN wire at the OEM terminal strip.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 1.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the 47-pin connector.
  • Disconnect the pre-catalyst oxygen SIGNAL and pre-catalyst oxygen RETURN wires in the 47-pin harness from the terminal strips in the OEM panel.

Action

Check for a short circuit to ground.

  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin in ECM connector A and ground.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin in ECM connector A and ground.
  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin in 47-pin harness to OEM control panel connector and ground.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin in 47-pin connector and the pre-catalyst oxygen RETURN pin in the 47-pin harness to OEM control panel connector and ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine or 47-pin harness to the OEM control panel.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors A and B from the ECM.
  • Disconnect the 47-pin connector
  • Disconnect the pre-catalyst oxygen SIGNAL and pre-catalyst oxygen RETURN wires in the 47-pin harness from the terminal strips in the OEM panel.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin in ECM connector A and all other pins in both ECM connector A and ECM Connector B.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin in ECM connector A and all other pins in both ECM connector A and ECM Connector B.
  • Measure the resistance between the pre-catalyst oxygen SIGNAL pin in 47-pin connector and all other pins in the 47-pin harness to OEM control panel.
  • Measure the resistance between the pre-catalyst oxygen RETURN pin in 47-pin connector and all other pins in the 47-pin harness to OEM control panel.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for an inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1859 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 4 - Check the OEM control panel.

Guided Step 4A - Check the OEM terminal strip supply voltage.

Conditions

  • Engine running for more than 45 seconds.
  • Disconnect the sensor harness from the OEM terminal strip.

Action

Measure the heated oxygen sensor heater supply voltage.

  • Measure the voltage between pre-catalyst oxygen heater supply terminal and pre-catalyst oxygen return terminal on the OEM terminal strip.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Supply voltage 13.6 to 14.0-VDC?
YES NO
No Repair

An open short to ground, or pin-to-pin short has been detected in the sensor harness.

  • Repair or replace the sensor harness. Refer to Procedure 019-202 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the switched mode 24 to 13.8-VDC converter.

Conditions

  • Turn keyswitch ON.
  • Engine running for more than 45 seconds.

Action

Measure the supply voltage to the switched mode 24 to 13.8-VDC Converter.

  • Measure the voltage from the battery +24-VDC wire to battery negative wire going into the switched mode 24 to 13.8-VDC converter.
  • Measure the voltage from the switched battery +24-VDC wire to battery negative wire going into the switched mode 24 to 13.8-VDC converter.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Supply voltage 24-VDC?
YES NO
No Repair

If there is 24-VDC going to the switched mode 24 to 13.8-VDC converter and not 13.8-VDC out, a damaged converter has been detected.

  • Replace switched mode 24 to 13.8-VDC converter. Refer to the OEM service manual.

Go to 4C

Go to 5A

Guided Step 4C - Check the OEM supply voltage circuit.

Conditions

  • Engine running for more than 45 seconds.

Action

Check OEM control panel for damaged wires, shorts, or open circuits. Possible causes:

  • Blown fuse
  • Malfunctioning 24 to 13.8-VDC converter
  • Low battery voltage .

Refer to OEM wiring diagram for wire names and component location.

Issues or damage found?
YES NO
No Repair

Repair or replace the damaged components or wires. Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1859 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Aug-2012


FAULT CODE 1862 - Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated aftertreatment outlet oxygen concentration sensor until it has cooled. The heated aftertreatment outlet oxygen concentration sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated aftertreatment outlet oxygen concentration sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault code. | Fault Code 1862 active?
STEP 2. | Check the heated oxygen sensor and sensor harness. |
 | STEP 2A. Inspect the sensor harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the catalyst outlet oxygen sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the sensor harness. | Greater than 100k ohms?
STEP 3. | Check the engine harness and 47-pin harness to OEM panel. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for inactive fault codes. | Fault Code 1862 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1862 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1862 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the heated oxygen sensor and sensor harness.

Guided Step 2A - Inspect the sensor harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the sensor harness.

Action

Inspect the OEM harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the heated aftertreatment outlet oxygen concentration sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the catalyst outlet oxygen sensor heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post catalyst oxygen sensor from the sensor harness.

Action

Check the heated oxygen sensor heater.

  • Measure the resistance between the post catalyst oxygen heater supply and the post catalyst oxygen heater return at the heated oxygen connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the heated aftertreatment outlet oxygen concentration sensor.

  • Refer to Procedure 019-100 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the sensor harness.
  • Disconnect the post catalyst oxygen SIGNAL and post catalyst oxygen RETURN sensor wires from the OEM terminal strips in the OEM panel.

Action

Check for an open circuit.

  • Measure the resistance between the post catalyst oxygen SIGNAL pin on the oxygen sensor connector and the post catalyst oxygen SIGNAL wire at the OEM terminal strip.
  • Measure the resistance between the post catalyst oxygen RETURN pin on the oxygen sensor connector and the post catalyst oxygen RETURN wire at the OEM terminal strip.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the sensor harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-204 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a pin-to-pin short circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the sensor harness.
  • Disconnect the post catalyst oxygen SIGNAL and post catalyst oxygen RETURN sensor wires from the OEM terminal strips in the OEM panel.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the post catalyst oxygen SIGNAL pin on the oxygen sensor connector and all other pins in the sensor harness.
  • Measure the resistance between the post catalyst oxygen RETURN pin on the oxygen sensor connector and all other pins in the sensor harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the sensor harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and 47 pin harness to OEM panel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the 47-pin connector.

Action

Inspect the ECM connector pins and the 47-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the 47-pin connector to the OEM panel.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the heated oxygen sensor from the sensor harness.
  • Disconnect the post catalyst oxygen signal and post catalyst oxygen return sensor wires n the 47-pin harness from the terminal strips in the OEM panel.

Action

Check for an open circuit.

  • Measure the resistance between the post catalyst oxygen SIGNAL pin in ECM connector B and the post catalyst oxygen SUPPLY pin in the 47-pin connector.
  • Measure the resistance between the post catalyst oxygen RETURN pin in ECM connector B and the post catalyst oxygen RETURN pin in the 47-pin connector.
  • Measure the resistance between the post catalyst oxygen SIGNAL pin in 47-pin connector and the post catalyst oxygen SIGNAL wire at the OEM terminal strip.
  • Measure the resistance between the post catalyst oxygen RETURN pin in 47-pin connector and the post catalyst oxygen RETURN wire at the OEM terminal strip.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine or OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.
  • Disconnect the 47-pin connector.
  • Disconnect the post catalyst oxygen signal and post catalyst oxygen return wires in the 47 pin harness from the terminal strips in the OEM panel.

Action

Check for a short circuit to ground.

  • Measure the resistance between the post catalyst oxygen SIGNAL pin in ECM connector B and all other pins in both ECM connector A and ECM Connector B.
  • Measure the resistance between the post catalyst oxygen RETURN pin in ECM connector B and all other pins in both ECM connector A and ECM Connector B.
  • Measure the resistance between the post catalyst oxygen SIGNAL pin in 47-pin connector and all other pins in the 47-pin harness to OEM control panel.
  • Measure the resistance between the post catalyst oxygen RETURN pin in 47-pin connector and all other pins in the 47-pin harness to OEM control panel.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1862 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1862 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Aug-2012


FAULT CODE 1863 - Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the post catalyst oxygen sensor until it has cooled. The post catalyst oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the post catalyst oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault code. | Fault Code 1863 active?
STEP 2. | Check the post catalyst oxygen sensor. |
 | STEP 2A. Inspect the sensor harness and post catalyst oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage 13.6 to 14.0-VDC?
 | STEP 2C. Check the post catalyst oxygen sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check for an open circuit in the sensor harness. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit to ground in the sensor harness. | Greater than 100k ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the sensor harness.. | Greater than 100k ohms?
STEP 3. | Check the engine harness and 47-pin harness to OEM panel. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault codes. | Fault Code 1863 inactive?
STEP 4. | Check the OEM control panel. |
 | STEP 4A. Check the OEM terminal strip supply voltage. | Supply voltage 13.6 to 14.0-VDC?
 | STEP 4B. Check the switched mode 24 to 13.8-VDC converter. | Supply voltage 24-VDC?
 | STEP 4C. Check the OEM supply voltage circuit. | Issues or damage found?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1863 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1863 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the post catalyst oxygen sensor.

Guided Step 2A - Inspect the sensor harness and post catalyst oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post catalyst oxygen sensor from the sensor harness.

Action

Inspect the sensor harness and post catalyst oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the sensor harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the post catalyst oxygen sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Engine running for more than 45 seconds.
  • Disconnect the post catalyst oxygen sensor from the sensor harness.

Action

Measure the post catalyst oxygen sensor heater supply voltage.

  • Measure the voltage between post catalyst oxygen heater SUPPLY pin and post catalyst oxygen RETURN pin in the sensor harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Supply voltage 13.6 to 14.0-VDC?
YES NO
No Repair

There is an issue in the sensor supply voltage circuit. The sensor is not getting enough voltage to function properly.

Go to 2C

Go to 4A

Guided Step 2C - Check the post catalyst oxygen sensor heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post catalyst oxygen sensor from the sensor harness.

Action

Check the heated post catalyst oxygen heater.

  • Measure the resistance between the post catalyst oxygen sensor heater supply and the post catalyst oxygen sensor heater return at the post catalyst oxygen connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the post catalyst oxygen sensor.

  • Refer to Procedure 019-100 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the sensor harness.
  • Disconnect the post catalyst oxygen SIGNAL and post catalyst oxygen RETURN sensor wires from the OEM terminal strips in the OEM panel.

Action

Check for an open circuit.

  • Measure the resistance between the post catalyst oxygen SIGNAL pin on the oxygen sensor connector and the post catalyst oxygen SIGNAL wire at the OEM terminal strip.
  • Measure the resistance between the post catalyst oxygen RETURN pin on the oxygen sensor connector and the post catalyst oxygen RETURN wire at the OEM terminal strip.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine or sensor harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check for an open circuit to ground in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the sensor harness.
  • Disconnect the post catalyst oxygen SIGNAL and post catalyst oxygen RETURN sensor wires from the OEM terminal strips in the OEM panel.

Action

Check for a short circuit to ground.

  • Measure the resistance between the post catalyst oxygen SIGNAL pin on the oxygen sensor connector and ground.
  • Measure the resistance between the post catalyst oxygen RETURN pin on the oxygen sensor connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the sensor harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 5A

Guided Step 2F - Check for a pin-to-pin short circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the sensor harness.
  • Disconnect the post catalyst oxygen SIGNAL and post catalyst oxygen RETURN sensor wires from the OEM terminal strips in the OEM panel.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the post catalyst oxygen SIGNAL pin on the oxygen sensor connector and all other pins in the sensor harness.
  • Measure the resistance between the post catalyst oxygen RETURN pin on the oxygen sensor connector and all other pins in the sensor harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness and 47 pin harness to OEM panel.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the 47-pin connector.

Action

Inspect the e ECM connector pins and the 47 pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the 47 pin connector to the OEM panel.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the 47-pin connector.
  • Disconnect the post catalyst oxygen SIGNAL and post catalyst oxygen RETURN wires in the 47-pin harness from the terminal strips in the OEM panel.

Action

Check for an open circuit.

  • Measure the resistance between the post catalyst oxygen SIGNAL pin in ECM connector A and the post catalyst oxygen RETURN pin in the 47-pin connector.
  • Measure the resistance between the post catalyst oxygen RETURN pin in ECM connector A and the post catalyst oxygen RETURN pin in the 47-pin connector.
  • Measure the resistance between the post catalyst oxygen SIGNAL pin in 47-pin connector and the post catalyst oxygen SIGNAL wire at the OEM terminal strip.
  • Measure the resistance between the post catalyst oxygen RETURN pin in 47-pin connector and the post catalyst oxygen RETURN wire at the OEM terminal strip.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine or engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector B from the ECM.
  • Disconnect the 47-pin connector.
  • Disconnect the post catalyst oxygen signal and post catalyst oxygen return wires in the 47 pin harness from the terminal strips in the OEM panel.

Action

Check for a short circuit to ground.

  • Measure the resistance between the post catalyst oxygen SIGNAL pin in ECM connector B and ground.
  • Measure the resistance between the post catalyst oxygen RETURN pin in ECM connector B and ground.
  • Measure the resistance between the post catalyst oxygen SIGNAL pin in 47-pin connector and ground.
  • Measure the resistance between the post catalyst oxygen RETURN pin in 47-pin connector to OEM control panel connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine or 47-pin connector to OEM control panel.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short circuit in the sensor harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors A and B from the ECM.
  • Disconnect the 47-pin connector.
  • Disconnect the post catalyst oxygen SIGNAL and post catalyst oxygen RETURN wires in the 47-pin harness from the terminal strips in the OEM panel.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the post catalyst oxygen SIGNAL pin in ECM connector B and all other pins in both ECM connector A and ECM Connector B.
  • Measure the resistance between the post catalyst oxygen RETURN pin in ECM connector B and all other pins in both ECM connector A and ECM Connector B.
  • Measure the resistance between the post catalyst oxygen SIGNAL pin in 47-pin connector and all other pins in the 47-pin harness to OEM control panel.
  • Measure the resistance between the post catalyst oxygen RETURN pin in 47-pin connector and all other pins in the 47-pin harness to OEM control panel.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-202 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

Go to 3A

Go to 5A

Guided Step 3E - Check for an inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1863 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 4 - Clear the OEM control panel.

Guided Step 4A - Check the OEM terminal strip supply voltage.

Conditions

  • Engine running for more than 45 seconds.
  • Disconnect the sensor harness from the OEM terminal strips.

Action

Measure the heated oxygen sensor heater supply voltage.

  • Measure the voltage between post catalyst oxygen heater supply terminal and post catalyst oxygen return terminal on the OEM terminal strip.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Supply voltage 13.6 to 14.0-VDC?
YES NO
No Repair

An open, short to ground, or pin-to-pin short has been detected in the sensor harness.

  • Repair or replace the sensor harness. Refer to Procedure 019-202 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the switched mode 24 to 13.8-VDC converter.

Conditions

  • Turn keyswitch ON.
  • Engine running for more than 45 seconds.

Action

Measure the supply voltage to the switched mode 24 to 13.8 VDC converter.

  • Measure the voltage from the battery +24-VDC wire to battery return wire going into the switched mode 24 to 13.8-VDC converter.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Supply voltage 24-VDC?
YES NO
No Repair

If there is 24-VDC going to the switched mode 24 to 13.8-VDC converter and not13.8-VDC out, then a faulty converter has been detected.

Replace switched mode 24 to 13.8-VDC converter. Refer to the OEM service manual.

Go to 4C

Go to 5A

Guided Step 4C - Check the OEM supply voltage circuit.

Conditions

  • Engine running for more than 45 seconds.

Action

Check OEM control panel for damaged wires, shorts, or open circuits. Possible causes:

  • Blown fuse
  • Malfunctioning 24 to 13.8-VDC converter
  • Low battery voltage.

Refer to the OEM wire diagram for wire names and detailed component location.

Issues or damage found?
YES NO
No Repair

Repair or replace the damaged components or wires. Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1862 is inactive.

Fault Code 1863 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Aug-2012


FAULT CODE 1965 - Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1965 or 1966 are active?
STEP 2. | Check the turbocharger outlet or exhaust outlet. |
 | STEP 2A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil contamination found in the turbocharger exhaust outlet?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1965 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1965 or 1966 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the turbocharger outlet.

Guided Step 2A - Inspect the exhaust outlet or turbocharger exhaust outlet for oil.

Conditions

  • Remove the exhaust outlet plumbing.

Action

Look for signs of oil in the exhaust outlet.

  • Inspect the exhaust outlet for signs of oil being introduced into the aftertreatment system from the engine.

Engine oil contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1966 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Aug-2012


FAULT CODE 1966 - Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1965 or 1966 active?
STEP 2. | Check the turbocharger outlet or exhaust outlet. |
 | STEP 2A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil contamination found in the turbocharger exhaust outlet?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1966 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1965 or 1966 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the turbocharger outlet.

Guided Step 2A - Inspect the exhaust outlet or turbocharger exhaust outlet for oil.

Conditions

  • Remove the exhaust outlet plumbing.

Action

Look for a sign of moisture in the exhaust outlet.

  • Inspect the exhaust outlet for signs of oil being introduced into the aftertreatment system from the engine.

Engine oil contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage.

Locate the cause of possible engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1966 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Aug-2012


FAULT CODE 1968 - Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1969 are active?
STEP 2. | Check the turbocharger outlet or exhaust outlet. |
 | STEP 2A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil contamination found in the turbocharger exhaust outlet?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1968 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1969 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the turbocharger outlet.

Guided Step 2A - Inspect the exhaust outlet or turbocharger exhaust outlet for oil.

Conditions

  • Remove the exhaust outlet plumbing.

Action

Look for signs of oil in the exhaust outlet.

  • Inspect the exhaust outlet for signs of oil being introduced into the aftertreatment system from the engine.

Engine oil contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1968 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Aug-2012


FAULT CODE 1969 - Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the turbocharger outlet or exhaust outlet. |
 | STEP 1A. Inspect the turbocharger exhaust outlet for oil. | Engine oil contamination found in the turbocharger exhaust outlet?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1969 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the turbocharger outlet.

Guided Step 1A - Inspect the exhaust outlet or turbocharger exhaust outlet for oil.

Conditions

  • Remove the exhaust outlet plumbing.

Action

Look for signs of oil in the exhaust outlet.

  • Inspect the exhaust outlet for signs of oil being introduced into the aftertreatment system from the engine.

Engine oil contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1969 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Aug-2012


FAULT CODE 1978 - Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes.. | Fault Code 1978 active?
 | STEP 1B. Check other active fault codes. | Fault Code 386 active?
STEP 2. | Check the OEM control panel. |
 | STEP 2A. Check the OEM voltage governing device. | Voltage governing device working properly?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and 47-pin harness to the OEM control panel connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the 47 pin harness to the OEM control panel |
 | STEP 4A. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4B. Check for an open circuit in the harness. | Less than 10 ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 1978 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check other active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

An issue with the voltage supply for the governing device has been detected.

  • Troubleshoot Fault Code 386.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the OEM Control Panel.

Guided Step 2A - Check the OEM governing device.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM speed bias potentiometer or voltage bias from the customer terminal strips.

Action

Inspect the OEM voltage governing device for correct functionality. If a potentiometer is used, check the resistors in the circuit for correct resistance.

  • Refer to the OEM service manual for circuit diagrams and component location.

Voltage governing device working properly?

YES NO
No Repair

Replace the OEM voltage governing device. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and 47-pin harness to OEM control panel connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connectors A and B from the ECM
  • Disconnect the 47-pin connector from the engine harness.

Action

Inspect the engine harness, ECM, and 47-pin harness to OEM control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM, harness, or 47-pin connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47 pin connector. Refer to Procedure 019-207 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both engine harness connectors A and B from the ECM.
  • Disconnect the 47-pin connector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the sensor supply 1 pin in engine harness connector A and generator/speed load governing bias supply pin in the 47-pin connector.
  • Measure the resistance between the generator/speed load governing bias signal pin in engine harness connector B and generator/speed load governing bias signal pin in the 47-pin connector.
  • Measure the resistance between the generator/speed load governing bias return pin in engine harness connector B and generator/speed load governing bias return pin in the 47-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin connector. Refer to Procedure 019-207 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both engine harness connectors A and B from the ECM.
  • Disconnect the 47-pin connector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor supply 1 pin in engine harness connector A and all other pins in both engine harness connectors A and B.
  • Measure the resistance between the generator/speed load governing bias signal pin in engine harness connector B and all other pins in both engine harness connectors A and B.
  • Measure the resistance between the generator/speed load governing bias return pin in engine harness connector B and all other pins in both engine harness connectors A and B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the 47-pin harness to OEM control panel.

Guided Step 4A - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector.
  • Disconnect the 5 volt regulated supply, generator/speed load governing bias supply, and generator/speed load governing bias return wires from the customer terminal strip.

Action

Check for a pin-to-pin short in the wiring harness:

  • Measure the resistance from the generator/speed load governing bias signal pin in the 47-pin connector and all other pins in the 47-pin connector.
  • Measure the resistance from the generator/speed load governing bias supply pin in the 47-pin connector and all other pins in the 47-pin connector.
  • Measure the resistance from the generator/speed load governing bias return pin in the 47-pin connector and all other pins in the 47-pin connector.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the 47-pin connector. Refer to Procedure 019-207 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector.
  • Disconnect the 5 volt regulated supply, generator/speed load governing bias supply and generator/speed load governing bias RETURN wires from the customer terminal strip.

Action

Check for an open circuit.

  • Measure the resistance between the generator/speed load governing bias SIGNAL pin in the 47-pin connector and the 5 volt regulated supply wire at the customer terminal strip.
  • Measure the resistance between the generator/speed load governing bias SUPPLY pin in the 47-pin connector and the generator/speed load governing bias SUPPLY wire at the customer terminal strip.
  • Measure the resistance between the generator/speed load governing bias RETURN pin in the 47-pin connector and the generator/speed load governing bias RETURN wire at the customer terminal strip.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1978 is inactive.

Fault Code 1978 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Aug-2012


FAULT CODE 1979 - Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new engine control module ( ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes.. | Fault Code 1979 active?
 | STEP 1B. Check other active fault codes. | Fault Code 352 active?
STEP 2. | Check the OEM control panel. |
 | STEP 2A. Check the OEM voltage governing device. | Voltage governing device working properly?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and 47-pin harness to the OEM control panel connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check the 47-pin harness to the OEM control panel |
 | STEP 4A. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 4B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 1979 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check other active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

An issue with the voltage supply for the governing device has been detected.

  • Troubleshoot Fault Code 352.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the OEM Control Panel.

Guided Step 2A - Check the OEM governing device.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM speed bias potentiometer or voltage bias from the customer terminal strips.

Action

Inspect the OEM voltage governing device for correct functionality. If a potentiometer is used, check the resistors in the circuit for correct resistance.

  • Refer to the OEM service manual for circuit diagrams and component location.

Voltage governing device working properly?

YES NO
No Repair

Replace the OEM voltage governing device. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and 47-pin harness to OEM control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors A and B from the ECM.
  • Disconnect the 47-pin connector from the engine harness.

Action

Inspect the engine harness, ECM, and 47-pin harness to OEM control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM, harness, or 47-pin connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin connector. Refer to Procedure 019-207 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both engine harness connectors A and B from the ECM.
  • Disconnect the 47-pin connector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the sensor SUPPLY 1 pin in engine harness connector A and generator/speed load governing SUPPLY pin in the 47-pin connector.
  • Measure the resistance between the generator/speed load governing SIGNAL pin in engine harness connector B and generator/speed load governing SIGNAL pin in the 47-pin connector.
  • Measure the resistance between the generator/speed load governing RETURN pin in engine harness connector B and generator/speed load governing RETURN pin in the 47-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin connector. Refer to Procedure 019-207 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both engine harness connectors A and B from the ECM.
  • Disconnect the 47-pin connector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 1 pin in engine harness connector A and all other pins in both engine harness connectors A and B.
  • Measure the resistance between the generator/speed load governing SIGNAL pin in engine harness connector B and all other pins in both engine harness connectors A and B.
  • Measure the resistance between the generator/speed load governing RETURN pin in engine harness connector B and all other pins in both engine harness connectors A and B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both engine harness connectors A and B from the ECM.
  • Disconnect the 47-pin connector from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the sensor SUPPLY 1 pin in engine harness connector A and ground.
  • Measure the resistance between the generator/speed load governing SIGNAL pin in engine harness connector B and ground.
  • Measure the resistance between the generator/speed load governing RETURN pin in engine harness connector B and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the 47-pin connector. Refer to Procedure 019-207 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the 47-pin harness to OEM control panel.

Guided Step 4A - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector.
  • Disconnect the 5 volt regulated supply, generator/speed load governing supply, and generator/speed load governing RETURN wires from the customer terminal strip.

Action

Check for a pin-to-pin short in the wiring harness:

  • Measure the resistance from the generator/speed load governing SIGNAL pin in the 47-pin connector and all other pins in the 47-pin connector.
  • Measure the resistance from the generator/speed load governing SUPPLY pin in the 47-pin connector and all other pins in the 47-pin connector.
  • Measure the resistance from the generator/speed load governing RETURN pin in the 47-pin connector and all other pins in the 47-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the 47-pin connector. Refer to Procedure 019-207 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector.
  • Disconnect the 5 volt regulated supply, generator/speed load governing SUPPLY and generator/speed load governing RETURN wires from the customer terminal strip.

Action

Check for an open circuit.

  • Measure the resistance between the generator/speed load governing SIGNAL pin in the 47-pin connector and the 5 volt regulated SUPPLY wire at the customer terminal strip.
  • Measure the resistance between the generator/speed load governing SUPPLY pin in the 47-pin connector and the generator/speed load governing SUPPLY wire at the customer terminal strip.
  • Measure the resistance between the generator/speed load governing RETURN pin in the 47-pin connector and the generator/speed load governing RETURN wire at the customer terminal strip.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector.
  • Disconnect the 5 volt regulated supply, generator/speed load governing SUPPLY and generator/speed load governing RETURN wires from the customer terminal strip.

Action

Check for a short circuit to ground.

  • Measure the resistance between the generator/speed load governing SIGNAL pin in the 47-pin connector and ground.
  • Measure the resistance between the generator/speed load governing SUPPLY pin in the 47-pin connector and ground.
  • Measure the resistance between the generator/speed load governing SIGNAL pin in the 47-pin connector and ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the 47-pin connector. Refer to Procedure 019-207 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1979 is inactive.

Fault Code 1979 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Aug-2012


FAULT CODE 1982 - Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1982 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Temperature within 3°C or 5°F?
STEP 3. | Check the catalyst temperature sensors. |
 | STEP 3A. Inspect the catalyst temperature sensors and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 1982 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1982 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1982 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

Compare both catalyst temperature sensor readings from INSITE™ electronic service tool to the reading from the probe.

NOTE: If no temperature measuring device is available, answer “NO” to this step.

Temperature within 3°C or 5°F?
YES NO
No Repair

Replace the catalyst temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment sensor harnesses.

Guided Step 3A - Inspect both catalyst temperature sensors and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the catalyst temperature sensors.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1982 active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 1982 is inactive.

Fault Code 1982 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Aug-2012


FAULT CODE 1983 - Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1983 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Temperature within 3°C or 5°F?
STEP 3. | Check the catalyst temperature sensors. |
 | STEP 3A. Inspect the catalyst temperature sensors and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 1983 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1983 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 1983 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

Compare both catalyst temperature sensor reading from INSITE™ electronic service tool to the reading from the probe.

NOTE: If no temperature measuring device is available, answer “NO” to this step.

Temperature within 3°C or 5°F?
YES NO
No Repair

Replace the catalyst temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment sensor harnesses.

Guided Step 3A - Inspect both catalyst temperature sensors and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the catalyst temperature sensors.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1983 active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 1983 is inactive.

Fault Code 1983 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 21-Aug-2012


FAULT CODE 2217 - Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM and engine harness. |
 | STEP 1A. Check for fault codes. | Fault Code 2217 active?
 | STEP 1B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the power supply. | Constant +24-VDC power supply to the ECM?
 | STEP 1D. Check the ECM for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1E. Calibrate the ECM. | ECM calibrated successfully?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2217 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM and engine harness.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to check for fault codes.

Fault Code 2217 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the power supply.

Conditions

  • Turn keyswitch ON.
  • Disconnect engine harness connector A from the ECM.

Action

Check the power supply.

  • Check voltage between ECM +24-VDC pin and ECM ground pin in the engine harness connector.
  • Manipulate the wiring harness while reading the voltage to check for intermittent shorts or opens.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Constant +24-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the ECM has been detected. Make sure to check the positive and ground side of the circuit.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness or 47-pin harness to OEM control panel. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check ECM for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from the engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from the battery (-) post to all pins in the ECM connector ports.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

ECM calibrated successfully?
YES NO
No Repair

Active fault codes present.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 2217 is inactive.

Fault Code 2217 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 04-Feb-2017


FAULT CODE 2311 - Electronic Fuel Injection Control Valve Circuit - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for ignition system faults. | Ignition system faults?
 | STEP 1B. Read the fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 2311 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2311 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for ignition system faults.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Ignition system faults?
YES NO

Use the following for instructions for to troubleshooting the ignition system. Reference the Master Repair Manual, QSL9 G CM558/CM2358, Bulletin 2883471.

No Repair

Go to 6A

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active or high inactive counts?
YES NO
No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the fuel valve command positive pin and the fuel valve command negative pin at the electronic fuel control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

  • Refer to Procedure 019-102 in Section 19.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the fuel valve command positive pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve.

  • Refer to Procedure 019-102 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the 47-pin harness to the OEM panel.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the electronic fuel control valve connector to the engine harness connector.
  • Disconnect the engine harness connector from the ECM connector B.

Action

Check the engine harness resistance.

  • Measure the resistance between the fuel valve command positive pin and the fuel valve command negative pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control valve connector from the engine harness connector.
  • Disconnect the engine harness connector from the ECM connector B.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the fuel valve command positive pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working over to the electronic fuel control valve.

Fault Codes 2311 active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

  • Refer to the circuit diagram or wiring harness for all harness interconnections.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the electronic fuel control valve. Refer to Procedure 019-102 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2311 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-Jun-2014


FAULT CODE 2315 - Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2315 active?
STEP 2. | Check the OEM control panel. |
 | STEP 2A. Check the OEM control panel and relays. | Any issues?
STEP 3. | Check the ECM and the wiring harness. |
 | STEP 3A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2315 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2315 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM control panel.

Guided Step 2A - Check the OEM control panel and relays.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM control panel for the following:

  • Blown fuse
  • Proper battery voltage
  • Proper wiring
  • Continuity
  • Short circuits
  • Relay functionality
  • Dirty or damaged connectors or pins.

Refer to the OEM service manual for component location and wiring information.

Any issues?
YES NO

Repair or replace the damaged section of the OEM control panel. Refer to the OEM service manual for component locations.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and wiring harness.

Guided Step 3A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.
  • Disconnect the 47-pin connector.

Action

Inspect the ECM, harness connectors, and 47-pin connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirt or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the 47-pin harness to the OEM control panel. Refer to Procedure 019-207 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector.
  • Disconnect the engine harness connectors A and B from the ECM.
  • Disconnect the red lamp signal wire from the relay in the OEM control panel.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the red stop lamp driver pin in ECM connector A to all other pins in the ECM connector A and B.
  • Measure the resistance from the red stop lamp driver pin in the 47-pin connector and all other pins in the 47-pin OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19
  • Repair or replace the 47-pin harness to the OEM control panel. Refer to Procedure 019-207 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connect A from the ECM.
  • Disconnect the 47-pin connector.
  • Disconnect the red lamp SIGNAL wire from the relay in the OEM control panel.

Action

Check for an open circuit.

  • Measure the resistance from the red stop lamp driver pin in the ECM connector A to the red stop lamp driver pin in the 47-pin connector.
  • Measure the resistance from the red stop lamp driver pin in the 47-pin connector to the engine shutdown red LED wire at the engine shutdown relay in the OEM control panel.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19
  • Repair or replace the 47-pin harness to the OEM control panel. Refer to Procedure 019-207 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let it idle for 1 minute.

Fault Code 2315 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Oct-2014


FAULT CODE 2316 - Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Check the OEM control panel and relays. | Any issues?
 | STEP 1B. Check for an open circuit. | Less than 10 ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2316 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM control panel and relays.

Guided Step 1A - Check the OEM control panel and relays.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM control panel for proper wiring, continuity, short circuits, relay functionality, and dirty or damaged pins.

  • Refer to the OEM service manual for OEM control panel schematics.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Any issues?
YES NO

Repair or replace the damaged section of the OEM control panel. Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors A and B from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the amber lamp driver pin on the engine harness ECM connector A to the amber lamp driver wire at the relay (CR6) in the OEM control panel.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected. Locate the damaged section of the harness or OEM control panel.

  • Repair or replace the harness. Refer to Procedure 019-043 in Section 19.
  • Refer to the OEM service manual for OEM control panel component details.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connectors A and B from the ECM.

Action

Inspect the ECM and the wire harness connectors A and B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pin
  • Moisture in or on connector.
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors A and B from the ECM.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from amber lamp driver pin in the ECM connector A to all of the other pins in connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

A short has been detected on the amber warning lamp driver circuit. Locate the damaged section of the harness or OEM control panel.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Refer to the OEM service manual for OEM control panel component details.

Go to 3A

Go to 2C

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Turn keyswitch OFF for 30 seconds
  • Connect all components.

Fault Code 2316 inactive?
YES NO

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Go to the appropriate troubleshooting chart.

Repair complete.

Last Modified: 21-Aug-2012


FAULT CODE 2317 - Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM control panel and relays. |
 | STEP 1A. Inspect the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2E. Check for an open circuit in the 47-pin harness to the OEM control panel. | Less than 10 ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2317 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM control panel and relays.

Guided Step 1A - Inspect the OEM control panel and relays.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM control panel for proper wiring, continuity, short circuits, relay functionality, and dirty or damages pins.

Reference the QSL9 G CM558/CM2358 Wiring Diagram, Bulletin 2883396 for connector pin identification.

Refer to the OEM service manual for OEM control panel schematics.

Any issues?
YES NO

Repair or replace the damaged section of the OEM control panel. Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors A and B from the ECM.
  • Disconnect the 47-pin harness to the OEM control panel connector from the ECM.

Action

Inspect the ECM, engine harness, and 47-pin harness to the OEM control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pin
  • Moisture in or on connector.
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors A and B from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the amber warning lamp driver pin in the engine harness connector A to all of the other pins in the engine harness connector A and B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 2C

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors A and B from the ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from the amber warning lamp driver pin in the engine harness connector A to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 2D

Guided Step 2D - Check for an open circuit in the engine harness.

Conditions

  • Disconnect the engine harness connector A from the ECM
  • Disconnect the 47-pin harness to the OEM control panel connector.

Action

Check for an open circuit.

  • Measure the resistance from the amber warning lamp driver pin in the engine harness connector A to the amber warning lamp driver pin in the 47-pin harness to the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit in the 47-pin harness to the OEM control panel.

Conditions

  • Disconnect the 47-pin harness to the OEM control panel connector
  • Disconnect the amber warning lamp driver circuit.

Action

Check the resistance of the amber warning lamp driver circuit.

  • Measure the resistance from the amber warning lamp driver pin in the 47-pin harness to the OEM control panel connector to the amber warning lamp driver contract in the OEM control panel.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completes and checked again.

An open circuit has been detected.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let it idle for 1 minute.

Fault Code 2317 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO

Troubleshoot any remaining active fault codes.

Troubleshoot any remaining fault codes.

Go to the appropriate troubleshooting chart.

Repair complete.

Last Modified: 11-Jun-2014


FAULT CODE 2455 - External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM control panel. |
 | STEP 1A. Inspect the OEM control panel. | Problems identified in the OEM control panel?
STEP 2. | Check for an open circuit in the engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Check the resistance in the external governor speed or frequency bias signal (4-20 mA) wire. |
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit in the 47-pin harness to the OEM control panel. | Less than 10 ohms?
 | STEP 2D. Check for an open circuit in the 47-pin harness to the OEM control panel. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2455 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM control panel.

Guided Step 1A - Inspect the OEM control panel.

Conditions

  • Disconnect the 47-pin harness to the OEM control panel from the engine harness.

Action

Check for open circuits on the external governor speed or frequency bias signal (4-20 mA) wire and the external governor speed or frequency bias return wire.

  • Check the OEM control panel for proper wiring, continuity, short circuits, OEM governing device, and dirty or damaged pins or terminals.
  • Verify the OEM governing device is producing commanded current.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to the OEM service manual for OEM control panel schematics.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Problems identified in the OEM control panel?
YES NO

Repair or replace the damaged section of the OEM control panel. Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check for an open circuit in the engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the 47-pin harness to the OEM control panel from the engine harness.

Action

Inspect the ECM, engine harness, and 47-pin harness to the OEM control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2A-1

Guided Step 2A-1 - Check the resistance in the external governor speed or frequency bias signal (4-20 mA) wire.

Conditions

  • Disconnect the engine harness connector A from the ECM.
  • Disconnect the 47-pin harness to the OEM control panel from the engine harness.

Action

Check the resistance in the external governor speed or frequency bias signal (4-20 mA) wire.

Measure the resistance from the external governor speed frequency bias signal (4-20 mA) pin in the engine interface connector A to the external governor speed or frequency bias signal (4-20 mA) pin at the 47-pin harness to the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?

YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Disconnect the engine harness connect A from the ECM.
  • Disconnect the 47-pin harness to the OEM control panel from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the external governor speed or frequency bias return (4-20 mA) pin in the engine harness connector A to the external governor speed or frequency bias return (4-20 mA) pin in the 47-pin harness to the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit in the 47-pin harness to the OEM control panel.

Conditions

  • Disconnect the 47-pin harness to the OEM control panel from the engine harness.
  • Disconnect the external governor speed or frequency bias signal (4-20 mA) wire in the OEM control panel.

Action

Check the resistance in the external governor speed or frequency bias signal (4-20 mA) wire.

  • Measure the resistance from the external governor speed or frequency bias signal (4-20 mA) pin in the 47-pin harness to the OEM control panel connector to the external governor speed or frequency bias signal (4-20 mA) wire in the OEM control panel.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit in the 47-pin harness to the OEM control panel.

Conditions

  • Disconnect the external governor speed or frequency bias return (4-20 mA) wire in the OEM control panel.
  • Disconnect the 47-pin harness to the OEM control panel from the engine harness.

Action

Check the resistance in the external governor speed or frequency bias return (4-20 mA) wire.

  • Measure the resistance from the external governor speed or frequency bias return (4-20 mA) wire in the 47-pin harness to the OEM control panel connector to the external governor speed or frequency bias return (4-20 mA) wire in the OEM control panel.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance from the external governor speed frequency bias signal (4-20 mA) pin in the ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2455 is inactive.

Fault Code 2455 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 21-Aug-2012


FAULT CODE 2456 - External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM control panel. |
 | STEP 1A. Inspect the OEM control panel. | Problems identified in OEM control panel?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2456 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM control panel.

Guided Step 1A - Inspect the OEM control panel.

Conditions

  • Disconnect the 47-pin harness to the OEM control panel from the engine harness.

Action

Check for short circuits on the external governor speed or frequency bias signal (4-20mA) wire and the external governor speed or frequency bias return wire.

  • Check OEM control panel for proper wiring, continuity, short circuits, relay functionality, OEM governing device, and dirty or damaged pins.
  • Verify the OEM governing device output is not exceeding 20 mA.

Refer to the OEM service manual for OEM control panel schematics.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Contact a Cummins® Authorized Repair Location for installation guidelines, and the OEM for OEM control panel schematics.

Problems identified in the OEM control panel?
YES NO

Repair or replace the damaged section of the OEM control panel. Refer to the OEM service manual for OEM control panel component information.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the 47-pin harness to the OEM control panel connector.

Action

Inspect the ECM, engine harness, and 47-pin to the OEM control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the external governor speed or frequency bias signal (4-20mA) wire in the ECM connector to all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let the engine idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2456 is inactive.

Fault Code 2456 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All inactive fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-Aug-2012


FAULT CODE 2544 - Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2544 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2544 active?
YES NO

Allow the ECM to cool and then restart the engine. If the fault occurs again, contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 22-Aug-2012


FAULT CODE 2661- At Least One Unacknowledged Most Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2661 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive fault codes?
YES NO

Troubleshoot other fault codes before acknowledging this fault code.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the OEM-supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2661 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Aug-2012


FAULT CODE 2789 - Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2789 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does temperature differ more than 5°C or 10°F?
STEP 3. | Check the coolant temperature sensor. |
 | STEP 3A. Inspect the coolant temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 2789 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2789 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.

Fault Code 2789 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the coolant temperature reading on INSITE™ electronic service tool to the reading from the temperature probe.

NOTE: Monitor INSITE™ electronic service tool and temperature probe readings at multiple points throughout the operating temperature range.

NOTE: If a temperature measuring device is not available, answer "NO" to this step.

Does temperature differ more than 5°C or 10°F?
YES NO

Replace the coolant sensor.

  • Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the coolant temperature sensor.

Guided Step 3A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if is is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Operate the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2789 active?
YES NO

Reference the Coolant Temperature Below Normal troubleshooting symptom tree in the QSL9 G CM558/CM2358 Service Manual, Bulletin 2883375 in Section TS.

No Repair

  • 4A

Go to 4B

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2789 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 11-Jun-2014


FAULT CODE 2793 - Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2793 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does temperature differ more than 5°C or 10°F?
STEP 3. | Check the coolant temperature sensor. |
 | STEP 3A. Inspect the coolant temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 2793 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2793 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.

Fault Code 2793 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the coolant temperature reading on INSITE™ electronic service tool to the reading from the temperature probe.

NOTE: Monitor INSITE™ electronic service tool and temperature probe reading at multiple points throughout the operating temperature range.

NOTE: If a temperature measuring device is not available, answer "NO" to this step.

Does temperature differ more than 5°C or 10°F?
YES NO

Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the coolant temperature sensor.

Guided Step 3A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19
  • Replace the coolant sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Operate engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2793 active?
YES NO

Reference the Coolant Temperature Below Normal troubleshooting symptom tree in the QSL9 G CM558 Service Manual, Bulletin 2883375 in Section TS.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Operate the engine and let it idle for 1 minute.
  • Verify that Fault Code 2793 is inactive.

Fault Code 2793 active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-Aug-2012


FAULT CODE 2864 - Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the fuel shutoff valve. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 2864 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2864 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place Run/Stop/Auto switch in STOP mode
  • Disconnect the engine harness from the fuel shutoff valve and the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the 47-pin harness to the OEM control panel.
  • Disconnect the engine harness from the fuel shutoff valve.
  • Disconnect the engine connector A and B from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness connector to all other pins in the engine harness connectors.
  • Measure the resistance from the fuel shutoff valve DRIVER pin on the engine harness connector to all other pins in the engine harness connectors.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector from the fuel shutoff valve.
  • Place Run/Stop/Auto switch in RUN mode and crank engine.

Action

Check for the appropriate ECM response.

  • Install a jumper to power the fuel shutoff valve relays and then crank the engine.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 2864 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in RUN mode and running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2864 is inactive.

Fault Code 2864 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 22-Aug-2012


FAULT CODE 2866 - Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electronic fuel control valve. |
 | STEP 1A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 2C. Check for an intermittent engine harness problem. | Fault Code 2866 become active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2866 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the electronic fuel control valve.

Guided Step 1A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.
  • Disconnect the engine harness connector B from the ECM.

Action

Check the engine harness resistance.

  • Measure the resistance from the engine electronic fuel valve 1 position SIGNAL pin to all other pins in the engine harness connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an intermittent engine harness connection.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Code 2866 active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

  • Refer to the circuit diagram or wiring harness for all harness interconnections.
  • Replace the damaged section of engine harness. Refer to Procedure 019-043 in Section 19.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2866 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Oct-2014


FAULT CODE 2867 - Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electronic fuel control valve. |
 | STEP 1A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine harness resistance. | Greater than 100k ohms?
 | STEP 2C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 2D. Check for an intermittent engine harness problem. | Fault Code 2867 becomes active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2867 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the electronic fuel control valve.

Guided Step 1A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair or replace the engine harness, or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine electronic fuel valve 1 connector to the engine harness connector.
  • Disconnect the engine harness connector B from the ECM.

Action

Check the engine harness resistance.

  • Measure the resistance from the engine electronic fuel valve 1 position SIGNAL pin to all other pins in the engine harness connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general reisistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine electronic fuel valve 1 connector from the engine harness connector.
  • Disconnect the engine harness connector B from the ECM.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the engine electronic fuel valve 1 position SIGNAL pin at the engine harness connector B and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Code 2867 active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

  • Refer to the circuit diagram or wiring harness for all harness interconnections.
  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2867 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-Aug-2012


FAULT CODE 2995 - Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2995 active?
 | STEP 1B. Check for high intake manifold temperature fault codes. | Fault Code 155 or 488 active?
STEP 2. | Check the sensor accuracy and wiring. |
 | STEP 2A. Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge. | INSITE™ electronic service tool reading within 17 kPa [2.5 PSI] of mechanical gauge reading?
 | STEP 2B. Inspect the intake pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
STEP 3. | Verify the engine load is within specifications. |
 | STEP 3A. Check to make sure the engine is not overloaded. | Engine overloaded?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2995 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2995 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for high intake manifold temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 or 488 active?
YES NO

Troubleshoot any active fault code before completing this troubleshooting tree.

 No Repair

Go to the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the sensor accuracy and wiring.

Guided Step 2A - Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge.

Conditions

  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Verify sensor accuracy.

  • Connect a mechanical pressure gauge to the engine, as close to the intake pressure/temperature sensor as possible in the intake manifold.
  • Start INSITE™ Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

NOTE: If the engine shuts down while trying to compare the measurements, unplug the sensor to allow the engine to run. Make sure to monitor pressure using a mechanical gauge and compare to values recorded in INSITE™ electronic service tool while the sensor was installed.

INSITE™ electronic service tool reading within 17 kPa [2.5 PSI] of mechanical gauge reading?
YES NO
No Repair

Replace the intake pressure/temperature sensor. Refer to Procedure 019-354 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the intake pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake pressure/temperature sensor. Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Verify the engine load is within specifications.

Guided Step 3A - Check to be sure the engine is not overloaded.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Compare load demanded to engine horsepower with applicable derates.

  • Contact the OEM to determine load demanded by the compressor or other driven devices.
  • Make sure engine has applicable derates.
  • Use the following procedure in the Operation and Maintenance Manual, QSL9 G CM558/CM2358, Bulletin 2883374. Refer to Procedure 018-033 in Section V.

Engine overload?
YES NO

Reduce engine load and be sure engine has applicable derates.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2995 is inactive.

Fault Code 2995 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 11-Jun-2014


FAULT CODE 2996 - Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2996 active?
 | STEP 1B. Check for high intake manifold temperature fault codes. | Fault Code 155 or 488 active?
STEP 2. | Check the sensor accuracy and wiring. |
 | STEP 2A. Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge. | INSITE™ electronic service tool reading within 127 mm-Hg [5 in-Hg] of mechanical gauge reading?
 | STEP 2B. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
STEP 3. | Verify the engine load is within specifications. |
 | STEP 3A. Check to make sure the engine is not overloaded. | Engine overloaded?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2996 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2996 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for high intake manifold temperature fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 or 488 active?
YES NO

Troubleshoot active fault codes before continuing this troubleshooting tree.

 No Repair

Go to the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the sensor accuracy and wiring.

Guided Step 2A - Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge.

Conditions

  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Verify sensor accuracy.

  • Connect a mechanical pressure gauge to the engine, as close to the intake pressure/temperature sensor as possible in the intake manifold.
  • Start INSITE™ Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 17kPa [2.5PSI] of mechanical gauge reading?
YES NO
No Repair

Replace the intake pressure/temperature sensor. Refer to Procedure 019-354 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the intake pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake pressure/temperature sensor.

Action

Inspect the following sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake pressure/temperature sensor. Refer to Procedure 019-354 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Verify the engine load is within specifications.

Guided Step 3A - Check to make sure the engine is not overloaded.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Compare load demanded to engine horsepower with applicable derates.

Contact the OEM to determine load demanded by the compressor or other driven device.

Be sure the engine has applicable derates.

Use the following procedure in the Operation and Maintenance Manual, QSL9 G CM558, Bulletin 2883374. Refer to Procedure 018-033 in Section V.

Engine overloaded?
YES NO

Reduce engine load and be sure the engine has applicable derates.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2996 is inactive.

Fault Code 2996 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 22-Aug-2012


FAULT CODE 3288 - Aftertreatment Outlet Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 or 478 active?
STEP 2. | Check the relay. |
 | STEP 2A. Inspect the relay. | Resistance between 64 and 475 ohms?
STEP 3. | Check the OEM panel. |
 | STEP 3A. Inspect the OEM panel connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short. | Greater than 100k ohms?
STEP 4. | Check the 47-pin harness to the OEM panel. |
 | STEP 4A. Inspect the 47-pin harness to the OEM panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short. | Greater than 100k ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open circuit. | Less than 10 ohms?
 | STEP 5C. Check for a pin-to-pin short. | Greater than 100k ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 1862 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 442 or 478 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the relay.

Guided Step 2A - Inspect the relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel from the engine harness.
  • Remove the aftertreatment outlet oxygen concentration sensor power relay (CR3) from the OEM panel.

Action

Check the aftertreatment outlet oxygen concentration sensor power relay (CR3) resistance across the coil.

Resistance between 64 and 475 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 6A

Guided Step 3 - Check the OEM panel.

Guided Step 3A - Inspect the OEM panel connector pins.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the terminals and connection points on the post catalyst power-up relay driver circuit for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM panel.

Repair or replace the wire or connector, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the OEM for wire and connector repair instructions.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the batteries. Refer to the OEM service manual.
  • Disconnect the post catalyst oxygen power relay command wire from the CR3 relay coil. Leave the wire connected to the relay coming from the 47-pin harness to the OEM panel.
  • Disconnect the post catalyst oxygen power relay command wire from the negative side of the battery.

Action

Check for an open circuit.

  • Measure the resistance between the post catalyst oxygen power relay command pin at the CR3 relay and the post catalyst oxygen power relay command pin at the negative side of the battery.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the wiring.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring. Refer to the OEM for wire and connector repair instructions.
  • Replace the wiring. Refer to the OEM for wire and connector repair instructions.

Go to 3C

Go to 6A

Guided Step 3C - Check for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the batteries. Refer to the OEM service manual.
  • Disconnect the post catalyst oxygen power relay command wire from the negative side of the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the post catalyst oxygen power relay command wire pin at the connector to the negative side of the battery and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification. Refer to the OEM for panel wiring diagrams and customer connections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the OEM panel.

  • Repair or replace the wire.
  • Repair the wiring. Refer to the OEM for wiring and connector repair instructions.
  • Replace the wiring. Refer to the OEM for wiring and connector replacement instructions.

Go to 4A

Go to 6A

Guided Step 4 - Check the 47-pin harness to the OEM panel.

Guided Step 4A - Inspect the 47-pin harness to the OEM panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector of the engine harness from the 47-pin harness to the OEM panel.

Action

Inspect the engine harness 47-pin connector and the 47-pin harness to the OEM panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt of debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or the 47-pin harness to the OEM panel connector.

Repair or replace the wire or connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the 47-pin harness to the OEM panel or connectors. Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector of the engine harness from the 47-pin harness to the OEM panel.
  • Disconnect the 47-pin harness to the OEM panel post catalyst oxygen power relay command wire from relay coil CR3.

Action

Check for an open circuit.

  • Measure the resistance between the post catalyst oxygen power relay command pin at the 47-pin harness to OEM panel connector and the post catalyst oxygen power relay command wire at the CR3 relay coil.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the 47-pin harness to the OEM panel.

  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the OEM service manual.

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector of the engine harness from the 47-pin harness to the OEM panel.
  • Disconnect the 47-pin harness to the OEM panel post catalyst oxygen power relay command wire from relay coil CR3.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the post catalyst oxygen power relay command pin at the 47-pin harness to the OEM panel connector and all of the other pins in the 47-pin harness to the OEM panel connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the 47-pin harness to the OEM panel.

Repair or replace the 47-pin harness to the OEM panel.

  • Install the appropriate connector seal if it is missing or damaged.
  • Repair or replace the 47-pin harness to the OEM panel. Refer to the OEM service manual.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine harness.

Guided Step 5A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A from the ECM.
  • Disconnect the 47-pin harness to the OEM panel connector from the engine harness 47-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the post catalyst oxygen power relay command pin at the ECM connector A of the engine harness and the post catalyst oxygen power relay command pin at the 47-pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A and B from the ECM.
  • Disconnect the 47-pin harness to the OEM panel connector from the engine harness 47-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the post catalyst oxygen power relay command pin at the ECM connector A of the engine harness and all other pins in the ECM connectors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 3288 is inactive.

Fault Code 3288 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-Aug-2012


FAULT CODE 3289 - Aftertreatment Outlet Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the aftertreatment outlet oxygen concentration sensor until it has cooled. The aftertreatment outlet oxygen concentration sensor operates at high temperature and can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441 and 442 or 477 and 478 active?
STEP 2. | Check the relay. |
 | STEP 2A. Inspect the relay | Resistance between 64 and 475 ohms?
STEP 3. | Check the OEM panel. |
 | STEP 3A. Inspect the OEM panel connector pins. | Dirty or damaged pins?
STEP 4. | Check the 47-pin harness to the OEM panel. |
 | STEP 4A. Inspect the 47-pin harness to the OEM panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 1862 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the relay.

Guided Step 2A - Inspect the relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel from the engine harness.
  • Remove the aftertreatment outlet oxygen concentration sensor power relay (CR3) from the OEM panel.

Action

Check the aftertreatment outlet oxygen concentration sensor power relay (CR3) resistance across the coil.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 64 and 475 ohms?
YES NO
No Repair

Replace the relay. Refer to the OEM service manual for replacement instructions.

Go to 3A

Go to 6A

Guided Step 3 - Check the OEM panel.

Guided Step 3A - Inspect the OEM panel connector pins.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the terminals and connection points on the post catalyst oxygen power relay command circuit for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM panel.

Repair or replace the wire or connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Refer to the OEM service manual for wire and connection repair instructions.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the 47-pin harness to the OEM panel.

Guided Step 4A - Inspect the 47-pin harness to the OEM panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector of the engine harness from the 47-pin harness to the OEM panel.

Action

Inspect the engine harness 47-pin connector and the 47-pin harness to the OEM panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or the 47-pin harness to the OEM panel connector.

Repair or replace the wire or connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine harness or connector.
  • Replace the 47-pin harness to the OEM panel or connectors. Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector of the engine harness from the 47-pin harness to the OEM panel.
  • Disconnect the 47-pin harness to the OEM panel post catalyst oxygen power relay command wire from the relay coil CR3.

Action

Check for a short circuit to ground.

  • Measure the resistance between the post catalyst oxygen power relay command pin at the 47-pin harness to the OEM panel connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the 47-pin harness to the OEM panel.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the 47-pin harness to the OEM panel. Refer to the OEM service manual.

  • 5A

Go to 6A

Guided Step 5 - Check the engine harness.

Guided Step 5A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A and B from the ECM.
  • Disconnect the 47-pin harness to the OEM panel connector from the engine harness 47-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the post catalyst oxygen power relay command pin at the ECM connector A of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in Run mode and running for more than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3289 is inactive.

Fault Code 3289 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-Aug-2012


FAULT CODE 3291 - Aftertreatment Inlet Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3291 active?
STEP 2. | Check the relay. |
 | STEP 2A. Inspect the relay. | Resistance between 64 and 475 ohms?
STEP 3. | Check the OEM panel. |
 | STEP 3A. Inspect the OEM panel connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short. | Greater than 100k ohms?
STEP 4. | Check the 47-pin harness to the OEM panel. |
 | STEP 4A. Inspect the 47-pin harness to the OEM panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short. | Greater than 100k ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for a pin-to-pin short. | Greater than 100k ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 1858 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3291 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the relay.

Guided Step 2A - Inspect the relay.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment inlet oxygen concentration sensor power relay (CR1) from the OEM panel.

Action

Check the aftertreatment inlet oxygen concentration sensor power relay (CR1) resistance across the coil.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Resistance between 64 and 475 ohms?
YES NO
No Repair

Replace the relay. Refer to the OEM service manual.

Go to 3A

Go to 6A

Guided Step 3 - Check the OEM panel.

Guided Step 3A - Inspect the OEM panel connector pins.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the terminals and connection points on the pre-catalyst oxygen power relay command circuit for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM panel.

Repair or replace the wire or connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the batteries. Refer to the OEM service manual.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the pre-catalyst oxygen power relay command wire pin at the connector to the positive side of the battery and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification. Refer to the OEM service manual for panel wiring diagram and customer connections.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM panel.

  • Repair or replace the wire. Refer to the OEM service manual.

Go to 4A

Go to 6A

Guided Step 4 - Check the 47-pin harness to the OEM panel.

Guided Step 4A - Inspect the 47-pin harness to the OEM panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector of the engine harness from the 47-pin harness to the OEM panel.

Action

Inspect the engine harness 47-pin connector and the 47-pin harness to the OEM panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or the 47-pin harness to the OEM panel connector.

Repair or replace the wire or connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the 47-pin harness to the OEM panel or connectors. Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector of the engine harness from the 47-pin harness to the OEM panel.
  • Disconnect the 47-pin harness to the OEM panel pre-catalyst oxygen power relay command wire from relay coil CR3.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the pre-catalyst oxygen power relay command pin at the 47-pin harness to the OEM panel connector and all other pins in the 47-pin harness to the OEM panel connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the 47-pin harness to the OEM panel.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the 47-pin harness to the OEM panel. Refer to the OEM service manual.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine harness.

Guided Step 5A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A and B from the ECM.
  • Disconnect the 47-pin harness to the OEM connector from the engine harness 47-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the pre-catalyst oxygen power relay command pin at the ECM connector A of the engine harness and all other pins in the ECM connectors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in RUN mode and operate engine for more than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3291 is inactive.

Fault Code 3291 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-Aug-2012


FAULT CODE 3292 - Aftertreatment Intake Oxygen Concentration Sensor Power Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperatures and can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1859 active?
STEP 2. | Check the relay. |
 | STEP 2A. Inspect the relay. | Resistance between 64 and 475 ohms?
STEP 3. | Check the OEM panel. |
 | STEP 3A. Inspect the OEM panel connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check the 47-pin harness to the OEM panel. |
 | STEP 4A. Inspect the 47-pin harness to the OEM panel connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open circuit. | Less than 10 ohms?
 | STEP 5C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 3291 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch is STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3292 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the relay.

Guided Step 2A - Inspect the relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM panel from the engine harness.
  • Remove the aftertreatment outlet oxygen concentration sensor power relay (CR3) across the coil.

Action

Check the aftertreatment outlet oxygen concentration sensor power relay (CR3) resistance across the coil.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 64 and 475 ohms?
YES NO
No Repair

Replace the relay. Refer to the OEM service manual.

Go to 3A

Go to 6A

Guided Step 3 - Check the OEM panel.

Guided Step 3A - Inspect the OEM panel connector pins.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the terminals and connection points on the pre-catalyst oxygen power relay command circuit for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM panel.

Repair or replace the wire or connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the batteries. Refer to the OEM service manual.

Action

Check for an open circuit.

  • Measure the resistance between the pre-catalyst oxygen power relay command wire at the CR1 relay and the EGO pre-catalyst power-up relay pin at the positive side of battery (2BAT+).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the damaged wiring.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring. Refer to the OEM service manual.
  • Replace the wiring. Refer to the OEM service manual.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the batteries. Refer to the OEM service manual.
  • Disconnect the pre-catalyst oxygen power relay command wire from the positive side of the battery (2BAT+).

Action

Check for a short to ground.

  • Measure the resistance between the pre-catalyst oxygen power relay command wire pin at the connector to the positive side of the battery (2BAT+) and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification. Refer to the OEM for panel wiring diagram and customer connections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM panel.

Repair or replace the wire.

  • Repair the wiring. Refer to the OEM service manual.
  • Replace the wiring. Refer to the OEM service manual.

Go to 4A

Go to 6A

Guided Step 4 - Check the 47-pin harness to the OEM panel.

Guided Step 4A - Inspect the 47-pin harness to the OEM panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector of the engine harness from the 47-pin harness to the OEM panel.

Action

Inspect the engine harness 47-pin connector and the 47-pin harness to the OEM panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or the 47 pin harness to OEM panel connector.

Repair or replace the wire or connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the 47-pin harness to the OEM panel or connectors. Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector of the engine harness from the 47-pin harness to the OEM panel.
  • Disconnect the 47-pin harness to the OEM panel pre-catalyst oxygen power relay command wire from relay coil CR1.

Action

Check for an open circuit.

  • Measure the resistance between the pre-catalyst oxygen power relay command pin at the 47-pin harness to OEM panel connector and the pre-catalyst oxygen power-up relay wire at the CR1 relay coil.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the 47-pin harness to the OEM panel.

  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the OEM service manual.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin connector of the engine harness from the 47-pin harness to the OEM panel.
  • Disconnect the 47-pin harness to the OEM panel pre-catalyst power relay command wire from relay CR1.

Action

Check for a short circuit to ground.

  • Measure the resistance between the pre-catalyst oxygen power relay command pin at the 47 pin harness to OEM panel connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the 47-pin harness to the OEM panel.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the 47-pin harness to the OEM panel. Refer to the OEM service manual.

  • 5A

Go to 6A

Guided Step 5 - Check the engine harness.

Guided Step 5A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A from the ECM.
  • Disconnect the 47-pin harness to the OEM panel connector from the engine harness 47-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the pre-catalyst oxygen power relay command pin at the ECM connector A of the engine harness and the pre-catalyst oxygen power relay command pin at the 47-pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

  • 5C

Go to 6A

Guided Step 5C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A and B from the ECM.
  • Disconnect the 47-pin harness to the OEM panel connector from the engine harness 47-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the pre-catalyst oxygen power relay command pin at the ECM connector A of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in Run mode and operate engine more than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1859 is inactive.

Fault Code 3292 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6B

Go to 6B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Oct-2014


FAULT CODE 3362 - Engine Electrical System Power Conservation Control - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the 47-pin harness to the OEM control panel. |
 | STEP 1A. Inspect the 47-pin harness to the OEM control panel. | Dirty or damaged pins?
 | STEP 1B. Check for an open in the battery conservation circuit. | Less than 10 ohms?
 | STEP 1C. Check the OEM control panel and relay. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1776 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the 47-pin harness to the OEM control panel.

Guided Step 1A - Inspect the 47-pin harness to the OEM control panel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin to the OEM control panel.

Action

Inspect the 47-pin harness to the control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness connector, or 47-pin harness to the OEM control panel, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the ignition ground connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 1C

Go to 3A

Guided Step 1B - Check for an open in the battery conservation circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM control panel.
  • Remove the diagnostic lamp.
  • Disconnect the ECM connector B.

Action

Check for an open circuit as follows:

  • Measure the resistance from the battery conservation relay RETURN wire at the battery conservation relay in the OEM control panel to the battery.
  • Measure the resistance from the battery conservation relay SUPPLY pin at the battery conservation relay in the OEM control panel to the battery conservation relay SUPPLY pin at the ECM connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

  • An open circuit has been detected. Determine the section of the harness containing the open circuit and repair or replace. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 1C - Check the OEM control panel and relay.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM control panel and relay for proper relay function, proper wiring, short circuits, open circuits, and/or damage.

  • Refer to the OEM service manual.

Any issues?
YES NO

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM control panel connector.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from battery conservation relay supply at ECM connector B to all of the other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the connectors. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 3362 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 22-Aug-2012


FAULT CODE 3363 - Engine Electrical System Power Conservation Control - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the 47-pin harness to the OEM control panel. |
 | STEP 1A. Inspect the 47-pin harness to the OEM control panel connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 3363 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the 47-pin harness to the OEM control panel.

Guided Step 1A - Inspect the 47-pin harness to the OEM control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM control panel connector.

Action

Inspect the 47-pin harness to the OEM control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness connector or 47-pin harness to the OEM control panel harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 1C

Go to 3A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM control panel connector.
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from the battery conservation relay SUPPLY pin on the 47-pin harness to the OEM control panel connector to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the harness. Refer to Procedure 019-071 in Section.

Go to 2A

Go to 3A

Guided Step 1C - Check the OEM control panel and relay.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM control panel and relay for proper relay function, proper wiring, short circuits, and/or damage.

  • Refer to the OEM service manual.

Any issues?
YES NO

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM control panel connector.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from ECM connector B battery conservation relay SUPPLY pin to all of the other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the connectors. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 2C

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 47-pin harness to the OEM control panel connector.
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from ECM connector B battery conservation relay SUPPLY pin to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 3363 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 06-Oct-2014


FAULT CODE 3364 - Engine Electrical System Power Conservation Control Diagnostics Has Detected An Error - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3364 active?
 | STEP 1B. Read the fault codes. | Fault Code 3362 active?
 | STEP 1C. Read the fault codes. | Fault Code 3363 active?
STEP 2. | Calibrate the engine control module (ECM). |
 | STEP 2A. Calibrate the ECM. | Fault Code 3364 active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3364 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3362 active?
YES NO

Refer to the appropriate troubleshooting tree.

 No Repair

Go to 1C

Go to 2A

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3363 active?
YES NO

Refer to the appropriate troubleshooting tree.

 No Repair

Go to 1C

Go to 2A

Guided Step 2 - Calibrate the ECM.

Guided Step 2A - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to calibrate the ECM.

Fault Code 3364 active?

YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Repair complete.

Repair complete.

Last Modified: 22-Aug-2012


FAULT CODE 3644 - Intake Manifold 1 Temperature - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1847. | Active or inactive counts of Fault Code 3644?
 | STEP 1B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 3644.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 3644.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 3644?
YES NO

Check for intake manifold related Fault Codes 153 and 154. Refer to the appropriate troubleshooting procedures for Fault Codes 153 and 154.

No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-Aug-2012


INDEX
149-fc121.htm

149-t05-121.htm

149-fc135.htm

149-t05-135.htm

149-fc141.htm

149-t05-141.htm

149-fc142.htm

149-t05-142.htm

149-fc143.htm

149-t05-143.htm

149-fc144.htm

149-t05-144.htm

149-fc145.htm

149-t05-145.htm

149-fc146.htm

149-t05-146.htm

149-fc151.htm

149-t05-151.htm

149-fc153.htm

149-t05-153.htm

149-fc154.htm

149-t05-154.htm

149-fc155.htm

149-t05-155.htm

149-fc177.htm

149-t05-177.htm

149-fc187.htm

149-t05-187.htm

149-fc212.htm

149-t05-212.htm

149-fc213.htm

149-t05-213.htm

149-fc214.htm

149-t05-214.htm

149-fc227.htm

149-t05-227.htm

149-fc234.htm

149-t05-234.htm

149-fc238.htm

149-t05-238.htm

149-fc239.htm

149-t05-239.htm

149-fc244.htm

149-t05-244.htm

149-fc254.htm

149-t05-254.htm

149-fc277.htm

149-t05-277.htm

149-fc343.htm

149-t05-343.htm

149-fc346.htm

149-t05-346.htm

149-fc352.htm

149-t05-352.htm

149-fc354.htm

149-t05-354.htm

149-fc355.htm

149-t05-355.htm

149-fc386.htm

149-t05-386.htm

149-fc415.htm

149-t05-415.htm

149-fc421.htm

149-t05-421.htm

149-fc426.htm

149-t05-426.htm

149-fc441.htm

149-t05-441.htm

149-fc442.htm

149-t05-442.htm

149-fc477.htm

149-t05-477.htm

149-fc478.htm

149-t05-478.htm

149-fc488.htm

149-t05-488.htm

149-fc512.htm

149-t05-512.htm

149-fc513.htm

149-t05-513.htm

149-fc689.htm

00-t05-689.htm

149-fc697.htm

149-t05-697.htm

149-fc698.htm

149-t05-698.htm

149-fc783.htm

149-t05-783.htm

149-fc1665.htm

149-t05-1665.htm

149-fc1666.htm

149-t05-1666.htm

149-fc1674.htm

149-t05-1674.htm

149-fc1675.htm

149-t05-1675.htm

149-fc1739.htm

149-t05-1739.htm

149-fc1791.htm

149-t05-1791.htm

149-fc1824.htm

149-t05-1824.htm

149-fc1858.htm

149-t05-1858.htm

149-fc1859.htm

149-t05-1859.htm

149-fc1862.htm

149-t05-1862.htm

149-fc1863.htm

149-t05-1863.htm

149-fc1965.htm

149-t05-1965.htm

149-fc1966.htm

149-t05-1966.htm

149-fc1968.htm

149-t05-1968.htm

149-fc1969.htm

149-t05-1969.htm

149-fc1978.htm

149-t05-1978.htm

149-fc1979.htm

149-t05-1979.htm

149-fc1982.htm

149-t05-1982.htm

149-fc1983.htm

149-t05-1983.htm

149-fc2217.htm

149-t05-2217.htm

149-fc2311.htm

149-t05-2311.htm

149-fc2315.htm

149-t05-2315.htm

149-fc2316.htm

149-t05-2316.htm

149-fc2317.htm

149-t05-2317.htm

149-fc2455.htm

149-t05-2455.htm

149-fc2456.htm

149-t05-2456.htm

149-fc2544.htm

149-t05-2544.htm

149-fc2661.htm

149-t05-2661.htm

149-fc2789.htm

149-t05-2789.htm

149-fc2793.htm

149-t05-2793.htm

149-fc2864.htm

149-t05-2864.htm

149-fc2866.htm

149-t05-2866.htm

149-fc2867.htm

149-t05-2867.htm

149-fc2995.htm

149-t05-2995.htm

149-fc2996.htm

149-t05-2996.htm

149-fc3288.htm

149-t05-3288.htm

149-fc3289.htm

149-t05-3289.htm

149-fc3291.htm

149-t05-3291.htm

149-fc3292.htm

149-t05-3292.htm

149-fc3362.htm

149-t05-3362.htm

149-fc3363.htm

149-t05-3363.htm

149-fc3364.htm

149-t05-3364.htm

149-fc3644.htm

149-t05-3644.htm