ISB5.9 G/ISC8.3 G CM2180/CM2380, ISB6.7G CM2380,

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the ECM related memory hardware failures or internal ECM voltage supply circuits. | Engine possibly will not start or operate.
Engine Control Module

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a read or write error internal to the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE electronic service tool.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code 111.

Last Modified: 01-Jun-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 190 FMI: 2 LAMP: Red SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect. | Engine can possibly die or will not start.
Engine Crankshaft and Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine camshaft speed/position circuit consists of two engine camshaft speed/position sensors. The engine camshaft speed/position sensor 1 is the primary engine position sensor and the engine camshaft position sensor 2 is the back up engine position sensor. Both engine camshaft speed/position sensors provide engine speed information to the electronic control module (ECM). The engine camshaft speed/position sensor 1 is powered by 5 volts from its dedicated sensor supply 3. The engine position sensor 2 is supplied 5 volts from sensor supply which is shares with other sensors on the sensor supply 1 circuit. The sensors generate a signal by sensing the movement of target teeth machined into camshaft gear.

Component Location

The engine camshaft speed/position sensors are located on the back side of the gear housing, above the air compressor. The engine camshaft speed/position sensors are mounted side by side. The engine camshaft speed/position sensor 1 is the outmost position sensor from the block. The engine camshaft speed/position sensor 2 is the closest to the block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The engine camshaft position sensors do not agree.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

When the intake manifold pressure indicates a vacuum, the ECM assumes the engine is operating. Fault Code 115 can become active with the keyswitch ON and the engine rpm at zero, if the intake manifold pressure indicates a pressure that is different than expected. INSITE™ electronic service tool can be used to compare the engine intake manifold pressure sensor to the engine throttle intake pressure sensor. These two sensors must be equal and read atmospheric pressure (101.3 kPa [14.7 psi] at sea level) with the keyswitch on and the engine not operating. If these are not equal, it possibly indicates an in-range malfunction of the intake manifold pressure sensor. The engine will possibly not start if this condition exists.

This fault code is recorded when the ECM does not receive a signal from the camshaft speedposition sensors, or if the signal it receives is degraded.

Possible causes of this fault code include:

  • Open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM
  • Short circuits to ground or return circuits in the sensor, engine harness, or ECM
  • Short circuits to a voltage source in the sensor, engine harness, or ECM
  • Damage to the sensor target teeth or tone wheel.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections, such as loose or worn pins in the engine harness connectors.

Refer to Troubleshooting Fault Code 115.

Last Modified: 01-Jun-2010


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. | Engine power derate.
Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine intake manifold pressure/temperature sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure/temperature sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions. The engine intake manifold pressure/temperature sensor is a combination sensor that also measures intake manifold temperature.

Component Location

The engine intake manifold pressure/temperature sensor is located on the back of the fuel module near the fuel pressure regulator end cap and fuel shutoff valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal voltage is greater than 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • A damaged sensor
  • Supply or signal line shorted to voltage source.
Refer to Troubleshooting Fault Code 122.

Last Modified: 19-Feb-2010


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance
Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine intake manifold pressure/temperature sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure/temperature sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions. The engine intake manifold pressure/temperature sensor is a combination sensor that also measures intake manifold temperature.

Component Location

The engine intake manifold pressure/temperature sensor is located on the back of the fuel module near the fuel pressure regulator end cap and fuel shutoff valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal voltage is less than 0.05-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code 123.

Last Modified: 18-Feb-2010


Intake Manifold 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 124

Intake Manifold 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 124 PID: P102 SPN: 102 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible reduced engine performance
Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine intake manifold pressure/temperature sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure/temperature sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions. The engine intake manifold pressure/temperature sensor is a combination sensor that also measures intake manifold temperature.

Component Location

The engine intake manifold pressure/temperature sensor is located on the back of the fuel module near the fuel pressure regulator end cap and fuel shutoff valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure is above a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Engine torque output will be derated.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine intake manifold pressure/temperature sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too high for the present the present operating conditions.

Refer to Troubleshooting Fault Code 124.

Last Modified: 01-Jun-2010


Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 125

Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 125 PID: P102 SPN: 102 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Intake manifold pressure is below the minimum operating limit. | Possible reduced engine performance.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor RETURN circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor SIGNAL circuit. This sensor signal voltage changes, based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions, such as during idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions. The engine intake manifold pressure/temperature sensor is a combination sensor that also measures intake manifold temperature.

Component Location

The engine intake manifold pressure/temperature sensor is located on the back of the fuel module, near the fuel pressure regulator end cap and fuel shutoff valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure is below a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Engine torque output will be derated.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine intake manifold pressure/temperature sensor monitors the pressure in the intake manifold. This fault is set active when the intake manifold pressure is too low for the present engine operating conditions.

Possible causes of this fault are:

  • Leaks in the air intake system between the turbocharger and intake manifold
  • A damaged intake manifold pressure sensor
  • A damaged barometric pressure sensor
  • Restriction in the charge-air cooler
  • Fuel inlet restriction too high (normally caused by a restricted fuel filter).
Refer to Troubleshooting Fault Code 125.

Last Modified: 23-Nov-2010


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 091 FMI: 3 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. | Engine will only idle.
Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator position sensor is a hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects when the throttle pedal signal voltage is greater than a calibrated value for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two accelerator position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal circuit shorted to battery or +5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Damaged accelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 131.

Last Modified: 01-Jun-2010


Accelerator Pedal or Lever Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 091 FMI: 4/4 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will enter limp-home mode.
Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator position sensor is a hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects when the accelerator pedal position 1 signal voltage is less than a calibrated value for more than 2 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and passes.

The engine will issue a severe power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let idle for 1 minute

  • The ECM will turn off the red STOP ENGINE light and/or the MIL immediately after the diagnostic runs and passes.
  • The inactive fault will be cleared from memory after the completion of 40 warm-up cycles.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 1 signal voltage can be monitored with INSITE™ electronic service tool while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Malfunctioning accelerator pedal position 1 sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 132.

Last Modified: 18-Mar-2010


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P372 SPN: 974 FMI: 3 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor Circuit - Voltage Above Normal or Shorted to High Source. | Engine will only idle if the remote accelerator is enabled.
ISL G CM2180 - Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects when the remote accelerator pedal signal voltage is greater than 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute:

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open remote accelerator pedal or lever return circuit in the harness or connections
  • Remote accelerator supply shorted to battery
  • Damaged remote accelerator pedal or lever position sensor.
Refer to Troubleshooting Fault Code 133.

Last Modified: 19-Feb-2010


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P372 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will only idle if the remote accelerator is enabled.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal position sensor is located on the remote accelerator pedal. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch is in the ON position and the remote accelerator is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects which remote accelerator pedal signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the amber STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

On engines equipped with On-Board Diagnostics (OBD) the ECM will issue a derate after a calibrated period of time.

Conditions for Clearing the Fault Code

To validate the repair start the engine, turn the remote accelerator to the ON position, and let it idle for 1 minute.

  • The ECM will turn off the amber STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL immediately after the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor.
  • Damaged remote accelerator pedal or lever position sensor.
  • Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 134.

Last Modified: 01-Jun-2010


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | None on performance. No engine protection for oil pressure.
ISB5.9 CM2180 - Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located in the block, beneath the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the signal voltage on the engine oil pressure signal pin is greater than 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Engine protection for oil pressure will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • A pin-to-pin short circuit in the signal wire.

Does the fault code occur only in cold weather? If so, allow the oil to warm up and see if the fault code goes inactive.

Refer to Troubleshooting Fault Code 135.

Last Modified: 01-Jun-2010


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | None on performance. No engine protection for oil pressure.
Engine Oil Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The oil pressure sensor is located on the intake side of the engine block below the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is less than 0.25-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.
  • Engine protection for oil pressure will be disabled.

Conditions for Clearing the Fault Code

To validate the repair start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • INSITE™ electronic service tool can also be used to clear the fault code.

Shop Talk

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 141.

Last Modified: 26-Jan-2010


Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level. | Engine power derate
Engine Oil Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the intake side of the engine block, below the ECM.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure is less than the engine protection limits.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

A torque derate issued by the ECM limits the power output of the engine.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • Use INSITE electronic service tool to clear the fault code.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Damaged oil pressure switch
  • Engine harness shorted to ground.
Refer to Troubleshooting Fault Code 143.

Last Modified: 01-Jun-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | Possible reduced performance. No engine protection for coolant temperature.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant in the engine. The electronic control muodule (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature. The engine coolant temperature value is used by the ECM for the engine protection system and emissions control.

Component Location

The coolant temperature sensor is located below the exhaust manifold port for cylinder number 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the coolant temperature signal voltage is greater than 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails
  • A default value is used for the coolant temperature reading.
  • Engine protection for coolant temperature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • The inactive fault will be cleared from memory after the completion of 40 warm-up cycles.

Shop Talk

When the temperature of the engine coolant is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the temperature of the engine coolant is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature. The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

This fault can log in extremely cold weather.

The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (C) | Temperature [F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code 144.

Last Modified: 03-Mar-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced performance. No engine protection for coolant temperature.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant in the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is located below the exhaust manifold port for cylinder number 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the coolant temperature signal voltage is less than 0.1-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails
  • A default value is used for the coolant temperature reading
  • Engine protection for coolant temperature will be disabled
  • A torque derate is issued by the ECM, limiting the power output in engines equipped with On-Board-Diagnostics (OBD).

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • The inactive fault will be cleared from memory after the completion of 40 warm-up cycles.

Shop Talk

When the coolant temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the coolant temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature. The engine coolant temperature value is used by the ECM for the engine protection system.

Possible causes of this fault code include:

  • A damaged engine coolant temperature sensor
  • A short to ground on the signal wire
  • A pin-to-pin short on the signal wire.

The resistance of the sensor varies with temperature. The reading observed should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code 145.

Last Modified: 01-Jun-2010


Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Power derate and possible engine shutdown if engine protection shutdown feature is enabled.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant in the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature. The engine coolant temperature value is used by the ECM for the engine protection system, and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

When the temperature of the engine coolant is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the temperature of the engine coolant is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located below the exhaust manifold port for cylinder 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects when the coolant temperature is greater than a calibrated limit set in the ECM.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately after the diagnostic runs and fails. The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate in the condition in which the fault occurred.

  • The ECM will turn off the fault code immediately after the engine coolant temperature decreases below the engine protection limit.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code indicates that the engine coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to the Engine Coolant Temperature Above Normal symptom troubleshooting tree.

Refer to Troubleshooting Fault Code 146.

Last Modified: 01-Jun-2010


Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level. | Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant in the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature. The engine coolant temperature value is used by the ECM for the engine protection system, and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

When the temperature of the engine coolant is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the temperature of the engine coolant is hot, the sensor resistance is low. The signal voltge pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The coolant temperature sensor is located below the exhaust manifold port for cylinder 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than the maximum operating limits set in the ECM calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to the Engine Coolant Temperature Above Normal troubleshooting symptom tree.

Refer to Troubleshooting Fault Code 151.

Last Modified: 01-Jun-2010


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold air temperature.
Engine Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine intake manifold pressure/temperature sensor is a variable resistor sensor and is used to measure the pressure and temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. The engine intake manifold pressure/temperature sensor is a combination sensor that also measures intake manifold pressure.

Component Location

The engine intake manifold pressure/temperature sensor is located on the back of the fuel module near the fuel pressure regulator end cap and fuel shutoff valve.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature signal voltage is greater than 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque may be reduced.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

When the temperature of the fuel mixture in the intake manifold is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the temperature of the air in the intake manifold is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. This fault may occur in extremely cold temperatures.

Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.

The resistance of the sensor varies with temperature. The reading observed should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 28k to 32k
10 | 50 | 18k to 20k
20 | 68 | 11k to 13k
30 | 86 | 7k to 9k
40 | 104 | 5300 to 5850
Refer to Troubleshooting Fault Code 153.

Last Modified: 19-Feb-2010


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced performance. Fan will stay ON if controlled by ECM. No engine protection for intake manifold air temperature.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine intake manifold pressure/temperature sensor is a variable resistor sensor and is used to measure the pressure and temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. The engine intake manifold pressure/temperature sensor is a combination sensor that also measures intake manifold pressure.

Component Location

The engine intake manifold pressure/temperature sensor is located on the back of the fuel module near the fuel pressure regulator end cap and fuel shutoff valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature signal voltage is less than 0.06-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque may be reduced.
  • An default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive igntition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

When the intake manifold air temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake manifold air temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. This fault may occur in extremely cold temperatures.

Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor

The resistance of the sensor varies with temperature. The reading observed should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code 154.

Last Modified: 19-Feb-2010


Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level. | Progressive power derate increasing in severity from time of alert. If engine protection shutdown feature is enabled, engine will shutdown 30 seconds after the red STOP lamp starts flashing.
Engine Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine intake manifold pressure/temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

When the intake air is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature. This sensor is a combination sensor and is also used to measure intake manifold pressure.

Component Location

The engine intake manifold pressure/temperature sensor is located on the back of the fuel module near the fuel pressure regulator end cap and fuel shutoff valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature is above the maximum operating limits in the ECM calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.

The ECM will turn off the red STOP ENGINE light immediately after the intake manifold temperature returns to normal operating limits.

Shop Talk

This fault code indicates that the intake manifold temperature has exceeded the maximum engine protection limit.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature

The resistance of the sensor varies with temperature. The reading observed should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

This sensor can control the engine fan if the OEM utilizes this feature within the ECM. The engine protection shutdown feature is customer-enabled and will require enabling at the customer's request.

Refer to Troubleshooting Fault Code 155.

Last Modified: 01-Jun-2010


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 176

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 176 PID: SPN: 3464 FMI: 4/4 LAMP: Red SRT: | Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source | Engine speed will only idle with a possible increase in idle speed.
Engine Throttle Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is cranking or operating.

Conditions for Setting the Fault Codes

The ECM detects that actual throttle position is greater than commanded throttle position by more than a calibrated amount.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.
  • Possible increase in idle speed.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles in which the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes for this fault code include:

  • A damaged throttle actuator
  • An open circuit in the wiring harness
  • A short circuit in the wiring harness.
Refer to Troubleshooting Fault Code 176.

Last Modified: 24-Aug-2010


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced performance.
Sensor Supply 2 Circuit

Circuit Description

This is 5 volt sensor supply 2 circuit . The ECM provides a 5-VDC supply for the engine intake manifold pressure/temperature sensor, engine oil pressure sensor, engine fuel regulator intake pressure sensor, exhaust back pressure sensor and engine fuel regulator outlet pressure/temperature sensor.

Component Location

The sensor supply 2 circuit is located in the wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 1 voltage is less than a calibrated value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on sensor supply 2.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles in which the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The voltage supplies are divided into 6 circuits 1 thru 6. Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 187.

Last Modified: 30-Mar-2010


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. | None on performance. No engine protection for coolant level.
Engine Coolant Level Sensor Circuit

Circuit Description

The electronic control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is greater than a calibratible amount for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code 195.

Last Modified: 01-Jun-2010


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant level circuit. | None on performance. No engine protection for coolant level.
Coolant Level Sensor 1 Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor SUPPLY circuit. The ECM also provides a ground on the sensor RETURN circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor SIGNAL circuit. This sensor signal voltage changes, based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is less than a calibratible value for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

The coolant level sensor is supplied by the OEM.

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to ground in the engine harness, connector, or sensor
  • Damaged engine coolant level sensor.
Refer to Troubleshooting Fault Code 196.

Last Modified: 18-Mar-2010


Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level. | Engine power derate.
Engine Coolant Level Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes, based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level is below the normal operating limits.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light after 20 seconds when low engine coolant level has been detected.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after 20 seconds of detecting the correct engine coolant level.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code 197.

Last Modified: 01-Jun-2010


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: 221 SPN: 3510 FMI: 3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. | Possible reduced performance.
Sensor Supply Voltage 2

Circuit Description

This is 5 volt sensor supply 2 circuit. The electronic control module (ECM) provides a 5 volt supply for the engine intake manifold pressure/temperature sensor, engine oil pressure sensor, engine fuel regulator intake pressure sensor, exhaust back pressure sensor and engine fuel regulator outlet pressure/temperature sensor.

Component Location

The sensor supply 2 circuit is contained in the wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects the sensor supply 2 signal voltage is more than 5.63-VDC for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

High voltage on the sensor supply 2 supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 227.

Last Modified: 01-Jun-2010


Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: 190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level. | Spark and fuel disabled until engine speed falls below the overspeed limit.
Engine Camshaft Speed/Position Sensor 1 Circuit

Circuit Description

The engine camshaft speed/position sensor 1 is the primary engine position sensor. The engine camshaft speed/position sensor 1 provides engine speed and position information to the electronic control module (ECM). The engine camshaft speed/position sensor 1 is powered by 5 volts from a dedicated sensor supply 3. The sensors generate a signal by sensing the movement of target teeth machined into the camshaft gear.

Component Location

The engine crankshaft speed/position sensors are located on the back side of the gear housing, above the compressor. The engine camshaft speed/position sensors are mounted side by side. The engine camshaft speed/position sensor 1 is the furthest position sensor from the block. The engine camshaft speed/position sensor 2 is the closest to the block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects engine speed greater than 3400 rpm.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the engine drops below 3200 rpm.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Make sure the correct operation conditions are followed when operating the engine as described in the operation and maintenance manual. To check for valid overspeed, check the fault code snapshot information for the speed reached.

Refer to Troubleshooting Fault Code 234.

Last Modified: 01-Jun-2010


Coolant Level - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | Coolant Level - Data Valid but Below Normal Operational Range - Most Severe Level. | Progressive power and speed derate; if engine protection shutdown is enabled, engine will shut down after 30 seconds of the lamp flashing.
Engine Coolant Level Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level is below the normal operating limits.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light after 20 seconds when low engine coolant level has been detected

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after 20 seconds of detecting the correct engine coolant level.

Shop Talk

This fault code becomes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

The engine protection for coolant level is a customer feature and will only be enabled at the customer's request. This sensor must deactivate or disable the fuel control valve if this feature is utilized by the OEM.

Refer to Troubleshooting Fault Code 235.

Last Modified: 01-Jun-2010


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced performance.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the engine camshaft speed/position sensor.

Component Location

The sensor supply 3 circuit is contained in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 3 signal voltage is less than 4.42-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will use the engine camshaft speed/position sensor 2 to determine engine speed and position.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

High voltage on the sensor supply 3 supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 238.

Last Modified: 01-Jun-2010


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. | Possible reduced performance.
Sensor Supply Number 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the engine camshaft speed/position sensor 1.

Component Location

The sensor supply circuit number 3 circuit is contained in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs contiuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 3 signal voltage is more than 5.63-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will use the engine camshaft speed/position sensor 2.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

High voltage on the sensor supply 3 supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 239.

Last Modified: 01-Jun-2010


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P84 SPN: 84 FMI: 2 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect. | Engine speed limited to maximum engine speed without VSS parameter value. Cruise control, gear-down protection, and road speed governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the original equipment manufactured (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion.

Conditions for Setting the Fault Codes

The ECM detects a loss of vehicle speed when other engine operating conditions indicate that the vehicle is in motion.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

Conditions for Clearing the Fault Code

  • Start the engine and move the vehicle.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid engine speed signal from the vehicle speed sensor.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake, or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a vehicle speed signal greater than zero. Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not detect all malfunctions of the circuit, due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors, and tachographs are not fully covered under this procedure.

Refer to Troubleshooting Fault Code 241.

Last Modified: 01-Jun-2010


Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P084 SPN: 84 FMI: 10/10 LAMP: Amber SRT: | Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change. Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to maximum engine speed without VSS parameter value. Cruise control, gear-down protection, and road speed governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission.

Conditions for Running the Diagnostics

  • The adjustable parameter "VSS Anti-Tampering" must be enabled.
  • This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The ECM detects a tampering event of the vehicle speed signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".
  • Cruise Control, Gear-down Protection, and Road Speed Governor features will be disabled.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and move the vehicle so the ECM detects road speed.

  • The ECM detects a valid vehicle speed signal from the vehicle speed sensor.
  • The keyswitch must be turned ON, and the vehicle speed and engine speed must be 0 for 10 seconds.

Shop Talk

Verify that the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for the specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

Refer to Troubleshooting Fault Code 242.

Last Modified: 19-Feb-2010


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S33 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. | None on performance. Fan will lock ON or OFF.
Engine Fan Clutch Supply Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the electronic control module (ECM) energizes the fan control circuit, the engine fan is engaged. The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement. There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is presently set up for use. The fan control circuit varies by the original equipment manufactured (OEM). Certain OEMs may use a solenoid return that is wired to the ECM, or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the relay is being energized or de-energized. In some cases, the diagnostics can also run at fixed intervals.

Conditions for Setting the Fault Codes

The fan control circuit PWM signal is not detected to be system voltage when the PWM signal is turned ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The fan control will not be enabled.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The fan control logic can be adjusted with INSITE™ electronic service tool. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle. The low voltage on the signal circuit may indicate a short circuit to ground in the harness or solenoid. If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Refer to Troubleshooting Fault Code 245.

Last Modified: 03-Mar-2010


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 SPN: 632 FMI: 4/4 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source | Fuel shutoff valve closes. Engine will stall or will not start.
Engine Fuel Shutoff Valve Circuit

Circuit Description

The engine fuel shutoff valve is a solenoid that is used to shutoff the flow of gas to the engine. The electronic control module (ECM) controls the fuel shutoff valve. The engine fuel shut off valve is a normally closed valve. The ECM will open the valve when it detects engine rpm.

Component Location

The engine fuel shutoff valve is located on the back of the fuel module, near the fuel pressure regulator end cap.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the ECM detects engine speed.

Conditions for Setting the Fault Codes

The ECM does not detect voltage when the engine fuel shutoff valve is commanded open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The engine fuel shutoff valve will not open. The engine will not start or run.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine fuel shutoff valve
  • Pin-to-ground short in the engine harness
  • Pin-to-pin short in the engine harness.
Refer to Troubleshooting Fault Code 254.

Last Modified: 27-Jan-2010


Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 255

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S17 SPN: 632 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source. | Engine fuel shutoff valve closes. Engine will stall or will not start.
Engine Fuel Shutoff Valve Circuit

Circuit Description

The engine fuel shutoff valve is a solenoid that is used to shut off the flow of gas to the engine. The electronic control module (ECM) controls the fuel shutoff valve. The engine fuel shutoff valve is a normally closed valve. The ECM will open the valve when it detects engine rpm.

Component Location

The engine fuel shutoff valve is located on the back of the fuel module, near the fuel pressure regulator end cap.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the ECM detects engine speed.

Conditions for Setting the Fault Codes

The ECM detects voltage when the engine fuel shutoff valve is commanded closed.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

  • The engine fuel shutoff valve will not open; the engine willnotstart or run.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light, and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine fuel shutoff valve
  • Pin-to-pin short in the engine harness.
Refer to Troubleshooting Fault Code 255.

Last Modified: 27-Jan-2010


Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 263

Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance.
Engine Fuel Regulator Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The engine fuel regulator pressure/temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel exiting the engine (low pressure) regulator. The electronic control module (ECM) supplies 5 volts to the engine fuel regulator outlet temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the fuel temperature.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing near the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine fuel regulator outlet temperature signal voltage is greater than 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the fuel regulator outlet temperature reading is used

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

When the temperature of the fuel exiting the engine (low pressure) regulator is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. The ECM senses a high signal voltage or low temperature. When the temperature of the fuel exiting the engine (low pressure) regulator is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Possible causes of this fault code include:

  • Pin-to-pin short circuit in the signal line
  • Open circuit in the signal line
  • Damaged engine fuel regulator outlet pressure/temperature sensor.
  • Extremely low temperatures.

The resistance of the sensor varies with temperature. The reading observed should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code 263.

Last Modified: 04-Mar-2010


Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 265

Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced performance.
Engine Fuel Regulator Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The engine fuel regulator outlet pressure/temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel exiting the engine (low pressure) regulator. The electronic control module (ECM) supplies 5 volts to the engine fuel regulator outlet temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the fuel temperature.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing near the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine fuel regulator outlet temperature signal voltage is less than 0.06-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the fuel regulator outlet temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

When the fuel temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage, or low temperature. When the fuel temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Damaged engine fuel regulator outlet pressure/temperature sensor.

The resistance of the sensor varies with temperature. The reading observed should compare to the following table if the sensor is functioning properly.

Temperature (C) | Temperature [F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code 265.

Last Modified: 24-Mar-2010


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. | One or more multiplexed devices will not operate properly. One or more symptoms will occur.
SAE J1939 Multiplexing Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine.

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1 second.

The ECM detects an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Possible causes for this fault code include:

  • The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® engine ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® engine ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® engine ECM, a bad connection between the component and the OEM VECU, damaged OEM VECU or damaged Cummins® engine ECM. It may be necessary to contact the OEM for proper multiplexing configuration.
  • Use INSITE™ electronic service tool to monitor multiplexed components.
Refer to Troubleshooting Fault Code 285.

Last Modified: 27-Jan-2010


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. | At least one multiplexed device will not operate properly.
SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. The component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from OEM VECU's or Transmission ECU's are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM VECU(s) must be configured correctly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine.

The J1939 data link wiring and VECU location vary by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

Use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code 286.

Last Modified: 04-Mar-2010


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

FAULT CODE 287

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 287 PID: P91 SPN: 91 FMI: 2/19 LAMP: Red SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error. | Engine may only idle or engine may not accelerate to full speed.
SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) VECU or transmission electronic control unit in the cab. The component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from the OEM VECU or transmission electronic control unit are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM VECU must be configured correctly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. The J1939 data link wiring and VECU location vary by OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent, but the secondary throttle position sensor indicates it is in the idle position.

When the accelerator is released and the OEM VECU reads accelerator position as 0 percent, but the secondary throttle position sensor indicates it is not in the idle position.

The OEM VECU determines that the accelerator signal wire is shorted high or shorted low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault can occur when the OEM VECU detects an error on the accelerator. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the idle validation switch states and accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component.

Possible causes for this fault code include:

  • Accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent but the idle validation switch indicates it is in the idle position. This fault status is transmitted to the Cummins® engine ECM on the J1939 data link.
  • Accelerator is released and the OEM VECU reads accelerator position as 0 percent, but the idle validation switch indicates it is not in the idle position. This fault status is transmitted to the Cummins® engine ECM on the J1939 data link.
  • The OEM VECU determines that the accelerator signal line is shorted high or shorted low.

NOTE: It is still possible to get Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins® engine ECM for other components, or if the accelerator and idle validation switch, or the data link is damaged. The OEM configurations must multiplex the accelerator and idle validation switch inputs together to allow the use of the J1939 multiplexing and limp home feature for these components. INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code 287.

Last Modified: 27-Jan-2010


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

FAULT CODE 288

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P372 SPN: 974 FMI: 2/19 LAMP: Red SRT: | SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error. | The engine will not respond to the remote throttle. Engine may only idle. The primary or cab accelerator may be able to be used.
SAE J1939 Multiplexing Remote Accelerator Pedal or Lever

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine Electronic Control Module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an Originial Equipment Manufacturer (OEM) vehicle electronic control unit (VECU) or transmission Electronic Control Unit (ECU) in the cab. The component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from the OEM VECU or transmission ECU are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. The J1939 data link wiring and VECU location varies by OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The OEM VECU determines the remote throttle signal wire is shorted high or shorted low. This fault status is transmitted to the Cummins® engine ECM on the J1939 data link.

When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU, this fault status is transmitted to the ECM on the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • The inactive fault will clear after 40 ignition cycles.

Shop Talk

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM VECUs will not have the circuitry to detect a remote throttle switch error.

Possible causes of this fault code include:

  • The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins® engine ECM on the J1939 data link.
  • When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU, this fault status is transmitted to the ECM on the J1939 data link. Most OEM VECUs will not incorporate fault detection on a switch.

Note: It is still possible to get Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins® engine ECM for other components, or if the remote throttle and remote throttle switch, or the data link is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components.

INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code 288.

Last Modified: 27-Jan-2010


Barometric Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 295

Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2/2 LAMP: Amber SRT: | Barometric Pressure - Data Erratic, Intermittent, or Incorrect. | Possible reduced performance.
Atmospheric Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the engine throttle intake pressure sensor to calculate barometric pressure. The ECM compares the reading of the engine throttle intake pressure sensor to all other pressure sensors at key ON, engine not operating, to verify the barometric pressure reading is accurate.

Component Location

The engine throttle intake pressure sensor is located in the air stream after the charge-air cooler just before the throttle actuator near the wastegate control valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned ON before the engine is started.

The diagnostic only runs once per trip when the keyswitch is initially turned ON.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure reading is higher or lower than the other absolute pressure sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the barometric pressure reading is used.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

At key ON, before the engine starts, the sensor readings for various engine pressure sensors on the engine are compared with the engine throttle intake pressure sensor. This fault code occurs if the engine throttle intake pressure sensor reading is different from the other sensor readings.

Possible causes of this fault code include:

  • Damaged engine turbocharger compressor intake pressure sensor
  • Pin-to-pin short in the engine harness.
Refer to Troubleshooting Fault Code 295.

Last Modified: 24-Mar-2010


Real Time Clock - Data Erratic, Intermittent, or Incorrect

FAULT CODE 319

Real Time Clock - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Amber (Maintenance Flashout) SRT: | Real Time Clock - Data Erratic, Intermittent, or Incorrect. | None on performance. Data in the ECM will not have accurate time and date information.
Real-Time Clock Power Circuit

Circuit Description

Under normal operating conditions, the real-time clock in the electronic control module (ECM) is powered by the vehicle's batteries.

Component Location

The real time clock is OEM dependent.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Action Taken When the Fault Code is Active

No action taken.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

This fault indicates that the real-time clock in the ECM lost power.

Possible cause for this fault:

  • Vehicle battery power to the ECM was lost.
Refer to Troubleshooting Fault Code 319.

Last Modified: 01-Jun-2010


Idle Shutdown Vehicle Accessories Relay Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 338

Idle Shutdown Vehicle Accessories Relay Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 338 PID: S087 SPN: 1267 FMI: 3/3 LAMP: Amber SRT: | Idle Shutdown Vehicle Accessories Relay Circuit - Voltage Above Normal or Shorted to High Source. | None on performance. Idle shutdown feature will not work.
Idle Shutdown Vehicle Accessories Relay Circuit

Circuit Description

The electronic control module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to Installed, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by original equipment manufacturer (OEM). The return circuit can be returned to the ECM through the ECM return (General) or connected directly to ground. Refer to the OEM service manual to determine grounding configuration.

Component Location

This idle shutdown relay location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The idle shutdown relay pulse width modulated (PWM) signal is detected to be at system voltage by the ECM when the PWM voltage is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a high voltage when the signal is commanded OFF, it will log this fault code.

Possible causes of this fault code include:

  • ECM Idle Shutdown feature set up incorrectly
  • Open circuit in the idle shutdown relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.
Refer to Troubleshooting Fault Code 338.

Last Modified: 04-Mar-2010


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 339

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 339 PID: S087 SPN: 1267 FMI: 4/4 LAMP: Amber SRT: | Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. | Vehicle accessories or ignition bus loads controlled by the idle shutdown feature will not work.
Idle Shutdown Vehicle Accessories Relay Circuit

Circuit Description

The electronic control module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to Installed, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by original equipment manufacturer (OEM). The return circuit can be returned to the ECM through the ECM return (General) or connected directly to ground. Refer to the OEM service manual to determine grounding configuration.

Component Location

This idle shutdown relay location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The idle shutdown relay pulse width modulated (PWM) signal is detected to be below system voltage by the ECM when the PWM voltage is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

The ECM monitors the voltage level on this circuit. This fault code is logged if it detects a low voltage when the relay signal is commanded ON.

Possible causes for this fault code include:

  • Short circuit to ground in the OEM harness or connectors
  • Short circuit to ground in the idle shutdown relay.
Refer to Troubleshooting Fault Code 339.

Last Modified: 04-Mar-2010


Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. | Possibly no noticeable performance effects, engine dying or hard starting. Fault information, trip information, and maintenance monitor data may be inaccurate.
Unswitched Battery Supply

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post, on 12 volt systems or the power supply on all other systems. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the original equipment manufactured (OEM) power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a read or write error internal to the module.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

Possible causes for this fault code include:

  • Resistance in the ECM battery supply (+) or (-) circuits.

Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code 343.

Last Modified: 27-Jan-2010


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3059 FMI: 4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced performance.
Sensor Supply Voltage 1 Circuit

Circuit Description

This circuit is the voltage supply 1. The ECM provides a 5 volt supply for the engine throttle intake humidity/temperature sensor, engine throttle actuator, engine camshaft speed position sensor 2, and the engine throttle intake pressure sensor.

Component Location

The sensor supply 1 is located in the wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 1 voltage is less than a calibrated value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on sensor supply 1.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The voltage supplies are broken up into 6 circuits, 1 thru 6.

Possible causes for this fault code include:

  • Short circuit to ground in a supply wire
  • Short circuit between a supply wire and a return wire
  • Damaged sensor
  • Damaged ECM power supply.
Refer to Troubleshooting Fault Code 352.

Last Modified: 24-Mar-2010


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance.
Sensor Supply Voltage 5 Volt (1)

Circuit Description

The sensor supply 1 circuit provides a 5 volt supply to the engine throttle intake humidity/temperature sensor, engine throttle actuator, engine camshaft speed/position sensor 2, and engine throttle intake pressure sensor.

Component Location

The sensor supply 1 circuit is located in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 1 signal voltage is more than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

High voltage on the sensor supply 1 supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 386.

Last Modified: 01-Apr-2010


Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level. | Progressive power derate increasing in severity from time of alert. If the engine protection shutdown feature is enabled, the engine will shutdown 30 seconds after the red STOP ENGINE lamp starts flashing.
Oil Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The oil pressure sensor is located on the engine block, under the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects the engine oil pressure is below the minimum operating limits.

Action Taken When the Fault Code is Active

To validate the repair, start the engine and let ir idle for 1 minute.

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • A torque derate is issued by the ECM.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE light, and the torque derate will be removed when the oil pressure reading is detected to be within the normal operating range.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Low operation speeds
  • Oil dilution
  • Oil filter needs to be changed
  • Incorrect oil level
  • Damaged oil pressure sensor
  • Engine harness shorted to ground.
Refer to Troubleshooting Fault Code 415.

Last Modified: 01-Jun-2010


Battery 1 Voltage - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Below Normal Operating Range - Moderately Severe Level. | Possible reduced performance.
Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires. There is one 30-ampere fuse in the unswitched battery wires to protect the original equipment manufacturer (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the main battery supply voltage is less than 6-VDC.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the battery voltage is above 6-VDC.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is logged when the ECM battery supply voltage drops below 6-VDC.

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code 441.

Last Modified: 01-Jun-2010


Battery 1 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 1/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible electrical damage to all electrical components.
Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires. There is one 30-ampere fuse in the unswitched battery wires to protect the original equipment manufacturer (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the main battery supply voltage is greater than 20-VDC.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, cycle the keyswitch, start the engine, and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is logged when the ECM battery supply voltage exceeds 20-VDC.

Possible causes of this fault code include:

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code 442.

Last Modified: 01-Jun-2010


Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 453

Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 453 PID: P149 SPN: 1241 FMI: 3/3 LAMP: Amber SRT: | Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | Possible reduced performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement.

Component Location

The gas mass flow sensor is located on the fuel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the gas mass flow signal voltage is greater than 4.95-VDC.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The gas mass flow to the engine is inferred by measuring a portion of the total flow as it travels through the bypass passage and across the gas mass flow sensor. The bypass flow is regulated by the flow split venturi and screen pack which are located behind the engine fuel shutoff valve.

Make sure the flow split venturi is seated fully and the screen pack is free from debris and oil.

The voltage for the gas mass flow sensor is provided by the ECM. This sensor supplies 15 volts to the gas mass flow sensor.

This fault can also log if a very high gas flow is being diverted to the gas mass flow sensor.

  • Very high gas flow can cause Fault Codes 2722, 2988, 455, and 511.
Refer to Troubleshooting Fault Code 453.

Last Modified: 01-Jun-2010


Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 454

Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 454 PID: P183 SPN: 183 FMI: 4 LAMP: Amber SRT: | Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement. The supply voltage for the gas mass flow sensor is provided by the ECM. This sensor circuit supplies 15 volts to the gas mass flow sensor.

Component Location

The gas mass flow sensor is located on the fuel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the gas mass flow signal voltage is less than 0.05-VDC.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The gas mass flow to the engine is inferred by measuring a portion of the total flow as it travels through the bypass passage and across the gas mass flow sensor. The bypass flow is regulated by the flow split venturi and screen pack which are located behind the engine fuel shutoff valve. The gas mass flow sensor supply voltage is regulated by the ECM. A DC to DC voltage regulator is not necessary.

Possible causes include:

  • A damaged gas mass flow sensor
  • An open circuit in the engine harness
  • A pin-to-ground short in the engine harness.
Refer to Troubleshooting Fault Code 454.

Last Modified: 30-Jan-2010


Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 455

Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 455 PID: S18 SPN: 633 FMI: 3 LAMP: Red SRT: | Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal or Shorted to High Source. | Engine will die or not start.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses a pulse width modulated valve to meter the fuel into the fuel housing.

Component Location

The engine fuel control valve is located in the fuel housing next to the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the engine fuel control valve voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine fuel control valve is a normally closed valve. The ECM will not command the valve open until the ECM detects engine rpm.

Refer to Troubleshooting Fault Code 455.

Last Modified: 30-Jan-2010


Ignition Timing Signal Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 458

Ignition Timing Signal Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 458 PID: S67 SPN: 726 FMI: 3 LAMP: Red SRT: | Ignition Timing Signal Circuit - Voltage Above Normal or Shorted to High Source | Engine will die or not start.
Ignition System Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 thru 3. coil pack 2 generates the voltage to fire cylinders 4 thru 6. Spark timing is controlled by the ECM. The ECM commands the ICM to energize the ignition coil for the current cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ignition timing voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, cycle the keyswitch, start the engine, and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The timing signal must be present at the ICM. If no signal is present, the engine will not start. This fault could become active due to a pin-to-pin short in the timing circuit.

Refer to Troubleshooting Fault Code 458.

Last Modified: 04-Mar-2010


Ignition Timing Signal Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 459

Ignition Timing Signal Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 459 PID: S67 SPN: 726 FMI: 4 LAMP: Red SRT: | Ignition Timing Signal Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will die or not start.
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 thru 3. Coil pack 2 generates the voltage to fire cylinders 4 thru 6. Spark timing is controlled by the ECM. The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ignition timing voltage is less than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will shut down or not start.

Conditions for Clearing the Fault Code

To validate the repair, cycle the keyswitch, start the engine, and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The timing signal must be present at the ICM. If no signal is present, the engine will not start. This fault could become active due to a pin-to-pin short in the timing circuit, an open circuit, or short to ground on the timing circuit.

The ICM provides the voltage on the timing and reference lines. If Fault Codes 459 (timing line) and 462 (reference line) shorted low are both present in the ECM image, this may indicate an issue with the power supply to the ICM. The ECM looks for a signal from the ICM right after key ON. Items such as a sticking relay on the switched battery supply causing a delay in the ICM power up can result in Fault Codes 459 and 462 and prevent the vehicle from starting. Both faults will latch active and will not allow the vehicle to start until the next key cycle, even if power has been restored to the ICM.

The ICM is supplied switched battery supply through the OEM harness. Due to the assortment of OEM wiring configurations, this troubleshooting tree will not troubleshoot the OEM side of the circuit. If an issue is suspected on the OEM side, the repair location must refer to the OEM service manual for troubleshooting steps.

Refer to Troubleshooting Fault Code t05-459.

Last Modified: 06-Oct-2011


Ignition Control Signal Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 461

Ignition Control Signal Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 461 PID: S66 SPN: 725 FMI: 3 LAMP: Red SRT: | Ignition Control Signal Circuit - Voltage Above Normal or Shorted to High Source. | Engine will die or not start.
Ignition Reference Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls 2 ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 thru 3. Coil pack 2 generates the voltage to fire cylinders 4 thru 6. Spark timing is controlled by the electronic control system (ECM). The ECM commands the ICM to energize the ignition coil for the cylinde presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ICM reference voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, cycle the keyswitch, start the engine, and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The reference signal must be present at the ICM. If the signal is not present, the engine will not start. This fault could become active due to a short circuit in the reference wire.

Refer to Troubleshooting Fault Code 461.

Last Modified: 01-Jun-2010


Ignition Control Signal Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 462

Ignition Control Signal Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 462 PID: S66 SPN: 725 FMI: 4 LAMP: Red SRT: | Ignition Control Signal Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will stall or not start.
Ignition Reference Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 thru 3. Coil pack 2 generates the voltage to fire cylinders 4 thru 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ICM reference voltage is less than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will shut down or not start.

Conditions for Clearing the Fault Code

To validate the repair, cycle the keyswitch, start the engine, and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The timing signal must be present at the ICM. If no signal is present, the engine will not start. This fault could become active due to a pin-to-pin short in the timing circuit, an open circuit, or short to ground on the timing circuit. The ICM provides the voltage on the timing and reference lines. If Fault Codes 459 (timing line) and 462 (reference line) shorted low are both present in the ECM image, this may indicate an issue with the power supply to the ICM. The ECM looks for a signal from the ICM right after key ON. Items such as a sticking relay on the switched battery supply causing a delay in the ICM power up can result in Fault Codes 459 and 462 and prevent the vehicle from starting. Both faults will latch active and will not allow the vehicle to restart until the next key cycle, even if power has been restored to the ICM. The ICM is supplied switched battery supply through the OEM harness. Due to the assortment of OEM wiring configurations, this troubleshooting tree will not troubleshoot the OEM side of the circuit. If an issue is suspected on the OEM side, the repair location must refer to the OEM service manual for troubleshooting steps.

Refer to Troubleshooting Fault Code t05-462.

Last Modified: 14-Sep-2011


Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 465

Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 465 PID: S32 SPN: 1188 FMI: 3 LAMP: Amber SRT: | Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses the engine turbocharger wastegate control valve to control the pressure in the diaphragm canister of the turbocharger actuator. The turbocharger actuator is connected to the turbocharger wastegate.

Component Location

The engine turbocharger wastegate control valve is located on the air inlet adapter block just upstream of the throttle and connected by a tube to the turbocharger actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine turbocharger wastegate control valve voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is caused by an electrical issue. A mechanical issue will not cause this fault to log.

Possible causes of this fault code include:

  • Open circuit in the engine harness or connectors
  • Open circuit in the engine turbocharger wastegate control valve
  • Signal circuit short to voltage source in the engine harness.
Refer to Troubleshooting Fault Code 465.

Last Modified: 01-Jun-2010


Turbocharger 1 Wastegate Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 466

Turbocharger 1 Wastegate Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 466 PID: S32 SPN: 1188 FMI: 4/4 LAMP: Amber SRT: | Turbocharger 1 Wastegate Control Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced performance.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses the engine turbocharger wastegate control valve to control the pressure in the diaphragm canister of the turbocharger actuator. The turbocharger actuator is connected to the turbocharger wastegate.

Component Location

The engine turbocharger wastegate control valve is located on the air inlet adapter block just upstream of the throttle and connected by a tube to the turbocharger actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the current is below a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is caused by an electrical problem. A mechanical issue will not cause this fault to log.

Possible causes of this fault code include:

  • Short circuit to ground on the (+) or (-) line
  • A damaged engine turbocharger wastegate control valve
  • An open circuit on the (+) or (-) line.
Refer to Troubleshooting Fault Code 466.

Last Modified: 01-Jun-2010


Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 511

Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 511 PID: S18 SPN: 633 FMI: 4/4 LAMP: Red SRT: | Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will stall or not start.
Fuel Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses a pulse width modulated valve to meter fuel into the fuel housing.

Component Location

The engine fuel control valve is located in the fuel housing next to the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 0.

Conditions for Setting the Fault Codes

The ECM detects that the engine fuel control valve current is below a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will stall or will not start.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine fuel control valve is a normally closed valve. The ECM will not command the valve open until the ECM detects engine RPM.

Possible causes of this fault code include:

  • A damaged engine fuel control valve
  • A short to ground on the engine fuel control valve (+) or (-) line
  • An open circuit on the engine fuel control valve (+) or (-) line.
Refer to Troubleshooting Fault Code 511.

Last Modified: 30-Jan-2010


Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 512

Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 512 PID: P51 SPN: 51 FMI: 3 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | Possible increase in idle speed.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the signal voltage on the engine throttle position 1 signal pin is greater than 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • A pin-to-pin short circuit in the in the signal wire
  • A damaged engine throttle actuator.
Refer to Troubleshooting Fault Code 512.

Last Modified: 30-Jan-2010


Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 513

Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 513 PID: P51 SPN: 51 FMI: 4/4 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible increase in idle speed.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside of the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that throttle position 1 signal voltage is below 0.05-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.
  • Possible increase in idle speed.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON.
  • The ECM will turn off the amber CHECK ENGINE light immediately after diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes include:

  • A damaged engine throttle actuator
  • A short to ground on the throttle position 1 signal line
  • An open circuit on the throttle position 1 signal line.
Refer to Troubleshooting Fault Code 513.

Last Modified: 30-Jan-2010


Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 515

Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 515 PID: S232 SPN: 3514 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit provides a 15 volt supply to the gas mass flow sensor.

Component Location

The sensor supply 6 circuit is contained in the wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 6 signal voltage is more than 15.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

High voltage on the sensor supply 6 supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 515.

Last Modified: 02-Mar-2010


Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 516

Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 516 PID: S232 SPN: 3514 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source | Possible Reduced Performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit provides a 15 volt supply to the gas mass flow sensor.

Component Location

The sensor supply 6 circuit is contained in the wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 6 signal voltage is less than 14.49-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Low voltage on the sensor supply 6 supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 516.

Last Modified: 02-Mar-2010


Engine Cylinder 1 (A1) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 561

Engine Cylinder 1 (A1) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 561 PID: S90 SPN: 1352 FMI: 0 LAMP: Red SRT: | Engine Cylinder 1 (A1) Knock - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Knock Sensor 1 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine knock for cylinder 1 is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.

  • The ECM will turn off the red STOP ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 561.

Last Modified: 01-Jun-2010


Engine Cylinder 2 (B1) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 562

Engine Cylinder 2 (B1) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 562 PID: S91 SPN: 1353 FMI: 0 LAMP: Red SRT: | Engine Cylinder 2 (B1) Knock - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine knock for cylinder 2 is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.

  • The ECM will turn off the red STOP ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 562.

Last Modified: 01-Jun-2010


Engine Cylinder 3 (A2) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 563

Engine Cylinder 3 (A2) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 563 PID: S91 SPN: 1353 FMI: 0 LAMP: Red SRT: | Engine Cylinder 3 (A2) Knock - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Knock Sensor 1 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine knock for cylinder 3 is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.

  • The ECM will turn off the red STOP ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 563.

Last Modified: 01-Jun-2010


Engine Cylinder 4 (B2) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 564

Engine Cylinder 4 (B2) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 564 PID: S93 SPN: 1355 FMI: 0 LAMP: Red SRT: | Engine Cylinder 4 (B2) Knock - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Knock Sensor 2 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine knock for cylinder 4 is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.

  • The ECM will turn off the red STOP ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 564.

Last Modified: 01-Jun-2010


Engine Cylinder 5 (A3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 565

Engine Cylinder 5 (A3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 565 PID: S94 SPN: 1365 FMI: 0 LAMP: Red SRT: | Engine Cylinder 5 (A3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine knock for cylinder 5 is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.

  • The ECM will turn off the red STOP ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 565.

Last Modified: 01-Jun-2010


Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 566

Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 566 PID: S95 SPN: 1357 FMI: 0 LAMP: Red SRT: | Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Knock Sensor 2 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine knock for cylinder 6 is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair start the engine and operate the engine in the condition in which the knock faults occurred.

  • The ECM will turn off the red STOP ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 566.

Last Modified: 01-Jun-2010


Engine Cylinder 2 (B1) Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 572

Engine Cylinder 2 (B1) Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 572 PID: S91 SPN: 1353 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 2 (B1) Knock - Voltage Below Normal or Shorted to Low Source. | Possible reduced engine protection.
Knock Sensor 1 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders. Knock sensor 1 is used to detect knock on cylinders 1 through 3.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects low voltage from knock sensor 1 for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, cycle the keyswitch from OFF to ON. Start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • A damaged knock sensor 1
  • Open circuit on the knock sensor 1 (+) line
  • Open circuit on the knock sensor 1 (-) line
  • Improper mounting or location of knock sensor 1.
Refer to Troubleshooting Fault Code 572.

Last Modified: 05-Mar-2010


Engine Cylinder 5 (A3) Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 575

Engine Cylinder 5 (A3) Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 575 PID: S94 SPN: 1356 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 5 (A3) Knock - Voltage Below Normal or Shorted to Low Source. | Possible reduced engine protection.
Knock Sensor 2 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders. Knock sensor 1 is used to detect knock on cylinders 1 thru 3. Knock sensor 2 is used to detect knock on cylinders 4 through 6.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects low voltage from knock sensor 2 for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, cycle the keyswitch from OFF to ON. Start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • A damaged knock sensor 2
  • Open circuit on the knock sensor 2 (+) line
  • Open circuit on the knock sensor 2 (-) line
  • Improper mounting or location of knock sensor 2.
Refer to Troubleshooting Fault Code 575.

Last Modified: 05-Mar-2010


Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S039 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Circuit

Circuit Description

The starter lockout relay is controlled by the Electronic Control Module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on original equipment manufacturer (OEM) wiring. It may be wired to the ECM return pin or to chassis or block ground. Reference the OEM wiring diagram for return circuit details.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the relay is being energized or de-energized. In some cases the diagnostic could also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit signal is detected to be greater than 0-VDC when the signal is turned OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded OFF, it records this fault code. This fault can be caused by:

  • Open circuit in the starter lockout relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.
Refer to Troubleshooting Fault Code 584.

Last Modified: 05-Mar-2010


Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S039 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source | The engine will not have starter lockout protection.
Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the electronic control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on original equipment manufacturer (OEM) wiring. It may be wired to the ECM return pin or to chassis or block ground. Reference the OEM wiring diagram for return circuit details.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the relay is being energized or de-energized. In some cases the diagnostic could also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit signal is not detected to be system voltage when the signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded ON, it records this fault code. This fault can be caused by:

  • A short circuit to ground in the starter lockout relay, OEM harness, or connectors.
Refer to Troubleshooting Fault Code 585.

Last Modified: 05-Mar-2010


Exhaust Back Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 591

Exhaust Back Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 591 PID: SPN: 648 FMI: 4/4 LAMP: Amber SRT: | Exhaust Back Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. | Possible Reduced Performance. No engine protection for exhaust back pressure.
Exhaust Back Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the exhaust back pressure sensor on the sensor supply 2 circuit. The ECM also provides a ground on the sensor return 2 circuit. The exhaust back pressure sensor provides a signal to the ECM on the exhaust back pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the exhaust. The ECM uses this input to determine the pressure of the exhaust gas, which affects the measured oxygen level and, therefore, the fueling of the engine.

Component Location

The exhaust back pressure sensor is located on top of the fuel module between the 3 and 4 cylinders.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust back pressure sensor signal voltage is above a calibratible value for more than 2 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The ECM will use a default value for the exhaust back pressure.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The exhaust back pressure sensor is remote-mounted from the exhaust manifold to protect it from heat. The orientation of the sensing tube is critical to the operation of the exhaust back pressure sensor. The tube must be able to drain freely into the exhaust outlet and not be able to trap moisture that will occur through condensation in the tube. If moisture is trapped in the tube then it is susceptible to reduced sensing capability. Periodic maintenance of this tube must be performed. Do not relocate this sensor from the on-engine position.

Refer to Troubleshooting Fault Code 591.

Last Modified: 05-Mar-2010


Exhaust Back Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 592

Exhaust Back Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 592 PID: SPN: 648 FMI: 4/4 LAMP: Amber SRT: | Exhaust Back Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced performance.
Exhaust Back Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the exhaust back pressure sensor on the sensor supply 2 circuit. The ECM also provides a ground on the sensor return 2 circuit. The exhaust back pressure sensor provides a signal to the ECM on the exhaust back pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the exhaust. The ECM uses this input to determine the pressure of the exhaust gas, which affects the measured oxygen level and, therefore, the fueling of the engine.

Component Location

The exhaust back pressure sensor is located on top of the fuel module between the 3 and 4 cylinders.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust back pressure sensor signal voltage is below a calibratible value for more than 2 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The ECM will use a default value for the exhaust back pressure.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The exhaust back pressure sensor is remote-mounted from the exhaust manifold to protect it from heat. The orientation of the sensing tube is critical to the operation of the exhaust back pressure sensor. The tube must be able to drain freely into the exhaust outlet and not be able to trap moisture that will occur through condensation in the tube. If moisture is trapped in the tube then it is susceptible to reduced sensing capability. Periodic maintenance of this tube must be performed. Do not relocate this sensor from the on-engine position.

Refer to Troubleshooting Fault Code 592.

Last Modified: 05-Mar-2010


Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Amber warning lamp illuminated until high battery voltage condition is corrected.
ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is higher than 16-VDC for 1 minute.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and idle the engine for 10 minutes.

The ECM will turn off the amber CHECK ENGINE light when the battery voltage falls below 16-VDC for 10 minutes.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if idle speedup is enabled. View the Alternator Failure Warning feature settings with INSITE™ electronic service tool. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Overcharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code 596.

Last Modified: 09-Apr-2012


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. | Amber lamp will light until low battery voltage condition is corrected.
ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is less than 12-VDC for more than 1 minute.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The ECM will turn off the amber CHECK ENGINE light when the diagnostic runs and passes.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if idle speedup is enabled. View the Alternator Failure Warning feature settings with INSITE™ electronic service tool. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault:

  • Undercharged batteries caused by a malfunctioning alternator or regulator
  • High-current devices on the vehicle such as Citizens Band radio amplifiers, numerous exterior lights, or other accessories.
Refer to Troubleshooting Fault Code 597.

Last Modified: 09-Apr-2012


Electrical Charging System Voltage - Data Valid But Below Normal Operational Range - Most Severe Level

FAULT CODE 598

Electrical Charging System Voltage - Data Valid But Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operational Range - Most Severe Level. | Red lamp illuminated until very low battery voltage condition is corrected.
ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the original equipment manufacturer (OEM) harness. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is less than 8-VDC for more than 1 minute.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The ECM will turn off the red STOP ENGINE light when the diagnostic runs and passes.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if idle speedup is enabled. View the Alternator Failure Warning feature settings with INSITE™ electronic service tool. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code 598.

Last Modified: 09-Apr-2012


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. | Engine may stall or not start.
Engine Speed/Position Sensor Circuit

Circuit Description

The engine camshaft speed/position sensor 1 is the primary engine position sensor. The engine camshaft speed/position sensor 1 provides engine speed and position information to the electronic control module (ECM). The engine camshaft speed/position sensor 1 is powered by 5 volts from its dedicated sensor supply 3. The sensor generates a signal by sensing the movement of target teeth machined into camshaft gear.

Component Location

The engine camshaft position sensor 1 is located on the back side of the gear housing, above the air compressor. The position sensors are mounted side by side. The engine camshaft position sensor 1 is the outmost position sensor from the block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than zero.

Conditions for Setting the Fault Codes

The ECM does not receive a signal from the engine crankshaft speed/position sensor 1 for greater than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The ECM will use the engine camshaft speed/position sensor 2 to determine engine speed and position.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it operate for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid signal from the camshaft speed position sensor 1.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code:

  • Open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM.
  • Short circuits to ground or return circuits in the sensor, engine harness, or ECM.
  • Short circuits to a voltage source in the sensor, engine harness, or ECM.
  • Damage to the sensor target teeth or tone wheel.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections such as loose or worn pins in the engine harness connectors.

Refer to Troubleshooting Fault Code 689.

Last Modified: 01-Jun-2010


Brake Switch Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 769

Brake Switch Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 769 PID: P102 SPN: 597 FMI: 3/3 LAMP: Amber SRT: | Brake Switch Circuit - Voltage Above Normal or Shorted to High Source | None on performance
Brake Switch Circuit

Circuit Description

The brake switch is an original equipment manufacturer (OEM) supplied switch. The switch is supplied 5 volts through the OEM wiring harness. The return is routed to the OEM switch return.

Component Location

The brake switch is an OEM supplied component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the voltage on the brake switch supply line is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL).

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The brake switch is an OEM-supplied component. It shares a common return with other OEM switches.

Refer to Troubleshooting Fault Code 769.

Last Modified: 11-May-2010


Brake Switch Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 771

Brake Switch Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 771 PID: P102 SPN: 597 FMI: 4 LAMP: Amber SRT: | Brake Switch Circuit - Voltage Below Normal or Shorted to Low Source | None on performance
Brake Switch Circuit

Circuit Description

The brake switch is an original equipment manufacturer (OEM) supplied switch. The switch is supplied 5 volts through the OEM wiring harness. The return is routed to the OEM switch return.

Component Location

The brake switch is an OEM supplied component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON.

Conditions for Setting the Fault Codes

The ECM detects that the voltage on the brake switch supply line is less than a calibrated value.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL).

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The brake switch is an OEM supplied component. It shares a common return with other OEM switches.

Refer to Troubleshooting Fault Code 771.

Last Modified: 25-Mar-2010


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S064 SPN: 723 FMI: 2 LAMP: Amber SRT: | Engine Camshaft Speed/Position Sensor Circuit - Data Erratic, Intermittent, or Incorrect. | Engine will possibly die or not start.
Engine Camshaft Speed/Position Sensor 2 Circuit

Circuit Description

The engine camshaft speed/position circuit consists of two engine camshaft speed/position sensors. The engine camshaft speed/position sensor 1 is the primary engine position sensor and the engine camshaft position sensor 2 is the back up engine position sensor. Both engine camshaft speed/position sensors provide engine speed information to the electronic control module (ECM). The engine camshaft speed/position sensor 1 is powered by 5 volts from its dedicated sensor supply 3. The engine position sensor 2 is supplied 5 volts from a common sensor supply which it shares with other sensors on the sensor supply 1 circuit. The sensors generate a signal by sensing the movement of target teeth machined into the camshaft gear.

Component Location

The engine camshaft speed/position sensors are located on the back side of the gear housing, above the air compressor. The engine camshaft speed/position sensors are mounted side by side. The engine camshaft speed/position sensor 1 is the outmost position sensor from the block. The engine camshaft speed/position sensor 2 is the closest to the block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the engine camshaft speed/position sensor 2 for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid signal from the engine camshaft speed/position sensor 2.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM.
  • Short circuits to ground or return circuits in the sensor, engine harness, or ECM.
  • Short circuits to a voltage source in the sensor, engine harness, or ECM.
  • Damage to the sensor target teeth or tone wheel.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections such as loose or worn pins in the engine harness connectors.

Refer to Troubleshooting Fault Code 778.

Last Modified: 01-Apr-2010


Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 627 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect. The ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Engine could possibly stall.
Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the ECM power wires that are connected through the original equipment manufacturer (OEM) harness. There is a 30 ampere fuse in the OEM harness to protect the harness from overheating. The ECM receives switched battery input through the keyswitch input when the ignition is turned ON. The ECM and inline module return wires are also connected through the OEM harness.

Component Location

The ECM is connected to the battery by the OEM power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM was not able to complete the power down routine correctly after keyswitch was turned OFF.

Action Taken When the Fault Code is Active

The ECM will not be able to store updates to power down parameters such as customer selectable trims or fuel system tables.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code state will become inactive immediately after the ECM has properly powered down.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If a battery disconnect switch is turned OFF after the keyswitch is turned OFF, but before the ECM completely powers down (up to 30 seconds), this fault code can register.

Refer to Troubleshooting Fault Code 1117.

Last Modified: 25-Mar-2010


Engine Mixer Intake Relative Humidity Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1128

Engine Mixer Intake Relative Humidity Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1128 PID: S307 SPN: 2946 FMI: 3/3 LAMP: Amber SRT: | Engine Mixer Intake Relative Humidity Sensor Circuit - Voltage Above Normal or Shorted to High Source. | Possible reduced performance.
Engine Mixer Intake Relative Humidity Sensor Circuit

Circuit Description

The ECM uses the engine throttle intake humidity/temperature sensor to measure relative humidity. The engine throttle intake humidity/temperature sensor is connected to sensor supply 1. The engine throttle intake humidity/temperature sensor is a combination sensor and is also used to measure the temperature of the air entering the throttle.

Component Location

The engine throttle intake humidity/temperature sensor is located just before engine throttle actuator next to coil pack number 1.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the relative humidity signal voltage is above a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the relative humidity reading is used.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The relative humidity signal from the engine turbocharger compressor intake humidity/temperature sensor is used with other sensors to calculate intake air specific humidity. The units are displayed in grams/kilogram, which are grams of water vapor per kilogram of air. The humidity sensor can only provide a valid reading under certain engine operating conditions. The value displayed for specific humidity is the last value updated by the sensor. A value of 10.7 grams/kg [75 grains/lb] the default and will be displayed until the engine operating conditions are met for an update.

Refer to Troubleshooting Fault Code 1128.

Last Modified: 24-Feb-2010


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: S385 SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source. | None.
Accelerator Pedal or Lever Position 2 Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is greater than 2.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • The inactive fault code will be cleared from memory after the completion of 40 warm-up cycles.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position 2 signal circuit shorted to battery or 5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Damaged accelerator pedal position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 1239.

Last Modified: 01-Jun-2010


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: None SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will enter limp-home mode.
Accelerator Pedal Position 2 Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the accelerator pedal position 2 signal voltage is less than 0.35-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

On engines equipped with On-Board Diagnostics (OBD) the ECM will issue a derate after a calibrated period of time.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light and the MIL immediately after the diagnostic runs and passes.
  • The inactive fault will be cleared from memory after the completion of 40 warm-up cycles.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Malfunctioning accelerator pedal position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 1241.

Last Modified: 01-Jun-2010


Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P091 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect. | The engine will only idle.
Accelerator Pedal or Lever Position Sensor 1 Circuit

Circuit Description

The accelerator position sensor is a Hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the readings between accelerator position sensor 1 and accelerator position sensor 2 differ by more than 10 percent.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will only allow the engine to idle.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 do not agree.

Possible causes of the fault code include:

  • Damaged accelerator pedal position sensor number 1 or damaged accelerator pedal position sensor number 2.
  • Accelerator pedal position sensor number 1 or accelerator pedal position sensor number 2 signal wires are shorted.
Refer to Troubleshooting Fault Code 1242.

Last Modified: 22-Mar-2010


Engine Misfire Cylinder 1 - Condition Exists

FAULT CODE 1654

Engine Misfire Cylinder 1 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1654 PID: None SPN: 1323 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 1 - Condition Exists | Possible engine power derate
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Each coil pack contains three coils, one for each cylinder it fires. Coil pack 1 generates the voltage to fire cylinder numbers 1 through 3. Coil pack 2 generates the voltage to fire cylinder numbers 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the spark return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine under the engine throttle actuator.

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a cylinder 1 misfire

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects the misfire percentage for cylinder 1 has dropped below a calibrated value.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the ICM detects an abnormal fire pulse on cylinder number 1 it will indicate misfire to the ECM via the spark return signal wire.

Possible causes of this fault include:

  • Damaged spark plug wire
  • Damaged spark plugs
  • Damaged coil
  • Shorted or open ignition harness
  • Damaged ICM.

Misfires may not occur under all operating conditions. Operate the engine under the conditions in which the misfire occurs, when troubleshooting.

If all six cylinders are misfiring this could indicate a damaged ICM or ignition harness.

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Refer to Troubleshooting Fault Code 1654.

Last Modified: 22-Mar-2010


Engine Misfire Cylinder 2 - Condition Exists

FAULT CODE 1655

Engine Misfire Cylinder 2 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1655 PID: None SPN: 1324 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 2 - Condition Exists | Possible engine power derate
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Each coil pack contains three coils, one for each cylinder it fires. Coil pack 1 generates the voltage to fire cylinder numbers 1 through 3. Coil pack 2 generates the voltage to fire cylinder numbers 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the spark return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine under the engine throttle actuator.

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a cylinder number 2 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects the misfire percentage for cylinder 2 has dropped below a calibrated value.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the ICM detects an abnormal fire pulse on cylinder number 2, it will indicate misfire to the ECM via the spark return signal wire.

Possible causes for the fault code may be:

  • Damaged spark plug wire
  • Damaged spark plugs
  • Damaged coil
  • Shorted or open ignition harness
  • Damaged ICM.
  • Misfires may not occur under all operating conditions. Operate the engine under the conditions in which the misfire occurs, when troubleshooting.

If all 6 cylinders are misfiring this could indicate a damaged ICM or ignition harness.

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Refer to Troubleshooting Fault Code 1655.

Last Modified: 03-Mar-2010


Engine Misfire Cylinder 3 - Condition Exists

FAULT CODE 1656

Engine Misfire Cylinder 3 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1656 PID: None SPN: 1325 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 3 - Condition Exists | Possible engine power derate
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Each coil pack contains three coils, one for each cylinder it fires. Coil pack 1 generates the voltage to fire cylinder numbers 1 through 3. Coil pack 2 generates the voltage to fire cylinder numbers 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the spark return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine under the engine throttle actuator. Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a cylinder 3 misfire

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects the misfire percentage for cylinder number 3 has dropped below a calibrated value.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the ICM detects an abnormal fire pulse on cylinder number 3, it will indicate misfire to the ECM via the spark return signal wire.

Possible causes for the fault code include:

  • Damaged spark plug wire
  • Damaged spark plugs
  • Damaged coil
  • Shorted or open ignition harness
  • Damaged ICM.

Misfires may not occur under all operating conditions. Operate the engine under the conditions in which the misfire occurs when troubleshooting.

If all 6 cylinders are misfiring this could indicate a damaged ICM or ignition harness.

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Refer to Troubleshooting Fault Code 1656.

Last Modified: 03-Mar-2010


Engine Misfire Cylinder 4 - Condition Exists

FAULT CODE 1657

Engine Misfire Cylinder 4 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1657 PID: None SPN: 1326 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 4 - Condition Exists | Possible engine power derate.
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Each coil pack contains three coils, one for each cylinder it fires. Coil pack 1 generates the voltage to fire cylinder numbers 1 through 3. Coil pack 2 generates the voltage to fire cylinder numbers 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the spark return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine under the engine throttle actuator. Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a cylinder number 4 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects the misfire percentage for cylinder number 4 has dropped below a calibrated value.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the ICM detects an abnormal fire pulse on cylinder number 4, it will indicate misfire to the ECM via the spark return signal wire.

Possible causes of this fault include:

  • Damaged spark plug wire
  • Damaged spark plugs
  • Damaged coil
  • Shorted or open ignition harness
  • Damaged ICM.

Misfires may not occur under all operating conditions. Operate the engine under the conditions in which the misfire occurs when troubleshooting.

If all 6 cylinders are misfiring this could indicate a damaged ICM or ignition harness.

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Refer to Troubleshooting Fault Code 1657.

Last Modified: 03-Mar-2010


Engine Misfire Cylinder 5 - Condition Exists

FAULT CODE 1658

Engine Misfire Cylinder 5 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1658 PID: None SPN: 1327 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 5 - Condition Exists | Possible engine power derate
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Each coil pack contains three coils, one for each cylinder it fires. Coil pack 1 generates the voltage to fire cylinder numbers 1 through 3. Coil pack 2 generates the voltage to fire cylinder numbers 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the spark return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine under the engine throttle actuator.

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a cylinder number 5 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects the misfire percentage for cylinder number 5 has dropped below a calibrated value.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the ICM detects an abnormal fire pulse on cylinder number 5, it will indicate misfire to the ECM via the spark return signal wire.

Possible causes of this fault code include:

  • Damaged spark plugs
  • Damaged spark plug wire
  • Damaged coil
  • Shorted or open ignition harness
  • Damaged ICM.

Misfires may not occur under all operating conditions. Operate the engine under the condition in which the misfire occurs when troubleshooting.

If all 6 cylinders are misfiring this could indicate a damaged ICM or ignition harness.

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Refer to Troubleshooting Fault Code 1658.

Last Modified: 22-Mar-2010


Engine Misfire Cylinder 6 - Condition Exists

FAULT CODE 1659

Engine Misfire Cylinder 6 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1659 PID: None SPN: 1328 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 6 - Condition Exists | Possible engine power derate
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate Ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Each coil pack contains three coils, one for each cylinder it fires. Coil pack 1 generates the voltage to fire cyllinder numbers 1 through 3. Coil pack 2 generates the voltage to fire cylinder numbers 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the spark return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine under the engine throttle actuator.

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running

Conditions for Setting the Fault Codes

The ICM detects a cylinder number 6 misfire

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred

  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects the misfire percentage for cylinder number 6 has dropped below a calibrated value.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the ICM detects an abnormal fire pulse on cylinder number 6, it will indicate misfire to the ECM via the spark return signal wire.

Possible causes for this fault code include:

  • Damaged spark plug wire
  • Damaged spark plugs
  • Damaged coil
  • Shorted or open ignition harness
  • Damaged ICM.

Misfires may not occur under all operating conditions. Operate the engine under the conditions in which the misfire occurred when troubleshooting.

All secondary return wires in the ignition harness are tied together. This way there will be continuity through each secondary return pin of each coil to the main secondary return wire at the ignition harness connector 2. If one of the secondary return wires is found to be open, then the ICM will think the engine is misfiring when it is not.

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Refer to Troubleshooting Fault Code 1659.

Last Modified: 22-Mar-2010


Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Above Normal or Shorted to High Source. | Severe derate in power output of the engine. Limp home power only.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 provides a 5 volt supply to the remote accelerator, engine coolant level sensor, and the accelerator position sensor 2. The remote accelerator is an optional original equipment manufacturer (OEM) component.

Component Location

Sensor supply number 5 is contained in the OEM wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects when the sensor supply 5 signal voltage is more than 5.63-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will issue an engine derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

High voltage on the sensor supply 5 supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 1695.

Last Modified: 18-Feb-2010


Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source. | Possible reduced performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit provides a 5 volt supply to the remote accelerator, engine coolant level sensor, and the accelerator position sensor 2. The remote accelerator is an optional original equipment manufacturer (OEM) component.

Component Location

The sensor supply 5 circuit is contained in the OEM wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects when the sensor supply 5 signal voltage is less than 4.42-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

High voltage on the sensor supply 5 supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 1696.

Last Modified: 18-Feb-2010


Engine Gas Control Valve Intake Pressure - Voltage Above Normal or Shorted to High Source

FAULT CODE 1827

Engine Gas Control Valve Intake Pressure - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1827 PID: None SPN: 1390 FMI: 3/3 LAMP: Amber SRT: | Engine Gas Control Valve Intake Pressure - Voltage Above Normal or Shorted to High Source. | Possible reduced performance.
Engine Fuel Regulator Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the engine fuel regulator outlet pressure/temperature sensor (combination sensor) to measure the pressure and temperature of fuel entering the engine fuel control valve.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing near the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine fuel regulator outlet pressure signal voltage is above 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the fuel regulator outlet pressure reading is used.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine fuel regulator outlet pressure/temperature sensor measures the pressure of the fuel after the engine (low pressure) regulator. The engine fuel regulator outlet pressure/temperature sensor is an absolute pressure sensor.

Refer to Troubleshooting Fault Code 1827.

Last Modified: 25-Feb-2010


Engine Gas Control Valve Intake Pressure - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1828

Engine Gas Control Valve Intake Pressure - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1828 PID: None SPN: 1390 FMI: 4/4 LAMP: Amber SRT: | Engine Gas Control Valve Intake Pressure - Voltage Below Normal or Shorted to Low Source. | Possible reduced performance.
Engine Fuel Regulator Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the engine fuel regulator outlet pressure/temperature sensor (combination sensor) to measure the pressure and temperature of fuel entering the engine fuel control valve.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing near the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine fuel regulator outlet pressure signal voltage is below 0.06-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the fuel regulator outlet pressure reading is used.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine fuel regulator outlet pressure/temperature sensor measures the pressure of the fuel after the engine (low pressure) regulator. The engine fuel regulator outlet pressure/temperature sensor is an absolute pressure sensor.

Refer to Troubleshooting Fault Code 1828.

Last Modified: 25-Feb-2010


Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1839

Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1839 PID: P159 SPN: 159 FMI: 3 LAMP: Amber SRT: | Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. | Possible reduced performance.
Gas Supply (Regulated) Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator intake pressure sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor circuit. This sensor signal voltage changes, based on the pressure of the fuel entering (low pressure) regulator.

Component Location

The engine fuel regulator intake pressure sensor is located in the fuel housing near the fuel supply fitting.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects when the engine fuel regulator intake pressure signal voltage is above 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the fuel regulator intake pressure reading is used.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared by using the INSITE™ electronic service tool.

Shop Talk

The engine fuel regulator intake pressure sensor measures the pressure of the fuel entering the engine (low pressure) regulator. The engine fuel regulator intake pressure sensor is an absolute pressure sensor.

Refer to Troubleshooting Fault Code 1839.

Last Modified: 07-Feb-2010


Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1841

Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1841 PID: P159 SPN: 159 FMI: 4 LAMP: Amber SRT: | Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced performance
Gas Supply (Regulated) Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator intake pressure sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel entering the engine (low pressure) regulator.

Component Location

The engine fuel regulator intake pressure sensor is located in the fuel housing near the fuel supply fitting.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine fuel regulator intake pressure signal voltage is less than 0.05-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the fuel regulator intake pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

The engine fuel regulator intake pressure sensor measures the pressure of the fuel entering the engine (low pressure) regulator. The engine fuel regulator intake pressure sensor is an absolute pressure sensor.

Possible causes of this fault code:

  • A damaged engine fuel regulator intake pressure sensor
  • An open circuit on the signal or return line.
Refer to Troubleshooting Fault Code 1841.

Last Modified: 08-Feb-2010


Aftertreatment Intake Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1858

Aftertreatment Intake Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1858 PID: None SPN: 3217 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Intake Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance.
Engine Turbocharger Outlet Oxygen Sensor

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heated oxygen sensor and an inline module. The inline module is supplied 12 volts through the switched battery connector. The inline module uses the supplied 12 volts to operate the oxygen sensor heater. The inline module also converts the engine turbocharger outlet oxygen sensor output signal into the inline module high range signal and the inline module low range signal that the ECM can use. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON.

Conditions for Setting the Fault Codes

  • The ECM detects the inline module high range oxygen signal line and/or the inline module low range oxygen signal line voltage to be greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced on engines equipped with On-Board diagnostics (OBD).

Conditions for Clearing the Fault Code

To validate the repair, turn the keyswitch from OFF to ON. Start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive warm up cycles that the diagnostic runs and passes.
  • The inactive fault will clear after 40 ignition cycles.

Shop Talk

Closed loop fueling command offsets are stored on power down, therefore fuel system tables need to be reset whenever the oxygen sensor, fuel control valve, engine (low pressure) fuel regulator, or gas mass flow sensor are replaced.

It is possible for Fault Codes 1858 and 1859 to be active at the same time.

Possible causes of this fault code:

  • A damaged engine wiring harness
  • A damaged inline module.
Refer to Troubleshooting Fault Code 1858.

Last Modified: 14-Apr-2010


Aftertreatment Intake Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1859

Aftertreatment Intake Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1859 PID: None SPN: 3217 FMI: 4 LAMP: Amber SRT: | Aftertreatment Intake Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced performance.
Aftertreatment Intake Oxygen Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heated oxygen sensor and an inline module. The inline module is supplied 12 volts through the switched battery connector. The inline module uses the supplied 12 volts to operate the oxygen sensor heater. The inline module also converts the engine turbocharger outlet oxygen sensor output signal into the inline module high range signal and the inline module low range signal that the electronic control module (ECM) can use. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust stream after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON.

Conditions for Setting the Fault Codes

The ECM detects the inline module high range oxygen signal line and/or the inline module low range oxygen signal line voltage to be less than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced on engines equipped with On-Board Diagnostics (OBD).

Conditions for Clearing the Fault Code

  • To validate the repair, turn the keyswitch from OFF to ON. Start the engine and let it idle for 6 minutes
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive warm up cycles that the diagnostic runs and passes.
  • The inactive fault will clear after forty ignition cycles.

Shop Talk

Closed loop fueling command offsets are stored on power down; therefore, fuel system tables need to be reset whenever the oxygen sensor, fuel control valve, engine fuel regulator (low pressure), or gas mass flow sensor, are replaced.

It is possible for Fault Codes 1858 and 1859 to be active at the same time.

Possible causes for this fault code include:

  • A damaged engine wiring harness
  • A damaged inline module.
Refer to Troubleshooting Fault Code 1859.

Last Modified: 08-Apr-2010


Engine Mixer Intake Relative Humidity - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1919

Engine Mixer Intake Relative Humidity - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1919 PID: S307 SPN: 2946 FMI: 2/2 LAMP: Amber SRT: | Engine Mixer Intake Relative Humidity - Data Erratic, Intermittent, or Incorrect. | Possible reduced performance.
Throttle Intake/Humidity Temperature Sensor Circuit

Circuit Description

The ECM uses the engine throttle intake humidity/temperature sensor to measure relative humidity. The engine throttle intake humidity/temperature sensor is connected to sensor supply 1. The engine throttle intake humidity/temperature sensor is a combination sensor and is also used to measure the temperature of the air entering the throttle.

Component Location

The engine throttle intake humidity/temperature sensor is located before the throttle next to coil pack number 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the relative humidity signal voltage is below a calibratible value for a calibrated period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and /or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the engine throttle intake humidity will be used.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the Malfunction Indicator Lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The relative humidity signal from the engine throttle intake humidity/temperature sensor is used with other sensors to calculate intake air specific humidity. The units are displayed in grams/kilogram, which is grams of humidity per kilogram of dry air. The humidity sensor can only provide a valid reading under certain engine operating conditions. The value displayed for specific humidity is the last value updated by the sensor. A value of 10.72 grams is the default and will be displayed until the engine operating conditions are met for an update.

Refer to Troubleshooting Fault Code 1919.

Last Modified: 05-Mar-2010


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. | Severe derate in power output of the engine. Limp home power only.
Sensor Supply Voltage (4) Circuit

Circuit Description

The sensor supply 4 circuit provides a 5 volt supply to the accelerator pedal position 1 sensor

Component Location

The sensor supply 4 circuit is contained in the OEM wiring harnesses.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 4 signal voltage is more than 5.63-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will issue an engine derate

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

High voltage on the sensor supply 4 supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 2185.

Last Modified: 18-Mar-2010


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced performance.
Sensor Supply Voltage (4) Circuit

Circuit Description

The sensor supply 4 circuit provides a 5 volt supply to the accelerator pedal position 1 sensor

Component Location

The sensor supply 4 circuit is contained in the OEM wiring harnesses.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 4 signal voltage is less than 4.42-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will issue an engine derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Low voltage on the sensor supply 4 supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 2186.

Last Modified: 18-Mar-2010


Exhaust Back Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2187

Exhaust Back Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2187 PID: S34 SPN: FMI: 0/16 LAMP: Amber SRT: | Exhaust Back Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Progressive speed and power derate.
Exhaust Back Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the exhaust back pressure sensor on the sensor supply 2 circuit. The ECM also provides a ground on the sensor return 2 circuit. The exhaust back pressure sensor provides a signal to the ECM on the exhaust back pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the exhaust. The ECM uses this input to determine the pressure of the exhaust gas, which affects the measured oxygen level and therefore the fueling of the engine.

Component Location

The exhaust back pressure sensor is located on top of the fuel module between the 3 and 4 cylinders.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 700 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust back pressure is above a calibrated value for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will issue a speed derate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate at high idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The exhaust back pressure sensor is remote-mounted from the exhaust manifold to protect it from heat. The orientation of the sensing tube is critical to the operation of the exhaust back pressure sensor. The tube must be able to drain freely into the exhaust outlet and not be able to trap moisture that will occur through condensation in the tube. If moisture is trapped in the tube, it is vulnerable to hindering the sensing capability of the sensor. Periodic maintenance of this tube must be performed. Do not relocate this sensor from the on-engine position.

Refer to Troubleshooting Fault Code 2187.

Last Modified: 01-Jun-2010


Throttle Plate Leaking - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2189

Throttle Plate Leaking - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2189 PID: S58 SPN: 51 FMI: 7 LAMP: Amber SRT: | Throttle Plate Leaking - Mechanical System Not Responding or Out of Adjustment. | None. Possible high idle speed.
Throttle Plate Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the throttle actuator; it is both an input and output device.

Component Location

The throttle actuator is located after the fuel housing and before the intake manifold cover.

Shop Talk

The throttle actuator is pulse-width modulated. Leaks, especially missing pipe and cap plugs, after the throttle actuator can also cause this fault. Excessive backfire can cause a bent throttle plate.

Refer to Troubleshooting Fault Code 2189.

Last Modified: 01-Jun-2010


Heated Oxygen Sensor - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2219

Heated Oxygen Sensor - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2219 PID: S65 SPN: FMI: 0/16 LAMP: Amber SRT: | Heated Oxygen Sensor - Data Valid but Above Normal Operating Range - Moderately Severe Level | Possible reduced performance. No closed loop operation.
Engine Turbocharger Outlet Oxygen Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heated oxygen sensor and an inline module. The inline module is supplied 12 volts through the switched battery connector. The inline module uses the supplied 12 volts to operate the oxygen sensor heater. The inline module also converts the engine turbocharger outlet oxygen sensor output signal into inline module low range and inline module high range oxygen signal that the electronic control module (ECM) can use. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust stream after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is in closed loop.

Conditions for Setting the Fault Codes

The ECM detects that the sensed oxygen content in the exhaust is higher than desired by a calibrated amount for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine will only operate in open loop.

Conditions for Clearing the Fault Code

  • Start the engine and let it idle for 2 minutes. If the fault is active only under certain operating conditions, operate the engine in that condition.
  • The ECM will turn off the amber CHECK ENGINE light immediately once the diagnostic runs and passes.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (L).

Closed loop fueling command offsets are stored on power down, therefore fuel system tables need to be reset whenever the O2 sensor, fuel control valve, or gas mass flow sensor are replaced.

Possible causes of this fault include insufficient fuel flow, excessive air flow, or an engine misfire causing a lean air/fuel ratio.

Possible causes for a lean condition include:

  • Engine misfire
  • Low fuel pressure
  • Oil contamination of the gas mass flow sensor
  • A damaged gas mass flow sensor
  • A damaged oxygen sensor
  • A damaged intake manifold pressure sensor
  • A damaged turbocharger
  • Restrictions in the fuel system.
Refer to Troubleshooting Fault Code 2219.

Last Modified: 01-Jun-2010


Heated Oxygen Sensor - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2221

Heated Oxygen Sensor - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2221 PID: S65 SPN: FMI: 1/18 LAMP: Amber SRT: | Heated Oxygen Sensor - Data Valid but Below Normal Operating Range - Moderately Severe Level. | Possible reduced performance. No closed loop operation.
Engine Turbocharger Outlet Oxygen Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heated oxygen sensor and an inline module. The inline module is supplied 12 volts through the switched battery connector. The inline module uses the supplied 12 volts to operate the oxygen sensor heater. The inline module also converts the engine turbocharger outlet oxygen sensor output signal into inline module low range and inline module high range oxygen signal that the electronic control module (ECM) can use. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust stream after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is in closed loop.

Conditions for Setting the Fault Codes

The ECM detects that the oxygen content in the exhaust is lower than a calibrated amount for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine will only operate in open loop.

Conditions for Clearing the Fault Code

  • Start the engine and let it idle for 2minutes. If the fault is active only under certain operating conditions operate the engine in that condition.
  • The ECM will turn off the amber CHECK ENGINE light immediately once the diagnostic runs and passes.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (L). Excessive exhaust back pressure can cause this fault by creating a lower partial pressure of oxygen to form at the heated oxygen sensor. If the fuel control valve is stuck open, the engine will not burn all the gas that is ingested, causing it to run rich. If the heated oxygen sensor heater supply has shorted to ground or has an open circuit, then the sensor will read a lower than normal exhaust oxygen value.

Closed loop fueling command offsets are stored on power down, therefore fuel system tables need to be reset whenever the oxygen sensor, fuel control valve, engine (low pressure) regulator, or gas mass flow sensor are replaced.

Possible causes of this fault include excessive fuel flow or insufficient air flow causing a rich air/fuel ratio.

Possible causes for a rich condition include:

  • A damaged oxygen sensor
  • A damaged mass air flow sensor
  • A damaged gas mass flow sensor
  • A damaged turbocharger or turbocharger wastegate actuator
  • An engine misfire.
Refer to Troubleshooting Fault Code 2221.

Last Modified: 01-Jun-2010


Heated Oxygen Sensor Circuit - Out of Calibration

FAULT CODE 2229

Heated Oxygen Sensor Circuit - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2229 PID: S65 SPN: FMI: 13/13 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Out of Calibration | Possible reduced performance. No closed loop operation.
Engine Turbocharger Outlet Oxygen Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heated oxygen sensor and an inline module. The inline module is supplied 12 volts through the switched battery connector. The inline module uses the supplied 12 volts to operate the oxygen sensor heater. The inline module also converts the engine turbocharger outlet oxygen sensor output signal into inline module low range and inline module high range oxygen signal that the electronic control module (ECM) can use. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust stream after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

In order to run this diagnostic the engine must be running for greater than 2 minutes and the engine must be in a motoring (coasting) condition for greater than 10 seconds.

Conditions for Setting the Fault Codes

The ECM detects sensed oxygen content in exhaust differs from desired by a calibrated amount for more than 1 hour.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK engine light immediately when this diagnostic runs and fails.
  • The engine will not operate in closed loop.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately when the sensed oxygen content in the exhaust is within specifications.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (L) units. The air/fuel ratio (stoichiometric) is 1L.

Any presence of hydrocarbons can cause the oxygen sensor to misread the air oxygen content in the exhaust. Oil, fuel or air contaminants that can pass by the heated oxygen sensor can cause the sensor to misread and light the fault lamp. Keep in mind this will occur only in a motoring situation. The ECM uses data from motoring instances to recalibrate fuel tables and maintain optimum fuel operation for the engine.

Possible causes of this fault include:

  • Contaminated engine turbocharger outlet oxygen sensor
  • Damaged engine turbocharger outlet oxygen sensor
  • Damaged in-line module.
Refer to Troubleshooting Fault Code 2229.

Last Modified: 08-Apr-2010


Engine Multiple Cylinder Spark Voltage Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2286

Engine Multiple Cylinder Spark Voltage Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2286 PID: None SPN: 3451 FMI: 3 LAMP: Amber SRT: | Engine Multiple Cylinder Spark Voltage Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance.
Ignition System Circuit

Circuit Description

The ignition system consists of two coil packs, six spark plug wires, six spark plugs, and an ignition control module (ICM). Each coil pack contains three coils. Coil pack 1 contains the the coils for cylinders 1, 2, and 3. Coil pack 2 contains the coils for cylinders 3, 4, and 5. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the current cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The spark plug wires transfer the electrical energy from the coils to the spark plugs. The ICM is capable of measuring spark voltage and detecting misfire over the secondary return wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) signal lines.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the spark voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM will not be capable of logging low cylinder KV or misfire faults if the spark voltage line becomes shorted.

Refer to Troubleshooting Fault Code 2286.

Last Modified: 04-Mar-2010


Engine Multiple Cylinder Spark Voltage Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2287

Engine Multiple Cylinder Spark Voltage Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2287 PID: None SPN: 3451 FMI: 3 LAMP: Amber SRT: | Engine Multiple Cylinder Spark Voltage Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced performance.
Ignition Timing Signal Circuit

Circuit Description

The ignition system consists of two coil packs, six spark plug wires, six spark plugs, and an ignition control module (ICM). Each coil pack contains three coils. Coil pack 1 contains the the coils for cylinders 1, 2, and 3. Coil pack 2 contains the coils for cylinders 3, 4, and 5. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The spark plug wires transfer the electrical energy from the coils to the spark plugs. The ICM is capable of measuring spark voltage and detecting misfire over the secondary return wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) signal lines.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the spark voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM will not be capable of logging low cylinder KV or misfire faults if the spark voltage line becomes shorted.

Refer to Troubleshooting Fault Code 2287.

Last Modified: 18-Feb-2010


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2/2 LAMP: None SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. | Engine may stall or not start.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine camshaft speed/position circuit consists of two engine camshaft speed/position sensors. The engine camshaft speed/position sensor 1 is the primary engine position sensor and the engine camshaft position sensor 2 is the back up engine position sensor. Both engine camshaft speed/position sensors provide engine speed information to the electronic control module (ECM). The engine camshaft speed/position sensor 1 is powered by 5 volts from its dedicated sensor supply 3. The engine position sensor 2 is supplied 5 volts from sensor supply which it shares with other sensors on the sensor supply 1 circuit. The sensors generate a signal by sensing the movement of target teeth machined into the camshaft gear.

Component Location

The engine camshaft speed/position sensors are located on the back side of the gear housing, above the air compressor. The engine camshaft speed/position sensors are mounted side by side.

The engine camshaft speed/position sensor 1 is the outer position sensor from the block. The engine camshaft speed/position sensor 2 is the closest to the block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects an intermittent or degraded signal from the engine camshaft speed/position sensor 1 over an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The fault code becomes inactive at each key ON or if the ECM does not detect a loss of the engine crankshaft speed/position sensor 1 signal for at least 10 seconds.

Shop Talk

During engine operation, the ECM monitors the engine camshaft speed/position sensor 1 signal. Fault Code 689 will become active and light the yellow lamp if the signal from the engine camshaft speed/position sensor 1 is not present or degraded for more than 3 continuous seconds. Meanwhile, if the engine camshaft speed/position sensor 1 signal is not present or is degraded for a moment (less than 3 seconds), the ECM will interrupt ignition events based on the engine camshaft speed/position sensor 1 and resume ignition events using the engine camshaft speed/position sensor 2. If the engine camshaft speed/position sensor 1 signal returns, the ECM will automatically interrupt ignition events based on the backup engine camshaft speed/position sensor 2 and resume ignition events based on the engine camshaft speed/position sensor 1. If, over a period of time, the ECM detects several incidents of a loss of the engine camshaft speed/position sensor 1 signal, this fault code will become active.

This fault code becomes active when the ECM detects a persistent loss of the engine camshaft speed/position sensor 1 signal over a short period of time.

Possible causes of this fault code include:

  • Intermittent loss of engine camshaft speed/position sensor 1 signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems
  • Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the engine camshaft speed/position sensor 1 circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the camshaft gear for damage.
Refer to Troubleshooting Fault Code 2321.

Last Modified: 01-Jun-2010


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S064 SPN: 723 FMI: 2/2 LAMP: None SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. | None on performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine camshaft speed/position circuit consists of two engine camshaft speed/position sensors. The engine camshaft speed/position sensor 1 is the primary engine position sensor and the engine camshaft position sensor 2 is the back up engine position sensor. Both engine camshaft speed/position sensors provide engine speed information to the electronic control module (ECM). The engine camshaft speed/position sensor 1 is powered by 5 volts from its dedicated sensor supply 3. The engine position sensor 2 is supplied 5 volts from sensor supply which it shares with other sensors on the sensor supply 1 circuit. The sensors generate a signal by sensing the movement of target teeth machined into the camshaft gear.

Component Location

The engine camshaft speed/position sensors are located on the back side of the gear housing, above the air compressor. The engine camshaft speed/position sensors are mounted side by side.

The engine camshaft speed/position sensor 1 is the outer position sensor from the block. The engine camshaft speed/position sensor 2 is the closest to the block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects an intermittent loss of the engine camshaft speed/position sensor 2 signal.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will set the fault code inactive after the ECM detects a valid signal from the engine camshaft speed/position sensor 2.

Shop Talk

During engine operation, the ECM monitors the engine camshaft speed/position sensor 2 signal. Fault Code 778 will become active and light the yellow lamp if the signal from the engine camshaft speed/position sensor 2 is not present or degraded for more than 3 continuous seconds. If, over a period of time, the ECM detects several incidents of a loss of the engine camshaft speed/position sensor 2 signal, but the signal loss is short in duration, this fault code will become active. Since the engine camshaft speed/position sensor 2 signal is not used for normal engine operation, a vehicle operator should not notice any symptoms related to this problem.

This fault becomes inactive at each key ON or if the ECM does not detect a loss of the secondary engine speed sensor signal for at least 10 seconds.

Problems that can cause this fault:

  • Intermittent loss of engine camshaft speed/position sensor 2 signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems.
  • Sensor air gap that is marginally too small or too large, or the camshaft gear exhibits excessive runout.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the engine camshaft speed/position sensor 2 circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the camshaft gear for damage.
Refer to Troubleshooting Fault Code 2322.

Last Modified: 18-Feb-2010


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S033 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Fan Control Circuit - Voltage Above Normal or Shorted to High Source. | None on performance. Fan will lock ON or OFF.
Engine Fan Clutch Supply Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the electronic control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the relay is being energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The fan control circuit signal voltage is detected when the PWM signal is turned OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The fan control will not be enabled.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The fan control logic can be adjusted with INSITE™ electronic service tool. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

The low voltage on the signal circuit can indicate a short circuit to ground in the harness or solenoid.

If Fault Code 2377 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan clutch device for a short circuit to ground.

Refer to Troubleshooting Fault Code 2377.

Last Modified: 03-Mar-2010


Engine Cylinder 1 (A1) Knock - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2431

Engine Cylinder 1 (A1) Knock - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2431 PID: S90 SPN: 1352 FMI: 0/15 LAMP: Amber SRT: | Engine Cylinder 1 (A1) Knock - Data Valid but Above Normal Operating Range - Least Severe Level. | Engine power derate.
Knock Sensor 1 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of the cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine knock for cylinder 1 is greater than a calibrated value

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle

Refer to Troubleshooting Fault Code 2431.

Last Modified: 01-Jun-2010


Engine Cylinder 2 (B1) Knock - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2432

Engine Cylinder 2 (B1) Knock - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2432 PID: S91 SPN: 1353 FMI: 0/15 LAMP: Amber SRT: | Engine Cylinder 2 (B1) Knock - Data Valid but Above Normal Operating Range - Least Severe Level | Engine power derate.
Knock Sensor 1 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. Therefore, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the side of the engine block, above the air compressor. Knock sensor 1 is mounted in the lower of the two holes near cylinder number 2. Knock sensor 2 is located on the cylinder head above cylinder number 6.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine knock for cylinder 2 is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 2432.

Last Modified: 01-Jun-2010


Engine Cylinder 3 (A2) Knock - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2433

Engine Cylinder 3 (A2) Knock - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2433 PID: S92 SPN: 1354 FMI: 0/15 LAMP: Amber SRT: | Engine Cylinder 3 (A2) Knock - Data Valid but Above Normal Operating Range - Least Severe Level. | Engine power derate.
Knock Sensor 1 Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of the cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine knock for cylinder 3 is greater than a calibrated value

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock can occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration can also cause knock faults to be logged. This can include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 2433.

Last Modified: 01-Jun-2010


Engine Cylinder 4 (B2) Knock - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2434

Engine Cylinder 4 (B2) Knock - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2434 PID: S93 SPN: 1355 FMI: 0/15 LAMP: Amber SRT: | Engine Cylinder 4 (B2) Knock - Data Valid but Above Normal Operating Range - Least Severe Level. | Engine power derate.
Knock Sensor 2 Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of the cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine knock for cylinder 4 is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock can occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration can also cause knock faults to be logged. This can include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 2434.

Last Modified: 01-Jun-2010


Engine Cylinder 5 (A3) Knock - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2435

Engine Cylinder 5 (A3) Knock - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2435 PID: S94 SPN: 1356 FMI: 0/15 LAMP: Amber SRT: | Engine Cylinder 5 (A3) Knock - Data Valid but Above Normal Operating Range - Least Severe Level | Engine power derate.
Knock Sensor 2 Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of the cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine knock for cylinder 5 is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock can occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration can also cause knock faults to be logged. This can include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 2435.

Last Modified: 01-Jun-2010


Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2436

Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2436 PID: S95 SPN: 1357 FMI: 0/15 LAMP: Amber SRT: | Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operating Range - Least Severe Level. | Engine power derate.
Knock Sensor 2 Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of the cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine knock for cylinder 6 is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.

  • The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock can occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration can also cause knock faults to be logged. This can include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 2436.

Last Modified: 01-Jun-2010


Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 2517

Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2517 PID: S309 SPN: 1127 FMI: 3/3 LAMP: Amber SRT: | Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source | Possible reduced performance.
Engine Throttle Intake Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine throttle intake pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The engine throttle intake pressure sensor provides a signal to the ECM on the engine throttle intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the air entering the engine throttle. The ECM will detect a low signal voltage when the engine throttle intake pressure is low. The ECM will detect a high signal voltage when the engine throttle intake pressure is high.

Component Location

The engine throttle intake pressure sensor is located in the air stream after the charge-air cooler, just before the throttle actuator near the wastegate control valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine throttle pressure signal voltage is above 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • An estimated value for the throttle intake pressure reading is used.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the engine throttle intake pressure sensor is disconnected, the engine can continue operating by using the throttle plate position and the engine intake manifold pressure to estimate the throttle intake pressure. The engine throttle intake pressure sensor has been referred to as the boost pressure sensor and the mixer inlet pressure sensor in previous products.

Possible causes for this fault code include:

  • A damaged sensor
  • A pin-to-pin short circuit on the supply, signal, or return line.
Refer to Troubleshooting Fault Code 2517.

Last Modified: 03-Mar-2010


Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2518

Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2518 PID: S309 SPN: 1127 FMI: 4/4 LAMP: Amber SRT: | Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source. | Possible reduced engine performance.
Engine Throttle Intake Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine throttle intake pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The engine throttle intake pressure sensor provides a signal to the ECM on the engine throttle intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the air entering the engine throttle. The ECM will detect a low signal voltage when the engine throttle intake pressure is low. The ECM will detect a high signal voltage when the engine throttle intake pressure is high.

Component Location

The engine throttle intake pressure sensor is located in the air stream after the charge-air cooler, just before the throttle actuator near the wastegate control valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine throttle pressure signal voltage is less than 0.06-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • An estimated value for the throttle intake pressure reading is used.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the engine throttle intake pressure sensor is disconnected, the engine can continue operating by using the throttle plate position and the engine intake manifold pressure to estimate the throttle intake pressure. The engine throttle intake pressure sensor has been referred to as the boost pressure sensor and the mixer inlet pressure sensor in previous products.

Possible causes for this fault code include:

  • A malfunctioning engine throttle intake pressure sensor
  • An open circuit on the supply, signal, or return line
  • A pin short to ground on the supply or signal line
  • A pin-to-pin short on the supply, signal, or return line.
Refer to Troubleshooting Fault Code 2518.

Last Modified: 03-Mar-2010


Gas Supply Pressure (Regulated) - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 2568

Gas Supply Pressure (Regulated) - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2568 PID: P159 SPN: 159 FMI: 0/0 LAMP: Red SRT: | Gas Supply Pressure (Regulated) - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Engine Fuel Regulator Intake Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator intake pressure sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel entering the engine (low pressure) regulator.

Component Location

The engine fuel regulator intake pressure sensor is located in the fuel housing near the fuel supply fitting.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM detects engine rpm.

Conditions for Setting the Fault Codes

The ECM detects that pressure of the fuel entering the engine (low pressure) regulator is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM will illuminate the red STOP ENGINE light as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light when the fuel pressure is within normal operating range.

Shop Talk

Two types of fuel systems can be used, compressed natural gas (CNG) or liquefied natural gas (LNG). The fuel system components up to the engine (low pressure) regulator are supplied by the OEM. If the fuel pressure at the intake of the engine (low pressure) regulator is too high, this indicates a problem with the OEM supplied fuel system components or the fuel supply.

Possible causes for this fault code include:

  • Over-pressurized fuel tanks
  • Malfunctioning OEM (high pressure) regulator
  • Malfunctioning engine fuel regulator pressure sensor.
Refer to Troubleshooting Fault Code 2568.

Last Modified: 01-Jun-2010


Engine Charge Air Cooler Outlet Temperature - Voltage Above Normal or Shorted to High Source

FAULT CODE 2571

Engine Charge Air Cooler Outlet Temperature - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2571 PID: Not Mapped SPN: 2630 FMI: 3/3 LAMP: Amber SRT: | Engine Charge Air Cooler Outlet Temperature - Voltage Above Normal or Shorted to High Source. | Possible reduced performance.
Engine Throttle Intake Humidity/Temperature Sensor Circuit

Circuit Description

The engine throttle intake humidity/temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the throttle intake. The electronic control module (ECM) supplies 5 volts to the engine throttle intake temperature sensor signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the temperature of the air entering the throttle intake.

Component Location

The engine throttle intake pressure sensor is located on the intake side of the engine just before the engine throttle actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON.

Conditions for Setting the Fault Codes

The ECM detects that the mass air flow temperature signal voltage is more than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL).
  • A default value will be used for engine throttle intake temperature.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber check ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine throttle intake temperature sensor circuit shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open return circuit in the engine harness
  • An open signal circuit or shorted to a voltage source
  • A damaged sensor.
Refer to Troubleshooting Fault Code 2571.

Last Modified: 01-Jun-2010


Engine Charge Air Cooler Outlet Temperature - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2572

Engine Charge Air Cooler Outlet Temperature - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2572 PID: None SPN: 2630 FMI: 4/4 LAMP: Amber SRT: | Engine Charge Air Cooler Outlet Temperature - Voltage Below Normal or Shorted to Low Source. | Possible reduced performance.
Engine Throttle Intake Humidity/Temperature Sensor Circuit

Circuit Description

The engine throttle intake humidity/temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the throttle intake. The electronic control module (ECM) supplies 5 volts to the engine throttle intake temperature sensor signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the temperature of the air entering the throttle intake.

Component Location

The engine throttle intake pressure sensor is located on the intake side of the engine just before the engine throttle actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON.

Conditions for Setting the Fault Codes

The ECM detects that the mass air flow temperature signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL).
  • A default value will be used for engine throttle intake temperature.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber check ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine throttle intake temperature sensor circuit shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors or sensor
  • An open signal circuit or shorted to a voltage source
  • A damaged sensor.
Refer to Troubleshooting Fault Code 2572.

Last Modified: 01-Jun-2010


Engine Spark Plug Number 1 (A1) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2586

Engine Spark Plug Number 1 (A1) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2586 PID: Not Mapped SPN: 1294 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug Number 1 (A1) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level. | None - information for misfire.
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 thru 3. Coil pack 2 generates the voltage to fire cylinders 4 thru 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

The cylinder 1 coil is located above the number 1 cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the cylinder 1 spark voltage is above a calibrated value.

Action Taken When the Fault Code is Active

The ECM will log the fault code as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and perform a stall test.

  • The ECM will set the fault code inactive as soon as the cylinder 1 spark voltage reading is detected to be within normal operating range.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service or for misfire complaints. Most probable cause for this fault code will be excessive spark plug gap, or a damaged/malfunctioning ignition coil.

Refer to Troubleshooting Fault Code 2586.

Last Modified: 01-Jun-2010


Engine Spark Plug Number 2 (B1) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2587

Engine Spark Plug Number 2 (B1) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2587 PID: Not Mapped SPN: 1295 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug Number 2 (B1) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level. | None - information for misfire.
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 thru 3. Coil pack 2 generates the voltage to fire cylinders 4 thru 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine near the flywheel housing.

The cylinder 2 coil is located above the number 2 cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the cylinder 2 spark voltage is above a calibrated value.

Action Taken When the Fault Code is Active

The ECM will log the fault code as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and perform a stall test.

  • The ECM will set the fault code inactive as soon as the cylinder 2 spark voltage reading is detected to be within normal operating range.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service or for misfire complaints. The most probable cause for this fault code will be excessive spark plug gap or a damaged/malfunctioning ignition coil.

Refer to Troubleshooting Fault Code 2587.

Last Modified: 01-Jun-2010


Engine Spark Plug Number 3 (A2) Voltage- Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2588

Engine Spark Plug Number 3 (A2) Voltage- Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2588 PID: Not Mapped SPN: 1296 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug Number 3 (A2) Voltage- Data Valid but Above Normal Operating Range - Least Severe Level | None - information for misfire.
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls 2 ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 thru 3. Coil pack 2 generates the voltage to fire cylinders 4 thru 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

The cylinder 3 coil is located above the number 3 cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the cylinder 3 spark voltage is above a calibrated value.

Action Taken When the Fault Code is Active

The ECM will log the fault code as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and perform a stall test.

  • The ECM will set the fault code inactive as soon as the cylinder 3 spark voltage reading is detected to be within normal operating range.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service, or for misfire complaints. The most probable cause for this fault code will be excessive spark plug gap or a damaged/malfunctioning ignition coil.

Refer to Troubleshooting Fault Code 2588.

Last Modified: 01-Jun-2010


Engine Spark Plug Number 4 (B2) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2589

Engine Spark Plug Number 4 (B2) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2589 PID: None SPN: 1297 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug Number 4 (B2) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level. | None - information for misfire.
Ignition System

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 through 3. Coil pack 2 generates the voltage to fire cylinders 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

The cylinder number 4 spark plug is located above the number 4 cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the cylinder number 4 spark voltage is above a calibrated value.

Action Taken When the Fault Code is Active

The ECM will log the fault code as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and perform a stall test.

The ECM will set the fault code inactive as soon as the cylinder number 4 spark voltage reading is detected to be within normal operating range.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service or for misfire complaints. The most probable cause for this fault code will be excessive spark plug gap, or a damaged/malfunctioning ignition coil.

Refer to Troubleshooting Fault Code 2589.

Last Modified: 01-Jun-2010


Engine Spark Plug Number 5 (A3) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2591

Engine Spark Plug Number 5 (A3) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2591 PID: None SPN: 1298 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug Number 5 (A3) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level. | None - information for misfire.
Ignition System

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 through 3. Coil pack 2 generates the voltage to fire cylinders 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

The cylinder number 5 spark plug is located above the number 5 cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the cylinder number 5 spark voltage is above a calibrated value.

Action Taken When the Fault Code is Active

The ECM will log the fault code as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and perform a stall test.

The ECM will set the fault code inactive as soon as the cylinder number 5 spark voltage reading is detected to be within normal operating range.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service, or for misfire complaints. The most probable cause for this fault code will be excessive spark plug gap, or a damaged/malfunctioning ignition coil.

Refer to Troubleshooting Fault Code 2591.

Last Modified: 01-Jun-2010


Engine Spark Plug Number 6 (B3) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2592

Engine Spark Plug Number 6 (B3) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2592 PID: None SPN: 1299 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug Number 6 (B3) Voltage - Data Valid but Above Normal Operating Range - Least Severe Level. | None - information for misfire.
Ignition System

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 through 3. Coil pack 2 generates the voltage to fire cylinders 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

The cylinder number 6 spark plug is located above the number 6 cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the cylinder number 6 spark voltage is above a calibrated value.

Action Taken When the Fault Code is Active

The ECM will log the fault code as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and perform a stall test.

The ECM will set the fault code inactive as soon as the cylinder number 6 spark voltage reading is detected to be within normal operating range.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service, or for misfire complaints. The most probable cause for this fault code will be excessive spark plug gap, or a damaged/malfunctioning ignition coil.

Refer to Troubleshooting Fault Code 2592.

Last Modified: 01-Jun-2010


Engine Spark Plug Number 1 (A1) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 2593

Engine Spark Plug Number 1 (A1) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2593 PID: None SPN: S1294 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug Number 1 (A1) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level. | None - information for misfire.
Ignition System

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 through 3. Coil pack 2 generates the voltage to fire cylinders 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

The cylinder number 1 spark plug is located above the number 1 cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is less than a calibrated value and engine speed is less than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the spark voltage for cylinder number 1 is below a calibrated value.

Action Taken When the Fault Code is Active

The ECM will log the fault code as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The ECM will set the fault code inactive as soon as the cylinder number 1 spark voltage reading is detected to be within normal operating range.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service, or for misfire complaints. The most probable cause for this fault code will be insufficient spark plug gap or a damaged/malfunctioning ignition coil.

Refer to Troubleshooting Fault Code 2593.

Last Modified: 01-Jun-2010


Engine Spark Plug Number 2 (B1) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 2594

Engine Spark Plug Number 2 (B1) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2594 PID: None SPN: S1295 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug Number 2 (B1) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level. | None - information for misfire.
Ignition System

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 through 3. Coil pack 2 generates the voltage to fire cylinders 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

The cylinder number 2 spark plug is located above the number 2 cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is less than a calibrated value and engine speed is less than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the spark voltage for cylinder number 2 is below a calibrated value.

Action Taken When the Fault Code is Active

The ECM will log the fault code as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The ECM will set the fault code inactive as soon as the cylinder number 2 spark voltage reading is detected to be within normal operating range.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service, or for misfire complaints. The most probable cause for this fault code will be insufficient spark plug gap or a damaged/malfunctioning ignition coil.

Refer to Troubleshooting Fault Code 2594.

Last Modified: 01-Jun-2010


Engine Spark Plug Number 3 (A2) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 2595

Engine Spark Plug Number 3 (A2) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: S2595 PID: None SPN: S1296 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug Number 3 (A2) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level. | None - information for misfire.
Ignition System

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 through 3. Coil pack 2 generates the voltage to fire cylinders 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

The cylinder number 3 spark plug is located above the number 3 cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is less than a calibrated value and engine speed is less than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the spark voltage for cylinder number 3 is below a calibrated value.

Action Taken When the Fault Code is Active

The ECM will log the fault code as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The ECM will set the fault code inactive as soon as the cylinder number 3 spark voltage reading is detected to be within normal operating range.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service, or for misfire complaints. The most probable cause for this fault code will be insufficient spark plug gap or a damaged/malfunctioning ignition coil.

Refer to Troubleshooting Fault Code 2595.

Last Modified: 01-Jun-2010


Engine Spark Plug Number 4 (B2) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 2596

Engine Spark Plug Number 4 (B2) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2596 PID: None SPN: S1297 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug Number 4 (B2) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level. | None - information for misfire.
Ignition System

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 through 3. Coil pack 2 generates the voltage to fire cylinders 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

The cylinder number 4 spark plug is located above the number 4 cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is less than a calibrated value and engine speed is less than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the spark voltage for cylinder number 4 is below a calibrated value.

Action Taken When the Fault Code is Active

The ECM will log the fault code as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The ECM will set the fault code inactive as soon as the cylinder number 4 spark voltage reading is detected to be within normal operating range.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service, or for misfire complaints. The most probable cause for this fault code will be insufficient spark plug gap or a damaged/malfunctioning ignition coil.

Refer to Troubleshooting Fault Code 2596.

Last Modified: 01-Jun-2010


Engine Spark Plug Number 5 (A3) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 2597

Engine Spark Plug Number 5 (A3) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2597 PID: None SPN: S1298 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug Number 5 (A3) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level. | None - information for misfire.
Ignition System

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 through 3. Coil pack 2 generates the voltage to fire cylinders 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

The cylinder number 5 spark plug is located above the number 5 cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is less than a calibrated value and engine speed is less than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the spark voltage for cylinder number 5 is below a calibrated value.

Action Taken When the Fault Code is Active

The ECM will log the fault code as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The ECM will set the fault code inactive as soon as the cylinder number 5 spark voltage reading is detected to be within normal operating range.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service, or for misfire complaints. The most probable cause for this fault code will be insufficient spark plug gap or a damaged/malfunctioning ignition coil.

Refer to Troubleshooting Fault Code 2597.

Last Modified: 01-Jun-2010


Engine Spark Plug Number 6 (B3) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 2598

Engine Spark Plug Number 6 (B3) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2598 PID: None SPN: S1299 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug Number 6 (B3) Voltage - Data Valid but Below Normal Operating Range - Least Severe Level. | None - information for misfire.
Ignition System

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 through 3. Coil pack 2 generates the voltage to fire cylinders 4 through 6. Spark timing is controlled by the electronic control module (ECM). The ECM commands the ICM to energize the ignition coil for the cylinder presently in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

The cylinder number 6 spark plug is located above the number 6 cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is less than a calibrated value and engine speed is less than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the spark voltage for cylinder number 6 is below a calibrated value.

Action Taken When the Fault Code is Active

The ECM will log the fault code as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The ECM will set the fault code inactive as soon as the cylinder number 6 spark voltage reading is detected to be within normal operating range.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service, or for misfire complaints. The most probable cause for this fault code will be insufficient spark plug gap or a damaged/malfunctioning ignition coil.

Refer to Troubleshooting Fault Code 2598.

Last Modified: 01-Jun-2010


Throttle Position 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2643

Throttle Position 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2643 PID: None SPN: 3673 FMI: 3/3 LAMP: Amber SRT: | Throttle Position 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | Engine will only idle with a possible increase in idle speed.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are 2 throttle position sensors located inside of the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives a 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that throttle position 2 signal voltage is above 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails
  • The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled
  • Possible increase in idle speed.

Conditions for Clearing the Fault Code

To validate the repair, cycle the keyswitch from OFF to ON.

  • The ECM will turn off the amber CHECK ENGINE light immediately after diagnostic runs and passes
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes include:

  • A damaged engine throttle actuator
  • A pin-to-pin short circuit on the throttle position 2 signal line.
Refer to Troubleshooting Fault Code 2643.

Last Modified: 26-Feb-2010


Throttle Position 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2644

Throttle Position 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2643 PID: None SPN: 3673 FMI: 4/4 LAMP: Amber SRT: | Throttle Position 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will only idle with a possible increase in speed.
Engine Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that throttle position 2 signal voltage is below 0.05-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled
  • Possible increase in idle speed.

Conditions for Clearing the Fault Code

To validate the repair, cycle the keyswitch from OFF to ON.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes include:

  • A damaged engine throttle actuator
  • A short to ground on the throttle position 2 signal line
  • An open circuit on the throttle position 2 signal line.
Refer to Troubleshooting Fault Code 2644.

Last Modified: 26-Feb-2010


Throttle Plate Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2645

Throttle Plate Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2645 PID: None SPN: 3673 FMI: 2/2 LAMP: Red SRT: | Throttle Plate Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect | Engine will only idle with a possible increase in idle speed.
Engine Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when keyswitch is ON.

Conditions for Setting the Fault Codes

The ECM detects that the difference between the throttle position signal 1 and throttle position signal 2 are greater than 20 percent for greater than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The engine will only idle and with a possible increase in idle speed.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes for this fault code include:

  • A damaged engine throttle actuator
  • A pin-to-pin short in the engine harness.
Refer to Troubleshooting Fault Code 2645.

Last Modified: 26-Feb-2010


Engine Gas Control Valve Intake Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2722

Engine Gas Control Valve Intake Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2722 PID: None SPN: 1390 FMI: 0/16 LAMP: Amber SRT: | Engine Gas Control Valve Intake Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible reduced performance.
Engine Fuel Regulator Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the engine fuel regulator outlet pressure/temperature sensor (combination sensor) to measure the pressure and temperature of fuel entering the engine fuel control valve. The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator outlet pressure/temperature sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator outlet pressure/temperature sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel exiting the engine (low pressure) regulator.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing just upstream of the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM detects engine rpm.

Conditions for Setting the Fault Codes

The ECM detects that pressure of the fuel exiting the engine (low pressure) regulator is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The ECM will turn off the amber CHECK ENGINE light when the fuel pressure is within normal operating range.

Shop Talk

The engine fuel regulator outlet pressure/temperature sensor detects fuel pressure after the fuel shutoff valve. The B5.9 G fuel module has a boost reference low pressure regulator which increases the fuel pressure available to the fuel control valve as boost pressure is increased. This helps optimize fuel control across the full range of fuel flows. The boost reference to the low pressure regulator is provided to the sealed end cap by an external pneumatic hose and associated fittings. Pressure drop tends to increase as the flow rate increases.

Two types of fuel systems can be used, compressed natural gas (CNG) or liquefied natural gas (LNG). The fuel system up to the engine (low pressure) regulator is supplied by the original equipment manufacturer (OEM). If the fuel pressure at the intake of the engine (low pressure) regulator is too high, this indicates a problem with the OEM fuel system or fuel supply.

Possible causes for this fault code include:

  • A damaged engine fuel regulator outlet pressure/temperature sensor
  • A damaged engine (low pressure) regulator
  • High fuel pressure at the engine (low pressure) regulator.
Refer to Troubleshooting Fault Code 2722.

Last Modified: 01-Jun-2010


Engine Gas Control Valve Intake Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2723

Engine Gas Control Valve Intake Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2723 PID: SPN: 1390 FMI: 1/18 LAMP: Amber SRT: | Engine Gas Control Valve Intake Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level. | Possible reduced performance.
Engine Fuel Regulator Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the engine fuel regulator outlet pressure/temperature sensor (combination sensor) to measure the pressure and temperature of fuel entering the engine fuel control valve. The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator outlet pressure/temperature sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator outlet pressure/temperature sensor provides a signal to the ECM on the engine fuel regulator intake pressure signal circuit. The pressure signal circuit voltage changes, based on the pressure of the fuel exiting the engine (low pressure) regulator.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing, just upstream of the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM detects engine rpm.

Conditions for Setting the Fault Codes

The ECM detects that pressure of the fuel exiting the engine (low pressure) regulator is less than a calibrated value.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine at rated power.

The ECM will turn off the amber CHECK ENGINE light when the fuel pressure is with in normal operating range.

Shop Talk

The engine fuel regulator outlet pressure/temperature sensor detects fuel pressure after the engine fuel shutoff valve. A restriction in the engine fuel shutoff valve can cause this fault to log. The ISL G fuel module has a boost referenced low pressure regulator which increases the fuel pressure available to the fuel control valve as boost pressure is increased.

This helps optimize fuel control across the full range of fuel flows. The boost reference to the low pressure regulator is provided to the sealed end cap by an external pneumatic hose and associated fittings. Pressure drop tends to increase as the flow rate increases and therefore fuel pressure might only be low during high flow conditions (such as a stall test or while operating at rated power). This diagnostic references the turbocharger compressor outlet pressure to determine the minimum fuel pressure. If the engine fuel regulator boost reference line is damaged, the engine (low pressure) regulator will not be able to compensate for the increased boost pressure and could cause this fault to log.

Two types of fuel systems can be used, compressed natural gas (CNG) or liquefied natural gas (LNG). The fuel system up to the engine (low pressure) regulator is supplied by the OEM. If the fuel pressure at the intake of the engine (low pressure) regulator is too low this indicates a problem with the OEM fuel system or fuel supply.

Possible causes for this fault code include:

  • Damaged engine fuel regulator outlet pressure/temperature sensor
  • Low fuel pressure supplied from the OEM fuel system
  • Damaged engine (low pressure) regulator
  • Damaged engine fuel regulator boost reference line
  • Damaged fuel shutoff valve.
Refer to Troubleshooting Fault Code 2723.

Last Modified: 01-Jun-2010


Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2724

Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2724 PID: P159 SPN: 159 FMI: 0/16 LAMP: Amber SRT: | Gas Supply Pressure (Regulated) - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible reduced performance.
Engine Fuel Regulator Intake Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine fuel regulator intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator intake pressure sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel entering the engine (low-pressure) regulator.

Component Location

The engine fuel regulator intake pressure sensor is located in the fuel housing near the fuel supply fitting.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM detects engine rpm.

Conditions for Setting the Fault Codes

The ECM detects that pressure of the fuel entering the engine (low-pressure) regulator is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light when the fuel pressure is with in normal operating range.

Shop Talk

Two types of fuel systems can be used, compressed natural gas (CNG) or liquefied natural gas (LNG). The fuel system up to the engine (low-pressure) regulator is supplied by the original equipment manufacturer (OEM). If the fuel pressure at the intake of the engine (low-pressure) regulator is too high, this indicates a problem with the OEM fuel system or fuel supply.

This is an information only fault, and is not used to diagnose malfunctioning Cummins® fuel system components.

Possible causes for this fault code include:

  • Overpressurized fuel tanks
  • Damaged OEM (high-pressure) regulator.
Refer to Troubleshooting Fault Code 2724.

Last Modified: 24-Jun-2016


Gas Supply Pressure (Regulated) - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2725

Gas Supply Pressure (Regulated) - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2725 PID: P159 SPN: 159 FMI: 1/18 LAMP: Amber SRT: | Gas Supply Pressure (Regulated) - Data Valid but Below Normal Operating Range - Moderately Severe Level. | Possible reduced performance.
Fuel Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator intake pressure sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel entering the engine (low-pressure) regulator.

Component Location

The fuel pressure sensor is located on the fuel module near the fuel inlet fitting toward the rear of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM detects engine rpm.

Conditions for Setting the Fault Codes

The ECM detects that pressure of the fuel entering the engine (low-pressure) regulator is less than a calibrated value.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light as soon as the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate it at rated power.

  • The ECM will turn off the amber CHECK ENGINE light when the fuel pressure is with in normal operating range.

Shop Talk

Two types of fuel systems can be used: compressed natural gas (CNG) or liquefied natural gas (LNG). The fuel system up to the engine (low-pressure) regulator is supplied by the OEM. If the fuel pressure at the intake of the engine (low pressure) regulator is too low, this indicates a problem with the equipment manufacturer (OEM) fuel system or fuel supply.

Fuel pressure tends to decrease as the flow rate increases. Therefore, the fuel pressure might only be low during high flow conditions such as stall test or rated power operations.

This is an information only fault, and is not used to diagnose malfunctioning Cummins fuel system components.

Possible causes for this fault code include:

  • Low fuel tank pressure or level
  • Damaged OEM (high-pressure) regulator
  • Restriction in the fuel lines or filter
  • Restricted or closed OEM fuel shutoff valve.
Refer to Troubleshooting Fault Code 2725.

Last Modified: 19-Apr-2016


Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit

FAULT CODE 2752

Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2752 PID: None SPN: 3464 FMI: 6/6 LAMP: Red SRT: | Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit | Engine will only idle with a possible increase in idle speed..
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The electronic throttle control actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects an open or short circuit on the engine throttle actuator (+) or (-) lines for 1 second.

Action Taken When the Fault Code is Active

The ECM will illuminate the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.

  • The engine throttle actuator will move to its default position.

Conditions for Clearing the Fault Code

To validate the repair, cycle the keyswitch, start the engine, and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes for this fault include:

  • A short circuit on the engine throttle actuator (+) or (-) line
  • An open circuit on the engine throttle actuator (+) or (-) line
  • A damaged engine throttle actuator.
Refer to Troubleshooting Fault Code 2752.

Last Modified: 26-Feb-2010


Electronic Throttle Control Actuator - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 2758

Electronic Throttle Control Actuator - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2758 PID: SPN: 3464 FMI: 0/0 LAMP: Red SRT: | Electronic Throttle Control Actuator - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine will shut down.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator, and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The electronic throttle control actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON, the engine speed is above 1000 rpm, the accelerator is depressed, and the engine throttle actuator is commanded closed.

Conditions for Setting the Fault Codes

The ECM will log this fault if the sensed throttle position is greater than commanded throttle position by a calibrated value and sensed mass air flow is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM will illuminate the red STOP ENGINE light immediately after the diagnostic runs and fails.

The ECM will shut the engine down.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes for this fault code include:

  • Engine throttle actuator sticking
  • Damaged throttle actuator.
Refer to Troubleshooting Fault Code 2758.

Last Modified: 01-Jun-2010


Electronic Throttle Control Actuator - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 2759

Electronic Throttle Control Actuator - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2759 PID: SPN: 3464 FMI: 1/1 LAMP: Red SRT: | Electronic Throttle Control Actuator - Data Valid but Below Normal Operational Range - Most Severe Level. | The engine will only idle with a possible increase in idle speed.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuato,r and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The electronic throttle control actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON, the engine speed is above 1000 rpm, the accelerator is depressed, and the engine throttle actuator is commanded open.

Conditions for Setting the Fault Codes

The ECM will log this fault if the sensed throttle position is less than commanded throttle position by a calibrated value.

Action Taken When the Fault Code is Active

The ECM will illuminate the red STOP ENGINE light immediately after the diagnostic runs and fails.

The ECM will command the engine throttle actuator to a default position.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Damaged throttle actuator.
Refer to Troubleshooting Fault Code 2759.

Last Modified: 01-Jun-2010


Gas Mass Flow 1 Sensor - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2775

Gas Mass Flow 1 Sensor - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2775 PID: P149 SPN: 1241 FMI: 0/16 LAMP: Amber SRT: | Gas Mass Flow 1 Sensor - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible reduced performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The engine control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement.

Component Location

The gas mass flow sensor is located on the fuel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is cranking or operating.

Conditions for Setting the Fault Codes

The ECM detects that actual gas flow is greater than desired gas flow by more than a calibrated amount for more than 3 seconds.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

The ECM will reset the fuel system tables.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Improper fuel pressure
  • Erratic reading due to deposits in the laminar flow screen
  • Oil contamination in the mixer housing and gas flow sensor
  • Damaged fuel control valve.
Refer to Troubleshooting Fault Code 2775.

Last Modified: 28-Mar-2016


Gas Mass Flow 1 Sensor - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2776

Gas Mass Flow 1 Sensor - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2776 PID: P149 SPN: 1241 FMI: 0/18 LAMP: Amber SRT: | Gas Mass Flow 1 Sensor - Data Valid but Below Normal Operating Range - Moderately Severe Level. | Possible reduced performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The engine control module (ECM) uses the gas mass flow sensor to measure fuel flow into the engine and to adjust the fuel control valve command based on this measurement.

Component Location

The gas mass flow sensor is located on the fuel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that actual gas flow is less than desired gas flow by more than a calibrated amount for more than 3 seconds.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will reset the fuel system tables.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The possible failure modes are the following:

  • Improper fuel pressure or low fuel level
  • Restriction due to deposits in the laminar flow screen and oil contamination in the mixer housing and gas flow sensor
  • A restriction in the fuel system
  • A damaged fuel control valve
  • A leak in the fuel system.
Refer to Troubleshooting Fault Code 2776.

Last Modified: 28-Mar-2016


Engine Turbocharger 1 Boost Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2782

Engine Turbocharger 1 Boost Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2782 PID: SPN: 1127 FMI: 0/16 LAMP: Amber SRT: | Engine Turbocharger 1 Boost Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible reduced performance.
Engine Throttle Intake Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine throttle intake pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The engine throttle intake pressure sensor provides a signal to the ECM on the engine throttle intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the air entering the engine throttle. The ECM will detect a low signal voltage when the engine throttle intake pressure is low. The ECM will detect a high signal voltage when the engine throttle intake pressure is high.

Component Location

The engine throttle intake pressure sensor is located in the air stream after the charger-air cooler, just before the throttle actuator near the wastegate control valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 700 rpm.

Conditions for Setting the Fault Codes

The ECM detects the engine throttle intake pressure is greater than a calibrated value for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate at peak power.

  • The ECM will turn off the amber check ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault may only go active under peak power conditions.

The engine throttle intake pressure sensor has been referred to as the boost pressure sensor and the mixer inlet pressure sensor in previous products.

Possible causes for this fault code include:

  • A damaged engine throttle intake pressure sensor
  • A damaged turbocharger or turbocharger wastegate
  • Incorrect turbocharger installed.
Refer to Troubleshooting Fault Code 2782.

Last Modified: 01-Jun-2010


Engine Turbocharger 1 Boost Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2783

Engine Turbocharger 1 Boost Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2783 PID: S309 SPN: 1127 FMI: 1/18 LAMP: Amber SRT: | Engine Turbocharger 1 Boost Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level. | Possible reduced engine performance.
Engine Throttle Intake Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine throttle intake pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The engine throttle intake pressure sensor provides a signal to the ECM on the engine throttle intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the air entering the engine throttle. The ECM will detect a low signal voltage when the engine throttle intake pressure is low. The ECM will detect a high signal voltage when the engine throttle intake pressure is high.

Component Location

The engine throttle intake pressure sensor is located in the air stream after the charger-air cooler, just before the throttle actuator, near the wastegate control valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 700 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the engine throttle intake pressure is less than a calibrated value for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate at high idle for 30 seconds.

  • The ECM will turn off the amber check ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine throttle intake pressure sensor has been referred to as the boost pressure sensor and the mixer inlet pressure sensor in previous products.

Possible causes of this fault code include:

  • A damaged turbocharger wastegate actuator
  • A damaged turbocharger wastegate valve
  • A damaged turbocharger.
Refer to Troubleshooting Fault Code 2783.

Last Modified: 01-Jun-2010


Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Least Severe Level. | Engine power derate.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature. The engine coolant temperature value is used by the ECM for the engine protection system, and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

When the temperature of the engine coolant is cold, the sensor or thermistor resistance is high. The ECM signal voltage pulls down only a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the temperature of the engine coolant is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The coolant temperature sensor is located below the exhaust manifold port for cylinder number 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than a calibrated limit set in the ECM.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately after the diagnostic runs and fails. The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn the fault code inactive immediately after the coolant temperature decreases below the engine protection limit.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to the Engine Coolant Temperature Above Normal symptom troubleshooting tree.

  • The resistance of the sensor varies with temperature. The reading observed should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code 2963.

Last Modified: 01-Jun-2010


Intake Manifold 1 Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2964

Intake Manifold 1 Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake Manifold 1 Temperature - Data Valid but Above Normal Operating Range - Least Severe Level. | Engine power derate.
Engine Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine intake manifold pressure/temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

When the intake air is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature. This sensor is a combination sensor and is also used to measure intake manifold pressure

Component Location

The engine intake manifold pressure/temperature sensor is located on the back of the fuel module near the fuel pressure regulator end cap and fuel shutoff valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature is greater than the calibration limit set in the ECM.

Action Taken When the Fault Code is Active

  • The ECM will log the fault code immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate this repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The maximum torque output of the engine will return and the fault code will go inactive after the intake manifold air temperature drops below the calibration limit set in the ECM.

Shop Talk

This fault code indicates that the intake manifold temperature has exceeded the maximum engine protection limit.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature

The resistance of the sensor varies with temperature. The reading observed should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

This sensor can control the engine fan if the OEM utilizes this feature within the ECM. The engine protection shutdown feature is customer-enabled and will require enabling at the customer's request.

Refer to Troubleshooting Fault Code 2964.

Last Modified: 01-Jun-2010


Engine Gas Control Valve Intake Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 2991

Engine Gas Control Valve Intake Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2991 PID: None SPN: 1390 FMI: 1/1 LAMP: Red SRT: | Engine Gas Control Valve Intake Pressure - Data Valid but Below Normal Operational Range - Most Severe Level. | Progressive power derate increasing in severity from time of start. If engine protection shutdown feature is enabled, engine will shut down after 30 seconds of the red lamp flashing.
Engine Fuel Regulator Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the engine fuel regulator outlet pressure/temperature sensor (combination sensor) to measure the pressure and temperature of fuel entering the engine fuel control valve. The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator outlet pressure/temperature sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator outlet pressure/temperature sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel exiting the engine (low pressure) regulator.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing just upstream of the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM detects engine rpm.

Conditions for Setting the Fault Codes

The ECM detects that pressure of the fuel exiting the engine (low pressure) regulator is less than a calibrated value

Action Taken When the Fault Code is Active

  • The ECM will illuminate the red STOP ENGINE light as soon as the diagnostic runs and fails.
  • The ECM will issue an engine power derate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE light when the fuel pressure is within normal operating range.

Shop Talk

The engine fuel regulator outlet pressure/temperature sensor detects fuel pressure after the fuel shutoff valve. The ISL G fuel module has a boost reference low pressure regulator which increases the fuel pressure available to the fuel control valve as boost pressure is increased. This helps optimize fuel control across the full range of fuel flows. The boost reference to the low pressure regulator is provided to the sealed end cap by an external pneumatic hose and associated fittings. Pressure drop tends to increase as the flow rate increases.

Two types of fuel systems can be used: compressed natural gas (CNG) or liquefied natural gas (LNG). The fuel system up to the engine (low pressure) regulator is supplied by the OEM. If the fuel pressure at the intake of the engine (low pressure) regulator is too low, this indicates a problem with the OEM fuel system or fuel supply.

Possible causes for this fault code include:

  • A damaged engine fuel regulator outlet pressure/temperature sensor
  • A damaged engine (low pressure) regulator
  • Low fuel pressure at the engine (low pressure) regulator.
Refer to Troubleshooting Fault Code 2991.

Last Modified: 01-Jun-2010


Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3366

Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3366 PID: SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level is below the normal operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light after 20 seconds when low engine coolant level has been detected.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after 20 seconds of detecting the correct engine coolant level.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code 3366.

Last Modified: 01-Jun-2010


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM |
 | STEP 1A. Check for fault codes. | Fault Code 111 active?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Calibrate the ECM. | ECM calibrated successfully?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If calibration update is available, does ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn keyswitch OFF and wait 30 seconds.
  • Start the engine and let it idle for 1 minute.

IFault Code 111 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the OEM connector as a possible source of an intermittent power supply.

Is there a constant +12-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 4-pin OEM connector.

Refer to the OEM service manual.

Go to 1C

Go to 2A

Guided Step 1C - Calibrate the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

Did the ECM calibrate correctly?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2A

Repair Complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Aug-2012


FAULT CODE 115 - Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Crankshaft Gear, Front (Crankshaft Removed) | Refer to Procedure 001-019 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 G CM2180 | 2883369
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibilty of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather Pack™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Codes 238, 239, 352, or 356 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 115 active?
STEP 2. | Check the engine camshaft speed/position sensors and circuits. |
 | STEP 2A. Inspect the engine camshaft speed/position sensor 1 connector pins. | Dirty or damages pins?
 | STEP 2B. Inspect the engine camshaft speed/position sensor 2 connector pins. | Dirty or damages pins?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Inspect the engine camshaft speed/position sensor 1. | Damaged sensor?
 | STEP 2E. Verify adequate engine camshaft speed/position sensor 1 air gap. | Distance is between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]?
 | STEP 2F. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2G. Inspect the engine camshaft speed/position sensor 2. | Damaged sensor tip?
 | STEP 2H. Verify adequate camshaft speed/position sensor 2 air gap. | Distance is between 29.96 mm [1.17 in] and 28.74 mm [1.13 in]?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 115 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and cleare fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238, 239, 352, or 386 active?
YES | NO
No Repair | No Repair

Troubleshoot active Fault Codes 238, 239, 352, or 386.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine camshaft speed/position sensors and circuits.

Guided Step 2A - Inspect the engine camshaft speed/position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.

Action

Inspect the engine harness and engine camshaft speed/position sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the damaged engine camshaft speed/position sensor 1. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine camshaft speed/position sensor 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine camshaft speed/position sensor 2 from the engine harness.

Action

Inspect the engine harness and engine camshaft speed/position sensor 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the damaged engine camshaft speed/position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine camshaft speed/position sensor 1 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine camshaft speed/position sensor 1 SUPPLY pin and the engine camshaft speed/position sensor 1 RETURN pin at the engine camshaft speed/position sensor 1 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Inspect the engine camshaft speed/position sensor 1.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine camshaft speed/position sensor 1 from the engine.

Action

Inspect the engine camshaft speed/position sensor 1 for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor?
YES NO

A damaged sensor has been detected.

Replace the engine camshaft speed/position sensor 1. Refer to Procedure 019-365 in the Associated Procedures Table.

Inspect the camshaft gear for damage orspinning. Measure the distance between the sensor mounting surface and the edge of the tone wheel. Is the distance between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Verify adequate engine camshaft speed/position sensor 2 air gap.

Conditions

  • Turn keyswitch OFF.
  • Remove engine camshaft speed/position sensor 1 from the engine.

Action

Verify adequate air gap.

  • Measure the distance between the sensor mounting surface and the edge of the tone wheel.

Distance is between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]?
YES NO
No Repair

Inspect the camshaft gear teeth for damage or spinning.

Go to 2F

Go to 4A

Guided Step 2F - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor 2 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine camshaft speed/position sensor 2 SUPPLY pin and the engine camshaft speed/position sensor 2 RETURN pin at the engine camshaft speed/position sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2G

Go to 3A

Guided Step 2G - Inspect the engine camshaft speed/position sensor 2.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine camshaft speed/position sensor 2 from the engine.

Action

Inspect the engine camshaft speed/position sensor 2 for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

A damaged sensor tip has been detected.

  • Replace the engine camshaft speed/position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.
  • Inspect the camshaft gear for damage or spinning. Measure the distance between the sensor mounting surface and the edge of the tone wheel. Is the distance between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]?

No Repair

Go to 4A

Go to 2H

Guided Step 2H - Verify adequate engine camshaft speed/position sensor 2 air gap.

Conditions

  • Turn keyswitch OFF.
  • Remove engine camshaft speed/position sensor 2 from the engine.

Action

Verify adequate air gap.

Measure the distance between the sensor mounting surface and the camshaft gear.

Distance is between 29.96 mm [1.17 in] and 28.74 mm [1.13 in]?
YES NO
No Repair

Inspect the camshaft gear teeth for damage or spinning.

  • Inspect the camshaft gear. Refer to Procedure 001-019 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or engine harness.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 inactive?
YES NO

NOTE: The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.
  • Disconnect the engine camshaft speed/position sensor 2 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 RETURN pin and the engine camshaft speed/position sensor 1 connector RETURN pin.
  • Measure the resistance between the ECM connector 1 SUPPLY pin and the engine camshaft speed/position sensor 1 connector SUPPLY pin.
  • Measure the resistance between the ECM connector 1 engine camshaft speed/position sensor 1 SIGNAL pin and the engine camshaft speed/position sensor 1 connector SIGNAL pin.
  • Measure the resistance between the ECM connector 1 engine camshaft speed/position sensor 1 RETURN pin and the engine camshaft speed/position sensor 2 connector RETURN pin.
  • Measure the resistance between the ECM connector 1 engine camshaft speed/position sensor 1 SUPPLY pin and the engine camshaft speed/position sensor 2 connector SUPPLY pin.
  • Measure the resistance between the ECM connector 1 engine camshaft speed/position sensor 1 SIGNAL pin and the engine camshaft speed/position sensor 2 connector SIGNAL pin.

NOTE: Shake and wiggle the harness to determine an intermittent connection.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.
  • Disconnect the engine camshaft speed/position sensor 2 from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine camshaft speed/position sensor 1 SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine camshaft speed/position sensor 1 SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine camshaft speed/position sensor 2 SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine camshaft speed/position sensor 2 SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4B

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1 and 2.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.
  • Disconnect the engine camshaft speed/position sensor 2 from the engine harness.
  • Disconnect all components on sensor supply 1.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine camshaft speed/position sensor 1, 5 volt SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine camshaft speed/position sensor 1, 5 volt SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine camshaft speed/position sensor 2, 5 volt SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine camshaft speed/position sensor 2, 5 volt SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the engine harness.

Replace the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4B

Guided Step 3F - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.
  • Disconnect the engine camshaft speed/position sensor 2 from the engine harness.

Action

Check for pin-to-ground short.

  • Measure the resistance between the engine camshaft speed/position sensor 1 SIGNAL pin in the engine harness ECM connector 1 and ground.
  • Measure the resistance between the engine camshaft speed/position sensor 2 SIGNAL pin in the engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Aug-2012


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 227. | Fault Code 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 122 active?
STEP 2. | Check the engine intake manifold pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the engine intake manifold pressure/temperature sensor and connector pins | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 123 active?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 123 active?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 227.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 227.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 122 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake manifold pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the engine intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace or replace the engine harness. Refer to Proedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine intake manifold pressure SUPPLY pin to the engine intake manifold pressure/temperature RETURN pin at the engine intake manifold pressure/temperature sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine intake manifold pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

None. The removal and installation of the connectors corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO
No Repair

A damaged ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Disconnect all sensors on the sensor supply.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine intake manifold pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine intake manifold pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine intake manifold pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine intake manifold pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine intake manifold pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine intake manifold pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision numbers in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Aug-2012


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
 | STEP 1B. Check for an active fault code. | Fault Code 123 active?
STEP 2. | Check the engine intake manifold pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the engine intake manifold pressure/temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response | Fault Code 122 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 123 active?
 | STEP 3F. Check the ECM response. | Fault Code 122 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 187.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 187.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake manifold pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the engine intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the SUPPLY pin and the engine intake manifold pressure/temperature RETURN pin at the engine intake manifold pressure/temperature sensor connector of the engine harness.

Refer to the circuit diagram and wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine intake manifold pressure SUPPLY pin and the engine intake manifold pressure SIGNAL pin at the engine intake manifold pressure/temperature sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine intake manifold pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 engine intake manifold pressure RETURN pin and the engine intake manifold pressure RETURN pin in the engine intake manifold pressure/temperature sensor connector.
  • Measure the resistance between the ECM connector 1 engine intake manifold pressure SUPPLY pin and the engine intake manifold pressure SUPPLY pin in the engine intake manifold pressure/temperature sensor connector.
  • Measure the resistance between the ECM connector 1 engine intake manifold pressure SIGNAL pin and the engine intake manifold pressure SIGNAL pin in the engine intake manifold pressure/temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Disconnect all sensors in sensor supply.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine intake manifold pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine intake manifold pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine intake manifold pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine intake manifold pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine intake manifold pressure RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine intake manifold pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-ground short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine intake manifold pressure sensor SIGNAL pin in the ECM connector 1 and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4B

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO
No Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 3F

Go to 4A

Guided Step 3F - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine intake manifold pressure SUPPLY pin and the engine intake manifold pressure SIGNAL pin at the engine intake manifold pressure/temperature sensor connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Aug-2012


FAULT CODE 124 - Intake Manifold 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Turbocharger | Refer to Procedure 010-033 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Valve Body | Refer to Procedure 010-055 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122 or 123 active?
STEP 2. | Check the engine intake manifold pressure/temperature sensor. |
 | STEP 2A. Inspect the engine harness and engine intake manifold pressure/temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify the engine intake manifold pressure. | Engine intake manifold pressure and engine turbocharger compressor intake values the same at atmospheric pressure?
 | STEP 2C. Read the fault codes. | Fault Code 124 active?
STEP 3. | Check the mechanical components. |
 | STEP 3A. Check the turbocharger. | Turbocharger correct and operating correctly?
 | STEP 3B. Check the air intake restriction. | Restriction less than 63.5 cm-H2O [25.0 in H2O]?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 122 or 123 active?

YES | NO
No Repair | No Repair

Reference the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine intake manifold pressure/temperature sensor.

Guided Step 2A - Inspect the engine harness and engine intake manifold pressure/temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine intake manifold pressure/temperature sensor.

Action

Inspect the engine harness and engine intake manifold pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Verify the engine intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine not operating.
  • Connect INSITE™ electronic service tool.

Action

Check the engine intake manifold pressure with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to compare the engine intake manifold and engine turbocharger intake pressure.

Engine turbocharger intake pressure and engine intake manifold pressure values the same as atmospheric pressure?
YES NO
No Repair

Replace the engine intake manifold sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Read the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and operate it in the condition in which the fault occurred.
  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 124 active?
YES NO
No Repair

None. The removal and installation of the connectors corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the mechanical components.

Guided Step 3A - Check the turbocharger.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger.

  • Confirm that the turbocharger is the correct one.
  • Check the turbocharger and wastegate plumbing for mechanical problems. Refer to Procedure 010-050 in the Associated Procedures Table.
  • Refer to Procedure 010-055 in the Associated Procedures Table.

Turbocharger is correct and is operating correctly?
YES NO
No Repair

Repair or replace the turbocharger wastegate actuator.

  • Refer to Procedure 010-050 in the Associated Procedures Table.
  • Refer to Procedure 010-055 in the Associated Procedures Table.

Repair or replace the turbocharger.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 3B

Go to 4B

Guided Step 3B - Check the air intake restriction.

Conditions

  • Turn keyswitch OFF.

Action

Check the air intake restriction.

  • Check the intake restriction of the engine. Refer to Procedure 010-031 in Section 10.

Is restriction less than 63.5 cm-H2O [25.0 in H2O]?

YES NO
No Repair

Correct the restriction. Remove the restriction or replace the air cleaner element. Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Aug-2012


FAULT CODE 125 - Intake Manifold 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | ISB5.9 G CM2180 Service Manual | 2883369
Turbocharger | Refer to Procedure 010-033 | ISB5.9 G CM2180 Service Manual | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 Service Manual | 2883369
Turbocharger Wastegate Valve Body | Refer to Procedure 010-055 | ISB5.9 G CM2180 Service Manual | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 Service Manual | 2883369
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | ISB5.9 G CM2180 Service Manual | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122 or 123 active?
STEP 2. | Check the engine intake manifold pressure/temperature sensor. |
 | STEP 2A. Inspect the engine harness and engine intake manifold pressure/temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify the engine intake manifold pressure. | Engine intake manifold pressure and engine turbocharger compressor intake values the same as atmospheric pressure?
 | STEP 2C. Read the fault code. | Fault Code 125 active?
STEP 3. | Check the mechanical components. |
 | STEP 3A. Check the turbocharger. | Turbocharger correct and operating correctly?
 | STEP 3B. Check the air intake restriction. | Restriction within specification?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 122 or 123 active?

YES | NO
No Repair | No Repair

Reference the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine intake manifold pressure/temperature sensor.

Guided Step 2A - Inspect the engine harness and engine intake manifold pressure/temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine intake manifold pressure/temperature sensor.

Action

Inspect the engine harness and engine intake manifold pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

No Repair

Go to 4B

Go to 2B

Guided Step 2B - Verify the engine intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the engine intake manifold pressure with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to compare the engine intake manifold pressure and engine turbocharger intake pressure when the engine is not operating.

Engine turbocharger intake pressure and engine intake manifold pressure values the same as atmospheric pressure?
YES NO
No Repair

Replace the engine intake manifold sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 125 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the mechanical components.

Guided Step 3A - Check the turbocharger.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger.

  • Confirm that the turbocharger is the correct one.
  • Check the turbocharger and wastegate plumbing for mechanical problems. Refer to Procedure 010-050 in the Associated Procedures Table.
  • Refer to Procedure 010-055 in the Associated Procedures Table.

Turbocharger is correct and is operating correctly?
YES NO
No Repair

Repair or replace the turbocharger wastegate actuator.

  • Refer to Procedure 010-050 in the Associated Procedures Table.
  • Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 3B

Go to 4B

Guided Step 3B - Check the air intake restriction.

Conditions

  • Turn keyswitch OFF.

Action

Check the air intake restriction.

  • Check the intake restriction of the engine. Refer to Procedure 010-031 in the Associated Procedures Table.

Is restriction less than 63.5 cm H20 [25.0 in H20]?

YES NO
No Repair

Correct the restriction. Remove the restriction or replace the air cleaner element. Refer to Procedure 010-031 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Aug-2012


FAULT CODE 131 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for a sensor supply fault code. | Fault Code 2185 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 2. | Check the accelerator pedal and circuit. |
 | STEP 2A. Inspect the accelerator pedal and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 131 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 132 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the engine harness and OEM harness. |
 | STEP 3A-2. Check for a pin-to-pin short circuit in the engine harness and OEM harness. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply 4 fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2185.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the accelerator pedal and circuit.

Guided Step 2A - Inspect the accelerator pedal and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the pedal or harness connector.

Repair or replace the engine harness or OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair or replace the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the accelerator pedal supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the accelerator pedal SUPPLY pin and the accelerator pedal RETURN pin at accelerator pedal connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active and Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES NO

A damaged accelerator pedal has been detected.

Replace the accelerator pedal. Refer to the OEM service manual.

 No Repair

Go to 4B

Go to 4A

Guided Step 3 - Check the engine ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect OEM harness ECM connector 2.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports, as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the OEM harness or the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector RETURN pin and the OEM harness accelerator pedal connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3A-2

Go to 4B

Guided Step 3A-2 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector 2 and all other pins in the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 4B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-Aug-2012


FAULT CODE 132 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
OEM Wiring Harness | Refer to Procedure 019-071 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for a sensor supply fault code. | Fault Code 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal and circuit. |
 | STEP 2A. Inspect the accelerator pedal and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 132 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness and OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness and OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for a sensor supply fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2186.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.
Go to

Guided Step 2 - Check the accelerator pedal and circuit.

Guided Step 2A - Inspect the accelerator pedal and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector or pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the accelerator pedal supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the accelerator pedal position 1 SUPPLY pin and the accelerator pedal position 1 RETURN pin at accelerator pedal connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the accelerator pedal position 1 SUPPLY pin and the accelerator pedal position 1 SIGNAL pin at the accelerator pedal connector of the OEM harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes .

Fault Code 131 active and Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes .

Fault Code 132 active?
YES NO

A damaged accelerator pedal has been detected.

Replace the accelerator pedal. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect OEM harness ECM connector 2.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the OEM harness. Refer to the OEM servie manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 2 accelerator pedal position 1 SUPPLY pin and the OEM harness accelerator pedal position 1 SUPPLY pin.
  • Measure the resistance between the ECM connector 2 accelerator pedal position 1 SIGNAL pin and the OEM harness accelerator pedal position 1 SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connectors 1 and 2.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal position 1 SIGNAL pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the accelerator pedal position 1 SIGNAL pin in the ECM connector 2 and all other pins in the ECM connector 1.
  • Measure the resistance between the accelerator pedal position 1 SUPPLY pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the accelerator pedal position 1 SUPPLY pin in the ECM connector 2 and all pins in the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 2.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal position 1 SIGNAL pin in the ECM connector 2 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Aug-2012


FAULT CODE 133 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 133 inactive?
STEP 2. | Check the remote accelerator pedal/lever and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal/lever and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal/lever supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 134 active and Fault Code 133 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal/lever condition. | Fault Code 133 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON or the Run/Stop switch to the RUN position.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1695.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch to the RUN position.
  • Turn the remote accelerator switch to ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 133 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the remote accelerator pedal/lever and circuit.

Guided Step 2A - Inspect the remote accelerator pedal/lever and connector pins.

Conditions

  • Turn keyswitch OFF or Run/Stop switch to the STOP position.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Inspect the OEM harness and remote accelerator pedal/lever connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the remote accelerator pedal/lever supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF or Run/Stop switch to the STOP position.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.
  • Turn keyswitch ON or the Run/Stop switch to the RUN position.

Action

Check the supply and return circuit.

  • Measure the voltage between the accelerator pedal voltage SUPPLY pin and the RETURN pin at the remote accelerator pedal/lever connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF or the Run/Stop switch to the STOP position.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.
  • Turn the remote accelerator switch to ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active and Fault Code 133 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal/lever condition.

Conditions

  • Turn keyswitch OFF or the Run/Stop switch to the STOP position.
  • Connect the remote accelerator pedal/lever to the OEM harness.
  • Turn keyswitch ON or the Run/Stop switch to the RUN position.
  • Turn the remote accelerator switch to ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after one minute.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES NO

A damaged remote accelerator pedal/lever has been detected.

  • Replace the remote accelerator pedal/lever. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF or the Run/Stop switch to the STOP position.
  • Disconnect engine harness ECM connector 2.

Action

Inspect the OEM harness and the ECM connector 2 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

An open circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF or the Run/Stop switch to the STOP position.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the remote accerator pedal/lever from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 2 RETURN pin and the OEM harness accelerator pedal/lever connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF or the Run/Stop switch to the STOP position.
  • Disconnect the OEM harness ECM connectors 1 and 2.
  • Disconnect the remote accerator pedal/lever from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the ECM connector 2 and all other pins in the connector 2.
  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the ECM connector 2 and all other pins in the connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Aug-2012


FAULT CODE 134 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 134 inactive?
STEP 2. | Check the remote accelerator pedal/lever and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal/lever and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal/lever supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 133 active and Fault Code 134 inactive?
 | STEP 2D. Check the fault code and verify remote accelerator pedal/lever condition. | Fault Code 134 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON or to the RUN position.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1696.

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON or to the RUN position.
  • Turn the remote accelerator switch to ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the remote accelerator pedal/lever and circuit.

Guided Step 2A - Inspect the remote accelerator pedal/lever and connector pins.

Conditions

  • Turn keyswitch OFF or Run/Stop switch to the STOP position.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Inspect the OEM harness and remote accelerator pedal/lever connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the remote accelerator pedal/lever supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF or Run/Stop switch to the STOP position.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.
  • Turn keyswitch ON or Run/Stop switch to the RUN position.

Action

Check the SUPPLY and RETURN circuit.

  • Measure the voltage between the remote accelerator pedal voltage SUPPLY pin and the RETURN pin at the remote accelerator pedal/lever connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF or Run/Stop switch to the STOP position.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.
  • Turn keyswitch ON or Run/Stop switch to the RUN position.
  • Turn the remote accelerator switch to ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the remote accelerator pedal SUPPLY pin and remote accelerator pedal SIGNAL pin at the remote accelerator pedal/lever connector of the OEM harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active and Fault Code 134 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal/lever condition.

Conditions

  • Turn keyswitch OFF or Run/Stop switch to the STOP position.
  • Connect the remote accelerator pedal/lever to the OEM harness.
  • Turn keyswitch ON or Run/Stop switch to the RUN position.
  • Turn the remote accelerator switch to ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO

A damaged remote accelerator pedal/lever has been detected.

  • Replace the remote accelerator/lever. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF or Run/Stop switch to the STOP position.
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the OEM harness and ECM connector 2 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on theconnector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedues Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF or Run/Stop switch to the STOP position.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 2 SUPPLY pin and the OEM harness accelerator pedal/lever connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF or Run/Stop switch to the STOP position.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the OEM harness ECM connector 2 and the OEM harness remote accelerator pedal/lever signal pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF or Run/Stop switch to the STOP.
  • Disconnect the ECM connectors 1 and 2.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Check for an pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the ECM connector 2 and all other pins in connector 2.
  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the ECM connector 2 and all other pins in connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF or Run/Stop switch to the STOP.
  • Disconnect the ECM connector 2.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the ECM connector 2 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness or OEM harness.

Repair or replace the engine harness or OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn keyswitch ON or to the RUN position.
  • Turn remote accelerator switch to ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 227.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 volt SUPPLY pin and the oil pressure RETURN pin on the oil pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected. Replace the oil pressure sensor.

  • Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or engine harness connector.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 RETURN pin and the oil pressure sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 1.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the oil pressure SIGNAL pin in ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the oil pressure SIGNAL pin in ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect all other components on the sensor supply number 2.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the oil pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the oil pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 187. | Fault Code 187 active?
 | STEP 1B. Check for an active fault code. | Fault Code 141 active?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 141 active?
 | STEP 3F. Check the ECM response. | Fault Code 135 active?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 187.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 187

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect th engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and engine oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-066 in Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine oil pressure SUPPLY pin to the engine oil pressure RETURN pin at the engine oil pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil pressure SUPPLY pin and the engine oil pressure SIGNAL pin at the engine oil pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: Do not spray contact cleaner directly into the ECM ports, as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 engine oil pressure RETURN pin and the engine oil pressure RETURN pin of the engine oil pressure sensor connector.
  • Measure the resistance between the ECM connector 1 engine oil pressure SUPPLY pin and the engine oil pressure SUPPLY pin at the engine oil pressure sensor connector.
  • Measure the resistance between the ECM connector 1 engine oil pressure SIGNAL pin and the engine oil pressure SIGNAL pin in the engine oil pressure sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connectors 1 and 2.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Disconnect all sensors in the sensor supply 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine oil pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine oil pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine oil pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine oil pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine oil pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine oil pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-ground short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine oil pressure SIGNAL pin in the ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procecdure 019-043 in Associated Procedures Table.

Go to 3E

Go to 4B

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3F

Go to 4A

Guided Step 3F - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil pressure SUPPLY pin and the engine oil pressure SIGNAL pin at the engine oil pressure sensor connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 135 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in in Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Lubricating Oil System | Refer to Procedure 018-017 | ISB5.9 G CM2180 | 2883369
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Lubricating oil level is above or below specification | Lubricating oil level is above or below specification?
 | STEP 1B. Check the sensor accuracy. | Sensor reading correct?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Lubricating oil level is above or below specification.

Conditions

  • Turn keyswitch OFF.

Action

Check oil level.

Lubricating oil level is above or below specification?
YES NO

Drain or fill the oil to bring oil level within specification. Refer to Procedure 018-017 in the Associated Procedures Table.

 No Repair

Go to 2B

Go to 1A

Guided Step 1B - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start and idle the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. If the display is absolute pressure, add atmospheric pressure to gauge reading.

NOTE: If internal engine noise is present and internal engine damage is suspected do not run the engine.

Sensor reading correct?
YES NO
No Repair

Replace the sensor if the electronic service tool reading differs from the mechanical gauge reading. Refer to Procedure 019-066 in the Associated Procedures Table.

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree.

Go to 2B

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 144 active?
STEP 2. | Check the coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Sensor resistance between 600 ohms and 420K ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature SIGNAL pin and the engine coolant temperature RETURN pin at the engine coolant temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Sensor resistance between 600 ohms and 420K ohms?
YES NO
No Repair

A damaged sensor had been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports, as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 engine coolant temperature RETURN pin and the engine harness engine coolant temperature RETURN pin in the engine harness engine coolant temperature sensor connector.
  • Measure the resistance between the ECM connector 1 engine coolant temperature SIGNAL pin and the engine harness engine coolant temperature SIGNAL pin in the engine harness engine coolant temperature sensor connector.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine coolant temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine coolant temperature RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine coolant temperature RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 G CM2180 | 2883369
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 145 active?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Sensor resistance between 600 ohms and 420K ohms?
 | STEP 2C. Check the fault code and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short to ground in the engine harness | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 145 active?
 | STEP 3E. Check the circuit response at the ECM. | Fault Code 144 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature SIGNAL pin and the engine coolant temperature RETURN pin at the engine coolant temperature sensor.
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Sensor resistance between 600 ohms and 420K ohms?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1 and 2.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports, as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin short circuit to ground.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine coolant temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine coolant temperature RETURN pin in the ECM connector 2 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine coolant temperature RETURN pin in the ECM connector 2 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3E

Go to 4A

Guided Step 3E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an active fault code. |
 | STEP 1A. Read the fault codes. | Fault Code 146 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the temperature differ by more than 3°C or 5°F?
STEP 3. | Check the coolant temperature sensor. |
 | STEP 3A. Inspect the coolant temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 146 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the coolant temperature reading from INSITE™ electronic service tool to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ by more than 3°C or 5°F?
YES NO

Replace the coolant sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the coolant temperature sensor.

Guided Step 3A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the coolant temperature sensor. Refer to Procdure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and operate it for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: If the fault occurred at a particular speed, operate the engine at that speed to verify that the problem has been corrected.

Fault Code 146 active?
YES NO

Reference the Coolant Temperature Above Normal troubleshooting symptom tree in Service Manual,QSB5.9 G CM2180, Bulletin 2883369.

 No Repair

Go to 4B

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 151 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the temperature differ by greater than 3°C or 5°F?
STEP 3. | Check the coolant temperature sensor. |
 | STEP 3A. Inspect the coolant temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 151 active?
STEP 4. | Check ECM calibration and cleare fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it operate for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the coolant temperature reading from INSITE™ electronic service tool to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ by more than 3°C or 5°F?
YES NO

Replace the coolant sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the coolant temperature sensor.

Guided Step 3A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and operate it for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: If the fault occured at a particular speed, operate the engine at that speed to verify that the problem has been corrected.

Fault Code 151 active?
YES NO

Reference the Coolant Temperature Above Normal troubleshooting symptom tree in Section TS in Service Manual, QSB5.9 G CM2180, Bulletin 2883369.

No Repair

Go to 4B

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 153 active?
STEP 2. | Check the engine intake manifold pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the engine intake manifold pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance | Sensor resistance between 600 ohms and 420k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 153 active?
 | STEP 3E. Check the circuit response at the ECM. | Fault Code 154 active?
STEP 4. | Check ECM calibration and cleare fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake manifold pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the engine intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine intake manifold pressure/temperature sensor.

Action

Inspect the engine harness and intake manifold pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine intake manifold temperature SIGNAL pin and the engine intake manifold temperature RETURN pin at the engine intake manifold pressure/temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Sensor resistance between 600 ohms and 420k ohms?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the engine intake manifold pressure/temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine intake manifold pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspections techniques. Refer to Procedure 019-361 in Section 19.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 engine intake manifold temperature RETURN pin and the engine harness engine intake manifold temperature RETURN pin in the engine harness engine intake manifold pressure/temperature sensor connector.
  • Measure the resistance between the ECM connector 1 engine intake manifold temperature SIGNAL pin and the engine harness engine intake manifold temperature SIGNAL pin in the engine harness engine intake manifold pressure/temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine intake manifold temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine intake manifold temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine intake manifold temperature RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3E

Go to 4A

Guided Step 3E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine intake manifold temperature SIGNAL pin and the engine intake manifold temperature RETURN pin at the engine intake manifold pressure/temperature sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Manifold Absolute Pressure Sensor | Refer to Procedure 019-099 | ISB5.9 G CM2180 | 2883369
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 154 active?
STEP 2. | Check the engine intake manifold pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the engine intake manifold pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance | Sensor resistance between 600 ohms and 420k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code 154 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake manifold pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the engine intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine intake manifold pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-099 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine intake manifold temperature SIGNAL pin and the engine intake manifold pressure/temperature RETURN pin at the engine intake manifold pressure/temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Sensor resistance between 600 ohms and 420k ohms?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine intake manifold pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports, as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine intake manifold temperature SIGNAL pin in the ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1and 2.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine intake manifold temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine intake manifold temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine intake manifold temperature RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine intake manifold temperature RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.
  • Use INSITE™ electronic service tool to verify that Fault Code 154 is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-354 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Monitor intake manifold air temperature. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 155 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Monitor intake manifold air temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES NO

Reference the Intake Manifold Air Temperature Above Specification symptom tree in Section TS in Service Manual, ISB5.9 G CM2180, Bulletin 2883369.

No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 176 - Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Throttle Actuator | Refer to Procedure 019-097 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 176 active?
STEP 2. | Check the engine throttle actuator. |
 | STEP 2A. Inspect the engine throttle actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 176 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 176 active?
 | STEP 3F. Check the engine throttle actuator. | Throttle actuator test passed?
STEP 4. | Check ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 176 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting inactive or intemittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle actuator.

Guided Step 2A - Inspect the engine throttle actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or actuator. Repair or replace the engine harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine throttle actuator. Refer to Procedure 019-097 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 176 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.
  • Disconnect the engine harness ECM connector 1.

Action

Check for an open circuit.

  • Measure the resistance between the engine throttle actuator positive (+) pin in the ECM connector 1 and the throttle actuator positive (+) pin in the engine harness engine throttle actuator connector.
  • Measure the resistance between the engine throttle actuator negative (-) pin in the ECM connector 1 and the throttle actuator (-) pin in the engine harness engine throttle actuator connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.
  • Disconnect the engine harness ECM connector 1.

Action

Check for a short circut to engine block ground.

  • Measure the resistance between the engine throttle actuator positive (+) pin in the ECM connector 1 and engine block ground.
  • Measure the resistance between the engine throttle actuator negative (-) pin in the ECM connector 1 and engine block ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.
  • Disconnect the engine harness ECM connectors 1 and 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine throttle actuator positive (+) pin in the ECM connector 1 and all other pins in connector 1.
  • Measure the resistance between the engine throttle actuator negative (-) pin in ECM connector 1 and all other pins in connector 1.
  • Measure the resistance between the engine throttle actuator positive (+) pin in ECM connector 1 and all pins in engine harness ECM connector 2.
  • Measure the resistance between the engine throttle actuator negative (-) pin in ECM connector 1 and all pins in engine harness ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4B

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and operate at 1000 rpm for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 176 active?
YES NO

A damaged engine throttle actuator has been detected.

  • Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3F

Guided Step 3F - Check the engine throttle actuator.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the throttle actuator test.

  • Use INSITE™ electronic service tool to run the throttle actuator test and confirm the actuator is operational.

NOTE: If the throttle actuator test is not available in INSITE™ elctronic service tool, answer yes to this step.

Did actuator pass test?
YES NO
No Repair

Replace the throttle actuator.

  • Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB5.9 G CM2180 | 2883369
Mixer Inlet Pressure Sensor | Refer to Procedure 019-098 | ISB5.9 G CM2180 | 2883369
Fuel Pressure/Temperature Sensor | Refer to Procedure 019-153 | ISB5.9 G CM2180 | 2883369
Fuel Pressure Sensor | Refer to Procedure 019-188 | ISB5.9 G CM2180 | 2883369
Exhaust Back Pressure Sensor | Refer to Procedure 019-347 | ISB5.9 G CM2180 | 2883369
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response |
 | STEP 2B. Inspect the engine fuel regulator outlet pressure/temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine intake manifold pressure/temperature sensor and connector pins connected to sensor supply 2. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the engine fuel regulator intake pressure sensor and connector pins connected to sensor supply 2. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the engine exhaust back pressure sensor and connector pins connected to sensor supply 2. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 187 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine oil pressure sensor harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged engine oil pressure sensor has been detected.

  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 2B

Go to 4B

Guided Step 2B - Inspect the engine fuel regulator outlet pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Inspect the engine fuel regulator outlet pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-153 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-153 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Inspect the engine intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine intake manifold pressure/temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the engine intake manifold pressure/temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

Go to 2D

Go to 4B

Guided Step 2D - Inspect the engine fuel regulator intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged engine fuel regulator intake pressure sensor has been detected.

  • Replace the engine fuel regulator intake pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 2E

Go to 4B

Guided Step 2E - Inspect the engine exhaust back pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine exhaust back pressure sensor. Refer to Procedure 019-347 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged engine exhaust back pressure sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-347 in the Associated Procedures Table.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.

Action

Inspect the engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness, or replace ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors 1 and 2 from the ECM.
  • Make sure all components connected to sensor supply 2 are disconnected.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply 2 has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4B

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Make sure all components connected to sensor supply 2 are disconnected.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor SUPPLY 2 pin in the engine harness ECM connector 2 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply 2 has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Disconnect engine harness ECM connector 1.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 195 - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1695

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

  • Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

  • Repair the damaged harness, connector, or pins, if possible. Refer to the OEM service manual.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 2.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 2 engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.
  • Measure the resistance between the ECM connector 2 engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM and engine harnesses.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the ECM connector 2 and all other pins in the ECM connector 1.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM or engine harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Disconnect all components connected to sensor supply 5 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the ECM connector 2 and all other pins in ECM connector 1.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3E

Go to 4B

Guided Step 3E - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 196 - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1696. | Fault Code 1696 active?
 | STEP 1B. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response | Fault Code 195 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short to ground in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1696.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1696

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual
  • Replace the sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine coolant level SUPPLY pin to the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 2 engine coolant level RETURN pin and the engine coolant level RETURN pin of the engine coolant level sensor connector.
  • Measure the resistance between the ECM connector 2 engine coolant level SUPPLY pin and the engine coolant level SUPPLY pin at the engine coolant level sensor connector.
  • Measure the resistance between the ECM connector 2 engine coolant level SIGNAL pin and the engine coolant level SIGNAL pin in the engine coolant level sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to the OEM service manual

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connectors 1 and 2.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Disconnect all sensors in sensor supply 5.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine coolant level SIGNAL pin in the ECM connector 2 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine coolant level SIGNAL pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine coolant level SUPPLY pin in the ECM connector 2 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine coolant level SUPPLY pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine coolant level RETURN pin in the ECM connector 2 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine coolant level RETURN pin in the ECM connector 2 and all other pins in the ECM connector 2.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin short to ground in the OEM and engine harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the ECM connector 2 and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin short to ground has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration code and clear fault codes

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 197 active?
STEP 2. | Check the coolant level. |
 | STEP 2A. Check for low coolant level. | Coolant level low?
STEP 3. | Check the ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 197 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the coolant level.

Guided Step 2A - Check for low coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant level.

  • Refer to the OEM service manual.

Coolant level low?
YES NO

Add coolant to the engine. Refer to the OEM service manual.

Check for coolant leaks. Reference the Coolant Loss troubleshooting symptom tree in Section TS in Service Manual, ISB5.9 G CM2180, Bulletin 2883369.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Codes 227 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply 2 supply voltage. | Voltage greater than 5.63-VDC?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.

Action

Inspect the ECM, engine harness, and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the sensor supply 2 supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage at the ECM.

  • Measure the voltage between the sensor supply 2 pin in the ECM connector 1 and the sensor return 2 pin in thes ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 5.63-VDC?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect all components connected to sensor supply number 2.

Action

Check for a pin-to pin-short.

  • Measure the resistance between the sensor SUPPLY 2 pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the sensor SUPPLY 2 pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor SUPPLY number 2 wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness.Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring downhill?
 | STEP 1B. Check for active fault codes. | Active Fault Codes 2758, 2759, 2189, 176, 2752, and 2645?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Inspect the engine harness and engine sensor connector pins. | Dirty or damaged pins?
 | STEP 1E. Check for an inactive fault code at low engine rpm. | Inactive fault code at low engine rpm?
 | STEP 1F. Check for an inactive fault code at low engine rpm. | Inactive fault code at low engine rpm?
 | STEP 1G. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Check the ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Interview the operator for conditions when the fault is set, such as motoring downhill or throttle depressed.

Motoring downhill?
YES NO

Check for engine damage.

  • Electronics OK.
  • Check the base engine for damage due to overspeed condition.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Codes 2758, 2759, 2189, 176, 2752, and 2645.

Active Fault Codes 2758, 2759, 2189, 176, 2752, and 2645?
YES | NO
No Repair | No Repair

Troubleshoot active Fault Codes 2758, 2759, 2189, 176, 2752, and 2645.

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Operate engine.
  • Connect INSITE™ electronic service tool.

Action

Check the engine rpm with INSITE™ electronic service tool.

  • Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or digital optical tachometer, Part Number 3377462, or equivalent.

Correct rpm reading?
YES NO
No Repair

Inspect the engine camshaft speed/position sensor 1 and engine camshaft speed/position sensor 2 as outlined in Fault Code 689 and Fault Code 778.

Go to 1D

Fault Codes 689 and 778.

Guided Step 1D - Inspect the engine harness and engine camshaft speed/position sensor 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 2B

Go to 1E

Guided Step 1E - Check for an inactive fault code at low engine rpm.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code at low engine rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Inactive fault code at low engine rpm?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 1H

Go to 1F

Guided Step 1F - Check for an inactive fault code at low engine rpm.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start engine and let it idle for 1 minute.

  • Check for an inactive fault code at low engine rpm.
  • Use INSITE™ electronic service tool to read the fault codes.

Inactive fault code at low engine rpm?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1H

Guided Step 1H - Test the vehicle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test the vehicle.

  • Connect INSITE™ electronic service tool to read the fault codes.

Fault Code 234 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number - 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 235 active?
STEP 2. | Check the coolant level. |
 | STEP 2A. Check for low coolant level. | Coolant level low?
STEP 3. | Check the ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 235 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the coolant level.

Guided Step 2A - Check for low coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant level.

  • Refer to the OEM service manual.

Coolant level low?
YES NO

Add coolant to the engine.

Refer to the OEM service manual.

Check for coolant leaks. Reference the Coolant Loss troubleshooting symptom tree in Section TS in Service Manual, ISB5.9 G CM2180, Bulletin 2883369.

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

Go to 3B

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control modue (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the engine camshaft speed/position sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 238 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the engine camshaft speed/position sensor 1 and connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft speed/position sensor 1 from the engine harness.

Action

Inspect the engine harness and engine camshaft speed/position sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft speed/position sensor 1 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connectors 1 and 2.
  • Disconnect all sensors on sensor supply 3 from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 3 pin in engine harness ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the sensor SUPPLY 3 pin in engine harness ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-ground short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connectors 1 and 2.
  • Disconnect all sensors on sensor supply 3 from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance of the sensor SUPPLY 3 pin in the engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3D - Check sensor supply 3 voltage.

Conditions

  • Disconnect the engine camshaft speed/position sensor 1.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply voltage at the ECM.

  • Measure the voltage between the sensor supply 3 pin in the engine harness ECM connector 1 and the sensor return 3 pin in the engine harness ECM connector 1.

Voltage less than 4.42-VDC?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 239 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check the sensor supply 3 supply voltage. | Voltage greater than 5.63-VDC?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness

Action

Check for pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 3 pin in ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the sensor SUPPLY number 3 pin in ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 3 circuit line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply 3 supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor 1.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage from the ECM.

  • Measure the voltage between the engine camshaft speed/position sensor 1 SUPPLY 3 pin in the engine harness ECM connector 1 and the sensor RETURN 3 pin in the engine camshaft speed/position sensor 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 5.63-VDC?
YES NO

A damaged sensor supply circuit has been detected in the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 241 - Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female WeatherPack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 241 active?
 | STEP 1B. Determine if the vehicle speed sensor is a VECU multiplexed component that is enabled for multiplexing over the SAE J1939 data link to the engine ECM. | Is the vehicle speed sensor a multiplex component?
 | STEP 1C. Check for active fault codes. | Fault Codes 285 or 286 active?
STEP 2. | Check the vehicle speed sensor. |
 | STEP 2A. Inspect the OEM harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 241 active?
 | STEP 2C. Use INSITE™ electronic service tool to verify correct sensor type is selected. | Correct sensor type selected?
 | STEP 2D. Check the vehicle speed sensor for proper adjustment. | 1/2 to 3/4 of a turn out from the gear?
 | STEP 2E. Check for proper operation of the OEM vehicle speed sensor. | Vehicle speed sensor operating properly?
 | STEP 2F. Check the vehicle speed sensor for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2G. Check the vehicle speed sensor for a short circuit between coils. | Greater than 100k ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 241 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and move the vehicle so that the ECM can read a vehicle speed.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 241 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Determine if the vehicle speed sensor is a VECU multiplexed component that is enabled for multiplexing over the SAE J1939 data link to the engine ECM.

Conditions

  • Determine proper OEM VECU multiplexing configuration.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Determine if the vehicle speed sensor is a multiplex component over the SAE J1939 data link to the engine ECM.

Is the vehicle speed sensor a multiplex component?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 285 and/or 286 active?
YES NO
No Repair

A damaged OEM vehicle speed sensor or damaged OEM wiring harness has been found.

Replace the sensor. Refer to the OEM service manual.

Repair or replace the harness. Refer to the OEM service manual.

Troubleshoot Fault Codes 285 and/or 286.

Go to 4B

Guided Step 2 - Check the vehicle speed sensor.

Guided Step 2A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or the OEM harness.

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to the OEM service manual.
  • Replace the sensor. Refer to Procedure 019-090 in Section 19.
  • Replace the sensor. Refer to Procedure 019-091 in Section 19.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and move the vehicle so that the ECM can read a vehicle speed.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 241 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Verify correct sensor type is selected in INSITE™ electronic service tool.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to check vehicle speed sensor type selected in Features and Parameters matches actual vehicle speed sensor type.

Correct sensor type selected?
YES NO
No Repair

Use INSITE™ electronic service tool to select the correct sensor type.

Go to 2D

Go to 4B

Guided Step 2D - Check the vehicle speed sensor for proper adjustment.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor for proper adjustment, and verify that the correct number of tailshaft teeth is entered in INSITE™ electronic service tool.

1/2 to 3/4 of a turn out from the gear?
YES NO
No Repair

Adjust the sensor. Refer to Procedure 019-091 in Section 19.

Go to 2E

Go to 4B

Guided Step 2E - Check for proper operation of the OEM vehicle speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Refer to the OEM service manual for vehicle speed sensor type and troubleshooting directions.

Action

Check for proper operation of the vehicle speed sensor.

  • Refer to the OEM service manual for sensor locations, and sensor type.
  • Refer to the OEM service manual for troubleshooting information.

Vehicle speed sensor operating properly?
YES NO
No Repair

  • Replace the sensor. Refer to Procedure 019-090 in Section 19.
  • Replace the sensor. Refer to Procedure 019-091 in Section 19.

Go to 2F

Go to 4B

Guided Step 2F - Check the vehicle speed sensor for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.
  • Make sure the sensor is installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the vehicle speed sensor SUPPLY pin in the vehicle speed sensor connector, sensor side, to ground.
  • Repeat the short circuit to ground check in the second coil, if applicable.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the sensor. Refer to Procedure 019-090 in Section 19.
  • Replace the sensor. Refer to Procedure 019-091 in Section 19.

Go to 2G

Go to 4B

Guided Step 2G - Check the vehicle speed sensor for a short circuit between coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance from the vehicle speed sensor SUPPLY pin in the vehicle speed sensor connector to the vehicle speed sensor SUPPLY pin in the second vehicle speed sensor connector, sensor side.

NOTE: If the sensor only has 1 coil answer YES to this question.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the sensor. Refer to Procedure 019-090 in Section 19.
  • Replace the sensor. Refer to Procedure 019-091 in Section 19.

Go to 3A

Go to 4B

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect OEM harness ECM connector 2.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and move the vehicle so the ECM can read the vehicle speed.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 241 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.
  • Disconnect OEM harness ECM connector 2.

Action

Check for an open circuit.

  • Measure the resistance from the vehicle speed sensor SUPPLY pin in the ECM connector 2 to the vehicle speed sensor SUPPLY pin in the sensor harness connector.
  • Measure the resistance from the vehicle speed sensor RETURN pin in the ECM connector 2 to the vehicle speed sensor RETURN pin in the sensor harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3D

Go to 4B

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect OEM harness ECM connector 2.

Action

Check for a short circuit to ground.

  • Measure the resistance from the vehicle speed sensor SUPPLY pin in the ECM connector 2 to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been found.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

3E

Go to 4B

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the vehicle speed sensor SUPPLY pin in the ECM connector 2 to all other pins in the ECM connector 2.
  • Measure the resistance from the vehicle speed sensor RETURN pin in the ECM connector 2 to all other pins in the ECM connector 2.
  • Measure the resistance from the vehicle speed sensor SUPPLY pin in the ECM connector 2 to all pins in ECM connector 1.
  • Measure the resistance from the vehicle speed sensor RETURN pin in the ECM connector 2 to all pins in ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been found. Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 242 - Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the feature settings are correct. |
 | STEP 1A. Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match. | Setting in INSITE™ electronic service tool match the speed sensor type on the vehicle?
 | STEP 1B. Verify that the Anti-Tampering Sensitivity Level is set correctly for the application. | Sensitivity level is set correctly?
 | STEP 1C. Determine if the vehicle speed sensor is a VECU multiplexed component that is enabled for multiplexing over the SAE J1939 data link to the engine ECM. | Is the vehicle speed sensor a multiplexed component?
 | STEP 1D. Check for active fault codes. | Is Fault Code 285 or 286 active?
STEP 2. | Look for signs or evidence of tampering. |
 | STEP 2A. Inspect the vehicle speed sensor. | Tampering, incorrect installation, or external device present?
 | STEP 2B. Check for open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2C. Check for short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check the vehicle speed reporting. |
 | STEP 3A. Use INSITE™ electronic service tool to monitor the vehicle speed signal. | INSITE™ electronic service tool readout and the vehicle speedometer match?
 | STEP 3B. Verify the vehicle speed. | Vehicle speed is accurate?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Verify the feature settings are correct.

Guided Step 1A - Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.

  • Verify that the Vehicle Speed Sensor Type parameter setting in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

Setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 1B

Go to 4A

Guided Step 1B - Verify that the Anti-Tampering Sensitivity Level is set correctly for the application.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify that the Vehicle Speed Signal Tampering Sensitivity Level is set correctly for the application.

  • Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.
  • Check the ECM setting for Vehicle Speed Signal Tampering Sensitivity Level.

Sensitivity Level is set correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to set the Vehicle Speed Signal Tampering Sensitivity Level to the correct value for the vehicle.

Go to 1C

Go to 4A

Guided Step 1C - Determine if the vehicle speed sensor is a VECU multiplexed component that is enabled for multiplexing over the SAE J1939 data link to the engine ECM.

Conditions

  • Determine proper OEM VECU multiplexing configuration.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Determine if the vehicle speed sensor is a multiplex component over the SAE J1939 data link to the engine ECM.

Is the vehicle speed sensor a multiplexed component?
YES | NO
No Repair | No Repair

Go to 1D

Go to 2A

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to check for active Fault Codes 285 and 286.

Fault Code 285 or 286 active?
YES NO
No Repair

A damaged OEM vehicle speed sensor or damaged OEM wiring harness has been detected.

Check for an improperly mounted sensor, externally mounted device, or any evidence of tampering to the OEM harness or vehicle speed sensor.

Replace the sensor. Refer to the OEM service manual.

Repair or replace the harness. Refer to the OEM service manual.

Troubleshoot Fault Codes 285 and/or 286.

Go to 4A

Guided Step 2 - Look for signs or evidence of tampering.

Guided Step 2A - Inspect the vehicle speed sensor.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the vehicle speed sensor for the following:

  • Improper mounting of the vehicle speed sensor
  • Vehicle speed sensor improperly connected to the OEM harness
  • Other external device connected in place of the vehicle speed sensor
  • Any evidence that tampering with the vehicle speed sensor has taken place.

Tampering, incorrect installation, or external device present?
YES NO

Remove the tampering device.

Install the sensor correctly or remove the external device.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance of the vehicle speed sensor SUPPLY wire between the ECM connector 2 and the OEM harness vehicle speed sensor connector.
  • Measure the resistance of the vehicle speed sensor RETURN wire between the ECM connector 2 and the OEM harness vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the vehicle speed sensor SUPPLY and vehicle speed sensor RETURN circuit in the OEM harness.

  • Measure the resistance of the vehicle speed sensor SUPPLY pin at the ECM connector 2 to ground.
  • Measure the resistance of the vehicle speed sensor RETURN pin at the ECM connector 2 to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance between the vehicle speed sensor SUPPLY pin at the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the vehicle speed sensor SUPPLY pin at the ECM connector 2 and all pins in the ECM connector 1.
  • Measure the resistance between the vehicle speed sensor RETURN pin at the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the vehicle speed sensor RETURN pin at the ECM connector 2 and all pins in the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the vehicle speed reporting.

Guided Step 3A - Use INSITE™ electronic service tool to monitor the vehicle speed signal.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the vehicle speed.

  • Verify that the vehicle speed is zero when the vehicle is stationary and the engine is running.
  • Drive the vehicle or run on a chassis dynamometer. Use INSITE™ electronic service tool to compare the vehicle speed reading to the speedometer reading on the dash.

INSITE™ electronic service tool readout and the vehicle speedometer match?
YES NO
No Repair

Verify that the tire size, rear axle ratio, and tailshaft gear teeth parameters are set correctly in the ECM.

Go to 3B

Go to 4A

Guided Step 3B - Verify the vehicle speed.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate vehicle.

Action

Use INSITE™ electronic service tool to verify that the speed reported is accurate or reasonable for the present gear.

  • (For example: 64 km/h [40 mph] in top gear is probably inaccurate data.)

Vehicle speed is accurate?
YES NO
No Repair

Verify that the tire size, rear axle ratio, and tailshaft gear teeth parameters are set correctly in the ECM.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Cannon™/Deutsch™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsh™ lead, and Part Number 3823994 - female Deutsh™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Check the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control solenoid. | Within the OEM resistance specification?
 | STEP 2C. Check for a pin-to-ground short circuit in the fan control solenoid. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit in the fan control solenoid | Less than 10 ohms?
 | STEP 2E. Check for an active fault code. | Fault Code 245 active?
STEP 3. | Check the ECM and OEM harnesses. |
 | STEP 3A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Check the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and the solenoid pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the OEM harness or solenoid. Repair or replace the OEM harness, or replace the solenoid, whichever has the damaged pins.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the fan control solenoid connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to the OEM service manual for resistance specifications.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

A damaged solenoid has been detected.

Replace the fan control solenoid. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on the OEM connector.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A damaged fan control solenoid has been detected.

Replace the fan control solenoid. Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness

Action

Check fan control solenoid resistance.

  • Measure the resistance between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the fan control solenoid has been detected.

Replace the fan control solenoid. Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 2 fan clutch output SIGNAL pin and the OEM harness fan control solenoid connector fan clutch output SIGNAL pin.
  • Measure the resistance between the ECM connector 2 fan clutch output RETURN pin and the OEM harness fan control solenoid connector fan clutch output RETURN pin.

NOTE: Certain OEMs can use a solenoid return that is wired to the ECM, or use a return that goes to engine block or chassis ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fan control solenoid circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine and OEM harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the fan control solenoid for the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ECM connector 2 fan clutch output SIGNAL pin and all other pins in the ECM connector 2.
  • Measure the resistance between the ECM connector 2 fan clutch output SIGNAL pin and all pins in the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 2.
  • Disconnect the fan control solenoid for the OEM harness.

Action

Check for pin-to-ground short.

  • Measure the resistance between the ECM connector 2 fan clutch output SIGNAL pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 254 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Fuel Shutoff Valve Solenoid | Refer to Procedure 019-050 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 254 active?
STEP 2. | Check the engine fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the engine fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine fuel shutoff valve. | Resistance between 12 to 20 ohms?
 | STEP 2C. Check for a short to ground in the engine fuel shutoff valve. | Greater than 100k ohms?
 | STEP 2D. Check the engine fuel shutoff valve supply voltage. | Greater than 10-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel shutoff valve and circuit.

Guided Step 2A - Inspect the engine fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine fuel shutoff valve or harness connector.

Repair or replace the engine harness, or replace the engine fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check for an open circuit in the engine fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check engine fuel shutoff valve resistance.

  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin and the engine fuel shutoff valve RETURN pin at the engine fuel shutoff valve.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 12 to 20 ohms?
YES NO
No Repair

A damaged engine fuel shutoff valve has been detected.

  • Replace the engine fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check for a short to ground in the engine fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for an engine fuel shutoff valve short to ground.

  • Measure the resistance between the engine fuel shutoff valve SUPPLY pin and ground at the engine fuel shutoff valve connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A damaged engine fuel shutoff valve has been detected.

  • Replace the engine fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 2D

Go to 4B

Guided Step 2D - Check the engine fuel shutoff valve supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel shutoff valve from the engine harness
  • Turn keyswitch ON.

Action

Check the engine fuel shutoff valve supply voltage and return circuit.

  • Measure the voltage between the engine fuel shutoff valve SUPPLY pin and the engine fuel shutoff valve RETURN pin at the engine fuel shutoff valve connector of the engine harness.

Greater than 10-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin in ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1 and 2.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 255 - Fuel Shutoff Valve Driver Circuit - Voltage High or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Fuel Shutoff Valve Solenoid | Refer to Procedure 019-050 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 255 active?
STEP 2. | Check the engine fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the engine fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine fuel shutoff valve. | Resistance between 12 to 20 ohms?
 | STEP 2C. Check the engine fuel shutoff valve supply voltage. | Greater than 12-VDC?
 | STEP 2D. Check for an open circuit in the engine fuel shutoff valve return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 active?
YES | NO
No Repair | No Repair

2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel shutoff valve and circuit.

Guided Step 2A - Inspect the engine fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and engine fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the valve or harness connector.

Repair or replace the engine harness, or replace the valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check for an open circuit in the engine fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check engine fuel shutoff valve resistance.

  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin and the engine fuel shutoff valve RETURN pin at the engine fuel shutoff valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 12 to 20 ohms?
YES NO
No Repair

A damaged engine fuel shutoff valve has been detected. Replace the engine fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check the engine fuel shutoff valve supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel shutoff valve from the engine harness.
  • Turn keyswitch ON.
  • Engage starter and crank the engine.

Action

Check the engine fuel shutoff valve supply voltage and return circuit.

  • Measure the voltage between the engine fuel shutoff valve SIGNAL pin and the engine fuel shutoff valve RETURN pin at the engine fuel shutoff valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 12-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the engine fuel shutoff valve return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel shutoff valve from the engine harness.
  • Disconnect the engine harness ECM connector 1.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 engine fuel shutoff valve RETURN pin and the engine harness engine fuel shutoff valve connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin-to-ground open circuit on the return line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 engine fuel shutoff valve SIGNAL pin and the engine harness engine fuel shutoff valve connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the engine fuel shutoff valve from engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin in engine harness ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin in engine harness ECM connector 1 and all other pins in ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 263 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Fuel Pressure/Temperature Sensor | Refer to Procedure 019-153 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female WeatherPack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 263 active?
STEP 2. | Check the engine fuel regulator outlet pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel regulator outlet pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Sensor resistance between 600 ohms and 420k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 263 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel regulator outlet pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel regulator outlet pressure/temperature sensor and connector pins

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and engine fuel regulator outlet pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-153 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine fuel regulator outlet temperature SIGNAL pin and the engine fuel regulator outlet temperature RETURN pin at the engine fuel regulator outlet pressure/temperature sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Sensor resistance between 600 ohms and 420k ohms?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-153 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel regulator outlet pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 engine fuel regulator outlet temperature RETURN pin and the engine harness engine fuel regulator outlet temperature RETURN pin in the engine harness engine fuel regulator outlet pressure/temperature sensor connector.
  • Measure the resistance between the ECM connector 1 engine fuel regulator outlet temperature SIGNAL pin and the engine harness engine fuel regulator outlet temperature SIGNAL pin in the engine harness engine fuel regulator outlet pressure/temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine fuel regulator outlet temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel regulator outlet temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine fuel regulator outlet temperature RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine fuel regulator outlet temperature RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 265 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Fuel Pressure/Temperature Sensor | Refer to Procedure 019-153 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 265 active?
STEP 2. | Check the engine fuel regulator outlet pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel regulator outlet pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Sensor resistance between 600 ohms and 420k ohms?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 265 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel regulator outlet pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel regulator outlet pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and engine fuel regulator outlet pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector. Repair or replace the harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Tables.
  • Replace the sensor. Refer to Procedure 019-153 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine fuel regulator outlet temperature SIGNAL pin and the engine fuel regulator outlet temperature RETURN pin at the engine fuel regulator outlet pressure/temperature sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Sensor resistance between 600 ohms and 420k ohms?
YES NO
No Repair

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-153 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel regulator outlet pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair or replace the harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-ground short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine fuel regulator outlet temperature SIGNAL pin in the ECM connector 1 and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine fuel regulator outlet temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel regulator outlet temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine fuel regulator outlet temperature RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine fuel regulator outlet temperature RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2012


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Resistance between 50 and 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Resistance between 50 and 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Disable the fault code. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify communication with the ECM.

  • Use INSITE™ electronic service tool to verify communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

NOTE: Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6B

Go to 6B

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-205 in Section 19.

 No Repair

Go to 6B

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit on the J1939 backbone.

  • Measure the resistance between the SAE J1939 Data link (+) wire and the SAE J1939 Data link (-) wire on the OEM service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6B

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 2 or OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 6B

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Disconnect the OEM harness ECM connector 2.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 Data link (+) wire and the SAE J1939 Data link (-) wire at the ECM connector 2.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 5C

Go to 6B

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 Data link (+) wire and the SAE J1939 Data link (-) wire on ECM connector 2 and all other pins in the ECM connector 2.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 Data link (+) and the SAE J1939 Data link (-) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

  • Replace the OEM harness. Refer to the OEM service manual.

Go to 5D

Go to 6B

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, a damaged ECM, or a calibration issue is causing the fault code.

Go to 6A

Go to the appropriate ECM No Communication symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Aug-2012


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check ECM communication with INSITE™ electronic service tool. | Communication established between INSITE™ electronic service tool and the ECM?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 286 active?
STEP 3. | Check the original equipment manufacturer (OEM) VECU and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Resistance between 50 ohms and 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Resistance between 50 ohms and 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 286 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for communication.

Verify INSITE™ electronic service tool communication with the ECM.

Communication established between INSITE™ electronic service tool and the ECM?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

NOTE: Reference the Multiplexing Troubleshooting, 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6B

Go to 6B

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable or connector.

Clean the connector and pins.

Repair the harness, connector, or pins, if possible.

Repair the harness. Refer to Procedure 019-205 in Section 19.

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6B

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit on the J1939 backbone.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the OEM service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the data link harness.

Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6B

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 2 or the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Repair the connectors. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 6B

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector 2.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 5C

Go to 6B

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® OEM harness ECM connector 2 and all other pins in the ECM connector 2.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 5D

Go to 6B

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Reference the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Sep-2012


FAULT CODE 287 - SAE J1939 Multiplexed Accerator Pedal or Lever Sensor System - Received Network Data In Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Accelerator Pedal or Lever Position Sensor Circuit | Refer to Procedure 019-086 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 287 active?
STEP 2. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 datalink to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the accelerator parameters are being received properly by the engine ECM. | Idle Validation parameter displays released and Percent accelerator pedal or position parameter displays a value of zero?
 | STEP 3B. Determine if the accelerator parameters are being received properly by the engine ECM. | Idle Validation parameter displays depressed and Percent accelerator pedal or position parameter displays a value greater than zero?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 287 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4B

Guided Step 3 - Monitor the accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent accelerator pedal or position
  • Idle Validation.

NOTE: Monitor parameters may not appear in the electronic service tool exactly as listed above.

When the throttle is released, the Throttle Status/Idle Validation parameter must display “released” and Percent Throttle parameter must display a value of zero.

Idle Validation parameter displays depressed and Percent accelerator pedal or position parameter displays a value of zero?
YES NO
No Repair

An OEM issue with the accelerator, idle validation switch, or OEM VECU has been detected.

  • Refer to the OEM service manual.
  • Refer to Procedure 019-085 in Section 19.
  • Refer to Procedure 019-086 in the Associated Procedures Table.

Go to 3B

Go to 4B

Guided Step 3B - Determine if the accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent accelerator pedal or position
  • Idle Validation.

NOTE: Monitor parameters may not appear in the electronic service tool exactly as listed above.

When the throttle is depressed, the Throttle Status/Idle Validation parameter must display “depressed” and Percent Throttle parameter must display a value greater than zero.

Idle Validation parameter displays released and Percent accelerator pedal or position parameter displays a value greater than zero?

YES NO
No Repair

There is an OEM issue with the idle validation switch, the accelerator, or with the OEM VECU.

  • Refer to the OEM service manual.
  • Refer to Procedure 019-085 in Section 19.
  • Refer to Procedure 019-086 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Sep-2012


FAULT CODE 288 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 285 and 286 active?
 | STEP 1B. Check for an active fault code. | Fault Code 288 active?
STEP 2. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 datalink to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the remote accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the remote throttle switch and/or remote accelerator parameters are being received properly by the engine ECM. | Remote accelerator pedal lever or switch parameter displays ON and percent remote accelerator or position parameter displays a value greater than zero?
 | STEP 3B. Determine if the remote throttle switch and/or remote throttle parameters are being received properly by the engine ECM. | Remote accelerator pedal lever or switch parameter displays ON and percent remote accelerator or position parameter displays a value greater than zero?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes 285 and 286.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 285 and 286 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Codes 285 and 286.

1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 288 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and ensure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4B

Guided Step 3 - Monitor the remote accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the remote throttle switch is ON and the remote accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent remote accelerator or position.
  • Remote accelerator pedal lever or switch.

NOTE: Monitor parameters may not appear in the electronic service tool exactly as listed above.

When the remote throttle is released, the Remote Throttle Switch parameter must display ON and the Percent Throttle parameter must display a value of 0.

Remote accelerator pedal lever or switch parameter displays ON and percent remote accelerator or position parameter displays a value greater than zero?

YES NO
No Repair

An OEM issue with the remote throttle switch, the remote throttle, or with the OEM VECU has been detected.

Refer to the OEM service manual.

Go to 3B

Go to 4B

Guided Step 3B - Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the remote throttle switch is ON and the remote accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent remote accelerator or position.
  • Remote accelerator pedal lever or switch.

NOTE: Monitor parameters can possibly not appear in the electronic service tool exactly as shown above.

When the remote throttle is depressed, the Remote Throttle Switch parameter must display ON and the Percent Throttle parameter must display a value greater than 0.

Remote accelerator pedal lever or switch parameter displays ON and percent remote accelerator or position parameter displays a value greater than zero?

YES NO
No Repair

An OEM issue with the remote throttle switch, or the remote throttle, or with the OEM VECU has been detected.

Refer to the OEM service manual.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Sep-2012


FAULT CODE 295 - Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 295 active?
STEP 2. | Check the sensor pressure reading. |
 | STEP 2A. Check the pressure reading of the engine throttle intake pressure sensor. | Pressure approximately 96.53 kPa [14 psi] or 723.90 mm Hg [28.5 in Hg] (atmospheric pressure)?
STEP 3. | Check the ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 295 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the sensor pressure reading.

Guided Step 2A - Check the pressure reading of the engine throttle intake pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Do not start the engine.

Action

Check the pressure reading of the engine throttle intake pressure sensor.

  • Turn the keyswitch ON, but do not start the engine.
  • Use INSITE™ electronic service tool to check the engine throttle intake pressure sensor.
  • Compare the INSITE™ electronic service tool reading for Barometric Air Pressure to the local barometric pressure.
  • Use the following procedure for local barometric pressure readings. Refer to Procedure 018-028 in Section V.

Pressure approximately 96.53 kPa [14 psi] or 723.90 mm-Hg [28.5 in-Hg] (atmospheric pressure)?
YES NO
No Repair

Refer to Fault Codes 2517 and 2518 to troubleshoot the engine throttle intake pressure sensor and circuit.

Go to 3A

Troubleshoot the appropriate fault code(s).

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Sep-2012


FAULT CODE 319 - Real Time Clock - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM connections. |
 | STEP 1A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
STEP 2. | Check the original equipment manufacturer (OEM) connector. |
 | STEP 2A. Check the OEM connectors and harness. | Dirty or damaged pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the OEM connector pins.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM connectors.

Action

Inspect the engine harness and OEM harness connector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Sep-2012


FAULT CODE 338 - Idle Shutdown Vehicle Accessories Relay Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and electronic settings. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 338 inactive?
 | STEP 1B. Check the ECM setup for idle shutdown accessory relay. | INSITE™ electronic service tool Idle Shutdown feature set up correctly?
STEP 2. | Check the idle shutdown relay and circuit. |
 | STEP 2A. Inspect the shutdown relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the idle shutdown relay for an open circuit. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit in the idle shutdown relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 338 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and electronic setting.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 338 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check the ECM setup for idle shutdown accessory relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the Idle Shutdown feature.

  • If the vehicle has an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “installed”.
  • If the vehicle does not have an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Not Installed”.

INSITE™ electronic service tool Idle Shutdown feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the Idle Shutdown feature setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the idle shutdown relay and circuit.

Guided Step 2A - Inspect the idle shutdown relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Inspect the OEM harness and idle shutdown relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the idle shutdown relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check the idle shutdown relay resistance.

  • Measure the resistance between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin in the idle shutdown relay.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the idle shutdown relay.

Refer to the OEM service manual.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit in the idle shutdown relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness ECM connector 2.

Action

Check for an open circuit.

  • Measure the resistance to the idle shutdown relay RETURN pin at the idle shutdown relay connector to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

  • If the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

  • Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 2 idle shutdown relay RETURN pin and the OEM harness idle shutdown relay connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Sep-2012


FAULT CODE 339 - Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and electronic settings. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 339 inactive?
 | STEP 1B. Check the ECM setup for idle shutdown accessory relay. | INSITE™ electronic service tool Idle Shutdown feature set up correctly?
STEP 2. | Check the idle shutdown relay and circuit. |
 | STEP 2A. Inspect the idle shutdown relay and circuit, and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the idle shutdown relay for an open circuit. | Greater than 6k ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the idle shutdown relay. |
 | STEP 2C. Check the idle shutdown relay supply voltage. | Greater than 3.75-VDC?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and electronic setting.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 339 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check the ECM setup for idle shutdown accessory relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the Idle Shutdown feature.

  • If the vehicle has an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “installed”.
  • If the vehicle does not have an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Not Installed”.

INSITE™ electronic service tool Idle Shutdown feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the Idle Shutdown feature setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the idle shutdown relay and circuit.

Guided Step 2A - Inspect the idle shutdown relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Inspect the OEM harness and idle shutdown relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the idle shutdown relay for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check the idle shutdown relay resistance.

  • Measure the resistance between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin in the relay.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6k ohms?
YES NO
No Repair

Replace the idle shutdown relay.

Refer to the OEM service manual.

Go to 2B-1

Go to 4B

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the idle shutdown relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Check for a short to ground.

  • Measure the resistance and check for a short circuit between the idle shutdown relay SIGNAL pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the OEM harness.

Refer to the OEM service manual.

Go to 2C

Go to 4B

Guided Step 2C - Check the idle shutdown relay signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the idle shutdown relay diagnostic supply.

  • Measure the voltage between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin at the starter idle shutdown relay connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector pins.

  • Repair the damaged harness, connector or pins, if possible.
  • Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness ECM connector 2.

Action

Check for a short circuit to ground in the OEM harness

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM harness ECM connector 2 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness.
  • Refer to the OEM service manual

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the ECM connector 2 and all other pins in connector 2.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the ECM connector 2 and all other pins in connector 1.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness.
  • Refer to the OEM service manual

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Sep-2012


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 343 active or more than three inactive counts?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least + 12-VDC [+ 24-VDC with 24 volt system]; During cranking: At least +6.2-VDC?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least +10-VDC [+20-VDC] for a 24 volt system?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire interrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Check the power harness |
 | STEP 4A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
STEP 5. | Calibrate the ECM. |
 | STEP 5A. Calibrate the ECM. | Fault Code 343 active after calibrating the ECM?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 6A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Clean the terminals.

Tighten the connections.

Refer to the OEM service manual.

Go to 2B

Go to 6A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least + 12-VDC [+ 24-VDC with 24 volt system]; During cranking: At least +6.2-VDC?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 3A

Go to 6A

Guided Step 3 - Check the ECM power harness and connector.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM connector.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery supply (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

At least +10-VDC [+20-VDC] for a 24 volt system?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuse installation.

  • Inspect the OEM fuse for correct installation.

Is fuse installed correctly?
YES NO
No Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 6A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuse.

  • Verify that the OEM fuse is not blown.

Is fuse blown?
YES NO

Locate the short circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

 No Repair

Go to 6A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Refer to the OEM service manual.

Go to 6A

Go to 6A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to 0.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

NOTE: Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Less than 1.0 ohms?
YES NO
No Repair

  • Repair or replace the ECM power harness.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input.

  • Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire interrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 6A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to the keyswitch input SIGNAL pin of the OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

  • Repair or replace the OEM harness.
  • Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the power harness.

Guided Step 4A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power supply to the ECM.
  • Disconnect the power supply connector from the OEM power supply connector.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5 - Calibrate the ECM.

Guided Step 5A - Calibrate the ECM

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Calibrate the ECM.

  • Use INSITE™ electronic service tool to calibrate the ECM with the latest engine calibrations.

Fault Code 343 active after calibrating the ECM?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 3B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2012


FAULT CODE 352 - Sensor Supply 1 Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Throttle Actuator | Refer to Procedure 019-097 | ISB5.9 G CM2180 | 2883369
Mixer Inlet Pressure Sensor | Refer to Procedure 019-098 | ISB5.9 G CM2180 | 2883369
Humidity Sensor | Refer to Procedure 019-356 | ISB5.9 G CM2180 | 2883369
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the engine turbocharger compressor outlet humidity/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the engine throttle intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine camshaft speed position sensor 2 and connector pins. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin-to-ground short circuit. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the engine throttle intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.

Action

Inspect the engine throttle intake pressure sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine throttle intake pressure sensor. Refer to Procedure 019-098 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the engine throttle intake pressure sensor. Refer to Procedure 019-098 in the Associated Procedures Table.

Go to 2B

Go to 4B

Guided Step 2B - Inspect the engine turbocharger compressor outlet humidity/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger compressor outlet humidity/temperature sensor from the engine harness.

Action

Inspect the engine turbocharger compressor outlet humidity/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine turbocharger compressor outlet humidity/temperature sensor. Refer to Procedure 019-356 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger compressor outlet humidity/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the engine turbocharger compressor outlet humidity/temperature sensor. Refer to Procedure 019-356 in the Associate Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine throttle actuator and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine throttle actuator. Refer to Procedure 019-097 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged actuator has been detected.

  • Replace the engine throttle actuator. Refer to Procedure 019-097 in the Associated Procedures Table.

Go to 2D

Go to 4B

Guided Step 2D - Inspect the engine camshaft speed position sensor 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed position sensor 2 from the engine harness.

Action

Inspect the engine harness and engine camshaft speed position sensor 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine camshaft speed position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed position sensor 2 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the engine camshaft speed position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect all components connected to sensor supply 1.

Action

Check for a pin-to-pin short.

  • Measure the resistance from the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 to all other pins in the ECM connector 1.
  • Measure the resistance from the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 to all pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4B

Guided Step 3B-1 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect all components connected to sensor supply 1.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor supply number 1 pin in the engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply 1 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2012


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply 2 supply voltage. | Voltage greater than 5.63-VDC?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the sensor supply 2 supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage at the ECM.

  • Measure the voltage between the sensor supply 1 pin in the engine harness ECM connector 1 and the sensor return 1 pin in the engine harness ECM connector 1.

Voltage greater than 5.63-VDC?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1 and 2.
  • Disconnect the engine fuel regulator outlet temperature pressure sensor, engine turbocharger compressor intake humidity/pressure sensor, engine throttle actuator, engine camshaft speed position sensor, engine fuel regulator intake pressure sensor.
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 1 pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the sensor SUPPLY 1 pin in thes ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 1.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply 1 line has been detected in the engine harness.

Repair or replace the engine harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2012


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Lubricating Oil System | Refer to Procedure 018-017 | ISB5.9 G CM2180 | 2883369
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Lubricating oil level is above or below specification. | Lubricating oil level above or below specification?
 | STEP 1B. Check the sensor accuracy. | Sensor reading correct?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Lubricating oil level is above or below specification.

Conditions

  • Turn keyswitch OFF.

Action

Check oil level.

Lubricating oil level above or below specification?
YES NO

Drain or fill oil to bring oil level within specification.

  • Refer to Procedure 018-017 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start and idle the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. If the display is absolute pressure then add atmospheric pressure to gauge reading.

NOTE: If internal engine noise is present and internal engine damage is suspected do not operate the engine. Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS in Service Manual, ISB5.9 G CM2180, Bulletin 2883369.

Sensor reading correct?
YES NO
No Repair

Replace the sensor if INSITE™ electronic service tool reading differs from mechanical gauge reading.

Refer to Procedure 019-066 in the Associated Procedures Table.

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS in Service Manual, ISB5.9 G CM2180, Bulletin 2883369

Go to 2B

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Nov-2012


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 2. | Check for a damaged voltage source. |
 | STEP 2A. Determine if vehicle has a voltage regulator. | Voltage regulator installed?
 | STEP 2B. Determine battery voltage. | Battery voltage between 11.5 and 15.0-VDC?
 | STEP 2C. Determine the voltage on the + 12-VDC side of the OEM voltage regulator. | Voltage between 11.5 and 15.0-VDC?
STEP 3. | Check the OEM and engine harnesses. |
 | STEP 3A. Inspect the OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the voltage at the 4-pin OEM connector. | Voltage between 11.5 and 15.0-VDC?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for voltage at the engine harness ECM 4 pin power connector. | Voltage between 11.5 and 15.0-VDC?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

2A

Guided Step 2 - Check for a damaged voltage source.

Guided Step 2A - Determine if vehicle has a voltage regulator.

Conditions

  • Turn keyswitch OFF.

Action

Check for the presence of a voltage regulator.

  • Inspect the vehicle for a voltage regulator or refer to the OEM service manual to determine if the vehicle has a voltage regulator installed.

NOTE: If the vehicle has a + 24-VDC or + 36-VDC system, then it must have a voltage regulator to supply + 12-VDC power to the unswitched battery pins in the ECM.

Voltage regulator installed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Battery voltage between 11.5 and 15.0-VDC?
YES NO
No Repair

A discharged or damaged battery has been detected.

Charge or replace the damaged battery or batteries. Refer to the OEM service manual.

Go to 3A

Go to 5B

Guided Step 2C - Determine the voltage on the + 12-VDC side of the OEM voltage regulator.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage on the + 12-VDC side of the voltage regulator across the positive (+) and negative (-) terminals.

  • Use a multimeter to read the voltage across the voltage regulator.

Voltage between 11.5 and 15.0-VDC?
YES NO
No Repair

A discharged or damaged battery has been detected.

Charge or replace the damaged battery or batteries. Refer to the OEM service manual.

Go to 3A

Go to 5B

Guided Step 3 - Check the OEM and engine harnesses.

Guided Step 3A - Inspect the OEM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 4-pin OEM power connector from the engine harness.
  • Disconnect the engine harness 4-pin power connector from the ECM.

Action

Inspect the OEM and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the 4-pin OEM connector or ECM.

Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 5B

Go to 3B

Guided Step 3B - Check the voltage at the 4-pin OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 4-pin power connector from the engine harness.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the 4-pin OEM connector unswitched battery SUPPLY pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5 and 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 3E

Go to 3C

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness at the 4-pin power connector from the engine harness.
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the 2 unswitched SUPPLY battery pins of the 4-pin OEM connector and the positive (+) battery terminal.

NOTE: Check for blown or corroded fuses that are in series with the unswitched battery supplies.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 4-pin power connector from the engine harness.
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the 2 unswitched battery SUPPLY pins in the 4-pin OEM connector and all other pins in the 4-pin OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to the OEM service manual.

Go to 4A

Go to 4B

Guided Step 3E - Check the voltage at the engine harness ECM 4-pin power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the ECM 4-pin power connector unswitched battery SUPPLY pins and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5 and 15.0-VDC?
YES NO
No Repair

Repair or replace the engine harness 4-pin power harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Nov-2012


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Alternator | Refer to Procedure 013-001 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To avoid personal injury, always ventilate the compartment before servicing the batteries. To avoid arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number - 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 2. | Check for a defective voltage source. |
 | STEP 2A. Determine if vehicle has a voltage regulator. | Voltage regulator installed?
 | STEP 2B. Determine battery voltage. | Battery voltage between 11.5 and 15.0-VDC?
 | STEP 2C. Determine voltage on the 12-VDC side of the OEM voltage regulator. | Voltage between 11.5 and 15.0-VDC?
STEP 3. | Check the charging system. |
 | STEP 3A. Inspect the alternator for correct charging voltage. | Charging system performing properly and voltage between 11.5 and 15.0-VDC?
STEP 4. | Check the OEM harness. |
 | STEP 4A. Inspect the OEM harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the voltage at the 4-pin OEM connector. | Voltage between 11.5 and 15.0-VDC?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for a defective voltage regulator.

Guided Step 2A - Determine if vehicle has a voltage regulator.

Conditions

  • Turn keyswitch OFF.

Action

Check for the presence of a voltage regulator.

  • Inspect the vehicle for a voltage regulator or refer to the OEM troubleshooting and repair manual to determine if the vehicle has a voltage regulator installed.

NOTE: If the vehicle has a 24-VDC or 36-VDC system, it must have a voltage regulator to supply 12-VDC power to the unswitched battery pins in the ECM.

Voltage regulator installed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Battery voltage between 11.5 and 15.0-VDC?
YES NO
No Repair

A damaged or incorrect battery connection has been detected.

Repair or replace the connection. Refer to the OEM service manual.

Go to 3A

Go to 5B

Guided Step 2C - Determine the voltage on the 12-VDC side of the OEM voltage regulator.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage of the 12-VDC side of the voltage regulator across the positive (+) and negative (-) terminals.

  • Use a multimeter to read the voltage across the voltage regulator.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 11.5 and 15.0-VDC?
YES NO
No Repair

A damaged battery circuit or voltage regulator has been detected.

Refer to the OEM service manual.

Go to 3A

Go to 5B

Guided Step 3 - Check the charging system.

Guided Step 3A - Check the alternator for correct charging voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle charging system.

  • Refer to Procedure 013-001 in the Associated Procedures Table.

Charging system performing properly and voltage between 11.5 and 15.0-VDC?
YES NO
No Repair

A damaged charging system has been detected.

Repair the charging system. Refer to Procedure 013-001 in the Associated Procedures Table.

Go to 4A

Go to 5B

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 4-pin power connector.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the 4-pin power connector.

Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to the OEM service manual.

 No Repair

Go to 5B

Go to 4B

Guided Step 4B - Check the voltage at the 4-pin OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 4-pin power connector.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the 4-pin OEM connector unswitched battery SUPPLY pins and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 11.5 and 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Nov-2012


FAULT CODE 453 - Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Gas Mass Flow Sensor | Refer to Procedure 019-101 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2722, 2988, 455, 511 active?
 | STEP 1B. Read the fault codes. | Fault Code 453 active?
STEP 2. | Check the gas mass flow sensor. |
 | STEP 2A. Inspect the engine harness and gas mass flow sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for circuit response. | Fault Code 454 active and Fault Code 453 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Voltage to specifications?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2722, 2988, 455, 511 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Codes 2722, 2988, 455, 511.

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 453 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensor.

Guided Step 2A - Inspect the engine harness and gas mass flow sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Inspect the engine harness and gas mass flow sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-101 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 454 active and Fault Code 453 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine harness
  • Turn keyswitch ON.

Action

Check the SUPPLY voltage and RETURN circuit.

Voltage output greater than 15-VDC?
YES NO

Replace the gas mass flow sensor.

Refer to Procedure 019-101 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19.
  • Repair the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector RETURN pin and the gas mass flow sensor connector RETURN pins.
  • Measure the resistance between the ECM connector SUPPLY pin and the gas mass flow sensor connector SUPPLY pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the gas mass flow sensor SIGNAL pin in engine harness connector 1and all other pins in the engine harness connector 1.
  • Measure the resistance between the gas mass flow sensor SIGNAL pin in engine harness connector 1 and all other pins in the engine harness connector 2.
  • Measure the resistance between the gas mass flow sensor SUPPLY pin in the engine harness connector 1 and all other pins in the engine harness connector 1.
  • Measure the resistance between the gas mass flow sensor SUPPLY pin in engine harness connector 1 and all other pins in the engine harness connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Measure the resistance between the gas mass flow sensor SIGNAL pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Nov-2012


FAULT CODE 454 - Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Diagram | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Gass Mass Flow Sensor | Refer to Procedure 019-101 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault code. | Fault Code 516 active?
 | STEP 1B. Check for an active fault code. | Fault Code 454 active?
STEP 2. | Check the gas mass flow sensor and circuit. |
 | STEP 2A. Inspect the gas mass flow sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage above 15-VDC?
 | STEP 2C. Check the sensor response. | Fault Code 453 active?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 454 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 454 active?
 | STEP 3F. Check the ECM response. | Fault Code 453 active?
STEP 4. | Check ECM calibration code and clear the fault codes. |
 | STEP 4A. Disable the fault code. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES | NO
No Repair | No Repair

Troubleshoot appropriate fault codes.

1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 454 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the gas mass flow sensor and circuit.

Guided Step 2 - Inspect the gas mass flow sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Inspect the engine harness and gas mass flow sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-212 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-101 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to reset the fuel tables, if the gas mass flow sensor is replaced.

 No Repair

Go to 4B

2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine harness
  • Turn keyswitch ON.

Action

Check for the supply voltage and return circuit.

  • Measure the voltage from the gas mass flow SUPPLY pin to the gas mass flow RETURN pin at the gas mass flow sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 13.5-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the gas mass flow SUPPLY pin and the gas mass flow SIGNAL pin at the gas mass flow sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 453 active?

YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the gas mass flow sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 454 active?

YES NO

A damaged sensor has been detected.

  • Replace the sensor.Refer to Procedure 019-101 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to reset the fuel tables, if the gas mass flow sensor is replaced.

NOTE: The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damged connection has been detected in the ECM or harness connector.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 gas mass flow RETURN pin and the gas mass flow RETURN pin of the gas mass flow sensor connector.
  • Measure the resistance between the ECM connector 1 gas mass flow SUPPLY pin and the gas mass flow SUPPLY pin at the gas mass flow sensor connector.
  • Measure the resistance between the ECM connector 1 gas mass flow SIGNAL pin and the gas mass flow SIGNAL pin in the gas mass flow sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the gas mass flow sensor from the engine harness.
  • Disconnect all sensors in sensor supply.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the gas mass flow SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the gas mass flow SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the gas mass flow SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the gas mass flow SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the gas mass flow RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the gas mass flow RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-212 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the gas mass flow SIGNAL pin in the ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin short to ground has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-212 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4B

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 454 active?
YES | NO
No Repair | No Repair

Go to 3F

4A

Guided Step 3F - Check for ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine harness
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the gas mass flow SUPPLY pin and the gas mass flow SIGNAL pin at the gas mass flow sensor connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 453 active?
YES NO
No Repair

A damaged ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Nov-2012


FAULT CODE 455 - Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Fuel Control Valve | Refer to Procedure 019-102 | ISB5.9 G C2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 455 active?
STEP 2. | Check the engine fuel control valve and circuit. |
 | STEP 2A. Inspect the engine fuel control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine fuel control valve. | 2 ohms to 5 ohms?
 | STEP 2C. Check the engine fuel control valve supply voltage and return circuit. | Greater than 0.5-VDC?
 | STEP 2D. Check for an open circuit in the engine fuel control valve return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 455 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel control valve and circuit.

Guided Step 2A - Inspect the engine fuel control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel control valve from the engine harness.

Action

Inspect the engine harness and engine fuel control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the valve or harness connector.

Repair or replace the harness, or replace the valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check for an open circuit in the engine fuel control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel control valve from the engine harness.

Action

Check the engine fuel control valve resistance.

  • Measure the resistance between the engine fuel control valve (+) pin and the engine fuel control valve (-) pin at the engine fuel control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

2 ohms to 5 ohms?
YES NO
No Repair

Replace the engine fuel control valve.

  • Refer to Procedure 019-102 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check the engine fuel control valve supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel control valve from the engine harness.
  • Turn keyswitch ON.
  • Engage the starter and crank the engine.

Action

Check the engine fuel control valve (+) voltage and (-) circuit.

  • Measure the voltage between the engine fuel control valve (+) pin and the engine fuel control valve (-) pin of the engine fuel control valve connector in the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 0.5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the engine fuel control valve return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel control valve from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the engine fuel control valve (-) pin in the engine harness and the (-) pin in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open pin-to-ground circuit on the return line has been detected in the engine harness.

Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine fuel control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM engine connector 1 and the engine fuel control valve (+) pin in the engine harness engine fuel control valve connector (+) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine fuel control valve (+) circuit has been detected in the engine harness.

Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the engine fuel control valve from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel control valve (+) pin in engine harness ECM engine connector 1 to all other pins in the engine connector 1.
  • Measure the resistance from the engine fuel control valve (+) pin in engine harness ECM engine connector 1 to all pins in engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short on the engine fuel control valve (+) line has been detected in the engine harness.

Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Nov-2012


FAULT CODE 458 - Ignition Timing Signal Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Ignition Control Module | Refer to Procedure 019-105 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 458 active?
STEP 2. | Check the ignition control module. |
 | STEP 2A. Inspect the ignition control module (ICM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 458 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 458 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Attempt to start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 458 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ICM.

Guided Step 2A - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ignition control module.

Action

Inspect the ignition control module and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Attempt to start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 458 active?
YES NO
No Repair

NOTE: The removal and installation of the connectors corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnec the ICM from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the ICM timing pin in engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance between the ICM timing pin in engine harness ECM connector 1 to all other pins in engine harness ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit had been detected in the engine harness. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 458 active?
YES NO

  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Nov-2012


FAULT CODE 459 - Ignition Timing Signal Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Ignition Control Module | Refer to Procedure 019-105 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Active or inactive counts of both Fault Codes 459 and 462?
 | STEP 1B. Read the fault codes. | Fault Code 459 active?
STEP 2. | Check the ignition control module (ICM). |
 | STEP 2A. Inspect the ICM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 459 active?
STEP 3. | Check the ICM switched battery supply |
 | STEP 3A. Inspect the ICM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the engine and OEM harness 4-pin switched battery connector. | Dirty or damaged pins?
 | STEP 3C. Check for an open circuit in the engine harness switched battery supply. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness switched battery supply. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness switched battery supply. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Code 459 active?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4E. Read the fault codes. | Fault Code 459 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of both Fault Codes 459 and 462?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 459 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the ICM.

Guided Step 2A - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.

Action

Inspect the ICM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Attempt to start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 459 active?
YES NO
No Repair

NOTE: The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 5A

Guided Step 3 - Check ICM switched battery supply.

Guided Step 3A - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.

Action

Inspect the ICM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the engine and OEM harness 4-pin switched battery connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin switched battery connector from the OEM harness.

Action

Inspect the engine and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected.

Repair or replace the OEM or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness switched battery supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin switched battery connector from the OEM harness.
  • Disconnect the ICM from the engine harness.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the ECM switched battery (+) (ICM Power) pin in the engine harness 4-pin switched battery connector and switched battery (+) pin in the engine harness ICM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been found in the engine harness.

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the engine harness switched battery supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin switched battery connector from the OEM harness.
  • Disconnect the ICM from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the switched battery (+) (ICM Power) pin in engine harness 4-pin switched battery connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness switched battery supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin switched battery connector.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the ICM from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the switched battery (+) (ICM Power) pin in the engine harness 4-pin power connector and all pins in the engine harness ECM connector 1.
  • Measure the resistance between the switched battery (+) (ICM Power) pin in the engine harness 4-pin switched battery connector and all pins in the engine harness ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 5A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Attempt to start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 459 active?
YES NO

There is an issue with the OEM switched battery supply. Refer to the OEM service manual

NOTE: The removal and installation of the connectors corrected the fault.

Go to 5A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Check for an open circuit.

  • Measure the resistance between the ICM timing pin in the engine harness ECM connector and the ICM timing pin in the engine harness ICM connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness ECM connector 1.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ICM timing pin in engine harness ECM connector 1 to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k Ohms?
YES NO

A short to ground has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness ECM connectors 1 and 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the ICM timing pin in engine harness ECM connector 1 and all other pins in the connector 1.
  • Measure the resistance between the ICM timing pin in engine harness ECM connector 1 and all pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Attempt to start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 459 active?
YES NO

There is an issue with the OEM switched battery supply. Refer to the OEM service manual

  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

NOTE: The removal and installation of the connectors corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Nov-2012


FAULT CODE 461 - Ignition Control Signal Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Diagram | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Ignition Control Module | Refer to Procedure 019-105 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 461 active?
STEP 2. | Check the ignition control module. |
 | STEP 2A. Inspect the ignition control module (ICM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 461 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 461 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Attempt to start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 461 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure Procedure 019-362 in Section 19

Guided Step 2 - Check the ignition control module.

Guided Step 2A - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.

Action

Inspect the ignition control module and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 019.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Attempt to start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 461 active?
YES NO
No Repair

NOTE: The removal and installation of the connectors corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.

Action

Inspect the engine harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness. Refer to Procedure 019-204 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect engine harness connectors 1 and 2.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the ICM reference pin in the engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance between the ICM reference pin in the engine harness ECM connector 1 to all other pins in engine harness ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 461 active?
YES NO

Replace the ICM. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Nov-2012


FAULT CODE 462 - Ignition Control Signal Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Ignition Control Module | Refer to Procedure 019-105 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Active or inactive counts of both fault codes 459 and 462?
 | STEP 1B. Read the fault codes. | Fault Code 462 active?
STEP 2. | Check the ignition control module (ICM). |
 | STEP 2A. Inspect the ICM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 462 active?
STEP 3. | Check ICM switched battery supply. |
 | STEP 3A. Inspect the ICM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the engine and OEM harness 4-pin switched battery connector. | Dirty or damaged pins?
 | STEP 3C. Check for an open circuit in the engine harness switched battery supply. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness switched battery supply. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness switched battery supply. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Code 462 active?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4E. Read the fault codes. | Fault Code 462 active?
STEP 5. | Check the ECM calibration and clear the fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of both fault codes 459 and 462?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 462 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ICM.

Guided Step 2A - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.

Action

Inspect the ICM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ICM module. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Read the fault codes.

  • Attempt to start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 462 active?
YES NO
No Repair

NOTE: The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 5A

Guided Step 3 - Check the ICM switched battery supply.

Guided Step 3A - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.

Action

Inspect the ICM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Reference the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the engine and OEM harness 4-pin switched battery connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin switched battery connector from the OEM harness.

Action

Inspect the engine and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected.

Repair or replace the OEM or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair the OEM harness. Refer to the OEM service manual.

Go to 5A

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness switched battery supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin switched battery connector from the OEM harness.
  • Disconnect the ICM from the engine harness.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the ECM switched battery (+) (ICM Power) pin in the engine harness 4-pin switched battery connector and switched battery (+) pin in the engine harness ICM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been found in the engine harness.

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the engine harness switched battery supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin switched battery connector from the OEM harness.
  • Disconnect the ICM from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the switched battery (+) (ICM Power) pin in engine harness 4-pin switched battery connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness switched battery supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin switched battery connector.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the ICM from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the switched battery (+) (ICM Power) pin in the engine harness 4-pin power connector and all pins in the engine harness ECM connector 1.
  • Measure the resistance between the switched battery (+) (ICM Power) pin in the engine harness 4-pin switched battery connector and all pins in the engine harness ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 5A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Attempt to start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 462 active?
YES NO

There is an issue with the OEM switched battery supply. Refer to the OEM service manual.

NOTE: The removal and installation of the connectors corrected the fault.

Go to 5A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Check for an open circuit.

  • Measure the resistance between the ICM reference pin in the engine harness ECM connector and the ICM reference pin in the engine harness ICM connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the 4-pin switched battery connector.
  • Disconnect the ICM from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ICM reference pin in engine harness ECM connector 1 to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Assoicated Procedures Table.

Go to 5A

Go to 4D

Guided Step 4D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness ECM connectors 1 and 2.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the ICM reference pin in engine harness ECM connector 1 and all other pins in the connector 1.
  • Measure the resistance between the ICM reference pin in engine harness ECM connector 1 and all pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Attempt to start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 462 active?
YES NO

An issue with the ICM has been detected.

  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

NOTE: The removal and installation of the connectors corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Nov-2012


FAULT CODE 465 - Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Diagram | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Wastegate Control Valve | Refer to Procedure 019-103 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 465 inactive?
STEP 2. | Check the engine turbocharger wastegate control valve and circuit. |
 | STEP 2A. Inspect the engine turbocharger wastegate control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine turbocharger wastegate control valve. | 2 ohms to 6 ohms?
 | STEP 2C. Check the engine turbocharger wastegate control valve voltage, supply line and return circuit. | Greater than 0.5-VDC?
 | STEP 2D. Check for an open circuit in the engine turbocharger wastegate control valve return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 465 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine turbocharger wastegate control valve and circuit.

Guided Step 2A - Inspect the engine turbocharger wastegate control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger wastegate control valve from the engine harness.

Action

Inspect the engine harness and engine turbocharger wastegate control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine turbocharger wastegate control valve. Refer to Procedure 019-103 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check for an open circuit in the engine turbocharger wastegate control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger wastegate control valve from the engine harness.

Action

Check the engine turbocharger wastegate control valve resistance.

  • Measure the resistance between the engine turbocharger wastegate control valve (+) pin and the engine turbocharger wastegate control valve (-) pin at the engine turbocharger wastegate control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

2 ohms to 6 ohms?
YES NO
No Repair

Replace the engine turbocharger wastegate control valve. Refer to Procedure 019-103 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check the engine turbocharger wastegate control valve voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger wastegate control valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the engine turbocharger wastegate control valve voltage and return circuit.

  • Measure the voltage between the engine turbocharger wastegate control valve (+) pin and the engine turbocharger wastegate control valve (-) pin at the engine turbocharger wastegate control valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 0.5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the engine turbocharger wastegate control valve return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger wastegate control valve from the engine harness.
  • Disconnect the engine wiring harness ECM connector 1.

Action

Check for an open circuit.

  • Measure the resistance between the engine turbocharger wastegate control valve (-) pin in the engine harness and the ECM connector engine turbocharger wastegate control valve return pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit on the return line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Repair or replace the engine harness. Replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine turbocharger wastegate control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine turbocharger wastegate control valve (+) pin and the engine harness engine turbocharger wastegate control valve connector (+) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine turbocharger wastegate control valve supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine turbocharger wastegate control valve from engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine turbocharger wastegate control valve (+) pin in the engine harness ECM connector 1 to all other pins in the ECM connector 1.
  • Measure the resistance between the engine turbocharger wastegate control valve (+) pin in the engine harness ECM connector 1 to all other pins in ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine turbocharger wastegate control valve supply line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Nov-2012


FAULT CODE 466 - Turbocharger 1 Wastegate Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Fuel Control Valve | Refer to Procedure 019-102 | ISB5.9 G CM2180 | 2883369
Wastegate Control Valve | Refer to Procedure 019-103 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1117 active or high inactive counts?
 | STEP 1B. Check for an inactive fault code. | Fault Code 466 inactive?
STEP 2. | Check the engine turbocharger wastegate control valve and circuit. |
 | STEP 2A. Inspect the engine turbocharger wastegate control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the engine turbocharger wastegate control valve coil. | 2 ohms to 6 ohms?
 | STEP 2C. Check for a short-to-ground in the engine turbocharger wastegate control valve. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available.. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE electronic service tool.

Action

Check for an active fault code or high inactive counts.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 1117 active or high inactive counts?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1117.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE electronic service tool.

Action

Check for active fault codes.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 466 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine turbocharger wastegate control valve and circuit.

Guided Step 2A - Inspect the engine turbocharger wastegate control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger wastegate control valve from the engine harness.

Action

Inspect the engine harness and engine turbocharger wastegate control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the harness, or replace the valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the valve. Refer to Procedure 019-102 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check for an open circuit in the engine turbocharger wastegate control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger wastegate control valve from the engine harness.

Action

Check the engine turbocharger wastegate control valve resistance.

  • Measure the resistance between the engine turbocharger wastegate control valve (+) pin and the engine turbocharger wastegate control valve (-) pin at the engine turbocharger wastegate control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

2 ohms to 6 ohms?
YES NO
No Repair

Replace the engine turbocharger wastegate control valve. Refer to Procedure 019-103 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check for a short circuit to ground in the engine turbocharger wastegate control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger wastegate control valve from the engine harness.

Action

Check the engine turbocharger wastegate control valve output short to ground.

  • Measure the resistance between the engine turbocharger wastegate control valve (+) pin and ground at the engine turbocharger wastegate control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine turbocharger wastegate control valve. Refer to Procedure 019-103 in the Associated Procedures Table.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine turbocharger wastegate control valve from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine turbocharger wastegate control valve (+) pin in the ECM connector 1 and ground.
  • Measure the resistance between the engine turbocharger wastegate control valve (-) pin in the ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-ground short circuit on the engine turbocharger wastegate control valve supply line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the engine turbocharger wastegate control valve from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine turbocharger wastegate control valve (+) pin in the engine harness ECM connector 1 to all other pins in the ECM connector 1.
  • Measure the resistance from the engine turbocharger wastegate control valve (+) pin in the ECM connector 1 to all pins in the ECM connector 2.
  • Measure the resistance between the engine turbocharger wastegate control valve (-) pin in the ECM connector 1 to all other pins in the ECM connector 1.
  • Measure the resistance from the engine turbocharger wastegate control valve (-) pin in the ECM connector 1 to all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short on the engine turbocharger wastegate control valve supply line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Nov-2012


FAULT CODE 511 - Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Fuel Control Valve | Refer to Procedure 019-102 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1117 active or high inactive counts?
 | STEP 1B. Check for an active fault code. | Fault Code 511 active?
STEP 2. | Check the engine fuel control valve and circuit. |
 | STEP 2A. Inspect the engine fuel control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine fuel control valve. | 2 ohms to 5 ohms?
 | STEP 2C. Check for a short to ground in the engine fuel control valve. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Check for an active fault code or high inactive counts.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 1117 active or high inactive counts?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1117

Go to 1B

Guided Step 1B - Check for an active fault code

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Read the fault codes.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 511 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel control valve and circuit.

Guided Step 2A - Inspect the engine fuel control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel control valve from the engine harness.

Action

Inspect the engine harness and engine fuel control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected. Repair or replace the harness, or replace the valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.
  • Use INSITE electronic service tool to reset the fuel tables if the engine fuel control valve is replaced.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check for an open circuit in the engine fuel control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel control valve from the engine harness.

Action

Check engine fuel control valve resistance.

  • Measure the resistance between the engine fuel control valve (+) pin and the engine fuel control valve (-) pin at the engine fuel control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

2 ohms to 5 ohms?
YES NO
No Repair

A damaged engine fuel control valve has been detected.

Replace the engine fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

Use INSITE electronic service tool to reset the fuel tables if the engine fuel control valve is replaced.

Go to 2C

Go to 4B

Guided Step 2C - Check for a short to ground in the engine fuel control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel control valve from the engine harness.

Action

Check the engine fuel control valve output short to ground.

  • Measure the resistance between the engine fuel control valve (+) pin and ground to the body of the fuel control valve.

Note: Remove any paint, grease, or foreign material which might compromise the measurement.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A damaged engine fuel control valve has been detected.

Replace the engine fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

Use INSITE electronic service tool to reset the fuel tables if the engine fuel control valve is replaced.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condesation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Repair or replace the harness or replace the ECM with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-ground short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine fuel control valve from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine fuel control valve (+) pin in the ECM connector 1 and ground.
  • Measure the resistance between the engine fuel control valve (-) pin in the ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the engine fuel control valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine fuel control valve (+) pin in the engine harness ECM connector 1 to all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel control valve (+) pin in the engine harness ECM connector to all other pins in the ECM connector 2.
  • Measure the resistance between the engine fuel control valve (-) pin in the engine harness ECM connector 1 to all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel control valve (-) pin in the engine harness ECM connector to all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 or Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Nov-2014


FAULT CODE 512 - Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Codes 352 or 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 512 active?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 513 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 512 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code 512 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Codes 352 and 386.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code.Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and engine throttle connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Repair or replace the harness, or replace the throttle actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the sensor SUPPLY pin to the throttle 1 pin at the engine throttle actuator connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage.Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check for fault codes and verify sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness.Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1 and 2.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle actuator SUPPLY pin in the engine harness ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the throttle actuator SUPPLY pin in the engine harness ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the throttle position 1 pin in the engine harness ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the throttle position 1 pin in the engine harness ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle actuator supply line or position signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Nov-2012


FAULT CODE 513 - Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply faults. | Fault Code 352 active?
 | STEP 1B. Check for an active fault code. | Fault Code 513 active?
STEP 2. | Check the throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 512 active?
 | STEP 2C. Check for fault codes and verify sensor condition. | Fault Code 512 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 352.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 active?
YES | NO
No Repair | No Repair

Go to 2B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and engine throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or engine harness connector.

Repair or replace the harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the circuit response after 30 seconds.

  • Place a jumper wire between the sensor SUPPLY 1 pin and the throttle position 1 pin in the engine harness engine throttle actuator connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 512 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine throttle actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 active?
YES NO

A damaged engine throttle actuator has been detected.

Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness.

Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness.Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 engine throttle actuator throttle position 1 pin and the throttle position 1 pin in the engine harness engine throttle actuator connector.
  • Measure the resistance between the ECM connector 1 sensor return 1 and the engine sensor return 1 pin in the engine harness engine throttle actuator connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit has been detected in the engine harness.

Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the ECM connector 1 engine throttle actuator throttle position 1 pin and ground.
  • Measure the resistance between the ECM connector sensor 1 return and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the engine throttle actuator supply or the engine throttle position 1 signal lines has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness.Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1 and 2.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ECM connector 1 engine throttle actuator throttle position 1 pin and all other pins in the ECM connector 1.
  • Measure the resistance between the ECM connector 1 engine throttle actuator throttle position 1 pin and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine throttle actuator command supply line or position signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Nov-2012


FAULT CODE 515 - Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 515 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply 6 supply voltage. | Greater than 15.75-VDC?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 515 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting inactive or intermittent fault code. Refer to Procedure 019-362

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Asssociated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Asssociated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the sensor supply 6 supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage at the ECM.

  • Measure the voltage between the sensor supply 6 SUPPLY pin in the ECM connector 1 and the sensor supply 6 RETURN pin in the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 15.75-VDC?
YES NO

A damaged sensor supply circuit has been detected in the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in the Asssociated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect all components connected to sensor supply 6.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor supply 6 SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the sensor supply 6 SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply 6 circuit has been detected in the engine harness. Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

All fault codes cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Nov-2012


FAULT CODE 516 - Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Gas Mass Flow Sensor | Refer to Procedure 019-101 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 516 active?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the gas mass flow sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 516 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the gas mass flow sensor and connector.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Inspect the engine harness and gas mass flow sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-212 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in the Associated Procedures Table.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connectors 1 and 2.
  • Disconnect all sensors on sensor supply 6 from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor supply 6 SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the sensor supply 6 SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply 6 circuit has been detected in the engine harness. Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-212 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connectors 1 and 2.
  • Disconnect all sensors on sensor supply 6 from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the sensor supply 6 SUPPLY pin in the engine harness ECM connector 1 and ground

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin short to ground has been detected in the engine harness. Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-212 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Nov-2012


FAULT CODE 561 - Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Air Compressor | Refer to Procedure 012-014 | ISB5.9 G CM2180 | 2883369
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire (Non Shielded) | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 572 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault code 561 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for in-cylinder damage. | Evidence of damage?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Is fault code 561 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

Use INSITE™ electronic service tool to check for active fault codes.

Fault code 572 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 572

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 561 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 1 from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation, such as torqued improperly

Inpect the connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Washers or p-clips can NOT be mounted with the knock sensor.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Reference the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

  • Repair or replace the damaged components. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Proceduers Table.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the wastegate functioning properly?
YES NO
No Repair

A damaged turbocharger wastegate has been detected.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Air compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected. Time the air compressor.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2F - Check for in-cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 spark plug.

Action

Inspect for in-cylinder damage:

  • Use a borescope to inspect cylinder 1 for knock damage.

Evidence of damage?
YES NO

Repair or replace the damaged components.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Proceduers Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Nov-2012


FAULT CODE 562 - Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Air Compressor | Refer to Procedure 012-014 | ISB5.9 G CM2180 | 2883369
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 572 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 562 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for in-cylinder damage. | Evidence of damage.
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Is Fault Code 562 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 572

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 562 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the knock sensor 1 from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation, such as torqued improperly.

Inspect the connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Washers or p-clips can NOT be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Reference the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

Repair or replace the damaged components.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Wastegate functioning properly?
YES NO
No Repair

A damaged turbocharger wastegate has been detected.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Air compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2F - Check for in-cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 spark plug.

Action

Inspect for in-cylinder damage:

  • Use a borescope to inspect cylinder 2 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Nov-2012


FAULT CODE 563 - Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Air Compressor | Refer to Procedure 012-014 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire (Non Shielded) | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 572 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 563 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressortimed correctly?
 | STEP 2F. Check for in cylinder damage. | Evidence of damage.
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Is Fault Code 563 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 572

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 563 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components.

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF
  • Disconnect the knock sensor 1 from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation, such as torqued improperly.

Inspect the connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulaton damage
  • Damage connector locking tab.

NOTE: Washer or p-clips can NOT be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Reference the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

Repair or replace the damaged components.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the wastegate functioning properly?
YES NO
No Repair

A damaged turbocharger wastegate has been detected.

Replace the damaged component.

Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Air compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected. Time the air compressor.

Refer to Procedure 012-014 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 spark plug.

Action

Inspect for in-cylinder damage:

  • Use a borescope to inspect cylinder 3 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Nov-2012


FAULT CODE 564 - Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Air Compressor | Refer to Procedure 012-014 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire (Non Shielded) | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 575 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 564 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for in-cylinder damage. | Evidence of damage.
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Is Fault Code 564 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 575 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 575

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 564 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components.

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF
  • Disconnect the knock sensor 2 from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation, such as torqued improperly.

Inspect the connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulaton damage
  • Damage connector locking tab.

NOTE: Washer or p-clips can NOT be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition-related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Reference the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition-related problem has been detected.

Repair or replace the damaged components.

  • Refer to Procedure 013-014 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the wastegate functioning properly?
YES NO
No Repair

A damaged turbocharger wastegate has been detected.

Replace the damaged component

Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Air compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected. Time the air compressor.

Refer to Procedure 012-014 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF
  • Remove the cylinder 4 spark plug.

Action

Inspect for in-cylinder damage:

  • Use a borescope to inspect cylinder 4 for knock damage.

Evidence of damage?
YES NO

Repair or replace the damaged components.

  • Refer to Procedure 013-014 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Nov-2012


FAULT CODE 565 - Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
 | Refer to Procedure 012-014 | ISB5.9 G CM2180 | 2883369
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 575 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 565 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for in-cylinder damage. | Evidence of damage.
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 575 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 575

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 565 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components.

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 2 from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation, such as torqued improperly.

Inspect the connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulaton damage
  • Damage connector locking tab.

NOTE: Washer or p-clips can NOT be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition-related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Reference the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the wastegate functioning properly?
YES NO
No Repair

A damaged turbocharger wastegate has been detected.

Replace the damaged component.

Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Air compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected. Time the air compressor.

Refer to Procedure 012-014 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 spark plug.

Action

Inspect for in-cylinder damage:

  • Use a borescope to inspect cylinder 5 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Nov-2012


FAULT CODE 566 - Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Air Compressor | Refer to Procedure 012-014 | ISB5.9 G CM2180 | 2883369
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 573 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 566 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor. | Any knock sensor damage?
 | STEP 2B. Check for an ignition-related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for in cylinder damage. | Evidence of damage.
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 573 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 573

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 566 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components.

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 2 from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation, such as torqued improperly.

Inspect the connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulaton damage
  • Damage connector locking tab.

NOTE: Washer or p-clips can NOT be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Reference Step 8 (Ignition System Troubleshooting Procedures) in the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the wastegate functioning properly?
YES NO
No Repair

A damaged turbocharger wastegate has been detected.

Replace the turborcharger.

Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Air compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected. Time the air compressor.

Refer to Procedure 012-014 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF
  • Remove the cylinder 6 spark plug.

Action

Inspect for in-cylinder damage:

  • Use a borescope to inspect cylinder 6 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Nov-2012


FAULT CODE 572 - Engine Cylinder 2 (B1) Knock - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 572 active?
STEP 2. | Check the knock sensor. |
 | STEP 2A. Inspect the engine harness and knock sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 572 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 572 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor.

Guided Step 2A - Inspect the engine harness and knock sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from knock sensor 1.

Action

Inspect the engine harness and knock sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine harness from knock sensor 1.

Action

Check for an open circuit.

  • Measure the resistance between the knock 1 (+) pin in the ECM connector 1 to the knock 1 (+) pin in the knock sensor 1 harness connector.
  • Measure the resistance between the knock 1 (-) pin in the ECM 1 connector to the knock 1 (-) pin in the knock sensor 1 harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-214or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine harness from knock sensor 1.

Action

Check for a short circuit to ground.

  • Measure the resistance between the knock 1 (+) pin in the ECM 1 to ground.
  • Measure the resistance between the knock 1 Negative (-) pin in the ECM connector 1 to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4B

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1 and 2.
  • Disconnect the engine harness from knock sensor 1.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the knock 1 (+) pin in the ECM connector 1 to all other pins in the connector 1.
  • Measure the resistance from the knock 1 positive (+) pin in engine harness ECM connector 1 to all other pins in engine harness ECM connector 2.
  • Measure the resistance between the knock 1 negative (-) pin in engine harness ECM connector 1 to all other pins in the ECM connector 1.
  • Measure the resistance from the knock 1 negative (-) pin in the ECM connector 1 to all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Nov-2012


FAULT CODE 575 - Engine Cylinder 5 (A3) Knock - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 575 active?
STEP 2. | Check the knock sensor. |
 | STEP 2A. Inspect the engine harness and knock sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 575 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 575 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 575 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor.

Guided Step 2A - Inspect the engine harness and knock sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from knock sensor 2.

Action

Inspect the engine harness and knock sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 575 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 575 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine harness from knock sensor 2.

Action

Check for an open circuit.

  • Measure the resistance between the knock 2 (+) pin in the ECM connector 1 to the knock 2 (+) pin in the knock sensor 2 harness connector.
  • Measure the resistance between the knock 2 (-) pin in the ECM 1 connector to the knock 2 (-) pin in the knock sensor 2 harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-214or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine harness from knock sensor 2.

Action

Check for a short circuit to ground.

  • Measure the resistance between the knock 2 (+) pin in the ECM connector 1 to ground.
  • Measure the resistance between the knock 2 negative (-) pin in the ECM connector 1 to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness.Refer to Procedure 019-204or Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4B

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1 and 2.
  • Disconnect the engine harness from knock sensor 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the knock 2 (+) pin in the ECM connector 1 to all other pins in the connector 1.
  • Measure the resistance from the knock 2 positive (+) pin in the engine harness ECM connector 1 to all other pins in engine harness ECM connector 2.
  • Measure the resistance between the knock 2 (+) pin in the ECM connector 1 to all other pins in the ECM connector 2.
  • Measure the resistance between the knock 2 negative (-) pin in the engine harness ECM connector 1 to all other pins in the ECM connector 1.
  • Measure the resistance from the knock 2 negative (-) pin in the ECM connector 1 to all other pins in ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness.Refer to Procedure 019-204or Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Nov-2012


FAULT CODE 584 - Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 584 active?
 | STEP 1B. Check the ECM setup for starter lockout relay. | INSITE™ electronic service tool starter lockout feature setup correctly?
STEP 2. | Check the starter lockout relay and circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit in the starter lockout relay return circuit. | Less than 10 ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code.Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM setup for starter lockout relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the starter lockout feature.

  • If the vehicle has a starter lockout relay installed, INSITE™ electronic service tool parameter starter lockout relay must be set to “Enable”.
  • If the vehicle does not have a starter lockout relay installed, INSITE™ electronic service tool parameter starter lockout relay must be set to “Disable”.

INSITE™ electronic service tool starter lockout feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the Idle Shutdown feature setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the starter lockout relay and circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Inspect the OEM harness and starter lockout relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay signal pin and the starter lockout relay RETURN pin in the starter lockout relay.
  • Use the OEM wiring diagram for starter relay pin configuration.

Use the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Less than 10K ohms?
YES NO
No Repair

Replace the starter lockout relay.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness ECM connector 2.

Action

Check for an open circuit.

  • Measure the resistance of the starter lockout relay connector to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Reference the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31-pin OEM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine or OEM harness connector.

Repair the damaged pins. Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the starter lockout relay SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the ECM connector 2 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Nov-2012


FAULT CODE 585 - Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 585 active?
 | STEP 1B. Check the ECM setup for starter lockout relay. | INSITE™ electronic service tool starter lockout feature setup correctly?
STEP 2. | Check the starter lockout relay and circuit. |
 | STEP 2A. Check the starter lockout relay resistance. | Greater than 6 ohms?
 | STEP 2B. Check for a pin-to-ground short circuit in the starter lockout relay. | Greater than 100K ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100K ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM setup for starter lockout relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the starter lockout feature.

  • If the vehicle has a starter lockout relay installed, INSITE™ electronic service tool parameter starter lockout relay must be set to “Enable”.
  • If the vehicle does not have a starter lockout relay installed, INSITE™electronic service tool parameter starter lockout relay must be set to “Disable”.

INSITE™ electronic service tool starter lockout feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the Idle Shutdown feature setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the starter lockout relay and circuit.

Guided Step 2A - Check starter lockout relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Measure the starter lockout relay resistance.

  • Measure the resistance of the relay coil and check for low resistance between the starter lockout relay SIGNAL pin and the relay RETURN pin in the starter lockout relay.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the starter lockout relay.

Refer to the OEM service manual.

Go to 2B

Go to 4A

Guided Step 2B - Check for a pin-to-ground short circuit in the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay SIGNAL pin and ground in the starter lockout relay.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Replace the starter lockout relay.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected.

Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness ECM connector 2.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM harness ECM connector 2 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin in the ECM connector 2 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Nov-2012


FAULT CODE 591 - Exhaust Back Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Exhaust Back Pressure Sensor | Refer to Procedure 019-347 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 227. | Fault Code 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 591 active?
STEP 2. | Check the exhaust back pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust back pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 592 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 591 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for the ECM response. | Fault Code 592 active?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 591 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 227.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 591 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust back pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust back pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust back pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the exhaust back pressure sensor. Refer to Procedure 019-347 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust back pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust back pressure sensor SUPPLY pin to the exhaust back pressure sensor RETURN pin at the exhaust back pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust back pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 592 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust back pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 591 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust back pressure sensor. Refer to Procedure 019-347 in the Associated Procedures Table.

None. The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 1.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 592 active?
YES NO
No Repair

A damaged ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the exhaust back pressure sensor from the engine harness.
  • Disconnect all sensors on the sensor supply.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust back pressure sensor SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the exhaust back pressure sensor SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the exhaust back pressure sensor SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the exhaust back pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the exhaust back pressure RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the exhaust back pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Nov-2012


Fault Code 592 - Exhaust Back Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Exhaust Back Pressure Sensor | Refer to Procedure 019-347 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 187. | Fault Code 187 active?
 | STEP 1B. Check for an active fault code. | Fault Code 592 active?
STEP 2. | Check the exhaust back pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust back pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 592 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 591 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit from in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short to ground in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 187.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 187

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 592 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust back pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust back pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust back pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-43 in the Associated Procedures Table.
  • Replace the exhaust back pressure sensor. Refer to Procedure 019-347 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust back pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust back pressure sensor SUPPLY pin to the exhaust back pressure sensor RETURN pin at the exhaust back pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust back pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust back pressure sensor SUPPLY pin and the exhaust back pressure sensor SIGNAL pin at the exhaust back pressure sensor.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 591 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust back pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 592 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust back pressure sensor. Refer to Procedure 019-347 in the Associated Procedures Table.

None. The removal and installation of the connectors corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 1.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 exhaust back pressure sensor RETURN pin and the exhaust back pressure sensor RETURN pin of the eexhaust back pressure sensor connector.
  • Measure the resistance between the ECM connector 1 exhaust back pressure sensor SUPPLY pin and the exhaust back pressure sensor SUPPLY pin at the exhaust back pressure sensor connector.
  • Measure the resistance between the ECM connector 1 exhaust back pressure sensor SIGNAL pin and the exhaust back pressure sensor SIGNAL pin in the exhaust back pressure sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the exhaust back pressure sensor from the engine harness.
  • Disconnect all sensors on the sensor supply.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the exhaust back pressure sensor SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the exhaust back pressure sensor SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the exhaust back pressure sensor SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the exhaust back pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the exhaust back pressure RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the exhaust back pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 1.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the exhaust back pressure sensor SIGNAL pin in the ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204or Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Nov-2012


FAULT CODE 596 - Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Voltages at least + 12-VDC under normal conditions and at least + 6.2-VDC during cranking?
STEP 2. | Check the charging system. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Refer to the OEM service manual.

 No Repair

Go to 3B

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive + terminal to the negative − terminal while trying to start the engine.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltages at least + 12-VDC under normal conditions and at least + 6.2-VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the charging system.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM amp meter or install an amp meter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

NOTE: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Nov-2012


FAULT CODE 597 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Voltages at least + 12-VDC under normal conditions and at least + 6.2-VDC during cranking?
STEP 2. | Check the alternator and power harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
 | STEP 2B. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit. | Greater than 100k ohms?
 | STEP 2D. Check the add-on or accessory wiring at the positive(+) terminal of the battery. | No damaged wires?
 | STEP 2E. Check for a pin-to-pin short circuit in the power harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Refer to the OEM service manual.

 No Repair

Go to 3B

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal. Touch the negative (-) probe of the multimeter to the negative battery terminal while trying to start the engine.

Voltage at least + 12-VDC under normal conditions and at least + 6.2-VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and power harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM amp meter or install an amp meter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

NOTE: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 2B

Go to 3B

Guided Step 2B - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the power harness connector from the ECM connector
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins of the OEM power harness ECM connector and the positive (+)battery terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the battery harness.

Refer to the OEM service manual.

Go to 2C

Go to 3B

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the power harness connector from the ECM connector
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins and the ECM battery SUPPLY (-) pins of the ECM power harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3B

Guided Step 2D - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit in the supply wire to the engine block.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Any damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 3B

Go to 2E

Guided Step 2E - Check for a pin-to-pin short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a pin-to-pin short circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins in the OEM power harness connector to all pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Nov-2012


FAULT CODE 598 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Voltages at least + 12-VDC under normal conditions and at least + 6.2-VDC during cranking?
STEP 2. | Check the alternator and OEM harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
 | STEP 2B. Inspect the battery power connector. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the power harness. | Greater than 100k ohms?
 | STEP 2E. Check the add-on or accessory wiring at the positive(+) terminal of the battery. | Damaged wires?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Refer to the OEM service manual.

 No Repair

Go to 3B

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Voltages at least + 12-VDC under normal conditions and at least + 6.2-VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and OEM harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

NOTE: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 2B

Go to 3B

Guided Step 2B - Inspect the battery power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness from the battery at the power connector.

Action

Inspect the battery power connector on both the battery side and the harness side for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the battery power connector.

Refer to the OEM service manual for location and procedure.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.
  • Disconnect the battery from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the ECM battery supply (+) circuit between the OEM power harness connector and the positive (+) terminal of the battery.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3B

Guided Step 2D - Check for a pin-to-pin short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM connector.
  • Disconnect the battery cable from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the ECM battery supply (+) pins and (-) pins of the power harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3B

Guided Step 2E - Check the add-on or accessory wiring at the positive (+)terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit at the supply wire to the engine block ground.

Damaged wires?
YES NO

Repair or replace the damaged wire.

Refer to the OEM service manual.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Nov-2012


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Camshaft Gear (Camshaft Removed) | Refer to Procedure 001-013 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 G CM2180 | 2883369
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the engine camshaft speed position sensor 1 and circuit. |
 | STEP 2A. Inspect the engine camshaft speed position sensor 1 and connector pins | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the engine camshaft speed/position sensor 1. | Damaged sensor tip?
 | STEP 2D. Verify adequate camshaft speed/position sensor air gap. | Is distance between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an active fault code. | Fault Code 689 active?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for a pin short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code 689 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Troubleshoot fault code 238 or 239

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the camshaft speed/position sensor 1 and circuit.

Guided Step 2A - Inspect the camshaft speed/position sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine camshaft speed/position sensor 1 from the engine harness.

Action

Inspect the engine harness and camshaft speed/position sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect camshaft speed/position sensor 1 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine camshaft speed/position sensor 1 SUPPLY pin and the engine camshaft speed/position sensor 1 RETURN pin at the engine camshaft speed/position sensor 1 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Inspect the engine camshaft speed/position sensor 1.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine crankshaft speed/position sensor 1 from the engine.

Action

Inspect the engine camshaft speed/position sensor 1 for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the camshaft gear.

Damaged sensor tip?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Inspect the camshaft gear teeth for damage or spinning. Refer to Procedure 001-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Verify adequate camshaft speed/position sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Remove engine camshaft speed/position sensor 1.

Action

Verify adequate air gap.

  • Measure the distance between the sensor mounting surface and the edge of the camshaft gear at several points in the camshaft's revolution.

Distance is between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]?
YES NO
No Repair

Inspect the camshaft for damage or spinning. Refer to Procedure 001-013 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 1.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine camshaft speed/position sensor 1 RETURN pin in the ECM connector and the engine camshaft speed/position sensor 1 connector RETURN pin.
  • Measure the resistance between the engine camshaft speed/position sensor 1 SUPPLY pin in the ECM connector 1 and the engine camshaft speed/position sensor 1 connector SUPPLY pin.
  • Measure the resistance between the engine camshaft speed/position sensor 1 SIGNAL pin in the ECM connector 1 and the engine camshaft speed/position sensor 1 connector SIGNAL pin.

NOTE: Shake and wiggle the harness to determine an intermittent connection.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine camshaft speed/position sensor 1 SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine camshaft speed/position sensor 1 SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine camshaft speed/position sensor 1 SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine camshaft speed/position sensor 1 SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the engine harness.Repair the damaged pins. Repair or replace the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair or replace the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.

Action

Check for pin to ground short.

  • Measure the resistance between the engine camshaft speed/position sensor 1 SIGNAL pin in the ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Nov-2012


FAULT CODE 769 - Brake Switch Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 769 active?
STEP 2. | Check the brake switch and circuit. |
 | STEP 2A. Inspect the brake switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the switch supply voltage. | Voltage between 4.75 to 5.25-VDC?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 769 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 769 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the brake switch and circuit.

Guided Step 2A - Inspect the brake switch and connector pins

Conditions

  • Turn keyswitch OFF.
  • Disconnect the brake switch from the OEM.

Action

Inspect the OEM harness and brake switch connector pins for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

  • Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the switch supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the brake switch from the engine harnes.
  • Turn key switch ON.

Action

Check the switch supply voltage.

  • Measure the voltage from the brake switch supply pin to the switch return pin at the OEM brake switch connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Voltage between 4.75 to 5.25-VDC?
YES NO
No Repair

An open or short circuit has been detected in the OEM harness.

Go to 2C

Go to 3A

Guided Step 2C - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the brake switch to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 769 active?.
YES NO

A damaged switch has been detected.

  • Replace the brake switch. Refer to the OEM service manual.

None. The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the brake switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector OEM switch RETURN pin and the OEM harness switch RETURN pin in the OEM harness brake switch connector.
  • Measure the resistance between the ECM connector 2 brake switch supply pin and the OEM harness brake switch supply pin in the OEM harness switch connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to the OEM service manual.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the brake switch from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the brake switch supply pin in the ECM connector 2 and all other pins in the ECM connector 1.
  • Measure the resistance between the brake switch supply pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the brake switch return pin in the ECM connector 2 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the brake switch return pin in the ECM connector 2 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to the OEM service manual.

  • Repair the engine harness. Refer to the OEM service manual.
  • Replace the engine harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision numbers in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Nov-2012


FAULT CODE 771 - Brake Switch Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 771 active?
STEP 2. | Check the brake switch and circuit. |
 | STEP 2A. Inspect the brake switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the switch supply voltage. | Voltage between 4.75 to 5.25-VDC?
 | STEP 2C. Check for fault codes and verify switch condition. | Fault Code 771 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Check for a short circuit to ground in the OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 771 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the brake switch and circuit.

Guided Step 2A - Inspect the brake switch and connector pins

Conditions

  • Turn keyswitch OFF.
  • Disconnect the brake switch from the OEM harness.

Action

Inspect the OEM harness and brake switch connector pins for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

  • Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.
  • Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the switch supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the brake switch from the engine harness.
  • Turn key switch ON.

Action

Check the switch supply voltage.

  • Measure the voltage from the brake switch SUPPLY pin to the switch RETURN pin at the OEM brake switch connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 to 5.25-VDC?
YES NO
No Repair

An open or short circuit has been detected in the OEM harness.

Go to 2C

Go to 3A

Guided Step 2C - Check for fault codes and verify switch condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the brake switch to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 771 active?
YES NO

A damaged switch has been detected.

  • Replace the brake switch. Refer to the OEM service manual.

None. The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the brake switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness brake switch SUPPLY pin in the OEM harness switch connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness

Repair or replace the OEM harness.

  • Refer to the OEM service manual.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connectors 1 and 2.
  • Disconnect the brake switch from the OEM harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the brake switch SUPPLY pin in the ECM connector 2 and all other pins in the ECM connector 1.
  • Measure the resistance between the brake switch SUPPLY pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the brake switch RETURN pin in the ECM connector 2 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the brake switch RETURN pin in the ECM connector 2 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to the OEM service manual.

  • Repair the engine harness. Refer to the OEM service manual.
  • Replace the engine harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision numbers in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Nov-2012


FAULT CODE 778 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Camshaft Gear (Camshaft Removed) | Refer to Procedure 001-013 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 778 inactive?
STEP 2. | Check the engine camshaft speed/position sensor 2 and circuit. |
 | STEP 2A. Inspect the engine camshaft speed/position sensor 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the engine camshaft speed/position sensor 2. | Damaged sensor tip?
 | STEP 2D. Verify adequate engine camshaft speed/position sensor 2 air gap. | Is distance between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 778 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352 or 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine camshaft speed/position sensor 2 and circuit.

Guided Step 2A - Inspect the engine camshaft speed/position sensor 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine camshaft speed/position sensor 2 from the engine harness.

Action

Inspect the engine harness and engine camshaft speed/position sensor 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor 2 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine camshaft speed/position sensor 2 SUPPLY pin and the engine camshaft speed/position sensor 2 RETURN pin at the engine camshaft speed/position sensor 2 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Inspect the engine camshaft speed/position sensor 2.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine camshaft speed/position sensor 2 from the engine.

Action

Inspect the engine camshaft speed/position sensor 2 for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

A damaged sensor has been detected.

  • Replace the engine camshaft speed/position sensor 2. Refer to Procedure 019-363 in the Associated Procedures Table.
  • Inspect the camshaft tone wheel/gear teeth for damage or spinning. Sensor depth is between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]. Refer to Procedure 001-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Verify adequate engine camshaft speed/position sensor 2 air gap.

Conditions

  • Turn keyswitch OFF.
  • Remove engine camshaft speed/position sensor 2 from the engine.

Action

Verify adequate air gap.

  • Measure the distance between the sensor mounting surface and the camshaft gear.

Distance is between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]?
YES NO
No Repair

Inspect the camshaft gear teeth for damage or spinning. Refer to Procedure 001-013 in the Associated Procedures Table.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 inactive?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine camshaft speed/position sensor 2 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 engine camshaft speed/position sensor 2 RETURN pin and the engine camshaft speed/position sensor connector RETURN pin.
  • Measure the resistance between the ECM connector 1 engine camshaft speed/position sensor 2 SUPPLY pin and the engine camshaft speed/position sensor connector SUPPLY pin.
  • Measure the resistance between the ECM connector 1 engine camshaft speed/position sensor 2 SIGNAL pin and the engine camshaft speed/position sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return current has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine camshaft speed/position sensor 2 from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine camshaft speed/position sensor 2 SIGNAL pin in the engine harness and all other pins in the engine connector 1.
  • Measure the resistance between the engine camshaft speed/position sensor 2 SIGNAL pin in the ECM connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4B

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine camshaft speed/position sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine camshaft speed/position sensor 2 SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine camshaft speed/position sensor 2 SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204or Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4B

Guided Step 3F - Check for a pin-to-ground short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine camshaft speed/position sensor 2 from the engine harness.

Action

Check for pin-to-ground short.

  • Measure the resistance between the engine camshaft speed/position sensor 2 SIGNAL pin in the engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness.

Replace or repair the damaged pins. Replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204or Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Nov-2012


FAULT CODE 1117 - Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

Batteries can emit explosive gasses. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824811 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 active?
 | STEP 1B. Check for add-on wiring, battery disconnect, or relay. | Add-on wiring, battery disconnect, or relay found in the OEM harness?
 | STEP 1C. Check the batteries and the power connection. | Connections tight and corrosion free?
STEP 2. | Check the OEM and engine power harness. |
 | STEP 2A. Inspect the OEM and engine power harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the OEM and engine power harness. | Less than 10 ohms?
STEP 3. | Check ECM calibration code and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to check for fault codes.

Fault Code 1117 active?
YES NO
No Repair

NOTE: If high inactive counts of Fault Code 1117 are found in the ECM, check the battery disconnect devices in the vehicle. If the keyswitch and ECM power are disconnected at the same time, Fault Code 1117 will be logged.

Go to 1B

Go to 3A

Guided Step 1B - Check for add-on wiring, battery disconnect, or relay on the OEM power harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for add on wiring, battery disconnect, or relay on the OEM power harness.

  • Starting at the (+) battery terminal, check for an add-on device, battery disconnect switch, or relay.

Add-on wiring, battery disconnect, or relay found in the OEM harness?
YES NO

Remove add-on device or make sure power is maintained to the ECM for at least 30 seconds after the keyswitch is turned OFF.

Repair the harness.

  • Refer to the OEM service manual.

 No Repair

Go to 3B

Go to 1C

Guided Step 1C - Check the batteries and the power connection.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals.

Replace the damaged section of the harness.

Refer to the OEM service manual.

Go to 2A

Go to 3B

Guided Step 2 - Check the OEM and engine harnesses.

Guided Step 2A - Inspect the OEM and engine power harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM 4-pin power harness connector from the engine harness.
  • Disconnect the engine 4-pin power harness from the ECM.

Action

Inspect the OEM 4-pin power connector and ECM for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector seals
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected.

Repair or replace the OEM or engine harness, whichever has the damaged pins..

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an open circuit in OEM and engine wiring harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery cables.
  • Disconnect the engine harness 4-pin power connector from the ECM.

Action

Check for an open circuit in the in the OEM and engine wiring harnesses.

  • Measure the resistance from the ECM unswitched battery (+) pins of the ECM 4-pin power connector and the OEM power harness positive battery connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been found in the OEM and/or engine harnesses.

Test the harness connected in series to determine which harness contains the open circuit.

Repair or replace the OEM and/or engine harnesses.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Nov-2012


FAULT CODE 1128 - Engine Mixer Inlet Relative Humidity Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Humidity Sensor | Refer to Procedure 019-356 | ISB5.9G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164596 - male Framatome™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 386. | Fault Code 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1128 active?
STEP 2. | Check the engine throttle intake humidity/temperature sensor and circuit. |
 | STEP 2A. Inspect the engine throttle intake humidity/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Is parameter throttle intake relative humidity sensor signal voltage less than 0.07-VDC and parameter throttle intake relative humidity equal to zero percent in INSITE™ electronic service tool?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1128 active?
STEP 3. | Check the ECM and engine harness connector pins. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Is parameter throttle intake relative humidity sensor signal voltage less than 0.07-VDC and parameter throttle intake relative humidity equal to zero percent in INSITE™electronic service tool?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 386.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 386.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle intake humidity/temperature sensor and circuit.

Guided Step 2A - Inspect the engine throttle intake humidity/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Inspect the engine harness and engine throttle intake humidity/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or replace the sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-356 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine throttle intake humidity SUPPLY pin to the engine throttle intake humidity RETURN pin at the engine throttle intake humidity/temperature sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger compressor intake humidity/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the parameters:

  • Throttle intake relative humidity sensor signal voltage.
  • Throttle intake relative humidity.

NOTE: INSITE™ electronic service tool parameters may be displayed as turbocharger compressor inlet relative humidity sensor signal voltage and turbocharger compressor inlet relative humidity.

Is parameter throttle intake relative humidity sensor signal voltage less than 0.07-VDC and parameter throttle intake relative humidity equal to zero percent in INSITE™ electronic service tool?

YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine turbocharger throttle intake humidity/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 active?
YES NO

A damaged sensor has been detected.

  • Replace the humidity sensor. Refer to Procedure 019-356 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor parameters.

  • Throttle intake relative humidity sensor signal voltage.
  • Throttle intake relative humidity

Note: INSITE™ electronic service tool parameters may be displayed as turbocharger compressor inlet relative humidity sensor signal voltage and turbocharger compressor inlet relative humidity.

Is parameter throttle intake relative humidity sensor signal voltage less than 0.07-VDC and parameter throttle intake relative humidity equal to zero percent in INSITE™ electronic service tool?

YES NO
No Repair

A damaged ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.
  • Disconnect all sensors on the sensor supply.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine throttle intake humidity SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine throttle intake humidity SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine throttle intake humidity SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine throttle intake humidity/temperature SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine throttle intake humidity/temperature RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine throttle intake humidity/temperature RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Nov-2012


FAULT CODE 1239 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for a sensor supply fault code. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1239 inactive?
STEP 2. | Check the accelerator pedal and circuit. |
 | STEP 2A. Inspect the accelerator pedal and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1241 active and Fault Code 1239 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1239 active?
STEP 3. | Check the engine ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the OEM harness. |
 | STEP 3A-2. Check for a pin-to-pin short circuit in the OEM harness. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for a sensor supply fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a sensor supply fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1695

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive and intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the accelerator pedal and circuit.

Guided Step 2A - Inspect the accelerator pedal and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair or replace the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the accelerator pedal supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the accelerator pedal position 2 SUPPLY pin and the accelerator pedal position 2 RETURN pin at accelerator pedal connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active and Fault Code 1239 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active?
YES NO

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

  • Replace the accelerator pedal. Refer to the OEM service manual.

 No Repair

Go to 4B

Go to 4A

Guided Step 3 - Check the engine ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

  • Repair or replace the OEM harness or the ECM, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the pedal position 2 ECM connector pedal position 2 RETURN pin and the OEM harness accelerator pedal connector pedal position 2 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3A-2

Go to 4B

Guided Step 3A-2 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connectors 1 and 2.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal position 2 SIGNAL pin in the engine harness ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the accelerator pedal position 2 SIGNAL pin in the engine harness ECM connector 2 and all other pins in the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Nov-2012


FAULT CODE 1241 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1239 active and Fault Code 1241 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1241 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1696

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the accelerator pedal position 2 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal position 2 sensor supply voltage.

  • Measure the voltage from the accelerator pedal position 2 sensor 5 volt SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the accelerator pedal position 2 sensor 5 volt SUPPLY pin and the accelerator pedal position 2 sensor SIGNAL pin at the sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1239 active and Fault Code 1241 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active?
YES NO

A damaged accelerator pedal has been detected.

  • Replace the accelerator pedal.
  • Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports, as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to the OEM service manual

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM and the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 2 accelerator pedal position 2 SUPPLY pin and the OEM harness accelerator pedal position 2 connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness.
  • Refer to the OEM service manual.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit in the OEM and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 2 accelerator pedal position 2 SIGNAL pin and the OEM harness accelerator pedal connector position 2 SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the SIGNAL wire.

  • Repair or replace the OEM harness.
  • Refer to the OEM service manual.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connectors 1 and 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator pedal position 2 SIGNAL pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the accelerator pedal position 2 SIGNAL pin in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the OEM harness.
  • Refer to the OEM service manual.

Go to 3E

Go to 4B

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the accelerator pedal position 2 SIGNAL pin in the ECM connector 2 and ground.

Use a circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

  • Repair or replace the OEM harness.
  • Refer to the OEM service manual.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Nov-2012


FAULT CODE 1242 - Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active faultcodes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 131, 132, 1239, or 1241 active?
STEP 2. | Check the accelerator pedal position sensor readings. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 132 and 1241 both active?
 | STEP 2C. Check the accelerator pedal position 1 sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the accelerator pedal position 2 sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2E. Check the fault codes. | Fault Code 1242 inactive?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1242 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 131, 132, 1239, or 1241 active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor readings.

Guided Step 2A - Inspect the accelerator pedal and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to the OEM service manual.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 132 and 1241 are both active?
YES NO
No Repair

If Fault Code 132 did not go active, follow Fault Code 132 troubleshooting tree.

If Fault Code 1241 did not go active, follow Fault Code 1241 troubleshooting tree.

Go to 2C

Reference the appropriate fault code troubleshooting tree

Guided Step 2C - Check the accelerator pedal position 1 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position 1 sensor +5 volt SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

Refer to Fault Code 132 troubleshooting tree.

Go to 2D

Fault Code 132 troubleshooting tree

Guided Step 2D - Check the accelerator pedal position 2 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position 2 sensor +5 volt SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

  • Refer to Fault Code 1241 troubleshooting tree.

Go to 2E

Fault Code 1241 troubleshooting tree

Guided Step 2E - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1242 is inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 2.

Action

Inspect the ECM connector 2 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports, as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine and OEM harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1 and 2.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit on the accelerator position 1 circuit.

  • Measure the resistance between the accelerator position 1 sensor SIGNAL pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the accelerator position 1 sensor SIGNAL pin in the ECM connector 2 and all pins in the ECM connector 1.
  • Measure the resistance between the accelerator position 1 sensor SUPPLY pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the accelerator position 1 sensor SUPPLY pin in the ECM connector 2 and all pins in the ECM connector 1.
  • Measure the resistance between the accelerator position 1 sensor RETURN pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the accelerator position 1 sensor RETURN pin in the ECM connector 2 and all pins in the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine and/or OEM harnesses.

  • Test each harness connected in series to determine which harness contains the pin-to-pin short circuit.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit on the accelerator position 2 circuit.

  • Measure the resistance between the accelerator position 2 sensor SIGNAL pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the accelerator position 2 sensor SIGNAL pin in the ECM connector 2 and all pins in the ECM connector 1.
  • Measure the resistance between the accelerator position 2 sensor SUPPLY pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the accelerator position 2 sensor SUPPLY pin in the ECM connector 2 and all pins in the ECM connector 1.
  • Measure the resistance between the accelerator position 2 sensor RETURN pin in the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the accelerator position 2 sensor RETURN pin in the ECM connector 2 and all pins in the ECM connector 1

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine and/or OEM harnesses.

  • Test each harness connected in series to determine which harness contains the pin-to-pin short circuit.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. Refer to the OEM service manual

Go to 3D

Go to 4B

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1242 is inactive?
YES NO
No Repair

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

  • Replace the accelerator pedal. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Nov-2012


FAULT CODE 1654 - Engine Misfire Cylinder 1 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire (Non Shielded)) | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plug (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Ignition Control Module | Refer to Procedure 019-105 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

The coil must be tested in the vertical position or damage to the coil can result.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1654 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the ignition coil connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for voltage at the coil. | Steady spark observed?
 | STEP 2C. Check the spark plug wire. | Spark plug wire damage or wear?
 | STEP 2D. Check the spark plug. | Spark plug damage or wear?
 | STEP 2E. Check the ignition coil for proper operation. | Does the misfire follow the coil pack?
STEP 3. | Check the ICM and ignition harness. |
 | STEP 3A. Check the ICM and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 3C. Check for pin short to ground in the ignition harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 3E. Check for voltage at the coil. | Steady spark observed?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1654 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components

Guided Step 2A - Inspect the coil pack and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the coil pack 1.

Action

Inspect the ignition harness and ignition coil connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for voltage at the coil.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Check the ignition coil for cylinder 1.

  • Test the cylinder 1 coil to determine if the plug is receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, or equivalent, to observe the spark in the observation window

Steady spark observed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2E

Guided Step 2C - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 spark plug wire.

Action

Inspect the spark plug wire for damage and check the resistance.

  • Refer to procedure 013-014 in the Associated Procedures Table.

Spark plug wire damage or wear?
YES NO

A damaged spark plug wire has been detected.

Replace the spark plug wire.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 spark plug.

Action

Inspect the spark plug.

  • Refer to procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the owner’s manual for spark plug maintenance intervals.

Spark plug damage or wear?
YES NO

A damaged spark plug wire has been detected.

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 2E - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Swap the coil packs 1 and 2. Inspect the coils for damage. Do not swap the plug wires

  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Does the misfire follow the coil pack?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ICM and ignition harness.

Guided Step 3A - Check the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinders for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ICM or ignition harness connector.

Repair the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.
  • Disconnect the ignition harness from the ignition coils.

Action

Check for an open circuit in the ignition harness.

  • Measure the resistance between the primary coil cylinder 1 pin in the ignition harness ICM connector and the primary coil cylinder 1 pin in the ignition harness coil pack 1 connector.
  • Measure the resistance between the charge voltage pin the ignition harness ICM connector and the charge voltage pin in the ignition harness coil pack 1 connector.
  • Measure the resistance between the spark return pin in the ignition harness ICM connector and the spark return pin in the ignition harness coil pack 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short to ground in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness from the ICM.
  • Disconnect the ignition harness from coil pack 1 and 2.

Action

Check for a pin-to-ground short in the ignition harness.

  • Measure the resistance between the primary coil cylinder 1 pin in the ignition harness ICM connector and ground.
  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector and ground.
  • Measure the resistance between the spark return in the ignition harness ICM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin short to ground has been detected in the ignition harness.

  • Repair or replace the harness.
  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.
  • Disconnect the ignition harness from coil packs 1 and 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.
  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.
  • Measure the resistance the primary coil cylinder 1 pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been identified in the ignition harness.

  • Repair or replace the harness.
  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3E

Go to 4A

CAUTION

The coil must be tested in the vertical position or damage to the coil can result.
Guided Step 3E - Check for voltage at the coil.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Check for voltage at cylinder 1 ignition coil.

  • Test the cylinder 1 coil to determine if the plug is receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

A damaged ICM has been detected.

  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Nov-2012


FAULT CODE 1655 - Engine Misfire Cylinder 2 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire (Non Shielded) | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plug (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Ignition Control Module | Refer to Procedure 019-105 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

The coil must be tested in the vertical position or damage to the coil can result.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1655 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the ignition coil connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for voltage at the spark plug wire. | Steady spark observed?
 | STEP 2C. Check the spark plug wire. | Spark plug wire damage or wear?
 | STEP 2D. Check the spark plug. | Spark plug damage or wear?
 | STEP 2E. Check the ignition coil for proper operation. | Does the misfire follow the coil pack?
STEP 3. | Check the ICM and ignition harness. |
 | STEP 3A. Check the ICM and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 3C. Check for pin short to ground in the ignition harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 3E. Check for voltage at the coil. | Steady spark observed?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1655 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components

Guided Step 2A - Inspect the coil pack and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the coil pack 1.

Action

Inspect the ignition harness and ignition coil connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for voltage at the coil.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Check for voltage at cylinder 2 ignition coil

  • Test the cylinder 2 ignition coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2E

Guided Step 2C - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 spark plug wire.

Action

Inspect the spark plug wire for damage and check the resistance.

  • Refer to procedure 013-014 in the Associated Procedures Table.

Spark plug wire damage or wear?
YES NO

A damaged spark plug wire has been detected.

Replace the spark plug wire.

  • Refer to Procedure 013-014 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 spark plug.

Action

Inspect the spark plug.

  • Refer to procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the owner’s manual for spark plug maintenance intervals.

Spark plug damage or wear?
YES NO

A damaged spark plug has been detected.

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 2E - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Swap the coil packs 1 and 2. Inspect the coils for damage. Do not swap the plug wires

  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Does the misfire follow the coil pack?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ICM and ignition harness.

Guided Step 3A - Check the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinders for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ICM or ignition harness connector.

Repair the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.
  • Disconnect the ignition harness from the ignition coils.

Action

Check for an open circuit in the ignition harness.

  • Measure the resistance between the primary coil cylinder 2 pin in the ignition harness ICM connector and the primary coil cylinder 2 pin in the ignition harness coil pack 1 connector.
  • Measure the resistance between the charge voltage pin the ignition harness ICM connector and the charge voltage pin in the ignition harness coil pack 1 connector.
  • Measure the resistance between the spark return pin in the ignition harness ICM connector and the spark return pin in the ignition harness coil pack 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short to ground in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness from the ICM.
  • Disconnect the ignition harness from coil pack 1 and 2.

Action

Check for a pin to ground short in the ignition harness.

  • Measure the resistance between the primary coil cylinder 2 pin in the ignition harness ICM connector and ground.
  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector and ground.
  • Measure the resistance between the spark return in the ignition harness ICM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin short to ground has been detected in the ignition harness.

  • Repair or replace the harness, whichever has the damaged pin.
  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.
  • Disconnect the ignition harness from coil packs 1 and 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.
  • Measure the resistance between the spark return pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.
  • Measure the resistance the primary coil cylinder 2 pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been identified in the ignition harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-202or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3E

Go to 4A

CAUTION

The coil must be tested in the vertical position or damage to the coil can result.
Guided Step 3E - Check for voltage at the coil.

Conditions

  • Turn keyswitch ON
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Check for voltage at the cylinder 2 ignition coil

  • Test the cylinder 2 ignition coil to determine if the plug is receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

A damaged ICM has been detected.

  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Nov-2012


FAULT CODE 1656 - Engine Misfire Cylinder 3 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire (Non Shielded) | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plug (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Ignition Control Module | Refer to Procedure 019-105 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

The coil must be tested in the vertical position or damage to the coil can result.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1656 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the ignition coil connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for voltage at the spark plug wire. | Steady spark observed?
 | STEP 2C. Check the spark plug wire. | Spark plug wire damage or wear?
 | STEP 2D. Check the spark plug. | Spark plug damage or wear?
 | STEP 2E. Check the ignition coil for proper operation. | Does the misfire follow the coil pack?
STEP 3. | Check the ICM and ignition harness. |
 | STEP 3A. Check the ICM and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 3C. Check for pin short to ground in the ignition harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 3E. Check for voltage at the coil. | Steady spark observed?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components

Guided Step 2A - Inspect the coil pack and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the coil pack 1.

Action

Inspect the ignition harness and ignition coil connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for voltage at the coil.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Check for voltage at the cylinder 3 ignition coil

  • Test the cylinder 3 ignition coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2E

Guided Step 2C - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 spark plug wire.

Action

Inspect the spark plug wire for damage and check the resistance.

  • Refer to procedure 013-014 in the Associated Procedures Table.

Spark plug wire damage or wear?
YES NO

A damaged spark plug wire has been detected.

Replace the spark plug wire.

  • Refer to Procedure 013-014 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 spark plug.

Action

Inspect the spark plugs.

  • Refer to procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the owner’s manual for spark plug maintenance intervals.

Spark plug damage or wear?
YES NO

A damaged spark plug has been detected.

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 2E - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Swap the coil packs 1 and 2. Inspect the coils for damage. Do not swap the plug wires.

  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Does the misfire follow the coil pack?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ICM and ignition harness.

Guided Step 3A - Check the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinders for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ICM or ignition harness connector.

Repair the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.
  • Disconnect the ignition harness from the ignition coils.

Action

Check for an open circuit in the ignition harness.

  • Measure the resistance between the primary coil cylinder 3 pin in the ignition harness ICM connector and the primary coil cylinder 3 pin in the ignition harness coil pack 1 connector.
  • Measure the resistance between the charge voltage pin the ignition harness ICM connector and the charge voltage pin in the ignition harness coil pack 1 connector.
  • Measure the resistance between the spark return pin in the ignition harness ICM connector and the spark return pin in the ignition harness coil pack 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short to ground in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness from the ICM.
  • Disconnect the ignition harness from coil pack 1 and 2.

Action

Check for a pin to ground short in the ignition harness.

  • Measure the resistance between the primary coil cylinder 3 pin in the ignition harness ICM connector and ground.
  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector and ground.
  • Measure the resistance between the spark return in the ignition harness ICM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin short to ground has been detected in the ignition harness.

  • Repair or replace the harness.
  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.
  • Disconnect the ignition harness from coil packs 1 and 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.
  • Measure the resistance between the spark return pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.
  • Measure the resistance the primary coil cylinder 3 pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been identified in the ignition harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3E

Go to 4A

CAUTION

The coil must be tested in the vertical position or damage to the coil can result.
Guided Step 3E - Check for voltage at the coil.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Check for voltage at the cylinder 3 ignition coil

  • Test the cylinder 3 ignition coil to determine if the plug is receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

A damaged ICM has been detected.

  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Nov-2012


FAULT CODE 1657- Engine Misfire Cylinder 4 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire (Non Shielded) | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plug (Non-Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Ignition Control Module | Refer to Procedure 019-105 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

The coil must be tested in the vertical position or damage to the coil can result.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1657 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the ignition coil connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for voltage at the spark plug wire. | Steady spark observed?
 | STEP 2C. Check the spark plug wire. | Spark plug wire damage or wear?
 | STEP 2D. Check the spark plug. | Spark plug damage or wear?
 | STEP 2E. Check the ignition coil for proper operation. | Does the misfire follow the coil pack?
STEP 3. | Check the ICM and ignition harness. |
 | STEP 3A. Check the ICM and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 3C. Check for pin short to ground in the ignition harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 3E. Check for voltage at the coil. | Steady spark observed?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1657 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components

Guided Step 2A - Inspect the coil pack and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the coil pack 2.

Action

Inspect the ignition harness and ignition coil connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil pack or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for voltage at the coil.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Check for voltage at the cylinder 4 ignition coil

  • Test the cylinder 4 ignition coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2E

Guided Step 2C - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 4 spark plug wire.

Action

Inspect the spark plug wire for damage and check the resistance.

  • Refer to procedure 013-014 in the Associated Procedures Table.

Spark plug wire damage or wear?
YES NO

A damaged spark plug wire has been detected.

Replace the spark plug wire.

  • Refer to Procedure 013-014 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the spark plug.

Conditions

  • Turn keyswitch OFF
  • Remove the cylinder 4 spark plug.

Action

Inspect the spark plug.

  • Refer to procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the owner’s manual for spark plug maintenance intervals.

Spark plug damage or wear?
YES NO

A damaged spark plug has been detected.

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 2E - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Swap the coil packs 1 and 2. Inspect the coils for damage. Do not swap the plug wires

  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Does the misfire follow the coil pack?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ICM and ignition harness.

Guided Step 3A - Check the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinders for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ICM or ignition harness connector.

Repair the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.
  • Disconnect the ignition harness from the ignition coils.

Action

Check for an open circuit in the ignition harness.

  • Measure the resistance between the primary coil cylinder 4 pin in the ignition harness ICM connector and the primary coil cylinder 4 pin in the ignition harness coil pack 1 connector.
  • Measure the resistance between the charge voltage pin the ignition harness ICM connector and the charge voltage pin in the ignition harness coil pack 1 connector.
  • Measure the resistance between the spark return pin in the ignition harness ICM connector and the spark return pin in the ignition harness coil pack 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short to ground in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness from the ICM.
  • Disconnect the ignition harness from coil pack 1 and 2.

Action

Check for a pin-to-ground short in the ignition harness.

  • Measure the resistance between the primary coil cylinder 4 pin in the ignition harness ICM connector and ground.
  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector and ground.
  • Measure the resistance between the spark return in the ignition harness ICM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin short to ground has been detected in the ignition harness.

  • Repair or replace the harness.
  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.
  • Disconnect the ignition harness from coil packs 1 and 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.
  • Measure the resistance between the spark return pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.
  • Measure the resistance the primary coil cylinder 4 pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been identified in the ignition harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3E

Go to 4A

CAUTION

The coil must be tested in the vertical position or damage to the coil can result.
Guided Step 3E - Check for voltage at the coil.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Check for voltage at the cylinder 4 ignition coil

  • Test the cylinder 4 ignition coil to determine if the plug is receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

A damaged ICM has been detected.

  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Nov-2012


FAULT CODE 1658 - Engine Misfire Cylinder 5 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire (Non Shielded) | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plug (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Ignition Control Module | Refer to Procedure 019-105 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

The coil must be tested in the vertical position or damage to the coil can result.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1658 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the ignition coil connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for voltage at the coil. | Steady spark observed?
 | STEP 2C. Check the spark plug wire. | Spark plug wire damage or wear?
 | STEP 2D. Check the spark plug. | Spark plug damage or wear?
 | STEP 2E. Check the ignition coil for proper operation. | Does the misfire follow the coil pack?
STEP 3. | Check the ICM and ignition harness. |
 | STEP 3A. Check the ICM and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 3C. Check for pin short to ground in the ignition harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 3E. Check for voltage at the coil. | Steady spark observed?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1658 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components

Guided Step 2A - Inspect the coil pack and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the coil pack 2.

Action

Inspect the ignition harness and ignition coil connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil pack or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for voltage at the coil.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Check for voltage at the cylinder 5 ignition coil.

  • Test the cylinder 5 ignition coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2E

Guided Step 2C - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 spark plug wire.

Action

Inspect the spark plug wire for damage and check the resistance.

  • Refer to procedure 013-014 in the Associated Procedures Table.

Spark plug wire damage or wear?
YES NO

A damaged spark plug wire has been detected.

Replace the spark plug wire.

  • Refer to Procedure 013-014 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 spark plug.

Action

Inspect the spark plug.

  • Refer to procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the owner’s manual for spark plug maintenance intervals.

Spark plug damage or wear?
YES NO

A damaged spark plug has been detected.

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 2E - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Swap the coil packs 1 and 2. Inspect the coils for damage. Do not swap the plug wires

  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Does the misfire follow the coil pack?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ICM and ignition harness.

Guided Step 3A - Check the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinders for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ICM or ignition harness connector.

Repair the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.
  • Disconnect the ignition harness from the ignition coils.

Action

Check for an open circuit in the ignition harness.

  • Measure the resistance between the primary coil cylinder 5 pin in the ignition harness ICM connector and the primary coil cylinder 5 pin in the ignition harness coil pack 2 connector.
  • Measure the resistance between the charge voltage pin the ignition harness ICM connector and the charge voltage pin in the ignition harness coil pack 2 connector.
  • Measure the resistance between the spark return pin in the ignition harness ICM connector and the spark return pin in the ignition harness coil pack 2 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short to ground in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness from the ICM.
  • Disconnect the ignition harness from coil pack 1 and 2.

Action

Check for a pin-to-ground short in the ignition harness.

  • Measure the resistance between the primary coil cylinder 5 pin in the ignition harness ICM connector and ground.
  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector and ground.
  • Measure the resistance between the spark return in the ignition harness ICM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin short to ground has been detected in the ignition harness.

  • Repair or replace the harness, whichever has the damaged pin.
  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.
  • Disconnect the ignition harness from coil packs 1 and 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.
  • Measure the resistance between the spark return pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.
  • Measure the resistance the primary coil cylinder 5 pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been identified in the ignition harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-202 in Section 19. or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3E

Go to 4A

CAUTION

The coil must be tested in the vertical position or damage to the coil can result.
Guided Step 3E - Check for voltage at the coil.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Check for voltage at the cylinder 5 ignition coil

  • Test the cylinder 5 ignition coil to determine if the plug is receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

A damaged ICM has been detected.

  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Nov-2012


FAULT CODE 1659 - Engine Misfire Cylinder 6 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire (Non Shielded) | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plug (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Ignition Control Module | Refer to Procedure 019-105 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

The coil must be tested in the vertical position or damage to the coil can result.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1659 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the ignition coil connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for voltage at the coil. | Steady spark observed?
 | STEP 2C. Check the spark plug wire. | Spark plug wire damage or wear?
 | STEP 2D. Check the spark plug. | Spark plug damage or wear?
 | STEP 2E. Check the ignition coil for proper operation. | Does the misfire follow the coil pack?
STEP 3. | Check the ICM and ignition harness. |
 | STEP 3A. Check the ICM and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 3C. Check for pin short to ground in the ignition harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 3E. Check for voltage at the coil. | Steady spark observed?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1659 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components

Guided Step 2A - Inspect the coil pack and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the coil pack 2.

Action

Inspect the ignition harness and ignition coil connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil pack or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for voltage at the coil.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Check for voltage at the cylinder 6 ignition coil

  • Test the cylinder 6 ignition coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2E

Guided Step 2C - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 spark plug wire.

Action

Inspect the spark plug wire for damage and check the resistance.

  • Refer to procedure 013-014 in the Associated Procedures Table.

Spark plug wire damage or wear?
YES NO

A damaged spark plug wire has been detected.

Replace the spark plug wire.

  • Refer to Procedure 013-014 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 spark plug.

Action

Inspect the spark plug.

  • Refer to procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the owner’s manual for spark plug maintenance intervals.

Spark plug damage or wear?
YES NO

A damaged spark plug has been detected.

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 2E - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Swap the coil packs 1 and 2. Inspect the coils for damage. Do not swap the plug wires.

  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Does the misfire follow the coil pack?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ICM and ignition harness.

Guided Step 3A - Check the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinders for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ICM or ignition harness connector.

Repair the harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.
  • Disconnect the ignition harness from the ignition coils.

Action

Check for an open circuit in the ignition harness.

  • Measure the resistance between the primary coil cylinder 6 pin in the ignition harness ICM connector and the primary coil cylinder 6 pin in the ignition harness coil pack 2 connector.
  • Measure the resistance between the charge voltage pin the ignition harness ICM connector and the charge voltage pin in the ignition harness coil pack 2 connector.
  • Measure the resistance between the spark return pin in the ignition harness ICM connector and the spark return pin in the ignition harness coil pack 2 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short to ground in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness from the ICM.
  • Disconnect the ignition harness from coil pack 1 and 2.

Action

Check for a pin to ground short in the ignition harness.

  • Measure the resistance between the primary coil cylinder 6 pin in the ignition harness ICM connector and ground.
  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector and ground.
  • Measure the resistance between the spark return in the ignition harness ICM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin short to ground has been detected in the ignition harness.

Repair or replace the harness, with the damaged pin.

  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.
  • Disconnect the ignition harness from coil packs 1 and 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.
  • Measure the resistance between the spark return pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.
  • Measure the resistance the primary coil cylinder 6 pin in the ignition harness ICM connector 1 and all other pins in the ignition harness connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been identified in the ignition harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-202 or Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 3E

Go to 4A

CAUTION

The coil must be tested in the vertical position or damage to the coil can result.
Guided Step 3E - Check for voltage at the coil.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Check for voltage at the cylinder 6 ignition coil

  • Test the cylinder 6 ignition coil to determine if the plug is receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

A damaged ICM has been detected.

  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Nov-2012


FAULT CODE 1695 - Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1695 active?
STEP 2. | Check the ECM and OEM harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check the sensor supply 5 supply voltage. | Voltage greater than 5.63-VDC?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect OEM harness ECM connector 2.

Action

Inspect the ECM and the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to the OEM service manual.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the engine coolant level sensor.
  • Disconnect the remote accelerator position sensor from the OEM harness (if equipped).

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY 5 pin at the ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the sensor SUPPLY 5 pin at the ECM connector 2 and all other pins in the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harnes.

  • Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the sensor supply 5 supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage at the coolant level sensor.

  • Measure the voltage between the sensor supply 5 pin in the OEM harness coolant level sensor and the sensor return 2 pin in the OEM harness coolant level sensor.

Voltage greater than 5.63-VDC??
YES NO
No Repair

A damaged sensor supply circuit has been detected in the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find thepresent ECM code and revision number in the ECM.The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete.

Go to 1A

Last Modified: 09-Nov-2012


FAULT CODE 1696 - Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1696 active?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the accelerator pedal and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1696 active?
 | STEP 2C. Inspect the remote accelerator pedal and connector. | Dirty or damaged pins?
 | STEP 2D. Check the circuit response. | Fault Code 1696 active?
 | STEP 2E. Inspect coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2F. Check the circuit response. | Fault Code 1696 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short to ground short in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update is available for this fault code, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the accelerator pedal and connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Inspect the OEM harness and accelerator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the OEM service manual.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 1696 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the sensor. Refer to the OEM service manual.

Go to 2C

Go to 4B

Guided Step 2C - Inspect the remote accelerator pedal and connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal from the OEM harness.

Action

Inspect the OEM harness and remote accelerator pedal connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: If the unit is not equipped with a remote accelerator, go to step 2E.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the OEM service manual.

 No Repair

Go to 4B

Go to 2D

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the sensor. Refer to the OEM service manual.

Go to 2E

Go to 4B

Guided Step 2E - Inspect the coolant level sensor and connector.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the sensor. Refer to the OEM service manual.

 No Repair

Go to 4B

Go to 2F

Guided Step 2F - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the sensor. Refer to the OEM service manual.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the OEM harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the engine harness, OEM harness, or the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connectors 1 and 2.
  • Disconnect all sensors on sensor supply 5 from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 5 pin in the engine harness ECM connector 2 to all other pins in the ECM connector 1.
  • Measure the resistance between the sensor SUPPLY 5 pin in the engine harness ECM connector 2 to all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to the OEM service manual.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-ground short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connector 2.
  • Disconnect all sensors on sensor supply 5 from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor supply 5 pin in the harness ECM connector 2 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short has been detected in the OEM harness.

Replace the OEM harness.

  • Refer to the OEM service manual.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete.

Go to 1A

Last Modified: 09-Nov-2012


FAULT CODE 1827 - Engine Gas Control Valve Intake Pressure - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Fuel Pressure/Temperature Sensor | Refer to Procedure 019-153 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 227. | Fault Code 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1827 active?
STEP 2. | Check the engine fuel regulator outlet pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel regulator outlet pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1828 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1827 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 1827 active?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 227.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1827 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel regulator outlet pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel regulator outlet pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and fuel pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-053 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine fuel regulator outlet pressure SUPPLY pin to the engine fuel regulator outlet pressure RETURN pin at the engine fuel regulator outlet pressure/temperature sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1828 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel regulator outlet pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1827 active?
YES NO

A damaged sensor has been detected.

  • Replace the fuel pressure sensor. Refer to Procedure 019-153 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1828 active?
YES NO
No Repair

A damaged ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.
  • Disconnect all sensors on the sensor supply.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine fuel regulator outlet pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel regulator outlet pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine fuel regulator outlet pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel regulator outlet pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine fuel regulator outlet pressure RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine fuel regulator outlet pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Nov-2012


FAULT CODE 1828 - Engine Gas Control Valve Intake Pressure - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Fuel Pressure/Temperature Sensor | Refer to Procedure 019-153 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1828 active?
STEP 2. | Check the engine fuel regulator outlet pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel regulator outlet pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1827 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1828 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1828 active?
 | STEP 3F. Check the ECM response. | Fault Code 1827 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 352.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1828 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel regulator outlet pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel regulator outlet pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and fuel regulator outlet pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-153 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine fuel regulator outlet pressure SUPPLY pin to the engine fuel regulator outlet pressure RETURN pin at the engine fuel regulator outlet pressure/temperature sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 to 5.25 -VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine fuel regulator outlet pressure SUPPLY pin and the engine fuel regulator outlet pressure SIGNAL pin at the engine fuel regulator outlet pressure/temperature sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1827 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel regulator outlet pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1828 active?
YES NO

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-153 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 engine fuel regulator outlet pressure RETURN pin and the engine fuel regulator outlet pressure RETURN pin of the engine fuel regulator outlet pressure/temperature sensor connector.
  • Measure the resistance between the ECM connector 1 engine fuel regulator outlet pressure SUPPLY pin and the engine fuel regulator outlet pressure SUPPLY pin at the engine fuel regulator outlet pressure/temperature sensor connector.
  • Measure the resistance between the ECM connector 1 engine fuel regulator outlet pressure SIGNAL pin and the engine fuel regulator outlet pressure SIGNAL pin in the engine fuel regulator outlet pressure/temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.
  • Disconnect all sensors on the sensor supply.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine fuel regulator outlet pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel regulator outlet pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine fuel regulator outlet pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel regulator outlet pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine fuel regulator outlet pressure RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine fuel regulator outlet pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to ground short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine fuel regulator outlet pressure SIGNAL pin in the ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4B

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1828 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3F

Go to 4A

Guided Step 3F - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine harness.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine fuel regulator outlet pressure SUPPLY pin and the engine fuel regulator outlet pressure SIGNAL pin at the engine fuel regulator outlet pressure/temperature sensor connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1827 active?
YES NO
No Repair

A damaged ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Nov-2012


FAULT CODE 1839 - Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Fuel Pressure/Temperature Sensor | Refer to Procedure 019-153 | ISB5.9 G CM2180 | 2883369
Fuel Pressure Sensor | Refer to Procedure 019-188 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 227. | Fault Code 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1839 inactive?
STEP 2. | Check the engine fuel regulator intake pressure sensor and circuit. |
 | STEP 2A. Inspect the engine fuel regulator intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1841 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1839 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 1841 active?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 227.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 227.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1839 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel regulator intake pressure sensor and circuit.

Guided Step 2A - Inspect the fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness .

Action

Inspect the engine harness and engine fuel regulator intake pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness.
  • Turn keyswitch ON

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine fuel regulator intake pressure SUPPLY pin to the engine fuel regulator intake pressure RETURN pin at the engine fuel regulator intake pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC??
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1841 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel regulator intake pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1839 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-153 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1841 active?
YES NO
No Repair

A damaged ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1 and 2.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness.
  • Disconnect all sensors on the sensor supply.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine fuel regulator intake pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel regulator intake pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine fuel regulator intake pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel regulator intake pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine fuel regulator intake pressure RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine fuel regulator intake pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Nov-2012


FAULT CODE 1841 - Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Fuel Pressure/Temperature Sensor | Refer to Procedure 019-153 | ISB5.9 G CM2180 | 2883369
Fuel Pressure Sensor | Refer to Procedure 019-188 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1841 active?
STEP 2. | Check the engine fuel regulator intake pressure sensor and circuit. |
 | STEP 2A. Inspect the engine fuel regulator intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1839 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1841 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short in the engine harness . | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1841 active?
 | STEP 3F. Check the ECM response. | Fault Code 1839 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1841 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel regulator intake pressure sensor and connector pins.

Guided Step 2A - Inspect the engine fuel regulator intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness .

Action

Inspect the engine harness and engine fuel regulator intake pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine fuel regulator intake pressure SUPPLY pin to the engine fuel regulator intake pressure RETURN pin at the engine fuel regulator intake pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine fuel regulator intake pressure SUPPLY pin and the engine fuel regulator intake pressure SIGNAL pin at the engine fuel regulator intake pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1839 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel regulator intake pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1841 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-153 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connectors.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 engine fuel regulator intake pressure RETURN pin and the engine fuel regulator intake pressure RETURN pin of the engine fuel regulator intake pressure sensor connector.
  • Measure the resistance between the ECM connector 1 engine fuel regulator intake pressure SUPPLY pin and the engine fuel regulator intake pressure SUPPLY pin at the engine fuel regulator intake pressure sensor connector.
  • Measure the resistance between the ECM connector 1 engine fuel regulator intake pressure SIGNAL pin and the engine fuel regulator intake pressure SIGNAL pin in the engine fuel regulator intake pressure sensor connector

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness.
  • Disconnect all sensors in sensor supply.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine fuel regulator intake pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel regulator intake pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine fuel regulator intake pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine fuel regulator intake pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine fuel regulator intake pressure RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine fuel regulator intake pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-ground short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine fuel regulator intake pressure SIGNAL pin in the ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-ground short has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the connectors. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4B

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1841 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3F

Go to 4A

Guided Step 3F - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel regulator intake pressure sensor from the engine harness.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine fuel regulator intake pressure SUPPLY pin and the engine fuel regulator intake pressure SIGNAL pin at the engine fuel regulator intake pressure sensor connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1839 active?
YES NO
No Repair

A damaged ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM Calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Nov-2012


FAULT CODE 1858 - Aftertreatment Intake Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Heated Oxygen Sensor | Refer to Procedure 019-100 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code | Fault Code 1858 active?
STEP 2. | Check the inline module. |
 | STEP 2A. Check the engine harness and inline module connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 1859 active and 1858 inactive?
 | STEP 2C. Check the circuit response and verify module condition. | Fault code 1858 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Less than 100K ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Less than 100K ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1858 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the inline module.

Guided Step 2A - Inspect the engine harness and inline module connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the inline module from the engine harness.

Action

Inspect the engine harness and inline module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: There is a 3 ampere fuse located in the switched battery supply in the inline module. Verify that that the fuse holder is not contaminated and that the fuse is not blown.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the inline module fuse. Refer to Procedure 019-198 in Section 19.
  • Repair the harness. Refer to Procedure 019-214 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the inline module. Refer to Procedure 019-100 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the inline module from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the circuit response after 30 seconds.

  • Place a jumper wire from the inline module low range oxygen SIGNAL pin to the inline module low range oxygen RETURN pin at the inline module low range oxygen connector.
  • Place a jumper wire from the inline module high range oxygen SIGNAL pin to the inline module high range oxygen RETURN pin at the inline module high range oxygen connector.

Use INSITE™ electronic service tool to read the fault codes.

Fault code 1859 active and 1858 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response and verify module condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the inline module to the engine harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1858 active?
YES NO

A damaged inline module has been detected.

Replace the inline module. Refer to Procedure 019-100 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: Do not spray contact cleaner directly into the ECM ports, as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the inline module from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the inline module low range oxygen SIGNAL pin in the engine harness ECM connector 1 and the inline module low range oxygen SIGNAL pin in the engine harness inline module low range oxygen connector.
  • Measure the resistance between the inline module low range oxygen RETURN pin in the engine harness ECM connector 1 and the inline module low range oxygen RETURN pin in the engine harness inline module low range oxygen connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connecter 1.
  • Disconnect the inline module from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the inline module high range oxygen SIGNAL pin in the engine harness inline ECM connector 1 and the inline module high range oxygen SIGNAL pin in the engine harness inline module high range oxygen connector.
  • Measure the resistance between the inline module high range oxygen RETURN pin in the engine harness ECM connector 1 and the inline module high range oxygen RETURN pin in the engine harness inline module high range oxygen connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. or Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the inline module from the engine harness.
  • Disconnect the engine coolant temperature sensor, gas mass flow sensor, and the ignition control module from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the inline module low range oxygen SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance from the inline module low range oxygen SIGNAL pin in the ECM connector 1 to all other pins in the ECM connector 2.
  • Measure the resistance between the inline module low range oxygen RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the inline module low range oxygen RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the inline module from the engine harness.
  • Disconnect the engine coolant temperature sensor, gas mass flow sensor, and the ignition control module from the engine harness.

Action

Check for a short circuit from pin-to-\pin.

  • Measure the resistance between the inline module high range oxygen SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the inline module high range oxygen SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the inline module high range oxygen RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the inline module high range oxygen RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. or Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Nov-2012


FAULT CODE 1859 - Aftertreatment Intake Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Heated Oxygen Sensor | Refer to Procedure 019-100 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

Do not touch the aftertreatment inlet oxygen concentration sensor until it has cooled. The aftertreatment inlet oxygen concentration sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the aftertreatment inlet oxygen concentration sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1859 active?
STEP 2. | Check the inline module. |
 | STEP 2A. Check the engine harness and inline module connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 1859 active and 1858 inactive?
 | STEP 2C. Check the circuit response and verify module condition. | Fault code 1858 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1859 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the engine harness. | Greater than 10 ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the engine harness. | Greater than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Less than 100K ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Less than 100K ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code 1858 inactive?

Guided Step 1 - Check for an active fault code

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1859 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the inline module.

Guided Step 2A - Inspect the engine harness and inline module connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the inline module from the engine harness.

Action

Inspect the engine harness and inline module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: There is a 3 ampere fuse located in the switched battery supply in the inline module. Verify that the fuse holder is not contaminated and that the fuse is not blown.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the inline module or harness connector.

Repair or replace the engine harness, or replace the module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the fuse. Refer to Procedure 019-198 in Section 19.
  • Repair the harness. Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the inline module. Refer to Procedure 019-100 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the inline module from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1858 active and 1859 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response and verify module condition

Conditions

  • Turn keyswitch OFF.
  • Connect the inline module from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes

Fault code 1859 active?
YES NO

A damaged inline module has been detected.

Replace the inline module. Refer to Procedure 019-100 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the engine harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM.
  • Disconnect the inline module from the engine harness.

Action

Check for a pin-to-ground short circuit in the engine harness.

  • Measure the resistance from the inline module high range oxygen SIGNAL pin in the connector 1 to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the ECM connector 1.
  • Disconnect the inline module from the engine harness.

Action

Check for a pin-to-ground short circuit in the engine harness.

  • Measure the resistance from the inline module low range oxygen SIGNAL pin in the connector 1 to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the inline module from the engine harness.
  • Disconnect the engine coolant temperature sensor, gas mass flow sensor, and the ignition control module from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the inline module high range oxygen SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the inline module high range oxygen SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the inline module high range oxygen RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the inline module high range oxygen RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the inline module from the engine harness.
  • Disconnect the engine coolant temperature sensor, gas mass flow sensor, and the ignition control module from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the inline module low range oxygen SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the inline module low range oxygen SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the inline module low range oxygen RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the inline module low range oxygen RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Nov-2012


FAULT CODE 1919 - Engine Mixer Intake Relative Humidity - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Humidity Sensor | Refer to Procedure 019-356 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164596 - male Framatome™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Read the fault codes. | Fault Code 1919 active?
STEP 2. | Check the engine throttle intake humidity/temperature sensor and circuit. |
 | STEP 2A. Inspect the engine throttle intake humidity/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1128 active and Fault Code 1919 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 and/or 386 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352 and/or 386

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1919 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle intake humidity/temperature sensor and circuit.

Guided Step 2A - Inspect the engine throttle intake humidity/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger intake humidity/temperature sensor from the engine harness.

Action

Inspect the engine harness and engine throttle intake humidity/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair the connectors. Refer to Procedure 019-218 in Section 19.
  • Replace the sensor. Refer to Procedure 019-356 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the humidity SUPPLY pin and the humidity RETURN pin at the humidity sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger intake humidity/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the humidity SUPPLY pin and the engine turbocharger intake humidity/temperature sensor SIGNAL pin at the engine turbocharger intake humidity/temperature sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 active and Fault Code 1919 inactive?
YES NO

A damaged sensor has been detected.

Replace the engine turbocharger intake humidity/temperature sensor. Refer to Procedure 019-356 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins for the folowing:

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 humidity SUPPLY pin and the engine throttle intake humidity/temperature sensor connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the connectors. Refer to Procedure 019-218 in Section 19.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 humidity SIGNAL pin and the engine harness engine throttle intake humidity/temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the connectors. Refer to Procedure 019-218 in Section 19.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 1.
  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4B

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM connector 1 and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Nov-2012


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2185 inactive?
STEP 2. | Check the ECM and OEM harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check the sensor supply 2 supply voltage. | Voltage greater than 5.63-VDC?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connector 1 and connector 2.
  • Disconnect all components connected to sensor supply number 4.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the sensor SUPPLY 4 pin in ECM connector 2 to all other pins in ECM connector 2.
  • Measure the resistance from the sensor SUPPLY 4 pin in ECM connector 2 to all pins in ECM connector 1.

Refer to the circuit diagram or wiring harness for connector pin identification.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor SUPPLY number 4 wire has been detected in the OEM harness.

  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2C

Go to 3B

Guided Step 2C - Check the sensor supply 4 supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness
  • Turn keyswitch ON

Action

Check for the sensor supply voltage at the ECM.

  • Measure the voltage between the sensor supply 4 pin in the OEM harness accelerator position sensor connector and the sensor return 4 pin in the OEM harness accelerator position sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 5.63-VDC?
YES NO

A damaged sensor supply circuit has been detected in the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Nov-2012


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
OEM Wiring Harness | Refer to Procedure 019-071 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead..

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the accelerator pedal and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 2186 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short to ground in the OEM harness | Greater than 100k ohms?
 | STEP 3D. Check the sensor supply 4 voltage. | Voltage below 4.42-VDC?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the accelerator pedal and connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.
  • Replace the sensor. Refer to the OEM service manual.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 2186 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to the OEM Service Manual.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1 and connector 2.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

A damaged connection has been detected in the ECM or harness connector.
YES NO

Repair or replace the OEM harness or the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connectors 1 and 2.
  • Disconnect all sensors on sensor supply 4 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the sensor SUPPLY 4 pin in the ECM connector 2 and all other pins in the ECM connector 1.
  • Measure the resistance from the sensor SUPPLY 4 pin in the ECM connector 2 and all pins in the ECM connector 2.

Refer to the circuit diagram or wiring harness for connector pin identification.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM connector 2.
  • Disconnect all sensors on sensor supply 4 from the OEM harness

Action

Check for a pin short to ground.

  • Measure the resistance between the sensor supply 4 pin in the ECM connector 2 and ground.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin short to ground has been detected in the OEM harness.

Repair or replace the OEM harness

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4B

Guided Step 3D - Check the sensor supply 4 voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage at the ECM.

  • Measure the voltage between the sensor supply 4 pin in the OEM harness accelerator pedal position sensor connector and the sensor return 4 pin in the OEM harness accelerator pedal position sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage below 4.42-VDC?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Nov-2012


FAULT CODE 2187 - Exhaust Back Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | ISB5.9 G CM2180 | 2883369
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Air/Fuel Mixer | Refer to Procedure 005-003 | ISB5.9 G CM2180 | 2883369
Charge-Air Cooler | Refer to Procedure 005-027 | ISB5.9 G CM2180 | 2883369
Turbocharger | Refer to Procedure 010-033 | ISB5.9 G CM2180 | 2883369
Exhaust Restriction | Refer to Procedure 011-009 | ISB5.9 G CM2180 | 2883369
Engine Testing (Chassis Dynamometer) | Refer to Procedure 014-012 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Heated Oxygen Sensor | Refer to Procedure 019-100 | ISB5.9 G CM2180 | 2883369
Gas Mass Flow Sensor | Refer to Procedure 019-101 | ISB5.9 G CM2180 | 2883369
Fuel Control Valve | Refer to Procedure 019-102 | ISB5.9 G CM2180 | 2883369
Exhaust Back Pressure Sensor | Refer to Procedure 019-347 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2187 active?
STEP 2. | Check the exhaust back pressure sensor. |
 | STEP 2A. Inspect the exhaust back pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor accuracy. | Exhaust back pressure (absolute) read atmospheric pressure?
 | STEP 2C. Inspect the back pressure sensing hardware for cracked fittings, plugging, or leaks. Verify back pressure measurement location. | Hardware failure or installation issue found?
 | STEP 2D. Check the exhaust back pressure. | Pressure between 61 to 127 mm Hg [2.4 to 5.0 in Hg]?
STEP 3. | Check for excessive oil consumption. |
 | STEP 3A. Check for oil residue in the turbocharger compressor outlet plumbing. | Oil residue present?
 | STEP 3B. Check for oil residue in the charge-air cooler outlet. | Oil residue present?
 | STEP 3C. Check for oil residue in the turbocharger turbine outlet. | Oil residue present?
 | STEP 3D. Inspect the valve stem seals. | Damaged, cracked, wrong, or improperly installed valve stem seals?
STEP 4. | Check air to fuel ratio control. |
 | STEP 4A. Check the overhead set. | Valve lash out of specification?
 | STEP 4B. Check compressor oil carryover. | Excessive compressor oil carryover in the fuel system.
 | STEP 4C. Check the fuel mixer housing. | Fuel mixer incorrect or venturi sleeve not seated properly?
 | STEP 4D. Check for a stuck open fuel control valve. | Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/-100 precent and mass gas flow compensation (percent) at +/-100 precent?
 | STEP 4E. Check the fuel control valve for proper operation. | Does mass gas flow error (lb/hr) exceed +/-1.5 lb/hr?
 | STEP 4F. Check for a stuck closed fuel control valve. | Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/-100 percent and mass gas flow compensation (percent) at +/-100 precent?
STEP 5. | Check combustion chamber sealing. |
 | STEP 5A. Check cylinder leak down. | Does cylinder pass leak down test?
STEP 6. | Check the exhaust back pressure. |
 | STEP 6A. Check the exhaust back pressure. | Pressure between 61 to 127 mm Hg [2.4 to 5.0 in Hg]?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2187 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2D

Guided Step 2 - Check the exhaust back pressure sensor.

Guided Step 2A - Inspect the exhaust back pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the exhaust back pressure sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Use electronic contact cleaner, Part Number 3824510, to flush the dirt, debris, or moisture from the connector pins.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-347 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Use the local weather station data to obtain ambient atmospheric pressure.

Action

Verify the sensor accuracy.

  • Use INSITE™ electronic service tool to verify the sensor accuracy.

NOTE: Convert psia to in. Hg. by multiplying by 2.036.

Exhaust back pressure (absolute) read atmospheric pressure?
YES NO
No Repair

Verify the sensing tube is free of blockage and replace the sensor.

  • Replace the sensor. Refer to Procedure 019-347 in the Associated Procedures Table.

Go to 2C

Go to 6A

Guided Step 2C - Inspect the back pressure sensing hardware for cracked fittings, plugging, or leaks. Verify back pressure measurement location.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the sensing hardware and measurement location.

  • Inspect the back pressure sensing hardware for cracked fittings, plugging, or leaks. Verify the back pressure measurement location is correct.

Hardware damage or installation issue found?
YES NO

Repair or replace the damaged components, or correct the exhaust back pressure measurement location.

 No Repair

Go to 6A

Go to 2D

Guided Step 2D - Check the exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust back pressure.

  • Measure the exhaust restriction. Refer to Procedure 011-009 in the Associated Procedures Table.
  • Make sure the back pressure tube is free from blockage.

Pressure between 61 to 127 mm Hg [2.4 to 5.0 in Hg]?
YES NO
No Repair

Remove the catalyst and utilize piping to restrict to required back pressure.

Go to 6A

Go to 3A

Guided Step 3 - Check for excessive oil consumption.

Guided Step 3A - Check for oil residue in the turbocharger compressor outlet plumbing.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger outlet pipe.

Action

Check for oil residue.

  • Check for oil residue in the turbocharger compressor outlet plumbing.

Oil residue present?
YES NO

A damaged turbocharger has been detected. Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3C

Guided Step 3B - Check for oil residue in the charge-air cooler outlet.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet pipe.

Action

Check for oil residue in the charge-air cooler outlet.

  • Disconnect the charge-air cooler outlet pipe.

Oil residue present?
YES NO

Clean the charge-air cooler.

  • Remove and clean the intake piping. Refer to Procedure 010-027 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 3C - Check for oil residue in the turbocharger turbine outlet.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger turbine piping.

Action

Check the turbocharger turbine outlet.

  • Check for oil residue in the turbocharger turbine outlet.

Oil residue present?
YES NO

The turbocharger is the source of oil.

  • Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.
  • Replace the oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3D

Guided Step 3D - Inspect the valve stem seals.

Conditions

  • Turn keyswitch OFF.

Action

Remove the valve covers

  • Inspect the valve stem seals. Refer to Procedure 002-004 in the Associated Procedures Table.

Damaged, cracked, wrong, or improperly installed valve stem seals?
YES NO

Replace the valve stem seals. Clean the exhaust system of any oil residue.

  • Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check air to fuel ratio control.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.

Action

Remove the valve cover.

  • Check the overhead set. Refer to Procedure 003-004 in the Associated Procedures Table.

Valve lash out of specification?
YES NO

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for oil carry over.

Conditions

  • Turn keyswitch OFF.

Action

Check for oil carry over.

  • Remove the fuel system components downstream of the fuel filter and check for excessive compressor oil carryover in the fuel system.

Excessive compressor oil carryover in the fuel system?
YES NO

Replace the fuel system screen pack and the gas mass flow sensor.

  • Refer to Procedure 019-101 in the Associated Procedures Table.
  • Clean the fuel system of compressor oil contamination.
  • Make sure the fuel filter drain interval is in accordance with the maintenance schedule.

 No Repair

Go to 6A

Go to 4C

Guided Step 4C - Check the fuel mixer housing.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the fuel shutoff valve is installed properly and check for debris on the screen.

  • Verify the o-ring sealing, snap ring is installed, the mixer part number and orientation are correct, and the set screw is properly installed behind the gas mass flow sensor to hold the flow venturi in place.

Fuel mixer incorrect or venturi sleeve not seated properly?

YES NO

Replace or repair the fuel mixer.

  • Refer to Procedure 005-003 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to log Aftertreatment Gas Oxidation Catalyst Intake Oxygen Compensation (Percent) and Mass Gas Flow Compensation (Percent) at idle for 2 minutes.

Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/-100 precent and mass gas flow compensation (percent) at +/-100 precent?

YES NO

A damaged fuel control valve has been detected.

  • Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4E

Guided Step 4E - Check the fuel control valve for proper operation.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check the fuel control valve for proper operation.

  • Start the engine and let it idle for 1 minute.
  • Connect INSITE™ electronic service tool to log Mass Air Flow (lb/hr) AND Mass Gas Flow Error (lb/hr) at idle for 30 seconds.
  • Mass Air Flow (lb/hr) must not fluctuate more than 140 lb/hr for this test to be valid.

Does mass gas flow error (lb/hr) exceed +/-1.5 lb/hr?
YES NO

A damaged fuel control valve has been detected.

  • Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4F

Guided Step 4F - Check for a stuck closed fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck closed fuel control valve.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to log Aftertreatment Gas Oxidation Catalyst Intake Oxygen Compensation (Percent) and Mass Gas Flow Compensation (Percent) at Rated power for 30 seconds.

Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/-100 precent and mass gas flow compensation (percent) at +/-100 precent?

YES NO

A damaged fuel control valve has been detected.

  • Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check combustion chamber sealing.

Guided Step 5A - Check cylinder leak down.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine compression.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

Does cylinder pass leak down test?
YES NO
No Repair

Repair the engine as necessary.

Go to 6A

Go to 6A

Guided Step 6 - Check the exhaust back pressure.

Guided Step 6A - Check the exhaust back pressure.

Conditions

  • Turn keyswitch OFF
  • Remove the test piece installed in Step 2D.
  • Install the original catalyst.

Action

Check the exhaust back pressure.

  • Refer to Procedure 011-009 in the Associated Procedures Table.
  • Make sure the back pressure tube is free from blockage.

Pressure between 61 to 127 mm Hg [2.4 to 5.0 in Hg]?
YES NO
No Repair

Inspect the oxidation catalyst and/or muffler, and replace according to the manufacturer's instructions.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Nov-2012


FAULT CODE 2189 - Throttle Plate Leaking - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | ISB5.9 G CM2180 | 2883369
Throttle Actuator | Refer to Procedure 019-097 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine idle speed. |
 | STEP 1A. Use INSITE™ electronic service tool to check the engine idle speed. | 700 to 900 rpm?
 | STEP 1B. Check for air leaks in the air intake system. | Air leaks?
 | STEP 1C. Check for an active fault code. | Fault Code 2189 active?
 | STEP 1D. Check the throttle actuator. | Did actuator pass the test?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2189 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine idle speed.

Guided Step 1A - Use INSITE™ electronic service tool to check the engine idle speed.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the engine idle speed.

  • Use INSITE™ electronic service tool to read the engine idle speed.

700 to 900 rpm?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for air leaks in the air intake system.

Conditions

  • Turn keyswitch ON.

Action

Check for air leaks near all gasket surfaces between the throttle actuator and where the intake meets the block. Check all pipe plugs for leaks or missing components.

  • Start the engine and let it idle
  • Listen for air leaks while engine is operating.

Air leaks?
YES NO

Locate all damaged gaskets or components and replace accordingly.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2189 active?
YES NO

Replace the throttle actuator.

  • Refer to Procedure 019-097 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check the throttle actuator

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform throttle actuator test.

  • Use INSITE™ electronic service tool to perform the throttle actuator test and confirm the actuator is operating.

Did actuator pass test?
YES NO
No Repair

Replace the throttle actuator.

  • Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2189 is inactive.

Fault Code 2189 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Nov-2012


FAULT CODE 2219 - Heated Oxygen Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Heated Oxygen Sensor | Refer to Procedure 019-100 | ISB5.9 G CM2180 | 2883369
Fuel Control Valve | Refer to Procedure 019-102 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Codes 453, 454, 455, 511, 1654-1659, 2586-2598, 2723, or 2991 active?
STEP 2. | Check the engine harness and engine turbocharger outlet sensor. |
 | STEP 2A. Check for a stuck open fuel control valve. | Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/- 100 percent and mass gas flow compensation (percent) at +/- 100 percent?
 | STEP 2B. Check the fuel control valve for proper operation. | Does mass gas flow error (lb/hr) exceed +/-1.5 lb/hr?
 | STEP 2C. Check for a stuck closed fuel control valve | Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/- 100 percent and mass gas flow compensation (percent) at +/- 100 percent?
STEP 3. | Check oil consumption. |
 | STEP 3A. Check for excessive oil consumption. | Excessive oil consumption?
STEP 4. | Check for an alternate fuel source or air contaminants. |
 | STEP 4A. Check for alternate fuel source or air contaminants. | Alternate fuel source or air contaminants.?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for gas mass flow sensor, fuel control valve, and misfire faults.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 453, 454, 455, 511, 1654-1659, 2586-2598, 2723, or 2991 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1858 or Fault Code 1859.

Go to 2A

Guided Step 2 - Check the fuel control valve.

Guided Step 2A - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to log aftertreatment gas oxidation catalyst intake oxygen compensation (percent) and mass gas flow compensation (percent) at idle for 2 minutes.

Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/- 100 percent and mass gas flow compensation (percent) at +/- 100 percent?

YES NO

A damaged fuel control valve has been detected. Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve for proper operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Start the engine and let it idle for 1 minute.

  • Connect INSITE™ electronic service tool to log mass air flow (lb/hr) and mass gas flow error (lb/hr) at idle for 30 seconds.

NOTE: Mass air flow (lb/hr) at idle must be stable for this test to be valid. Consider the engine to have a stable idle if maximum mass air flow minus mass air flow is less than 140 lb/hr.

Does mass gas flow error (lb/hr) exceed +/-1.5 lb/hr?
YES NO

A damaged fuel control valve has been detected. Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a stuck closed fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to log aftertreatment gas oxidation catalyst intake oxygen compensation (percent) and mass gas flow compensation (percent) at rated power for 30 seconds.

Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/- 100 percent and mass gas flow compensation (percent) at +/- 100 percent?

YES NO

A damaged fuel control valve has been detected. Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check oil consumption.

Guided Step 3A - Check for excessive oil consumption.

Conditions

  • Turn keyswitch OFF.

Action

Check for excessive oil consumption.

  • Reference the Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS in the ISB5.9 G CM2180 Service Manual, Bulletin 2883369.

Excessive oil consumption?
YES NO

  • Reference the Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS in the ISB5.9 G CM2180 Service Manual, Bulletin 2883369.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check for an alternate fuel source or air contaminants.

Guided Step 4A - Check for alternate fuel source or air contaminants.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for an alternate fuel source or an excess of hydrocarbons in the air.

  • Interview the operator to see if he recognized an alternate fuel source or air contaminants while in a motoring state.

NOTE: Air contaminants over time can cause the oxygen sensor to misread oxygen content in the air. If this occurs, the fuel tables can become inaccurate and cause poor open loop performance.

Alternate fuel source or air contaminants?
YES NO

Reset the fueling tables. Use INSITE™ electronic service tool to reset the fuel tables.

The engine must not be operated in the presence of combustible vapors.

Replace the turbocharger outlet oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault codes inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Nov-2012


FAULT CODE 2221 - Heated Oxygen Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Exhaust Restriction | Refer to Procedure 011-009 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Heated Oxygen Sensor | Refer to Procedure 019-100 | ISB5.9 G CM2180 | 2883369
Fuel Control Valve | Refer to Procedure 019-102 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Codes 453, 454, 455, 511, 1654-1659, 2586-2598, 2722, 2723, or 2991 active?
 | STEP 1B. Check for an active fault code.. | Fault Code 2219 active?
STEP 2. | Check the engine harness and engine turbocharger outlet oxygen sensor. |
 | STEP 2A. Inspect the in-line module and engine turbocharger outlet oxygen sensor connector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness and in-line module connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the in-line module voltage supply and ground. | Voltage between 11.0 to 14.0- VDC?
 | STEP 2D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms??
 | STEP 2E. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 3. | Check the fuel control valve. |
 | STEP 3A. Check for a stuck open fuel control valve. | Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/-100% and mass gas flow compensation (percent) at +/-100%
 | STEP 3B. Check the fuel control valve for proper operation. | Does mass gas flow error (lb/hr) exceed +/-1.5 lb/hr?
STEP 4. | Check the exhaust system. |
 | STEP 4A. Check for high exhaust back pressure. | Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
STEP 5. | Check oil consumption. |
 | STEP 5A. Check for excessive oil consumption. | Excessive oil consumption?
 | STEP 5B. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for gas mass flow sensor, fuel control valve, and misfire faults.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 453, 454, 455, 511, 1654-1659, 2586-2598, 2722, 2723, or 2991 active?
YES | NO
No Repair | No Repair

Troubleshoot the appropriate fault code.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine harness and engine turbocharger outlet oxygen sensor.

Guided Step 2A - Inspect the in-line module and engine turbocharger outlet oxygen sensor connector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine turbocharger outlet oxygen sensor from the in-line module.

Action

Inspect the in-line module and engine turbocharger outlet oxygen sensor connector pins for the following:.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the in-line module and engine turbocharger outlet oxygen sensor connector.

Repair or replace the in-line module, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the in-line module. Refer to Procedure 019-100 in the Associated Procedures Table.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Inspect the engine harness and in-line module connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the in-line module from the engine harness.
  • Disconnect the 4 pin switched power connector from the ECM.

Action

Inspect the ECM connector 1 and in-line module connector pins for the following:.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: There is a 3 ampere fuse located in the switched battery supply in the in-line module. Verify that the fuse holder is not contaminated and that the fuse is not blown.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the in-line module, ECM, or engine harness

Repair or replace the in-line module, ECM, or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the in-line module. Refer to Procedure 019-100 in the Associated Procedures Table.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2C

Guided Step 2C - Check the in-line module voltage supply and ground.

Conditions

  • Disconnect the engine harness from the engine turbocharger outlet oxygen in-line module.
  • Turn keyswitch ON.

Action

Check the in-line module voltage supply and ground.

  • Measure the voltage between the in-line module SUPPLY pin and the in-line module RETURN pin in the in-line module power connector.

Voltage between 11.0 and 14.0-VDC?
YES NO
No Repair

An open circuit in the engine harness or OEM harness has been detected. Test the harnesses connected in series to determine which harness contains the open circuit.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2D

Go to 6A

Guided Step 2D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1 and connector 2.
  • Disconnect the in-line module from the engine harness.
  • Disconnect the engine coolant temperature sensor, gas mas flow sensor, and ignition control module from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the in-line module high range oxygen SIGNAL pin in the engine harness ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the in-line module high range oxygen RETURN pin in the engine harness ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the in-line module low range oxygen SIGNAL pin in the engine harness ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the in-line module low range oxygen RETURN pin in the engine harness ECM connector 1 and all other pins in the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 6A

Guided Step 2E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the fuel control valve.

Guided Step 3A - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to log aftertreatment gas oxidation catalyst intake oxygen compensation (percent) and mass gas flow compensation (percent) at idle for 2 minutes.

Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/- 100 percent and mass gas flow compensation (percent) at +/- 100 percent?

YES NO

A damaged fuel control valve has been detected. Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the fuel control valve for proper operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Connect INSITE™ electronic service tool to log mass air flow (lb/hr) and mass gas flow error (lb/hr) at idle for 30 seconds.
  • Mass air flow (lb/hr) at idle must be stable for this test to be valid. Consider engine to have a stable idle if maximum mass air flow minus minimum mass air flow is less than 140 lb/hr.

Does mass gas flow error (lb/hr) exceed +/-1.5 lb/hr?
YES NO

A damaged fuel control valve has been detected.

  • Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the exhaust systems.

Guided Step 4A - Check for high exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system for higher than specified exhaust back pressure.

  • Check the exhaust back pressure by installing a pressure gauge into the exhaust system just past the turbocharger outlet.
  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
YES NO
No Repair

Troubleshoot Fault Code 2187 for high exhaust back pressure.

Go to 5A

Go to 6A

Guided Step 5 - Check oil consumption.

Guided Step 5A - Check for excessive oil consumption.

Conditions

  • Turn keyswitch OFF.

Action

Check for excessive oil consumption.

  • Reference the Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS in the ISB5.9 G CM2180 Service Manual, Bulletin 2883369.

Excessive oil consumption?
YES NO

  • Reference the Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS in the ISB5.9 G CM2180 Service Manual, Bulletin 2883369.

No Repair

Go to 5A

Go to 5B

Guided Step 5B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES NO
No Repair

  • Replace the engine turbocharger outlet oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault codes inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Nov-2012


FAULT CODE 2229 - Heated Oxygen Sensor - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Heated Oxygen Sensor | Refer to Procedure 019-100 | ISB5.9 G CM2180 | 2883369
Fuel Control Valve | Refer to Procedure 019-102 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Code 1858 or 1859 active?
STEP 2. | Check the fuel control valve. |
 | STEP 2A. Check for a stuck open fuel control valve. | Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/-100 percent and mass gas flow compensation (percent) at +/-100 percent?
 | STEP 2B. Check the fuel control valve for proper operation. | Does mass gas flow error (lb/hr) exceed +/-1.5 lb/hr?
 | STEP 2C. Check for a stuck closed fuel control valve | Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/-100 percent and mass gas flow compensation (percent) at +/-100 percent?
STEP 3. | Check oil consumption. |
 | STEP 3A. Check for excessive oil consumption. | Excessive oil consumption?
STEP 4. | Check for air contaminants. |
 | STEP 4A. Check for alternate fuel source or air contaminants. | Alternate fuel source or air contaminants?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1858 or 1859 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1858 or Fault Code 1859

Go to 2A

Guided Step 2 - Check the fuel control valve.

Guided Step 2A - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute

  • Use INSITE™ electronic service tool to log aftertreatment gas oxidation catalyst intake oxygen compensation (percent) and mass gas flow compensation (percent) at idle for 2 minutes.

Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/-100 percent and mass gas flow compensation (percent) at +/-100 percent?

YES NO

A damaged fuel control valve has been detected.

  • Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve for proper operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Connect INSITE™ electronic service tool to log mass air flow (lb/hr) and mass gas flow error (lb/hr) at idle for 30 seconds.

Mass air flow (lb/hr) at idle must be stable for this test to be valid. Consider the engine to have a stable idle if the maximum air flow minus the minimum mass air flow is less than 140 lb/hr.

Does mass gas flow error (lb/hr) exceed +/-1.5 lb/hr?
YES NO

A damaged fuel control valve has been detected.

  • Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a stuck closed fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to log aftertreatment gas oxidation catalyst intake oxygen compensation (percent) and mass gas flow compensation (percent) at rated power for 30 seconds.

Is aftertreatment gas oxidation catalyst intake oxygen compensation (percent) at +/-100 percent and mass gas flow compensation (percent) at +/-100 percent?

YES NO

A damaged fuel control valve has been detected.

  • Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check oil consumption.

Guided Step 3A - Check for excessive oil consumption.

Conditions

  • Turn keyswitch OFF.

Action

Check for excessive oil consumption.

  • Reference the Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS in the ISB5.9 G CM2180 Service Manual, Bulletin 2883369.

Excessive oil consumption?
YES NO

  • Reference the Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS in the ISB5.9 G CM2180 Service Manual, Bulletin 2883369.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check for air contaminants.

Guided Step 4A - Check for alternate fuel source or air contaminants.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for an alternate fuel source or an excess of hydrocarbons in the air.

  • Interview the operator to see if he recognized an alternate fuel source or contaminant while in a motoring state.

Note: Air contaminants over time can cause the oxygen sensor to misread oxygen content in the air. If this occurs, the fuel tables can become inaccurate and cause poor open loop performance.

Alternate fuel source or air contaminants?
YES NO

Reset the fueling tables. Use INSITE™ electronic service tool to reset the fuel tables.

Engine must not be operated in the presence of combustible vapors.

Replace the engine turbocharger outlet oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Nov-2012


FAULT CODE 2286 - Engine Multiple Cylinder Spark Voltage Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369
Ignition Control Module | Refer to Procedure 019-105 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2286 inactive?
STEP 2. | Check the ignition control module (ICM) and ignition harness. |
 | STEP 2A. Inspect the ICM ignition harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 2B-1. Check for an open circuit in the ignition harness. |
 | STEP 2C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 2E. Check for an inactive fault code. | Fault Code 2286 inactive?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2286 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ICM ignition harness.

Guided Step 2A - Inspect ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the ignition harness connector C1 and connector C2 from the ICM.

Action

Inspect the ignition harness and ICM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ICM or ignition harness connectors.

Repair or replace the ignition harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the ignition harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector C2 from the ICM.
  • Disconnect ignition harness from all coils.

Action

Check for an open circuit for each cylinder coil connector line.

  • Measure the resistance between the ignition harness ICM connector C2 coil SIGNAL pin and the ignition harness coil connector SIGNAL pin.
  • Measure the resistance between the ignition harness ICM connector C2 CD voltage pin and the ignition harness coil connector CD voltage pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the ignition harness.

Repair or replace the ignition harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector C2 from the ICM.
  • Disconnect ignition harness from all coils.

Action

Check for an open circuit.

  • Measure the resistance between the ignition harness ICM connector spark RETURN SIGNAL pin and the ignition harness coil connector RETURN SIGNAL pins.

NOTE: All spark return signal wires in the ignition harness are tied together. This way there will be continuity through each spark signal pin of each coil to the main spark return signal wire at the ignition harness connector C2. If one of the spark signal circuits is found to be open, then the ICM will think that the engine is misfiring when it is not.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open signal circuit has been detected in the ignition harness.

Repair or replace the ignition harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-ground short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness connector C2 from the ICM.
  • Disconnect the ignition harness from all coils.

Action

Check for a pin to ground short for each cylinder coil connector.

  • Measure the resistance between the CD voltage pin at the coil connector and engine block ground.
  • Measure the resistance between the coil SIGNAL pin at the coil connector and engine block ground.
  • Measure the resistance between the spark SIGNAL pin at the coil connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the ignition harness.

Repair or replace the ignition harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector C2 from the ICM.
  • Disconnect ignition harness from the ignition coils.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the CD voltage pin in the ignition harness ICM connector C2 and all other pins in the ignition harness connector C2.
  • Measure the resistance between the spark RETURN SIGNAL pin in the ignition harness ICM connector C2 and all other pins in the ignition harness connector C2.
  • Measure the resistance between each coil SIGNAL pin in the ignition harness ICM connector C2 and all other pins in the ignition harness connector C2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the ignition harness.

Repair or replace the ignition harness. Refer to Procedure 013-037 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start engine and let idle.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2286 inactive?
YES NO

None. The removal and installation of the connectors corrected the fault.

  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedures Table.

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Nov-2012


FAULT CODE 2287 - Engine Multiple Cylinder Spark Voltage Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Ignition Control Module | Refer to Procedure 019-105 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2287 active?
STEP 2. | Check the ignition control module (ICM). |
 | STEP 2A. Inspect the ICM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 2287 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check the ECM for active fault codes. | Fault Code 2287 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2287 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition control module (ICM).

Guided Step 2A - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ignition control module.

Action

Inspect the ICM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or ICM connector.

Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedure Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2287 active?
YES NO
No Repair

None. The removal and installation of the connectors corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1 and connector 2.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM or ICM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in the Associated Procedure Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect engine harness ECM connector 1.

Action

Check for an open circuit.

  • Measure the resistance between the spark voltage SIGNAL pin in the ECM connector 1 and the spark voltage SIGNAL pin in the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness ECM connector 1.

Action

Check for a short circuit to ground.

  • Measure the resistance from the spark voltage SIGNAL pin at the ECM connector 1 to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect engine harness ECM connector 1 and connector 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between spark voltage SIGNAL pin in the ECM connector 1 and to all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

Go to 3E

Go to 4B

Guided Step 3E - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2287 inactive?
YES NO
No Repair

  • Replace the ICM. Refer to Procedure 019-105 in the Associated Procedure Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of the troubleshooting procedure

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Nov-2012


FAULT CODE 2321 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 689 active or has a high number of inactive counts?
STEP 2. | Check the engine camshaft speed/position sensor 1. |
 | STEP 2A. Inspect the engine camshaft speed/position sensor 1. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the engine camshaft speed/position sensor 1 circuit at the engine harness ECM connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Fault Code 2321 become active during engine operation?
 | STEP 3B. Inspect the air gap and camshaft gear. | Distance is between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 2321 status change from inactive to active while manipulating the engine harness?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 is active or has a high number of inactive counts?

NOTE: If Fault Code 689 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the engine camshaft speed/position sensor 1.

YES | NO
No Repair | No Repair

Refer to Fault Code 689 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine camshaft speed/position sensor 1.

Guided Step 2A - Inspect the engine camshaft speed/position sensor 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.

Action

Inspect the engine harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine camshaft speed/position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.

Action

Closely inspect the engine harness near the engine camshaft speed/position sensor 1.

  • Check for places where the wire harness insulation is damaged, allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2C

Guided Step 2C - Inspect the engine camshaft speed/position sensor 1 circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor 1 from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Check for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the engine camshaft speed/position sensor 1 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. With the engine running, accelerate the engine several times.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2321 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect the air gap and camshaft gear.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine camshaft speed/position sensor 1 from the engine.

Action

Verify adequate air gap.

  • Measure the distance between the sensor mounting surface and the edge of the camshaft gear at several points in the camshaft's revolution. Refer to Procedure 019-363 in the Associated Procedures Table.

Distance is between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]?
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the camshaft gear runout is excessive, replace the camshaft gear.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2321 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backwards from the ECM connector towards the engine camshaft speed/position sensor 1 connector.

Does Fault Code 2321 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19. or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Nov-2012


FAULT CODE 2322 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Camshaft Gear (Camshaft Removed) | Refer to Procedure 001-013 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 778 active or has high number of inactive counts?
STEP 2. | Check the engine camshaft speed/position sensor 2. |
 | STEP 2A. Inspect the engine camshaft speed/position sensor 2 connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the engine camshaft speed/position sensor 2 circuit at the engine harness connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Fault Code 2322 become active during engine operation?
 | STEP 3B. Inspect the air gap and camshaft gear. | Distance is between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Fault Code 2322 status change from inactive to active while manipulating the engine harness?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 is active or has a high number of inactive counts?

NOTE: If Fault Code 778 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the engine camshaft speed/position sensor 2.

YES | NO
No Repair | No Repair

Refer to Fault Code 778 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine camshaft speed/position sensor 2.

Guided Step 2A - Inspect the engine camshaft speed/position sensor 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor 2 from the engine harness.

Action

Inspect the engine harness and engine camshaft speed/position sensor 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-220 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine camshaft speed/position sensor 2. Refer to Procedure 019-363 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor 2 from the engine harness.

Action

Closely inspect the engine harness near the engine camshaft speed/position sensor 2.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the engine camshaft speed/position sensor 2 circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor 2 from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Check for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

A damaged connection has been detected in the engine harness connector.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the engine camshaft speed/position sensor 2 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

With the engine running, accelerate the engine several times.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2322 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect the air gap and camshaft gear.

Conditions

  • Turn keyswitch OFF.
  • Disconect the engine camshaft speed/position sensor 2 from the engine harness.
  • Remove the engine camshaft speed/position sensor 2.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify adequate air gap.

  • Measure the distance between the sensor mounting surface and the edge of the camshaft gear at several points in the camshaft's revolution.

Refer to Procedure 019-363 in the Associated Procedures Table.

Distance is between 28.74 mm [1.13 in] and 29.96 mm [1.17 in]?
YES NO
No Repair

Inspect the camshaft tone wheel (camshaft gear) for damage or spinning. Refer to Procedure 001-013 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2322 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backward from the ECM connector toward the engine speed sensor connector.

Fault Code 2322 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

  • Repair the engine harness. Refer to Procedure 019-220 in Section 19. or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Nov-2012


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2377 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control solenoid. | Greater than 3 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the fan control solenoid. | Greater than 100 ohms?
 | STEP 2D. Check for an open circuit in the fan control solenoid. | Less than 10 ohms?
 | STEP 2E. Check for an active fault code. | Fault Code 2377 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 is active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the OEM harness or solenoid.

Repair or replace the OEM harness, or replace the solenoid, whichever has the damaged pins.

  • Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pins of the fan control solenoid connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3 ohms?
YES NO
No Repair

A damaged solenoid has been detected.

Replace the fan control solenoid. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on the fan control solenoid.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A damaged fan control solenoid has been detected.

Replace the fan control solenoid. Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check fan control solenoid resistance.

  • Measure the resistance between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the fan control solenoid has been detected.

Replace the fan control solenoid. Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports, as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine and OEM harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector 2.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 2 fan clutch output SIGNAL pin and the OEM harness fan control solenoid connector fan clutch output SIGNAL pin.
  • Measure the resistance between the ECM connector 2 fan clutch output RETURN pin and the OEM harness fan control solenoid connector fan clutch output RETURN pin.

NOTE: Certain OEMs may use a solenoid return that is wired to the ECM or may use a return that goes to engine block or chassis ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fan control solenoid circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the ECM connector 2 fan clutch output SIGNAL pin and all other pins in the ECM connector 2.
  • Measure the resistance between the ECM connector 2 fan clutch output SIGNAL pin and all pins in the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM connector 2.
  • Disconnect the fan control solenoid for the OEM harness.

Action

Check for pin-to-ground short.

  • Measure the resistance between the ECM connector 2 fan clutch output SIGNAL pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the engine and/or OEM harness.

  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of the troubleshooting procedure

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Nov-2012


FAULT CODE 2431 - Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Air Compressor | Refer to Procedure 012-014 | ISB5.9 G CM2180 | 2883369
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 572 active?
 | STEP 1B. Check for existing fault codes other than knock sensor fault codes. | Active fault codes other than knock sensor fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 2431 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor. | Any knock sensor damage?
 | STEP 2B. Check for an ignition-related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for in-cylinder damage. | Evidence of damage?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock sensor fault occurred.

  • Use INSITE™ electronic service tool to check for active fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 572

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock sensor fault occurred.

  • Check for existing fault codes other than knock sensor fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s).

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock sensor fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2431 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components.

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 1 from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation, such as torqued improperly
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition-related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Go to Section 8 (Ignition System Troubleshooting Procedures) in the Performance Troubleshooting tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

Repair or replace the damaged components.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the wastegate functioning properly?
YES NO
No Repair

A damaged turbocharger wastegate has been detected. Replace the turbocharger actuator.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust overhead.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

Turn keyswitch OFF.

Action

Check the air compressor timing.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Air Compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected. Time the air compressor.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2F - Check for in-cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 spark plug.

Action

Inspect for in-cylinder damage:

  • Use a borescope to inspect cylinder 1 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Nov-2012


FAULT CODE 2432 - Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Air Compressor | Refer to Procedure 012-014 | ISB5.9 G CM2180 | 2883369
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 572 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 2432 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor. | Any knock sensor damage?
 | STEP 2B. Check for an ignition-related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for in-cylinder damage. | Evidence of damage?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to check for active fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 572

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2432 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components.

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 1 from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation, such as torqued improperly
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedure Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition-related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Go to Section 8 (Ignition System Troubleshooting Procedures) in the Performance Troubleshooting tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

Repair or replace the damaged components.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the wastegate functioning properly?
YES NO
No Repair

A damaged turbocharger wastegate has been detected. Replace the turbocharger wastegate actuator.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust overhead.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

Turn keyswitch OFF.

Action

Check the air compressor timing.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Air Compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected. Time the air compressor.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2F - Check for in-cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 spark plug.

Action

Inspect for in-cylinder damage:

  • Use a borescope to inspect cylinder 2 for knock damage.

Evidence of damage?
YES NO

Replace the any damaged components.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Nov-2012


FAULT CODE 2433 - Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Air Compressor | Refer to Procedure 012-014 | ISB5.9 G CM2180 | 2883369
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 572 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 2433 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for in-cylinder damage. | Evidence of damage?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 572

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2433 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 1 from the engine harness.

Action

Inspect the knock sensor for the following..

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation, such as torqued improperly
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Washers or p-clips can NOT be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Go to Step 8 (Ignition System Troubleshooting Procedures) in the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition-related problem has been detected.

  • Repair or replace the damaged components. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the wastegate functioning properly?
YES NO
No Repair

A damaged turbocharger wastegate has been detected. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Air Compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected.

  • Set the air compressor timing. Refer to Procedure 012-014 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2F - Check for in-cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 spark plug.

Action

Inspect for in-cylinder damage.

  • Use a bore scope to inspect cylinder 3 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the Conditions for Clearing the Fault Code found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Nov-2012


FAULT CODE 2434 - Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Air Compressor | Refer to Procedure 012-014 | ISB5.9 G CM2180 | 2883369
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 573 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 2434 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for in cylinder damage. | Evidence of damage?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 573 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 573

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2434 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 2 from the engine harness.

Action

Inspect the knock sensor for the following..

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation, such as torqued improperly
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Washers or p-clips can NOT be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Go to Step 8 (Ignition System Troubleshooting Procedures) in the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition-related problem has been detected.

  • Repair or replace the damaged components. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the wastegate functioning properly?
YES NO
No Repair

A damaged turbocharger wastegate has been detected. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Air Compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected.

  • Set the air compressor timing. Refer to Procedure 012-014 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2F - Check for in-cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 4 spark plug.

Action

Inspect for in-cylinder damage.

  • Use a bore scope to inspect cylinder 4 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the Conditions for Clearing the Fault Code found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Nov-2012


FAULT CODE 2435 - Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Air Compressor | Refer to Procedure 012-014 | ISB5.9 G CM2180 | 2883369
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 573 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 2435 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for in cylinder damage. | Evidence of damage?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 573 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 573

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2435 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 2 from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation, such as torqued improperly
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Washers or p-clips can NOT be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Go to Step 8 (Ignition System Troubleshooting Procedures) in the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

  • Repair or replace the damaged components. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the wastegate functioning properly?
YES NO
No Repair

A damaged turbocharger wastegate has been detected. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Air Compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected.

  • Set the air compressor timing. Refer to Procedure 012-014 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2F - Check for in-cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 spark plug.

Action

Inspect for in-cylinder damage.

  • Use a bore scope to inspect cylinder 5 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the Conditions for Clearing the Fault Code found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Nov-2012


FAULT CODE 2436 - Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Air Compressor | Refer to Procedure 012-014 | ISB5.9 G CM2180 | 2883369
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Knock Sensor | Refer to Procedure 019-346 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 573 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 2436 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for in cylinder damage. | Evidence of damage?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 573 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 573

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2436 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 2 from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation, such as torqued improperly
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Washers or p-clips can NOT be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Go to Step 8 (Ignition System Troubleshooting Procedures) in the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

  • Repair or replace the damaged components. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the wastegate functioning properly?
YES NO
No Repair

A damaged turbocharger wastegate has been detected. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing.

  • Refer to Procedure 012-014 in the Associated Procedures Table.

Air Compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected.

  • Set the air compressor timing. Refer to Procedure 012-014 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2F - Check for in-cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 spark plug.

Action

Inspect for in-cylinder damage.

  • Use a bore scope to inspect cylinder 6 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the Conditions for Clearing the Fault Code found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Nov-2012


FAULT CODE 2517 - Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Mixer Inlet Pressure Sensor | Refer to Procedure 019-098 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 358 | Fault Code 358 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2517 active?
STEP 2. | Check the engine throttle intake pressure sensor and circuit. |
 | STEP 2A. Inspect the engine throttle intake pressure sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2C. Check for circuit response. | Fault Code 2518 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2517 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check ECM response. | Fault Code 2518 active?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 358.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 358 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 358

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2517 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle intake pressure sensor and circuit.

Guided Step 2A - Inspect the engine throttle intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.

Action

Inspect the engine harness and engine throttle intake pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-098 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine throttle intake pressure SUPPLY pin to the engine throttle intake pressure RETURN pin at the engine throttle intake pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2518 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine throttle intake pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2517 active?
YES NO

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-098 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2518 active?
YES NO
No Repair

A damaged ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1 and 2.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.
  • Disconnect all sensors on sensor supply 2, and sensor return 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine throttle intake pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine throttle intake pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine throttle intake pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine throttle intake pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine throttle intake pressure RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine throttle intake pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the Conditions for Clearing the Fault Code found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Nov-2012


FAULT CODE 2518 - Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Mixer Inlet Pressure Sensor | Refer to Procedure 019-098 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 352. | Fault Code 352 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2518 active?
STEP 2. | Check the engine throttle intake pressure sensor and circuit. |
 | STEP 2A. Inspect the engine throttle intake pressure sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2C. Check for circuit response. | Fault Code 2517 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2518 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | More than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 2518 active?
 | STEP 3F. Check ECM response. | Fault Code 2517 active?
STEP 4. | Check ECM calibration code and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 352.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor SUPPLY fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2518 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle intake pressure sensor and circuit.

Guided Step 2A - Inspect the engine throttle intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.

Action

Inspect the engine harness and engine throttle intake pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-098 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the SUPPLY pin and the engine throttle intake pressure RETURN pin at the engine throttle intake pressure sensor connector of the engine harness.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine throttle intake pressure SUPPLY pin and the engine throttle intake pressure SIGNAL pin at the engine throttle intake pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2517 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine throttle intake pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2518 active?
YES NO

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-098 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine throttle intake pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 engine throttle intake pressure RETURN pin and the engine throttle intake pressure RETURN pin of the engine throttle intake pressure sensor connector.
  • Measure the resistance between the ECM connector 1 engine throttle intake pressure SUPPLY pin and the engine throttle intake pressure SUPPLY pin at the engine throttle intake pressure sensor connector.
  • Measure the resistance between the ECM connector 1 engine throttle intake pressure SIGNAL pin and the engine throttle intake pressure SIGNAL pin in the engine throttle intake pressure sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.
  • Disconnect all sensors in sensor supply 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine throttle intake pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine throttle intake pressure SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine throttle intake pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine throttle intake pressure SUPPLY pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine throttle intake pressure RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine throttle intake pressure RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the engine throttle intake pressure SIGNAL pin in the ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin short to ground has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4B

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2518 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3F

Go to 4A

Guided Step 3F - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine throttle intake pressure SUPPLY pin and the engine throttle intake pressure SIGNAL pin at the engine throttle intake pressure sensor connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2517 active?
YES NO
No Repair

A damaged ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the Conditions for Clearing the Fault Code found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Nov-2012


FAULT CODE 2568 - Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
High Pressure Regulator, NG | Refer to Procedure 005-061 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Fuel Pressure Sensor | Refer to Procedure 019-188 | ISB5.9 G CM2180 | 2883369
Fuel Pressure Sensor Circuit | Refer to Procedure 019-394 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 1839 or 1841 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2568 active?
STEP 2. | Check the engine fuel regulator intake pressure sensor. |
 | STEP 2A. Inspect the engine fuel regulator intake pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify the engine fuel regulator intake pressure sensor reading. | Fuel pressure within 5 percent?
STEP 3. | Check the ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1839 or 1841 active?
YES | NO
No Repair | No Repair

Go to Appropriate Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2568 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel regulator intake pressure sensor.

Guided Step 2A - Inspect the engine fuel regulator intake pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine fuel regulator intake pressure sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-394 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Verify the engine fuel regulator intake pressure sensor reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical gauge. Refer to Procedure 005-061 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge against the fuel pressure measurement value displayed in INSITE™ electronic service tool.
  • Engine fuel regulator intake pressure sensor may be displayed in INSITE™ electronic service tool as fuel supply pressure sensor or similar.

NOTE: Fuel pressure is displayed in absolute in INSITE™ electronic service tool. The Compucheck™ fitting located on the fuel housing is used to measure engine (low pressure) regulator outlet pressure.

Fuel pressure within 5 percent?
YES NO

An original equipment manufacturer (OEM) fuel delivery issue has been detected.

Troubleshoot the OEM fuel system. Refer to the OEM service manual.

Replace the fuel pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of the system ID and Dataplate in Features and Parameters.

If a Calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine with in the Conditions for Clearing the Fault Code found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2571 - Engine Charge-Air Cooler Outlet Temperature - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2571 active?
STEP 2. | Check the engine throttle intake humidity/temperature sensor and circuit. |
 | STEP 2A. Inspect the engine throttle intake humidity/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Sensor resistance between 227k ohms and 963 ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2571 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 2571 active?
 | STEP 3E. Check the circuit response at the ECM. | Fault Code 2572 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2571 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle intake humidity/temperature sensor and circuit.

Guided Step 2 - Inspect the engine throttle intake humidity/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Inspect the engine harness and engine throttle intake humidity/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine throttle intake temperature SIGNAL pin and the engine throttle intake temperature RETURN pin at the engine throttle intake humidity/temperature sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Sensor resistance between 227k ohms and 963 ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine throttle intake humidity/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2571 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness ECM connector 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damage connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 engine throttle intake temperature RETURN pin and the engine harness engine throttle intake temperature RETURN pin in the engine harness engine throttle intake humidity/temperature sensor connector.
  • Measure the resistance between the ECM connector 1 engine throttle intake temperature SIGNAL pin and the engine harness engine throttle intake temperature SIGNAL pin in the engine harness engine throttle intake humidity/temperature sensor connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine throttle intake temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine throttle intake temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine throttle intake temperature RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine throttle intake temperature RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2571 active?
YES NO
No Repair

None. The removal and installation of the connectors corrected the fault.

Go to 3E

Go to 4A

Guided Step 3E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine throttle intake temperature SIGNAL pin and the engine throttle intake temperature RETURN pin at the engine throttle intake humidity/temperature sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2572 active?
YES NO
No Repair

A damaged ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2572 - Engine Charge-Air Cooler Outlet Temperature - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault codes. | Fault Code 2572 active?
STEP 2. | Check the engine throttle intake humidity/temperature sensor and circuit. |
 | STEP 2A. Inspect the engine throttle intake humidity/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Sensor resistance between 227k ohms and 963 ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2572 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short to ground in the engine harness | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 2572 active?
 | STEP 3E. Check the circuit response at the ECM. | Fault Code 2571 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2572 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle intake humidity/temperature sensor and circuit.

Guided Step 2 - Inspect the engine throttle intake humidity/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Inspect the engine harness and engine throttle intake humidity/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine throttle intake temperature SIGNAL pin and the engine throttle intake temperature RETURN pin at the engine throttle intake humidity/temperature sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Sensor resistance between 227k ohms and 963 ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine throttle intake humidity/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2572 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness ECM connector 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 2.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damage connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage can result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the engine throttle intake pressure/temperature SIGNAL pin in the ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin short to ground has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-218 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connectors 1 and 2.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine throttle intake temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine throttle intake temperature SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine throttle intake temperature RETURN pin in the ECM connector 1 and all other pins in the ECM engine connector 1.
  • Measure the resistance between the engine throttle intake temperature RETURN pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-218 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2572 active?

YES NO
No Repair

None. The removal and installation of the connectors corrected the fault.

Go to 3E

Go to 4A

Guided Step 3E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake humidity/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2571 active?
YES NO
No Repair

A damaged ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2586 - Engine Spark Plug Number 1 (A1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2586 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the spark plug wire. | Spark plug wire resistance between 2k and 7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2586 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect coil pack number 1 from the ignition harness.
  • Disconnect the ICM from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ignition control harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following prcedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 spark plug.

Action

Check the spark plug wire resistance.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Spark plug wire resistance between 2k and 7k ohms?
YES NO
No Repair

A damaged spark plug wire has been detected

Replace the spark plug wire. Refer to Procedure 013-014 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 1.

  • Test the cylinder 1 coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2587 - Engine Spark Plug Number 2 (B1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for active fault codes. | Fault Code 2587 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the spark plug wire. | Spark plug wire resistance between 2k and 7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2587 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coil pack number 1 from the ignition harness.
  • Disconnect the ICM from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil, or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 spark plug wire.

Action

Check the spark plug wire resistance.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Spark plug wire resistance between 2k and 7k ohms?
YES NO
No Repair

A damaged spark plug wire has been detected.

  • Replace the spark plug wire. Refer to Procedure 013-014 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil for cylinder 2.

  • Test the cylinder 2 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

  • Replace the ignition coil. Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2588 - Engine Spark Plug Number 3 (A2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2588 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the spark plug wire. | Spark plug wire resistance between 2k and 7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2588 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coil pack number 1 from the ignition harness
  • Disconnect the ICM from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ignition control harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 spark plug wire.

Action

Check the spark plug wire resistance.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Spark plug wire resistance between 2k and 7k ohms?
YES NO
No Repair

A damaged spark plug wire has been detected.

Replace the spark plug wire. Refer to Procedure 013-014 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 3.

  • Test the cylinder 3 coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-016 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2589 - Engine Spark Plug Number 4 (B2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault code 2589 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the spark plug wire. | Spark plug wire between 2k and 7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2589 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the number 2 coil pack from the ignition harness.
  • Disconnect the ICM from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil, or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the number 4 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Refer to Procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the maintenance manual for spark plug maintenance intervals.

Spark plug damaged or excessive gap?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the number 4 spark plug wire.

Action

Check the spark plug wire resistance.

  • Measure the resistance of the number 4 spark plug wire.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Spark plug wire resistance between 2k and 7k ohms?
YES NO
No Repair

A damaged spark plug wire has been detected.

  • Replace the spark plug wire. Refer to Procedure 013-014 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Install ignition coil test kit, Part Number 4918343.

Action

Check the ignition coil for cylinder 4.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Test the cylinder 4 coil to determine if the plug is receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2591 - Engine Spark Plug Number 5 (A3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2591 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the spark plug wire. | Spark plug wire between 2k and 7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2591 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the number 2 coil pack from the ignition harness.
  • Disconnect the ICM from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the number 5 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Refer to Procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the maintenance manual for spark plug maintenance intervals.

Spark plug damaged or excessive gap?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the number 5 spark plug wire.

Action

Check the spark plug wire resistance.

  • Measure the resistance of the number 5 spark plug wire.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Spark plug wire resistance between 2k and 7k ohms?
YES NO
No Repair

A damaged spark plug wire has been detected.

  • Replace the spark plug wire. Refer to Procedure 013-014 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Install ignition coil test kit, Part Number 4918343.

Action

Check the ignition coil for cylinder 5.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Test the cylinder 5 coil to determine if the plug is receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2592 - Engine Spark Plug Number 6 (B3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plug Wire | Refer to Procedure 013-014 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2592 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the spark plug wire. | Spark plug wire between 2k and 7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2592 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the number 2 coil pack from the ignition harness.
  • Disconnect the ICM from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil, or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the number 6 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Refer to Procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the maintenance manual for spark plug maintenance intervals.

Spark plug damaged or excessive gap?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the spark plug wire.

Conditions

  • Turn keyswitch OFF.
  • Remove the number 6 spark plug wire.

Action

Check the spark plug wire resistance.

  • Measure the resistance of the number 6 spark plug wire.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Spark plug wire resistance between 2k and 7k ohms?
YES NO
No Repair

A damaged spark plug wire has been detected.

  • Replace the spark plug wire. Refer to Procedure 013-014 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Install ignition coil test kit, Part Number 4918343.

Action

Check the ignition coil for cylinder 6.

  • Refer to Procedure 013-012 in the Associated Procedures Table.
  • Test the cylinder 6 coil to determine if the plug is receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2593 - Engine Spark Plug Number 1 (A1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2593 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2593 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the number 1 coil pack from the ignition harness.
  • Disconnect the ICM from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the number 1 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Refer to Procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the maintenance manual for spark plug maintenance intervals.

Spark plug damaged or excessive gap?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2594 - Engine Spark Plug Number 2 (B1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2594 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2594 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the number 1 coil pack from the ignition harness.
  • Disconnect the ICM from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil. whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the number 2 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Refer to Procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the maintenance manual for spark plug maintenance intervals.

Spark plug damaged or excessive gap?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2595 - Engine Spark Plug Number 3 (A2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2595 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2595 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the number 1 coil pack from the ignition harness.
  • Disconnect the ICM from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the number 3 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Refer to Procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the maintenance manual for spark plug maintenance intervals.

Spark plug damaged or excessive gap?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2596 - Engine Spark Plug Number 4 (B2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2596 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2596 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the number 2 coil pack from the ignition harness.
  • Disconnect the ICM from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the number 4 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Refer to Procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the maintenance manual for spark plug maintenance intervals.

Spark plug damaged or excessive gap?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2597 - Engine Spark Plug Number 5 (A3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2597 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2597 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the number 2 coil pack from the ignition harness.
  • Disconnect the ICM from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the number 5 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Refer to Procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the maintenance manual for spark plug maintenance intervals.

Spark plug damaged or excessive gap?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2598 - Engine Spark Plug Number 6 (B3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | ISB5.9 G CM2180 | 2883369
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | ISB5.9 G CM2180 | 2883369
Ignition Control Harness | Refer to Procedure 013-037 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

WARNING

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2598 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2598 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the number 2 coil pack from the ignition harness.
  • Disconnect the ICM from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 013-037 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the number 6 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Refer to Procedure 013-016 in the Associated Procedures Table.

NOTE: Refer to the maintenance manual for spark plug maintenance intervals.

Spark plug damaged or excessive gap?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Nov-2012


FAULT CODE 2643 - Throttle Position 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Throttle Actuator | Refer to Procedure 019-097 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply faults. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2643 inactive?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2643 inactive and Fault Code 2644 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2643 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply faults.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2643 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and engine throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Repair or replace the harness, or replace the engine throttle actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2643 inactive and 2644 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2643 inactive?
YES NO

None. The removal and installation of the connectors corrected the fault.

Replace the engine throttle actuator.

  • Refer to Procedure 019-097 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness.

Repair or replace the harness or ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine throttle actuator position 2 SUPPLY pin in the engine harness ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine throttle actuator position 2 SUPPLY pin in the engine harness ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the engine throttle position 2 SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine throttle position 2 SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Nov-2012


FAULT CODE 2644 - Throttle Position 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply faults. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2644 inactive?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2643 active?
 | STEP 2C. Check for an active fault code. | Fault Code 2644 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code 2644 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply faults.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply faults.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2644 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and engine throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Repair or replace the harness, or replace the engine throttle actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the sensor SUPPLY 1 pin and the throttle position 2 pin the the engine harness engine throttle actuator connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2643 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the engine throttle actuator to the engine harness.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2644 active?
YES NO

Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

None. The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness.

Repair or replace the harness, or replace the ECM whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 engine throttle actuator throttle position 2 pin and the throttle position 2 pin in the engine harness engine throttle actuator connector.
  • Measure the resistance between the ECM connector 1 sensor return 1 and the engine sensor return 1 pin in the engine harness engine throttle actuator connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the ECM connector 1 engine throttle actuator throttle position 2 pin and ground.
  • Measure the resistance between the ECM connector sensor 1 return 1 and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-ground short circuit has been detected in the engine harness.

Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connectors 1 and 2.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ECM connector 1 engine throttle actuator throttle position 2 pin and all other pins in the ECM connector 1.
  • Measure the resistance between the ECM connector 1 engine throttle actuator position 2 pin and all other pins in the ECM connector 2.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4B

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Nov-2012


FAULT CODE 2645 - Throttle Plate Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2645 active?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an active fault code. | Fault Code 2645 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2645 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and the engine throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or engine harness connector.

Repair or replace the harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator.

Action

Check for a pin-to-pin short circuit in the throttle position 1 sensor circuit.

  • Measure the resistance between the ECM connector 1 throttle position 1 pin and and all other pins in the ECM connector 1.
  • Measure the resistance between the ECM connector 1 throttle position 1 pin and and all pins in the ECM connector 2.
  • Measure the resistance between the ECM connector 1 throttle position 2 pin and and all other pins in the ECM connector 1.
  • Measure the resistance between the ECM connector 1 throttle position 2 pin and and all pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness. repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine throttle actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 2645 active?
YES NO

Replace the throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

None. The removal and installation of the connectors corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Nov-2012


FAULT CODE 2722 - Engine Gas Control Valve Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Low Pressure Regulator | Refer to Procedure 005-047 | ISB5.9 G CM2180 | 2883369
High Pressure Regulator | Refer to Procedure 005-061 | ISB5.9 G CM2180 | 2883369
Fuel Pressure Sensor | Refer to Procedure 019-188 | ISB5.9 G CM2180 | 2883369
Engine Fuel Regulator Outlet Pressure/Temperature Sensor | Refer to Procedure 019-394 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 1839, 1841, 2517, 2518, 2724, 2725, and/or 2568 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2722 active?
STEP 2. | Check the engine fuel regulator outlet pressure/temperature sensor. |
 | STEP 2A. Verify the engine fuel regulator outlet pressure/temperature sensor reading. | Fuel pressure within 5 percent?
 | STEP 2B. Check the engine fuel regulator intake pressure. | Is pressure greater than 1035 kPa [150 psia] [305 in-Hg]?
 | STEP 2C. Verify the engine fuel regulator intake pressure sensor reading. | Fuel pressure within 5 percent?
STEP 3. | Inspect the engine (low pressure) regulator and o-rings. |
 | STEP 3A. Inspect the engine (low pressure) regulator and o-rings. | Missing or damaged components?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1839, 1841, 2517, 2518, 2724, 2725, and/or 2568 active?
YES NO

Troubleshoot the active fault codes.

No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2722 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel regulator outlet pressure/temperature sensor.

Guided Step 2A - Verify the engine fuel regulator outlet pressure/temperature sensor reading.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical pressure gauge.
  • Connect INSITE™ electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge connected to the Compuchek™ fitting on the fuel module against the fuel pressure measurement displayed in INSITE™ electronic service tool.

The engine fuel regulator outlet pressure reading may be listed in INSITE™ electronic service tool as fuel control valve intake pressure or similar.

NOTE: Fuel pressure is displayed in absolute in INSITE™ electronic service tool.

Fuel pressure within 5 percent?
YES NO
No Repair

Replace the engine fuel regulator outlet pressure/temperature sensor Refer to Procedure 019-394 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the engine fuel regulator intake pressure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the engine fuel regulator intake pressure.

  • Use INSITE™ electronic service tool to read the fuel pressure.

Engine fuel regulator intake pressure may be displayed in INSITE™ electronic service tool as fuel supply pressure sensor or similar.

Is pressure greater than 1035 kPa [150 psia] [305 in-Hg]?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Verify the engine fuel regulator intake pressure sensor reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical pressure gauge. Refer to Procedure 005-061 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the fuel pressure reading.

  • Verify the fuel pressure measurement with a mechanical gauge against the fuel pressure measurement displayed in INSITE™ electronic service tool.

Engine fuel regulator intake pressure may be displayed in INSITE™ electronic service tool as fuel supply pressure sensor or similar.

NOTE: Fuel pressure is displayed in absolute in INSITE™ electronic service tool. The Compuchek™ fitting located on the fuel housing is used to measure engine (low pressure) regulator outlet pressure.

Fuel pressure within 5 percent?
YES NO

The OEM fuel system supply pressure to the engine (low pressure) regulator is too high.

  • Troubleshoot the OEM fuel system. Refer to the OEM service manual.

A damaged engine fuel regulator intake pressure sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine (low pressure) regulator.

Guided Step 3A - Inspect the engine (low pressure) regulator and o-rings.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine (low pressure) regulator. Refer to Procedure 005-047 in the Associated Procedures Table.

Action

Inspect the engine low pressure regulator.

  • Refer to Procedure 005-047 in the Associated Procedures Table.

Missing or damaged component?
YES NO

A damaged low pressure regulator has been detected.

  • Repair or replace the missing or damaged components. Refer to Procedure 005-047 in the Associated Procedures Table.

NOTE: All fuel system modes have been eliminated.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Nov-2012


FAULT CODE 2723 - Engine Gas Control Valve Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Low Pressure Regulator | Refer to Procedure 005-047 | ISB5.9 G CM2180 | 2883369
High Pressure Regulator, NG | Refer to Procedure 005-061 | ISB5.9 G CM2180 | 2883369
Fuel Shutoff Valve | Refer to Procedure 019-050 | ISB5.9 G CM2180 | 2883369
Gas Mass Flow Sensor | Refer to Procedure 019-101 | ISB5.9 G CM2180 | 2883369
Fuel Control Valve | Refer to Procedure 019-102 | ISB5.9 G CM2180 | 2883369
Fuel Pressure Sensor | Refer to Procedure 019-188 | ISB5.9 G CM2180 | 2883369
Fuel Pressure Sensor Circuit | Refer to Procedure 019-394 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possiblity of pin and harness damage, use the appropriate test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel tank pressure or level. |
 | STEP 1A. Check the fuel tank pressure or level. | Fuel tank pressure/level low?
 | STEP 1B. Check the vehicle fueling history. | Low fuel pressure only after refueling?
STEP 2. | Check the fault codes |
 | STEP 2A. Check for multiple fault codes. | Fault Codes 453, 454, 1827, 1828, 1839, 1841, 2568, 2722, 2724, 2725, 2775, 2776, 2782, 2783, or 2991 active?
 | STEP 2B. Check for an active fault code. | Fault Code 2723 active?
STEP 3. | Check for low fuel pressure. |
 | STEP 3A. Verify the engine fuel regulator outlet pressure/temperature sensor reading. | Fuel pressure within 5 percent?
 | STEP 3B. Check the engine fuel regulator intake pressure. | Is fuel pressure less than 345 kPa [50 psia/102 in-Hg]?
 | STEP 3C. Verify the engine fuel regulator intake pressure sensor reading. | Fuel pressure within 5 percent?
 | STEP 3D. Check the engine fuel regulator intake pressure. | Is fuel pressure less than 345 kPa [50 psia/102 in-Hg]?
 | STEP 3E. Check the fuel system for leaks. | Fuel leaks?
 | STEP 3F. Compare the engine intake manifold pressure to engine throttle intake pressure. | Are the two pressure readings within 20 kPa [3 psi]?
 | STEP 3G. Check the laminar flow screen. | Deposites or evidence of oil?
 | STEP 3H. Check for oil in the air fuel mixer housing. | Deposits or evidence of oil?
 | STEP 3I. Inspect the engine (low pressure) regulator and o-rings. | Missing or damaged components?
 | STEP 3J. Inspect the engine fuel shutoff valve. | Damaged engine fuel shutoff valve or missing hardware?
STEP 4. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fuel tank pressure or level.

Guided Step 1A - Check the fuel tank pressure or level.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel tank pressure or level.

  • Use the original equipment manufacturer (OEM) pressure gauge to check the pressure/level of the fuel in the fuel tank.

Fuel tank pressure/level low?
YES NO

Low fuel tank pressure or level has been detected. Correct the low fuel pressure or level. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check the vehicle fueling history.

Conditions

  • Turn keyswitch OFF.

Action

Check the history to see if the vehicle’s low fuel pressure complaints occur only after refueling.

Low fuel pressure only after refueling?
YES NO

A fuel fill issue has been detected. Refer to the OEM or fuel system supplier to review fuel fill procedures.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 453, 454, 1827, 1828, 1839, 1841, 2568, 2722, 2724, 2725, 2775, 2776, 2782, 2783, or 2991 active?
YES | NO
No Repair | No Repair

Reference the appropriate troubleshooting tree

Go to 2B

Guided Step 2B - Check for an active Fault Code 2723.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at rated power.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2723 active?
YES | NO
No Repair | No Repair

Go to 4A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check for low fuel pressure.

Guided Step 3A - Verify the engine fuel regulator outlet pressure/temperature sensor reading.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical gauge.
  • Connect INSITE™ electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge connected to the Compuchek™ fitting on the fuel module against the fuel pressure measurement displayed in INSITE™ electronic service tool.

Engine fuel regulator outlet pressure reading may be listed in INSITE™ as fuel control valve intake pressure or similar.

NOTE: Fuel pressure is displayed in absolute in INSITE™ electronic service tool.

Fuel pressure within 5 percent?
YES NO
No Repair

Replace the engine fuel regulator outlet pressure/temperature sensor.

  • Refer to Procedure 019-394 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check the engine fuel regulator intake pressure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the engine fuel regulator intake pressure.

  • Use INSITE™ electronic service tool to read the fuel pressure.

Engine fuel regulator intake pressure sensor may be displayed in INSITE™ electronic service tool as fuel supply pressure sensor or similar.

Is fuel pressure less than 345 kPa [50 psia/102 in-Hg]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3D

Guided Step 3C - Verify the engine fuel regulator intake pressure sensor reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical gauge. Refer to Procedure 005-061 in the Associated Procedures Table
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge against the fuel pressure measurement value displayed in INSITE™ electronic service tool

Engine fuel regulator intake pressure sensor may be displayed in INSITE™ electronic service tool as fuel supply pressure sensor or similar.

NOTE: Fuel pressure is displayed in absolute in INSITE™ electronic service tool. The Compuchek™ fitting located on the fuel housing is used to measure engine (low pressure) regulator outlet pressure.

Fuel pressure within 5 percent?
YES NO

The OEM fuel system is not supplying sufficient fuel pressure to the engine (low pressure) regulator.

Troubleshoot the OEM fuel system. Refer to the OEM service manual.

Replace the engine fuel regulator intake pressure sensor.

Replace the fuel pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3D - Check the engine fuel regulator intake pressure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the engine fuel regulator intake pressure while performing a stall test.

  • Use INSITE™ electronic service tool to read the fuel pressure.

Engine fuel regulator intake pressure sensor may be displayed in INSITE™ electronic service tool as fuel supply pressure sensor or similar.

Is fuel pressure less than 345 kPa [50 psia/102 in-Hg]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3E

Guided Step 3E - Check the fuel system for leaks.

Conditions

  • Turn keyswitch ON.

Action

Start the engine and check for leaks in the fuel system.

  • Check the fuel lines, fuel connections, and fuel filters for leaks using the combustible gas detector service tool.

Fuel leaks?
YES NO

A leak has been detected in the fuel system. Repair or replace the leaking component.

 No Repair

Go to 4A

Go to 3F

Guided Step 3F - Compare engine intake manifold pressure to engine throttle intake pressure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the values for engine intake manifold pressure and engine throttle intake pressure during a stall test.

INSITE™ electronic service tool may display engine throttle intake pressure as compressor outlet pressure.

Are the two pressure readings within 20 kPa [3 psi]?
YES | NO
No Repair | No Repair

Go to 3G

Go to Step 6 of the engine performance troubleshooting tree.

Guided Step 3G - Check the laminar flow screen.

Conditions

  • Turn keyswitch OFF.

Action

Check for deposits on the laminar flow screen.

  • Remove the fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table
  • Inspect the laminar flow screen for deposits, damage, and oil contamination.
  • Check the gas mass flow venturi for proper installation.

Deposits or evidence of oil?
YES NO

Replace the fuel control valve.

  • Refer to Procedure 019-102 in the Associated Procedures Table.

If the venturi is not properly seated, seat the venturi and reset the fuel system tables.

If oil deposits are found, locate the source of the oil and correct. Clean all contaminated fuel system components

 No Repair

Go to 4A

Go to 3H

Guided Step 3H - Check for oil in the air fuel mixer housing.

Conditions

  • Turn keyswitch OFF.

Action

Check for oil in the air fuel mixer housing and on the sensor components.

  • Remove the gas mass flow sensor. Refer to Procedure 019-101 in the Associated Procedures Table.

NOTE: Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check the gas compression station for oil carry over.

Deposits or evidence of oil?
YES NO

Replace the gas mass flow sensor.

  • Refer to Procedure 005-047 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3I

Guided Step 3I - Inspect the engine (low pressure) regulator and o-rings.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine (low pressure) regulator. Refer to Procedure 005-047 in the Associated Procedures Table.

Action

Inspect the engine low pressure regulator.

  • Refer to Procedure 005-047 in the Associated Procedures Table.

Missing or damaged components?
YES NO

Repair or replace the missing or damaged components.

  • Refer to Procedure 005-047 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3K

Guided Step 3J - Inspect the engine fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Action

Inspect the engine fuel shutoff valve for restrictions, damage, or missing o-rings.

  • Refer to Procedure 019-050 in the Associated Procedures Table.

Damaged engine fuel shutoff valve or missing hardware?
YES NO

Replace the engine fuel shutoff valve.

  • Refer to Procedure 019-050 in the Associated Procedures Table.

NOTE: All fuel system modes have been eliminated.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Nov-2012


FAULT CODE 2724 - Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Code 1839 or 1841 active?
 | STEP 1B. Check the fuel tank pressure or level. | Fuel tank pressure or level high?
 | STEP 1C. Check for an active fault code. | Fault Code 2724 active?
STEP 2. | Check engine control module (ECM) Calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multipe fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1839 or 1841 active?
YES | NO
No Repair | No Repair

Refer to the appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check the fuel tank pressure or level.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel tank pressure or level.

  • Use the original equipment manufacturer (OEM) pressure gauge to check the pressure or level of the fuel in the fuel tank.

Fuel tank pressure or level high?

YES NO

High fuel tank pressure or level has been detected. Correct the high fuel pressure or level. Reference the equipment manufacturer service information.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2724 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Jun-2016


FAULT CODE 2725 - Gas Supply Pressure (Regulated) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel tank pressure or level. |
 | STEP 1A. Check the fuel tank pressure or level. | Fuel tank pressure or level low?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 2725 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fuel tank pressure or level.

Guided Step 1A - Check the fuel tank pressure or level.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel tank pressure or level.

  • Use the original equipment manufacturer (OEM) pressure gauge to check the pressure or level of the fuel in the fuel tank.

Fuel tank pressure or level low?
YES NO

Low fuel tank pressure or level has been detected. Correct the low fuel pressure or level. Refer to the OEM service manual.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at rated power.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2725 active?
YES NO

Consult the equipment manufacturer fuel system troubleshooting procedures.

 No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Feb-2016


FAULT CODE 2752 - Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | ISB5.9 G CM2180 | 2883369
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Throttle Actuator | Refer to Procedure 019-097 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2752 active?
STEP 2. | Check the engine throttle actuator. |
 | STEP 2A. Inspect the engine throttle actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 2752 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 2752 active?
 | STEP 3F. Check the engine throttle actuator. | Did the actuator pass the test?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2752 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle actuator.

Guided Step 2A - Inspect the engine throttle actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine throttle actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or engine harness connector.

Repair or replace the engine harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the actuator. Refer to Procedure 019-097 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2752 active?
YES NO
No Repair

None. The removal and installation of the connectors corrected the fault.

Go to 3B

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector 1.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine throttle actuator.
  • Disconnect the engine harness ECM connector 1.

Action

Check for an open circuit.

  • Measure the resistance between the throttle actuator positive (+) pin in the ECM connector 1 and the throttle actuator positive (+) pin in the engine harness actuator connector.
  • Measure the resistance between the throttle actuator negative (-) pin in the ECM connector 1 and the throttle actuator (-) pin in the engine harness actuator connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine throttle actuator.
  • Disconnect the engine harness ECM connector 1.

Action

Check for a short circut to ground.

  • Measure the resistance between the engine throttle actuator positive (+) pin in the ECM connector1 and ground.
  • Measure the resistance between the engine throttle actuator negative (-) pin in the ECM connector 1 and ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4B

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine throttle actuator.
  • Disconnect engine harness ECM connectors 1 and 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine throttle actuator positive (+) pin in ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine throttle actuator negative (-) pin in ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the engine throttle actuator positive (+) pin in ECM connector 1 and all pins in ECM connector 2.
  • Measure the resistance between the engine throttle actuator negative (-) pin in ECM connector 1 and all pins ins ECM connector 2.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Fault 2752 active?
YES NO

A damaged engine throttle actuator has been detected.

  • Replace the throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3F

Guided Step 3F - Check the engine throttle actuator.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the engine throttle actuator test

  • Use INSITE™ electronic service tool to conduct the throttle actuator test and confirm the actuator is operational.

NOTE: If the test is not available in INSITE™ electronic service tool, answer YES to this step.

Did the actuator pass the test?
YES NO
No Repair

A damaged engine throttle actuator has been detected.

  • Replace the actuator. Refer to Procedure 019-097 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Nov-2012


FAULT CODE 2758 - Electronic Throttle Control Actuator - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | ISB5.9 G CM2180 | 2883369
Throttle Actuator | Refer to Procedure 019-097 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes 352 or 386 active?
STEP 2. | Check the engine throttle actuator. |
 | STEP 2A. Inspect the engine throttle actuator. | Engine throttle actuator damaged?
 | STEP 2B. Check for an active fault code. | Fault Code 2758 active?
 | STEP 2C. Perform the throttle actuator test. | Throttle actuator test passed?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 or 386 active?
YES | NO
No Repair | No Repair

Troubleshoot the active fault codes

2A

Guided Step 2 - Check the engine throttle actuator.

Guided Step 2A - Inspect the electronic throttle control actuator.

Conditions

  • Turn keyswitch OFF.
  • Remove the electronic throttle control actuator. Refer to Procedure 019-097 in the Associated Procedures Table.

Action

Inspect the engine throttle actuator.

  • Check for a bent or missing throttle plate or other obstructions that are not allowing the throttle to close. Refer to Procedure 005-052 in the Associated Procedures Table.

Engine throttle actuator damaged?
YES NO

  • Replace the engine throttle actuator. Refer to Procedure 019-097 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Fault 2758 active?
YES NO

A damaged engine throttle actuator has been detected.

  • Replace the throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Perform the throttle actuator test.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Verify proper throttle operation.

  • Use INSITE™ electronic service tool to activate the engine throttle actuator test.

NOTE: If the throttle actuator test is not available in INSITE™ electronic service tool, answer YES to this step.

Did the throttle actuator pass the test?
YES NO
No Repair

  • Replace the engine throttle actuator. Refer to Procedure 019-097 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Nov-2012


FAULT CODE 2759 - Electronic Throttle Control Actuator - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | ISB5.9 G CM2180 | 2883369
Throttle Actuator | Refer to Procedure 019-097 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822759 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 352 or 386 active?
STEP 2. | Check the engine throttle actuator. |
 | STEP 2A. Inspect the engine throttle actuator. | Engine throttle actuator damaged?
 | STEP 2B. Check for an active fault code. | Fault Code 2759 active?
 | STEP 2C. Perform the throttle actuator test. | Throttle actuator test passed?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 or 386 active?
YES | NO
No Repair | No Repair

Troubleshoot the active fault codes

2A

Guided Step 2 - Check the engine throttle actuator.

Guided Step 2A - Inspect the engine throttle actuator.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine throttle actuator. Refer to Procedure 019-097 in the Associated Procedures Table.

Action

Inspect the engine throttle actuator.

  • Check for a bent or missing throttle plate or other obstructions that are not allowing the throttle to close. Refer to Procedure 005-052 in the Associated Procedures Table.

Engine throttle actuator damaged?
YES NO

  • Replace the engine throttle actuator. Refer to Procedure 019-097 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Fault 2759 active?
YES NO

A damaged engine throttle actuator has been detected.

  • Replace the throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Perform the throttle actuator test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify proper throttle operation.

  • Use INSITE™ electronic service tool to activate the engine throttle actuator test.

NOTE: if the throttle actuator test is not available in INSITE™ electronic service tool, answer YES to this step.

Throttle actuator test passed?
YES NO
No Repair

A damaged engine throttle actuator has been detected.

  • Replace the engine throttle actuator. Refer to Procedure 019-097 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Nov-2012


FAULT CODE 2775 - Gas Mass Flow 1 Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Control Valve | Refer to Procedure 019-102 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 453, 454, 751, 1827, 1828, 1839, 1841, 2568, 2722, or 2724 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2775 active?
STEP 2. | Check the components. |
 | STEP 2A. Check the fuel system for leaks. | Fuel leaks found?
 | STEP 2B. Check for a stuck open fuel control valve. | Is aftertreatment gas oxidation catalyst intake oxygen compensation at ±100 percent and mass gas flow compensation at ±100 percent?
 | STEP 2C. Check the fuel control valve for proper operation. | Does mass gas flow error (lb/hr) exceed ±1.5 lb/hr?
 | STEP 2D. Check for a restricted fuel control valve. | Is aftertreatment gas oxidation catalyst intake oxygen compensation at ±100 percent and mass gas flow compensation at ±100 percent?
STEP 3. | Check engine control module (ECM) calibration code and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code in active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 453, 454, 751, 1827, 1828, 1839, 1841, 2568, 2722, or 2724 active?
YES | NO
No Repair | No Repair

Troubleshoot the appropriate fault codes

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate it in the condition in which the fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2775 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the components.

Guided Step 2A - Check the fuel system for leaks.

Conditions

  • Turn keyswitch ON.

Action

Start the engine and let it idle.

  • Use a combustible gas detector to check for leaks

Fuel leaks found?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to log aftertreatment gas oxidation catalyst intake oxygen compensation (percent) and mass gas flow compensation (percent) at idle for 2 minutes.

Is aftertreatment gas oxidation catalyst intake oxygen compensation at ±100 percent and mass gas flow compensation at ±100 percent?

YES NO

A damaged fuel control valve has been detected.

  • Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel control valve for proper operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Connect INSITE™ electronic service tool to log mass air flow (lb/hr) and mass gas flow error (lb/hr) at idle for 30 seconds.

Mass gas flow (lb/hr) must not fluctuate more than 140 lb/hr for this test to be valid.

Does mass gas flow error (lb/hr) exceed ±1.5 lb/hr?
YES NO

A damaged fuel control valve has been detected.

  • Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check for a restricted fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to log aftertreatment gas oxidation catalyst intake oxygen compensation (percent) and mass gas flow compensation (percent) at rated power for 30 seconds.

Is aftertreatment gas oxidation catalyst intake oxygen compensation at ±100 percent and mass gas flow compensation at ±100 percent?

YES NO

A damaged fuel control valve has been detected.

  • Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2016


FAULT CODE 2776 - Gas Mass Flow 1 Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air/Fuel Mixer | Refer to Procedure 005-003 | ISB5.9 G CM2180 | 2883369
Low Pressure Regulator | Refer to Procedure 005-047 | ISB5.9 G CM2180 | 2883369
Turbocharger | Refer to Procedure 010-033 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Valve Body | Refer to Procedure 010-055 | ISB5.9 G CM2180 | 2883369
Fuel Shutoff Valve Solenoid | Refer to Procedure 019-050 | ISB5.9 G CM2180 | 2883369
Fuel Control Valve | Refer to Procedure 019-102 | ISB5.9 G CM2180 | 2883369
Wastegate Control Valve | Refer to Procedure 019-103 | ISB5.9 G CM2180 | 2883369
Wastegate Control Valve Circuit | Refer to Procedure 019-352 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 453, 454, 458, 511, 2723, 2725, 2988, or 2991 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2776 active?
STEP 2. | Check the turbocharger. |
 | STEP 2A. Check the wastegate control line. | Wastegate control line leaking or damaged?
 | STEP 2B. Check the wastegate actuator. | Wastegate actuator functioning properly?
 | STEP 2C. Check the wastegate valve body. | Wastegate valve body functioning properly?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check the laminar flow screen. | Deposits or evidence of oil?
 | STEP 3B. Check for oil in the air fuel mixer housing. | Evidence of oil?
 | STEP 3C. Check the fuel mixer. | Fuel mixer restricted or damaged?
STEP 4. | Check engine control module (ECM) calibration code and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 453, 454, 458, 511, 751, 2723, 2725, 2988, or 2991 active?
YES | NO
No Repair | No Repair

Troubleshoot the appropriate fault codes

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate it in the condition in which the fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2776 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger.

Guided Step 2A - Check the wastegate control line.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the wastegate control line.

  • Check the wastegate actuator control line for damage or leaks.

Wastegate control line leaking or damaged?
YES NO

Replace the wastegate control line.

  • Refer to Procedure 019-103 in the Associated Procedures Table.
  • Refer to Procedure 019-352 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the wastegate actuator.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate actuator.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Wastegate actuator functioning properly?
YES NO
No Repair

A damaged wastegate actuator has been detected.

  • Replace the wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the wastegate valve body.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate valve body.

  • Refer to Procedure 010-055 in the Associated Procedures Table.

Wastegate valve body functioning properly?
YES NO
No Repair

A damaged wastegate valve body has been detected.

  • Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check the laminar flow screen.

Conditions

  • Turn keyswitch OFF.

Action

Check for deposits on the laminar flow screen.

  • Remove the fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.
  • Inspect the laminar flow screen for deposits, damage, and oil contamination.

Deposits or evidence of oil?
YES NO

Replace the fuel control valve.

  • Refer to Procedure 019-102 in the Associated Procedures Table.

If the venturi is not properly seated, seat the venturi and reset the fuel system tables.

If oil deposits are found, locate the source of the oil and correct. Clean all contaminated fuel system components.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for oil in the air fuel mixer housing.

Conditions

  • Turn keyswitch OFF.

Action

Check for oil in the air fuel mixer housing and on the sensor components.

  • Remove the gas mass flow sensor. Refer to Procedure 019-101 in the Associated Procedures Table.
  • Check for compressor station oil contamination in the gas mass flow sensor.

Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check their gas compression station for oil carry over.

Evidence of oil?
YES NO

Replace the gas mass flow sensor. Refer to Procedure 005-047 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the fuel mixer.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel mixer for signs of damage or restrictions.

  • Refer to Procedure 005-003 in the Associated Procedures Table.

Fuel mixer restricted or damaged?
YES NO

Clean or replace the fuel mixer.

  • Clean the fuel mixer if dirty or restricted. Refer to Procedure 005-003 in the Associated Procedures Table.
  • Replace the fuel mixer if damaged. Refer to Procedure 005-003 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine with in the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Mar-2016


FAULT CODE 2782 - Engine Turbocharger 1 Boost Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | ISB5.9 G CM2180 | 2883369
Turbocharger | Refer to Procedure 010-033 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Valve Body | Refer to Procedure 010-055 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Mixer Inlet Pressure Sensor | Refer to Procedure 019-098 | ISB5.9 G CM2180 | 2883369
Wastegate Control Valve | Refer to Procedure 019-103 | ISB5.9 G CM2180 | 2883369
Wastegate Control Valve Circuit | Refer to Procedure 019-352 | ISB5.9 G CM2180 | 2883369
Intake Manifold Absolute Pressure and Temperature | Refer to Procedure 019-354 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2782 active?
STEP 2. | Check the engine throttle intake pressure sensor. |
 | STEP 2A. Inspect the engine harness and engine throttle intake pressure sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify the engine throttle intake pressure. | Engine throttle intake pressure value the same as atmospheric pressure?
STEP 3. | Check the components. |
 | STEP 3A. Check the wastegate control line. | Wastegate control line leaking or damaged?
 | STEP 3B. Check the wastegate actuator. | Wastegate actuator functioning properly?
 | STEP 3C. Check the wastegate valve body. | Wastegate valve body functioning properly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2782 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle intake pressure sensor.

Guided Step 2A - Inspect the engine harness and the engine throttle intake pressure sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.

Action

Inspect the engine harness and engine throttle intake pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-098 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 2B

Guided Step 2B - Verify engine throttle intake pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the engine throttle intake pressure sensor with INSITE™ electronic service tool while the engine is not running.

  • Use INSITE™ electronic service tool to compare engine throttle intake pressure to atmospheric pressure.

NOTE: INSITE™ electronic service tool may display engine throttle intake pressure as turbocharger compressor outlet pressure.

Engine throttle intake pressure value the same as atmospheric pressure?
YES NO
No Repair

A damaged sensor has been detected. Replace the sensor. Refer to procedure 019-098 in the Associated Procedures Table.

Go to 3A

Go to 4B

Guided Step 3 - Check the components.

Guided Step 3A - Check the wastegate control line.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the wastegate control line.

  • Check the wastegate actuator control line for damage or leaks.

Wastegate control line leaking or damaged?
YES NO

Replace the wastegate control line.

  • Refer to Procedure 019-103 in the Associated Procedures Table.
  • Refer to Procedure 019-352 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the wastegate actuator.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate actuator.

  • Check the wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Wastegate actuator functioning properly?
YES NO
No Repair

A damaged wastegate actuator has been detected.

  • Replace the wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the wastegate valve body.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate valve body.

  • Check the wastegate valve body. Refer to Procedure 010-055 in the Associated Procedures Table.

Wastegate valve body functioning properly?
YES NO
No Repair

A damaged wastegate valve body has been detected.

  • Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Nov-2012


FAULT CODE 2783 - Engine Turbocharger 1 Boost Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISB5.9 G CM2180 | 2883369
Air Intake Restriction | Refer to Procedure 010-031 | ISB5.9 G CM2180 | 2883369
Turbocharger | Refer to Procedure 010-033 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISB5.9 G CM2180 | 2883369
Turbocharger Wastegate Valve Body | Refer to Procedure 010-055 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369
Mixer Inlet Pressure Sensor | Refer to Procedure 019-098 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2783 active?
STEP 2. | Check the components. |
 | STEP 2A. Inspect the engine harness and engine throttle intake pressure sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for air leaks in the intake system. | Air leaks detected?
 | STEP 2C. Check the exhaust system before the turbocharger for leaks. | Exhaust leaks detected?
 | STEP 2D. Check the wastegate actuator. | Wastegate actuator functioning properly?
 | STEP 2E. Check the wastegate valve body. | Wastegate valve body functioning properly?
 | STEP 2F. Check air intake restriction. | Is the restriction within specification?
 | STEP 2G. Check the turbocharger. | Turbocharger damaged?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2783 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the components.

Guided Step 2A - Inspect the engine harness and the engine throttle intake pressure sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle intake pressure sensor from the engine harness.

Action

Inspect the engine harness and engine throttle intake pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-098 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for air leaks in the intake system.

Conditions

  • Turn keyswitch ON.

Action

Start the engine and check for air leaks in the intake system.

  • Check for intake air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Air leaks detected?
YES NO

Repair or replace the leaking components.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the exhaust system for leaks before the turbocharger.

Conditions

  • Turn keyswitch ON.

Action

Start the engine and check for leaks in the exhaust system before the turbocharger.

  • Check for exhuast leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Exhaust leaks detected?
YES NO

Repair or replace the leaking components.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the wastegate actuator.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate actuator.

  • Check the wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Wastegate actuator functioning properly?
YES NO
No Repair

A damaged wastegate actuator has been detected.

  • Replace the wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the wastegate valve body.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate valve body.

  • Check the wastegate valve body. Refer to Procedure 010-055 in the Associated Procedures Table.

Wastegate valve body functioning properly?
YES NO
No Repair

A damaged wastegate valve body has been detected.

  • Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check the air intake restriction.

Conditions

  • Turn keyswitch OFF.

Action

Check the air intake restriction.

  • Check the intake restriction of the engine. Refer to Procedure 010-031 in the Associated Procedures Table.

Is restriction within specification?
YES NO
No Repair

Correct the restriction.

  • Remove the restriction or replace the intake air cleaner element.

Go to 2G

Go to 3A

Guided Step 2G - Check the turbocharger.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger for damage.

  • Check the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

Turbocharger damaged?
YES NO

Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Nov-2012


FAULT CODE 2963 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 G CM2180 | 2883369
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2963 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the coolant temperature sensor. |
 | STEP 3A. Inspect the coolant temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 2963 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. A Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine in the condition in which the fault occured.

Check for Fault Code 2963.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2963 active?
YES | NO
No Repair | No Repair

Go to 2A

3B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify sensor accuracy.

  • Compare the coolant temperature reading from INSITE™ electronic service tool to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C [5°F]?
YES NO

Replace the coolant sensor.

  • Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the coolant temperature sensor.

Guided Step 3A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the sensor and engine harnessconnector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on theconnector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damged connection has been detected in the sensor or engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the Engine Harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Operate the engine in the condition in which the fault occured.

Read the fault codes.

  • Start the engine and let it operate for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: If the fault was at a particular speed, operate the engine at that speed to verify the problem is corrected.

Fault Code 2963 active?
YES NO

Reference the Coolant Temperature Above Normal troubleshooting symptom tree in Section TS of the ISB5.9 G CM2180 Service Manual, Bulletin 2883369.

No Repair

Go to 4B

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Nov-2012


FAULT CODE 2964 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | ISB5.9 G CM2180 | 2883369

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Monitor intake manifold air temperature. | Does the temperature sensor reading with INSITE™ electronic service tool correlate with a known value or a mechanical gauge?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 2964 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Monitor intake manifold air temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a known value or a mechanical gauge.

Does the temperature sensor reading with INSITE™ electronic service tool correlate with a known value or a mechanical gauge?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2964 active?
YES NO

Reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in the ISB5.9 G CM2180 Service Manual, Bulletin 2883369.

No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Nov-2012


FAULT CODE 2991 - Engine Gas Control Valve Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Low Pressure Regulator | Refer to Procedure 005-047 | ISB5.9 G CM2180 | 2883369
Fuel Shutoff Valve Solenoid | Refer to Procedure 019-050 | ISB5.9 G CM2180 | 2883369
Fuel Control Valve | Refer to Procedure 019-102 | ISB5.9 G CM2180 | 2883369
Fuel Pressure Sensor | Refer to Procedure 019-188 | ISB5.9 G CM2180 | 2883369
Fuel Pressure Sensor Circuit | Refer to Procedure 019-394 | ISB5.9 G CM2180 | 2883369

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel tank pressure or level. |
 | STEP 1A. Check the fuel tank pressure or level. | Fuel tank pressure/level low?
 | STEP 1B. Check the vehicle fueling history. | Low fuel pressure only after refueling?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for multiple fault codes. | Fault Codes 1839, 1841, 2517, 2518, 2724, 2725 and/or 2568 active?
 | STEP 2B. Check for an active fault code. | Fault Code 2991 active?
STEP 3. | Check for low fuel pressure. |
 | STEP 3A. Verify the engine fuel regulator outlet pressure/temperature sensor reading. | Fuel pressure within 5 percent?
 | STEP 3B. Check the engine fuel regulator intake pressure. | Pressure less than 345 kPa [50 psia] [102 in-Hg]?
 | STEP 3C. Verify the engine fuel regulator intake pressure sensor reading. | Fuel pressure measurement within 5 percent?
 | STEP 3D. Check the engine fuel regulator intake pressure. | Pressure less than 345 kPa [50 psia] [102 in-Hg]?
 | STEP 3E. Check the fuel system for leaks. | Fuel leaks?
 | STEP 3F. Compare engine intake manifold pressure to engine throttle intake pressure. | The two pressure readings within 20 kPa [3 psi]?
 | STEP 3G. Check the laminar flow screen. | Deposits or evidence of oil?
 | STEP 3H. Check for oil in the air fuel mixer housing. | Evidence of oil?
 | STEP 3I. Inspect the engine (low pressure) regulator and o-rings. | Missing or damaged components?
 | STEP 3J. Inspect the engine fuel shutoff valve. | Damaged engine fuel shutoff valve or missing hardware?
STEP 4. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fuel tank pressure or level.

Guided Step 1A - Check the fuel tank pressure or level.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel tank pressure or level.

  • Use the original equipment manufacturer (OEM) pressure gauge to check the pressure/level of the fuel in the fuel tank.

Fuel tank pressure/level low?
YES NO

Low fuel tank pressure or level has been detected. Correct the low fuel pressure or level. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check the vehicle fueling history.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle fueling history.

  • Check the history to see if the vehicle's low fuel pressure complaints occur only after refueling.

Low fuel pressure only after refueling?

YES NO

A fuel fill issue has been detected. Refer to the OEM or fuel system supplier to review fuel fill procedures.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 1839, 1841, 2517, 2518, 2724, 2725 and/or 2568 active?
YES | NO
No Repair | No Repair

Troubleshoot the active fault codes.

Go to 2B

Guided Step 2B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2991 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check for low fuel pressure.

Guided Step 3A - Verify the engine fuel regulator outlet pressure/temperature sensor reading.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical pressure gauge.
  • Connect INSITE™ electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge connected to the Compuchek™ fitting on the fuel module against the fuel pressure measurement displayed in INSITE™ electronic service tool.

Engine fuel regulator outlet pressure reading maybe listed in INSITE™ electronic service tool as fuel control valve intake pressure or similar.

NOTE: Fuel pressure is displayed in absolute in INSITE™ electronic service tool.

Fuel pressure within 5 percent?
YES NO
No Repair

Replace the engine fuel regulator outlet pressure/temperature sensor.

  • Replace the sensor. Refer to Procedure 019-394 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check the engine fuel regulator intake pressure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the engine fuel regulator intake pressure.

  • Use INSITE™ electronic service tool to read the fuel pressure.

Engine fuel regulator intake pressure reading may be listed in INSITE™ electronic service tool as fuel supply pressure or similar.

NOTE: Fuel pressure is displayed in absolute in INSITE™ electronic service tool.

Pressure less than 345 kPa [50 psia] [102 in-Hg]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3D

Guided Step 3C - Verify the engine fuel regulator intake pressure sensor reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical gauge.
  • Refer to Procedure 005-061 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge against the fuel pressure measurement value displayed in INSITE™ electronic service tool.

Engine fuel regulator intake pressure reading may be listed in INSITE™ electronic service tool as fuel supply pressure or similar.

NOTE: Fuel pressure is displayed in absolute in INSITE™ electronic service tool. The Compuchek™ fitting located on the fuel housing is used to measure engine (low pressure) regulator outlet pressure.

Fuel pressure within 5 percent?
YES NO

The OEM fuel system is not supplying sufficient fuel pressure to the engine (low pressure) regulator.

  • Troubleshoot the OEM fuel system. Refer to the OEM service manual.

Replace the engine fuel regulator intake pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3D - Check the engine fuel regulator intake pressure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the engine fuel regulator intake pressure while performing a stall test.

  • Use INSITE™ electronic service tool to read the fuel pressure.

NOTE: Engine fuel regulator intake pressure reading may be listed in INSITE™ electronic service tool as fuel supply pressure or similar.

Pressure less than 345 kPa [50 psia] [102 in-Hg]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3E

Guided Step 3E - Check the fuel system for leaks.

Conditions

  • Turn keyswitch ON.

Action

Start the engine and check for leaks in the fuel system.

  • Check the fuel lines, fuel connections, and fuel filters for leaks. Use the combustible gas detector service tool.

Fuel leaks?
YES NO

A leak has been detected in the fuel system. Repair or replace the leaking component.

 No Repair

Go to 4A

Go to 3F

Guided Step 3F - Compare engine intake manifold pressure to engine throttle intake pressure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare engine intake manifold pressure to engine throttle intake pressure.

  • Use INSITE™ electronic service tool to monitor the values for engine intake manifold pressure and engine throttle intake pressure during a stall test.

NOTE: INSITE™ electronic service tool may display engine throttle intake pressure as compressor outlet pressure.

The two pressure readings within 20 kPa [3 psi]?
YES | NO
No Repair | No Repair

Go to 3G

Reference the Engine Performance Troubleshooting Tree in Section TT of the ISB5.9 G CM2180 Service Manual, Bulletin 2883369.

Guided Step 3G - Check the laminar flow screen.

Conditions

  • Turn keyswitch OFF.

Action

Check for deposits on the laminar flow screen.

  • Remove the fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.
  • Inspect the laminar flow screen for deposits, damage, and oil contamination.
  • Check the gas mass flow venturi for proper installation.

Deposits or evidence of oil?
YES NO

Replace the fuel control valve. Refer to Procedure 019-102 in the Associated Procedures Table.

If the venturi is not properly seated, seat it and then reset the fuel system tables.

If oil deposits are found, locate the source of the oil and correct.

Clean all contaminated fuel system components of oil.

 No Repair

Go to 4A

Go to 3H

Guided Step 3H - Check for oil in the air fuel mixer housing.

Conditions

  • Turn keyswitch OFF.

Action

Check for oil in the air fuel mixer housing and on the sensor components.

  • Remove the gas mass flow sensor. Refer to Procedure 019-101 in the Associated Procedures Table.

NOTE: Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check their gas compression station for oil carry over.

Evidence of oil?
YES NO

Replace the gas mass flow sensor. Refer to Procedure 005-047 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3I

Guided Step 3I - Inspect the engine (low pressure) regulator and o-rings.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine (low pressure) regulator. Refer to Procedure 005-047 in the Associated Procedures Table.

Action

Inspect the engine low pressure regulator.

  • Refer to Procedure 005-047 in the Associated Procedures Table.

Missing or damaged components?
YES NO

Repair or replace the missing or damaged components. Refer to Procedure 005-047 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3J

Guided Step 3J - Inspect the engine fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine fuel shut off valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Action

Inspect the engine fuel shutoff valve for restrictions, damage, or missing o-rings.

  • Refer to Procedure 019-050 in the Associated Procedures Table.

Damaged engine fuel shutoff valve or missing hardware?
YES NO

  • Replace the engine fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

NOTE: All fuel system modes have been eliminated.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Nov-2012


FAULT CODE 3366 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3366 active?
STEP 2. | Check the coolant level. |
 | STEP 2A. Check for low coolant level. | Coolant level low?
STEP 3. | Check ECM calibration code and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3366 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the coolant level.

Guided Step 2A - Check for low coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant level.

  • Refer to the OEM service manual.

Coolant level low?
YES NO

Add coolant to the engine.

Refer to the OEM service manual.

Check for coolant leaks. Reference the Coolant Loss - External and Coolant Loss - Internal troubleshooting symptom trees in the ISB5.9 G CM2180 Service Manual, Bulletin 2883369.

If Fault Code 3366 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Last Modified: 28-Nov-2012


INDEX
144-fc111.htm

144-t05-111.htm

144-fc115.htm

144-t05-115.htm

144-fc122.htm

144-t05-122.htm

144-fc123.htm

144-t05-123.htm

144-fc124.htm

144-t05-124.htm

144-fc125.htm

144-t05-125.htm

144-fc131.htm

144-t05-131.htm

144-fc132.htm

144-t05-132.htm

144-fc133.htm

144-t05-133.htm

144-fc134.htm

144-t05-134.htm

144-fc135.htm

144-t05-135.htm

144-fc141.htm

144-t05-141.htm

144-fc143.htm

144-t05-143.htm

144-fc144.htm

144-t05-144.htm

144-fc145.htm

144-t05-145.htm

144-fc146.htm

144-t05-146.htm

144-fc151.htm

144-t05-151.htm

144-fc153.htm

144-t05-153.htm

144-fc154.htm

144-t05-154.htm

144-fc155.htm

144-t05-155.htm

144-fc176.htm

144-t05-176.htm

144-fc187.htm

144-t05-187.htm

144-fc195.htm

144-t05-195.htm

144-fc196.htm

144-t05-196.htm

144-fc197.htm

144-t05-197.htm

144-fc227.htm

144-t05-227.htm

144-fc234.htm

144-t05-234.htm

144-fc235.htm

144-t05-235.htm

144-fc238.htm

144-t05-238.htm

144-fc239.htm

144-t05-239.htm

144-fc241.htm

144-t05-241.htm

144-fc242.htm

144-t05-242.htm

144-fc245.htm

144-t05-245.htm

144-fc254.htm

144-t05-254.htm

144-fc255.htm

144-t05-255.htm

144-fc263.htm

144-t05-263.htm

144-fc265.htm

144-t05-265.htm

144-fc285.htm

144-t05-285.htm

144-fc286.htm

144-t05-286.htm

144-fc287.htm

144-t05-287.htm

144-fc288.htm

144-t05-288.htm

144-fc295.htm

144-t05-295.htm

144-fc319.htm

144-t05-319.htm

144-fc338.htm

144-t05-338.htm

144-fc339.htm

144-t05-339.htm

144-fc343.htm

144-t05-343.htm

144-fc352.htm

144-t05-352.htm

144-fc386.htm

144-t05-386.htm

144-fc415.htm

144-t05-415.htm

144-fc441.htm

144-t05-441.htm

144-fc442.htm

144-t05-442.htm

144-fc453.htm

144-t05-453.htm

144-fc454.htm

144-t05-454.htm

144-fc455.htm

144-t05-455.htm

144-fc458.htm

144-t05-458.htm

144-fc459.htm

144-t05-459.htm

144-fc461.htm

144-t05-461.htm

144-fc462.htm

144-t05-462.htm

144-fc465.htm

144-t05-465.htm

144-fc466.htm

144-t05-466.htm

144-fc511.htm

144-t05-511.htm

144-fc512.htm

144-t05-512.htm

144-fc513.htm

144-t05-513.htm

144-fc515.htm

144-t05-515.htm

144-fc516.htm

144-t05-516.htm

144-fc561.htm

144-t05-561.htm

144-fc562.htm

144-t05-562.htm

144-fc563.htm

144-t05-563.htm

144-fc564.htm

144-t05-564.htm

144-fc565.htm

144-t05-565.htm

144-fc566.htm

144-t05-566.htm

144-fc572.htm

144-t05-572.htm

144-fc575.htm

144-t05-575.htm

144-fc584.htm

144-t05-584.htm

144-fc585.htm

144-t05-585.htm

144-fc591.htm

144-t05-591.htm

144-fc592.htm

144-t05-592.htm

144-fc596.htm

144-t05-596.htm

144-fc597.htm

144-t05-597.htm

144-fc598.htm

144-t05-598.htm

144-fc689.htm

144-t05-689.htm

144-fc769.htm

144-t05-769.htm

144-fc771.htm

144-t05-771.htm

144-fc778.htm

144-t05-778.htm

144-fc1117.htm

144-t05-1117.htm

144-fc1128.htm

144-t05-1128.htm

144-fc1239.htm

144-t05-1239.htm

144-fc1241.htm

144-t05-1241.htm

144-fc1242.htm

144-t05-1242.htm

144-fc1654.htm

144-t05-1654.htm

144-fc1655.htm

144-t05-1655.htm

144-fc1656.htm

144-t05-1656.htm

144-fc1657.htm

144-t05-1657.htm

144-fc1658.htm

144-t05-1658.htm

144-fc1659.htm

144-t05-1659.htm

144-fc1695.htm

144-t05-1695.htm

144-fc1696.htm

144-t05-1696.htm

144-fc1827.htm

144-t05-1827.htm

144-fc1828.htm

144-t05-1828.htm

144-fc1839.htm

144-t05-1839.htm

144-fc1841.htm

144-t05-1841.htm

144-fc1858.htm

144-t05-1858.htm

144-fc1859.htm

144-t05-1859.htm

144-fc1919.htm

144-t05-1919.htm

144-fc2185.htm

144-t05-2185.htm

144-fc2186.htm

144-t05-2186.htm

144-fc2187.htm

144-t05-2187.htm

144-fc2189.htm

144-t05-2189.htm

144-fc2219.htm

144-t05-2219.htm

144-fc2221.htm

144-t05-2221.htm

144-fc2229.htm

144-t05-2229.htm

144-fc2286.htm

144-t05-2286.htm

144-fc2287.htm

144-t05-2287.htm

144-fc2321.htm

144-t05-2321.htm

144-fc2322.htm

144-t05-2322.htm

144-fc2377.htm

144-t05-2377.htm

144-fc2431.htm

144-t05-2431.htm

144-fc2432.htm

144-t05-2432.htm

144-fc2433.htm

144-t05-2433.htm

144-fc2434.htm

144-t05-2434.htm

144-fc2435.htm

144-t05-2435.htm

144-fc2436.htm

144-t05-2436.htm

144-fc2517.htm

144-t05-2517.htm

144-fc2518.htm

144-t05-2518.htm

144-fc2568.htm

144-t05-2568.htm

144-fc2571.htm

144-t05-2571.htm

144-fc2572.htm

144-t05-2572.htm

144-fc2586.htm

144-t05-2586.htm

144-fc2587.htm

144-t05-2587.htm

144-fc2588.htm

144-t05-2588.htm

144-fc2589.htm

144-t05-2589.htm

144-fc2591.htm

144-t05-2591.htm

144-fc2592.htm

144-t05-2592.htm

144-fc2593.htm

144-t05-2593.htm

144-fc2594.htm

144-t05-2594.htm

144-fc2595.htm

144-t05-2595.htm

144-fc2596.htm

144-t05-2596.htm

144-fc2597.htm

144-t05-2597.htm

144-fc2598.htm

144-t05-2598.htm

144-fc2643.htm

144-t05-2643.htm

144-fc2644.htm

144-t05-2644.htm

144-fc2645.htm

144-t05-2645.htm

144-fc2722.htm

144-t05-2722.htm

144-fc2723.htm

144-t05-2723.htm

144-fc2724.htm

144-t05-2724.htm

144-fc2725.htm

144-t05-2725.htm

144-fc2752.htm

144-t05-2752.htm

144-fc2758.htm

144-t05-2758.htm

144-fc2759.htm

144-t05-2759.htm

144-fc2775.htm

144-t05-2775.htm

144-fc2776.htm

144-t05-2776.htm

144-fc2782.htm

144-t05-2782.htm

144-fc2783.htm

144-t05-2783.htm

144-fc2963.htm

144-t05-2963.htm

144-fc2964.htm

144-t05-2964.htm

144-fc2991.htm

144-t05-2991.htm

144-fc3366.htm

144-t05-3366.htm